Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

C4DtoA no material preview (black square with red around)

15 REPLIES 15
Reply
Message 1 of 16
brokanteur
3389 Views, 15 Replies

C4DtoA no material preview (black square with red around)

3758-2019-04-16-05506-r.jpg

Hello,

I don't know why but since I updated arnold to 2.5.0 and now 2.5.1 all my materials previews turn to black with a red contour but my renders are ok

Any thought ?

Thanks

Tags (2)
Labels (2)
15 REPLIES 15
Message 2 of 16

That's odd, there were no changes related to material previews, as far as I recall. The black preview with red frame indicates a render error, a typical issue is a missing texture in the shader network. We had no similar reports recently, so may be something local. Maybe the preview scenes got corrupted somehow? What if you create a new scene, are the previews work there?

Message 3 of 16
brokanteur
in reply to: brokanteur

Hello Peter,

If I create a new scene, the material preview is ok

In this corrupted scene there's only few materials in black but after a while evreything turn to black

Not all materials have texture and I have checked the path in the Asset/tx manager and all links are ok

Is there a way to recover these material preview ?

Thanks

Message 4 of 16

If it works in a new scene than the preview scenes are not corrupted. I'm not sure what's going on, I have not heard of previews turning to black on-the-fly before. Sounds like the issue is specific to this one scene. Can you send me the scene, I wonder if I can reproduce the issue with it?

Message 5 of 16
brokanteur
in reply to: brokanteur

Here is the corrupted materials library

arnold-corrupted-mat.zip

Message 6 of 16
brokanteur
in reply to: brokanteur

When I import them they are black

Message 7 of 16

If I change a parameter or open the network editor, which triggers an update, then the previews render fine.

Message 8 of 16
alex.altmann
in reply to: brokanteur

I've had this happen as well. Double click on the shader in question. When the window opens, right click on the black square with red outline and select either a new size or preview type. It recreates the preview.

Message 9 of 16
alex.altmann
in reply to: brokanteur

Was playing with this a little more. Fastest way is to select all of the shaders with the black box, then right click and select "Render Materials". Don't have to do them individually then.

Message 10 of 16
brokanteur
in reply to: brokanteur

Alex and peter, thanks for your help

I have already done this with my corrupted scene and it was not working so peter you are right, it's a problem with the local scene

Here it is and if I try to Render Materials as Alex said, it's not working at all, materials stay black

arnold-corrupted-scene.zip

Message 11 of 16
brokanteur
in reply to: brokanteur

Ok finally I have found a solution to recover my corrupted materials:

1. create a new scene

2. merge the corrupted scene

3. right clic on a black square of death an choose "Render All Materials"

4. some materials will stay black because of the path of the texture not good

5. to fix this go to plugins>c4dtoA>Asset/tx Manager

6. in the manager clic "select missing" and clic "relink" button next to it

7. choose texture location and that's all, everything is fixed !!

Thank to Peter and Alex for their help !

Message 12 of 16

I'm glad you could finally solve it. I can reproduce the issue in your scene and I'm trying to figure out what's going on and fix this.

Message 13 of 16

OK, got it. At least on my system the previews fail, because the color manager in the scene is set to OCIO and the config file is defined by the OCIO environment variable ($OCIO) which is not set on my system.

Would be nice to report preview render errors in the console, trying to add this to the next release.

Message 14 of 16
brokanteur
in reply to: brokanteur

Well done peter !

Would be nice to report preview render errors in the console, trying to add this to the next release.

on this site or with c4d application ?

what should I do exactly ?

Message 15 of 16

You don't have to do anything. I will update the code to display the error message in the console, so users will have a better understanding of why the material preview is not rendering.

Message 16 of 16

ah ok I understand, yes it's a good idea to inform users

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report