Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

C4DtoA - Displacement - Arnold Tag Iterations Parameter Bug

8 REPLIES 8
Reply
Message 1 of 9
AJUKking
302 Views, 8 Replies

C4DtoA - Displacement - Arnold Tag Iterations Parameter Bug

I have discovered a bug where changing the number of displacement subdivision iterations on an Arnold Tag that's attached to some geometry will cause the geometry to render incorrectly in the IPR. For some reason, any value entered into this parameter that is >= 8 (for subdiv Type Catclark) by clicking the increment up and down arrows causes the geometry to change drastically to something incorrect. But typing in the value 8 into the parameter and pressing Enter on the keyboard causes the geometry to display correctly. This problem is the same for subdiv Type Linear at a value of >=7 for some reason. Quite bizarre.

This problem also seems to occur if you enter a higher value such as 8 and quickly toggle the IPR render region ability before the IPR has a chance to start actually rendering the new level of subdivs.

Tags (1)
Labels (1)
8 REPLIES 8
Message 2 of 9

I'm not able to reproduce it. What's your C4D and C4DtoA version? This might be related to an issue which was fixed recently.

Message 3 of 9

C4D R20.059

C4DtoA 2.5.1

Arnold core 5.3.0.2

Sorry, should have provided this info earlier.

Message 4 of 9

I'm still not able to reproduce it. A couple of questions. Does it happen constantly or randomly? Can you reproduce it with any geometry or just with a specific one? Can you show me a video or picture of the issue and the incorrect geometry?

Message 5 of 9

- Problem occurs ~90% of the time

- Can reproduce problem with any geometry

Linked is a video based on the attached c4d files that are various levels of simplified so you can get both a quick scene to look at and two other files which contain more objects/tags to look at. Each arnold tag has subdiv value set to 1 below the value that causes that geo to disappear. Add subdiv iterations on each tag by 1 or 2 to see the issue. Might have to increment / decrement few times to reproduce error. I recommend watching the video first before looking at the c4d files.

Youtube Video

c4d.zip

Message 6 of 9

Excellent, thanks! I'm a bit busy today and tomorrow, so bear with me please. I will get back to you as soon as I have some time to check.

Message 7 of 9

No rush here! Take your time.

Message 8 of 9

Thanks for the scene, I can easily reproduce the issue with it. I will investigate and get back to you with my findings.

Message 9 of 9

Great! Glad to hear I helped. Thank you!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums