Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

C4DtoA AOVs with Team Render

9 REPLIES 9
Reply
Message 1 of 10
Andrew_Brewer
724 Views, 9 Replies

C4DtoA AOVs with Team Render

New to Arnold but I appear to have my AOV passes and obj mattes all rendering and saving nicely in a layered EXR yet when I'm working locally, yet when I try to use Team Render all I get back is a main beauty pass and an alpha.

Can someone help with what i'm missing here please!

Labels (4)
9 REPLIES 9
Message 2 of 10

It should work fine, no extra setup is needed for Team Render. What's your Cinema 4D and C4DtoA version? I'll take a look tomorrow if I can reproduce it.

Message 3 of 10

Ah thanks dude. Yeah, i'm using R.19 and Arnold 5. Have been using 'file from render settings (multipass)' and multi layer exrs - tried a different settings and variations but was chasing my tail...

Message 4 of 10

Wait, the Arnold drivers are not supported in Team Render. You can only use the native (Multi-Pass Image) Save in the render settings.

Message 5 of 10

Ah ok. So I can't render AOVs with Team Render? What a shame - i guess production houses just send their scenes to farms then?

Message 6 of 10

You can render AOVs with Team Render, you just have setup the AOVs for the <display driver> and save a Multi-Layer EXR in the render settings. That should work.

Message 7 of 10

Peter, I am a little bit confused here. We do this all the time - use team render with arnold drivers. Typically we either do not enable save at all in the render settings, or we use the Arnold Dummy, in the case of using Render Queue.

I'm not sure if this applies to distributed still frames, but unless I'm seriously mistaken, Arnold Drivers do seem to work for team rendered sequences. Could you please clarify?

Message 8 of 10

Right, sorry I was not clear. So the Arnold drivers are processed on the client machines. If you specify the path properly (valid on the clients) then they work with sequences. But not with still frames, because they render only a part of the image on each client.

Message 9 of 10

Thanks guys, looks like I might have been falling over then with both trying to render one test image and also attempting to use the native render settings. I've had to streamline my output in light of hitting a deadline anyway but I look forward to getting this working soon.

Message 10 of 10
akehurstm
in reply to: Andrew_Brewer

Hi @Peter Horvath - I'm having a similar issue to Andrew above:

C4DtoA project - submitted to a 28 node Team Render Server controlled farm with Display Driver and Multiple AOVs within the project.

But the Team Render only produces main beauty and alpha. It appears to ignore all AOV requests.

When the project is run locally it produces all AOVs as expected.

I was hoping that maybe a fix/work around for this issue had been found?

We've only recently updated the Render Farm to support Arnold - but this AOV problem has affected all Arnold projects submitted to it.

Our local machines and the render nodes are running:

C4D R21.115

C4DtoA 2.6.1.5 [a79361bf]

Arnold core 5.4.0.2


Thanks greatly for your time!

(I've attached screen grabs of render setting from one of the projects)

C4DtoA_AOVs.PNGC4DtoA_Output.PNG

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums