Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

C4DtoA Quad Light Roundess or Softness GPU IPR Light goes off

Message 1 of 9
428 Views, 8 Replies

C4DtoA Quad Light Roundess or Softness GPU IPR Light goes off

When modifying the Roundess or Softness value with GPU IPR active, the light will stop responding and will stop emitting. Restarting the IPR will light the scene, but again if you modify the roundess or softness the light being edited will stop emitting.

Example video :

Tags (4)
Labels (4)
Message 2 of 9

I can't reproduce it (R23.008 & C4DtoA Does it behave the same in a new simple scene (like a Sphere with a quad light)? Do you see any warning or error in the console log (Shift+F10)?

Message 3 of 9

Hi Peter,

I'm using C4D 23.110. No errors reported in console.

I created a new scene with just a sphere and so far it's not an issue. I then recreated the scene using the model linked below, added a default Arnold standard surface material and a quad-light. I was then able to recreate the issue. I added a sphere primitive, disabled the statue model and even with a sphere the issue was evident.

I do have the scene zipped and I can email it to Arnold support if you like.


Message 4 of 9

Upon using this scene, I'm finding editing most any light parameter will cause the IPR to black out.

Message 5 of 9

Thanks for the description, finally I was able to reproduce it. It a strange one, it fails to me only when there are multiple materials assigned to the geo and one has a Spherical (non UVW) projection. Trying to figure out what's going on.

Message 6 of 9

Same issue here. Single quad light was used and whenever I changed sometihng light emmiting stoped. Every time I had do invisible it and revisible it to see light. In Current project no issues like that though.

Message 7 of 9

This seems to be caused by the same issue described here:

As a workaround until we fix it in one of our next releases, you can disable fast path for camera-only updates in Render Setting -> Diagnostics -> User options, by typing enable_fast_ipr off in the field.

Message 8 of 9

Thanks Peter. Setting that option works.

Message 9 of 9

The just released Arnold (C4DtoA 3.2.1) should have a fix for this so that you can re-enable fast ipr. This was fixed by:
core#10196 [GPU] Light disappears during GPU IPR after modified

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators

Autodesk Design & Make Report