Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Big error issue with mix 2 hair shader with add mode

4 REPLIES 4
Reply
Message 1 of 5
Suppybird.kingdom
208 Views, 4 Replies

Big error issue with mix 2 hair shader with add mode

I get error with mix 2 standard hair shader ( with different " SHIFT " parameter ) with add mode of mix shader. When set mode to " add ". It's freeze. I cannot render, IPR or anything else. I cannot do another ways because " add " mode is only way for me to create the shader I want. Please fix this. Thanks.

Tags (1)
Labels (1)
4 REPLIES 4
Message 2 of 5

What do you mean by "mix 2 hair shader"? Is this the mix_shader and you're connecting two standard_hair shaders to it?

Message 3 of 5

Exactly !

2 standard_hair with different "Shift" parameter !

Message 4 of 5

The add mode currently does a straight add of all the closures. This means the transparency closures will also be added together which is probably not desired since this could result in opacity going to 0 and the curves being fully transparent. While that will clearly make the render look wrong, I'm not sure why that should freeze arnold. If you disable the min_pixel_width (set it to 0) and make sure the opacity params are kept at fully opaque, does that fix your issues?

As for this issue with add and transparencies, by happy coincedence we came up with a possible fix for that just yesterday, so assuming no unexpected surprises during our testing, we might be able to release that in an upcoming version of arnold.

Message 5 of 5

Is it crashing when it freezes? If so, can you upload a log file?

Lee Griggs
Arnold rendering specialist
AUTODESK

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums