Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ass Procedurals rendered red

24 REPLIES 24
SOLVED
Reply
Message 1 of 25
Anonymous
841 Views, 24 Replies

Ass Procedurals rendered red

Hello, I have one scene and work on it with 2 computers. I use relative paths for textures and ass files. Althoug geometry is loaded textures on some procedurals fail to load and turn up red. Some procedurals render ok, like the bed in the back and bush on the left. I have designated search paths. Still textures wont load.
I would like to ask for advice.
5898-screenshot-2020-02-12-at-165304.png5896-screenshot-2020-02-12-at-165223.png5895-screenshot-2020-02-12-at-165215.png5894-screenshot-2020-02-12-at-165208.png

Tags (3)
Labels (3)
24 REPLIES 24
Message 2 of 25
peter.horvath6V6K3
in reply to: Anonymous

Seems like your textures are specified with absolute paths, probably in the procedural ASS files. The Texture Search Path works only for relative paths. Make sure all textures specified relative when you export the procedurals (you can check in the Asset/Tx Mananger).

If your setup seems fine and you still have the error, it could be a bug somewhere.

Message 3 of 25
peter.horvath6V6K3
in reply to: Anonymous

Actually I could reproduce it. Seems like a bug with auto tx. If you disable auto tx or specify TX textures directly, then relative paths exported fine. I'll fix this ASAP.

Message 4 of 25
Anonymous
in reply to: Anonymous

Hello Peter,
I am relative path man, you won´t find single abosolute path in my assets or textures. It seem that when I export .ass file, .tx paths are exported along as absolute links.
5809-screenshot-2020-02-12-at-184258.png5808-screenshot-2020-02-12-at-184319.png

Message 5 of 25
peter.horvath6V6K3
in reply to: Anonymous

Yes, it's a bug, see my comment below.

Message 6 of 25
Anonymous
in reply to: peter.horvath6V6K3

not sure how exactly to reproduce your work-around, I still get red textures, or should I just wait for some sort of quick hot fix?

Message 7 of 25

If you disable auto tx and re-export the procedural ASS files, that should work. Alternatively you can replace the absolute paths manually in the ASS files.

Or wait for the next release (coming soon) which will the fix the export. That means you have to re-export the procedural ASS files with the new build.

Message 8 of 25
Anonymous
in reply to: peter.horvath6V6K3

First option did not work for me. How/where can I change the .tx paths of .ass manually?

It would be good if during export .tx paths would copy behavior of original textures. Absolute stay absolute, relative stay relative.

thank you
daniel

Message 9 of 25

You can open ASS files in a text editor.

Message 10 of 25
peter.horvath6V6K3
in reply to: Anonymous

C4DtoA 3.0.2 has been released which has the fix to keep relative paths when auto tx is on. You have to re-export your procedural ASS files using this build. Please let me know if you still have issues.

Message 11 of 25
Anonymous
in reply to: peter.horvath6V6K3

Hello Peter,
after taking steps you mentioned, it still renders red. It is like it cannot find .tx files. But there are there, just like search paths.

5924-screenshot-2020-02-13-at-181716.png

5923-screenshot-2020-02-13-at-181705.png

5922-screenshot-2020-02-13-at-181657.png5921-screenshot-2020-02-13-at-182548.png

Message 12 of 25

Do you have 'Search In Subfolders' enabled? What if you define the full folder path in the search path: /Users/MIKOLAJCAK/assets/Decoration/Organic/Textures/Pine Cones

Message 13 of 25
Anonymous
in reply to: peter.horvath6V6K3

I had "search subfolder on" all along. Arnold finally finds .tx when I specify exact search path: /Users/MIKOLAJCAK/assets/Decoration/Organic/Textures
is this another bug perhaps? Textures in the scene and .ass geometry are loaded fine without exact path specification.

Message 14 of 25

Right, it's a current limitation, the subfolder option does not work for textures in procedurals. You have to specify the full path. I'll take a look if this can be solved.

Message 15 of 25
Anonymous
in reply to: peter.horvath6V6K3

Although as workaround it is ok, It would be very good if it need not to be specified for each ass object.
thanks

Message 16 of 25
Anonymous
in reply to: peter.horvath6V6K3

Hello Peter,
any success in the matter of subfolder search for ASS textures? ASS are in my opinion best way to reference external assets.

Message 17 of 25

Sorry, it's not fixed yet. Since procedurals are black boxes, the difficulty here is to find the right solution which does not affect performance. Will let you know if I have a fix.

Message 18 of 25
Anonymous
in reply to: peter.horvath6V6K3

No Problem, take your time

Message 19 of 25
Anonymous
in reply to: Anonymous

Hello Peter,
since you mentioned viewport performance of ASS objects it reminded me that once ASS are set to display as wireframe, polywire, shaded polywire or shaded, FPS drops drastically to 4 fps.
when set to pointcloud fps goes to 20 and when it is set to bounding box, fps is 200.

However when I import original 3d plant (688000 triangles) mesh and display it as shaded mesh, fps stays at 200 and is barely affected. It is not ASS specific and happens with every referenced mesh.

I guess this has something to do with the subfolder path mapping as well.

Anyway viewport performance is already now very bad.

Message 20 of 25
peter.horvath6V6K3
in reply to: Anonymous

Sorry I missed that. I'm not aware of this issue, must be something with the viewport display code. Will take a look.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report