Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Arnold transmission C4D in render is black

12 REPLIES 12
SOLVED
Reply
Message 1 of 13
fabrizioV53SW
1433 Views, 12 Replies

Arnold transmission C4D in render is black

hi, i have a problem with transmission, i'm trying to have water droplets on a can model, do you know why is black? i turned opaque of on my droplets and have transmission set to max on my material.schermata-2021-01-13-alle-180812.png

Tags (2)
Labels (2)
12 REPLIES 12
Message 2 of 13

What are the shader settings on those droplets?
I did a quick test in Maya and I didn't get dark droplets with this clear_water standard surface:

clear_water.ass.txt

Just save the file, remove the .txt, and load it with Arnold > Materials > Import



// Stephen Blair
// Arnold Renderer Support
Message 3 of 13

The point is I just did a sphere and a cloner on the subdivision surface and apply on that cloner a simple standard surface with transmission set to max. In maya I don’t have that problem but in cinema 4d I have it. The weird thing is that on the top of the can the droplets are fine, they are simply transparent how suppose to be. I’m frustrated..

Message 4 of 13
lee_griggs
in reply to: fabrizioV53SW

It looks like it is because the drops geo are intersecting the can and therefore are refracting the dark interior of the can?

Other things to consider:

Opaque should be disabled (although this is automatically computed now).

What are the normals like?

Is transmission_ray_depth high enough?

Are the lights visible in transmission rays?

Is caustics (Advanced) enabled?

If that doesn't work, upload a simple scene somewhere.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 5 of 13

And my point is that we don't know any of your settings.



// Stephen Blair
// Arnold Renderer Support
Message 6 of 13

the funny thing is that the droplets on te top of the can are transparent...look ate the screenshot.


the things seems to not change even if I apply another material on the can...schermata-2021-01-14-alle-150223.png

Message 7 of 13

ok update, the problem seems appear whenever i put a ground plane ! but why? i need a ground for my animation....cant escape from this situation...schermata-2021-01-14-alle-151829.png

Message 8 of 13
lee_griggs
in reply to: fabrizioV53SW

Upload the scene somewhere, please.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 9 of 13
fabrizioV53SW
in reply to: lee_griggs

the C4D file you mean?

Message 10 of 13

here the project ->>>> https://we.tl/t-xb7EK7DaBu

Message 11 of 13
lee_griggs
in reply to: fabrizioV53SW

As I recommended earlier, you need to enable caustics for the drop shader.


1610694503387.png

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 12 of 13
fabrizioV53SW
in reply to: lee_griggs

i did it but nothing seems changing...

Message 13 of 13
Pham_Nhat
in reply to: fabrizioV53SW

Pham_Nhat_0-1684750389234.png

Hey i have solution, you can increase specular a bit in Raydepth render setting. It's work for me

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report