Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Arnold Sky not appearing in reflections of Toon Shader Specular

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
jatomchuk
216 Views, 4 Replies

Arnold Sky not appearing in reflections of Toon Shader Specular

Hello,

 

So I have a toon car in a scene. The windows, I would like to be 100% reflective of the environment. It seems to work in both the toon shader, and standard shader when cranking up the specular - however the Arnold sky does not appear in the reflections, in both standard and toon shaders. Does anyone have any idea why this could be?

 

I've attached screenshots of my settings.

 

Thanks!

Screen Shot 2023-05-17 at 2.45.07 PM.pngScreen Shot 2023-05-17 at 2.48.18 PM.pngScreen Shot 2023-05-17 at 2.45.46 PM.pngScreen Shot 2023-05-17 at 2.45.26 PM.png

4 REPLIES 4
Message 2 of 5
Stephen.Blair
in reply to: jatomchuk

I can't tell what's the sky in that IPR screenshot. Is everything I see a texture on the sky?

Might need to see some sort of test scene, because I don't know how to make that problem happen.

c4dtoa_toon_physicalsky.jpg



// Stephen Blair
// Arnold Renderer Support
Message 3 of 5
jatomchuk
in reply to: Stephen.Blair

Hi Stephen,

 

I've attached a project file that replicates the problem I'm facing using basic geometry. The purple cube is a "building", which appears to reflect on the reflective cube and sphere.

 

Screen Shot 2023-05-17 at 4.24.25 PM.png

 

The sky is an animation of a starry night with shooting stars using noise, connected to a flat shader - and applied to the Arnold Sky. Perhaps Arnold Sky is not meant to be used this way? It works for everything except reflections.

 

Many thanks for your help,

Justin

Message 4 of 5
jatomchuk
in reply to: Stephen.Blair

Ahh I seemed to have solved it! I had the "resolution" of the Arnold Sky set to 0. Setting it above that restored the sky. Not sure how I missed that, spent the majority of the afternoon going through everything.
Message 5 of 5
Stephen.Blair
in reply to: jatomchuk


@jatomchuk wrote:
Ahh I seemed to have solved it! I had the "resolution" of the Arnold Sky set to 0. Setting it above that restored the sky. Not sure how I missed that, spent the majority of the afternoon going through everything.

oh..I saw 1000 in the screenshot

but great you got it sorted out



// Stephen Blair
// Arnold Renderer Support

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report