Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Arnold Sky lags big in C4DR25 and C4D2023

15 REPLIES 15
SOLVED
Reply
Message 1 of 16
Kidmograph
683 Views, 15 Replies

Arnold Sky lags big in C4DR25 and C4D2023

Hi there, I'm working with the Arnold Sky (Physical Sky) and I can barely select the tabs to manipulate the values.

It hangs each time I click a tab for about 5-8 seconds (mainly the MAIN tab)

I noticed this lag in the last 2 updates.

I'm using C4DtoA 4.4.0 and using CPU as I'm working with Toon shader.

Any help is very much appreciated. 

Thanks

Labels (3)
15 REPLIES 15
Message 2 of 16
Stephen.Blair
in reply to: Kidmograph

Only physical sky, nothing else slows things down?

Can you get an Info-level Arnold log for some IPR rendering, so we check that?



// Stephen Blair
// Arnold Renderer Support
Message 3 of 16
Kidmograph
in reply to: Kidmograph

Thank you Stephen.

Yes, only the Physical Sky. No matter what other object I select, when I select it back it keeps hanging. The console don't show any errors, where I can get more info?

Message 4 of 16
Stephen.Blair
in reply to: Kidmograph


@Kidmograph wrote:

Thank you Stephen.

Yes, only the Physical Sky. No matter what other object I select, when I select it back it keeps hanging. The console don't show any errors, where I can get more info?


If you're rendering, then an Arnold Info-level log should show something (not necessarily errors, just information and progress...). The verbosity level is in Render Settings > Diagnostics, and the log goes the Extensions > Console

 

What if you disable the material and shader previews? (Preferences > Renderer > Arnold)



// Stephen Blair
// Arnold Renderer Support
Message 5 of 16
Kidmograph
in reply to: Stephen.Blair

Tried to save a log and a text file and they're empty. Also the console won't show any activity. Please find the attached screenshot. Sorry for the noob issues here. I can make a file collect and send it to you. Thank you.

 

Message 6 of 16
peter_horvath
in reply to: Kidmograph

Just to clarify, this lag happens when you select the Arnold Sky object, before displaying its attributes in the Attribute Manager, right? Even if no render is running.

Had a similar report recently, but was not able to reproduce it.


// Peter Horvath
// C4DtoA developer
Message 7 of 16
Kidmograph
in reply to: peter_horvath

Hi Peter. Yes. This big lag only happens while selecting the "main" tab on the physical sky. Not even using the IPR, just selecting the tab. It's a lag of about 10 seconds! very strange and really makes my workflow super slow. Happy to share the project, but it's indistinct.

Also I wanted to roll back to previous versions but there is not an update available for C4D 2023?

Thank you in advance.

 

Message 8 of 16
peter_horvath
in reply to: Kidmograph


@Kidmograph wrote:

Also I wanted to roll back to previous versions but there is not an update available for C4D 2023?


Unfortunately not, 4.4.0 was the first one supporting C4D 2023. Hopefully I can figure out soon what's going on and fix it in a next release.


// Peter Horvath
// C4DtoA developer
Message 9 of 16
Kidmograph
in reply to: peter_horvath

Alright, thanks. How about C4D R25? Is there a way to get an installer at least 2 version older?

Message 10 of 16
peter_horvath
in reply to: Kidmograph


@Kidmograph wrote:

Alright, thanks. How about C4D R25? Is there a way to get an installer at least 2 version older?


Sure, previous installers are here: https://arnoldrenderer.com/download/archive/

Actually it would be interesting to know which version introduced this problem.


// Peter Horvath
// C4DtoA developer
Message 11 of 16
Kidmograph
in reply to: peter_horvath

Thank you. Somehow didn't find them yesterday.

I will try to go back a few and see what version started with this issue.

Message 12 of 16
peter_horvath
in reply to: Kidmograph

I've been able to track the issue down and fix it. It will be available in the next bugfix release, soon.


// Peter Horvath
// C4DtoA developer
Message 13 of 16
Kidmograph
in reply to: peter_horvath

Oh really? That's amazing to hear, thank you so much! Looking forward to it!

Message 14 of 16
peter_horvath
in reply to: Kidmograph

The fix has been released in C4DtoA 4.4.0.1. Please give it a try and let me know if it works as expected now.


// Peter Horvath
// C4DtoA developer
Message 15 of 16
Kidmograph
in reply to: peter_horvath

Will do it right away. Thanks!!
Message 16 of 16
Kidmograph
in reply to: Kidmograph

This works great. Thank you so much Peter for your hard and fast work!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report