Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Arnold Scatter gives an error when setting Included/Excluded objects on a light's Project tab.

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
lmmorone_mvc
415 Views, 9 Replies

Arnold Scatter gives an error when setting Included/Excluded objects on a light's Project tab.

Not sure if it's a bug, or if I'm missing something, but whenever I set a light link and I have an Scatter in the scene, Arnold displays an error. Even just setting a single light to "Inclusive" mode triggers it. The log outputs a couple of messages for every object used by the scatter:

object.shadow_group: unresolved reference to ''

object.light_group: unresolved reference to ''

 

I've tried including the scattered objects themselves in the list but it makes no difference. On the IPR, when the errors pops up, I can just click wherever and the render goes through, and even though the Scatter is in a group that is Included in a light, every object in the group lights up but the Scatter object remains black. However when actually rendering the scene, the render is aborted right at the beginning. 

 

Any clues as to why that happens? Is there something I need to set on the Scatter object for it to actually be affected by a light link? I actually found a way around it by outputting every single light in a group and sorting it out in comp, but that's far from ideal since I end up with tons of layers for each permutation of light and render pass.

Labels (2)
9 REPLIES 9
Message 2 of 10

Sounds like a bug, although I'm not able to reproduce the error. What's your plugin version? Can you reproduce it in a basic scene as well?

What I see though is that the Include mode does not work, the instances do not light up indeed. I'll take a look if it can be fixed.


// Peter Horvath
// C4DtoA developer
Message 3 of 10

I assume I'm running the latest version, which is currently Arnold 7.1.4.3.

I actually just tested a basic scene and... it works. However, I cannot include the Scatter object into more than one light link. It just goes black, but outputs no errors.

So, this must mean that I have some sort of problem going on with the scattered objects themselves, or their materials in my original scene. Not sure yet what parameters in my geometry and materials I should be looking out for, though.

 

Edit: I just tested again, but this time I dragged the actual objects I was originally using in the scene. The light works with simple geometry, as I stated on my reply, but as soon as I merged the other objects (which are foliage objs from megascans, with atlases) the Inclusion mode stops working. No errors this time, though. Now, what's weirder to me is that, if I delete everything from my scene, along with the materials, and set it all up again with simple shapes, it still doesn't work. I even created a new surface and a new scatter, but the Inclusive mode just stops working altogether.

 

Edit2: Just confirmed also that if I have a Scatter into multiple Exclusion lists, it displays the same error as well. It seems it boils down to having multiple Inclusion/Exclusion lists on a scene with scattered objects.

Message 4 of 10

I still can't reproduce the error, not even with multiple Exclusion lists. I wonder if it's actually depends on the geometry or the type of lights in the scene. Is there a simple repo scene which you could share?


// Peter Horvath
// C4DtoA developer
Message 5 of 10

Sure. I'm fairly new, what's the best way to share a project here?
Message 6 of 10


@lmmorone_mvc wrote:
Sure. I'm fairly new, what's the best way to share a project here?

You can attach it here, or send it to support(at)arnoldrenderer(dot)com.


// Peter Horvath
// C4DtoA developer
Message 7 of 10

Here you go. I attached the project and a picture showing the problem. I've found that bug is not consistent. Sometimes it works, sometimes it doesn't, but on the picture you can clearly see it in effect.

Thanks for your time.

Message 8 of 10

Thanks. There will be a few scatter/instancer related changes in the upcoming release, I'll fix this one as well.


// Peter Horvath
// C4DtoA developer
Message 9 of 10

Released C4DtoA 4.6.1 with the fix. Hopefully everything works fine now. If not, please let me know.


// Peter Horvath
// C4DtoA developer
Message 10 of 10

I just tested it, and now seems to be working. Great support, thanks.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums