Community
Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
cancel
Showing results forย 
Showย ย onlyย  | Search instead forย 
Did you mean:ย 

Arnold rendering IPR different than in Perspective preview

10 REPLIES 10
SOLVED
Reply
Message 1 of 11
Darren_Jaffe
1614 Views, 10 Replies

Arnold rendering IPR different than in Perspective preview

2816-arnoldrendererror.jpg

Hello AA-

I am in desperate need of some assistance here. For some reason, the IPR and renderer are rendering something quite different than I am seeing in the perspective preview window. In the top image attached is what I am seeing in my perspective window. It's what I want. The bottom image is what I am getting the IPR window. NOT what I want.

Sometimes I have noticed that mograph elements or fracture objects do a similar thing where they render differently than the perspective window, but never with non-mograph keyframed animations.

*I am working other scenes that are rendering correctly so this is an anomaly in this production.

I would really appreciate any help with this issue. I'm on a deadline and this was not in the schedule! ๐Ÿ˜›

Thank you kindly,

Jason

Tags (2)
Labels (2)
10 REPLIES 10
Message 2 of 11
zenop
in reply to: Darren_Jaffe

I'd suggest caching out anything that's been animated, that will for sure fix your issue.

Message 3 of 11

The perspective preview window uses Arnold? I don't think so, so I wouldn't expect them to be the same.
Maybe I don't know CINEMA 4D well enough. The Arnold IPR window uses Arnold. Render to Picture Viewer users Arnold (if you set the renderer to Arnold).

I'd start by looking at what shaders you have on those objects.
For the thing that renders "black", is it even handled by Arnold? Maybe it's something that isn't even exported.



// Stephen Blair
// Arnold Renderer Support
Message 4 of 11

Thank you Stephen-

Perhaps I misspoke. What I am seeing in the perspective/preview window to compose the frame and animate etc is different than what I am getting at render in arnold IPR and picture viewer. For example I render out a playblast of the animation and all is well, but when it goes to render it's all messed up. I've never seen this before.

The black you see is just the bkgd.

Appreciate your help. I am going to try baking the keys and see what that gets me, but it's not a real good solution if I have to make edits later.

Jason

Message 5 of 11
Darren_Jaffe
in reply to: zenop

Thanks Zeno. I am going to give that a try.

Message 6 of 11
Darren_Jaffe
in reply to: Darren_Jaffe

OK. I baked the keys down and am still getting this craziness (attached.)

Notice how in the preview window the hands on the right are separated and in the IPR they are mashed together. What is going on??

The shaders in the scene are really simple. No displacement, just diffuse and spec contribution. There is a tiny bit of animation in the hands. It's an IK rig.

I just don't understand how the preview window is correct and the result in the IPR is so completely broken. Something really funky is happening at render. I've copied the whole scene into a new project and still the same result.

Any more thoughts would be enormously appreciated!

Thank you.

2817-arnoldrendererror-02.jpg

Message 7 of 11

I wonder if you have the same mismatch with the Standard or Physical Renderer, or is it just Arnold? If you can send me a simplified scene (just a hand maybe?) then I can take a look.

Message 8 of 11
Darren_Jaffe
in reply to: Darren_Jaffe

Hello Peter-

I actually tried that and no it didnโ€™t mismatch. Good news is I solved the issue. Turns out the hand geo was in a hyperburbs object. As soon as I took it out and fired up IPR it rendered correctly. I then put an Arnold parameters tag on the hand Geo and smoothed it out again.

Does this make sense to you? Iโ€™m grateful to get it working but not sure I understand why hypernurbs would adversely effect the render in Arnold only.

Thank you so much for responding and trying help!

Message 9 of 11

I can not recall any issues with hypernurbs. Would be great if you could send me a simple repro scene.

Message 10 of 11
Darren_Jaffe
in reply to: Darren_Jaffe

Happy to share the file Peter. Here ya go. I left the Hypernurbs activated so you can see what's happening. Simply turn them off and activate sub divs in the arnold parameter tag to fix issue.

Thank you! I look forward to hearing what you think..

hands-hypernurbsc4d.zip

Message 11 of 11

I checked the scene. This is actually an expected behavior, deformers with the Subdivision Surface object are directly not supported. By default C4DtoA exports the geometry under the Subdivision Surface object and executes the subdivision in render-time, so the deformer does not have any effect.

The solution is to add an Arnold tag to the Subdivision Surface object and export the subdivided mesh presented by the Subdivision Surface object.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums