Arnold for Cinema 4D Forum
Rendering with Arnold in CINEMA 4D using the C4DtoA plug-in.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ACES Flat Shading Incorrect

Message 1 of 7
249 Views, 6 Replies

ACES Flat Shading Incorrect

Hi there,

I am trying to render a flat background based on a set RGB/Hex value but the colour appears much darker in the IPR and final render than what it should be.

Attached is a screengrab of the render. I've extended the background in Photoshop using my original RGB/Hex colour to demonstrate what it should look like.

Note: My background is a flat shadowmatte but even as a a flat plane it renders out just as dark.screen-shot-2022-03-14-at-35151-pm.png

Tags (2)
Labels (2)
Message 2 of 7

Sorry, I forgot to add that I am in the default colour space, ACES.

Message 3 of 7
in reply to: cassidydodge2

Does it happen without the shadow_matte?

Does it render like that with sRGB?

Lee Griggs
Arnold rendering specialist
Message 4 of 7

Hi Lee,

Yes, I have the same issue even with a flat shader in ACES.

If I switch to Legacy in the Color Manager I get very close to an actual match (see below) but I would prefer to ACES if I can.


Message 5 of 7

In which color space do you have your input RGB values? Colors in Cinema 4D are in sRGB space by default (Edit > Project Settings... > Input Color Profile), therefore there's an sRGB to linear (ACEScg) transform when exported to Arnold.

Message 6 of 7

Hi Peter, Yes, my input color space is sRGB. What should it be set to in order to get the correct values with Arnold and ACES?

Message 7 of 7

Actually, I think what you want is changing the View Color Space to Un-tone-mapped (sRGB). The default view color space (ACES 1.0 SDR-video) has a tone mapping which makes the result darker.

I assume your display color space is Photoshop is sRGB and so is your input color.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums