Community
Arnold for 3ds Max Forum
Rendering with Arnold in 3ds Max using the MaxtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to keep refraction with enlarging?

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
Parmenides
389 Views, 7 Replies

How to keep refraction with enlarging?

I have a project where the diamond refraction is the way we want it but if I enlarge it, that and the transparency change. If I have different sized meshes they don't look correct. How do I keep my settings (or look?) as I enlarge objects?

 

Attached is the same mesh but the one on the right is 3x bigger. 

 

diamondBig2.jpg

Tags (1)
7 REPLIES 7
Message 2 of 8
thiago.ize
in reply to: Parmenides

Make the transmission_depth 3x smaller?

Message 3 of 8
Parmenides
in reply to: Parmenides

Thanks, I tried that but it doesn't give the same look. I also tried changing the project working units but that had no effect. It seems there must be a way to lock in a look once you have it dialed in.

Message 4 of 8
thiago.ize
in reply to: Parmenides

Units, with the object inside a standin, would be I think the ideal solution. But if that's not working, you'll need to modify the shader parameters manually. Since transparency depth didn't help, you might also have sss in your shader, in which case you'll need to also adjust subsurface_scale by 3x.

Message 5 of 8
lee_griggs
in reply to: Parmenides

Does it have dispersion_abbe?

Can you share paste the shader UI here or better yet, the scene? 

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 6 of 8
Parmenides
in reply to: lee_griggs

Hello Lee, thanks for looking at this. I did not use the dispersion_abbe setting. Here is the model: https://www.dropbox.com/s/26qzavoidbefiu0/diamond.zip?dl=0

Message 7 of 8
lee_griggs
in reply to: Parmenides

Increasing the depth works for me:

lee_griggs_1-1693398428680.png

 

 

If I set the depth to 0, scatter to black, and set the IOR to 2.42  (click on IOR to see the menu) I get something that looks more like a diamond and should render correctly at any scale. I would only use transmission_color for colored gemstones. Transmission_scatter is more suited to liquids such as a deep body of water or honey. If you really need them, then adjust the transmission_depth and transmission_scatter color.

 

From the docs:

Depth is scene scale-dependent and can have a dramatic effect on its appearance. The transmission_color and depth control transmittance/absorption, and that depends on the object scale. So for a small object to see anything you might need to set a quite low depth, or for a big object a high one. If you cannot see the effect of depth, then you may need to check the size of your scene.

When the scene scale is too small, the transmission_color (orange) appears incorrect (left image) with a transmission_depth of 1. Lowering the transmission_depth fixes it (right image). It is recommended to model to real-world scale to avoid these situations.

 

lee_griggs_0-1693397590673.png

 

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 8 of 8
Parmenides
in reply to: Parmenides

Perfect, thanks!  I never noticed the pulldown menu for IOR, now I see there is one for Dispersion Abbe as well.  I always try to keep things real world scale but in animation sometimes things need to be crazy proportions...

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report