Reply
Explorer
8 Posts

Running Scripts

52 Views, 7 Replies
2 weeks ago

No matter what I try. Every time I attempt to use the Image2Surface Script it refuses to work. After opening a new instance of Fusion 360 I create a Base Form and after I attempt to use the script, nothing happens. There is no popup window or anything else occurring.

What am I doing wrong?

 

 

PS: It worked fine 2 weeks ago with no problems, but now nothing.

Employee
358 Posts
45 Kudos
50 Solutions

Re: Running Scripts

a week ago in reply to: Ronald4418

Hello,

 

Where did you get the script "Image2Surface"? I would help figure out if I can get a copy of the script somewhere or you send a copy to me(marshal dot tu at autodesk dot com).

 

Thanks,

Marshal



Marshal Tu
Fusion 360 Developer
Autodesk, Inc.

Explorer
8 Posts

Re: Running Scripts

a week ago in reply to: marshaltu
I downloaded it from GitHub at hanskellner/Fusion360Image2Surface

|
|
|
| | |

|

|
|
| |
hanskellner/Fusion360Image2Surface
Fusion360Image2Surface - Image2Surface Script for Autodesk Fusion 360 | |

|

|
Employee
358 Posts
45 Kudos
50 Solutions

Re: Running Scripts

a week ago in reply to: Ronald4418

Hello,

 

I downloaded a copy from Github and tested in my Windows and MAC machines. It seemed to work well. 

 

I am aware of the notes in the Github site about usage of the script. You have to work parametric design with the script and otherwise it would not work. I am not sure if you were running the case. If yes, you can right-mouse click root component in the browser and execute "Capture Design History" to switch to parametric design from direct-modeling design.

 

  1. Enter the Model environment
  2. If not in direct modeling mode, create a Base Feature that will hold the surface mesh

Thanks,

Marshal



Marshal Tu
Fusion 360 Developer
Autodesk, Inc.

Explorer
8 Posts

Re: Running Scripts

Tuesday in reply to: marshaltu
I finally figured out how to get into the Scripts Folder and this Script is not present. I tried removing the Script and reloading it from the Zip File downloaded from GitHub and for some reason it will not deposit the necessary files into the Script Folder. I am running Fusion 360 Dev at present.
Explorer
8 Posts

Re: Running Scripts

Tuesday in reply to: marshaltu
I finally figured out how to get into the Scripts Folder and this Script is not present. I tried removing the Script and reloading it from the Zip File downloaded from GitHub and for some reason it will not deposit the necessary files into the Script Folder. I am running Fusion 360 Dev at present.
Explorer
8 Posts

Re: Running Scripts

Wednesday in reply to: Ronald4418

I tried everything that has been suggested and the Script once opened will not deposit into the Scripts Folder. I've tried unzipping the Image2Surface download and Extracting it directly into the Scripts folder and I have tried copying and Pasting it in directly all to no avail.

Employee
358 Posts
45 Kudos
50 Solutions

Re: Running Scripts

Wednesday in reply to: Ronald4418

Hello,

 

Please try the following steps to load the script:

 

1. Download zipped script from Github and unzip it to a folder.

2. Launch Fusion 360 and invoke "Addin & Script Manager" dialog.

3. Hit "+" button to add an existing script to Fusion.

Screen Shot 2017-04-20 at 9.23.13 AM.png

4. Browse the folder which the script is located at and select "Image2Surface.js".

Screen Shot 2017-04-20 at 9.23.43 AM.png

Thanks,

Marshal



Marshal Tu
Fusion 360 Developer
Autodesk, Inc.