Community
Alias Forum
Welcome to Autodesk’s Alias Forums. Share your knowledge, ask questions, and explore popular Alias topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Program crashes with skin tool

6 REPLIES 6
Reply
Message 1 of 7
bsalsman
338 Views, 6 Replies

Program crashes with skin tool

I am suddenly encountering crash issues when trying to skin surfaces. I am simply trying to connect 4 straight curves and connect them with skins. I am able to connect a couple curves with the skin tool, but when I try to make a third curve, it either: crashes immediately, or highlights the wrong curve, and then crashes when I try to click anywhere else. I am able to perform these exact steps on a different computer running the same version of Alias and have never had this happen before. I have uninstalled, reinstalled multiple times but nothing works. Everything is up to date. I have not changed any settings. Please help! I can't find anything on this topic.

Labels (2)
6 REPLIES 6
Message 2 of 7
bsalsman
in reply to: bsalsman

I'm realizing now that Alias crashes every time I try to select the edge of any surface. This is very frustrating.

Message 3 of 7
bob55
in reply to: bsalsman

Please enter what version of Alias you are running and what OS and graphics card and a simple workflow to reproduce the crash.  I assume you tried renaming your preferences.

Message 4 of 7
bsalsman
in reply to: bob55

Hi! I tried renaming my preferences and that did not work either. I am on a 2020 iMac (Retina 5k), Processor: 3.3 GHz 6-Core Intel Core i5, 64GB Ram, Graphics: AMD Radeon Pro 5300 4GB. Running Parallels 17.1.2 and Alias 2022.2. 

 

Workflow: Created 4 EP curves in the shape of an L, copy and pasted them to create other end. Skin Tool > Connect 4 curves> try to created skins with edges of surfaces and then FAIL. I have also tried simply creating two circles, skinning them and then select edge of skin to create a planar surface > FAIL. I cannot seem to even select edges of surfaces. (I've uploaded a screen recording of the process.)

 

What's confusing is that I have been using this setup for 4 months and suddenly it's now failing. I installed Parallels and Alias on my 2015 MacBook and it's doing the same thing.

 

Message 5 of 7
rauscht
in reply to: bsalsman

Hi,

sorry for the crashes you are experiencing. And thanks for the screen recording you have shared recently. That helped me a lot to understand what you are doing.

 

The bad news is that I was not able to reproduce the crash on my machine. I tried it a couple of times while watching your video in parallel. In order to proceed with this issue, I would like to ask you for some additional tests:


1. Can you check the attached l-shape.wire (contained in that zip archive

As said, I have tried to reproduce the crash on my end, but failed. Please unzip the file, load file l-shape.wire, delete all the skin surfaces contained (which I was able to create), and then try to reproduce the crash again.

 

Two possible outcomes:

* Either it is not crashing => it must be related to the curves you are using => can you provide me the file please

* Or it is still crashing => there must be something specific to your set-up causing the crash

 

2. Provide a CER

Personally, I expect the second alternative to happen. In any case, but specifically in that situation, could you please send me that Customer Error Report. Simply push the Send button rather than closing the crash window. As a result, you will be given a CER report ID, which you would ideally pass to me. As a result, I would be able to inspect some more details on what caused the crash.

 

3. What have you clicked before the crash?

The most puzzling thing about your video actually is the selection feedback (i.e. which edge is highlighted) shortly before the crash is happening. If I am not mistaken, you are clicking on the top (vertical) edge of the first skin surface. But the selection feedback indicates the left (vertical) edge curve. Can you confirm you have clicked the upper edge?

 

Allow me a final comment on your set-up:
Unfortunately, using Parallels is not a certified "platform" to run Alias on. There are a lot of restrictions which prevents us from assuming this to be a stable environment for our application (limited OpenGL support is just one).

 

Even though you have mentioned that this set-up has worked for you before, there is no guarantee that it will be in future, say after some Parallels updates on their internally used drivers.

Hth
Thomas



Thomas Rausch

Software Development Manager
Message 6 of 7
bsalsman
in reply to: rauscht

Hello again! I have since resolved my issue by installing a previous version of Parallels. The fact that this happened all of a sudden, and I was able to recreate the issue on another laptop running the same setup but with different hardware, I realized it had to be an issue with Parallels. I reverted back to version 16, because the latest version of Parallels 17.1.2 is where I was able to recreate the problem.

 

There may be some settings within the Parallels configuration on the latest version that would need to be adjusted, but I could not figure that part out. I kept trying different configurations for memory and graphics use, but for now, running Parallels Desktop 16 has resolved my issue, and I can continue with skinning simple curves and selecting the edges of any surface.

 

I may dive into the bug with Parallels 17.1.2 when I have the time, and have reported the issue to them directly.

 

(Just for clarification, I was indeed selecting the top edge of the skin, and not the curve along the Z-axis, even though that one was being highlighted.)

 

Thank you again for trying to troubleshoot with me.

Message 7 of 7
rauscht
in reply to: bsalsman

Hi,

 

glad to hear that your environment is operating again. Thanks for sharing that!



Thomas Rausch

Software Development Manager

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report