Vault General

Reply
Contributor
Posts: 50
Registered: ‎12-02-2008
Message 41 of 60 (1,117 Views)

Re: I HATE THE JOB PROCESSOR!

07-20-2012 02:50 AM in reply to: jeff_jordan

I recognize 95% of you have described. In europe we have 4 countries using one database and use 5 jobservers (1 for every country and 2 for Netherlands --> VMs) to get the work done. (+/- 50 engineers)

Our company, Parker Hannifin has a Platinum contract (global) with Autodesk. All Autodesk products can be used unlimited. So licenses are not an issue for us. BUT we still have big problems with job servers.

The message

a visualization file cannot be generated for a non cad file.

is something I am working on today. We recieve it once every 3,4 months. Till now we have no idea why.

Reregister inventor sometimes helps. Updating with a SP sometimes helps....  :smileysad:

 I asked for a priority of tasks for the job server as well. dwf should be made during the night (so time planning should be possible.)

After creating a new version by the jobserver, the remarks placed by the engineer in the field comment are 'lost'. (We place the text 'To be checked by xxx" when the state = For Review. A user can search on this in order to know what he has to check this day. But an update of teh title block by the jobserver creates a new version and we can not search on this info anymore. :smileysad:

 

 

 

Maarten Weers
CAD Manager IT Core Competency Team EMEA
Parker Hannifin
Oldenzaal - The Netherlands
-------------------------------------------------------------------------------------------
Inventor Pro 2014 - Vault Professional 2014 - Windows 7 64 bit -
Contributor
Posts: 21
Registered: ‎05-07-2012
Message 42 of 60 (883 Views)

Re: I HATE THE JOB PROCESSOR!

10-12-2012 07:04 AM in reply to: Maarten65

Has anyone set up the Job Processor to run on a Virtual Machine?

 

We have two job processors running, one on an old XP CAD workstation and another on a VM in our server cluster. Aside from the usual (and frequent) issues with the job processor the VM one hangs up on several times a day and the only way to get it going again is to kill the Inventor process. This requires someone to constantly monitor this VM which is not something we enjoy doing.

It appears that Inventor (apprenticeserver) max's out the memory which is what is causing Inventor to hang up, not surprisingly. 

 

So I'm wondering if anyone else has successfully set up the Job Processor on a VM, and if so how did they configure it? 

 

Thanks,

Sailin Benedum
Member
Posts: 4
Registered: ‎09-05-2012
Message 43 of 60 (814 Views)

Re: I HATE THE JOB PROCESSOR!

10-18-2012 01:01 PM in reply to: sbenedum

sbenedum,

What release of Vault are you using?

 

If 2013 Professional, the following work-around may help. You could use the JobProcessor.exe command line arguments, in combination with a scheduled task+powershell, to restart JobProcessor.exe every few hours on the VM.

 

# === powershell.ps1 script ===

& "C:\Program Files\Autodesk\Vault Professional 2013\Explorer\JobProcessor.exe" /stop
Wait-Process JobProcessor
& "C:\Program Files\Autodesk\Vault Professional 2013\Explorer\JobProcessor.exe"

# === powershell.ps1 script ===

 

The /stop command will finish the current job then exit the JobProcessor (releasing Inventor's resources).

 

If you are using a different verison of Inventor, let me know; there may be other options to try.

 

-- Alex

 

 

Active Contributor
Posts: 37
Registered: ‎01-03-2010
Message 44 of 60 (695 Views)

a visualization file cannot be generated for a non cad file

11-16-2012 10:02 AM in reply to: jeff_jordan

We use Job Processor to handle DWF creation for 15 users. sometimes more than a 1000 files a day. Yes it has been problematic at times.

The error "a visualization file cannot be generated for a non cad file" had me frustated until I tracked it down to our anti-virus software (ESET). Since adding all Autodesk software to the Excluded applications list that error has stopped.

 

Vince B

Inventor Pro 2013 / Vault Pro 2013

*Expert Elite*
Mark_Wigan
Posts: 436
Registered: ‎03-07-2006
Message 45 of 60 (598 Views)

Re: I HATE THE JOB PROCESSOR!

12-05-2012 04:48 PM in reply to: jeff_jordan

thanks jeff (& others) for your post. i aggree with your ideas and comments.

 

we are just implementing vault collaboration in the past few months and having some of these issues.

 

i have had some serious crashing of inventor while running JP on my workstation & trying to work at the same time in inventor. these were not just a normal inventor crash though, as i later discovered that all my addins were broken, had to try to repair / reinstall inventor and so on. (that is another story).

 

during the process though i posted some thoughts on the (vault and inventor) ideas forum about having some improved functionality of the job processor. i just wanted to note it again here for the ability of Autodesk to consolidate everyone's feedback while they "hopefully" put the resources into this thing to get it working properly.

 

maybe it wouldn't be as bad if we were all using a free program and trying to develop a new piece of software together but this is an expensive piece of software that a massive organisation has developed, (pitched as something great) that our buisinesses rely on it to run efficiently, but this JP runs like it came out of a breakfast serial packet.

 

very dissapointing.

 

 

best regards,
- Mark

PDSU 2014 Windows 7, 64bit. (please consider Kudos or Tag as Solved if your issue is sorted)

Valued Contributor
jddrinkwater
Posts: 61
Registered: ‎01-03-2012
Message 46 of 60 (573 Views)

Re: I HATE THE JOB PROCESSOR!

12-06-2012 03:35 PM in reply to: Mark_Wigan

I have had my own issues with JP (hanging and crashing).  I am using physical PCs, I don't have experience with VMs.  

 

In my troubles I've discovered 2 tricks:

 

#1 - if you have 2 (or more) PCs available to run the JP, configure them so that one machine does only dwfs for IDW/DWG and the other machine does all other tasks.  What i've discovered is that at least 80% of the hangs can be eliminated when it isn't switching between drawings and assemblies/sync properties/etc.

 

#2 - the job processor (inventor) seems to operate single threaded, but you can trick it into utilizing multiple cores on your PC by logging in under multiple user names.  Each windows account can run it's own copy of the JP.  I recently had to generate several thousand DWFs.  By having all the engineers log in to our CFD/rendering computer, we utilized al 8 cores and cranked the DWFs out in under a day.

 

#3 - I don't like that these hacks were necessary to make the program run smoothly.  It is also an annoyance that the JP consumes a license.  If the JP gets backed up i have 2 options: have the engineers wait for files to get slowly processed, or ask engineers to log off vault so that i can start more JPs and process the excess files.

Distinguished Contributor
Posts: 139
Registered: ‎08-02-2006
Message 47 of 60 (337 Views)

Re: I HATE THE JOB PROCESSOR!

05-22-2013 10:54 PM in reply to: jeff_jordan

I was hoping that the JP processor improvements in 2014 were here to help but not so sure

I would appreciate any feedback/help on this

 

I left JP with default settings. Submitted approx 100 for DWF update

 

After about 20, Job Queue is showing processing. An hour later still processing on that object

 

It's not file specific as I kill the JP and restart it and it does 2 more files tha it hangs again

 

I also noticed a new error to add to the others that JP likes to throw

"The new job processor is not responding" 

 

The JP log does not help much, it shows it's still executing

 

General 23/05/2013 3:03:21 PM
-------Job 557 Autodesk.Vault.DWF.Create.idw : DWF Create: 3172_BARREL ASSEMBLY.idw-------
            
General 23/05/2013 3:03:21 PM
Started executing

 

I am trying to like the JP but it's not liking me. Maybe it's personal

 

Max Bodnar

Active Contributor
Posts: 37
Registered: ‎01-03-2010
Message 48 of 60 (333 Views)

Re: I HATE THE JOB PROCESSOR!

05-23-2013 05:36 AM in reply to: jeff_jordan

Look at your anti virus program. We were getting the same error message. Our ESET anti Virus was the culprit. When I excluded Autodesk products in Protocol filtering the problem stopped. Some days I'll see more than a 1000 files processed. Large assembly drawings that are not resolved properly can be a problem.

 

Vince Balge

ATCOEM

Vault Pro 2013

Distinguished Contributor
Posts: 139
Registered: ‎08-02-2006
Message 49 of 60 (327 Views)

Re: I HATE THE JOB PROCESSOR!

05-23-2013 05:51 AM in reply to: VINCEBALGE4109
Hi Vince

Thanks for the reply. I had suspected that the antivirus might be the issue (running TrendMicro) as it has already blocked some of the installs.

I tested on machine without antivirus and JP still hung after about 10 files. Will double check again

Cheers
Max Bodnar
Distinguished Contributor
Posts: 139
Registered: ‎08-02-2006
Message 50 of 60 (326 Views)

Re: I HATE THE JOB PROCESSOR!

05-23-2013 05:53 AM in reply to: VINCEBALGE4109
One more question please did you exclude any particular *.exe processes or all Autodesk products/programs?

Max

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community