Installation & Licensing

Reply
*Eisenstein, Jason
Message 1 of 5 (132 Views)

AutoCAD ADT 3 install

132 Views, 4 Replies
04-04-2001 05:29 AM
We will be moving soon to Windows 2000 with ADT 3.
We are currently using NT SP5.
With the new configuration we will be setting all users as "users" they are
currently admins on NT.
I have been able to get AutoCAD to run as a standard user.
My problem lies with instillation ADT3 as a standard user. I will be using
ghost to push out a standard copy of Win2K to all workstations. I have
tried using the publish or advertise method of software distribtution that
is in the new Windows Installer MSI. This works fine for MS Office but not
for ADT 3.
Has anyone gotten the msiexec.exe /jm to work yet with ADT3? I don't want
to include ADT3 on the image Since not everyone need AutoCAD, but I don't
want to walk around to everyone's computer loging on as admin and run the
install.

Setup:
Windows 2000 SP1
AutoCAD ADT 3 SP1
ADLM on NT 4.0
Ran Netsetup.exe to create client install
Using MSI from \\Server\share\deploy\image\adt.msi

Thanks in Advance
Jason Eisenstein
jason.nospam@bos.bergmeyer.com.invalid
*martin, jason
Message 2 of 5 (132 Views)

Re: AutoCAD ADT 3 install

04-04-2001 09:03 AM in reply to: *Eisenstein, Jason
Jason -

I can't currently find the documentation for this in the kb, but I know that
I've seen that admin privileges are req'd for installation of acad2000(i).
I think that you could probably get around this by allowing users some
additional rights on the w2k stations. I know that you would have to
increase the rights to the registry (HKLM\Software and HKCR) and probably to
some system folders.

As far as I know pushing acad to the clients isn't currently supported. The
only supported method is running the actual install from the client. Please
keep experimenting and let us know if you can get it to work. I know that
there are a number of people interested in this.

I know that these aren't the answers that you wanted to hear, but it's all I
have right now. sorry

jason martin
frankfurt-short-bruza

Jason Eisenstein wrote in message
news:4A400546589D8F42E024B851A8682865@in.WebX.maYIadrTaRb...
> We will be moving soon to Windows 2000 with ADT 3.
> We are currently using NT SP5.
> With the new configuration we will be setting all users as "users" they
are
> currently admins on NT.
> I have been able to get AutoCAD to run as a standard user.
> My problem lies with instillation ADT3 as a standard user. I will be
using
> ghost to push out a standard copy of Win2K to all workstations. I have
> tried using the publish or advertise method of software distribtution that
> is in the new Windows Installer MSI. This works fine for MS Office but
not
> for ADT 3.
> Has anyone gotten the msiexec.exe /jm to work yet with ADT3? I don't want
> to include ADT3 on the image Since not everyone need AutoCAD, but I don't
> want to walk around to everyone's computer loging on as admin and run the
> install.
>
> Setup:
> Windows 2000 SP1
> AutoCAD ADT 3 SP1
> ADLM on NT 4.0
> Ran Netsetup.exe to create client install
> Using MSI from \\Server\share\deploy\image\adt.msi
>
> Thanks in Advance
> Jason Eisenstein
> jason.nospam@bos.bergmeyer.com.invalid
>
*van Tichelen, Raf
Message 3 of 5 (132 Views)

Re:

04-26-2001 11:56 PM in reply to: *Eisenstein, Jason
I currently have the same problem with some new workstations on our network.
Those are Win2K PC's while the server is running NT4. ADT 2 & 3 only work
smoothly when logged in as an administrator. As it is not our policy to give
administrator rights to everyone using AutoCAD information on the settings
for users using AutoCAD is welcome (I did' t find proper settings yet)
Does anyone know if this problem is solved by upgrading the server to Win2K
?

Raf van Tichelen

ARCHITECTENBUREAU C. CONIX

"jason martin" wrote in message
news:83C655D86FD2382E578F4ADF827114E6@in.WebX.maYIadrTaRb...
> Jason -
>
> I can't currently find the documentation for this in the kb, but I know
that
> I've seen that admin privileges are req'd for installation of acad2000(i).
> I think that you could probably get around this by allowing users some
> additional rights on the w2k stations. I know that you would have to
> increase the rights to the registry (HKLM\Software and HKCR) and probably
to
> some system folders.
>
> As far as I know pushing acad to the clients isn't currently supported.
The
> only supported method is running the actual install from the client.
Please
> keep experimenting and let us know if you can get it to work. I know that
> there are a number of people interested in this.
>
> I know that these aren't the answers that you wanted to hear, but it's all
I
> have right now. sorry
>
> jason martin
> frankfurt-short-bruza
>
> Jason Eisenstein wrote in message
> news:4A400546589D8F42E024B851A8682865@in.WebX.maYIadrTaRb...
> > We will be moving soon to Windows 2000 with ADT 3.
> > We are currently using NT SP5.
> > With the new configuration we will be setting all users as "users" they
> are
> > currently admins on NT.
> > I have been able to get AutoCAD to run as a standard user.
> > My problem lies with instillation ADT3 as a standard user. I will be
> using
> > ghost to push out a standard copy of Win2K to all workstations. I have
> > tried using the publish or advertise method of software distribtution
that
> > is in the new Windows Installer MSI. This works fine for MS Office but
> not
> > for ADT 3.
> > Has anyone gotten the msiexec.exe /jm to work yet with ADT3? I don't
want
> > to include ADT3 on the image Since not everyone need AutoCAD, but I
don't
> > want to walk around to everyone's computer loging on as admin and run
the
> > install.
> >
> > Setup:
> > Windows 2000 SP1
> > AutoCAD ADT 3 SP1
> > ADLM on NT 4.0
> > Ran Netsetup.exe to create client install
> > Using MSI from \\Server\share\deploy\image\adt.msi
> >
> > Thanks in Advance
> > Jason Eisenstein
> > jason.nospam@bos.bergmeyer.com.invalid
> >
>
*martin, jason
Message 4 of 5 (132 Views)

Re:

04-27-2001 12:28 AM in reply to: *Eisenstein, Jason
Raf -
Below are instructions on allowing autocad 2000 to run on windows 2000 with user
privileges. (Instructions provided by Shaan Hurley / found by a reference from Kevin
Nehls)


Running AutoCAD~ 2000 as a Domain User on Microsoft~ Windows 2000

[Problem]
When you run AutoCAD~ 2000 as a Domain User on a Microsoft~ Windows 2000
domain,
the following errors occur:

º On start-up: Failed to update the system registry. Please try using
REGEDIT.

º DesignCenter: Exception occurred.

Other numerous errors are encountered using things such as dbConnect, or any
other feature that writes to the install directory or the registry.

[Solution]
These errors occur because Windows 2000 has additional lockdowns on the
registry
(specifically in the HKEY_LOCAL_MACHINE folder) and the Program Files
directory.

This means that a member of the Domain Users group is denied write
permissions
to these objects, which prevents AutoCAD 2000 from functioning correctly.

You can use Group Policies to get AutoCAD 2000 to work correctly, but a
Window's
2000 domain controller must be used.

Important: Only an Administrator for the domain can change the Group Policy.

First, an Administrator for the Domain Controller must make the following
changes, effectively giving full access rights to the Domain Users group for
the
relevant area of the registry required by AutoCAD 2000:

1. On the Domain server open Active Directory Users and Computers.
2. Right click the Domain name and choose Properties.
3. Select the Group Policy tab, and select the Edit button (unless policies
have
been created previously, only "Default Domain Policy" will be listed).
4. Navigate to the following folder: Computer Configuration\Windows
Settings\Security Settings\Registry.
5. Either right-click the Registry folder or in the right pane, and then
choose
Add Key.
6. In the Selected Key folder type MACHINE\SOFTWARE\Autodesk and choose OK.
7. In the Database Security dialog box, highlight the Everyone group and
select
Remove.
8. Select Add and then select the Domain Users group in the dialog box.
Choose
OK.
9. Select the Allow check box for Full Control, and choose OK.
10. In the Template Policy Security Setting dialog, choose OK to return to
the
Group Policy Editor.

Second, while in the Group Policy Editor the Administrator must add similar
permissions for the install folder security:

1. Navigate to the following folder: Computer Configuration\Windows
Settings\Security Settings\File System.
2. Either right-click the File System folder or in the right pane, and then
choose Add File.
3. Enter the install directory for AutoCAD 2000 on the Client machines. The
default directory is program files\autocad 2000.
4. In the Database Security dialog box, highlight the Everyone group and
select
Remove.
5. Select Add and then select the Domain Users group in the dialog box.
Choose
OK.
6. Select the Allow check box for Full Control, and choose OK.
7. In the Template Policy Security Setting dialog, choose OK to return to
the
Group Policy Editor.
8. Exit the Group Policy Editor and Active Directory for Users and
Computers.

There may be a delay of several minutes while the Domain Policy propagates
to
the Client machines.

Test logging in on a client machine as a Domain User to ensure that AutoCAD
2000
functions correctly.



hth

jason martin
frankfurt-short-bruza

"Raf van Tichelen" wrote in message
news:7CDA2CF0380E627567F961CC06193908@in.WebX.maYIadrTaRb...
> I currently have the same problem with some new workstations on our network.
> Those are Win2K PC's while the server is running NT4. ADT 2 & 3 only work
> smoothly when logged in as an administrator. As it is not our policy to give
> administrator rights to everyone using AutoCAD information on the settings
> for users using AutoCAD is welcome (I did' t find proper settings yet)
> Does anyone know if this problem is solved by upgrading the server to Win2K
> ?
>
> Raf van Tichelen
>
> ARCHITECTENBUREAU C. CONIX
>
> "jason martin" wrote in message
> news:83C655D86FD2382E578F4ADF827114E6@in.WebX.maYIadrTaRb...
> > Jason -
> >
> > I can't currently find the documentation for this in the kb, but I know
> that
> > I've seen that admin privileges are req'd for installation of acad2000(i).
> > I think that you could probably get around this by allowing users some
> > additional rights on the w2k stations. I know that you would have to
> > increase the rights to the registry (HKLM\Software and HKCR) and probably
> to
> > some system folders.
> >
> > As far as I know pushing acad to the clients isn't currently supported.
> The
> > only supported method is running the actual install from the client.
> Please
> > keep experimenting and let us know if you can get it to work. I know that
> > there are a number of people interested in this.
> >
> > I know that these aren't the answers that you wanted to hear, but it's all
> I
> > have right now. sorry
> >
> > jason martin
> > frankfurt-short-bruza
> >
> > Jason Eisenstein wrote in message
> > news:4A400546589D8F42E024B851A8682865@in.WebX.maYIadrTaRb...
> > > We will be moving soon to Windows 2000 with ADT 3.
> > > We are currently using NT SP5.
> > > With the new configuration we will be setting all users as "users" they
> > are
> > > currently admins on NT.
> > > I have been able to get AutoCAD to run as a standard user.
> > > My problem lies with instillation ADT3 as a standard user. I will be
> > using
> > > ghost to push out a standard copy of Win2K to all workstations. I have
> > > tried using the publish or advertise method of software distribtution
> that
> > > is in the new Windows Installer MSI. This works fine for MS Office but
> > not
> > > for ADT 3.
> > > Has anyone gotten the msiexec.exe /jm to work yet with ADT3? I don't
> want
> > > to include ADT3 on the image Since not everyone need AutoCAD, but I
> don't
> > > want to walk around to everyone's computer loging on as admin and run
> the
> > > install.
> > >
> > > Setup:
> > > Windows 2000 SP1
> > > AutoCAD ADT 3 SP1
> > > ADLM on NT 4.0
> > > Ran Netsetup.exe to create client install
> > > Using MSI from \\Server\share\deploy\image\adt.msi
> > >
> > > Thanks in Advance
> > > Jason Eisenstein
> > > jason.nospam@bos.bergmeyer.com.invalid
> > >
> >
>
*van Tichelen, Raf
Message 5 of 5 (132 Views)

Re:

04-27-2001 01:05 AM in reply to: *Eisenstein, Jason
Thanx

It seems that We'll have to upgrade our server to Win2K to have a good
solution for the problem.

Raf van Tichelen

"jason martin" wrote in message
news:21808EDF15EDF4B9CA1CC3430B1C5558@in.WebX.maYIadrTaRb...
> Raf -
> Below are instructions on allowing autocad 2000 to run on windows 2000
with user
> privileges. (Instructions provided by Shaan Hurley / found by a reference
from Kevin
> Nehls)
>
>
> Running AutoCAD~ 2000 as a Domain User on Microsoft~ Windows 2000
>
> [Problem]
> When you run AutoCAD~ 2000 as a Domain User on a Microsoft~ Windows 2000
> domain,
> the following errors occur:
>
> º On start-up: Failed to update the system registry. Please try using
> REGEDIT.
>
> º DesignCenter: Exception occurred.
>
> Other numerous errors are encountered using things such as dbConnect, or
any
> other feature that writes to the install directory or the registry.
>
> [Solution]
> These errors occur because Windows 2000 has additional lockdowns on the
> registry
> (specifically in the HKEY_LOCAL_MACHINE folder) and the Program Files
> directory.
>
> This means that a member of the Domain Users group is denied write
> permissions
> to these objects, which prevents AutoCAD 2000 from functioning correctly.
>
> You can use Group Policies to get AutoCAD 2000 to work correctly, but a
> Window's
> 2000 domain controller must be used.
>
> Important: Only an Administrator for the domain can change the Group
Policy.
>
> First, an Administrator for the Domain Controller must make the following
> changes, effectively giving full access rights to the Domain Users group
for
> the
> relevant area of the registry required by AutoCAD 2000:
>
> 1. On the Domain server open Active Directory Users and Computers.
> 2. Right click the Domain name and choose Properties.
> 3. Select the Group Policy tab, and select the Edit button (unless
policies
> have
> been created previously, only "Default Domain Policy" will be listed).
> 4. Navigate to the following folder: Computer Configuration\Windows
> Settings\Security Settings\Registry.
> 5. Either right-click the Registry folder or in the right pane, and then
> choose
> Add Key.
> 6. In the Selected Key folder type MACHINE\SOFTWARE\Autodesk and choose
OK.
> 7. In the Database Security dialog box, highlight the Everyone group and
> select
> Remove.
> 8. Select Add and then select the Domain Users group in the dialog box.
> Choose
> OK.
> 9. Select the Allow check box for Full Control, and choose OK.
> 10. In the Template Policy Security Setting dialog, choose OK to return to
> the
> Group Policy Editor.
>
> Second, while in the Group Policy Editor the Administrator must add
similar
> permissions for the install folder security:
>
> 1. Navigate to the following folder: Computer Configuration\Windows
> Settings\Security Settings\File System.
> 2. Either right-click the File System folder or in the right pane, and
then
> choose Add File.
> 3. Enter the install directory for AutoCAD 2000 on the Client machines.
The
> default directory is program files\autocad 2000.
> 4. In the Database Security dialog box, highlight the Everyone group and
> select
> Remove.
> 5. Select Add and then select the Domain Users group in the dialog box.
> Choose
> OK.
> 6. Select the Allow check box for Full Control, and choose OK.
> 7. In the Template Policy Security Setting dialog, choose OK to return to
> the
> Group Policy Editor.
> 8. Exit the Group Policy Editor and Active Directory for Users and
> Computers.
>
> There may be a delay of several minutes while the Domain Policy propagates
> to
> the Client machines.
>
> Test logging in on a client machine as a Domain User to ensure that
AutoCAD
> 2000
> functions correctly.
>
>

>
> hth
>
> jason martin
> frankfurt-short-bruza
>
> "Raf van Tichelen" wrote in message
> news:7CDA2CF0380E627567F961CC06193908@in.WebX.maYIadrTaRb...
> > I currently have the same problem with some new workstations on our
network.
> > Those are Win2K PC's while the server is running NT4. ADT 2 & 3 only
work
> > smoothly when logged in as an administrator. As it is not our policy to
give
> > administrator rights to everyone using AutoCAD information on the
settings
> > for users using AutoCAD is welcome (I did' t find proper settings yet)
> > Does anyone know if this problem is solved by upgrading the server to
Win2K
> > ?
> >
> > Raf van Tichelen
> >
> > ARCHITECTENBUREAU C. CONIX
> >
> > "jason martin" wrote in message
> > news:83C655D86FD2382E578F4ADF827114E6@in.WebX.maYIadrTaRb...
> > > Jason -
> > >
> > > I can't currently find the documentation for this in the kb, but I
know
> > that
> > > I've seen that admin privileges are req'd for installation of
acad2000(i).
> > > I think that you could probably get around this by allowing users some
> > > additional rights on the w2k stations. I know that you would have to
> > > increase the rights to the registry (HKLM\Software and HKCR) and
probably
> > to
> > > some system folders.
> > >
> > > As far as I know pushing acad to the clients isn't currently
supported.
> > The
> > > only supported method is running the actual install from the client.
> > Please
> > > keep experimenting and let us know if you can get it to work. I know
that
> > > there are a number of people interested in this.
> > >
> > > I know that these aren't the answers that you wanted to hear, but it's
all
> > I
> > > have right now. sorry
> > >
> > > jason martin
> > > frankfurt-short-bruza
> > >
> > > Jason Eisenstein wrote in
message
> > > news:4A400546589D8F42E024B851A8682865@in.WebX.maYIadrTaRb...
> > > > We will be moving soon to Windows 2000 with ADT 3.
> > > > We are currently using NT SP5.
> > > > With the new configuration we will be setting all users as "users"
they
> > > are
> > > > currently admins on NT.
> > > > I have been able to get AutoCAD to run as a standard user.
> > > > My problem lies with instillation ADT3 as a standard user. I will
be
> > > using
> > > > ghost to push out a standard copy of Win2K to all workstations. I
have
> > > > tried using the publish or advertise method of software
distribtution
> > that
> > > > is in the new Windows Installer MSI. This works fine for MS Office
but
> > > not
> > > > for ADT 3.
> > > > Has anyone gotten the msiexec.exe /jm to work yet with ADT3? I
don't
> > want
> > > > to include ADT3 on the image Since not everyone need AutoCAD, but I
> > don't
> > > > want to walk around to everyone's computer loging on as admin and
run
> > the
> > > > install.
> > > >
> > > > Setup:
> > > > Windows 2000 SP1
> > > > AutoCAD ADT 3 SP1
> > > > ADLM on NT 4.0
> > > > Ran Netsetup.exe to create client install
> > > > Using MSI from \\Server\share\deploy\image\adt.msi
> > > >
> > > > Thanks in Advance
> > > > Jason Eisenstein
> > > > jason.nospam@bos.bergmeyer.com.invalid
> > > >
> > >
> >
>

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with Us

Twitter

Pinterest

Blog

Youtube