Autodesk Namespace

Enumerations
 | Enumeration | Description
Public enumeration | Axes | Definition of three geometric axes used throughout Delcam Custom Software Core.
Public enumeration | LengthUnits | Definition of length units used throughout Delcam Custom Software Core.
Public enumeration | Planes | Definition of geometric planes used throughout Delcam Custom Software Core.
Public enumeration | ViewAngles | Definition of viewing angles used throughout Delcam Custom Software Core.

© Copyright 2017 Autodesk, Inc

Send comments on this topic to the Autodesk forums


Axes Enumeration

Definition of three geometric axes used throughout Delcam Custom Software Core.

Namespace: Autodesk
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum Axes
Public Enumeration Axes
Members
Member name | Value | Description
X | 0 |
Y | 1 |
Z | 2 |
See Also

Reference

Autodesk Namespace


LengthUnits Enumeration

Definition of length units used throughout Delcam Custom Software Core.

Namespace: Autodesk
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum LengthUnits
Public Enumeration LengthUnits
Members
Member name | Value | Description
MM | 0 |
Inches | 1 |
See Also

Reference

Autodesk Namespace


Planes Enumeration

Definition of geometric planes used throughout Delcam Custom Software Core.

Namespace: Autodesk
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum Planes
Public Enumeration Planes
Members
Member name | Value | Description
XY | 0 |
YZ | 1 |
ZX | 2 |
See Also

Reference

Autodesk Namespace


ViewAngles Enumeration

Definition of viewing angles used throughout Delcam Custom Software Core.

Namespace: Autodesk
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ViewAngles
Public Enumeration ViewAngles
Members
Member name | Value | Description
ViewFromTop | 0 |
ViewFromBottom | 1 |
ViewFromLeft | 2 |
ViewFromRight | 3 |
ViewFromFront | 4 |
ViewFromBack | 5 |
ISO1 | 6 |
ISO2 | 7 |
ISO3 | 8 |
ISO4 | 9 |
See Also

Reference

Autodesk Namespace


Autodesk.Extensions Namespace

Classes
 | Class | Description
Public class | BooleanExtensions | Contains Boolean extension method
Public class | EnumExtensions | This module contains all enum extensions


BooleanExtensions Class

Contains Boolean extension method
Inheritance Hierarchy
SystemObject
Autodesk.ExtensionsBooleanExtensions

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static class BooleanExtensions
<ExtensionAttribute>
Public NotInheritable Class BooleanExtensions

The BooleanExtensions type exposes the following members.

Methods
Name | Description
ToOneZero | This operation returns the string "1" if the input boolean is True, "0" otherwise.
ToOnOff | This operation returns the string "ON" if the input boolean is True, "OFF" otherwise.
ToYesNo | This operation returns the string "YES" if the input boolean is True, "NO" otherwise.
Top
See Also

Reference

Autodesk.Extensions Namespace


BooleanExtensions Methods

The BooleanExtensions type exposes the following members.

Methods
Name | Description
ToOneZero | This operation returns the string "1" if the input boolean is True, "0" otherwise.
ToOnOff | This operation returns the string "ON" if the input boolean is True, "OFF" otherwise.
ToYesNo | This operation returns the string "YES" if the input boolean is True, "NO" otherwise.
Top
See Also

Reference

BooleanExtensions Class
Autodesk.Extensions Namespace


BooleanExtensions.ToOneZero Method

Autodesk PowerShape And PowerMill API

BooleanExtensionsToOneZero Method

This operation returns the string "1" if the input boolean is True, "0" otherwise.

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static int ToOneZero(
    this bool inputBoolean
)
<ExtensionAttribute>
Public Shared Function ToOneZero (
    inputBoolean As Boolean
) As Integer

Parameters

inputBoolean
Type: SystemBoolean
Boolean value to convert.

Return Value

Type: Int32
1 or 0

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Boolean. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BooleanExtensions Class
Autodesk.Extensions Namespace


BooleanExtensions.ToOnOff Method

BooleanExtensionsToOnOff Method

This operation returns the string "ON" if the input boolean is True, "OFF" otherwise.

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string ToOnOff(
    this bool inputBoolean
)
<ExtensionAttribute>
Public Shared Function ToOnOff (
    inputBoolean As Boolean
) As String

Parameters

inputBoolean
Type: SystemBoolean
Boolean value to convert.

Return Value

Type: String
"ON" or "OFF"

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Boolean. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BooleanExtensions Class
Autodesk.Extensions Namespace


BooleanExtensions.ToYesNo Method

BooleanExtensionsToYesNo Method

This operation returns the string "YES" if the input boolean is True, "NO" otherwise.

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string ToYesNo(
    this bool inputBoolean
)
<ExtensionAttribute>
Public Shared Function ToYesNo (
    inputBoolean As Boolean
) As String

Parameters

inputBoolean
Type: SystemBoolean
Boolean value to convert.

Return Value

Type: String
"YES" or "NO"

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Boolean. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BooleanExtensions Class
Autodesk.Extensions Namespace


EnumExtensions Class

This module contains all enum extensions
Inheritance Hierarchy
SystemObject
Autodesk.ExtensionsEnumExtensions

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static class EnumExtensions
<ExtensionAttribute>
Public NotInheritable Class EnumExtensions

The EnumExtensions type exposes the following members.

Methods
Name | Description
AxisToPlane | Returns plane normal to the input axis.
GetEnumByResourceValueT | Get enum value by string value representing value withing a ResourceSet lookup
GetFullNameT | Get enum full name
PlaneToAxis | Returns axis normal to the input plane.
ToDescriptionT | Get Enum description value
Top
See Also

Reference

Autodesk.Extensions Namespace


EnumExtensions Methods

The EnumExtensions type exposes the following members.

Methods
Name | Description
AxisToPlane | Returns plane normal to the input axis.
GetEnumByResourceValueT | Get enum value by string value representing value withing a ResourceSet lookup
GetFullNameT | Get enum full name
PlaneToAxis | Returns axis normal to the input plane.
ToDescriptionT | Get Enum description value
Top
See Also

Reference

EnumExtensions Class
Autodesk.Extensions Namespace


EnumExtensions.AxisToPlane Method

EnumExtensionsAxisToPlane Method

Returns plane normal to the input axis.

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Planes AxisToPlane(
    this Axes inputAxis
)
<ExtensionAttribute>
Public Shared Function AxisToPlane (
    inputAxis As Axes
) As Planes

Parameters

inputAxis
Type: AutodeskAxes
Axis against which to return the plane.

Return Value

Type: Planes
Plane normal to input axis.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Axes. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumExtensions Class
Autodesk.Extensions Namespace


EnumExtensions.GetEnumByResourceValue(T) Method

EnumExtensionsGetEnumByResourceValueT Method

Get enum value by string value representing value withing a ResourceSet lookup

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static T GetEnumByResourceValue<T>(
    string value,
    ResourceSet resourceSet
)
where T : struct, new()

Public Shared Function GetEnumByResourceValue(Of T As {Structure, New}) (
    value As String,
    resourceSet As ResourceSet
) As T

Parameters

value
Type: SystemString
a string value of Enum
resourceSet
Type: System.ResourcesResourceSet
lookup resources

Type Parameters

T
type of Enum

Return Value

Type: T
value of enum
Examples
Giving enumOfItems { FirstItem, SecondItem, LastItme } mapped to keys of resourceSet { ("FirstItem","First value"), ("SecondItem","Second value"), ("LastItem","Last value") } and if you need to find an enum of value = "Second value" this will return enumOfItems.SecondItem
See Also

Reference

EnumExtensions Class
Autodesk.Extensions Namespace


EnumExtensions.GetFullName(T) Method

EnumExtensionsGetFullNameT Method

Get enum full name

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string GetFullName<T>(
    T value
)
where T : struct, new()

Public Shared Function GetFullName(Of T As {Structure, New}) (
    value As T
) As String

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:Autodesk.Extensions.EnumExtensions.GetFullName``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Autodesk.Extensions.EnumExtensions.GetFullName``1(``0)"]

Return Value

Type: String
Examples
enum Colors{ Red, Yellow } GetFullName(Colors.Red) --> "ColorsRed";
See Also

Reference

EnumExtensions Class
Autodesk.Extensions Namespace


EnumExtensions.PlaneToAxis Method

EnumExtensionsPlaneToAxis Method

Returns axis normal to the input plane.

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Axes PlaneToAxis(
    this Planes inputPlane
)
<ExtensionAttribute>
Public Shared Function PlaneToAxis (
    inputPlane As Planes
) As Axes

Parameters

inputPlane
Type: AutodeskPlanes
Plane against which to return the axis.

Return Value

Type: Axes
Axis normal to input plane.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Planes. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumExtensions Class
Autodesk.Extensions Namespace


EnumExtensions.ToDescription(T) Method

EnumExtensionsToDescriptionT Method

Get Enum description value

Namespace: Autodesk.Extensions
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string ToDescription<T>(
    T value
)
where T : struct, new()

Public Shared Function ToDescription(Of T As {Structure, New}) (
    value As T
) As String

Parameters

value
Type: T
enum value

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Autodesk.Extensions.EnumExtensions.ToDescription``1(``0)"]

Return Value

Type: String
description value
See Also

Reference

EnumExtensions Class
Autodesk.Extensions Namespace


Autodesk.FileSystem Namespace

Classes
 | Class | Description
Public class | BinaryFileReader | Provides a simplified interface for reading binary data from file.
Public class | BinaryFileWriter | Provides a simplified interface for writing binary data to file.
Public class | Directory | Simplifies certain operations on file system directories.
Public class | DirectoryWatcher | Monitors directories and raises events when files are created, modified or deleted.
Public class | File | Provides a thin wrapper around System.IO File to simplify certain operations.
Public class | FileWatcher | Monitors a single file and raises events when it is modified.
Public class | Watcher | Abstract class on which are built the Delcam directory and file watcher classes. Regularly checks the specified directory and raises a notification event should it no longer exist.
Public class | WatcherEventArgs | Encapsulates arguments pertinent to the Watcher class.
Delegates
 | Delegate | Description
Public delegate | DirectoryWatcherFileDeletedHandle | Use this as the prototype to handle the FileDeleted event fired by this class.
Public delegate | DirectoryWatcherFileEventHandler | Use this as the prototype to handle the FileCreated event fired by this class.
Public delegate | WatcherDirectoryUnavailableHandler | Use this as the prototype to handle the DirectoryUnavailable event fired by this class.


BinaryFileReader Class

Provides a simplified interface for reading binary data from file.
Inheritance Hierarchy
SystemObject
Autodesk.FileSystemBinaryFileReader

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class BinaryFileReader
Public Class BinaryFileReader

The BinaryFileReader type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryFileReader(Byte) | Constructs a BinaryFileReader object.
Public method | BinaryFileReader(File) | Constructs a BinaryFileReader object.
Top
Methods
 | Name | Description
Public method | Close | Close the file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadByte | Reads a single byte from the binary stream and advances the file pointer to the next byte.
Public method | ReadBytes | Reads from the stream a byte array of the specified length and advances the file pointer to the next position after. If the end of file marker is reached then the number of bytes returned will be less than that requested.
Public method | ReadDouble | Reads an eight byte (double precision) floating point value from the binary stream.
Public method | ReadInteger | Reads a 32 bit integer from the binary stream.
Public method | ReadShort | Reads a 16 bit signed integer from the binary stream.
Public method | ReadSingle | Reads a four byte (single precision) floating point value from the binary stream.
Public method | ReadString | Reads a string from the stream of the specified length.
Public method | ReadStringUntil(Byte, Int32) | Reads a string of ASCII text from the stream until the specified terminating character is encountered or the maximum specified string length is reached. The terminating character is NOT included in the returned string.
Public method | ReadStringUntil(Byte, Int32, Boolean) | Reads a string of ASCII text from the stream until the specified terminating character is encountered or the maximum specified string length is reached. The terminating character can optionally be included in the return string.
Public method | ReadUInt16 | Reads an unsigned, 16 bit integer from the binary stream (Same as ReadUShort).
Public method | ReadUInteger | Reads an unsigned 32 bit integer from the binary stream.
Public method | ReadUShort | Reads an unsigned short integer from the binary stream (Same as ReadUInt16).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.FileSystem Namespace


BinaryFileReader Constructor

Overload List
 | Name | Description
Public method | BinaryFileReader(Byte) | Constructs a BinaryFileReader object.
Public method | BinaryFileReader(File) | Constructs a BinaryFileReader object.
Top
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader Constructor (Byte[])

BinaryFileReader Constructor (Byte)

Constructs a BinaryFileReader object.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BinaryFileReader(
    byte[] bytes
)
Public Sub New (
    bytes As Byte()
)

Parameters

bytes
Type: SystemByte
Byte array around which to create the binary reader.
See Also

Reference

BinaryFileReader Class
BinaryFileReader Overload
Autodesk.FileSystem Namespace


BinaryFileReader Constructor (File)

Constructs a BinaryFileReader object.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BinaryFileReader(
    File file
)
Public Sub New (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
File around which to create the binary reader.
See Also

Reference

BinaryFileReader Class
BinaryFileReader Overload
Autodesk.FileSystem Namespace


BinaryFileReader Methods

The BinaryFileReader type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close the file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadByte | Reads a single byte from the binary stream and advances the file pointer to the next byte.
Public method | ReadBytes | Reads from the stream a byte array of the specified length and advances the file pointer to the next position after. If the end of file marker is reached then the number of bytes returned will be less than that requested.
Public method | ReadDouble | Reads an eight byte (double precision) floating point value from the binary stream.
Public method | ReadInteger | Reads a 32 bit integer from the binary stream.
Public method | ReadShort | Reads a 16 bit signed integer from the binary stream.
Public method | ReadSingle | Reads a four byte (single precision) floating point value from the binary stream.
Public method | ReadString | Reads a string from the stream of the specified length.
Public method | ReadStringUntil(Byte, Int32) | Reads a string of ASCII text from the stream until the specified terminating character is encountered or the maximum specified string length is reached. The terminating character is NOT included in the returned string.
Public method | ReadStringUntil(Byte, Int32, Boolean) | Reads a string of ASCII text from the stream until the specified terminating character is encountered or the maximum specified string length is reached. The terminating character can optionally be included in the return string.
Public method | ReadUInt16 | Reads an unsigned, 16 bit integer from the binary stream (Same as ReadUShort).
Public method | ReadUInteger | Reads an unsigned 32 bit integer from the binary stream.
Public method | ReadUShort | Reads an unsigned short integer from the binary stream (Same as ReadUInt16).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.Close Method

BinaryFileReaderClose Method

Close the file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadByte Method

BinaryFileReaderReadByte Method

Reads a single byte from the binary stream and advances the file pointer to the next byte.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public byte ReadByte()
Public Function ReadByte As Byte

Return Value

Type: Byte
Byte read.
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadBytes Method

BinaryFileReaderReadBytes Method

Reads from the stream a byte array of the specified length and advances the file pointer to the next position after. If the end of file marker is reached then the number of bytes returned will be less than that requested.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public byte[] ReadBytes(
    int count
)
Public Function ReadBytes (
    count As Integer
) As Byte()

Parameters

count
Type: SystemInt32
Number of bytes to read.

Return Value

Type: Byte
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadDouble Method

BinaryFileReaderReadDouble Method

Reads an eight byte (double precision) floating point value from the binary stream.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double ReadDouble()
Public Function ReadDouble As Double

Return Value

Type: Double
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadInteger Method

BinaryFileReaderReadInteger Method

Reads a 32 bit integer from the binary stream.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int ReadInteger()
Public Function ReadInteger As Integer

Return Value

Type: Int32
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadShort Method

BinaryFileReaderReadShort Method

Reads a 16 bit signed integer from the binary stream.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public short ReadShort()
Public Function ReadShort As Short

Return Value

Type: Int16
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadSingle Method

BinaryFileReaderReadSingle Method

Reads a four byte (single precision) floating point value from the binary stream.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public float ReadSingle()
Public Function ReadSingle As Single

Return Value

Type: Single
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadString Method

BinaryFileReaderReadString Method

Reads a string from the stream of the specified length.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ReadString(
    int length
)
Public Function ReadString (
    length As Integer
) As String

Parameters

length
Type: SystemInt32
String length in bytes (ASCII characters).

Return Value

Type: String
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadStringUntil Method

BinaryFileReaderReadStringUntil Method

Overload List
 | Name | Description
Public method | ReadStringUntil(Byte, Int32) | Reads a string of ASCII text from the stream until the specified terminating character is encountered or the maximum specified string length is reached. The terminating character is NOT included in the returned string.
Public method | ReadStringUntil(Byte, Int32, Boolean) | Reads a string of ASCII text from the stream until the specified terminating character is encountered or the maximum specified string length is reached. The terminating character can optionally be included in the return string.
Top
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadStringUntil Method (Byte, Int32)

BinaryFileReaderReadStringUntil Method (Byte, Int32)

Reads a string of ASCII text from the stream until the specified terminating character is encountered or the maximum specified string length is reached. The terminating character is NOT included in the returned string.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ReadStringUntil(
    byte terminator,
    int maximumLength
)
Public Function ReadStringUntil (
    terminator As Byte,
    maximumLength As Integer
) As String

Parameters

terminator
Type: SystemByte
Byte containing character to break on.
maximumLength
Type: SystemInt32
Maximum permissible string length.

Return Value

Type: String
String of ASCII characters.
See Also

Reference

BinaryFileReader Class
ReadStringUntil Overload
Autodesk.FileSystem Namespace


BinaryFileReader.ReadStringUntil Method (Byte, Int32, Boolean)

BinaryFileReaderReadStringUntil Method (Byte, Int32, Boolean)

Reads a string of ASCII text from the stream until the specified terminating character is encountered or the maximum specified string length is reached. The terminating character can optionally be included in the return string.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ReadStringUntil(
    byte terminator,
    int maximumLength,
    bool includeTerminator
)
Public Function ReadStringUntil (
    terminator As Byte,
    maximumLength As Integer,
    includeTerminator As Boolean
) As String

Parameters

terminator
Type: SystemByte
Byte containing character to break on.
maximumLength
Type: SystemInt32
Maximum permissible string length.
includeTerminator
Type: SystemBoolean
Includes terminating character in return string if True.

Return Value

Type: String
String of ASCII characters.
See Also

Reference

BinaryFileReader Class
ReadStringUntil Overload
Autodesk.FileSystem Namespace


BinaryFileReader.ReadUInt16 Method

BinaryFileReaderReadUInt16 Method

Reads an unsigned, 16 bit integer from the binary stream (Same as ReadUShort).

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ushort ReadUInt16()
Public Function ReadUInt16 As UShort

Return Value

Type: UInt16
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadUInteger Method

BinaryFileReaderReadUInteger Method

Reads an unsigned 32 bit integer from the binary stream.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public uint ReadUInteger()
Public Function ReadUInteger As UInteger

Return Value

Type: UInt32
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileReader.ReadUShort Method

BinaryFileReaderReadUShort Method

Reads an unsigned short integer from the binary stream (Same as ReadUInt16).

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ushort ReadUShort()
Public Function ReadUShort As UShort

Return Value

Type: UInt16
See Also

Reference

BinaryFileReader Class
Autodesk.FileSystem Namespace


BinaryFileWriter Class

Provides a simplified interface for writing binary data to file.
Inheritance Hierarchy
SystemObject
Autodesk.FileSystemBinaryFileWriter

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class BinaryFileWriter
Public Class BinaryFileWriter

The BinaryFileWriter type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryFileWriter(File) | Constructs a BinaryFileWriter object.
Public method | BinaryFileWriter(File, Encoding) | Constructs a BinaryFileWriter object.
Top
Methods
 | Name | Description
Public method | Close | Closes the file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte to file.
Public method | WriteBytes | Writes a byte array to file.
Public method | WriteDouble | Write an eight byte (double precision) floating point number to file.
Public method | WriteInteger | Write a signed 32 bit integer to file.
Public method | WriteShort | Writes a signed 16 bit integer to file.
Public method | WriteSingle | Write a four byte (single precision) floating point number to file.
Public method | WriteString | Writes string to file .
Public method | WriteUInt16 | Writes an unsigned 16 bit integer to file (same as WriteUShort).
Public method | WriteUInt32 | Write an unsigned 32 bit integer to file.
Public method | WriteUInteger | Writes an unsigned 32 bit integer to file.
Public method | WriteUShort | Writes a 16 bit unsigned integer to file (same as WriteUInt16).
Top
See Also

Reference

Autodesk.FileSystem Namespace


BinaryFileWriter Constructor

Overload List
 | Name | Description
Public method | BinaryFileWriter(File) | Constructs a BinaryFileWriter object.
Public method | BinaryFileWriter(File, Encoding) | Constructs a BinaryFileWriter object.
Top
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter Constructor (File)

Constructs a BinaryFileWriter object.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BinaryFileWriter(
    File file
)
Public Sub New (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
File around which to create the writer.
See Also

Reference

BinaryFileWriter Class
BinaryFileWriter Overload
Autodesk.FileSystem Namespace


BinaryFileWriter Constructor (File, Encoding)

Constructs a BinaryFileWriter object.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BinaryFileWriter(
    File file,
    Encoding encoding
)
Public Sub New (
    file As File,
    encoding As Encoding
)

Parameters

file
Type: Autodesk.FileSystemFile
File around which to create the writer.
encoding
Type: System.TextEncoding
Character encoding to use when writing to file.
See Also

Reference

BinaryFileWriter Class
BinaryFileWriter Overload
Autodesk.FileSystem Namespace


BinaryFileWriter Methods

The BinaryFileWriter type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteByte | Writes a single byte to file.
Public method | WriteBytes | Writes a byte array to file.
Public method | WriteDouble | Write an eight byte (double precision) floating point number to file.
Public method | WriteInteger | Write a signed 32 bit integer to file.
Public method | WriteShort | Writes a signed 16 bit integer to file.
Public method | WriteSingle | Write a four byte (single precision) floating point number to file.
Public method | WriteString | Writes string to file .
Public method | WriteUInt16 | Writes an unsigned 16 bit integer to file (same as WriteUShort).
Public method | WriteUInt32 | Write an unsigned 32 bit integer to file.
Public method | WriteUInteger | Writes an unsigned 32 bit integer to file.
Public method | WriteUShort | Writes a 16 bit unsigned integer to file (same as WriteUInt16).
Top
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.Close Method

BinaryFileWriterClose Method

Closes the file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteByte Method

BinaryFileWriterWriteByte Method

Writes a single byte to file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteByte(
    byte value
)
Public Sub WriteByte (
    value As Byte
)

Parameters

value
Type: SystemByte
The byte value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteBytes Method

BinaryFileWriterWriteBytes Method

Writes a byte array to file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteBytes(
    byte[] value
)
Public Sub WriteBytes (
    value As Byte()
)

Parameters

value
Type: SystemByte
Array to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteDouble Method

BinaryFileWriterWriteDouble Method

Write an eight byte (double precision) floating point number to file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteDouble(
    double value
)
Public Sub WriteDouble (
    value As Double
)

Parameters

value
Type: SystemDouble
Value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteInteger Method

BinaryFileWriterWriteInteger Method

Write a signed 32 bit integer to file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteInteger(
    int value
)
Public Sub WriteInteger (
    value As Integer
)

Parameters

value
Type: SystemInt32
Value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteShort Method

BinaryFileWriterWriteShort Method

Writes a signed 16 bit integer to file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteShort(
    short value
)
Public Sub WriteShort (
    value As Short
)

Parameters

value
Type: SystemInt16
Value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteSingle Method

BinaryFileWriterWriteSingle Method

Write a four byte (single precision) floating point number to file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteSingle(
    float value
)
Public Sub WriteSingle (
    value As Single
)

Parameters

value
Type: SystemSingle
Value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteString Method

BinaryFileWriterWriteString Method

Writes string to file .

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteString(
    string value
)
Public Sub WriteString (
    value As String
)

Parameters

value
Type: SystemString
String to be written.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteUInt16 Method

BinaryFileWriterWriteUInt16 Method

Writes an unsigned 16 bit integer to file (same as WriteUShort).

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteUInt16(
    ushort value
)
Public Sub WriteUInt16 (
    value As UShort
)

Parameters

value
Type: SystemUInt16
Value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteUInt32 Method

BinaryFileWriterWriteUInt32 Method

Write an unsigned 32 bit integer to file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteUInt32(
    uint value
)
Public Sub WriteUInt32 (
    value As UInteger
)

Parameters

value
Type: SystemUInt32
Value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteUInteger Method

BinaryFileWriterWriteUInteger Method

Writes an unsigned 32 bit integer to file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteUInteger(
    uint value
)
Public Sub WriteUInteger (
    value As UInteger
)

Parameters

value
Type: SystemUInt32
Value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


BinaryFileWriter.WriteUShort Method

BinaryFileWriterWriteUShort Method

Writes a 16 bit unsigned integer to file (same as WriteUInt16).

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteUShort(
    ushort value
)
Public Sub WriteUShort (
    value As UShort
)

Parameters

value
Type: SystemUInt16
Value to write.
See Also

Reference

BinaryFileWriter Class
Autodesk.FileSystem Namespace


Directory Class

Simplifies certain operations on file system directories.
Inheritance Hierarchy
SystemObject
Autodesk.FileSystemDirectory

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Directory
<SerializableAttribute>
Public Class Directory

The Directory type exposes the following members.

Constructors
 | Name | Description
Public method | Directory(String) | Creates a new Directory object.
Public method | Directory(Directory, String) | Creates a new Directory object with a path relative to the specified parent.
Top
Properties
 | Name | Description
Public property | Directories | List of directories contained within this directory.
Public property | Exists | True if directory exists, false otherwise.
Public property | Files | List of files contained within this directory.
Public property | IsEmpty | True if directory is empty, false otherwise.
Public property | Name | Directory name.
Public property | ParentDirectory | Parent directory of this directory object.
Public property | Path | Directory path.
Top
Methods
 | Name | Description
Public method | Copy | Copies the directory and its contents to the specified path, overwriting all files with the same names.
Public method | CopyToNewParent | Copy directory and its contents to the specified new parent, overwriting all files with the same names.
Public method | Create | Create the directory
 | CreateTemporaryDirectory | Creates a new logical temporary Directory object within the temp folder of the logged in user and, optionally, creates the directory on disk. The directory is created with the name format TMP00000, thus providing a maximum upper limit of 99999 directories.
Public method | Delete | Delete this directory and all its contents from disk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the directory and its contents to a new path.
Public method | MoveToNewParent | Move directory to the new specified parent
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.FileSystem Namespace


Directory Constructor

Overload List
 | Name | Description
Public method | Directory(String) | Creates a new Directory object.
Public method | Directory(Directory, String) | Creates a new Directory object with a path relative to the specified parent.
Top
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory Constructor (String)

Creates a new Directory object.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Directory(
    string path
)
Public Sub New (
    path As String
)

Parameters

path
Type: SystemString
The directory path.
See Also

Reference

Directory Class
Directory Overload
Autodesk.FileSystem Namespace


Directory Constructor (Directory, String)

Creates a new Directory object with a path relative to the specified parent.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Directory(
    Directory parentDirectory,
    string directoryName
)
Public Sub New (
    parentDirectory As Directory,
    directoryName As String
)

Parameters

parentDirectory
Type: Autodesk.FileSystemDirectory
Parent directory of the new directory.
directoryName
Type: SystemString
Directory to add to Parent directory.
See Also

Reference

Directory Class
Directory Overload
Autodesk.FileSystem Namespace


Directory Properties

The Directory type exposes the following members.

Properties
 | Name | Description
Public property | Directories | List of directories contained within this directory.
Public property | Exists | True if directory exists, false otherwise.
Public property | Files | List of files contained within this directory.
Public property | IsEmpty | True if directory is empty, false otherwise.
Public property | Name | Directory name.
Public property | ParentDirectory | Parent directory of this directory object.
Public property | Path | Directory path.
Top
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Directories Property

DirectoryDirectories Property

List of directories contained within this directory.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Directory> Directories { get; }
Public ReadOnly Property Directories As List(Of Directory)
    Get

Property Value

Type: List Directory
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Exists Property

DirectoryExists Property

True if directory exists, false otherwise.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Files Property

DirectoryFiles Property

List of files contained within this directory.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<File> Files { get; }
Public ReadOnly Property Files As List(Of File)
    Get

Property Value

Type: List File
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.IsEmpty Property

DirectoryIsEmpty Property

True if directory is empty, false otherwise.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Name Property

DirectoryName Property

Directory name.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.ParentDirectory Property

DirectoryParentDirectory Property

Parent directory of this directory object.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Directory ParentDirectory { get; }
Public ReadOnly Property ParentDirectory As Directory
    Get

Property Value

Type: Directory
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Path Property

DirectoryPath Property

Directory path.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory Methods

The Directory type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Copies the directory and its contents to the specified path, overwriting all files with the same names.
Public method | CopyToNewParent | Copy directory and its contents to the specified new parent, overwriting all files with the same names.
Public method | Create | Create the directory
 | CreateTemporaryDirectory | Creates a new logical temporary Directory object within the temp folder of the logged in user and, optionally, creates the directory on disk. The directory is created with the name format TMP00000, thus providing a maximum upper limit of 99999 directories.
Public method | Delete | Delete this directory and all its contents from disk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the directory and its contents to a new path.
Public method | MoveToNewParent | Move directory to the new specified parent
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Copy Method

DirectoryCopy Method

Copies the directory and its contents to the specified path, overwriting all files with the same names.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Copy(
    Directory newPath
)
Public Sub Copy (
    newPath As Directory
)

Parameters

newPath
Type: Autodesk.FileSystemDirectory
Destination path.
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.CopyToNewParent Method

DirectoryCopyToNewParent Method

Copy directory and its contents to the specified new parent, overwriting all files with the same names.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CopyToNewParent(
    Directory newParentDirectory
)
Public Sub CopyToNewParent (
    newParentDirectory As Directory
)

Parameters

newParentDirectory
Type: Autodesk.FileSystemDirectory
Destination directory.
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Create Method

DirectoryCreate Method

Create the directory

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Create()
Public Sub Create
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.CreateTemporaryDirectory Method

DirectoryCreateTemporaryDirectory Method

Creates a new logical temporary Directory object within the temp folder of the logged in user and, optionally, creates the directory on disk. The directory is created with the name format TMP00000, thus providing a maximum upper limit of 99999 directories.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Directory CreateTemporaryDirectory(
    bool createFolder = false
)
Public Shared Function CreateTemporaryDirectory (
    Optional createFolder As Boolean = false
) As Directory

Parameters

createFolder (Optional)
Type: SystemBoolean
If True, the directory is created on disk.

Return Value

Type: Directory
Directory
Exceptions
Exception | Condition
Exception | Limit of temporary directory names exceeded.
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Delete Method

DirectoryDelete Method

Delete this directory and all its contents from disk.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Delete()
Public Sub Delete
Exceptions
Exception | Condition
IOException | Please refer to the System.IO.Directory Delete method.
UnauthorizedAccessException | Please refer to the System.IO.Directory Delete method.
DirectoryNotFoundException | Please refer to the System.IO.Directory Delete method.
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.Move Method

DirectoryMove Method

Moves the directory and its contents to a new path.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Move(
    Directory newPath
)
Public Sub Move (
    newPath As Directory
)

Parameters

newPath
Type: Autodesk.FileSystemDirectory
New directory path.
Exceptions
Exception | Condition
Exception | The new path already exists.
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


Directory.MoveToNewParent Method

DirectoryMoveToNewParent Method

Move directory to the new specified parent

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MoveToNewParent(
    Directory newParentDirectory
)
Public Sub MoveToNewParent (
    newParentDirectory As Directory
)

Parameters

newParentDirectory
Type: Autodesk.FileSystemDirectory
New parent directory.
Exceptions
Exception | Condition
Exception | The new parent exists already.
See Also

Reference

Directory Class
Autodesk.FileSystem Namespace


DirectoryWatcher Class

Monitors directories and raises events when files are created, modified or deleted.
Inheritance Hierarchy
SystemObject
Autodesk.FileSystemWatcher
Autodesk.FileSystemDirectoryWatcher

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class DirectoryWatcher : Watcher
Public Class DirectoryWatcher
    Inherits Watcher

The DirectoryWatcher type exposes the following members.

Constructors
 | Name | Description
Public method | DirectoryWatcher(Directory) | Constructs a DirectoryWatcher object about the directory specified in the single input argument.
Public method | DirectoryWatcher(Directory, String, Boolean) | Constructs a DirectoryWatcher object with options to monitor specific file types and sub-directories.
Top
Properties
 | Name | Description
Public property | DirectoryUnavailableTimerStatus | True if timer running; False otherwise. (Inherited from Watcher.)
Public property | EnableRaisingEvents | If True the raising of events is enabled; suppresed otherwise.
Top
Methods
 | Name | Description
Protected method | _watcher_Created | Raises FileCreated event.
Protected method | _watcher_Deleted | Raises FileDeleted event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DirectoryUnavailable | Occurs when the directory monitored by this object has been deleted. (Inherited from Watcher.)
Public event | FileCreated | Occurs when a file is created in the monitored directory.
Public event | FileDeleted | Occurs when a file is deleted from the monitored directory.
Top
Fields
 | Name | Description
Protected field | _watcher | System watcher object upon which this class leverages. (Inherited from Watcher.)
Top
See Also

Reference

Autodesk.FileSystem Namespace


DirectoryWatcher Constructor

Overload List
 | Name | Description
Public method | DirectoryWatcher(Directory) | Constructs a DirectoryWatcher object about the directory specified in the single input argument.
Public method | DirectoryWatcher(Directory, String, Boolean) | Constructs a DirectoryWatcher object with options to monitor specific file types and sub-directories.
Top
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher Constructor (Directory)

Constructs a DirectoryWatcher object about the directory specified in the single input argument.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DirectoryWatcher(
    Directory directoryToWatch
)
Public Sub New (
    directoryToWatch As Directory
)

Parameters

directoryToWatch
Type: Autodesk.FileSystemDirectory
Directory to monitor.
See Also

Reference

DirectoryWatcher Class
DirectoryWatcher Overload
Autodesk.FileSystem Namespace


DirectoryWatcher Constructor (Directory, String, Boolean)

Constructs a DirectoryWatcher object with options to monitor specific file types and sub-directories.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DirectoryWatcher(
    Directory directoryToWatch,
    string filter,
    bool watchSubdirectories
)
Public Sub New (
    directoryToWatch As Directory,
    filter As String,
    watchSubdirectories As Boolean
)

Parameters

directoryToWatch
Type: Autodesk.FileSystemDirectory
Directory to monitor.
filter
Type: SystemString
File types to monitor e.g. *.TXT.
watchSubdirectories
Type: SystemBoolean
If True, subdirectories are also monitored.
See Also

Reference

DirectoryWatcher Class
DirectoryWatcher Overload
Autodesk.FileSystem Namespace


DirectoryWatcher Properties

The DirectoryWatcher type exposes the following members.

Properties
 | Name | Description
Public property | DirectoryUnavailableTimerStatus | True if timer running; False otherwise. (Inherited from Watcher.)
Public property | EnableRaisingEvents | If True the raising of events is enabled; suppresed otherwise.
Top
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher.EnableRaisingEvents Property

DirectoryWatcherEnableRaisingEvents Property

If True the raising of events is enabled; suppresed otherwise.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool EnableRaisingEvents { get; set; }
Public Property EnableRaisingEvents As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher Methods

The DirectoryWatcher type exposes the following members.

Methods
 | Name | Description
Protected method | _watcher_Created | Raises FileCreated event.
Protected method | _watcher_Deleted | Raises FileDeleted event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher._watcher_Created Method

DirectoryWatcher_watcher_Created Method

Raises FileCreated event.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void _watcher_Created(
    Object sender,
    FileSystemEventArgs e
)
Protected Sub _watcher_Created (
    sender As Object,
    e As FileSystemEventArgs
)

Parameters

sender
Type: SystemObject
Object raising event i.e. this.
e
Type: System.IOFileSystemEventArgs
Arguments pertinent to this event.
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher._watcher_Deleted Method

DirectoryWatcher_watcher_Deleted Method

Raises FileDeleted event.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void _watcher_Deleted(
    Object sender,
    FileSystemEventArgs e
)
Protected Sub _watcher_Deleted (
    sender As Object,
    e As FileSystemEventArgs
)

Parameters

sender
Type: SystemObject
Object raising event i.e. this.
e
Type: System.IOFileSystemEventArgs
Arguments pertinent to this event.
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher Events

The DirectoryWatcher type exposes the following members.

Events
 | Name | Description
Public event | DirectoryUnavailable | Occurs when the directory monitored by this object has been deleted. (Inherited from Watcher.)
Public event | FileCreated | Occurs when a file is created in the monitored directory.
Public event | FileDeleted | Occurs when a file is deleted from the monitored directory.
Top
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher.FileCreated Event

DirectoryWatcherFileCreated Event

Occurs when a file is created in the monitored directory.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public event DirectoryWatcherFileEventHandler FileCreated
Public Event FileCreated As DirectoryWatcherFileEventHandler

Value

Type: Autodesk.FileSystemDirectoryWatcherFileEventHandler
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher.FileDeleted Event

DirectoryWatcherFileDeleted Event

Occurs when a file is deleted from the monitored directory.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public event DirectoryWatcherFileDeletedHandle FileDeleted
Public Event FileDeleted As DirectoryWatcherFileDeletedHandle

Value

Type: Autodesk.FileSystemDirectoryWatcherFileDeletedHandle
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher Fields

The DirectoryWatcher type exposes the following members.

Fields
 | Name | Description
Protected field | _watcher | System watcher object upon which this class leverages. (Inherited from Watcher.)
Top
See Also

Reference

DirectoryWatcher Class
Autodesk.FileSystem Namespace


DirectoryWatcher.FileDeletedHandle Delegate

DirectoryWatcherFileDeletedHandle Delegate

Use this as the prototype to handle the FileDeleted event fired by this class.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public delegate void FileDeletedHandle(
    Object sender,
    FileSystemEventArgs e
)
Public Delegate Sub FileDeletedHandle (
    sender As Object,
    e As FileSystemEventArgs
)

Parameters

sender
Type: SystemObject
Sender of this event.
e
Type: System.IOFileSystemEventArgs
Encapsulates arguments pertinent to this event.
See Also

Reference

Autodesk.FileSystem Namespace


DirectoryWatcher.FileEventHandler Delegate

DirectoryWatcherFileEventHandler Delegate

Use this as the prototype to handle the FileCreated event fired by this class.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public delegate void FileEventHandler(
    Object sender,
    FileSystemEventArgs e
)
Public Delegate Sub FileEventHandler (
    sender As Object,
    e As FileSystemEventArgs
)

Parameters

sender
Type: SystemObject
Sender of this event.
e
Type: System.IOFileSystemEventArgs
Encapsulates arguments pertinent to this event.
See Also

Reference

Autodesk.FileSystem Namespace


File Class

Provides a thin wrapper around System.IO File to simplify certain operations.
Inheritance Hierarchy
SystemObject
Autodesk.FileSystemFile
Autodesk.GeometryMSRFile

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class File
<SerializableAttribute>
Public Class File

The File type exposes the following members.

Constructors
 | Name | Description
Public method | File(String) | Creates a new File object for the specified path. Note: the file is not created on disk at this point.
Public method | File(Directory, String) | Creates a new File object with path specified by the parentDirectory argument and filename specified in the string argument. NOTE: the file is not created on disk at this point.
Top
Properties
 | Name | Description
Public property | Exists | True if the file exists.
Public property | Extension | File extension (without the '.').
Public property | LastChangedDate | Date the file was last modifed.
Public property | Name | Filename.
Public property | NameWithoutExtension | Filename without extension.
Public property | ParentDirectory | File's parent Directory object..
Public property | Path | Full path to the file.
Top
Methods
 | Name | Description
Public method | Copy | Copy the file to a new filepath. If a file with the same name and path already exists, it will be overwritten.
Public method | CopyToDirectory | Copies the file to the specified new parent directory. If a file with the same name already exists, it will be overwritten.
Public method | Create | Create the file if it does not already exist.
 | CreateTemporaryFile | Creates a new File object representing a temporary file (i.e. in the user's temporary file folder) and with the specified extension. The file will, optionally, be created on disk.
Public method | Delete | Delete the file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Move File to new path
Public method | MoveToDirectory | Moves file to a new directory.
Public method | ReadFirstLine | Returns the text of the first line of the file using UTF8 encoding.
Public method | ReadText | Returns Entire file contents using UTF8 encoding.
Public method | ReadText(Encoding) | Returns entire file contents using the encoding passed in the single input argument.
Public method | ReadTextLines | Returns file contents as a list of strings using UTF8 encoding. Each string represents a seperate line of text in the file.
Public method | ReadTextLines(Encoding) | Returns file contents as a list of strings using the encoding specified in the single input argument. Each string represents a seperate line of text in the file.
Public method | Rename | Renames file within the current directory.
Public method | ToString | Overrides ToString method. Returns full path to this file. (Overrides ObjectToString.)
Public method | WriteText(String) | Writes a string of text to file using UTF8 encoding.
Public method | WriteText(String, Boolean) | Writes a string of text to file using UTF8 encoding.
Public method | WriteText(String, Boolean, Encoding) | Writes a string of text to file using the specified encoding.
Public method | WriteTextLine | Writes a single line of text to file using the specified encoding.
Public method | WriteTextLines | Writes to file all lines of text encapsulated within the passed array of strings.
Top
See Also

Reference

Autodesk.FileSystem Namespace


File Constructor

Overload List
 | Name | Description
Public method | File(String) | Creates a new File object for the specified path. Note: the file is not created on disk at this point.
Public method | File(Directory, String) | Creates a new File object with path specified by the parentDirectory argument and filename specified in the string argument. NOTE: the file is not created on disk at this point.
Top
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File Constructor (String)

Creates a new File object for the specified path. Note: the file is not created on disk at this point.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public File(
    string filePath
)
Public Sub New (
    filePath As String
)

Parameters

filePath
Type: SystemString
Fully qualified path to the destination file.
Exceptions
Exception | Condition
ArgumentNullException | Results from a null or empty filePath argument.
ArgumentException | No containing folder: only a file name is specified in the filePath argument.
See Also

Reference

File Class
File Overload
Autodesk.FileSystem Namespace


File Constructor (Directory, String)

Creates a new File object with path specified by the parentDirectory argument and filename specified in the string argument. NOTE: the file is not created on disk at this point.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public File(
    Directory parentDirectory,
    string fileName
)
Public Sub New (
    parentDirectory As Directory,
    fileName As String
)

Parameters

parentDirectory
Type: Autodesk.FileSystemDirectory
Parent directory of the file.
fileName
Type: SystemString
Name of the file.
Exceptions
Exception | Condition
Exception | Results from a null or empty fileName argument.
See Also

Reference

File Class
File Overload
Autodesk.FileSystem Namespace


File Properties

The File type exposes the following members.

Properties
 | Name | Description
Public property | Exists | True if the file exists.
Public property | Extension | File extension (without the '.').
Public property | LastChangedDate | Date the file was last modifed.
Public property | Name | Filename.
Public property | NameWithoutExtension | Filename without extension.
Public property | ParentDirectory | File's parent Directory object..
Public property | Path | Full path to the file.
Top
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.Exists Property

FileExists Property

True if the file exists.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.Extension Property

FileExtension Property

File extension (without the '.').

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Extension { get; }
Public ReadOnly Property Extension As String
    Get

Property Value

Type: String
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.LastChangedDate Property

FileLastChangedDate Property

Date the file was last modifed.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DateTime LastChangedDate { get; }
Public ReadOnly Property LastChangedDate As DateTime
    Get

Property Value

Type: DateTime
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.Name Property

FileName Property

Filename.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.NameWithoutExtension Property

FileNameWithoutExtension Property

Filename without extension.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string NameWithoutExtension { get; }
Public ReadOnly Property NameWithoutExtension As String
    Get

Property Value

Type: String
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.ParentDirectory Property

FileParentDirectory Property

File's parent Directory object..

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Directory ParentDirectory { get; }
Public ReadOnly Property ParentDirectory As Directory
    Get

Property Value

Type: Directory
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.Path Property

FilePath Property

Full path to the file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File Methods

The File type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Copy the file to a new filepath. If a file with the same name and path already exists, it will be overwritten.
Public method | CopyToDirectory | Copies the file to the specified new parent directory. If a file with the same name already exists, it will be overwritten.
Public method | Create | Create the file if it does not already exist.
 | CreateTemporaryFile | Creates a new File object representing a temporary file (i.e. in the user's temporary file folder) and with the specified extension. The file will, optionally, be created on disk.
Public method | Delete | Delete the file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Move File to new path
Public method | MoveToDirectory | Moves file to a new directory.
Public method | ReadFirstLine | Returns the text of the first line of the file using UTF8 encoding.
Public method | ReadText | Returns Entire file contents using UTF8 encoding.
Public method | ReadText(Encoding) | Returns entire file contents using the encoding passed in the single input argument.
Public method | ReadTextLines | Returns file contents as a list of strings using UTF8 encoding. Each string represents a seperate line of text in the file.
Public method | ReadTextLines(Encoding) | Returns file contents as a list of strings using the encoding specified in the single input argument. Each string represents a seperate line of text in the file.
Public method | Rename | Renames file within the current directory.
Public method | ToString | Overrides ToString method. Returns full path to this file. (Overrides ObjectToString.)
Public method | WriteText(String) | Writes a string of text to file using UTF8 encoding.
Public method | WriteText(String, Boolean) | Writes a string of text to file using UTF8 encoding.
Public method | WriteText(String, Boolean, Encoding) | Writes a string of text to file using the specified encoding.
Public method | WriteTextLine | Writes a single line of text to file using the specified encoding.
Public method | WriteTextLines | Writes to file all lines of text encapsulated within the passed array of strings.
Top
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.Copy Method

FileCopy Method

Copy the file to a new filepath. If a file with the same name and path already exists, it will be overwritten.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Copy(
    File destination
)
Public Sub Copy (
    destination As File
)

Parameters

destination
Type: Autodesk.FileSystemFile
File object representing new path and filename.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.CopyToDirectory Method

FileCopyToDirectory Method

Copies the file to the specified new parent directory. If a file with the same name already exists, it will be overwritten.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CopyToDirectory(
    Directory newParentDirectory
)
Public Sub CopyToDirectory (
    newParentDirectory As Directory
)

Parameters

newParentDirectory
Type: Autodesk.FileSystemDirectory
Directory to which the file is to be copied.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.Create Method

FileCreate Method

Create the file if it does not already exist.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Create()
Public Sub Create
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.CreateTemporaryFile Method

FileCreateTemporaryFile Method

Creates a new File object representing a temporary file (i.e. in the user's temporary file folder) and with the specified extension. The file will, optionally, be created on disk.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static File CreateTemporaryFile(
    string extension,
    bool createFile = false
)
Public Shared Function CreateTemporaryFile (
    extension As String,
    Optional createFile As Boolean = false
) As File

Parameters

extension
Type: SystemString
File extension.
createFile (Optional)
Type: SystemBoolean
If True, a zero-byte file is created on disk.

Return Value

Type: File
DelcamFile
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.Delete Method

FileDelete Method

Delete the file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Delete()
Public Sub Delete
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.Move Method

FileMove Method

Move File to new path

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Move(
    File newFile
)
Public Sub Move (
    newFile As File
)

Parameters

newFile
Type: Autodesk.FileSystemFile
File object representing new path.
Exceptions
Exception | Condition
IOException | Thrown if file already exists in destination path.
UnauthorizedAccessException | Caller does not possess the required permission.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.MoveToDirectory Method

FileMoveToDirectory Method

Moves file to a new directory.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MoveToDirectory(
    Directory newDirectory
)
Public Sub MoveToDirectory (
    newDirectory As Directory
)

Parameters

newDirectory
Type: Autodesk.FileSystemDirectory
Target Directory.
Exceptions
Exception | Condition
IOException | Thrown if file already exists in destination path.
UnauthorizedAccessException | Caller does not possess the required permission.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.ReadFirstLine Method

FileReadFirstLine Method

Returns the text of the first line of the file using UTF8 encoding.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ReadFirstLine()
Public Function ReadFirstLine As String

Return Value

Type: String
The first line of the file.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.ReadText Method

FileReadText Method

Overload List
 | Name | Description
Public method | ReadText | Returns Entire file contents using UTF8 encoding.
Public method | ReadText(Encoding) | Returns entire file contents using the encoding passed in the single input argument.
Top
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.ReadText Method

FileReadText Method

Returns Entire file contents using UTF8 encoding.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ReadText()
Public Function ReadText As String

Return Value

Type: String
String containing file contents.
See Also

Reference

File Class
ReadText Overload
Autodesk.FileSystem Namespace


File.ReadText Method (Encoding)

FileReadText Method (Encoding)

Returns entire file contents using the encoding passed in the single input argument.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ReadText(
    Encoding encoding
)
Public Function ReadText (
    encoding As Encoding
) As String

Parameters

encoding
Type: System.TextEncoding
System.Text.Encoding to use.

Return Value

Type: String
String containing file Contents.
See Also

Reference

File Class
ReadText Overload
Autodesk.FileSystem Namespace


File.ReadTextLines Method

FileReadTextLines Method

Overload List
 | Name | Description
Public method | ReadTextLines | Returns file contents as a list of strings using UTF8 encoding. Each string represents a seperate line of text in the file.
Public method | ReadTextLines(Encoding) | Returns file contents as a list of strings using the encoding specified in the single input argument. Each string represents a seperate line of text in the file.
Top
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.ReadTextLines Method

FileReadTextLines Method

Returns file contents as a list of strings using UTF8 encoding. Each string represents a seperate line of text in the file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<string> ReadTextLines()
Public Function ReadTextLines As List(Of String)

Return Value

Type: List String
List of strings.
See Also

Reference

File Class
ReadTextLines Overload
Autodesk.FileSystem Namespace


File.ReadTextLines Method (Encoding)

FileReadTextLines Method (Encoding)

Returns file contents as a list of strings using the encoding specified in the single input argument. Each string represents a seperate line of text in the file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<string> ReadTextLines(
    Encoding encoding
)
Public Function ReadTextLines (
    encoding As Encoding
) As List(Of String)

Parameters

encoding
Type: System.TextEncoding
System.Text.Encoding to use.

Return Value

Type: List String
List of strings
See Also

Reference

File Class
ReadTextLines Overload
Autodesk.FileSystem Namespace


File.Rename Method

FileRename Method

Renames file within the current directory.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Rename(
    string newFileName
)
Public Sub Rename (
    newFileName As String
)

Parameters

newFileName
Type: SystemString
New name of the file.
Exceptions
Exception | Condition
ArgumentException | Thrown if input argument is not a valid filename.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.ToString Method

FileToString Method

Overrides ToString method. Returns full path to this file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
Full path to file.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.WriteText Method

FileWriteText Method

Overload List
 | Name | Description
Public method | WriteText(String) | Writes a string of text to file using UTF8 encoding.
Public method | WriteText(String, Boolean) | Writes a string of text to file using UTF8 encoding.
Public method | WriteText(String, Boolean, Encoding) | Writes a string of text to file using the specified encoding.
Top
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.WriteText Method (String)

FileWriteText Method (String)

Writes a string of text to file using UTF8 encoding.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteText(
    string text
)
Public Sub WriteText (
    text As String
)

Parameters

text
Type: SystemString
String containing text to be written.
See Also

Reference

File Class
WriteText Overload
Autodesk.FileSystem Namespace


File.WriteText Method (String, Boolean)

FileWriteText Method (String, Boolean)

Writes a string of text to file using UTF8 encoding.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteText(
    string text,
    bool appendText
)
Public Sub WriteText (
    text As String,
    appendText As Boolean
)

Parameters

text
Type: SystemString
String containing text to be written.
appendText
Type: SystemBoolean
If True, text is appended to the file; otherwise the file will be overwritten.
See Also

Reference

File Class
WriteText Overload
Autodesk.FileSystem Namespace


File.WriteText Method (String, Boolean, Encoding)

FileWriteText Method (String, Boolean, Encoding)

Writes a string of text to file using the specified encoding.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteText(
    string text,
    bool appendText,
    Encoding encoding
)
Public Sub WriteText (
    text As String,
    appendText As Boolean,
    encoding As Encoding
)

Parameters

text
Type: SystemString
String containing text to be written.
appendText
Type: SystemBoolean
If True, text is appended to the file; otherwise the file will be overwritten.
encoding
Type: System.TextEncoding
System.Text.Encoding to use.
See Also

Reference

File Class
WriteText Overload
Autodesk.FileSystem Namespace


File.WriteTextLine Method

FileWriteTextLine Method

Writes a single line of text to file using the specified encoding.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteTextLine(
    string text,
    bool appendText,
    Encoding encoding
)
Public Sub WriteTextLine (
    text As String,
    appendText As Boolean,
    encoding As Encoding
)

Parameters

text
Type: SystemString
String containing text to be written.
appendText
Type: SystemBoolean
If True, text is appended to the file; otherwise the file will be overwritten.
encoding
Type: System.TextEncoding
System.Text.Encoding to use.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


File.WriteTextLines Method

FileWriteTextLines Method

Writes to file all lines of text encapsulated within the passed array of strings.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteTextLines(
    List<string> textLines,
    bool appendText = false,
    Encoding encoding = null
)
Public Sub WriteTextLines (
    textLines As List(Of String),
    Optional appendText As Boolean = false,
    Optional encoding As Encoding = Nothing
)

Parameters

textLines
Type: System.Collections.GenericList String
Lines of text to be written.
appendText (Optional)
Type: SystemBoolean
If True, text is appended to the file; otherwise the file will be overwritten.
encoding (Optional)
Type: System.TextEncoding
System.Text.Encoding to use.
See Also

Reference

File Class
Autodesk.FileSystem Namespace


FileWatcher Class

Monitors a single file and raises events when it is modified.
Inheritance Hierarchy
SystemObject
Autodesk.FileSystemWatcher
Autodesk.FileSystemFileWatcher

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class FileWatcher : Watcher
Public Class FileWatcher
    Inherits Watcher

The FileWatcher type exposes the following members.

Constructors
 | Name | Description
Public method | FileWatcher(String) | Constructs a watcher for the specified file.
Public method | FileWatcher(File) | Creates a watcher that will monitor all changes to the specified file.
Top
Properties
 | Name | Description
Public property | DirectoryUnavailableTimerStatus | True if timer running; False otherwise. (Inherited from Watcher.)
Top
Methods
 | Name | Description
Protected method | _watcher_Changed | Raises the FileChanged event.
Protected method | _watcher_Created | Raises the FileCreated event.
Protected method | _watcher_Deleted | Raises the FileDeleted event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DirectoryUnavailable | Occurs when the directory monitored by this object has been deleted. (Inherited from Watcher.)
Public event | FileChanged | Occurs when the file name is changed, the file is accessed or the file is written to.
Public event | FileCreated | Occurs when the file is created.
Public event | FileDeleted | Occurs when the file is deleted.
Top
Fields
 | Name | Description
Protected field | _watcher | System watcher object upon which this class leverages. (Inherited from Watcher.)
Top
See Also

Reference

Autodesk.FileSystem Namespace


FileWatcher Constructor

Overload List
 | Name | Description
Public method | FileWatcher(String) | Constructs a watcher for the specified file.
Public method | FileWatcher(File) | Creates a watcher that will monitor all changes to the specified file.
Top
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher Constructor (String)

Constructs a watcher for the specified file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public FileWatcher(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
File to monitor.
See Also

Reference

FileWatcher Class
FileWatcher Overload
Autodesk.FileSystem Namespace


FileWatcher Constructor (File)

Creates a watcher that will monitor all changes to the specified file.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public FileWatcher(
    File fileIn
)
Public Sub New (
    fileIn As File
)

Parameters

fileIn
Type: Autodesk.FileSystemFile
DelcamFile to watch
See Also

Reference

FileWatcher Class
FileWatcher Overload
Autodesk.FileSystem Namespace


FileWatcher Properties

The FileWatcher type exposes the following members.

Properties
 | Name | Description
Public property | DirectoryUnavailableTimerStatus | True if timer running; False otherwise. (Inherited from Watcher.)
Top
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher Methods

The FileWatcher type exposes the following members.

Methods
 | Name | Description
Protected method | _watcher_Changed | Raises the FileChanged event.
Protected method | _watcher_Created | Raises the FileCreated event.
Protected method | _watcher_Deleted | Raises the FileDeleted event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher._watcher_Changed Method

FileWatcher_watcher_Changed Method

Raises the FileChanged event.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void _watcher_Changed(
    Object sender,
    FileSystemEventArgs e
)
Protected Sub _watcher_Changed (
    sender As Object,
    e As FileSystemEventArgs
)

Parameters

sender
Type: SystemObject
Object raising event i.e. this.
e
Type: System.IOFileSystemEventArgs
Encapsulates arguments pertinent to this event.
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher._watcher_Created Method

FileWatcher_watcher_Created Method

Raises the FileCreated event.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void _watcher_Created(
    Object sender,
    FileSystemEventArgs e
)
Protected Sub _watcher_Created (
    sender As Object,
    e As FileSystemEventArgs
)

Parameters

sender
Type: SystemObject
Object raising event i.e. this.
e
Type: System.IOFileSystemEventArgs
Encapsulates arguments pertinent to this event.
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher._watcher_Deleted Method

FileWatcher_watcher_Deleted Method

Raises the FileDeleted event.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void _watcher_Deleted(
    Object sender,
    FileSystemEventArgs e
)
Protected Sub _watcher_Deleted (
    sender As Object,
    e As FileSystemEventArgs
)

Parameters

sender
Type: SystemObject
Object raising event i.e. this.
e
Type: System.IOFileSystemEventArgs
Encapsulates arguments pertinent to this event.
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher Events

The FileWatcher type exposes the following members.

Events
 | Name | Description
Public event | DirectoryUnavailable | Occurs when the directory monitored by this object has been deleted. (Inherited from Watcher.)
Public event | FileChanged | Occurs when the file name is changed, the file is accessed or the file is written to.
Public event | FileCreated | Occurs when the file is created.
Public event | FileDeleted | Occurs when the file is deleted.
Top
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher.FileChanged Event

FileWatcherFileChanged Event

Occurs when the file name is changed, the file is accessed or the file is written to.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public event EventHandler<FileSystemEventArgs> FileChanged
Public Event FileChanged As EventHandler(Of FileSystemEventArgs)

Value

Type: SystemEventHandler FileSystemEventArgs
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher.FileCreated Event

FileWatcherFileCreated Event

Occurs when the file is created.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public event EventHandler<FileSystemEventArgs> FileCreated
Public Event FileCreated As EventHandler(Of FileSystemEventArgs)

Value

Type: SystemEventHandler FileSystemEventArgs
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher.FileDeleted Event

FileWatcherFileDeleted Event

Occurs when the file is deleted.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public event EventHandler<FileSystemEventArgs> FileDeleted
Public Event FileDeleted As EventHandler(Of FileSystemEventArgs)

Value

Type: SystemEventHandler FileSystemEventArgs
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


FileWatcher Fields

The FileWatcher type exposes the following members.

Fields
 | Name | Description
Protected field | _watcher | System watcher object upon which this class leverages. (Inherited from Watcher.)
Top
See Also

Reference

FileWatcher Class
Autodesk.FileSystem Namespace


Watcher Class

Abstract class on which are built the Delcam directory and file watcher classes. Regularly checks the specified directory and raises a notification event should it no longer exist.
Inheritance Hierarchy
SystemObject
Autodesk.FileSystemWatcher
Autodesk.FileSystemDirectoryWatcher
Autodesk.FileSystemFileWatcher

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class Watcher
Public MustInherit Class Watcher

The Watcher type exposes the following members.

Constructors
 | Name | Description
Public method | Watcher(String) | Creates a new directory on disk and constructs a Watcher object about it.
Public method | Watcher(Directory) | Constructs a Watcher object about the directory specified in the single input argument.
Top
Properties
 | Name | Description
Public property | DirectoryUnavailableTimerStatus | True if timer running; False otherwise.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DirectoryUnavailable | Occurs when the directory monitored by this object has been deleted.
Top
Fields
 | Name | Description
Protected field | _watcher | System watcher object upon which this class leverages.
Top
See Also

Reference

Autodesk.FileSystem Namespace


Watcher Constructor

Overload List
 | Name | Description
Public method | Watcher(String) | Creates a new directory on disk and constructs a Watcher object about it.
Public method | Watcher(Directory) | Constructs a Watcher object about the directory specified in the single input argument.
Top
See Also

Reference

Watcher Class
Autodesk.FileSystem Namespace


Watcher Constructor (String)

Creates a new directory on disk and constructs a Watcher object about it.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Watcher(
    string directoryPath
)
Public Sub New (
    directoryPath As String
)

Parameters

directoryPath
Type: SystemString
String containing path of new directory to create.
See Also

Reference

Watcher Class
Watcher Overload
Autodesk.FileSystem Namespace


Watcher Constructor (Directory)

Constructs a Watcher object about the directory specified in the single input argument.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Watcher(
    Directory directoryToWatch
)
Public Sub New (
    directoryToWatch As Directory
)

Parameters

directoryToWatch
Type: Autodesk.FileSystemDirectory
Directory to monitor.
See Also

Reference

Watcher Class
Watcher Overload
Autodesk.FileSystem Namespace


Watcher Properties

The Watcher type exposes the following members.

Properties
 | Name | Description
Public property | DirectoryUnavailableTimerStatus | True if timer running; False otherwise.
Top
See Also

Reference

Watcher Class
Autodesk.FileSystem Namespace


Watcher.DirectoryUnavailableTimerStatus Property

WatcherDirectoryUnavailableTimerStatus Property

True if timer running; False otherwise.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool DirectoryUnavailableTimerStatus { get; set; }
Public Property DirectoryUnavailableTimerStatus As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Watcher Class
Autodesk.FileSystem Namespace


Watcher Methods

The Watcher type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Watcher Class
Autodesk.FileSystem Namespace


Watcher Events

The Watcher type exposes the following members.

Events
 | Name | Description
Public event | DirectoryUnavailable | Occurs when the directory monitored by this object has been deleted.
Top
See Also

Reference

Watcher Class
Autodesk.FileSystem Namespace


Watcher.DirectoryUnavailable Event

WatcherDirectoryUnavailable Event

Occurs when the directory monitored by this object has been deleted.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public event WatcherDirectoryUnavailableHandler DirectoryUnavailable
Public Event DirectoryUnavailable As WatcherDirectoryUnavailableHandler

Value

Type: Autodesk.FileSystemWatcherDirectoryUnavailableHandler
See Also

Reference

Watcher Class
Autodesk.FileSystem Namespace


Watcher Fields

The Watcher type exposes the following members.

Fields
 | Name | Description
Protected field | _watcher | System watcher object upon which this class leverages.
Top
See Also

Reference

Watcher Class
Autodesk.FileSystem Namespace


Watcher._watcher Field

Watcher_watcher Field

System watcher object upon which this class leverages.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected FileSystemWatcher _watcher
Protected _watcher As FileSystemWatcher

Field Value

Type: FileSystemWatcher
See Also

Reference

Watcher Class
Autodesk.FileSystem Namespace


Watcher.DirectoryUnavailableHandler Delegate

WatcherDirectoryUnavailableHandler Delegate

Use this as the prototype to handle the DirectoryUnavailable event fired by this class.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public delegate void DirectoryUnavailableHandler(
    Object sender,
    WatcherEventArgs e
)
Public Delegate Sub DirectoryUnavailableHandler (
    sender As Object,
    e As WatcherEventArgs
)

Parameters

sender
Type: SystemObject
Sender of this event.
e
Type: Autodesk.FileSystemWatcherEventArgs
Encapsulates arguments pertinent to this event.
See Also

Reference

Autodesk.FileSystem Namespace


WatcherEventArgs Class

Encapsulates arguments pertinent to the Watcher class.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Autodesk.FileSystemWatcherEventArgs

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class WatcherEventArgs : EventArgs
Public Class WatcherEventArgs
    Inherits EventArgs

The WatcherEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WatcherEventArgs | Initializes a new instance of the WatcherEventArgs class
Top
Properties
 | Name | Description
Public property | Directory | The directory being watched.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.FileSystem Namespace


WatcherEventArgs Constructor

Initializes a new instance of the WatcherEventArgs class

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public WatcherEventArgs(
    Directory watchedDirectory
)
Public Sub New (
    watchedDirectory As Directory
)

Parameters

watchedDirectory
Type: Autodesk.FileSystemDirectory
Directory being watched
See Also

Reference

WatcherEventArgs Class
Autodesk.FileSystem Namespace


WatcherEventArgs Properties

The WatcherEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Directory | The directory being watched.
Top
See Also

Reference

WatcherEventArgs Class
Autodesk.FileSystem Namespace


WatcherEventArgs.Directory Property

WatcherEventArgsDirectory Property

The directory being watched.

Namespace: Autodesk.FileSystem
Assembly: Autodesk.Utilities (in Autodesk.Utilities.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Directory Directory { get; }
Public ReadOnly Property Directory As Directory
    Get

Property Value

Type: Directory
See Also

Reference

WatcherEventArgs Class
Autodesk.FileSystem Namespace


WatcherEventArgs Methods

The WatcherEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WatcherEventArgs Class
Autodesk.FileSystem Namespace


Autodesk.Geometry Namespace

Classes
 | Class | Description
Public class | BoundingBox | Defines a three-dimensional bounding box.
Public class | CubicBezier | Most important case in the family of bezier curves. Consists of four control points, the first and last of which are incident on the curve.
Public class | DMTFileException | Defines the exception to be thrown on DMT file errors.
Public class | DMTModel | Handles the reading and writing of DMT files and facilitates the manipulation of triangles therein.
Public class | DMTModelReader | Reads a mesh file.
Public class | DMTModelWriter | Writes a DMTModel model to a file.
Public class | DMTTriangle | Encapsulates a triangle. One or more triangles constitute a block.
Public class | DMTTriangleBlock | Represents a block of triangles. One or more blocks make up a DMT model.
Public class | DMTTriangleZone | Encapsulates the list of triangles that constitute a zone of the model. Zoning a model increases performance when projecting a point onto the model in the Z axis.
Public class | DMTTriangleZoneEntry | Encapsulates the indices of both block and triangle for the list of triangles that constitute a zone of the model.
Public class | DMTVertex | Encapsulates DMT mesh vertices. A vertex has a position, a normal and 'knows' what triangles it is a part of.
Public class | Line | Encapsulates a straight line.
Public class | MSRFile | Performs read and write operations on MSR files.
Public class | MSRFilePointData | Encapsulates data for each point.
Public class | Point | Encapsulates a three-dimensional point and the permissible operations thereon.
Public class | PointCloud | Encapsulates a point cloud, a collection of points that are not linked together.
Public class | Polyline | Encapsulates a Polyline. A Polyline comprises a collection of points, each connected by a straight line. If marked as closed, the start and end points are also joined by a line; it is not necessary to duplicate the start point at the end of the list in order to close the shape.
Public class | Spline | Encapsulates a Spline Curve.
Public class | SplinePoint | SplinePoint inherits from Point. In addition to possessing location, a spline point also has direction and magnitude before and after the point.
Public class | Vector | Encapsulates a three dimensional vector and operations thereon.
Public class | Workplane | Encapsulates a Workplane. A workplane consists of three vectors that describe the orientation of a model in respect to the world.
Structures
 | Structure | Description
Public structure | Degree | Structure encapsulating all operations for manipulating angles in degrees.
Public structure | Inch | Encapsulates length measured in inches and the operations thereon.
Public structure | MM | Encapsulates length measured in millimetres and the operations thereon.
Public structure | Radian | Structure encapsulating all operations for manipulating angles in radians.
Interfaces
 | Interface | Description
Public interface | IDMTModelFilter | Allows to apply a filter for a DMTModel.
Enumerations
 | Enumeration | Description
Public enumeration | SplineSplineExtensionEnd | Used to specify endedness for extension operations.


BoundingBox Class

Defines a three-dimensional bounding box.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryBoundingBox

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BoundingBox
<SerializableAttribute>
Public Class BoundingBox

The BoundingBox type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBox | Constructs a maximally sized bounding box.
Public method | BoundingBox(Point, Point) | Constructs a bounding box with the specified dimensions.
Public method | BoundingBox(MM, MM, MM, MM, MM, MM) | Constructs a bounding box with the specified dimensions.
Top
Properties
 | Name | Description
Public property | MaximumBounds | Maximum X, Y and Z bounds of the bounding box.
Public property | MaxX | Maximum boundary in X.
Public property | MaxY | Maximum boundary in Y.
Public property | MaxZ | Maximum boundary in Z.
Public property | MinimumBounds | Minimum X, Y and Z bounds of the bounding box.
Public property | MinX | Minimum boundary in X.
Public property | MinY | Minimum boundary in Y.
Public property | MinZ | Minimum boundary in Z.
Public property | Volume | Volume of bounding box.
Public property | VolumetricCentre | Volumetric centre of the bounding box.
Public property | XSize | Boundary extent in X.
Public property | YSize | Boundary extent in Y.
Public property | ZSize | Boundary extent in Z.
Top
Methods
 | Name | Description
Public method | Clone | Clones of the current BoundingBox.
Public method | Equals | Test whether this item is the same as the passed object (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge | Get the bounding box around two boxes.
Public method | ToString | Returns a string representation of the BoundingBox (Overrides ObjectToString.)
Top
See Also

Reference

Autodesk.Geometry Namespace


BoundingBox Constructor

Overload List
 | Name | Description
Public method | BoundingBox | Constructs a maximally sized bounding box.
Public method | BoundingBox(Point, Point) | Constructs a bounding box with the specified dimensions.
Public method | BoundingBox(MM, MM, MM, MM, MM, MM) | Constructs a bounding box with the specified dimensions.
Top
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox Constructor

Constructs a maximally sized bounding box.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox()
Public Sub New
See Also

Reference

BoundingBox Class
BoundingBox Overload
Autodesk.Geometry Namespace


BoundingBox Constructor (Point, Point)

Constructs a bounding box with the specified dimensions.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox(
    Point minimumBounds,
    Point maximumBounds
)
Public Sub New (
    minimumBounds As Point,
    maximumBounds As Point
)

Parameters

minimumBounds
Type: Autodesk.GeometryPoint
Minimum values in X, Y and Z.
maximumBounds
Type: Autodesk.GeometryPoint
Maximum values in X, Y and Z.
See Also

Reference

BoundingBox Class
BoundingBox Overload
Autodesk.Geometry Namespace


BoundingBox Constructor (MM, MM, MM, MM, MM, MM)

Constructs a bounding box with the specified dimensions.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox(
    MM minX,
    MM maxX,
    MM minY,
    MM maxY,
    MM minZ,
    MM maxZ
)
Public Sub New (
    minX As MM,
    maxX As MM,
    minY As MM,
    maxY As MM,
    minZ As MM,
    maxZ As MM
)

Parameters

minX
Type: Autodesk.GeometryMM
Minimum value in X.
maxX
Type: Autodesk.GeometryMM
Maximum value in X.
minY
Type: Autodesk.GeometryMM
Minimum value in Y.
maxY
Type: Autodesk.GeometryMM
Maximum value in Y.
minZ
Type: Autodesk.GeometryMM
Minimum value in Z.
maxZ
Type: Autodesk.GeometryMM
Maximum value in Z.
See Also

Reference

BoundingBox Class
BoundingBox Overload
Autodesk.Geometry Namespace


BoundingBox Properties

The BoundingBox type exposes the following members.

Properties
 | Name | Description
Public property | MaximumBounds | Maximum X, Y and Z bounds of the bounding box.
Public property | MaxX | Maximum boundary in X.
Public property | MaxY | Maximum boundary in Y.
Public property | MaxZ | Maximum boundary in Z.
Public property | MinimumBounds | Minimum X, Y and Z bounds of the bounding box.
Public property | MinX | Minimum boundary in X.
Public property | MinY | Minimum boundary in Y.
Public property | MinZ | Minimum boundary in Z.
Public property | Volume | Volume of bounding box.
Public property | VolumetricCentre | Volumetric centre of the bounding box.
Public property | XSize | Boundary extent in X.
Public property | YSize | Boundary extent in Y.
Public property | ZSize | Boundary extent in Z.
Top
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.MaximumBounds Property

BoundingBoxMaximumBounds Property

Maximum X, Y and Z bounds of the bounding box.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point MaximumBounds { get; }
Public ReadOnly Property MaximumBounds As Point
    Get

Property Value

Type: Point
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.MaxX Property

BoundingBoxMaxX Property

Maximum boundary in X.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MaxX { get; set; }
Public Property MaxX As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.MaxY Property

BoundingBoxMaxY Property

Maximum boundary in Y.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MaxY { get; set; }
Public Property MaxY As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.MaxZ Property

BoundingBoxMaxZ Property

Maximum boundary in Z.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MaxZ { get; set; }
Public Property MaxZ As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.MinimumBounds Property

BoundingBoxMinimumBounds Property

Minimum X, Y and Z bounds of the bounding box.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point MinimumBounds { get; }
Public ReadOnly Property MinimumBounds As Point
    Get

Property Value

Type: Point
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.MinX Property

BoundingBoxMinX Property

Minimum boundary in X.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MinX { get; set; }
Public Property MinX As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.MinY Property

BoundingBoxMinY Property

Minimum boundary in Y.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MinY { get; set; }
Public Property MinY As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.MinZ Property

BoundingBoxMinZ Property

Minimum boundary in Z.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MinZ { get; set; }
Public Property MinZ As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.Volume Property

BoundingBoxVolume Property

Volume of bounding box.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Volume { get; }
Public ReadOnly Property Volume As Double
    Get

Property Value

Type: Double
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.VolumetricCentre Property

BoundingBoxVolumetricCentre Property

Volumetric centre of the bounding box.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point VolumetricCentre { get; }
Public ReadOnly Property VolumetricCentre As Point
    Get

Property Value

Type: Point
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.XSize Property

BoundingBoxXSize Property

Boundary extent in X.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM XSize { get; }
Public ReadOnly Property XSize As MM
    Get

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.YSize Property

BoundingBoxYSize Property

Boundary extent in Y.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM YSize { get; }
Public ReadOnly Property YSize As MM
    Get

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.ZSize Property

BoundingBoxZSize Property

Boundary extent in Z.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ZSize { get; }
Public ReadOnly Property ZSize As MM
    Get

Property Value

Type: MM
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox Methods

The BoundingBox type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clones of the current BoundingBox.
Public method | Equals | Test whether this item is the same as the passed object (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge | Get the bounding box around two boxes.
Public method | ToString | Returns a string representation of the BoundingBox (Overrides ObjectToString.)
Top
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.Clone Method

BoundingBoxClone Method

Clones of the current BoundingBox.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox Clone()
Public Function Clone As BoundingBox

Return Value

Type: BoundingBox
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.Equals Method

BoundingBoxEquals Method

Test whether this item is the same as the passed object

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Item to compare against

Return Value

Type: Boolean
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.Merge Method

BoundingBoxMerge Method

Get the bounding box around two boxes.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static BoundingBox Merge(
    BoundingBox box1,
    BoundingBox box2
)
Public Shared Function Merge (
    box1 As BoundingBox,
    box2 As BoundingBox
) As BoundingBox

Parameters

box1
Type: Autodesk.GeometryBoundingBox

[Missing <param name="box1"/> documentation for "M:Autodesk.Geometry.BoundingBox.Merge(Autodesk.Geometry.BoundingBox,Autodesk.Geometry.BoundingBox)"]

box2
Type: Autodesk.GeometryBoundingBox

[Missing <param name="box2"/> documentation for "M:Autodesk.Geometry.BoundingBox.Merge(Autodesk.Geometry.BoundingBox,Autodesk.Geometry.BoundingBox)"]

Return Value

Type: BoundingBox
Returns the bounding box around two bounding boxes. If either box is Nothing, the other will be returned. If both boxes are Nothing, Nothing will be returned.
Remarks
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


BoundingBox.ToString Method

BoundingBoxToString Method

Returns a string representation of the BoundingBox

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

BoundingBox Class
Autodesk.Geometry Namespace


CubicBezier Class

Most important case in the family of bezier curves. Consists of four control points, the first and last of which are incident on the curve.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryCubicBezier

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class CubicBezier
Public Class CubicBezier

The CubicBezier type exposes the following members.

Constructors
 | Name | Description
Public method | CubicBezier | Constructs a CubicBezier object with the specified parameters.
Top
Properties
 | Name | Description
Public property | EndControlPoint | Second control point.
Public property | EndPoint | End point.
Public property | StartControlPoint | First control point.
Public property | StartPoint | Start point.
Top
Methods
 | Name | Description
Public method | Curvature | Returns vector representing radius of curvature at the specified position on the curve in t where 0 <= t <= 1.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNearestPositionOnSpan | Calculates the value of t, where 0 <= t <= 1, at which occurs the point on the bezier curve closest to a given point in space.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSpanStraight | Determines whether the Bezier curve is straight. Occurs when all points along it are colinear.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Position | Returns a point on the curve in t where 0 <= t <= 1
Public method | Tangent | Returns the tangent at a position on the Bezier Curve in t where 0 <= t <= 1. The tangent is normalized by default.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.Geometry Namespace


CubicBezier Constructor

Constructs a CubicBezier object with the specified parameters.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public CubicBezier(
    Point startPoint,
    Point endPoint,
    Point controlPoint1,
    Point controlPoint2
)
Public Sub New (
    startPoint As Point,
    endPoint As Point,
    controlPoint1 As Point,
    controlPoint2 As Point
)

Parameters

startPoint
Type: Autodesk.GeometryPoint
Curve starts here.
endPoint
Type: Autodesk.GeometryPoint
Curve ends here.
controlPoint1
Type: Autodesk.GeometryPoint
First control point.
controlPoint2
Type: Autodesk.GeometryPoint
Second control point.
Remarks
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier Properties

The CubicBezier type exposes the following members.

Properties
 | Name | Description
Public property | EndControlPoint | Second control point.
Public property | EndPoint | End point.
Public property | StartControlPoint | First control point.
Public property | StartPoint | Start point.
Top
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.EndControlPoint Property

CubicBezierEndControlPoint Property

Second control point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point EndControlPoint { get; set; }
Public Property EndControlPoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.EndPoint Property

CubicBezierEndPoint Property

End point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point EndPoint { get; set; }
Public Property EndPoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.StartControlPoint Property

CubicBezierStartControlPoint Property

First control point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point StartControlPoint { get; set; }
Public Property StartControlPoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.StartPoint Property

CubicBezierStartPoint Property

Start point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point StartPoint { get; set; }
Public Property StartPoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier Methods

The CubicBezier type exposes the following members.

Methods
 | Name | Description
Public method | Curvature | Returns vector representing radius of curvature at the specified position on the curve in t where 0 <= t <= 1.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNearestPositionOnSpan | Calculates the value of t, where 0 <= t <= 1, at which occurs the point on the bezier curve closest to a given point in space.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSpanStraight | Determines whether the Bezier curve is straight. Occurs when all points along it are colinear.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Position | Returns a point on the curve in t where 0 <= t <= 1
Public method | Tangent | Returns the tangent at a position on the Bezier Curve in t where 0 <= t <= 1. The tangent is normalized by default.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.Curvature Method

CubicBezierCurvature Method

Returns vector representing radius of curvature at the specified position on the curve in t where 0 <= t <= 1.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector Curvature(
    double t
)
Public Function Curvature (
    t As Double
) As Vector

Parameters

t
Type: SystemDouble
Relative time parameter specifying position at which tangent is to be calculated.

Return Value

Type: Vector
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if t does not satisfy the condition: 0 <= t <= 1.
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.FindNearestPositionOnSpan Method

CubicBezierFindNearestPositionOnSpan Method

Calculates the value of t, where 0 <= t <= 1, at which occurs the point on the bezier curve closest to a given point in space.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double FindNearestPositionOnSpan(
    ref Point pointInSpace,
    ref List<int> nIterationsList,
    out double distanceToNearestPosition
)
Public Function FindNearestPositionOnSpan (
    ByRef pointInSpace As Point,
    ByRef nIterationsList As List(Of Integer),
    <OutAttribute> ByRef distanceToNearestPosition As Double
) As Double

Parameters

pointInSpace
Type: Autodesk.GeometryPoint
Point in space at which to determine the bezier closest approach.
nIterationsList
Type: System.Collections.GenericList Int32
List of iteration coefficients.
distanceToNearestPosition
Type: SystemDouble
Actual distance from curve at t to point in space.

Return Value

Type: Double
Value of t at closest approach.
Remarks
Algorithm progressively reduces granularity of result by first identifying a span t/n of closest approach, where n is nIterationList[0], and then refining the outcome with successive decomposition phases, the number of which is the number of integers in nIterationList.
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.IsSpanStraight Method

CubicBezierIsSpanStraight Method

Determines whether the Bezier curve is straight. Occurs when all points along it are colinear.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsSpanStraight(
    bool isAllowOutsideRange = true
)
Public Function IsSpanStraight (
    Optional isAllowOutsideRange As Boolean = true
) As Boolean

Parameters

isAllowOutsideRange (Optional)
Type: SystemBoolean
If True, control points do not have to fall between start and end points.

Return Value

Type: Boolean
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.Position Method

CubicBezierPosition Method

Returns a point on the curve in t where 0 <= t <= 1

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Position(
    double t
)
Public Function Position (
    t As Double
) As Point

Parameters

t
Type: SystemDouble
Relative time parameter at which to calculate point.

Return Value

Type: Point
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if t does not satisfy the condition: 0 <= t <= 1.
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


CubicBezier.Tangent Method

CubicBezierTangent Method

Returns the tangent at a position on the Bezier Curve in t where 0 <= t <= 1. The tangent is normalized by default.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector Tangent(
    double t,
    bool normalize = true
)
Public Function Tangent (
    t As Double,
    Optional normalize As Boolean = true
) As Vector

Parameters

t
Type: SystemDouble
Relative time parameter specifying position at which tangent is to be calculated.
normalize (Optional)
Type: SystemBoolean
If True, tangent will be normalised. False otherwise.

Return Value

Type: Vector
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if t does not satisfy the condition: 0 <= t <= 1.
See Also

Reference

CubicBezier Class
Autodesk.Geometry Namespace


Degree Structure

Structure encapsulating all operations for manipulating angles in degrees.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct Degree : IFormattable, IComparable
<SerializableAttribute>
Public Structure Degree
    Implements IFormattable, IComparable

The Degree type exposes the following members.

Constructors
 | Name | Description
Public method | Degree | Constructs a Degree structure and initialises the angle to the specified number of degrees
Top
Properties
 | Name | Description
Public property | Value | Value of the angle in degrees.
Top
Methods
 | Name | Description
Public method | CompareTo | Determines whether the passed argument is before or after this one in logical sort order.
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type Degree or Radian, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type Degree or Radian, false will be returned.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string representation of the value in degrees. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Returns a formatted string representation of the value in degrees.
Public method | ToString(String, IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified format and culture-specific format information.
Top
Operators
Name | Description
Addition | Add one Degree object to another.
Division(Degree, Degree) | Division of one Degree object by another.
Division(Degree, Double) | Division of one Degree object by a double.
Equality | Determine whether two Degree objects are equal.
(Degree to Single) | Cast a Degree object to int. Note: There is an implicit loss of precision with this operation.
(Degree to Decimal) | Cast a Degree object to decimal.
GreaterThan(Degree, Degree) | Determine whether the left-hand Degree object is greater than the right.
GreaterThan(Degree, Double) | Determine whether the left-hand Degree object is greater than the right hand double.
GreaterThanOrEqual(Degree, Degree) | Determine whether the left-hand Degree object is greater than or equal to the right.
GreaterThanOrEqual(Degree, Double) | Determine whether the left-hand Degree object is greater than or equal to the right hand double.
(Double to Degree) | Cast a double to a Degree object.
(Degree to Double) | Cast a Degree object to double.
(Radian to Degree) | Cast a Radian object to a Degree object.
Inequality | Determine whether two Degree objects are not equal.
LessThan(Degree, Degree) | Determine whether the left-hand Degree object is less than the right.
LessThan(Degree, Double) | Determine whether the left-hand Degree object is less than the right hand double.
LessThanOrEqual(Degree, Degree) | Determine whether the left-hand Degree object is less than or equal to the right.
LessThanOrEqual(Degree, Double) | Determine whether the left-hand Degree object is less than or equal to the right hand double.
Multiply(Double, Degree) | Multiplication of a double by a Degree object.
Multiply(Degree, Degree) | Multiplication of two degrees objects.
Multiply(Degree, Double) | Multiplication of a Degree object by a double.
Subtraction | Subtract one Degree object from another.
UnaryNegation | Negates the current value of the angle.
Top
See Also

Reference

Autodesk.Geometry Namespace


Degree Constructor

Constructs a Degree structure and initialises the angle to the specified number of degrees

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree(
    double angle
)
Public Sub New (
    angle As Double
)

Parameters

angle
Type: SystemDouble
Angle in degrees.
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree Properties

The Degree type exposes the following members.

Properties
 | Name | Description
Public property | Value | Value of the angle in degrees.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.Value Property

DegreeValue Property

Value of the angle in degrees.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The angle in degrees.
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree Methods

The Degree type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Determines whether the passed argument is before or after this one in logical sort order.
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type Degree or Radian, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type Degree or Radian, false will be returned.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string representation of the value in degrees. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Returns a formatted string representation of the value in degrees.
Public method | ToString(String, IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.CompareTo Method

DegreeCompareTo Method

Determines whether the passed argument is before or after this one in logical sort order.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: SystemObject
Passed object to compare. Must be of type Degree.

Return Value

Type: Int32
Integer detailing the relative ordering of the two objects in the sort order: If zero, both occur in the same position; negative and this object preceeds the passed argument and, if positive, this object comes after the passed argument.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | Thrown if the object to compare is not of type Degree.
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.Equals Method

DegreeEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type Degree or Radian, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type Degree or Radian, false will be returned.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.Equals Method (Object)

DegreeEquals Method (Object)

Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type Degree or Radian, false will be returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Object with which to compare this.

Return Value

Type: Boolean
True if the magnitudes of this and the specified object are equivalent; false otherwise.
See Also

Reference

Degree Structure
Equals Overload
Autodesk.Geometry Namespace


Degree.Equals Method (Object, Int32)

DegreeEquals Method (Object, Int32)

Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type Degree or Radian, false will be returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    Object obj,
    int nDecPts
)
Public Function Equals (
    obj As Object,
    nDecPts As Integer
) As Boolean

Parameters

obj
Type: SystemObject
Object with which to compare this.
nDecPts
Type: SystemInt32
Number of decimal places to compare.

Return Value

Type: Boolean
True if the magnitudes of this and the specified object are considered equivalent; false otherwise.
See Also

Reference

Degree Structure
Equals Overload
Autodesk.Geometry Namespace


Degree.ToString Method

DegreeToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string representation of the value in degrees. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Returns a formatted string representation of the value in degrees.
Public method | ToString(String, IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.ToString Method

DegreeToString Method

Returns a string representation of the value in degrees.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
String representation of the value in degrees.
See Also

Reference

Degree Structure
ToString Overload
Autodesk.Geometry Namespace


Degree.ToString Method (IFormatProvider)

DegreeToString Method (IFormatProvider)

Returns the numeric value of this instance in its equivalent string representation using the specified culture-specific format information.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    IFormatProvider fp
)
Public Function ToString (
    fp As IFormatProvider
) As String

Parameters

fp
Type: SystemIFormatProvider
Custom object implementing the IFormatProvider interface.

Return Value

Type: String
String representation of the value in degrees.
See Also

Reference

Degree Structure
ToString Overload
Autodesk.Geometry Namespace


Degree.ToString Method (String)

DegreeToString Method (String)

Returns a formatted string representation of the value in degrees.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String

Parameters

format
Type: SystemString
Standard numeric format specifier.

Return Value

Type: String
String representation of the value in degrees.
See Also

Reference

Degree Structure
ToString Overload
Autodesk.Geometry Namespace


Degree.ToString Method (String, IFormatProvider)

DegreeToString Method (String, IFormatProvider)

Returns the numeric value of this instance in its equivalent string representation using the specified format and culture-specific format information.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    string format,
    IFormatProvider fp
)
Public Function ToString (
    format As String,
    fp As IFormatProvider
) As String

Parameters

format
Type: SystemString
Standard numeric format specifier.
fp
Type: SystemIFormatProvider
Custom object implementing the IFormatProvider interface.

Return Value

Type: String
String representation of the value in degrees.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Degree Structure
ToString Overload
Autodesk.Geometry Namespace


Degree Operators and Type Conversions

The Degree type exposes the following members.

Operators
Name | Description
Addition | Add one Degree object to another.
Division(Degree, Degree) | Division of one Degree object by another.
Division(Degree, Double) | Division of one Degree object by a double.
Equality | Determine whether two Degree objects are equal.
(Degree to Single) | Cast a Degree object to int. Note: There is an implicit loss of precision with this operation.
(Degree to Decimal) | Cast a Degree object to decimal.
GreaterThan(Degree, Degree) | Determine whether the left-hand Degree object is greater than the right.
GreaterThan(Degree, Double) | Determine whether the left-hand Degree object is greater than the right hand double.
GreaterThanOrEqual(Degree, Degree) | Determine whether the left-hand Degree object is greater than or equal to the right.
GreaterThanOrEqual(Degree, Double) | Determine whether the left-hand Degree object is greater than or equal to the right hand double.
(Double to Degree) | Cast a double to a Degree object.
(Degree to Double) | Cast a Degree object to double.
(Radian to Degree) | Cast a Radian object to a Degree object.
Inequality | Determine whether two Degree objects are not equal.
LessThan(Degree, Degree) | Determine whether the left-hand Degree object is less than the right.
LessThan(Degree, Double) | Determine whether the left-hand Degree object is less than the right hand double.
LessThanOrEqual(Degree, Degree) | Determine whether the left-hand Degree object is less than or equal to the right.
LessThanOrEqual(Degree, Double) | Determine whether the left-hand Degree object is less than or equal to the right hand double.
Multiply(Double, Degree) | Multiplication of a double by a Degree object.
Multiply(Degree, Degree) | Multiplication of two degrees objects.
Multiply(Degree, Double) | Multiplication of a Degree object by a double.
Subtraction | Subtract one Degree object from another.
UnaryNegation | Negates the current value of the angle.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.Addition Operator

DegreeAddition Operator

Add one Degree object to another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree operator +(
    Degree left,
    Degree right
)
Public Shared Operator + (
    left As Degree,
    right As Degree
) As Degree

Parameters

left
Type: Autodesk.GeometryDegree
First of two Degree objects to be summed.
right
Type: Autodesk.GeometryDegree
Second of two Degree objects to be summed.

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.Division Operator

DegreeDivision Operator

Overload List
Name | Description
Division(Degree, Degree) | Division of one Degree object by another.
Division(Degree, Double) | Division of one Degree object by a double.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.Division Operator (Degree, Degree)

DegreeDivision Operator (Degree, Degree)

Division of one Degree object by another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree operator /(
    Degree left,
    Degree right
)
Public Shared Operator / (
    left As Degree,
    right As Degree
) As Degree

Parameters

left
Type: Autodesk.GeometryDegree
Degree object to be divided (dividend).
right
Type: Autodesk.GeometryDegree
Degree object to divide with (divisor).

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Division Overload
Autodesk.Geometry Namespace


Degree.Division Operator (Degree, Double)

DegreeDivision Operator (Degree, Double)

Division of one Degree object by a double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree operator /(
    Degree left,
    double right
)
Public Shared Operator / (
    left As Degree,
    right As Double
) As Degree

Parameters

left
Type: Autodesk.GeometryDegree
Degree object to be divided (dividend).
right
Type: SystemDouble
Double to divide by (divisor).

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Division Overload
Autodesk.Geometry Namespace


Degree.Equality Operator

DegreeEquality Operator

Determine whether two Degree objects are equal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator ==(
    Degree left,
    Degree right
)
Public Shared Operator = (
    left As Degree,
    right As Degree
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two Degree objects to compare.
right
Type: Autodesk.GeometryDegree
Second of two Degree objects to compare.

Return Value

Type: Boolean
Returns True if the two Degree objects are equivalent; false otherwise.
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree Explicit Conversion Operators

Degree Conversion Operators

Overload List
Name | Description
(Degree to Single) | Cast a Degree object to int. Note: There is an implicit loss of precision with this operation.
(Degree to Decimal) | Cast a Degree object to decimal.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree Explicit Conversion (Degree to Single)

Degree Conversion (Degree to Single)

Cast a Degree object to int. Note: There is an implicit loss of precision with this operation.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator float (
    Degree left
)
Public Shared Narrowing Operator CType (
    left As Degree
) As Single

Parameters

left
Type: Autodesk.GeometryDegree
Degree object to cast.

Return Value

Type: Single
Integer representation of the Degree object.
See Also

Reference

Degree Structure
Overload
Autodesk.Geometry Namespace


Degree Explicit Conversion (Degree to Decimal)

Degree Conversion (Degree to Decimal)

Cast a Degree object to decimal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator decimal (
    Degree left
)
Public Shared Narrowing Operator CType (
    left As Degree
) As Decimal

Parameters

left
Type: Autodesk.GeometryDegree
Degree object to cast.

Return Value

Type: Decimal
Decimal representation of the Degree object.
See Also

Reference

Degree Structure
Overload
Autodesk.Geometry Namespace


Degree.GreaterThan Operator

DegreeGreaterThan Operator

Overload List
Name | Description
GreaterThan(Degree, Degree) | Determine whether the left-hand Degree object is greater than the right.
GreaterThan(Degree, Double) | Determine whether the left-hand Degree object is greater than the right hand double.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.GreaterThan Operator (Degree, Degree)

DegreeGreaterThan Operator (Degree, Degree)

Determine whether the left-hand Degree object is greater than the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >(
    Degree left,
    Degree right
)
Public Shared Operator > (
    left As Degree,
    right As Degree
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two Degree objects to compare.
right
Type: Autodesk.GeometryDegree
Second of two Degree objects to compare.

Return Value

Type: Boolean
Returns True if the left-hand Degree object is greater than the right; false otherwise.
See Also

Reference

Degree Structure
GreaterThan Overload
Autodesk.Geometry Namespace


Degree.GreaterThan Operator (Degree, Double)

DegreeGreaterThan Operator (Degree, Double)

Determine whether the left-hand Degree object is greater than the right hand double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >(
    Degree left,
    double right
)
Public Shared Operator > (
    left As Degree,
    right As Double
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two parameters to compare.
right
Type: SystemDouble
Second of two parameters to compare.

Return Value

Type: Boolean
Returns True if the Degree objects is greater than the double; false otherwise.
See Also

Reference

Degree Structure
GreaterThan Overload
Autodesk.Geometry Namespace


Degree.GreaterThanOrEqual Operator

DegreeGreaterThanOrEqual Operator

Overload List
Name | Description
GreaterThanOrEqual(Degree, Degree) | Determine whether the left-hand Degree object is greater than or equal to the right.
GreaterThanOrEqual(Degree, Double) | Determine whether the left-hand Degree object is greater than or equal to the right hand double.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.GreaterThanOrEqual Operator (Degree, Degree)

DegreeGreaterThanOrEqual Operator (Degree, Degree)

Determine whether the left-hand Degree object is greater than or equal to the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >=(
    Degree left,
    Degree right
)
Public Shared Operator >= (
    left As Degree,
    right As Degree
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two Degree objects to compare.
right
Type: Autodesk.GeometryDegree
Second of two Degree objects to compare.

Return Value

Type: Boolean
Returns True if the left-hand Degree object is greater than or equal to the right; false otherwise.
See Also

Reference

Degree Structure
GreaterThanOrEqual Overload
Autodesk.Geometry Namespace


Degree.GreaterThanOrEqual Operator (Degree, Double)

DegreeGreaterThanOrEqual Operator (Degree, Double)

Determine whether the left-hand Degree object is greater than or equal to the right hand double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >=(
    Degree left,
    double right
)
Public Shared Operator >= (
    left As Degree,
    right As Double
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two parameters to compare.
right
Type: SystemDouble
Second of two parameters to compare.

Return Value

Type: Boolean
Returns True if the Degree objects is greater than or equal to the double; false otherwise.
See Also

Reference

Degree Structure
GreaterThanOrEqual Overload
Autodesk.Geometry Namespace


Degree Implicit Conversion Operators

Degree Conversion Operators

Overload List
Name | Description
(Double to Degree) | Cast a double to a Degree object.
(Degree to Double) | Cast a Degree object to double.
(Radian to Degree) | Cast a Radian object to a Degree object.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree Implicit Conversion (Double to Degree)

Degree Conversion (Double to Degree)

Cast a double to a Degree object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator Degree (
    double left
)
Public Shared Widening Operator CType (
    left As Double
) As Degree

Parameters

left
Type: SystemDouble
Double to cast.

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Overload
Autodesk.Geometry Namespace


Degree Implicit Conversion (Degree to Double)

Degree Conversion (Degree to Double)

Cast a Degree object to double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator double (
    Degree left
)
Public Shared Widening Operator CType (
    left As Degree
) As Double

Parameters

left
Type: Autodesk.GeometryDegree
Degree object to cast.

Return Value

Type: Double
Double representation of the Degree object.
See Also

Reference

Degree Structure
Overload
Autodesk.Geometry Namespace


Degree Implicit Conversion (Radian to Degree)

Degree Conversion (Radian to Degree)

Cast a Radian object to a Degree object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator Degree (
    Radian left
)
Public Shared Widening Operator CType (
    left As Radian
) As Degree

Parameters

left
Type: Autodesk.GeometryRadian
Radian object to cast.

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Overload
Autodesk.Geometry Namespace


Degree.Inequality Operator

DegreeInequality Operator

Determine whether two Degree objects are not equal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator !=(
    Degree left,
    Degree right
)
Public Shared Operator <> (
    left As Degree,
    right As Degree
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two Degree objects to compare.
right
Type: Autodesk.GeometryDegree
Second of two Degree objects to compare.

Return Value

Type: Boolean
Returns True if the two Degree objects are unquivalent; false otherwise.
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.LessThan Operator

DegreeLessThan Operator

Overload List
Name | Description
LessThan(Degree, Degree) | Determine whether the left-hand Degree object is less than the right.
LessThan(Degree, Double) | Determine whether the left-hand Degree object is less than the right hand double.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.LessThan Operator (Degree, Degree)

DegreeLessThan Operator (Degree, Degree)

Determine whether the left-hand Degree object is less than the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <(
    Degree left,
    Degree right
)
Public Shared Operator < (
    left As Degree,
    right As Degree
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two Degree objects to compare.
right
Type: Autodesk.GeometryDegree
Second of two Degree objects to compare.

Return Value

Type: Boolean
Returns True if the left-hand Degree object is less than the right; false otherwise.
See Also

Reference

Degree Structure
LessThan Overload
Autodesk.Geometry Namespace


Degree.LessThan Operator (Degree, Double)

DegreeLessThan Operator (Degree, Double)

Determine whether the left-hand Degree object is less than the right hand double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <(
    Degree left,
    double right
)
Public Shared Operator < (
    left As Degree,
    right As Double
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two parameters to compare.
right
Type: SystemDouble
Second of two parameters to compare.

Return Value

Type: Boolean
Returns True if the Degree objects is less than the double; false otherwise.
See Also

Reference

Degree Structure
LessThan Overload
Autodesk.Geometry Namespace


Degree.LessThanOrEqual Operator

DegreeLessThanOrEqual Operator

Overload List
Name | Description
LessThanOrEqual(Degree, Degree) | Determine whether the left-hand Degree object is less than or equal to the right.
LessThanOrEqual(Degree, Double) | Determine whether the left-hand Degree object is less than or equal to the right hand double.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.LessThanOrEqual Operator (Degree, Degree)

DegreeLessThanOrEqual Operator (Degree, Degree)

Determine whether the left-hand Degree object is less than or equal to the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <=(
    Degree left,
    Degree right
)
Public Shared Operator <= (
    left As Degree,
    right As Degree
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two Degree objects to compare.
right
Type: Autodesk.GeometryDegree
Second of two Degree objects to compare.

Return Value

Type: Boolean
Returns True if the left-hand Degree object is less than or equal to the right; false otherwise.
See Also

Reference

Degree Structure
LessThanOrEqual Overload
Autodesk.Geometry Namespace


Degree.LessThanOrEqual Operator (Degree, Double)

DegreeLessThanOrEqual Operator (Degree, Double)

Determine whether the left-hand Degree object is less than or equal to the right hand double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <=(
    Degree left,
    double right
)
Public Shared Operator <= (
    left As Degree,
    right As Double
) As Boolean

Parameters

left
Type: Autodesk.GeometryDegree
First of two parameters to compare.
right
Type: SystemDouble
Second of two parameters to compare.

Return Value

Type: Boolean
Returns True if the Degree objects is less than or equal to the double; false otherwise.
See Also

Reference

Degree Structure
LessThanOrEqual Overload
Autodesk.Geometry Namespace


Degree.Multiply Operator

DegreeMultiply Operator

Overload List
Name | Description
Multiply(Double, Degree) | Multiplication of a double by a Degree object.
Multiply(Degree, Degree) | Multiplication of two degrees objects.
Multiply(Degree, Double) | Multiplication of a Degree object by a double.
Top
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.Multiply Operator (Double, Degree)

DegreeMultiply Operator (Double, Degree)

Multiplication of a double by a Degree object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree operator *(
    double left,
    Degree right
)
Public Shared Operator * (
    left As Double,
    right As Degree
) As Degree

Parameters

left
Type: SystemDouble
First of two parameters to multiply (multiplicand).
right
Type: Autodesk.GeometryDegree
Second of two parameters to multiply (multiplier).

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Multiply Overload
Autodesk.Geometry Namespace


Degree.Multiply Operator (Degree, Degree)

DegreeMultiply Operator (Degree, Degree)

Multiplication of two degrees objects.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree operator *(
    Degree left,
    Degree right
)
Public Shared Operator * (
    left As Degree,
    right As Degree
) As Degree

Parameters

left
Type: Autodesk.GeometryDegree
First of two Degree objects to be multiplied (multiplicand).
right
Type: Autodesk.GeometryDegree
Second of two Degree objects to be multiplied (multiplier).

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Multiply Overload
Autodesk.Geometry Namespace


Degree.Multiply Operator (Degree, Double)

DegreeMultiply Operator (Degree, Double)

Multiplication of a Degree object by a double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree operator *(
    Degree left,
    double right
)
Public Shared Operator * (
    left As Degree,
    right As Double
) As Degree

Parameters

left
Type: Autodesk.GeometryDegree
First of two parameters to multiply (multiplicand).
right
Type: SystemDouble
Second of two parameters to multiply (multiplier).

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Multiply Overload
Autodesk.Geometry Namespace


Degree.Subtraction Operator

DegreeSubtraction Operator

Subtract one Degree object from another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree operator -(
    Degree left,
    Degree right
)
Public Shared Operator - (
    left As Degree,
    right As Degree
) As Degree

Parameters

left
Type: Autodesk.GeometryDegree
Degree object from which to subtract (minuend).
right
Type: Autodesk.GeometryDegree
Degree object to subtract (subtrahend).

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


Degree.UnaryNegation Operator

DegreeUnaryNegation Operator

Negates the current value of the angle.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree operator -(
    Degree right
)
Public Shared Operator - (
    right As Degree
) As Degree

Parameters

right
Type: Autodesk.GeometryDegree
Degree object to negate.

Return Value

Type: Degree
New Degree object containing the result of the operation.
See Also

Reference

Degree Structure
Autodesk.Geometry Namespace


DMTFileException Class

Defines the exception to be thrown on DMT file errors.
Inheritance Hierarchy
SystemObject
SystemException
Autodesk.GeometryDMTFileException

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class DMTFileException : Exception
Public Class DMTFileException
    Inherits Exception

The DMTFileException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Textual representation of the error condition. (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Autodesk.Geometry Namespace


DMTFileException Properties

The DMTFileException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Textual representation of the error condition. (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DMTFileException Class
Autodesk.Geometry Namespace


DMTFileException.Message Property

DMTFileExceptionMessage Property

Textual representation of the error condition.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

DMTFileException Class
Autodesk.Geometry Namespace


DMTFileException Methods

The DMTFileException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DMTFileException Class
Autodesk.Geometry Namespace


DMTFileException Events

The DMTFileException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DMTFileException Class
Autodesk.Geometry Namespace


DMTModel Class

Handles the reading and writing of DMT files and facilitates the manipulation of triangles therein.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryDMTModel

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DMTModel
<SerializableAttribute>
Public Class DMTModel

The DMTModel type exposes the following members.

Constructors
 | Name | Description
Public method | DMTModel | Constructs an empty DMTModel and initialises an empty list of blocks.
Top
Properties
 | Name | Description
Public property | BoundingBox | Bounding box of the model.
Public property | TotalNoOfTriangles | Total number of Triangles (DMTTriangleBlock) that make up the model.
Public property | TotalNoOfVertices | Total number of vertices (DMTVertex) that make up the model.
Public property | TriangleBlocks | List of DMTTriangleBlock used by the model.
Public property | ZoneDensity | Zone density used by the model. Default is 5.
Public property | Zones | This is the list of triangle zones within the DMTModel. These are used during point projection.
Top
Methods
 | Name | Description
Public method | AddTriangleBlock | Adds a new Block to the list of blocks
Public method | Boundaries | Returns a list of Polylines representing the edges of the DMT. Note that if a STL is provided the number of boundaries will equal the number of triangles.
Public method | BoundaryNodes | Returns a point cloud of the DMT boundary points.
Public method | Clone | Returns a clone of the current Model.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the model by the specified Vector in the ActiveWorkplane - or in the world if none is set.
Public method | PointCloudFromTop | Creates a point cloud of all points that make up the "Top" surface of the DMT Model (i.e. those points that can be seen from above).
Public method | ProjectPoint | Projects a point onto the model in the Z axis and returns the nearest point to it.
Public method | ProjectPoints | Projects an array of points onto the model in the Z axis and returns the nearest point to each one.
Public method | RebaseFromWorkplane | Rebases the model from the specified workplane to the world.
Public method | RebaseToWorkplane | Rebases the model from the world to the specified workplane.
Public method | RotateAboutXAxis | Rotates the entire model by the speified angle about the X axis and about the specified origin in the ActiveWorkplane - or the world if none is set.
Public method | RotateAboutYAxis | Rotates the entire model by the speified angle about the Y axis and about the specified origin in the ActiveWorkplane - or the world if none is set.
Public method | RotateAboutZAxis | Rotates the entire model by the speified angle about the Z axis and about the specified origin in the ActiveWorkplane - or the world if none is set.
Public method | Scale(Double) | Uses the specified scalar to scale the model about the origin.
Public method | Scale(Point, Double) | Uses the specified scalar to scale the model about the specified origin.
Public method | Scale(Double, Double, Double) | Uses the specified scalars to scale the model about the origin.
Public method | Scale(Point, Double, Double, Double) | Uses the specified scalars to scale the model about the specified origin origin.
Public method | SurfaceFromTop | Creates a new model from all the points that make up the "Top" surface of the DMT Model (i.e. those triangles that can be seen in entirety from above).
Public method | ToPointCloud | Returns the model points as a PointCloud.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
A DMT Model contains many triangle blocks, with each block containing many vertices and triangles. Each vertex has a position, may have a normal and contains a list of indices referencing the triangles that connect to it. Each triangle has three indices referencing the vertices that comprise it.
See Also

Reference

Autodesk.Geometry Namespace


DMTModel Constructor

Constructs an empty DMTModel and initialises an empty list of blocks.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTModel()
Public Sub New
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel Properties

The DMTModel type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Bounding box of the model.
Public property | TotalNoOfTriangles | Total number of Triangles (DMTTriangleBlock) that make up the model.
Public property | TotalNoOfVertices | Total number of vertices (DMTVertex) that make up the model.
Public property | TriangleBlocks | List of DMTTriangleBlock used by the model.
Public property | ZoneDensity | Zone density used by the model. Default is 5.
Public property | Zones | This is the list of triangle zones within the DMTModel. These are used during point projection.
Top
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.BoundingBox Property

DMTModelBoundingBox Property

Bounding box of the model.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox BoundingBox { get; }
Public ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.TotalNoOfTriangles Property

DMTModelTotalNoOfTriangles Property

Total number of Triangles (DMTTriangleBlock) that make up the model.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public uint TotalNoOfTriangles { get; }
Public ReadOnly Property TotalNoOfTriangles As UInteger
    Get

Property Value

Type: UInt32
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.TotalNoOfVertices Property

DMTModelTotalNoOfVertices Property

Total number of vertices (DMTVertex) that make up the model.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public uint TotalNoOfVertices { get; }
Public ReadOnly Property TotalNoOfVertices As UInteger
    Get

Property Value

Type: UInt32
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.TriangleBlocks Property

DMTModelTriangleBlocks Property

List of DMTTriangleBlock used by the model.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<DMTTriangleBlock> TriangleBlocks { get; set; }
Public Property TriangleBlocks As List(Of DMTTriangleBlock)
    Get
    Set

Property Value

Type: List DMTTriangleBlock
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.ZoneDensity Property

DMTModelZoneDensity Property

Zone density used by the model. Default is 5.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int ZoneDensity { get; set; }
Public Property ZoneDensity As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.Zones Property

DMTModelZones Property

This is the list of triangle zones within the DMTModel. These are used during point projection.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<List<DMTTriangleZone>> Zones { get; set; }
Public Property Zones As List(Of List(Of DMTTriangleZone))
    Get
    Set

Property Value

Type: List List DMTTriangleZone
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel Methods

The DMTModel type exposes the following members.

Methods
 | Name | Description
Public method | AddTriangleBlock | Adds a new Block to the list of blocks
Public method | Boundaries | Returns a list of Polylines representing the edges of the DMT. Note that if a STL is provided the number of boundaries will equal the number of triangles.
Public method | BoundaryNodes | Returns a point cloud of the DMT boundary points.
Public method | Clone | Returns a clone of the current Model.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the model by the specified Vector in the ActiveWorkplane - or in the world if none is set.
Public method | PointCloudFromTop | Creates a point cloud of all points that make up the "Top" surface of the DMT Model (i.e. those points that can be seen from above).
Public method | ProjectPoint | Projects a point onto the model in the Z axis and returns the nearest point to it.
Public method | ProjectPoints | Projects an array of points onto the model in the Z axis and returns the nearest point to each one.
Public method | RebaseFromWorkplane | Rebases the model from the specified workplane to the world.
Public method | RebaseToWorkplane | Rebases the model from the world to the specified workplane.
Public method | RotateAboutXAxis | Rotates the entire model by the speified angle about the X axis and about the specified origin in the ActiveWorkplane - or the world if none is set.
Public method | RotateAboutYAxis | Rotates the entire model by the speified angle about the Y axis and about the specified origin in the ActiveWorkplane - or the world if none is set.
Public method | RotateAboutZAxis | Rotates the entire model by the speified angle about the Z axis and about the specified origin in the ActiveWorkplane - or the world if none is set.
Public method | Scale(Double) | Uses the specified scalar to scale the model about the origin.
Public method | Scale(Point, Double) | Uses the specified scalar to scale the model about the specified origin.
Public method | Scale(Double, Double, Double) | Uses the specified scalars to scale the model about the origin.
Public method | Scale(Point, Double, Double, Double) | Uses the specified scalars to scale the model about the specified origin origin.
Public method | SurfaceFromTop | Creates a new model from all the points that make up the "Top" surface of the DMT Model (i.e. those triangles that can be seen in entirety from above).
Public method | ToPointCloud | Returns the model points as a PointCloud.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.AddTriangleBlock Method

DMTModelAddTriangleBlock Method

Adds a new Block to the list of blocks

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddTriangleBlock(
    DMTTriangleBlock block
)
Public Sub AddTriangleBlock (
    block As DMTTriangleBlock
)

Parameters

block
Type: Autodesk.GeometryDMTTriangleBlock
Block to be added.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.Boundaries Method

DMTModelBoundaries Method

Returns a list of Polylines representing the edges of the DMT. Note that if a STL is provided the number of boundaries will equal the number of triangles.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Polyline> Boundaries()
Public Function Boundaries As List(Of Polyline)

Return Value

Type: List Polyline
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.BoundaryNodes Method

DMTModelBoundaryNodes Method

Returns a point cloud of the DMT boundary points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointCloud BoundaryNodes()
Public Function BoundaryNodes As PointCloud

Return Value

Type: PointCloud
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.Clone Method

DMTModelClone Method

Returns a clone of the current Model.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTModel Clone()
Public Function Clone As DMTModel

Return Value

Type: DMTModel
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.Move Method

DMTModelMove Method

Moves the model by the specified Vector in the ActiveWorkplane - or in the world if none is set.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Move(
    Vector offset
)
Public Sub Move (
    offset As Vector
)

Parameters

offset
Type: Autodesk.GeometryVector
Offset vector.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.PointCloudFromTop Method

DMTModelPointCloudFromTop Method

Creates a point cloud of all points that make up the "Top" surface of the DMT Model (i.e. those points that can be seen from above).

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointCloud PointCloudFromTop()
Public Function PointCloudFromTop As PointCloud

Return Value

Type: PointCloud
PointCloud object containing the points.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.ProjectPoint Method

DMTModelProjectPoint Method

Projects a point onto the model in the Z axis and returns the nearest point to it.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point ProjectPoint(
    Point objPoint,
    bool blnProjectDownOnly = false
)
Public Function ProjectPoint (
    objPoint As Point,
    Optional blnProjectDownOnly As Boolean = false
) As Point

Parameters

objPoint
Type: Autodesk.GeometryPoint
Point to project.
blnProjectDownOnly (Optional)
Type: SystemBoolean
If True, points above the point of projection are ignored.

Return Value

Type: Point
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.ProjectPoints Method

DMTModelProjectPoints Method

Projects an array of points onto the model in the Z axis and returns the nearest point to each one.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Point> ProjectPoints(
    List<Point> pointsToProject,
    bool projectDownOnly = false
)
Public Function ProjectPoints (
    pointsToProject As List(Of Point),
    Optional projectDownOnly As Boolean = false
) As List(Of Point)

Parameters

pointsToProject
Type: System.Collections.GenericList Point
List of the points to project.
projectDownOnly (Optional)
Type: SystemBoolean
If True, points above the point of projection are ignored.

Return Value

Type: List Point
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.RebaseFromWorkplane Method

DMTModelRebaseFromWorkplane Method

Rebases the model from the specified workplane to the world.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RebaseFromWorkplane(
    Workplane fromWorkplane
)
Public Sub RebaseFromWorkplane (
    fromWorkplane As Workplane
)

Parameters

fromWorkplane
Type: Autodesk.GeometryWorkplane
Source workplane.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.RebaseToWorkplane Method

DMTModelRebaseToWorkplane Method

Rebases the model from the world to the specified workplane.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RebaseToWorkplane(
    Workplane toWorkplane
)
Public Sub RebaseToWorkplane (
    toWorkplane As Workplane
)

Parameters

toWorkplane
Type: Autodesk.GeometryWorkplane
Target workplane.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.RotateAboutXAxis Method

DMTModelRotateAboutXAxis Method

Rotates the entire model by the speified angle about the X axis and about the specified origin in the ActiveWorkplane - or the world if none is set.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutXAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutXAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin of rotation.
angle
Type: Autodesk.GeometryRadian
Angle of rotation.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.RotateAboutYAxis Method

DMTModelRotateAboutYAxis Method

Rotates the entire model by the speified angle about the Y axis and about the specified origin in the ActiveWorkplane - or the world if none is set.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutYAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutYAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin of rotation.
angle
Type: Autodesk.GeometryRadian
Angle of rotation.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.RotateAboutZAxis Method

DMTModelRotateAboutZAxis Method

Rotates the entire model by the speified angle about the Z axis and about the specified origin in the ActiveWorkplane - or the world if none is set.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutZAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutZAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin of rotation.
angle
Type: Autodesk.GeometryRadian
Angle of rotation.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.Scale Method

DMTModelScale Method

Overload List
 | Name | Description
Public method | Scale(Double) | Uses the specified scalar to scale the model about the origin.
Public method | Scale(Point, Double) | Uses the specified scalar to scale the model about the specified origin.
Public method | Scale(Double, Double, Double) | Uses the specified scalars to scale the model about the origin.
Public method | Scale(Point, Double, Double, Double) | Uses the specified scalars to scale the model about the specified origin origin.
Top
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.Scale Method (Double)

DMTModelScale Method (Double)

Uses the specified scalar to scale the model about the origin.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    double scalar
)
Public Sub Scale (
    scalar As Double
)

Parameters

scalar
Type: SystemDouble
Scaling factor.
See Also

Reference

DMTModel Class
Scale Overload
Autodesk.Geometry Namespace


DMTModel.Scale Method (Point, Double)

DMTModelScale Method (Point, Double)

Uses the specified scalar to scale the model about the specified origin.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    Point origin,
    double scalar
)
Public Sub Scale (
    origin As Point,
    scalar As Double
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin about which to scale the model.
scalar
Type: SystemDouble
Scaling factor.
See Also

Reference

DMTModel Class
Scale Overload
Autodesk.Geometry Namespace


DMTModel.Scale Method (Double, Double, Double)

DMTModelScale Method (Double, Double, Double)

Uses the specified scalars to scale the model about the origin.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    double scalarX,
    double scalarY,
    double scalarZ
)
Public Sub Scale (
    scalarX As Double,
    scalarY As Double,
    scalarZ As Double
)

Parameters

scalarX
Type: SystemDouble
The factor by which to scale in X.
scalarY
Type: SystemDouble
The factor by which to scale in Y.
scalarZ
Type: SystemDouble
The factor by which to scale in Z.
See Also

Reference

DMTModel Class
Scale Overload
Autodesk.Geometry Namespace


DMTModel.Scale Method (Point, Double, Double, Double)

DMTModelScale Method (Point, Double, Double, Double)

Uses the specified scalars to scale the model about the specified origin origin.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    Point origin,
    double scalarX,
    double scalarY,
    double scalarZ
)
Public Sub Scale (
    origin As Point,
    scalarX As Double,
    scalarY As Double,
    scalarZ As Double
)

Parameters

origin
Type: Autodesk.GeometryPoint
The origin about which to scale.
scalarX
Type: SystemDouble
The factor by which to scale in X.
scalarY
Type: SystemDouble
The factor by which to scale in Y.
scalarZ
Type: SystemDouble
The factor by which to scale in Z.
See Also

Reference

DMTModel Class
Scale Overload
Autodesk.Geometry Namespace


DMTModel.SurfaceFromTop Method

DMTModelSurfaceFromTop Method

Creates a new model from all the points that make up the "Top" surface of the DMT Model (i.e. those triangles that can be seen in entirety from above).

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTModel SurfaceFromTop()
Public Function SurfaceFromTop As DMTModel

Return Value

Type: DMTModel
DMTModel object of the top surface.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModel.ToPointCloud Method

DMTModelToPointCloud Method

Returns the model points as a PointCloud.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointCloud ToPointCloud()
Public Function ToPointCloud As PointCloud

Return Value

Type: PointCloud
PointCloud object containing all model points.
See Also

Reference

DMTModel Class
Autodesk.Geometry Namespace


DMTModelReader Class

Reads a mesh file.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryDMTModelReader

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class DMTModelReader
Public Class DMTModelReader

The DMTModelReader type exposes the following members.

Constructors
 | Name | Description
Public method | DMTModelReader | Initializes a new instance of the DMTModelReader class
Top
Methods
 | Name | Description
 | AppendFile(DMTModel, File) | Appends the contents of the specified DMT file to the model.
 | AppendFile(DMTModel, File, IDMTModelFilter) | Appends the contents of the specified DMT file that obeys to a specified filter to the existing model.
 | AppendFile(DMTModel, File, IDMTModelFilter, DMTModel) | Appends the contents of the specified DMT file that obeys to a specified filter to the existing model.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadFile(File) | Reads a mesh file.
 | ReadFile(File, IDMTModelFilter) | Reads a mesh file filtered by filter.
 | ReadFile(File, IDMTModelFilter, DMTModel) | Reads a mesh file filtered by filter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry Namespace


DMTModelReader Constructor

Initializes a new instance of the DMTModelReader class

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTModelReader()
Public Sub New
See Also

Reference

DMTModelReader Class
Autodesk.Geometry Namespace


DMTModelReader Methods

The DMTModelReader type exposes the following members.

Methods
 | Name | Description
 | AppendFile(DMTModel, File) | Appends the contents of the specified DMT file to the model.
 | AppendFile(DMTModel, File, IDMTModelFilter) | Appends the contents of the specified DMT file that obeys to a specified filter to the existing model.
 | AppendFile(DMTModel, File, IDMTModelFilter, DMTModel) | Appends the contents of the specified DMT file that obeys to a specified filter to the existing model.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadFile(File) | Reads a mesh file.
 | ReadFile(File, IDMTModelFilter) | Reads a mesh file filtered by filter.
 | ReadFile(File, IDMTModelFilter, DMTModel) | Reads a mesh file filtered by filter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DMTModelReader Class
Autodesk.Geometry Namespace


DMTModelReader.AppendFile Method

DMTModelReaderAppendFile Method

Overload List
Name | Description
AppendFile(DMTModel, File) | Appends the contents of the specified DMT file to the model.
AppendFile(DMTModel, File, IDMTModelFilter) | Appends the contents of the specified DMT file that obeys to a specified filter to the existing model.
AppendFile(DMTModel, File, IDMTModelFilter, DMTModel) | Appends the contents of the specified DMT file that obeys to a specified filter to the existing model.
Top
See Also

Reference

DMTModelReader Class
Autodesk.Geometry Namespace


DMTModelReader.AppendFile Method (DMTModel, File)

DMTModelReaderAppendFile Method (DMTModel, File)

Appends the contents of the specified DMT file to the model.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void AppendFile(
    DMTModel dmtModel,
    File file
)
Public Shared Sub AppendFile (
    dmtModel As DMTModel,
    file As File
)

Parameters

dmtModel
Type: Autodesk.GeometryDMTModel
The DMTModel to append to.
file
Type: Autodesk.FileSystemFile
Path and filename of the DMT model.
Exceptions
Exception | Condition
DMTFileException | Thrown for any of the following reasons: Specified file does not exist. File format is unsupported. File contains no triangle blocks. File contains no vertices. File contains no triangles. Block version does not match file version.
See Also

Reference

DMTModelReader Class
AppendFile Overload
Autodesk.Geometry Namespace


DMTModelReader.AppendFile Method (DMTModel, File, IDMTModelFilter)

DMTModelReaderAppendFile Method (DMTModel, File, IDMTModelFilter)

Appends the contents of the specified DMT file that obeys to a specified filter to the existing model.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void AppendFile(
    DMTModel dmtModel,
    File file,
    IDMTModelFilter filter
)
Public Shared Sub AppendFile (
    dmtModel As DMTModel,
    file As File,
    filter As IDMTModelFilter
)

Parameters

dmtModel
Type: Autodesk.GeometryDMTModel
The DMTModel to append to.
file
Type: Autodesk.FileSystemFile
Path and filename of the DMT model.
filter
Type: Autodesk.GeometryIDMTModelFilter
The filterto filter by.
Exceptions
Exception | Condition
DMTFileException | Thrown for any of the following reasons: Specified file does not exist. File format is unsupported. File contains no triangle blocks. File contains no vertices. File contains no triangles. Block version does not match file version.
See Also

Reference

DMTModelReader Class
AppendFile Overload
Autodesk.Geometry Namespace


DMTModelReader.AppendFile Method (DMTModel, File, IDMTModelFilter, DMTModel)

DMTModelReaderAppendFile Method (DMTModel, File, IDMTModelFilter, DMTModel)

Appends the contents of the specified DMT file that obeys to a specified filter to the existing model.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void AppendFile(
    DMTModel dmtModel,
    File file,
    IDMTModelFilter filter,
    out DMTModel excludedModel
)
Public Shared Sub AppendFile (
    dmtModel As DMTModel,
    file As File,
    filter As IDMTModelFilter,
    <OutAttribute> ByRef excludedModel As DMTModel
)

Parameters

dmtModel
Type: Autodesk.GeometryDMTModel
The DMTModel to append to.
file
Type: Autodesk.FileSystemFile
Path and filename of the DMT model.
filter
Type: Autodesk.GeometryIDMTModelFilter
The filterto filter by.
excludedModel
Type: Autodesk.GeometryDMTModel
The DMTModel that doesn't obey to the filter condition.
Exceptions
Exception | Condition
DMTFileException | Thrown for any of the following reasons: Specified file does not exist. File format is unsupported. File contains no triangle blocks. File contains no vertices. File contains no triangles. Block version does not match file version.
See Also

Reference

DMTModelReader Class
AppendFile Overload
Autodesk.Geometry Namespace


DMTModelReader.ReadFile Method

DMTModelReaderReadFile Method

Overload List
Name | Description
ReadFile(File) | Reads a mesh file.
ReadFile(File, IDMTModelFilter) | Reads a mesh file filtered by filter.
ReadFile(File, IDMTModelFilter, DMTModel) | Reads a mesh file filtered by filter.
Top
See Also

Reference

DMTModelReader Class
Autodesk.Geometry Namespace


DMTModelReader.ReadFile Method (File)

DMTModelReaderReadFile Method (File)

Reads a mesh file.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static DMTModel ReadFile(
    File file
)
Public Shared Function ReadFile (
    file As File
) As DMTModel

Parameters

file
Type: Autodesk.FileSystemFile
The mesh file.

Return Value

Type: DMTModel
The DMTModel that represents the mesh file.
See Also

Reference

DMTModelReader Class
ReadFile Overload
Autodesk.Geometry Namespace


DMTModelReader.ReadFile Method (File, IDMTModelFilter)

DMTModelReaderReadFile Method (File, IDMTModelFilter)

Reads a mesh file filtered by filter.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static DMTModel ReadFile(
    File file,
    IDMTModelFilter filter
)
Public Shared Function ReadFile (
    file As File,
    filter As IDMTModelFilter
) As DMTModel

Parameters

file
Type: Autodesk.FileSystemFile
The mesh file.
filter
Type: Autodesk.GeometryIDMTModelFilter
The filter to filter by.

Return Value

Type: DMTModel
The DMTModel that represents the mesh that obeys to the filter condition.
Exceptions
Exception | Condition
DMTFileException | Thrown for any of the following reasons: Specified file does not exist. File format is unsupported. File contains no triangle blocks. File contains no vertices. File contains no triangles. Block version does not match file version.
See Also

Reference

DMTModelReader Class
ReadFile Overload
Autodesk.Geometry Namespace


DMTModelReader.ReadFile Method (File, IDMTModelFilter, DMTModel)

DMTModelReaderReadFile Method (File, IDMTModelFilter, DMTModel)

Reads a mesh file filtered by filter.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static DMTModel ReadFile(
    File file,
    IDMTModelFilter filter,
    out DMTModel excludedModel
)
Public Shared Function ReadFile (
    file As File,
    filter As IDMTModelFilter,
    <OutAttribute> ByRef excludedModel As DMTModel
) As DMTModel

Parameters

file
Type: Autodesk.FileSystemFile
The mesh file.
filter
Type: Autodesk.GeometryIDMTModelFilter
The filter to filter by.
excludedModel
Type: Autodesk.GeometryDMTModel
The DMTModel that doesn't obey to the filter condition.

Return Value

Type: DMTModel
The DMTModel that obeys to the filter condition.
Exceptions
Exception | Condition
DMTFileException | Thrown for any of the following reasons: Specified file does not exist. File format is unsupported. File contains no triangle blocks. File contains no vertices. File contains no triangles. Block version does not match file version.
See Also

Reference

DMTModelReader Class
ReadFile Overload
Autodesk.Geometry Namespace


DMTModelWriter Class

Writes a DMTModel model to a file.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryDMTModelWriter

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class DMTModelWriter
Public Class DMTModelWriter

The DMTModelWriter type exposes the following members.

Constructors
 | Name | Description
Public method | DMTModelWriter | Initializes a new instance of the DMTModelWriter class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WriteFile | Write the contents of the model into the specified file. If the provided file is a DMT file, it will use the DMT file writer. If the provided file is a STL file, it will use a STL file writer.
Top
See Also

Reference

Autodesk.Geometry Namespace


DMTModelWriter Constructor

Initializes a new instance of the DMTModelWriter class

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTModelWriter()
Public Sub New
See Also

Reference

DMTModelWriter Class
Autodesk.Geometry Namespace


DMTModelWriter Methods

The DMTModelWriter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WriteFile | Write the contents of the model into the specified file. If the provided file is a DMT file, it will use the DMT file writer. If the provided file is a STL file, it will use a STL file writer.
Top
See Also

Reference

DMTModelWriter Class
Autodesk.Geometry Namespace


DMTModelWriter.WriteFile Method

DMTModelWriterWriteFile Method

Write the contents of the model into the specified file. If the provided file is a DMT file, it will use the DMT file writer. If the provided file is a STL file, it will use a STL file writer.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void WriteFile(
    DMTModel dmtModel,
    File file
)
Public Shared Sub WriteFile (
    dmtModel As DMTModel,
    file As File
)

Parameters

dmtModel
Type: Autodesk.GeometryDMTModel
The DMTModel to write.
file
Type: Autodesk.FileSystemFile
Destination file.
See Also

Reference

DMTModelWriter Class
Autodesk.Geometry Namespace


DMTTriangle Class

Encapsulates a triangle. One or more triangles constitute a block.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryDMTTriangle

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DMTTriangle
<SerializableAttribute>
Public Class DMTTriangle

The DMTTriangle type exposes the following members.

Constructors
 | Name | Description
Public method | DMTTriangle | Constructs a DMTTriangle with the specified vertex indices.
Top
Properties
 | Name | Description
Public property | Vertex1 | Index of vertex 1.
Public property | Vertex2 | Index of vertex 2.
Public property | Vertex3 | Index of vertex 3.
Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this triangle.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCentroid | Gets triangle centroid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormal(DMTTriangleBlock) | Returns a vector normal to the surface of the triangle.
 | GetNormal(Point, Point, Point) | Returns a unit normal vector to the surface of the triangle.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry Namespace


DMTTriangle Constructor

Constructs a DMTTriangle with the specified vertex indices.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangle(
    int vertex1,
    int vertex2,
    int vertex3
)
Public Sub New (
    vertex1 As Integer,
    vertex2 As Integer,
    vertex3 As Integer
)

Parameters

vertex1
Type: SystemInt32
Vertex index 1.
vertex2
Type: SystemInt32
Vertex index 2.
vertex3
Type: SystemInt32
Vertex index 3.
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle Properties

The DMTTriangle type exposes the following members.

Properties
 | Name | Description
Public property | Vertex1 | Index of vertex 1.
Public property | Vertex2 | Index of vertex 2.
Public property | Vertex3 | Index of vertex 3.
Top
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle.Vertex1 Property

DMTTriangleVertex1 Property

Index of vertex 1.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Vertex1 { get; set; }
Public Property Vertex1 As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle.Vertex2 Property

DMTTriangleVertex2 Property

Index of vertex 2.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Vertex2 { get; set; }
Public Property Vertex2 As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle.Vertex3 Property

DMTTriangleVertex3 Property

Index of vertex 3.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Vertex3 { get; set; }
Public Property Vertex3 As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle Methods

The DMTTriangle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a clone of this triangle.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCentroid | Gets triangle centroid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormal(DMTTriangleBlock) | Returns a vector normal to the surface of the triangle.
 | GetNormal(Point, Point, Point) | Returns a unit normal vector to the surface of the triangle.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle.Clone Method

DMTTriangleClone Method

Returns a clone of this triangle.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangle Clone()
Public Function Clone As DMTTriangle

Return Value

Type: DMTTriangle
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle.GetCentroid Method

DMTTriangleGetCentroid Method

Gets triangle centroid.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Point GetCentroid(
    Point vertex1,
    Point vertex2,
    Point vertex3
)
Public Shared Function GetCentroid (
    vertex1 As Point,
    vertex2 As Point,
    vertex3 As Point
) As Point

Parameters

vertex1
Type: Autodesk.GeometryPoint
Triangle Vertex.
vertex2
Type: Autodesk.GeometryPoint
Second vertex.
vertex3
Type: Autodesk.GeometryPoint
Third vertex.

Return Value

Type: Point
The point that represents the centroid of the triangle.
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle.GetNormal Method

DMTTriangleGetNormal Method

Overload List
 | Name | Description
Public method | GetNormal(DMTTriangleBlock) | Returns a vector normal to the surface of the triangle.
 | GetNormal(Point, Point, Point) | Returns a unit normal vector to the surface of the triangle.
Top
See Also

Reference

DMTTriangle Class
Autodesk.Geometry Namespace


DMTTriangle.GetNormal Method (DMTTriangleBlock)

DMTTriangleGetNormal Method (DMTTriangleBlock)

Returns a vector normal to the surface of the triangle.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetNormal(
    DMTTriangleBlock block
)
Public Function GetNormal (
    block As DMTTriangleBlock
) As Vector

Parameters

block
Type: Autodesk.GeometryDMTTriangleBlock
Block containing this triangle is part of.

Return Value

Type: Vector
See Also

Reference

DMTTriangle Class
GetNormal Overload
Autodesk.Geometry Namespace


DMTTriangle.GetNormal Method (Point, Point, Point)

DMTTriangleGetNormal Method (Point, Point, Point)

Returns a unit normal vector to the surface of the triangle.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Vector GetNormal(
    Point vertex1,
    Point vertex2,
    Point vertex3
)
Public Shared Function GetNormal (
    vertex1 As Point,
    vertex2 As Point,
    vertex3 As Point
) As Vector

Parameters

vertex1
Type: Autodesk.GeometryPoint
Point for the first triangle vertex.
vertex2
Type: Autodesk.GeometryPoint
Point for the second triangle vertex.
vertex3
Type: Autodesk.GeometryPoint
Point for the third triangle vertex.

Return Value

Type: Vector
The unit normal vector for the triangle.
Remarks
See Also

Reference

DMTTriangle Class
GetNormal Overload
Autodesk.Geometry Namespace


DMTTriangleBlock Class

Represents a block of triangles. One or more blocks make up a DMT model.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryDMTTriangleBlock

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DMTTriangleBlock
<SerializableAttribute>
Public Class DMTTriangleBlock

The DMTTriangleBlock type exposes the following members.

Constructors
 | Name | Description
Public method | DMTTriangleBlock | Constructs an empty DMTTriangleBlock.
Public method | DMTTriangleBlock(ListDMTTriangle, ListDMTVertex, Boolean) | Constructs a DMTTriangleBlock and populates it with the passed list of triangles and vertices.
Top
Properties
 | Name | Description
Public property | DoVerticesHaveNormals | If True, vertices have IJK normals. False otherwise.
Public property | Flags | Gets the flags for the Block. 1 if nodes have normals, 0 otherwise
Public property | NoOfTriangles | Number of triangles in a block.
Public property | NoOfVertices | Number of vertices in a block.
Public property | Triangles | Gets the triangles of a triangle block.
Public property | VertexNormals | List of all the vertex normals.
Public property | Vertices | Gets the vertices of a triangle block.
Top
Methods
 | Name | Description
Public method | AddTriangle(Int32, Int32, Int32) | Adds a triangle to the block using vertex indices.
Public method | AddTriangle(Point, Point, Point) | Adds a triangle to the block using the vertex points.
Public method | AddVertex | Manually add a vertex to your triangle block
Public method | Clone | Returns a clone of this block.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormal | Returns the vector normal of the first triangle with that vertex.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry Namespace


DMTTriangleBlock Constructor

Overload List
 | Name | Description
Public method | DMTTriangleBlock | Constructs an empty DMTTriangleBlock.
Public method | DMTTriangleBlock(ListDMTTriangle, ListDMTVertex, Boolean) | Constructs a DMTTriangleBlock and populates it with the passed list of triangles and vertices.
Top
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock Constructor

Constructs an empty DMTTriangleBlock.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangleBlock()
Public Sub New
See Also

Reference

DMTTriangleBlock Class
DMTTriangleBlock Overload
Autodesk.Geometry Namespace


DMTTriangleBlock Constructor (List(DMTTriangle), List(DMTVertex), Boolean)

DMTTriangleBlock Constructor (ListDMTTriangle, ListDMTVertex, Boolean)

Constructs a DMTTriangleBlock and populates it with the passed list of triangles and vertices.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangleBlock(
    List<DMTTriangle> triangles,
    List<DMTVertex> vertices,
    bool nodesHaveIJK
)
Public Sub New (
    triangles As List(Of DMTTriangle),
    vertices As List(Of DMTVertex),
    nodesHaveIJK As Boolean
)

Parameters

triangles
Type: System.Collections.GenericList DMTTriangle
List of triangles with which to populate the block.
vertices
Type: System.Collections.GenericList DMTVertex
List of vertices.
nodesHaveIJK
Type: SystemBoolean
If True, vertices have IJK vector normals.
See Also

Reference

DMTTriangleBlock Class
DMTTriangleBlock Overload
Autodesk.Geometry Namespace


DMTTriangleBlock Properties

The DMTTriangleBlock type exposes the following members.

Properties
 | Name | Description
Public property | DoVerticesHaveNormals | If True, vertices have IJK normals. False otherwise.
Public property | Flags | Gets the flags for the Block. 1 if nodes have normals, 0 otherwise
Public property | NoOfTriangles | Number of triangles in a block.
Public property | NoOfVertices | Number of vertices in a block.
Public property | Triangles | Gets the triangles of a triangle block.
Public property | VertexNormals | List of all the vertex normals.
Public property | Vertices | Gets the vertices of a triangle block.
Top
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.DoVerticesHaveNormals Property

DMTTriangleBlockDoVerticesHaveNormals Property

If True, vertices have IJK normals. False otherwise.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool DoVerticesHaveNormals { get; set; }
Public Property DoVerticesHaveNormals As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.Flags Property

DMTTriangleBlockFlags Property

Gets the flags for the Block. 1 if nodes have normals, 0 otherwise

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public uint Flags { get; }
Public ReadOnly Property Flags As UInteger
    Get

Property Value

Type: UInt32
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.NoOfTriangles Property

DMTTriangleBlockNoOfTriangles Property

Number of triangles in a block.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NoOfTriangles { get; }
Public ReadOnly Property NoOfTriangles As Integer
    Get

Property Value

Type: Int32
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.NoOfVertices Property

DMTTriangleBlockNoOfVertices Property

Number of vertices in a block.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NoOfVertices { get; }
Public ReadOnly Property NoOfVertices As Integer
    Get

Property Value

Type: Int32
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.Triangles Property

DMTTriangleBlockTriangles Property

Gets the triangles of a triangle block.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public IEnumerable Triangles { get; }
Public ReadOnly Property Triangles As IEnumerable
    Get

Property Value

Type: IEnumerable
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.VertexNormals Property

DMTTriangleBlockVertexNormals Property

List of all the vertex normals.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Vector> VertexNormals { get; set; }
Public Property VertexNormals As List(Of Vector)
    Get
    Set

Property Value

Type: List Vector
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.Vertices Property

DMTTriangleBlockVertices Property

Gets the vertices of a triangle block.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public IEnumerable Vertices { get; }
Public ReadOnly Property Vertices As IEnumerable
    Get

Property Value

Type: IEnumerable
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock Methods

The DMTTriangleBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddTriangle(Int32, Int32, Int32) | Adds a triangle to the block using vertex indices.
Public method | AddTriangle(Point, Point, Point) | Adds a triangle to the block using the vertex points.
Public method | AddVertex | Manually add a vertex to your triangle block
Public method | Clone | Returns a clone of this block.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormal | Returns the vector normal of the first triangle with that vertex.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.AddTriangle Method

DMTTriangleBlockAddTriangle Method

Overload List
 | Name | Description
Public method | AddTriangle(Int32, Int32, Int32) | Adds a triangle to the block using vertex indices.
Public method | AddTriangle(Point, Point, Point) | Adds a triangle to the block using the vertex points.
Top
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.AddTriangle Method (Int32, Int32, Int32)

DMTTriangleBlockAddTriangle Method (Int32, Int32, Int32)

Adds a triangle to the block using vertex indices.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddTriangle(
    int vertex1Index,
    int vertex2Index,
    int vertex3Index
)
Public Sub AddTriangle (
    vertex1Index As Integer,
    vertex2Index As Integer,
    vertex3Index As Integer
)

Parameters

vertex1Index
Type: SystemInt32
The first vertex index.
vertex2Index
Type: SystemInt32
The second vertex index.
vertex3Index
Type: SystemInt32
The third vertex index.
Remarks
See Also

Reference

DMTTriangleBlock Class
AddTriangle Overload
Autodesk.Geometry Namespace


DMTTriangleBlock.AddTriangle Method (Point, Point, Point)

DMTTriangleBlockAddTriangle Method (Point, Point, Point)

Adds a triangle to the block using the vertex points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddTriangle(
    Point vertex1,
    Point vertex2,
    Point vertex3
)
Public Sub AddTriangle (
    vertex1 As Point,
    vertex2 As Point,
    vertex3 As Point
)

Parameters

vertex1
Type: Autodesk.GeometryPoint
The first vertex.
vertex2
Type: Autodesk.GeometryPoint
The second vertex.
vertex3
Type: Autodesk.GeometryPoint
The third vertex.
Remarks
See Also

Reference

DMTTriangleBlock Class
AddTriangle Overload
Autodesk.Geometry Namespace


DMTTriangleBlock.AddVertex Method

DMTTriangleBlockAddVertex Method

Manually add a vertex to your triangle block

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddVertex(
    Point vertex
)
Public Sub AddVertex (
    vertex As Point
)

Parameters

vertex
Type: Autodesk.GeometryPoint
The vertex to add.
Remarks
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.Clone Method

DMTTriangleBlockClone Method

Returns a clone of this block.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangleBlock Clone()
Public Function Clone As DMTTriangleBlock

Return Value

Type: DMTTriangleBlock
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleBlock.GetNormal Method

DMTTriangleBlockGetNormal Method

Returns the vector normal of the first triangle with that vertex.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetNormal(
    Point vertex
)
Public Function GetNormal (
    vertex As Point
) As Vector

Parameters

vertex
Type: Autodesk.GeometryPoint

[Missing <param name="vertex"/> documentation for "M:Autodesk.Geometry.DMTTriangleBlock.GetNormal(Autodesk.Geometry.Point)"]

Return Value

Type: Vector
The normal for the first triangle with specified vertex.
Remarks
See Also

Reference

DMTTriangleBlock Class
Autodesk.Geometry Namespace


DMTTriangleZone Class

Encapsulates the list of triangles that constitute a zone of the model. Zoning a model increases performance when projecting a point onto the model in the Z axis.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryDMTTriangleZone

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DMTTriangleZone
<SerializableAttribute>
Public Class DMTTriangleZone

The DMTTriangleZone type exposes the following members.

Constructors
 | Name | Description
Public method | DMTTriangleZone | Constructs an empty DMTTriangleZone.
Public method | DMTTriangleZone(ListDMTTriangleZoneEntry) | Constructs a DMTTriangleZone and populates it with the passed list.
Top
Properties
 | Name | Description
Public property | Triangles | List of triangles that constitute the zone.
Top
Methods
 | Name | Description
Public method | AddTriangle | Adds a triangle to the zone.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry Namespace


DMTTriangleZone Constructor

Overload List
 | Name | Description
Public method | DMTTriangleZone | Constructs an empty DMTTriangleZone.
Public method | DMTTriangleZone(ListDMTTriangleZoneEntry) | Constructs a DMTTriangleZone and populates it with the passed list.
Top
See Also

Reference

DMTTriangleZone Class
Autodesk.Geometry Namespace


DMTTriangleZone Constructor

Constructs an empty DMTTriangleZone.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangleZone()
Public Sub New
See Also

Reference

DMTTriangleZone Class
DMTTriangleZone Overload
Autodesk.Geometry Namespace


DMTTriangleZone Constructor (List(DMTTriangleZoneEntry))

DMTTriangleZone Constructor (ListDMTTriangleZoneEntry)

Constructs a DMTTriangleZone and populates it with the passed list.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangleZone(
    List<DMTTriangleZoneEntry> triangles
)
Public Sub New (
    triangles As List(Of DMTTriangleZoneEntry)
)

Parameters

triangles
Type: System.Collections.GenericList DMTTriangleZoneEntry
List of triangles with which to populate the zone.
See Also

Reference

DMTTriangleZone Class
DMTTriangleZone Overload
Autodesk.Geometry Namespace


DMTTriangleZone Properties

The DMTTriangleZone type exposes the following members.

Properties
 | Name | Description
Public property | Triangles | List of triangles that constitute the zone.
Top
See Also

Reference

DMTTriangleZone Class
Autodesk.Geometry Namespace


DMTTriangleZone.Triangles Property

DMTTriangleZoneTriangles Property

List of triangles that constitute the zone.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<DMTTriangleZoneEntry> Triangles { get; set; }
Public Property Triangles As List(Of DMTTriangleZoneEntry)
    Get
    Set

Property Value

Type: List DMTTriangleZoneEntry
See Also

Reference

DMTTriangleZone Class
Autodesk.Geometry Namespace


DMTTriangleZone Methods

The DMTTriangleZone type exposes the following members.

Methods
 | Name | Description
Public method | AddTriangle | Adds a triangle to the zone.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DMTTriangleZone Class
Autodesk.Geometry Namespace


DMTTriangleZone.AddTriangle Method

DMTTriangleZoneAddTriangle Method

Adds a triangle to the zone.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddTriangle(
    DMTTriangleZoneEntry triangle
)
Public Sub AddTriangle (
    triangle As DMTTriangleZoneEntry
)

Parameters

triangle
Type: Autodesk.GeometryDMTTriangleZoneEntry
Triangle to add.
See Also

Reference

DMTTriangleZone Class
Autodesk.Geometry Namespace


DMTTriangleZoneEntry Class

Encapsulates the indices of both block and triangle for the list of triangles that constitute a zone of the model.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryDMTTriangleZoneEntry

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DMTTriangleZoneEntry
<SerializableAttribute>
Public Class DMTTriangleZoneEntry

The DMTTriangleZoneEntry type exposes the following members.

Constructors
 | Name | Description
Public method | DMTTriangleZoneEntry | Default Constructor. Initialises both block and triangle indices to invalid values.
Public method | DMTTriangleZoneEntry(Int32, Int32) | Initialises indices of both block and triangle to the specified values.
Top
Properties
 | Name | Description
Public property | Block | Index of the block that contains the triangle.
Public property | Triangle | Index of the triangle within the block.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry Namespace


DMTTriangleZoneEntry Constructor

Overload List
 | Name | Description
Public method | DMTTriangleZoneEntry | Default Constructor. Initialises both block and triangle indices to invalid values.
Public method | DMTTriangleZoneEntry(Int32, Int32) | Initialises indices of both block and triangle to the specified values.
Top
See Also

Reference

DMTTriangleZoneEntry Class
Autodesk.Geometry Namespace


DMTTriangleZoneEntry Constructor

Default Constructor. Initialises both block and triangle indices to invalid values.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangleZoneEntry()
Public Sub New
See Also

Reference

DMTTriangleZoneEntry Class
DMTTriangleZoneEntry Overload
Autodesk.Geometry Namespace


DMTTriangleZoneEntry Constructor (Int32, Int32)

Initialises indices of both block and triangle to the specified values.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTTriangleZoneEntry(
    int block,
    int triangle
)
Public Sub New (
    block As Integer,
    triangle As Integer
)

Parameters

block
Type: SystemInt32
Block index.
triangle
Type: SystemInt32
Triangle index.
See Also

Reference

DMTTriangleZoneEntry Class
DMTTriangleZoneEntry Overload
Autodesk.Geometry Namespace


DMTTriangleZoneEntry Properties

The DMTTriangleZoneEntry type exposes the following members.

Properties
 | Name | Description
Public property | Block | Index of the block that contains the triangle.
Public property | Triangle | Index of the triangle within the block.
Top
See Also

Reference

DMTTriangleZoneEntry Class
Autodesk.Geometry Namespace


DMTTriangleZoneEntry.Block Property

DMTTriangleZoneEntryBlock Property

Index of the block that contains the triangle.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Block { get; set; }
Public Property Block As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DMTTriangleZoneEntry Class
Autodesk.Geometry Namespace


DMTTriangleZoneEntry.Triangle Property

DMTTriangleZoneEntryTriangle Property

Index of the triangle within the block.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Triangle { get; set; }
Public Property Triangle As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DMTTriangleZoneEntry Class
Autodesk.Geometry Namespace


DMTTriangleZoneEntry Methods

The DMTTriangleZoneEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DMTTriangleZoneEntry Class
Autodesk.Geometry Namespace


DMTVertex Class

Encapsulates DMT mesh vertices. A vertex has a position, a normal and 'knows' what triangles it is a part of.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryDMTVertex

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DMTVertex : IEquatable<DMTVertex>
<SerializableAttribute>
Public Class DMTVertex
    Implements IEquatable(Of DMTVertex)

The DMTVertex type exposes the following members.

Constructors
 | Name | Description
Public method | DMTVertex(Point) | Initialises the vertex position to the specified value.
Public method | DMTVertex(Point, Vector) | Initialises vertex position and normal to the specified values.
Public method | DMTVertex(MM, MM, MM) | Initialises the vertex position to the specified values.
Public method | DMTVertex(MM, MM, MM, MM, MM, MM) | Initialises the vertex position and the IJK components of the normal to the values specified.
Top
Properties
 | Name | Description
Public property | Position | Vertex position.
Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this vertex.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(DMTVertex) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry Namespace


DMTVertex Constructor

Overload List
 | Name | Description
Public method | DMTVertex(Point) | Initialises the vertex position to the specified value.
Public method | DMTVertex(Point, Vector) | Initialises vertex position and normal to the specified values.
Public method | DMTVertex(MM, MM, MM) | Initialises the vertex position to the specified values.
Public method | DMTVertex(MM, MM, MM, MM, MM, MM) | Initialises the vertex position and the IJK components of the normal to the values specified.
Top
See Also

Reference

DMTVertex Class
Autodesk.Geometry Namespace


DMTVertex Constructor (Point)

Initialises the vertex position to the specified value.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTVertex(
    Point position
)
Public Sub New (
    position As Point
)

Parameters

position
Type: Autodesk.GeometryPoint
Captures vertex position in three axes.
See Also

Reference

DMTVertex Class
DMTVertex Overload
Autodesk.Geometry Namespace


DMTVertex Constructor (Point, Vector)

Initialises vertex position and normal to the specified values.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTVertex(
    Point position,
    Vector normal
)
Public Sub New (
    position As Point,
    normal As Vector
)

Parameters

position
Type: Autodesk.GeometryPoint
Captures vertex position in three axes.
normal
Type: Autodesk.GeometryVector
Vector normal to the vertex.
See Also

Reference

DMTVertex Class
DMTVertex Overload
Autodesk.Geometry Namespace


DMTVertex Constructor (MM, MM, MM)

Initialises the vertex position to the specified values.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTVertex(
    MM x,
    MM y,
    MM z
)
Public Sub New (
    x As MM,
    y As MM,
    z As MM
)

Parameters

x
Type: Autodesk.GeometryMM
Position in X.
y
Type: Autodesk.GeometryMM
Position in Y.
z
Type: Autodesk.GeometryMM
Position in Z.
See Also

Reference

DMTVertex Class
DMTVertex Overload
Autodesk.Geometry Namespace


DMTVertex Constructor (MM, MM, MM, MM, MM, MM)

Initialises the vertex position and the IJK components of the normal to the values specified.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTVertex(
    MM x,
    MM y,
    MM z,
    MM i,
    MM j,
    MM k
)
Public Sub New (
    x As MM,
    y As MM,
    z As MM,
    i As MM,
    j As MM,
    k As MM
)

Parameters

x
Type: Autodesk.GeometryMM
Vertex position in X.
y
Type: Autodesk.GeometryMM
Vertex position in Y.
z
Type: Autodesk.GeometryMM
Vertex position in Z.
i
Type: Autodesk.GeometryMM
I component of the normal vector.
j
Type: Autodesk.GeometryMM
J component of the normal vector.
k
Type: Autodesk.GeometryMM
K component of the normal vector.
See Also

Reference

DMTVertex Class
DMTVertex Overload
Autodesk.Geometry Namespace


DMTVertex Properties

The DMTVertex type exposes the following members.

Properties
 | Name | Description
Public property | Position | Vertex position.
Top
See Also

Reference

DMTVertex Class
Autodesk.Geometry Namespace


DMTVertex.Position Property

DMTVertexPosition Property

Vertex position.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

DMTVertex Class
Autodesk.Geometry Namespace


DMTVertex Methods

The DMTVertex type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a clone of this vertex.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(DMTVertex) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DMTVertex Class
Autodesk.Geometry Namespace


DMTVertex.Clone Method

DMTVertexClone Method

Returns a clone of this vertex.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTVertex Clone()
Public Function Clone As DMTVertex

Return Value

Type: DMTVertex
See Also

Reference

DMTVertex Class
Autodesk.Geometry Namespace


DMTVertex.Equals Method

DMTVertexEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(DMTVertex) |
Top
See Also

Reference

DMTVertex Class
Autodesk.Geometry Namespace


DMTVertex.Equals Method (DMTVertex)

DMTVertexEquals Method (DMTVertex)

[Missing <summary> documentation for "M:Autodesk.Geometry.DMTVertex.Equals(Autodesk.Geometry.DMTVertex)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    DMTVertex other
)
Public Function Equals (
    other As DMTVertex
) As Boolean

Parameters

other
Type: Autodesk.GeometryDMTVertex

[Missing <param name="other"/> documentation for "M:Autodesk.Geometry.DMTVertex.Equals(Autodesk.Geometry.DMTVertex)"]

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

DMTVertex Class
Equals Overload
Autodesk.Geometry Namespace


IDMTModelFilter Interface

Allows to apply a filter for a DMTModel.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IDMTModelFilter
Public Interface IDMTModelFilter

The IDMTModelFilter type exposes the following members.

Methods
 | Name | Description
Public method | CanAddTriangle | Checks if a triangle can be added to the DMTModel.
Top
See Also

Reference

Autodesk.Geometry Namespace


IDMTModelFilter Methods

The IDMTModelFilter type exposes the following members.

Methods
 | Name | Description
Public method | CanAddTriangle | Checks if a triangle can be added to the DMTModel.
Top
See Also

Reference

IDMTModelFilter Interface
Autodesk.Geometry Namespace


IDMTModelFilter.CanAddTriangle Method

IDMTModelFilterCanAddTriangle Method

Checks if a triangle can be added to the DMTModel.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
bool CanAddTriangle(
    Point vertex1,
    Point vertex2,
    Point vertex3
)
Function CanAddTriangle (
    vertex1 As Point,
    vertex2 As Point,
    vertex3 As Point
) As Boolean

Parameters

vertex1
Type: Autodesk.GeometryPoint
The 1st triangle vertex.
vertex2
Type: Autodesk.GeometryPoint
The 2nd triangle vertex.
vertex3
Type: Autodesk.GeometryPoint
The 3rd triangle vertex.

Return Value

Type: Boolean
Returns true if triangle obeys to the filter conditions, returns false otherwise.
See Also

Reference

IDMTModelFilter Interface
Autodesk.Geometry Namespace


Inch Structure

Encapsulates length measured in inches and the operations thereon.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct Inch : IFormattable
<SerializableAttribute>
Public Structure Inch
    Implements IFormattable

The Inch type exposes the following members.

Constructors
 | Name | Description
Public method | Inch | Constructs an Inch object and initialises it to the specified length.
Top
Properties
 | Name | Description
Public property | Value | Length in Inches.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type MM or Inch, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type MM or Inch, false will be returned.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the value of this object as a string. (Overrides ValueTypeToString.)
Public method | ToString(String) | Returns the value of this object as a formatted string.
Public method | ToString(String, IFormatProvider) | Returns the value of this object in its equivalent string representation using the specified format and culture-specific format information.
Top
Operators
Name | Description
Addition | Returns the sum ot two Inch objects.
Division(Inch, Inch) | Divides one Inch object by another.
Division(Inch, Double) |
Equality | Compares two Inch objects for equivalence and returns true if they are within one 100,000th of an inch.
(Inch to Double) | Casts an Inch object to Double.
(Inch to Single) | Casts an Inch object to Single.
(Inch to Decimal) | Casts an Inch object to Decimal.
GreaterThan | Determines whether one Inch object is greater than another.
GreaterThanOrEqual | Determines whether one Inch object is greater than or equal to another.
(Double to Inch) | Casts a Double to an Inch object.
(MM to Inch) | Casts a MM (millimetre) object to an Inch object.
Inequality | Compares two Inch objects and returns True if the difference between them is greater than one 100,000th of an inch. I.e. they are unequal.
LessThan | Determines whether one Inch object is less than another.
LessThanOrEqual | Determines whether one Inch object is less than or equal to another.
Multiply(Double, Inch) |
Multiply(Inch, Inch) | Multiplies two Inch objects together.
Multiply(Inch, Double) |
Subtraction | Subtracts one Inch object from another.
UnaryNegation | Negates the Inch object to the right of the operator.
Top
See Also

Reference

Autodesk.Geometry Namespace


Inch Constructor

Constructs an Inch object and initialises it to the specified length.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Inch(
    double length
)
Public Sub New (
    length As Double
)

Parameters

length
Type: SystemDouble
Initial value of the structure.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch Properties

The Inch type exposes the following members.

Properties
 | Name | Description
Public property | Value | Length in Inches.
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.Value Property

InchValue Property

Length in Inches.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch Methods

The Inch type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type MM or Inch, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type MM or Inch, false will be returned.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the value of this object as a string. (Overrides ValueTypeToString.)
Public method | ToString(String) | Returns the value of this object as a formatted string.
Public method | ToString(String, IFormatProvider) | Returns the value of this object in its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.Equals Method

InchEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type MM or Inch, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type MM or Inch, false will be returned.
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.Equals Method (Object)

InchEquals Method (Object)

Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type MM or Inch, false will be returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Object with which to compare this.

Return Value

Type: Boolean
True if the magnitudes of this and the specified object are equivalent; false otherwise.
See Also

Reference

Inch Structure
Equals Overload
Autodesk.Geometry Namespace


Inch.Equals Method (Object, Int32)

InchEquals Method (Object, Int32)

Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type MM or Inch, false will be returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    Object obj,
    int nDecPts
)
Public Function Equals (
    obj As Object,
    nDecPts As Integer
) As Boolean

Parameters

obj
Type: SystemObject
Object with which to compare this.
nDecPts
Type: SystemInt32
Number of decimal places to compare.

Return Value

Type: Boolean
True if the magnitudes of this and the specified object are considered equivalent; false otherwise.
See Also

Reference

Inch Structure
Equals Overload
Autodesk.Geometry Namespace


Inch.ToString Method

InchToString Method

Overload List
 | Name | Description
Public method | ToString | Returns the value of this object as a string. (Overrides ValueTypeToString.)
Public method | ToString(String) | Returns the value of this object as a formatted string.
Public method | ToString(String, IFormatProvider) | Returns the value of this object in its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.ToString Method

InchToString Method

Returns the value of this object as a string.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

Inch Structure
ToString Overload
Autodesk.Geometry Namespace


Inch.ToString Method (String)

InchToString Method (String)

Returns the value of this object as a formatted string.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String

Parameters

format
Type: SystemString
Standard format specifier with which to format the string.

Return Value

Type: String
See Also

Reference

Inch Structure
ToString Overload
Autodesk.Geometry Namespace


Inch.ToString Method (String, IFormatProvider)

InchToString Method (String, IFormatProvider)

Returns the value of this object in its equivalent string representation using the specified format and culture-specific format information.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    string format,
    IFormatProvider fp
)
Public Function ToString (
    format As String,
    fp As IFormatProvider
) As String

Parameters

format
Type: SystemString
Standard numeric format specifier.
fp
Type: SystemIFormatProvider
Custom object implementing the IFormatProvider interface.

Return Value

Type: String

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Inch Structure
ToString Overload
Autodesk.Geometry Namespace


Inch Operators and Type Conversions

The Inch type exposes the following members.

Operators
Name | Description
Addition | Returns the sum ot two Inch objects.
Division(Inch, Inch) | Divides one Inch object by another.
Division(Inch, Double) |
Equality | Compares two Inch objects for equivalence and returns true if they are within one 100,000th of an inch.
(Inch to Double) | Casts an Inch object to Double.
(Inch to Single) | Casts an Inch object to Single.
(Inch to Decimal) | Casts an Inch object to Decimal.
GreaterThan | Determines whether one Inch object is greater than another.
GreaterThanOrEqual | Determines whether one Inch object is greater than or equal to another.
(Double to Inch) | Casts a Double to an Inch object.
(MM to Inch) | Casts a MM (millimetre) object to an Inch object.
Inequality | Compares two Inch objects and returns True if the difference between them is greater than one 100,000th of an inch. I.e. they are unequal.
LessThan | Determines whether one Inch object is less than another.
LessThanOrEqual | Determines whether one Inch object is less than or equal to another.
Multiply(Double, Inch) |
Multiply(Inch, Inch) | Multiplies two Inch objects together.
Multiply(Inch, Double) |
Subtraction | Subtracts one Inch object from another.
UnaryNegation | Negates the Inch object to the right of the operator.
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.Addition Operator

InchAddition Operator

Returns the sum ot two Inch objects.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Inch operator +(
    Inch left,
    Inch right
)
Public Shared Operator + (
    left As Inch,
    right As Inch
) As Inch

Parameters

left
Type: Autodesk.GeometryInch
Left value to sum.
right
Type: Autodesk.GeometryInch
Right value to sum.

Return Value

Type: Inch
Sum of the two Inch operands.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.Division Operator

InchDivision Operator

Overload List
Name | Description
Division(Inch, Inch) | Divides one Inch object by another.
Division(Inch, Double) |
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.Division Operator (Inch, Inch)

InchDivision Operator (Inch, Inch)

Divides one Inch object by another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double operator /(
    Inch left,
    Inch right
)
Public Shared Operator / (
    left As Inch,
    right As Inch
) As Double

Parameters

left
Type: Autodesk.GeometryInch
Inch object to divide (dividend).
right
Type: Autodesk.GeometryInch
Inch object to divide with (divisor).

Return Value

Type: Double
Quotient resulting from the operation.
See Also

Reference

Inch Structure
Division Overload
Autodesk.Geometry Namespace


Inch.Division Operator (Inch, Double)

InchDivision Operator (Inch, Double)

[Missing <summary> documentation for "M:Autodesk.Geometry.Inch.op_Division(Autodesk.Geometry.Inch,System.Double)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Inch operator /(
    Inch left,
    double right
)
Public Shared Operator / (
    left As Inch,
    right As Double
) As Inch

Parameters

left
Type: Autodesk.GeometryInch
Inch object to divide (dividend).
right
Type: SystemDouble
Double to divide by (divisor).

Return Value

Type: Inch
Result of the division.
See Also

Reference

Inch Structure
Division Overload
Autodesk.Geometry Namespace


Inch.Equality Operator

InchEquality Operator

Compares two Inch objects for equivalence and returns true if they are within one 100,000th of an inch.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator ==(
    Inch left,
    Inch right
)
Public Shared Operator = (
    left As Inch,
    right As Inch
) As Boolean

Parameters

left
Type: Autodesk.GeometryInch
First of two Inch objects.
right
Type: Autodesk.GeometryInch
Second of two Inch objects.

Return Value

Type: Boolean
True if the operands are considered equivalent; false otherwise.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch Explicit Conversion Operators

Inch Conversion Operators

Overload List
Name | Description
(Inch to Double) | Casts an Inch object to Double.
(Inch to Single) | Casts an Inch object to Single.
(Inch to Decimal) | Casts an Inch object to Decimal.
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch Explicit Conversion (Inch to Double)

Inch Conversion (Inch to Double)

Casts an Inch object to Double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator double (
    Inch left
)
Public Shared Narrowing Operator CType (
    left As Inch
) As Double

Parameters

left
Type: Autodesk.GeometryInch
Inch object to cast.

Return Value

Type: Double
Double representation of the Inch object.
See Also

Reference

Inch Structure
Overload
Autodesk.Geometry Namespace


Inch Explicit Conversion (Inch to Single)

Inch Conversion (Inch to Single)

Casts an Inch object to Single.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator float (
    Inch left
)
Public Shared Narrowing Operator CType (
    left As Inch
) As Single

Parameters

left
Type: Autodesk.GeometryInch
Inch object to cast.

Return Value

Type: Single
Single representation of the Inch object.
See Also

Reference

Inch Structure
Overload
Autodesk.Geometry Namespace


Inch Explicit Conversion (Inch to Decimal)

Inch Conversion (Inch to Decimal)

Casts an Inch object to Decimal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator decimal (
    Inch left
)
Public Shared Narrowing Operator CType (
    left As Inch
) As Decimal

Parameters

left
Type: Autodesk.GeometryInch
Inch object to cast.

Return Value

Type: Decimal
Decimal representation of the Inch object.
See Also

Reference

Inch Structure
Overload
Autodesk.Geometry Namespace


Inch.GreaterThan Operator

InchGreaterThan Operator

Determines whether one Inch object is greater than another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >(
    Inch left,
    Inch right
)
Public Shared Operator > (
    left As Inch,
    right As Inch
) As Boolean

Parameters

left
Type: Autodesk.GeometryInch
First Inch object.
right
Type: Autodesk.GeometryInch
Second Inch object.

Return Value

Type: Boolean
True if the left-hand Inch object is greater than the right; false otherwise.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.GreaterThanOrEqual Operator

InchGreaterThanOrEqual Operator

Determines whether one Inch object is greater than or equal to another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >=(
    Inch left,
    Inch right
)
Public Shared Operator >= (
    left As Inch,
    right As Inch
) As Boolean

Parameters

left
Type: Autodesk.GeometryInch
First Inch object.
right
Type: Autodesk.GeometryInch
Second Inch object.

Return Value

Type: Boolean
True if the left-hand Inch object is greater than or equal to the right; false otherwise.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch Implicit Conversion Operators

Inch Conversion Operators

Overload List
Name | Description
(Double to Inch) | Casts a Double to an Inch object.
(MM to Inch) | Casts a MM (millimetre) object to an Inch object.
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch Implicit Conversion (Double to Inch)

Inch Conversion (Double to Inch)

Casts a Double to an Inch object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator Inch (
    double left
)
Public Shared Widening Operator CType (
    left As Double
) As Inch

Parameters

left
Type: SystemDouble
Double to be cast.

Return Value

Type: Inch
New Inch object containing the result of the operation.
See Also

Reference

Inch Structure
Overload
Autodesk.Geometry Namespace


Inch Implicit Conversion (MM to Inch)

Inch Conversion (MM to Inch)

Casts a MM (millimetre) object to an Inch object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator Inch (
    MM left
)
Public Shared Widening Operator CType (
    left As MM
) As Inch

Parameters

left
Type: Autodesk.GeometryMM
MM object to cast.

Return Value

Type: Inch
New Inch object containing the result of the operation.
See Also

Reference

Inch Structure
Overload
Autodesk.Geometry Namespace


Inch.Inequality Operator

InchInequality Operator

Compares two Inch objects and returns True if the difference between them is greater than one 100,000th of an inch. I.e. they are unequal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator !=(
    Inch left,
    Inch right
)
Public Shared Operator <> (
    left As Inch,
    right As Inch
) As Boolean

Parameters

left
Type: Autodesk.GeometryInch
First of two Inch objects.
right
Type: Autodesk.GeometryInch
Second of two Inch objects.

Return Value

Type: Boolean
True if the operands are considered unequal; false otherwise.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.LessThan Operator

InchLessThan Operator

Determines whether one Inch object is less than another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <(
    Inch left,
    Inch right
)
Public Shared Operator < (
    left As Inch,
    right As Inch
) As Boolean

Parameters

left
Type: Autodesk.GeometryInch
First Inch object.
right
Type: Autodesk.GeometryInch
Second Inch object.

Return Value

Type: Boolean
True if the left-hand Inch object is less than the right; false otherwise.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.LessThanOrEqual Operator

InchLessThanOrEqual Operator

Determines whether one Inch object is less than or equal to another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <=(
    Inch left,
    Inch right
)
Public Shared Operator <= (
    left As Inch,
    right As Inch
) As Boolean

Parameters

left
Type: Autodesk.GeometryInch
First Inch object.
right
Type: Autodesk.GeometryInch
Second Inch object.

Return Value

Type: Boolean
True if the left-hand Inch object is less than or equal to the right; false otherwise.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.Multiply Operator

InchMultiply Operator

Overload List
Name | Description
Multiply(Double, Inch) |
Multiply(Inch, Inch) | Multiplies two Inch objects together.
Multiply(Inch, Double) |
Top
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.Multiply Operator (Double, Inch)

InchMultiply Operator (Double, Inch)

[Missing <summary> documentation for "M:Autodesk.Geometry.Inch.op_Multiply(System.Double,Autodesk.Geometry.Inch)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Inch operator *(
    double left,
    Inch right
)
Public Shared Operator * (
    left As Double,
    right As Inch
) As Inch

Parameters

left
Type: SystemDouble
A dobule scalar.
right
Type: Autodesk.GeometryInch
The Inch object.

Return Value

Type: Inch
Product of the multiplication.
See Also

Reference

Inch Structure
Multiply Overload
Autodesk.Geometry Namespace


Inch.Multiply Operator (Inch, Inch)

InchMultiply Operator (Inch, Inch)

Multiplies two Inch objects together.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double operator *(
    Inch left,
    Inch right
)
Public Shared Operator * (
    left As Inch,
    right As Inch
) As Double

Parameters

left
Type: Autodesk.GeometryInch
First of two Inch objects.
right
Type: Autodesk.GeometryInch
Second of two Inch objects.

Return Value

Type: Double
Product of the multiplication.
See Also

Reference

Inch Structure
Multiply Overload
Autodesk.Geometry Namespace


Inch.Multiply Operator (Inch, Double)

InchMultiply Operator (Inch, Double)

[Missing <summary> documentation for "M:Autodesk.Geometry.Inch.op_Multiply(Autodesk.Geometry.Inch,System.Double)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Inch operator *(
    Inch left,
    double right
)
Public Shared Operator * (
    left As Inch,
    right As Double
) As Inch

Parameters

left
Type: Autodesk.GeometryInch
The Inch object.
right
Type: SystemDouble
A dobule scalar.

Return Value

Type: Inch
Product of the multiplication.
See Also

Reference

Inch Structure
Multiply Overload
Autodesk.Geometry Namespace


Inch.Subtraction Operator

InchSubtraction Operator

Subtracts one Inch object from another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Inch operator -(
    Inch left,
    Inch right
)
Public Shared Operator - (
    left As Inch,
    right As Inch
) As Inch

Parameters

left
Type: Autodesk.GeometryInch
Object from which to subtract (minuend).
right
Type: Autodesk.GeometryInch
Object to subtract (subtrahend).

Return Value

Type: Inch
Inch object containing the result.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Inch.UnaryNegation Operator

InchUnaryNegation Operator

Negates the Inch object to the right of the operator.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Inch operator -(
    Inch right
)
Public Shared Operator - (
    right As Inch
) As Inch

Parameters

right
Type: Autodesk.GeometryInch
Inch object to negate.

Return Value

Type: Inch
Inch object containing the result of the operation.
See Also

Reference

Inch Structure
Autodesk.Geometry Namespace


Line Class

Encapsulates a straight line.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryLine

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Line
<SerializableAttribute>
Public Class Line

The Line type exposes the following members.

Constructors
 | Name | Description
Public method | Line | Constructs a Line between the specified start and end points.
Top
Properties
 | Name | Description
Public property | BoundingBox | Returns the bounding box of the line.
Public property | EndPoint | Line ends here.
Public property | MidPoint | Centre of the line.
Public property | StartPoint | Line starts here.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Determins whether two line segments intersect.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry Namespace


Line Constructor

Constructs a Line between the specified start and end points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Line(
    Point startPoint,
    Point endPoint
)
Public Sub New (
    startPoint As Point,
    endPoint As Point
)

Parameters

startPoint
Type: Autodesk.GeometryPoint
Start point.
endPoint
Type: Autodesk.GeometryPoint
End point.
See Also

Reference

Line Class
Autodesk.Geometry Namespace


Line Properties

The Line type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Returns the bounding box of the line.
Public property | EndPoint | Line ends here.
Public property | MidPoint | Centre of the line.
Public property | StartPoint | Line starts here.
Top
See Also

Reference

Line Class
Autodesk.Geometry Namespace


Line.BoundingBox Property

LineBoundingBox Property

Returns the bounding box of the line.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox BoundingBox { get; }
Public ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

Line Class
Autodesk.Geometry Namespace


Line.EndPoint Property

LineEndPoint Property

Line ends here.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point EndPoint { get; set; }
Public Property EndPoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

Line Class
Autodesk.Geometry Namespace


Line.MidPoint Property

LineMidPoint Property

Centre of the line.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point MidPoint { get; }
Public ReadOnly Property MidPoint As Point
    Get

Property Value

Type: Point
See Also

Reference

Line Class
Autodesk.Geometry Namespace


Line.StartPoint Property

LineStartPoint Property

Line starts here.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point StartPoint { get; set; }
Public Property StartPoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

Line Class
Autodesk.Geometry Namespace


Line Methods

The Line type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Determins whether two line segments intersect.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Line Class
Autodesk.Geometry Namespace


Line.Intersects Method

LineIntersects Method

Determins whether two line segments intersect.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Intersects(
    Line secondLine
)
Public Function Intersects (
    secondLine As Line
) As Boolean

Parameters

secondLine
Type: Autodesk.GeometryLine

[Missing <param name="secondLine"/> documentation for "M:Autodesk.Geometry.Line.Intersects(Autodesk.Geometry.Line)"]

Return Value

Type: Boolean
See Also

Reference

Line Class
Autodesk.Geometry Namespace


MM Structure

Encapsulates length measured in millimetres and the operations thereon.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct MM : IFormattable, IComparable
<SerializableAttribute>
Public Structure MM
    Implements IFormattable, IComparable

The MM type exposes the following members.

Properties
 | Name | Description
Public property | Value | Length in MM.
Top
Methods
 | Name | Description
Public method | CompareTo | Required for MM to implement IComparable.
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type MM or Inch, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type MM or Inch, false will be returned.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the value of this object as a string. (Overrides ValueTypeToString.)
Public method | ToString(String) | Returns the value of this object as a formatted string.
Public method | ToString(String, IFormatProvider) | Returns the value of this object in its equivalent string representation using the specified format and culture-specific format information.
Top
Operators
Name | Description
Addition(Int32, MM) | Adds a Int32 and an MM.
Addition(String, MM) | Returns the result of concatenating the specified string with the string representation of the specified MM object. The specified string is added to the result first.
Addition(MM, MM) | Returns the sum of two MM objects.
Addition(MM, Int32) | Adds an MM and a Int32.
Addition(MM, String) | Returns the string result of concatenating the string representation of the specified MM object with the specified string. The MM object is added to the result first.
Division(Int32, MM) | Divide the left-hand Int32 object by a MM.
Division(MM, MM) | Divide the left-hand MM object by the right.
Division(MM, Double) | Divide the left-hand MM object by a double.
Division(MM, Int32) | Divide the left-hand MM object by a Int32.
Equality | Returns True if the two specified MM objects are equal.
(MM to Single) | Casts an MM object to Single.
(MM to Decimal) | Casts an MM object to Decimal.
(MM to Int32) | Casts an MM object to int.
GreaterThan | Determines whether one MM object is greater than another.
GreaterThanOrEqual | Determines whether one MM object is greater than or equal to another.
(Double to MM) | Casts a Double to an MM object.
(Inch to MM) | Casts an Inch object to a MM object.
(MM to Double) | Casts an MM object to a Double.
Inequality | Compares two MM objects and returns True if they are unequal.
LessThan | Determines whether one MM object is less than another.
LessThanOrEqual | Determines whether one MM object is less than or equal to another.
Multiply(Double, MM) | Multiplies a MM by a double.
Multiply(Int32, MM) | Multiplies a MM by a Double.
Multiply(MM, MM) | Multiplies two MM objects together.
Multiply(MM, Double) | Multiplies a MM by a double.
Multiply(MM, Int32) | Multiplies a MM by a Int32.
Subtraction(Int32, MM) | Subtracts one MM object from a Int32.
Subtraction(MM, MM) | Subtracts one MM object from another.
Subtraction(MM, Int32) | Subtracts a Int32 from one MM object.
UnaryNegation | Negates the MM object to the right of the operator.
Top
See Also

Reference

Autodesk.Geometry Namespace


MM Properties

The MM type exposes the following members.

Properties
 | Name | Description
Public property | Value | Length in MM.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Value Property

MMValue Property

Length in MM.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM Methods

The MM type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Required for MM to implement IComparable.
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type MM or Inch, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type MM or Inch, false will be returned.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the value of this object as a string. (Overrides ValueTypeToString.)
Public method | ToString(String) | Returns the value of this object as a formatted string.
Public method | ToString(String, IFormatProvider) | Returns the value of this object in its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.CompareTo Method

MMCompareTo Method

Required for MM to implement IComparable.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: SystemObject
Object to compare.

Return Value

Type: Int32

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | Thrown if the object to compare is not of type MM.
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Equals Method

MMEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type MM or Inch, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type MM or Inch, false will be returned.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Equals Method (Object)

MMEquals Method (Object)

Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type MM or Inch, false will be returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Object with which to compare this.

Return Value

Type: Boolean
True if the magnitudes of this and the specified object are equivalent; false otherwise.
See Also

Reference

MM Structure
Equals Overload
Autodesk.Geometry Namespace


MM.Equals Method (Object, Int32)

MMEquals Method (Object, Int32)

Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type MM or Inch, false will be returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    Object obj,
    int nDecPts
)
Public Function Equals (
    obj As Object,
    nDecPts As Integer
) As Boolean

Parameters

obj
Type: SystemObject
Object with which to compare this.
nDecPts
Type: SystemInt32
Number of decimal places to compare.

Return Value

Type: Boolean
True if the magnitudes of this and the specified object are considered equivalent; false otherwise.
See Also

Reference

MM Structure
Equals Overload
Autodesk.Geometry Namespace


MM.ToString Method

MMToString Method

Overload List
 | Name | Description
Public method | ToString | Returns the value of this object as a string. (Overrides ValueTypeToString.)
Public method | ToString(String) | Returns the value of this object as a formatted string.
Public method | ToString(String, IFormatProvider) | Returns the value of this object in its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.ToString Method

MMToString Method

Returns the value of this object as a string.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

MM Structure
ToString Overload
Autodesk.Geometry Namespace


MM.ToString Method (String)

MMToString Method (String)

Returns the value of this object as a formatted string.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String

Parameters

format
Type: SystemString
Standard format specifier with which to format the string.

Return Value

Type: String
See Also

Reference

MM Structure
ToString Overload
Autodesk.Geometry Namespace


MM.ToString Method (String, IFormatProvider)

MMToString Method (String, IFormatProvider)

Returns the value of this object in its equivalent string representation using the specified format and culture-specific format information.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    string format,
    IFormatProvider fp
)
Public Function ToString (
    format As String,
    fp As IFormatProvider
) As String

Parameters

format
Type: SystemString
Standard numeric format specifier.
fp
Type: SystemIFormatProvider
Custom object implementing the IFormatProvider interface.

Return Value

Type: String

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

MM Structure
ToString Overload
Autodesk.Geometry Namespace


MM Operators and Type Conversions

The MM type exposes the following members.

Operators
Name | Description
Addition(Int32, MM) | Adds a Int32 and an MM.
Addition(String, MM) | Returns the result of concatenating the specified string with the string representation of the specified MM object. The specified string is added to the result first.
Addition(MM, MM) | Returns the sum of two MM objects.
Addition(MM, Int32) | Adds an MM and a Int32.
Addition(MM, String) | Returns the string result of concatenating the string representation of the specified MM object with the specified string. The MM object is added to the result first.
Division(Int32, MM) | Divide the left-hand Int32 object by a MM.
Division(MM, MM) | Divide the left-hand MM object by the right.
Division(MM, Double) | Divide the left-hand MM object by a double.
Division(MM, Int32) | Divide the left-hand MM object by a Int32.
Equality | Returns True if the two specified MM objects are equal.
(MM to Single) | Casts an MM object to Single.
(MM to Decimal) | Casts an MM object to Decimal.
(MM to Int32) | Casts an MM object to int.
GreaterThan | Determines whether one MM object is greater than another.
GreaterThanOrEqual | Determines whether one MM object is greater than or equal to another.
(Double to MM) | Casts a Double to an MM object.
(Inch to MM) | Casts an Inch object to a MM object.
(MM to Double) | Casts an MM object to a Double.
Inequality | Compares two MM objects and returns True if they are unequal.
LessThan | Determines whether one MM object is less than another.
LessThanOrEqual | Determines whether one MM object is less than or equal to another.
Multiply(Double, MM) | Multiplies a MM by a double.
Multiply(Int32, MM) | Multiplies a MM by a Double.
Multiply(MM, MM) | Multiplies two MM objects together.
Multiply(MM, Double) | Multiplies a MM by a double.
Multiply(MM, Int32) | Multiplies a MM by a Int32.
Subtraction(Int32, MM) | Subtracts one MM object from a Int32.
Subtraction(MM, MM) | Subtracts one MM object from another.
Subtraction(MM, Int32) | Subtracts a Int32 from one MM object.
UnaryNegation | Negates the MM object to the right of the operator.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Addition Operator

MMAddition Operator

Overload List
Name | Description
Addition(Int32, MM) | Adds a Int32 and an MM.
Addition(String, MM) | Returns the result of concatenating the specified string with the string representation of the specified MM object. The specified string is added to the result first.
Addition(MM, MM) | Returns the sum of two MM objects.
Addition(MM, Int32) | Adds an MM and a Int32.
Addition(MM, String) | Returns the string result of concatenating the string representation of the specified MM object with the specified string. The MM object is added to the result first.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Addition Operator (Int32, MM)

MMAddition Operator (Int32, MM)

Adds a Int32 and an MM.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator +(
    int left,
    MM right
)
Public Shared Operator + (
    left As Integer,
    right As MM
) As MM

Parameters

left
Type: SystemInt32
Left value to sum.
right
Type: Autodesk.GeometryMM
Right value to sum.

Return Value

Type: MM
Sum of the add operation.
See Also

Reference

MM Structure
Addition Overload
Autodesk.Geometry Namespace


MM.Addition Operator (String, MM)

MMAddition Operator (String, MM)

Returns the result of concatenating the specified string with the string representation of the specified MM object. The specified string is added to the result first.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string operator +(
    string left,
    MM right
)
Public Shared Operator + (
    left As String,
    right As MM
) As String

Parameters

left
Type: SystemString
First of two operands.
right
Type: Autodesk.GeometryMM
Second of two operands.

Return Value

Type: String
Result of the concatenation.
See Also

Reference

MM Structure
Addition Overload
Autodesk.Geometry Namespace


MM.Addition Operator (MM, MM)

MMAddition Operator (MM, MM)

Returns the sum of two MM objects.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator +(
    MM left,
    MM right
)
Public Shared Operator + (
    left As MM,
    right As MM
) As MM

Parameters

left
Type: Autodesk.GeometryMM
Left value to sum.
right
Type: Autodesk.GeometryMM
Right value to sum.

Return Value

Type: MM
Sum of the two MM operands.
See Also

Reference

MM Structure
Addition Overload
Autodesk.Geometry Namespace


MM.Addition Operator (MM, Int32)

MMAddition Operator (MM, Int32)

Adds an MM and a Int32.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator +(
    MM left,
    int right
)
Public Shared Operator + (
    left As MM,
    right As Integer
) As MM

Parameters

left
Type: Autodesk.GeometryMM
Left value to sum.
right
Type: SystemInt32
Right value to sum.

Return Value

Type: MM
Sum of the add operation.
See Also

Reference

MM Structure
Addition Overload
Autodesk.Geometry Namespace


MM.Addition Operator (MM, String)

MMAddition Operator (MM, String)

Returns the string result of concatenating the string representation of the specified MM object with the specified string. The MM object is added to the result first.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string operator +(
    MM left,
    string right
)
Public Shared Operator + (
    left As MM,
    right As String
) As String

Parameters

left
Type: Autodesk.GeometryMM
First of two operands.
right
Type: SystemString
Second of two operands.

Return Value

Type: String
Result of the concatenation.
See Also

Reference

MM Structure
Addition Overload
Autodesk.Geometry Namespace


MM.Division Operator

MMDivision Operator

Overload List
Name | Description
Division(Int32, MM) | Divide the left-hand Int32 object by a MM.
Division(MM, MM) | Divide the left-hand MM object by the right.
Division(MM, Double) | Divide the left-hand MM object by a double.
Division(MM, Int32) | Divide the left-hand MM object by a Int32.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Division Operator (Int32, MM)

MMDivision Operator (Int32, MM)

Divide the left-hand Int32 object by a MM.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double operator /(
    int left,
    MM right
)
Public Shared Operator / (
    left As Integer,
    right As MM
) As Double

Parameters

left
Type: SystemInt32
Int to divide (dividend).
right
Type: Autodesk.GeometryMM
MM object to divide by (divisor).

Return Value

Type: Double
Result of the division.
See Also

Reference

MM Structure
Division Overload
Autodesk.Geometry Namespace


MM.Division Operator (MM, MM)

MMDivision Operator (MM, MM)

Divide the left-hand MM object by the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double operator /(
    MM left,
    MM right
)
Public Shared Operator / (
    left As MM,
    right As MM
) As Double

Parameters

left
Type: Autodesk.GeometryMM
MM object to divide (dividend).
right
Type: Autodesk.GeometryMM
MM object to divide with (divisor).

Return Value

Type: Double
Result of the division.
See Also

Reference

MM Structure
Division Overload
Autodesk.Geometry Namespace


MM.Division Operator (MM, Double)

MMDivision Operator (MM, Double)

Divide the left-hand MM object by a double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator /(
    MM left,
    double right
)
Public Shared Operator / (
    left As MM,
    right As Double
) As MM

Parameters

left
Type: Autodesk.GeometryMM
MM object to divide (dividend).
right
Type: SystemDouble
Double to divide by (divisor).

Return Value

Type: MM
Result of the division.
See Also

Reference

MM Structure
Division Overload
Autodesk.Geometry Namespace


MM.Division Operator (MM, Int32)

MMDivision Operator (MM, Int32)

Divide the left-hand MM object by a Int32.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator /(
    MM left,
    int right
)
Public Shared Operator / (
    left As MM,
    right As Integer
) As MM

Parameters

left
Type: Autodesk.GeometryMM
MM object to divide (dividend).
right
Type: SystemInt32
Int to divide by (divisor).

Return Value

Type: MM
Result of the division.
See Also

Reference

MM Structure
Division Overload
Autodesk.Geometry Namespace


MM.Equality Operator

MMEquality Operator

Returns True if the two specified MM objects are equal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator ==(
    MM left,
    MM right
)
Public Shared Operator = (
    left As MM,
    right As MM
) As Boolean

Parameters

left
Type: Autodesk.GeometryMM
First of two MM objects.
right
Type: Autodesk.GeometryMM
Second of two MM objects.

Return Value

Type: Boolean
True if the operands are equivalent in magnitude; false otherwise.
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM Explicit Conversion Operators

MM Conversion Operators

Overload List
Name | Description
(MM to Single) | Casts an MM object to Single.
(MM to Decimal) | Casts an MM object to Decimal.
(MM to Int32) | Casts an MM object to int.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM Explicit Conversion (MM to Single)

MM Conversion (MM to Single)

Casts an MM object to Single.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator float (
    MM left
)
Public Shared Narrowing Operator CType (
    left As MM
) As Single

Parameters

left
Type: Autodesk.GeometryMM
MM object to cast.

Return Value

Type: Single
Single representation of the MM object.
See Also

Reference

MM Structure
Overload
Autodesk.Geometry Namespace


MM Explicit Conversion (MM to Decimal)

MM Conversion (MM to Decimal)

Casts an MM object to Decimal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator decimal (
    MM left
)
Public Shared Narrowing Operator CType (
    left As MM
) As Decimal

Parameters

left
Type: Autodesk.GeometryMM
MM object to cast.

Return Value

Type: Decimal
Decimal representation of the MM object.
See Also

Reference

MM Structure
Overload
Autodesk.Geometry Namespace


MM Explicit Conversion (MM to Int32)

MM Conversion (MM to Int32)

Casts an MM object to int.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator int (
    MM left
)
Public Shared Narrowing Operator CType (
    left As MM
) As Integer

Parameters

left
Type: Autodesk.GeometryMM
MM object to cast.

Return Value

Type: Int32
Decimal representation of the MM object.
See Also

Reference

MM Structure
Overload
Autodesk.Geometry Namespace


MM.GreaterThan Operator

MMGreaterThan Operator

Determines whether one MM object is greater than another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >(
    MM left,
    MM right
)
Public Shared Operator > (
    left As MM,
    right As MM
) As Boolean

Parameters

left
Type: Autodesk.GeometryMM
First MM object.
right
Type: Autodesk.GeometryMM
Second MM object.

Return Value

Type: Boolean
True if the left-hand MM object is greater than the right; false otherwise.
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.GreaterThanOrEqual Operator

MMGreaterThanOrEqual Operator

Determines whether one MM object is greater than or equal to another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >=(
    MM left,
    MM right
)
Public Shared Operator >= (
    left As MM,
    right As MM
) As Boolean

Parameters

left
Type: Autodesk.GeometryMM
First MM object.
right
Type: Autodesk.GeometryMM
Second MM object.

Return Value

Type: Boolean
True if the left-hand MM object is greater than or equal to the right; false otherwise.
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM Implicit Conversion Operators

MM Conversion Operators

Overload List
Name | Description
(Double to MM) | Casts a Double to an MM object.
(Inch to MM) | Casts an Inch object to a MM object.
(MM to Double) | Casts an MM object to a Double.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM Implicit Conversion (Double to MM)

MM Conversion (Double to MM)

Casts a Double to an MM object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator MM (
    double left
)
Public Shared Widening Operator CType (
    left As Double
) As MM

Parameters

left
Type: SystemDouble
Double to be cast.

Return Value

Type: MM
New MM object containing the result of the operation.
See Also

Reference

MM Structure
Overload
Autodesk.Geometry Namespace


MM Implicit Conversion (Inch to MM)

MM Conversion (Inch to MM)

Casts an Inch object to a MM object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator MM (
    Inch left
)
Public Shared Widening Operator CType (
    left As Inch
) As MM

Parameters

left
Type: Autodesk.GeometryInch
Inch object to cast.

Return Value

Type: MM
New MM object containing the result of the operation.
See Also

Reference

MM Structure
Overload
Autodesk.Geometry Namespace


MM Implicit Conversion (MM to Double)

MM Conversion (MM to Double)

Casts an MM object to a Double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator double (
    MM left
)
Public Shared Widening Operator CType (
    left As MM
) As Double

Parameters

left
Type: Autodesk.GeometryMM
MM object to cast.

Return Value

Type: Double
Double representation of the MM object.
See Also

Reference

MM Structure
Overload
Autodesk.Geometry Namespace


MM.Inequality Operator

MMInequality Operator

Compares two MM objects and returns True if they are unequal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator !=(
    MM left,
    MM right
)
Public Shared Operator <> (
    left As MM,
    right As MM
) As Boolean

Parameters

left
Type: Autodesk.GeometryMM
First of two MM objects.
right
Type: Autodesk.GeometryMM
Second of two MM objects.

Return Value

Type: Boolean
True if the operands are unequal in magnitude; false otherwise.
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.LessThan Operator

MMLessThan Operator

Determines whether one MM object is less than another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <(
    MM left,
    MM right
)
Public Shared Operator < (
    left As MM,
    right As MM
) As Boolean

Parameters

left
Type: Autodesk.GeometryMM
First MM object.
right
Type: Autodesk.GeometryMM
Second MM object.

Return Value

Type: Boolean
True if the left-hand MM object is less than the right; false otherwise.
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.LessThanOrEqual Operator

MMLessThanOrEqual Operator

Determines whether one MM object is less than or equal to another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <=(
    MM left,
    MM right
)
Public Shared Operator <= (
    left As MM,
    right As MM
) As Boolean

Parameters

left
Type: Autodesk.GeometryMM
First MM object.
right
Type: Autodesk.GeometryMM
Second MM object.

Return Value

Type: Boolean
True if the left-hand MM object is less than or equal to the right; false otherwise.
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Multiply Operator

MMMultiply Operator

Overload List
Name | Description
Multiply(Double, MM) | Multiplies a MM by a double.
Multiply(Int32, MM) | Multiplies a MM by a Double.
Multiply(MM, MM) | Multiplies two MM objects together.
Multiply(MM, Double) | Multiplies a MM by a double.
Multiply(MM, Int32) | Multiplies a MM by a Int32.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Multiply Operator (Double, MM)

MMMultiply Operator (Double, MM)

Multiplies a MM by a double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator *(
    double left,
    MM right
)
Public Shared Operator * (
    left As Double,
    right As MM
) As MM

Parameters

left
Type: SystemDouble
A dobule scalar.
right
Type: Autodesk.GeometryMM
The MM object.

Return Value

Type: MM
Product of the multiplication.
See Also

Reference

MM Structure
Multiply Overload
Autodesk.Geometry Namespace


MM.Multiply Operator (Int32, MM)

MMMultiply Operator (Int32, MM)

Multiplies a MM by a Double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator *(
    int left,
    MM right
)
Public Shared Operator * (
    left As Integer,
    right As MM
) As MM

Parameters

left
Type: SystemInt32
A int scalar.
right
Type: Autodesk.GeometryMM
The MM object.

Return Value

Type: MM
Product of the multiplication.
See Also

Reference

MM Structure
Multiply Overload
Autodesk.Geometry Namespace


MM.Multiply Operator (MM, MM)

MMMultiply Operator (MM, MM)

Multiplies two MM objects together.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double operator *(
    MM left,
    MM right
)
Public Shared Operator * (
    left As MM,
    right As MM
) As Double

Parameters

left
Type: Autodesk.GeometryMM
First of two MM objects.
right
Type: Autodesk.GeometryMM
Second of two MM objects.

Return Value

Type: Double
Product of the multiplication.
See Also

Reference

MM Structure
Multiply Overload
Autodesk.Geometry Namespace


MM.Multiply Operator (MM, Double)

MMMultiply Operator (MM, Double)

Multiplies a MM by a double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator *(
    MM left,
    double right
)
Public Shared Operator * (
    left As MM,
    right As Double
) As MM

Parameters

left
Type: Autodesk.GeometryMM
The MM object.
right
Type: SystemDouble
A dobule scalar.

Return Value

Type: MM
Product of the multiplication.
See Also

Reference

MM Structure
Multiply Overload
Autodesk.Geometry Namespace


MM.Multiply Operator (MM, Int32)

MMMultiply Operator (MM, Int32)

Multiplies a MM by a Int32.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator *(
    MM left,
    int right
)
Public Shared Operator * (
    left As MM,
    right As Integer
) As MM

Parameters

left
Type: Autodesk.GeometryMM
The MM object.
right
Type: SystemInt32
A int scalar.

Return Value

Type: MM
Product of the multiplication.
See Also

Reference

MM Structure
Multiply Overload
Autodesk.Geometry Namespace


MM.Subtraction Operator

MMSubtraction Operator

Overload List
Name | Description
Subtraction(Int32, MM) | Subtracts one MM object from a Int32.
Subtraction(MM, MM) | Subtracts one MM object from another.
Subtraction(MM, Int32) | Subtracts a Int32 from one MM object.
Top
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MM.Subtraction Operator (Int32, MM)

MMSubtraction Operator (Int32, MM)

Subtracts one MM object from a Int32.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator -(
    int left,
    MM right
)
Public Shared Operator - (
    left As Integer,
    right As MM
) As MM

Parameters

left
Type: SystemInt32
Object from which to subtract (minuend).
right
Type: Autodesk.GeometryMM
Object to subtract (subtrahend).

Return Value

Type: MM
MM object containing the result.
See Also

Reference

MM Structure
Subtraction Overload
Autodesk.Geometry Namespace


MM.Subtraction Operator (MM, MM)

MMSubtraction Operator (MM, MM)

Subtracts one MM object from another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator -(
    MM left,
    MM right
)
Public Shared Operator - (
    left As MM,
    right As MM
) As MM

Parameters

left
Type: Autodesk.GeometryMM
Object from which to subtract (minuend).
right
Type: Autodesk.GeometryMM
Object to subtract (subtrahend).

Return Value

Type: MM
MM object containing the result.
See Also

Reference

MM Structure
Subtraction Overload
Autodesk.Geometry Namespace


MM.Subtraction Operator (MM, Int32)

MMSubtraction Operator (MM, Int32)

Subtracts a Int32 from one MM object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator -(
    MM left,
    int right
)
Public Shared Operator - (
    left As MM,
    right As Integer
) As MM

Parameters

left
Type: Autodesk.GeometryMM
Object from which to subtract (minuend).
right
Type: SystemInt32
Object to subtract (subtrahend).

Return Value

Type: MM
MM object containing the result.
See Also

Reference

MM Structure
Subtraction Overload
Autodesk.Geometry Namespace


MM.UnaryNegation Operator

MMUnaryNegation Operator

Negates the MM object to the right of the operator.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM operator -(
    MM right
)
Public Shared Operator - (
    right As MM
) As MM

Parameters

right
Type: Autodesk.GeometryMM
MM object to negate.

Return Value

Type: MM
MM object containing the result of the operation.
See Also

Reference

MM Structure
Autodesk.Geometry Namespace


MSRFile Class

Performs read and write operations on MSR files.
Inheritance Hierarchy
SystemObject
Autodesk.FileSystemFile
Autodesk.GeometryMSRFile

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MSRFile : File
<SerializableAttribute>
Public Class MSRFile
    Inherits File

The MSRFile type exposes the following members.

Constructors
 | Name | Description
Public method | MSRFile(String, Boolean) | Constructs an MSRFile object and populates it with points from the specified file.
Public method | MSRFile(String, ListMSRFilePointData) | Constructs a new file with the specified path and filename and copies to it the specified list of points.
Top
Properties
 | Name | Description
Public property | Exists | True if the file exists. (Inherited from File.)
Public property | Extension | File extension (without the '.'). (Inherited from File.)
Public property | HeaderLines | File headers.
Public property | LastChangedDate | Date the file was last modifed. (Inherited from File.)
Public property | Name | Filename. (Inherited from File.)
Public property | NameWithoutExtension | Filename without extension. (Inherited from File.)
Public property | ParentDirectory | File's parent Directory object.. (Inherited from File.)
Public property | Path | Full path to the file. (Inherited from File.)
Public property | Points | File's point data.
Top
Methods
 | Name | Description
Public method | Copy | Copy the file to a new filepath. If a file with the same name and path already exists, it will be overwritten. (Inherited from File.)
Public method | CopyToDirectory | Copies the file to the specified new parent directory. If a file with the same name already exists, it will be overwritten. (Inherited from File.)
Public method | Create | Create the file if it does not already exist. (Inherited from File.)
Public method | Delete | Delete the file. (Inherited from File.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Move File to new path (Inherited from File.)
Public method | MoveToDirectory | Moves file to a new directory. (Inherited from File.)
Public method | ReadFirstLine | Returns the text of the first line of the file using UTF8 encoding. (Inherited from File.)
Public method | ReadText | Returns Entire file contents using UTF8 encoding. (Inherited from File.)
Public method | ReadText(Encoding) | Returns entire file contents using the encoding passed in the single input argument. (Inherited from File.)
Public method | ReadTextLines | Returns file contents as a list of strings using UTF8 encoding. Each string represents a seperate line of text in the file. (Inherited from File.)
Public method | ReadTextLines(Encoding) | Returns file contents as a list of strings using the encoding specified in the single input argument. Each string represents a seperate line of text in the file. (Inherited from File.)
Public method | Rename | Renames file within the current directory. (Inherited from File.)
Public method | ToString | Returns to the caller a string containing the contents of this object. E.g. START G800 N1 X-86.807 Y-7.998 Z242.112 I0.894 J-0.241 K0.377 O0 U0.1 L-0.1 G801 N1 X-85.466 Y-8.36 Z242.678 R1.5 (Overrides FileToString.)
Public method | WriteFile | Writes detransformed data (see ToString) to the specified file.
Public method | WriteText(String) | Writes a string of text to file using UTF8 encoding. (Inherited from File.)
Public method | WriteText(String, Boolean) | Writes a string of text to file using UTF8 encoding. (Inherited from File.)
Public method | WriteText(String, Boolean, Encoding) | Writes a string of text to file using the specified encoding. (Inherited from File.)
Public method | WriteTextLine | Writes a single line of text to file using the specified encoding. (Inherited from File.)
Public method | WriteTextLines | Writes to file all lines of text encapsulated within the passed array of strings. (Inherited from File.)
Top
Operators
Name | Description
Addition | Appends two MSR files
Top
See Also

Reference

Autodesk.Geometry Namespace


MSRFile Constructor

Overload List
 | Name | Description
Public method | MSRFile(String, Boolean) | Constructs an MSRFile object and populates it with points from the specified file.
Public method | MSRFile(String, ListMSRFilePointData) | Constructs a new file with the specified path and filename and copies to it the specified list of points.
Top
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile Constructor (String, Boolean)

Constructs an MSRFile object and populates it with points from the specified file.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MSRFile(
    string filePath,
    bool anglesInDegrees = true
)
Public Sub New (
    filePath As String,
    Optional anglesInDegrees As Boolean = true
)

Parameters

filePath
Type: SystemString
Path to the .msr file.
anglesInDegrees (Optional)
Type: SystemBoolean
Specifies whether the angles in a G330 line are in degrees (default) or radians
See Also

Reference

MSRFile Class
MSRFile Overload
Autodesk.Geometry Namespace


MSRFile Constructor (String, List(MSRFile.PointData))

MSRFile Constructor (String, ListMSRFilePointData)

Constructs a new file with the specified path and filename and copies to it the specified list of points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MSRFile(
    string filePathToCreate,
    List<MSRFilePointData> pointData
)
Public Sub New (
    filePathToCreate As String,
    pointData As List(Of MSRFilePointData)
)

Parameters

filePathToCreate
Type: SystemString
Path to the new file.
pointData
Type: System.Collections.GenericList MSRFilePointData
List of points to be included in the file.
See Also

Reference

MSRFile Class
MSRFile Overload
Autodesk.Geometry Namespace


MSRFile Properties

The MSRFile type exposes the following members.

Properties
 | Name | Description
Public property | Exists | True if the file exists. (Inherited from File.)
Public property | Extension | File extension (without the '.'). (Inherited from File.)
Public property | HeaderLines | File headers.
Public property | LastChangedDate | Date the file was last modifed. (Inherited from File.)
Public property | Name | Filename. (Inherited from File.)
Public property | NameWithoutExtension | Filename without extension. (Inherited from File.)
Public property | ParentDirectory | File's parent Directory object.. (Inherited from File.)
Public property | Path | Full path to the file. (Inherited from File.)
Public property | Points | File's point data.
Top
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile.HeaderLines Property

MSRFileHeaderLines Property

File headers.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<string> HeaderLines { get; set; }
Public Property HeaderLines As List(Of String)
    Get
    Set

Property Value

Type: List String
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile.Points Property

MSRFilePoints Property

File's point data.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<MSRFilePointData> Points { get; set; }
Public Property Points As List(Of MSRFilePointData)
    Get
    Set

Property Value

Type: List MSRFilePointData
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile Methods

The MSRFile type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Copy the file to a new filepath. If a file with the same name and path already exists, it will be overwritten. (Inherited from File.)
Public method | CopyToDirectory | Copies the file to the specified new parent directory. If a file with the same name already exists, it will be overwritten. (Inherited from File.)
Public method | Create | Create the file if it does not already exist. (Inherited from File.)
Public method | Delete | Delete the file. (Inherited from File.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Move File to new path (Inherited from File.)
Public method | MoveToDirectory | Moves file to a new directory. (Inherited from File.)
Public method | ReadFirstLine | Returns the text of the first line of the file using UTF8 encoding. (Inherited from File.)
Public method | ReadText | Returns Entire file contents using UTF8 encoding. (Inherited from File.)
Public method | ReadText(Encoding) | Returns entire file contents using the encoding passed in the single input argument. (Inherited from File.)
Public method | ReadTextLines | Returns file contents as a list of strings using UTF8 encoding. Each string represents a seperate line of text in the file. (Inherited from File.)
Public method | ReadTextLines(Encoding) | Returns file contents as a list of strings using the encoding specified in the single input argument. Each string represents a seperate line of text in the file. (Inherited from File.)
Public method | Rename | Renames file within the current directory. (Inherited from File.)
Public method | ToString | Returns to the caller a string containing the contents of this object. E.g. START G800 N1 X-86.807 Y-7.998 Z242.112 I0.894 J-0.241 K0.377 O0 U0.1 L-0.1 G801 N1 X-85.466 Y-8.36 Z242.678 R1.5 (Overrides FileToString.)
Public method | WriteFile | Writes detransformed data (see ToString) to the specified file.
Public method | WriteText(String) | Writes a string of text to file using UTF8 encoding. (Inherited from File.)
Public method | WriteText(String, Boolean) | Writes a string of text to file using UTF8 encoding. (Inherited from File.)
Public method | WriteText(String, Boolean, Encoding) | Writes a string of text to file using the specified encoding. (Inherited from File.)
Public method | WriteTextLine | Writes a single line of text to file using the specified encoding. (Inherited from File.)
Public method | WriteTextLines | Writes to file all lines of text encapsulated within the passed array of strings. (Inherited from File.)
Top
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile.ToString Method

MSRFileToString Method

Returns to the caller a string containing the contents of this object.

E.g.

START
G800 N1 X-86.807 Y-7.998 Z242.112 I0.894 J-0.241 K0.377 O0 U0.1 L-0.1
G801 N1 X-85.466 Y-8.36 Z242.678 R1.5

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
The file's PointData as a string
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile.WriteFile Method

MSRFileWriteFile Method

Writes detransformed data (see ToString) to the specified file.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteFile(
    string filePath
)
Public Sub WriteFile (
    filePath As String
)

Parameters

filePath
Type: SystemString
Path and filename of destination file.
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile Operators

The MSRFile type exposes the following members.

Operators
Name | Description
Addition | Appends two MSR files
Top
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile.Addition Operator

MSRFileAddition Operator

Appends two MSR files

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<MSRFilePointData> operator +(
    MSRFile firstMSRFile,
    MSRFile secondMSRFile
)
Public Shared Operator + (
    firstMSRFile As MSRFile,
    secondMSRFile As MSRFile
) As List(Of MSRFilePointData)

Parameters

firstMSRFile
Type: Autodesk.GeometryMSRFile
First MSR file to append.
secondMSRFile
Type: Autodesk.GeometryMSRFile
Second MSR file to append.

Return Value

Type: List MSRFilePointData
List of the combined pointData.
See Also

Reference

MSRFile Class
Autodesk.Geometry Namespace


MSRFile.PointData Class

MSRFilePointData Class

Encapsulates data for each point.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryMSRFilePointData

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PointData
<SerializableAttribute>
Public Class PointData

The MSRFilePointData type exposes the following members.

Constructors
 | Name | Description
Public method | MSRFilePointData | Constructs a PointData object with default values.
Public method | MSRFilePointData(Point, Vector, Double, Double, Double, Double, Point, MM) | Constructs a PointData object with the specified values.
Top
Properties
 | Name | Description
Public property | LowerTolerance | Lower permissible tolerance.
Public property | MeasuredSurfacePoint | Position of point as probed.
Public property | NominalSurfacePoint | Nominal position of the PointData.
Public property | PointNumber | Number of the point in the file.
Public property | ProbeCentre | Probe centre.
Public property | ProbeRadius | Probe radius.
Public property | SurfaceNormal | Normal to the surface at the nominal point.
Public property | SurfaceOffset | Expected manufactured offset from the nominal point.
Public property | UpperTolerance | Upper permissible tolerance.
Public property | Variation | Distance between measured surface point and nominal surface point. A more accurate value is provided by the VariationProjectedToSurfaceNormal property.
Public property | VariationProjectedToSurfaceNormal | Distance between measured surface point and nominal surface point projected onto the surface normal to give the variation and ignoring cosine error.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry Namespace


PointData Constructor

Overload List
 | Name | Description
Public method | MSRFilePointData | Constructs a PointData object with default values.
Public method | MSRFilePointData(Point, Vector, Double, Double, Double, Double, Point, MM) | Constructs a PointData object with the specified values.
Top
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData Constructor

MSRFilePointData Constructor

Constructs a PointData object with default values.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointData()
Public Sub New
See Also

Reference

MSRFilePointData Class
MSRFilePointData Overload
Autodesk.Geometry Namespace


MSRFile.PointData Constructor (Point, Vector, Double, Double, Double, Double, Point, MM)

MSRFilePointData Constructor (Point, Vector, Double, Double, Double, Double, Point, MM)

Constructs a PointData object with the specified values.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointData(
    Point nominalSurfacePoint,
    Vector surfaceNormal,
    double surfaceOffset,
    double upperTolerance,
    double lowerTolerance,
    double weight,
    Point probeCentre,
    MM probeRadius
)
Public Sub New (
    nominalSurfacePoint As Point,
    surfaceNormal As Vector,
    surfaceOffset As Double,
    upperTolerance As Double,
    lowerTolerance As Double,
    weight As Double,
    probeCentre As Point,
    probeRadius As MM
)

Parameters

nominalSurfacePoint
Type: Autodesk.GeometryPoint
Nominal point on the surface to be probed.
surfaceNormal
Type: Autodesk.GeometryVector
Vector normal to the surface at nominalSurfacePoint.
surfaceOffset
Type: SystemDouble
Expected offset of the point from the ideal.
upperTolerance
Type: SystemDouble
Upper permissible offset tolerance.
lowerTolerance
Type: SystemDouble
Lower permissible offset tolerance.
weight
Type: SystemDouble
Relative importance of this point in the model.
probeCentre
Type: Autodesk.GeometryPoint
Probe centre on measurement.
probeRadius
Type: Autodesk.GeometryMM
Probe radius in millimetres.
Remarks
See Also

Reference

MSRFilePointData Class
MSRFilePointData Overload
Autodesk.Geometry Namespace


PointData Properties

The MSRFilePointData type exposes the following members.

Properties
 | Name | Description
Public property | LowerTolerance | Lower permissible tolerance.
Public property | MeasuredSurfacePoint | Position of point as probed.
Public property | NominalSurfacePoint | Nominal position of the PointData.
Public property | PointNumber | Number of the point in the file.
Public property | ProbeCentre | Probe centre.
Public property | ProbeRadius | Probe radius.
Public property | SurfaceNormal | Normal to the surface at the nominal point.
Public property | SurfaceOffset | Expected manufactured offset from the nominal point.
Public property | UpperTolerance | Upper permissible tolerance.
Public property | Variation | Distance between measured surface point and nominal surface point. A more accurate value is provided by the VariationProjectedToSurfaceNormal property.
Public property | VariationProjectedToSurfaceNormal | Distance between measured surface point and nominal surface point projected onto the surface normal to give the variation and ignoring cosine error.
Top
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.LowerTolerance Property

MSRFilePointDataLowerTolerance Property

Lower permissible tolerance.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double LowerTolerance { get; set; }
Public Property LowerTolerance As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.MeasuredSurfacePoint Property

MSRFilePointDataMeasuredSurfacePoint Property

Position of point as probed.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point MeasuredSurfacePoint { get; }
Public ReadOnly Property MeasuredSurfacePoint As Point
    Get

Property Value

Type: Point
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.NominalSurfacePoint Property

MSRFilePointDataNominalSurfacePoint Property

Nominal position of the PointData.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point NominalSurfacePoint { get; set; }
Public Property NominalSurfacePoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.PointNumber Property

MSRFilePointDataPointNumber Property

Number of the point in the file.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int PointNumber { get; set; }
Public Property PointNumber As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.ProbeCentre Property

MSRFilePointDataProbeCentre Property

Probe centre.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point ProbeCentre { get; set; }
Public Property ProbeCentre As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.ProbeRadius Property

MSRFilePointDataProbeRadius Property

Probe radius.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ProbeRadius { get; set; }
Public Property ProbeRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.SurfaceNormal Property

MSRFilePointDataSurfaceNormal Property

Normal to the surface at the nominal point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector SurfaceNormal { get; set; }
Public Property SurfaceNormal As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.SurfaceOffset Property

MSRFilePointDataSurfaceOffset Property

Expected manufactured offset from the nominal point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double SurfaceOffset { get; set; }
Public Property SurfaceOffset As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.UpperTolerance Property

MSRFilePointDataUpperTolerance Property

Upper permissible tolerance.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double UpperTolerance { get; set; }
Public Property UpperTolerance As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.Variation Property

MSRFilePointDataVariation Property

Distance between measured surface point and nominal surface point. A more accurate value is provided by the VariationProjectedToSurfaceNormal property.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Variation { get; }
Public ReadOnly Property Variation As MM
    Get

Property Value

Type: MM
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


MSRFile.PointData.VariationProjectedToSurfaceNormal Property

MSRFilePointDataVariationProjectedToSurfaceNormal Property

Distance between measured surface point and nominal surface point projected onto the surface normal to give the variation and ignoring cosine error.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM VariationProjectedToSurfaceNormal { get; }
Public ReadOnly Property VariationProjectedToSurfaceNormal As MM
    Get

Property Value

Type: MM
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


PointData Methods

The MSRFilePointData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MSRFilePointData Class
Autodesk.Geometry Namespace


Point Class

Encapsulates a three-dimensional point and the permissible operations thereon.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryPoint
Autodesk.GeometrySplinePoint

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Point
<SerializableAttribute>
Public Class Point

The Point type exposes the following members.

Constructors
 | Name | Description
Public method | Point | Constructs a point at the origin of the co-ordinate system.
Public method | Point(Double) | Constructs a point from an array of Doubles.
Public method | Point(MM) | Constructs a point from an array of MM objects.
Public method | Point(String, Char) | Constructs a point from a single line of text and a delimiter.
Public method | Point(MM, MM, MM) | Constructs a point at the specified position in the co-ordinate system.
Top
Properties
 | Name | Description
Public property | X | X coordinate.
Public property | Y | Y coordinate.
Public property | Z | Z coordinate.
Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this Point.
Public method | DistanceToPoint | Returns the distance between this and another Point.
Public method | Equals(Object) | Returns true if the Point is equal to the specified object. If the object is not a point or is not equivalent to the Point, the operation returns False. (Overrides ObjectEquals(Object).)
Public method | Equals(Object, Int32) | Returns true if the Point is equal to the specified object with at least the specified precision. If the the object is not a point or is not equivalent to the Point, the operation returns False.
Public method | EulerRotation | Rotates the Point by the specified Euler Angles.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the HashCode for this Point. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInsideTriangle | Returns true if the point is inside the triangle, otherwise it returns false. It uses Barycentric coordinates of the point to return the result.
Public method | IsRayInterceptTriangleTest | Returns true if a ray with given direction from the point intercepts the triangle, otherwise it returns false. Uses ray triangle intersection algorithm by Moller Haines.
Public method | LiesOnLine | Determines whether this Point lies on the straight line between two Points specified in the input arguments.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectToPlane | This operation projects a point onto a Plane
Public method | RebaseFromWorkplane | Rebases the Point from the specified workplane to the world.
Public method | RebaseToWorkplane | Rebases Point from the world to the specified Workplane
Public method | RotateAboutVector | Rotates Point by the specified angle in radians about the specified Vector.
Public method | RotateAboutXAxis | Rotates Point by the specified angle in radians about the specified Point in the X axis.
Public method | RotateAboutYAxis | Rotates Point by the specified angle in radians about the specified Point in the Y axis.
Public method | RotateAboutZAxis | Rotates Point by the specified angle in radians about the specified Point in the Z axis.
Public method | ToString | Returns a string representation of the Point in the form: X.XXX Y.YYY Z.ZZZ. (Overrides ObjectToString.)
Public method | ToString(Char) | Returns a string representation of the point with a custom delimiter between the three coordinates. If, for example, a comma were chosen as the delimeter, the resultant output would be of the form: X.XXX,Y.YYY,Z.ZZZ
Top
Operators
Name | Description
Addition | Sums a Point and a Vector i.e displace the point by the vector.
Division | Divides a point in all axes by the scalar value.
Equality(MM, Point) | Compares a Point to an array of MM length objects, returning True if they are equal.
Equality(Point, Object) | Compares a Point to an Object and returns true if they are equal. Returns False if the specified Object is neither a Point nor a MM. Returns True if both Point and Object are null.
Inequality(MM, Point) | Compares a Point to an array of MM length objects, returning True if they are unequal.
Inequality(Point, Object) | Compares a Point to an Object and returns false if they are equal. Returns True if the specified Object is neither a Point nor a MM. Returns False if both Point and Object are null.
Multiply(Double, Point) | Scales a point in all axes by the specified scalar value.
Multiply(Point, Double) | Scales a point in all axes by the specified scalar value.
Subtraction(Point, Point) | Subtracts the specified right-hand point from the left, thereby rendering the vector from right to left.
Subtraction(Point, Vector) | Subtracts the given Vector from the Point i.e displaces the point by the vector.
Top
Fields
 | Name | Description
Protected field | _x | X coordinate.
Protected field | _y | Y coordinate.
Protected field | _z | Z coordinate.
Top
See Also

Reference

Autodesk.Geometry Namespace


Point Constructor

Overload List
 | Name | Description
Public method | Point | Constructs a point at the origin of the co-ordinate system.
Public method | Point(Double) | Constructs a point from an array of Doubles.
Public method | Point(MM) | Constructs a point from an array of MM objects.
Public method | Point(String, Char) | Constructs a point from a single line of text and a delimiter.
Public method | Point(MM, MM, MM) | Constructs a point at the specified position in the co-ordinate system.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point Constructor

Constructs a point at the origin of the co-ordinate system.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point()
Public Sub New
See Also

Reference

Point Class
Point Overload
Autodesk.Geometry Namespace


Point Constructor (Double[])

Point Constructor (Double)

Constructs a point from an array of Doubles.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point(
    double[] pointArray
)
Public Sub New (
    pointArray As Double()
)

Parameters

pointArray
Type: SystemDouble
Array from which to create the point.
See Also

Reference

Point Class
Point Overload
Autodesk.Geometry Namespace


Point Constructor (MM[])

Point Constructor (MM)

Constructs a point from an array of MM objects.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point(
    MM[] pointArray
)
Public Sub New (
    pointArray As MM()
)

Parameters

pointArray
Type: Autodesk.GeometryMM
Array from which to create the point.
Exceptions
Exception | Condition
Exception | Thrown if input array does not contain exactly three coordinates.
See Also

Reference

Point Class
Point Overload
Autodesk.Geometry Namespace


Point Constructor (String, Char)

Constructs a point from a single line of text and a delimiter.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point(
    string textLine,
    char delimiter = ''
)
Public Sub New (
    textLine As String,
    Optional delimiter As Char = ""C
)

Parameters

textLine
Type: SystemString
Line of text containing the delimited coordinates.
delimiter (Optional)
Type: SystemChar
Delimiter. If none is specified, a space is assumed.
Exceptions
Exception | Condition
Exception | Thrown if the input string does not contain exactly three coordinates or if the string cannot be parsed.
See Also

Reference

Point Class
Point Overload
Autodesk.Geometry Namespace


Point Constructor (MM, MM, MM)

Constructs a point at the specified position in the co-ordinate system.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point(
    MM x,
    MM y,
    MM z
)
Public Sub New (
    x As MM,
    y As MM,
    z As MM
)

Parameters

x
Type: Autodesk.GeometryMM
X co-ordinate.
y
Type: Autodesk.GeometryMM
Y co-ordinate.
z
Type: Autodesk.GeometryMM
Z co-ordinate
See Also

Reference

Point Class
Point Overload
Autodesk.Geometry Namespace


Point Properties

The Point type exposes the following members.

Properties
 | Name | Description
Public property | X | X coordinate.
Public property | Y | Y coordinate.
Public property | Z | Z coordinate.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.X Property

PointX Property

X coordinate.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM X { get; set; }
Public Property X As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Y Property

PointY Property

Y coordinate.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Y { get; set; }
Public Property Y As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Z Property

PointZ Property

Z coordinate.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Z { get; set; }
Public Property Z As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point Methods

The Point type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a clone of this Point.
Public method | DistanceToPoint | Returns the distance between this and another Point.
Public method | Equals(Object) | Returns true if the Point is equal to the specified object. If the object is not a point or is not equivalent to the Point, the operation returns False. (Overrides ObjectEquals(Object).)
Public method | Equals(Object, Int32) | Returns true if the Point is equal to the specified object with at least the specified precision. If the the object is not a point or is not equivalent to the Point, the operation returns False.
Public method | EulerRotation | Rotates the Point by the specified Euler Angles.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the HashCode for this Point. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInsideTriangle | Returns true if the point is inside the triangle, otherwise it returns false. It uses Barycentric coordinates of the point to return the result.
Public method | IsRayInterceptTriangleTest | Returns true if a ray with given direction from the point intercepts the triangle, otherwise it returns false. Uses ray triangle intersection algorithm by Moller Haines.
Public method | LiesOnLine | Determines whether this Point lies on the straight line between two Points specified in the input arguments.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectToPlane | This operation projects a point onto a Plane
Public method | RebaseFromWorkplane | Rebases the Point from the specified workplane to the world.
Public method | RebaseToWorkplane | Rebases Point from the world to the specified Workplane
Public method | RotateAboutVector | Rotates Point by the specified angle in radians about the specified Vector.
Public method | RotateAboutXAxis | Rotates Point by the specified angle in radians about the specified Point in the X axis.
Public method | RotateAboutYAxis | Rotates Point by the specified angle in radians about the specified Point in the Y axis.
Public method | RotateAboutZAxis | Rotates Point by the specified angle in radians about the specified Point in the Z axis.
Public method | ToString | Returns a string representation of the Point in the form: X.XXX Y.YYY Z.ZZZ. (Overrides ObjectToString.)
Public method | ToString(Char) | Returns a string representation of the point with a custom delimiter between the three coordinates. If, for example, a comma were chosen as the delimeter, the resultant output would be of the form: X.XXX,Y.YYY,Z.ZZZ
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Clone Method

PointClone Method

Returns a clone of this Point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Clone()
Public Function Clone As Point

Return Value

Type: Point
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.DistanceToPoint Method

PointDistanceToPoint Method

Returns the distance between this and another Point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM DistanceToPoint(
    Point secondPoint
)
Public Function DistanceToPoint (
    secondPoint As Point
) As MM

Parameters

secondPoint
Type: Autodesk.GeometryPoint
Point from which to calculate distance.

Return Value

Type: MM
Inter-point distance.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Equals Method

PointEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Returns true if the Point is equal to the specified object. If the object is not a point or is not equivalent to the Point, the operation returns False. (Overrides ObjectEquals(Object).)
Public method | Equals(Object, Int32) | Returns true if the Point is equal to the specified object with at least the specified precision. If the the object is not a point or is not equivalent to the Point, the operation returns False.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Equals Method (Object)

PointEquals Method (Object)

Returns true if the Point is equal to the specified object. If the object is not a point or is not equivalent to the Point, the operation returns False.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Object to comare against.

Return Value

Type: Boolean
See Also

Reference

Point Class
Equals Overload
Autodesk.Geometry Namespace


Point.Equals Method (Object, Int32)

PointEquals Method (Object, Int32)

Returns true if the Point is equal to the specified object with at least the specified precision. If the the object is not a point or is not equivalent to the Point, the operation returns False.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    Object obj,
    int nDecPts
)
Public Function Equals (
    obj As Object,
    nDecPts As Integer
) As Boolean

Parameters

obj
Type: SystemObject
Object to comare against.
nDecPts
Type: SystemInt32
Number of decimal places to compare.

Return Value

Type: Boolean
True if the operands are deemed equal.
See Also

Reference

Point Class
Equals Overload
Autodesk.Geometry Namespace


Point.EulerRotation Method

PointEulerRotation Method

Rotates the Point by the specified Euler Angles.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EulerRotation(
    Angles angle
)
Public Sub EulerRotation (
    angle As Angles
)

Parameters

angle
Type: Autodesk.Geometry.EulerAngles
Angles of rotation.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.GetHashCode Method

PointGetHashCode Method

Returns the HashCode for this Point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
The HashCode for this Point.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.IsInsideTriangle Method

PointIsInsideTriangle Method

Returns true if the point is inside the triangle, otherwise it returns false. It uses Barycentric coordinates of the point to return the result.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsInsideTriangle(
    Point vertex1,
    Point vertex2,
    Point vertex3
)
Public Function IsInsideTriangle (
    vertex1 As Point,
    vertex2 As Point,
    vertex3 As Point
) As Boolean

Parameters

vertex1
Type: Autodesk.GeometryPoint
First triangle Vertex
vertex2
Type: Autodesk.GeometryPoint
Second triangle Vertex
vertex3
Type: Autodesk.GeometryPoint
Third triangle Vertex

Return Value

Type: Boolean
True if point is within the triangle.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.IsRayInterceptTriangleTest Method

PointIsRayInterceptTriangleTest Method

Returns true if a ray with given direction from the point intercepts the triangle, otherwise it returns false. Uses ray triangle intersection algorithm by Moller Haines.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsRayInterceptTriangleTest(
    Vector rayDirection,
    Point vertex1,
    Point vertex2,
    Point vertex3
)
Public Function IsRayInterceptTriangleTest (
    rayDirection As Vector,
    vertex1 As Point,
    vertex2 As Point,
    vertex3 As Point
) As Boolean

Parameters

rayDirection
Type: Autodesk.GeometryVector
Direction of the ray
vertex1
Type: Autodesk.GeometryPoint
First triangle Vertex
vertex2
Type: Autodesk.GeometryPoint
Second triangle Vertex
vertex3
Type: Autodesk.GeometryPoint
Third triangle Vertex

Return Value

Type: Boolean
True if point is within the triangle.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.LiesOnLine Method

PointLiesOnLine Method

Determines whether this Point lies on the straight line between two Points specified in the input arguments.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool LiesOnLine(
    Point lineStartPoint,
    Point lineEndPoint
)
Public Function LiesOnLine (
    lineStartPoint As Point,
    lineEndPoint As Point
) As Boolean

Parameters

lineStartPoint
Type: Autodesk.GeometryPoint
First point.
lineEndPoint
Type: Autodesk.GeometryPoint
Second point.

Return Value

Type: Boolean
True if the points are colinear; false otherwise.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.ProjectToPlane Method

PointProjectToPlane Method

This operation projects a point onto a Plane

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point ProjectToPlane(
    Vector projectionVector,
    Point pointOnPlane,
    Vector planeNormal
)
Public Function ProjectToPlane (
    projectionVector As Vector,
    pointOnPlane As Point,
    planeNormal As Vector
) As Point

Parameters

projectionVector
Type: Autodesk.GeometryVector
This is the direction in which to project the point
pointOnPlane
Type: Autodesk.GeometryPoint
This is any point on the plane
planeNormal
Type: Autodesk.GeometryVector
This is the plane normal

Return Value

Type: Point
The point on the plane where the projected point hits
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.RebaseFromWorkplane Method

PointRebaseFromWorkplane Method

Rebases the Point from the specified workplane to the world.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RebaseFromWorkplane(
    Workplane fromWorkplane
)
Public Sub RebaseFromWorkplane (
    fromWorkplane As Workplane
)

Parameters

fromWorkplane
Type: Autodesk.GeometryWorkplane
Workplane from which to rebase the point.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.RebaseToWorkplane Method

PointRebaseToWorkplane Method

Rebases Point from the world to the specified Workplane

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RebaseToWorkplane(
    Workplane toWorkplane
)
Public Sub RebaseToWorkplane (
    toWorkplane As Workplane
)

Parameters

toWorkplane
Type: Autodesk.GeometryWorkplane
Workplane to rebase the Point to.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.RotateAboutVector Method

PointRotateAboutVector Method

Rotates Point by the specified angle in radians about the specified Vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutVector(
    Vector vectorToRotateAbout,
    Point rotationOrigin,
    Radian angle
)
Public Sub RotateAboutVector (
    vectorToRotateAbout As Vector,
    rotationOrigin As Point,
    angle As Radian
)

Parameters

vectorToRotateAbout
Type: Autodesk.GeometryVector
Vector about which to rotate the Point.
rotationOrigin
Type: Autodesk.GeometryPoint
Origin of coordinate system.
angle
Type: Autodesk.GeometryRadian
Angle to rotate.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.RotateAboutXAxis Method

PointRotateAboutXAxis Method

Rotates Point by the specified angle in radians about the specified Point in the X axis.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutXAxis(
    Point pointToRotateAbout,
    Radian angle
)
Public Sub RotateAboutXAxis (
    pointToRotateAbout As Point,
    angle As Radian
)

Parameters

pointToRotateAbout
Type: Autodesk.GeometryPoint
Point about which to rotate.
angle
Type: Autodesk.GeometryRadian
Angle to rotate.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.RotateAboutYAxis Method

PointRotateAboutYAxis Method

Rotates Point by the specified angle in radians about the specified Point in the Y axis.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutYAxis(
    Point pointToRotateAbout,
    Radian angle
)
Public Sub RotateAboutYAxis (
    pointToRotateAbout As Point,
    angle As Radian
)

Parameters

pointToRotateAbout
Type: Autodesk.GeometryPoint
Point about which to rotate.
angle
Type: Autodesk.GeometryRadian
Angle to rotate.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.RotateAboutZAxis Method

PointRotateAboutZAxis Method

Rotates Point by the specified angle in radians about the specified Point in the Z axis.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutZAxis(
    Point pointToRotateAbout,
    Radian angle
)
Public Sub RotateAboutZAxis (
    pointToRotateAbout As Point,
    angle As Radian
)

Parameters

pointToRotateAbout
Type: Autodesk.GeometryPoint
Point about which to rotate.
angle
Type: Autodesk.GeometryRadian
Angle to rotate.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.ToString Method

PointToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string representation of the Point in the form: X.XXX Y.YYY Z.ZZZ. (Overrides ObjectToString.)
Public method | ToString(Char) | Returns a string representation of the point with a custom delimiter between the three coordinates. If, for example, a comma were chosen as the delimeter, the resultant output would be of the form: X.XXX,Y.YYY,Z.ZZZ
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.ToString Method

PointToString Method

Returns a string representation of the Point in the form: X.XXX Y.YYY Z.ZZZ.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

Point Class
ToString Overload
Autodesk.Geometry Namespace


Point.ToString Method (Char[])

PointToString Method (Char)

Returns a string representation of the point with a custom delimiter between the three coordinates. If, for example, a comma were chosen as the delimeter, the resultant output would be of the form: X.XXX,Y.YYY,Z.ZZZ

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    char[] delimiter
)
Public Function ToString (
    delimiter As Char()
) As String

Parameters

delimiter
Type: SystemChar
Can be any string.

Return Value

Type: String
See Also

Reference

Point Class
ToString Overload
Autodesk.Geometry Namespace


Point Operators

The Point type exposes the following members.

Operators
Name | Description
Addition | Sums a Point and a Vector i.e displace the point by the vector.
Division | Divides a point in all axes by the scalar value.
Equality(MM, Point) | Compares a Point to an array of MM length objects, returning True if they are equal.
Equality(Point, Object) | Compares a Point to an Object and returns true if they are equal. Returns False if the specified Object is neither a Point nor a MM. Returns True if both Point and Object are null.
Inequality(MM, Point) | Compares a Point to an array of MM length objects, returning True if they are unequal.
Inequality(Point, Object) | Compares a Point to an Object and returns false if they are equal. Returns True if the specified Object is neither a Point nor a MM. Returns False if both Point and Object are null.
Multiply(Double, Point) | Scales a point in all axes by the specified scalar value.
Multiply(Point, Double) | Scales a point in all axes by the specified scalar value.
Subtraction(Point, Point) | Subtracts the specified right-hand point from the left, thereby rendering the vector from right to left.
Subtraction(Point, Vector) | Subtracts the given Vector from the Point i.e displaces the point by the vector.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Addition Operator

PointAddition Operator

Sums a Point and a Vector i.e displace the point by the vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Point operator +(
    Point left,
    Vector right
)
Public Shared Operator + (
    left As Point,
    right As Vector
) As Point

Parameters

left
Type: Autodesk.GeometryPoint
Point to sum.
right
Type: Autodesk.GeometryVector
Vector to sum.

Return Value

Type: Point
Displaced point.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Division Operator

PointDivision Operator

Divides a point in all axes by the scalar value.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Point operator /(
    Point left,
    double scalar
)
Public Shared Operator / (
    left As Point,
    scalar As Double
) As Point

Parameters

left
Type: Autodesk.GeometryPoint
Point to scale.
scalar
Type: SystemDouble
Scaling factor.

Return Value

Type: Point
New point containing the result of the operation.
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Equality Operator

PointEquality Operator

Overload List
Name | Description
Equality(MM, Point) | Compares a Point to an array of MM length objects, returning True if they are equal.
Equality(Point, Object) | Compares a Point to an Object and returns true if they are equal. Returns False if the specified Object is neither a Point nor a MM. Returns True if both Point and Object are null.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Equality Operator (MM[], Point)

PointEquality Operator (MM, Point)

Compares a Point to an array of MM length objects, returning True if they are equal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator ==(
    MM[] left,
    Point right
)
Public Shared Operator = (
    left As MM(),
    right As Point
) As Boolean

Parameters

left
Type: Autodesk.GeometryMM
MM array.
right
Type: Autodesk.GeometryPoint
Point.

Return Value

Type: Boolean
True if operands are equivalent; false otherwise.
See Also

Reference

Point Class
Equality Overload
Autodesk.Geometry Namespace


Point.Equality Operator (Point, Object)

PointEquality Operator (Point, Object)

Compares a Point to an Object and returns true if they are equal. Returns False if the specified Object is neither a Point nor a MM. Returns True if both Point and Object are null.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator ==(
    Point left,
    Object right
)
Public Shared Operator = (
    left As Point,
    right As Object
) As Boolean

Parameters

left
Type: Autodesk.GeometryPoint
Point to compare.
right
Type: SystemObject
Object to compare.

Return Value

Type: Boolean
Remarks
See Also

Reference

Point Class
Equality Overload
Autodesk.Geometry Namespace


Point.Inequality Operator

PointInequality Operator

Overload List
Name | Description
Inequality(MM, Point) | Compares a Point to an array of MM length objects, returning True if they are unequal.
Inequality(Point, Object) | Compares a Point to an Object and returns false if they are equal. Returns True if the specified Object is neither a Point nor a MM. Returns False if both Point and Object are null.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Inequality Operator (MM[], Point)

PointInequality Operator (MM, Point)

Compares a Point to an array of MM length objects, returning True if they are unequal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator !=(
    MM[] left,
    Point right
)
Public Shared Operator <> (
    left As MM(),
    right As Point
) As Boolean

Parameters

left
Type: Autodesk.GeometryMM
MM array.
right
Type: Autodesk.GeometryPoint
Point.

Return Value

Type: Boolean
True if operands are unequivalent; false otherwise.
See Also

Reference

Point Class
Inequality Overload
Autodesk.Geometry Namespace


Point.Inequality Operator (Point, Object)

PointInequality Operator (Point, Object)

Compares a Point to an Object and returns false if they are equal. Returns True if the specified Object is neither a Point nor a MM. Returns False if both Point and Object are null.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator !=(
    Point left,
    Object right
)
Public Shared Operator <> (
    left As Point,
    right As Object
) As Boolean

Parameters

left
Type: Autodesk.GeometryPoint
Point to compare.
right
Type: SystemObject
Object to compare.

Return Value

Type: Boolean
Remarks
See Also

Reference

Point Class
Inequality Overload
Autodesk.Geometry Namespace


Point.Multiply Operator

PointMultiply Operator

Overload List
Name | Description
Multiply(Double, Point) | Scales a point in all axes by the specified scalar value.
Multiply(Point, Double) | Scales a point in all axes by the specified scalar value.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Multiply Operator (Double, Point)

PointMultiply Operator (Double, Point)

Scales a point in all axes by the specified scalar value.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Point operator *(
    double scalar,
    Point right
)
Public Shared Operator * (
    scalar As Double,
    right As Point
) As Point

Parameters

scalar
Type: SystemDouble
Scaling factor.
right
Type: Autodesk.GeometryPoint
Point to scale.

Return Value

Type: Point
New point containing the result of the operation.
See Also

Reference

Point Class
Multiply Overload
Autodesk.Geometry Namespace


Point.Multiply Operator (Point, Double)

PointMultiply Operator (Point, Double)

Scales a point in all axes by the specified scalar value.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Point operator *(
    Point left,
    double scalar
)
Public Shared Operator * (
    left As Point,
    scalar As Double
) As Point

Parameters

left
Type: Autodesk.GeometryPoint
Point to scale.
scalar
Type: SystemDouble
Scaling factor.

Return Value

Type: Point
New point containing the result of the operation.
See Also

Reference

Point Class
Multiply Overload
Autodesk.Geometry Namespace


Point.Subtraction Operator

PointSubtraction Operator

Overload List
Name | Description
Subtraction(Point, Point) | Subtracts the specified right-hand point from the left, thereby rendering the vector from right to left.
Subtraction(Point, Vector) | Subtracts the given Vector from the Point i.e displaces the point by the vector.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point.Subtraction Operator (Point, Point)

PointSubtraction Operator (Point, Point)

Subtracts the specified right-hand point from the left, thereby rendering the vector from right to left.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Vector operator -(
    Point left,
    Point right
)
Public Shared Operator - (
    left As Point,
    right As Point
) As Vector

Parameters

left
Type: Autodesk.GeometryPoint
Left-hand point.
right
Type: Autodesk.GeometryPoint
Right-hand point.

Return Value

Type: Vector
Vector from right to left.
See Also

Reference

Point Class
Subtraction Overload
Autodesk.Geometry Namespace


Point.Subtraction Operator (Point, Vector)

PointSubtraction Operator (Point, Vector)

Subtracts the given Vector from the Point i.e displaces the point by the vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Point operator -(
    Point left,
    Vector right
)
Public Shared Operator - (
    left As Point,
    right As Vector
) As Point

Parameters

left
Type: Autodesk.GeometryPoint
Point from which to subtract vector.
right
Type: Autodesk.GeometryVector
Vector to subtract.

Return Value

Type: Point
See Also

Reference

Point Class
Subtraction Overload
Autodesk.Geometry Namespace


Point Fields

The Point type exposes the following members.

Fields
 | Name | Description
Protected field | _x | X coordinate.
Protected field | _y | Y coordinate.
Protected field | _z | Z coordinate.
Top
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point._x Field

Point_x Field

X coordinate.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected MM _x
Protected _x As MM

Field Value

Type: MM
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point._y Field

Point_y Field

Y coordinate.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected MM _y
Protected _y As MM

Field Value

Type: MM
See Also

Reference

Point Class
Autodesk.Geometry Namespace


Point._z Field

Point_z Field

Z coordinate.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected MM _z
Protected _z As MM

Field Value

Type: MM
See Also

Reference

Point Class
Autodesk.Geometry Namespace


PointCloud Class

Encapsulates a point cloud, a collection of points that are not linked together.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList Point
Autodesk.GeometryPointCloud

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PointCloud : List<Point>
<SerializableAttribute>
Public Class PointCloud
    Inherits List(Of Point)

The PointCloud type exposes the following members.

Constructors
 | Name | Description
Public method | PointCloud | Constructs an empty PointCloud.
Public method | PointCloud(ListPoint) | Constructs a PointCloud and populates it with the specified points.
Top
Properties
 | Name | Description
Public property | BoundingBox | Calculates and returns the bounding box of the point cloud.
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List Point .)
Public property | Centre | Point representing the centre of the point cloud.
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List Point .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List Point .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List Point .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List Point .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List Point .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List Point .)
Public method | Clone | Returns a clone of this PointCloud.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List Point .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List Point .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List Point .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Point .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Point .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Point .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Point .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Point .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Point .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List Point .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List Point .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List Point .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Point .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Point .)
Public method | IndexOfMinumumPoint | Returns the index of the point that is the minimum in the specified axis.
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List Point .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List Point .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Point .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Point .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List Point .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List Point .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List Point .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List Point .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List Point .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List Point .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List Point .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List Point .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List Point .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List Point .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List Point .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | WriteDUCTPictureFile | Creates a DUCTPicture file at the specified path and using the specified units.
Top
See Also

Reference

Autodesk.Geometry Namespace


PointCloud Constructor

Overload List
 | Name | Description
Public method | PointCloud | Constructs an empty PointCloud.
Public method | PointCloud(ListPoint) | Constructs a PointCloud and populates it with the specified points.
Top
See Also

Reference

PointCloud Class
Autodesk.Geometry Namespace


PointCloud Constructor

Constructs an empty PointCloud.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointCloud()
Public Sub New
See Also

Reference

PointCloud Class
PointCloud Overload
Autodesk.Geometry Namespace


PointCloud Constructor (List(Point))

PointCloud Constructor (ListPoint)

Constructs a PointCloud and populates it with the specified points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointCloud(
    List<Point> points
)
Public Sub New (
    points As List(Of Point)
)

Parameters

points
Type: System.Collections.GenericList Point
List of points with which to populate the PointCloud.
See Also

Reference

PointCloud Class
PointCloud Overload
Autodesk.Geometry Namespace


PointCloud Properties

The PointCloud type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Calculates and returns the bounding box of the point cloud.
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List Point .)
Public property | Centre | Point representing the centre of the point cloud.
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List Point .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List Point .)
Top
See Also

Reference

PointCloud Class
Autodesk.Geometry Namespace


PointCloud.BoundingBox Property

PointCloudBoundingBox Property

Calculates and returns the bounding box of the point cloud.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox BoundingBox { get; }
Public ReadOnly Property BoundingBox As BoundingBox
    Get

Return Value

Type: BoundingBox
Bounding box of this PointCloud.
See Also

Reference

PointCloud Class
Autodesk.Geometry Namespace


PointCloud.Centre Property

PointCloudCentre Property

Point representing the centre of the point cloud.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Centre { get; }
Public ReadOnly Property Centre As Point
    Get

Property Value

Type: Point
See Also

Reference

PointCloud Class
Autodesk.Geometry Namespace


PointCloud Methods

The PointCloud type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List Point .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List Point .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List Point .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List Point .)
Public method | Clone | Returns a clone of this PointCloud.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List Point .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List Point .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List Point .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Point .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Point .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Point .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Point .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Point .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Point .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List Point .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List Point .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List Point .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Point .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Point .)
Public method | IndexOfMinumumPoint | Returns the index of the point that is the minimum in the specified axis.
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List Point .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List Point .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Point .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Point .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List Point .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List Point .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List Point .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List Point .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List Point .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List Point .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List Point .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List Point .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List Point .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List Point .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List Point .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | WriteDUCTPictureFile | Creates a DUCTPicture file at the specified path and using the specified units.
Top
See Also

Reference

PointCloud Class
Autodesk.Geometry Namespace


PointCloud.Clone Method

PointCloudClone Method

Returns a clone of this PointCloud.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointCloud Clone()
Public Function Clone As PointCloud

Return Value

Type: PointCloud
See Also

Reference

PointCloud Class
Autodesk.Geometry Namespace


PointCloud.IndexOfMinumumPoint Method

PointCloudIndexOfMinumumPoint Method

Returns the index of the point that is the minimum in the specified axis.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int IndexOfMinumumPoint(
    Axes Axis
)
Public Function IndexOfMinumumPoint (
    Axis As Axes
) As Integer

Parameters

Axis
Type: AutodeskAxes
X, Y or Z.

Return Value

Type: Int32
Index of the minimum point.
See Also

Reference

PointCloud Class
Autodesk.Geometry Namespace


PointCloud.WriteDUCTPictureFile Method

PointCloudWriteDUCTPictureFile Method

Creates a DUCTPicture file at the specified path and using the specified units.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteDUCTPictureFile(
    File file,
    LengthUnits enmUnits
)
Public Sub WriteDUCTPictureFile (
    file As File,
    enmUnits As LengthUnits
)

Parameters

file
Type: Autodesk.FileSystemFile
Path to file.
enmUnits
Type: AutodeskLengthUnits
Units to use.
See Also

Reference

PointCloud Class
Autodesk.Geometry Namespace


Polyline Class

Encapsulates a Polyline. A Polyline comprises a collection of points, each connected by a straight line. If marked as closed, the start and end points are also joined by a line; it is not necessary to duplicate the start point at the end of the list in order to close the shape.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList Point
Autodesk.GeometryPolyline

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Polyline : List<Point>
<SerializableAttribute>
Public Class Polyline
    Inherits List(Of Point)

The Polyline type exposes the following members.

Constructors
 | Name | Description
Public method | Polyline | Constructs an empty PolyLine.
Public method | Polyline(File) | Constructs a Polyline and initialises it from an ASCII file. Each line of the file comprises the three coordinates of each point seperated by spaces. I.e. A.AAA B.BBB C.CCC D.DDD E.EEE F.FFF ... etc.
Public method | Polyline(ListPoint) | Constructs a PolyLine with the specified list of points.
Public method | Polyline(ListPoint, Boolean) | Constructs a Polyline, initialises the list of points to the specified value and, if specified, closes the line.
Public method | Polyline(Spline, Double) | Constructs a Polyline from a SplineCurve, fitting it to the specified tolerance.
Top
Properties
 | Name | Description
Public property | BoundingBox | BoundingBox of the Polyline. Nothing if the Polyline contains no points.
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List Point .)
Public property | Centre | Centre point of the Polyline.
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List Point .)
Public property | IsClosed | True if the Polyline is closed; false otherwise.
Public property | Item | Gets or sets the element at the specified index. (Inherited from List Point .)
Public property | Length | Length of the Polyline.
Public property | LengthMap | List of distances between consecutive points. The 1st element of the list will be zero because it is the first point. The 2nd element of the list will be the distance between the 2nd point of the polyline and the 1st point. In generic terms, LengthMap will contain Point(n) - Point(n-1).
Public property | Normal | Vector normal to the centre of the Polyline.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List Point .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List Point .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List Point .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List Point .)
Public method | Clone | Returns a clone of this Polyline.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List Point .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List Point .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List Point .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Point .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Point .)
Public method | Densify | Ensures that no connecting line exceeds the specified span length. If such a line exists, a point(s) is inserted and the line split. Linearity is preserved.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Point .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Point .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Point .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Point .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List Point .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List Point .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List Point .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Point .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Point .)
Public method | IndexOfNearestPoint | Returns to the caller the index of the point on the Polyline that is nearest to that specified in the single input argument.
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List Point .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List Point .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Point .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Point .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the polyline by the specified Vector. All points are displaced.
Public method | NextPointIndex | Returns to the caller the index of the next point after the one specified. If the specified index is greater or equal to the end of the line, the start index is returned.
 | ReadFromDUCTPictureFile | Extracts Polylines from a DUCT picture file and returns them as a list.
Public method | RebaseFromWorkplane | Rebases the polyline from the specified workplane to the world.
Public method | RebaseToWorkplane | Rebases the polyline from the world to the specified workplane.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List Point .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List Point .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List Point .)
Public method | Repoint | Repoints the curve creating the specified number of points.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List Point .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List Point .)
Public method | RotateAboutXAxis | Rotates the entire polyline by the specified angle about the X axis and the specified origin within the ActiveWorkplane - or the world if none is set.
Public method | RotateAboutYAxis | Rotates the entire polyline by the specified angle about the Y axis and the specified origin within the ActiveWorkplane - or the world if none is set.
Public method | RotateAboutZAxis | Rotates the entire polyline by the specified angle about the Z axis and the specified origin within the ActiveWorkplane - or the world if none is set.
Public method | Scale(Double) | Scales the Polyline about the origin by the specified scaling factor. All points are scaled.
Public method | Scale(Point, Double) | Scales the Polyline about the specified origin and by the specified scaling factor. All points are scaled.
Public method | Scale(Double, Double, Double) | Scales the Polyline about the origin using the specified scaling factors. All points are scaled.
Public method | Scale(Point, Double, Double, Double) | Scales the Polyline about the specified origin and using the specified scaling factors. All points are scaled.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List Point .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List Point .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List Point .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List Point .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List Point .)
Public method | ToPointCloud | Returns a PointCloud of all points on the PolyLine.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List Point .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | WriteToASCIIFile | Writes the Polyline to the specified ascii file. Each point on the Polyline is written as a seperate line in the file, each coordinate being delimited from the next with a space.
Public method | WriteToDUCTPictureFile | Writes this Polyline to the specified DUCT picture file. The file is always written in MM, as that is the unit of measure of the Polyline.
Top
See Also

Reference

Autodesk.Geometry Namespace


Polyline Constructor

Overload List
 | Name | Description
Public method | Polyline | Constructs an empty PolyLine.
Public method | Polyline(File) | Constructs a Polyline and initialises it from an ASCII file. Each line of the file comprises the three coordinates of each point seperated by spaces. I.e. A.AAA B.BBB C.CCC D.DDD E.EEE F.FFF ... etc.
Public method | Polyline(ListPoint) | Constructs a PolyLine with the specified list of points.
Public method | Polyline(ListPoint, Boolean) | Constructs a Polyline, initialises the list of points to the specified value and, if specified, closes the line.
Public method | Polyline(Spline, Double) | Constructs a Polyline from a SplineCurve, fitting it to the specified tolerance.
Top
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline Constructor

Constructs an empty PolyLine.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Polyline()
Public Sub New
See Also

Reference

Polyline Class
Polyline Overload
Autodesk.Geometry Namespace


Polyline Constructor (File)

Constructs a Polyline and initialises it from an ASCII file. Each line of the file comprises the three coordinates of each point seperated by spaces.
I.e.

A.AAA B.BBB C.CCC
D.DDD E.EEE F.FFF
...
etc.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Polyline(
    File asciiFile
)
Public Sub New (
    asciiFile As File
)

Parameters

asciiFile
Type: Autodesk.FileSystemFile
ASCII file from which to read the Polyline data.
See Also

Reference

Polyline Class
Polyline Overload
Autodesk.Geometry Namespace


Polyline Constructor (List(Point))

Polyline Constructor (ListPoint)

Constructs a PolyLine with the specified list of points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Polyline(
    List<Point> points
)
Public Sub New (
    points As List(Of Point)
)

Parameters

points
Type: System.Collections.GenericList Point
Points with which to initialise the Polyline.
See Also

Reference

Polyline Class
Polyline Overload
Autodesk.Geometry Namespace


Polyline Constructor (List(Point), Boolean)

Polyline Constructor (ListPoint, Boolean)

Constructs a Polyline, initialises the list of points to the specified value and, if specified, closes the line.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Polyline(
    List<Point> points,
    bool isClosed
)
Public Sub New (
    points As List(Of Point),
    isClosed As Boolean
)

Parameters

points
Type: System.Collections.GenericList Point
List of points with which to initialise the Polyline.
isClosed
Type: SystemBoolean
If True, the Polyline is closed. False otherwise.
See Also

Reference

Polyline Class
Polyline Overload
Autodesk.Geometry Namespace


Polyline Constructor (Spline, Double)

Constructs a Polyline from a SplineCurve, fitting it to the specified tolerance.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Polyline(
    Spline splineCurve,
    double tolerance
)
Public Sub New (
    splineCurve As Spline,
    tolerance As Double
)

Parameters

splineCurve
Type: Autodesk.GeometrySpline
SplineCurve from which to create the Polyline.
tolerance
Type: SystemDouble
Square tolerance within which to fit the spline curve.
See Also

Reference

Polyline Class
Polyline Overload
Autodesk.Geometry Namespace


Polyline Properties

The Polyline type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox of the Polyline. Nothing if the Polyline contains no points.
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List Point .)
Public property | Centre | Centre point of the Polyline.
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List Point .)
Public property | IsClosed | True if the Polyline is closed; false otherwise.
Public property | Item | Gets or sets the element at the specified index. (Inherited from List Point .)
Public property | Length | Length of the Polyline.
Public property | LengthMap | List of distances between consecutive points. The 1st element of the list will be zero because it is the first point. The 2nd element of the list will be the distance between the 2nd point of the polyline and the 1st point. In generic terms, LengthMap will contain Point(n) - Point(n-1).
Public property | Normal | Vector normal to the centre of the Polyline.
Top
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.BoundingBox Property

PolylineBoundingBox Property

BoundingBox of the Polyline. Nothing if the Polyline contains no points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox BoundingBox { get; }
Public ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Centre Property

PolylineCentre Property

Centre point of the Polyline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Centre { get; }
Public ReadOnly Property Centre As Point
    Get

Property Value

Type: Point
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.IsClosed Property

PolylineIsClosed Property

True if the Polyline is closed; false otherwise.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsClosed { get; set; }
Public Property IsClosed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Length Property

PolylineLength Property

Length of the Polyline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; }
Public ReadOnly Property Length As MM
    Get

Property Value

Type: MM
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.LengthMap Property

PolylineLengthMap Property

List of distances between consecutive points. The 1st element of the list will be zero because it is the first point. The 2nd element of the list will be the distance between the 2nd point of the polyline and the 1st point. In generic terms, LengthMap will contain Point(n) - Point(n-1).

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<MM> LengthMap { get; }
Public ReadOnly Property LengthMap As List(Of MM)
    Get

Property Value

Type: List MM
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Normal Property

PolylineNormal Property

Vector normal to the centre of the Polyline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector Normal { get; }
Public ReadOnly Property Normal As Vector
    Get

Property Value

Type: Vector
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline Methods

The Polyline type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List Point .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List Point .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List Point .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Point .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List Point .)
Public method | Clone | Returns a clone of this Polyline.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List Point .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List Point .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List Point .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Point .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Point .)
Public method | Densify | Ensures that no connecting line exceeds the specified span length. If such a line exists, a point(s) is inserted and the line split. Linearity is preserved.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Point .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Point .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Point .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Point .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List Point .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List Point .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List Point .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Point .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Point .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Point .)
Public method | IndexOfNearestPoint | Returns to the caller the index of the point on the Polyline that is nearest to that specified in the single input argument.
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List Point .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List Point .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Point .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Point .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Point .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the polyline by the specified Vector. All points are displaced.
Public method | NextPointIndex | Returns to the caller the index of the next point after the one specified. If the specified index is greater or equal to the end of the line, the start index is returned.
 | ReadFromDUCTPictureFile | Extracts Polylines from a DUCT picture file and returns them as a list.
Public method | RebaseFromWorkplane | Rebases the polyline from the specified workplane to the world.
Public method | RebaseToWorkplane | Rebases the polyline from the world to the specified workplane.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List Point .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List Point .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List Point .)
Public method | Repoint | Repoints the curve creating the specified number of points.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List Point .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List Point .)
Public method | RotateAboutXAxis | Rotates the entire polyline by the specified angle about the X axis and the specified origin within the ActiveWorkplane - or the world if none is set.
Public method | RotateAboutYAxis | Rotates the entire polyline by the specified angle about the Y axis and the specified origin within the ActiveWorkplane - or the world if none is set.
Public method | RotateAboutZAxis | Rotates the entire polyline by the specified angle about the Z axis and the specified origin within the ActiveWorkplane - or the world if none is set.
Public method | Scale(Double) | Scales the Polyline about the origin by the specified scaling factor. All points are scaled.
Public method | Scale(Point, Double) | Scales the Polyline about the specified origin and by the specified scaling factor. All points are scaled.
Public method | Scale(Double, Double, Double) | Scales the Polyline about the origin using the specified scaling factors. All points are scaled.
Public method | Scale(Point, Double, Double, Double) | Scales the Polyline about the specified origin and using the specified scaling factors. All points are scaled.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List Point .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List Point .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List Point .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List Point .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List Point .)
Public method | ToPointCloud | Returns a PointCloud of all points on the PolyLine.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List Point .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List Point .)
Public method | WriteToASCIIFile | Writes the Polyline to the specified ascii file. Each point on the Polyline is written as a seperate line in the file, each coordinate being delimited from the next with a space.
Public method | WriteToDUCTPictureFile | Writes this Polyline to the specified DUCT picture file. The file is always written in MM, as that is the unit of measure of the Polyline.
Top
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Clone Method

PolylineClone Method

Returns a clone of this Polyline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Polyline Clone()
Public Function Clone As Polyline

Return Value

Type: Polyline
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Densify Method

PolylineDensify Method

Ensures that no connecting line exceeds the specified span length. If such a line exists, a point(s) is inserted and the line split. Linearity is preserved.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Densify(
    double maximumSpanLength
)
Public Sub Densify (
    maximumSpanLength As Double
)

Parameters

maximumSpanLength
Type: SystemDouble
Maximum permissible span length.
Remarks
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.IndexOfNearestPoint Method

PolylineIndexOfNearestPoint Method

Returns to the caller the index of the point on the Polyline that is nearest to that specified in the single input argument.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int IndexOfNearestPoint(
    Point testPoint
)
Public Function IndexOfNearestPoint (
    testPoint As Point
) As Integer

Parameters

testPoint
Type: Autodesk.GeometryPoint
Point for which to find the nearest point on the Polyline.

Return Value

Type: Int32
Index of the nearest Polyline point to that specified.
Exceptions
Exception | Condition
Exception | Thrown if the PolyLine contains no points.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Move Method

PolylineMove Method

Moves the polyline by the specified Vector. All points are displaced.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Move(
    Vector offset
)
Public Sub Move (
    offset As Vector
)

Parameters

offset
Type: Autodesk.GeometryVector
Vector specifying offset.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.NextPointIndex Method

PolylineNextPointIndex Method

Returns to the caller the index of the next point after the one specified. If the specified index is greater or equal to the end of the line, the start index is returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NextPointIndex(
    int index
)
Public Function NextPointIndex (
    index As Integer
) As Integer

Parameters

index
Type: SystemInt32
Index prior to the one that is to be returned.

Return Value

Type: Int32
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.ReadFromDUCTPictureFile Method

PolylineReadFromDUCTPictureFile Method

Extracts Polylines from a DUCT picture file and returns them as a list.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<Polyline> ReadFromDUCTPictureFile(
    File file
)
Public Shared Function ReadFromDUCTPictureFile (
    file As File
) As List(Of Polyline)

Parameters

file
Type: Autodesk.FileSystemFile
DUCT picture file.

Return Value

Type: List Polyline
List of polylines.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.RebaseFromWorkplane Method

PolylineRebaseFromWorkplane Method

Rebases the polyline from the specified workplane to the world.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RebaseFromWorkplane(
    Workplane fromWorkplane
)
Public Sub RebaseFromWorkplane (
    fromWorkplane As Workplane
)

Parameters

fromWorkplane
Type: Autodesk.GeometryWorkplane
Workplane from which the line is to be rebased.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.RebaseToWorkplane Method

PolylineRebaseToWorkplane Method

Rebases the polyline from the world to the specified workplane.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RebaseToWorkplane(
    Workplane toWorkplane
)
Public Sub RebaseToWorkplane (
    toWorkplane As Workplane
)

Parameters

toWorkplane
Type: Autodesk.GeometryWorkplane
Destination workplane.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Repoint Method

PolylineRepoint Method

Repoints the curve creating the specified number of points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Repoint(
    int numberOfPoints
)
Public Sub Repoint (
    numberOfPoints As Integer
)

Parameters

numberOfPoints
Type: SystemInt32
The number of new points that are added to the curve and evenly distributed between the start and end points.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.RotateAboutXAxis Method

PolylineRotateAboutXAxis Method

Rotates the entire polyline by the specified angle about the X axis and the specified origin within the ActiveWorkplane - or the world if none is set.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutXAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutXAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin about which to rotate the line.
angle
Type: Autodesk.GeometryRadian
Number of radians to rotate.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.RotateAboutYAxis Method

PolylineRotateAboutYAxis Method

Rotates the entire polyline by the specified angle about the Y axis and the specified origin within the ActiveWorkplane - or the world if none is set.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutYAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutYAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin about which to rotate the line.
angle
Type: Autodesk.GeometryRadian
Number of radians to rotate.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.RotateAboutZAxis Method

PolylineRotateAboutZAxis Method

Rotates the entire polyline by the specified angle about the Z axis and the specified origin within the ActiveWorkplane - or the world if none is set.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutZAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutZAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin about which to rotate the line.
angle
Type: Autodesk.GeometryRadian
Number of radians to rotate.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Scale Method

PolylineScale Method

Overload List
 | Name | Description
Public method | Scale(Double) | Scales the Polyline about the origin by the specified scaling factor. All points are scaled.
Public method | Scale(Point, Double) | Scales the Polyline about the specified origin and by the specified scaling factor. All points are scaled.
Public method | Scale(Double, Double, Double) | Scales the Polyline about the origin using the specified scaling factors. All points are scaled.
Public method | Scale(Point, Double, Double, Double) | Scales the Polyline about the specified origin and using the specified scaling factors. All points are scaled.
Top
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.Scale Method (Double)

PolylineScale Method (Double)

Scales the Polyline about the origin by the specified scaling factor. All points are scaled.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    double scalar
)
Public Sub Scale (
    scalar As Double
)

Parameters

scalar
Type: SystemDouble
Factor by which to scale.
See Also

Reference

Polyline Class
Scale Overload
Autodesk.Geometry Namespace


Polyline.Scale Method (Point, Double)

PolylineScale Method (Point, Double)

Scales the Polyline about the specified origin and by the specified scaling factor. All points are scaled.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    Point origin,
    double scalar
)
Public Sub Scale (
    origin As Point,
    scalar As Double
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin about which to scale.
scalar
Type: SystemDouble
Factor by which to scale.
See Also

Reference

Polyline Class
Scale Overload
Autodesk.Geometry Namespace


Polyline.Scale Method (Double, Double, Double)

PolylineScale Method (Double, Double, Double)

Scales the Polyline about the origin using the specified scaling factors. All points are scaled.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    double scalarX,
    double scalarY,
    double scalarZ
)
Public Sub Scale (
    scalarX As Double,
    scalarY As Double,
    scalarZ As Double
)

Parameters

scalarX
Type: SystemDouble
Factor by which to scale in X.
scalarY
Type: SystemDouble
Factor by which to scale in Y.
scalarZ
Type: SystemDouble
Factor by which to scale in Z.
See Also

Reference

Polyline Class
Scale Overload
Autodesk.Geometry Namespace


Polyline.Scale Method (Point, Double, Double, Double)

PolylineScale Method (Point, Double, Double, Double)

Scales the Polyline about the specified origin and using the specified scaling factors. All points are scaled.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    Point origin,
    double scalarX,
    double scalarY,
    double scalarZ
)
Public Sub Scale (
    origin As Point,
    scalarX As Double,
    scalarY As Double,
    scalarZ As Double
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin about which to scale.
scalarX
Type: SystemDouble
Factor by which to scale in X.
scalarY
Type: SystemDouble
Factor by which to scale in Y.
scalarZ
Type: SystemDouble
Factor by which to scale in Z.
See Also

Reference

Polyline Class
Scale Overload
Autodesk.Geometry Namespace


Polyline.ToPointCloud Method

PolylineToPointCloud Method

Returns a PointCloud of all points on the PolyLine.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointCloud ToPointCloud()
Public Function ToPointCloud As PointCloud

Return Value

Type: PointCloud
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.WriteToASCIIFile Method

PolylineWriteToASCIIFile Method

Writes the Polyline to the specified ascii file. Each point on the Polyline is written as a seperate line in the file, each coordinate being delimited from the next with a space.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToASCIIFile(
    File asciiFile
)
Public Sub WriteToASCIIFile (
    asciiFile As File
)

Parameters

asciiFile
Type: Autodesk.FileSystemFile
ASCII file to to be written.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Polyline.WriteToDUCTPictureFile Method

PolylineWriteToDUCTPictureFile Method

Writes this Polyline to the specified DUCT picture file. The file is always written in MM, as that is the unit of measure of the Polyline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToDUCTPictureFile(
    File file
)
Public Sub WriteToDUCTPictureFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
DUCT file to be written.
See Also

Reference

Polyline Class
Autodesk.Geometry Namespace


Radian Structure

Structure encapsulating all operations for manipulating angles in radians.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct Radian : IFormattable, IComparable
<SerializableAttribute>
Public Structure Radian
    Implements IFormattable, IComparable

The Radian type exposes the following members.

Constructors
 | Name | Description
Public method | Radian | Constructs a Radian structure and initialises the angle to the specified number of radians.
Top
Properties
 | Name | Description
Public property | Value | Value of the angle in radians.
Top
Methods
 | Name | Description
Public method | CompareTo | Determines whether the passed argument is before or after this one in logical sort order.
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type Degree or Radian, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type Degree or Radian, false will be returned.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string representation of the value in radians. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Returns a formatted string representation of the value in radians.
Public method | ToString(String, IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified format and culture-specific format information.
Top
Operators
Name | Description
Addition(String, Radian) | Concatenates a string with the string representation of a Radian object.
Addition(Radian, Radian) | Add one Radian object to another.
Addition(Radian, String) | Concatenates the string representation of a Radian object with a string.
Division(Radian, Radian) | Division of one Radian object by another.
Division(Radian, Double) | Division of one Radian object by a double.
Equality | Determine whether two Radian objects are equal.
(Radian to Single) | Cast a Radian object to Single.
(Radian to Decimal) | Cast a Radian object to Decimal.
GreaterThan | Determine whether the left-hand Radian object is greater than the right.
GreaterThanOrEqual | Determine whether the left-hand Radian object is greater than or equal to the right.
(Double to Radian) | Cast a double to a Radian object.
(Degree to Radian) | Cast a Degree object to a Radian object.
(Radian to Double) | Cast a Radian object to double.
Inequality | Determine whether two Radian objects are not equal.
LessThan | Determine whether the left-hand Radian object is less than the right.
LessThanOrEqual | Determine whether the left-hand Radian object is less than or equal to the right.
Multiply(Double, Radian) | Multiplication of a double by a Radian object.
Multiply(Radian, Radian) | Multiplication of two Radian objects.
Multiply(Radian, Double) | Multiplication of a Radian object by a double.
Subtraction | Subtract one Radian object from another.
UnaryNegation | Negates the current value of the angle.
Top
See Also

Reference

Autodesk.Geometry Namespace


Radian Constructor

Constructs a Radian structure and initialises the angle to the specified number of radians.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Radian(
    double angle
)
Public Sub New (
    angle As Double
)

Parameters

angle
Type: SystemDouble
Initial angle.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian Properties

The Radian type exposes the following members.

Properties
 | Name | Description
Public property | Value | Value of the angle in radians.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.Value Property

RadianValue Property

Value of the angle in radians.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The angle in radians.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian Methods

The Radian type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Determines whether the passed argument is before or after this one in logical sort order.
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type Degree or Radian, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type Degree or Radian, false will be returned.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string representation of the value in radians. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Returns a formatted string representation of the value in radians.
Public method | ToString(String, IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.CompareTo Method

RadianCompareTo Method

Determines whether the passed argument is before or after this one in logical sort order.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: SystemObject
Passed object to compare. Must be of type Radian.

Return Value

Type: Int32
Integer detailing the relative ordering of the two objects in the sort order: If zero, both occur in the same position; negative and this object preceeds the passed argument and, if positive, this object comes after the passed argument.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | Thrown if the object to compare is not of type Radian.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.Equals Method

RadianEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type Degree or Radian, false will be returned. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Object, Int32) | Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type Degree or Radian, false will be returned.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.Equals Method (Object)

RadianEquals Method (Object)

Returns True if the magnitude of this object is equivalent to that of the specified object. If the specified object is neither of type Degree or Radian, false will be returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Object with which to compare this.

Return Value

Type: Boolean
True if the magnitudes of this and the specified object are equivalent; false otherwise.
See Also

Reference

Radian Structure
Equals Overload
Autodesk.Geometry Namespace


Radian.Equals Method (Object, Int32)

RadianEquals Method (Object, Int32)

Returns True if the magnitude of this object is equivalent to that of the specified object to the specified number of decimal places. If the specified object is neither of type Degree or Radian, false will be returned.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    Object obj,
    int nDecPts
)
Public Function Equals (
    obj As Object,
    nDecPts As Integer
) As Boolean

Parameters

obj
Type: SystemObject
Object with which to compare this.
nDecPts
Type: SystemInt32
Number of decimal places to compare.

Return Value

Type: Boolean
True if the magnitudes of this and the specified object are considered equivalent; false otherwise.
See Also

Reference

Radian Structure
Equals Overload
Autodesk.Geometry Namespace


Radian.ToString Method

RadianToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string representation of the value in radians. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Returns a formatted string representation of the value in radians.
Public method | ToString(String, IFormatProvider) | Returns the numeric value of this instance in its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.ToString Method

RadianToString Method

Returns a string representation of the value in radians.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
String representation of the value in radians.
See Also

Reference

Radian Structure
ToString Overload
Autodesk.Geometry Namespace


Radian.ToString Method (IFormatProvider)

RadianToString Method (IFormatProvider)

Returns the numeric value of this instance in its equivalent string representation using the specified culture-specific format information.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    IFormatProvider fp
)
Public Function ToString (
    fp As IFormatProvider
) As String

Parameters

fp
Type: SystemIFormatProvider
Custom object implementing the IFormatProvider interface.

Return Value

Type: String
String representation of the value in radians.
See Also

Reference

Radian Structure
ToString Overload
Autodesk.Geometry Namespace


Radian.ToString Method (String)

RadianToString Method (String)

Returns a formatted string representation of the value in radians.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String

Parameters

format
Type: SystemString
Standard numeric fornat specifier.

Return Value

Type: String
String representation of the value in radians.
See Also

Reference

Radian Structure
ToString Overload
Autodesk.Geometry Namespace


Radian.ToString Method (String, IFormatProvider)

RadianToString Method (String, IFormatProvider)

Returns the numeric value of this instance in its equivalent string representation using the specified format and culture-specific format information.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToString(
    string format,
    IFormatProvider fp
)
Public Function ToString (
    format As String,
    fp As IFormatProvider
) As String

Parameters

format
Type: SystemString
Standard numeric fornat specifier.
fp
Type: SystemIFormatProvider
Custom object implementing the IFormatProvider interface.

Return Value

Type: String
String representation of the value in radians.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Radian Structure
ToString Overload
Autodesk.Geometry Namespace


Radian Operators and Type Conversions

The Radian type exposes the following members.

Operators
Name | Description
Addition(String, Radian) | Concatenates a string with the string representation of a Radian object.
Addition(Radian, Radian) | Add one Radian object to another.
Addition(Radian, String) | Concatenates the string representation of a Radian object with a string.
Division(Radian, Radian) | Division of one Radian object by another.
Division(Radian, Double) | Division of one Radian object by a double.
Equality | Determine whether two Radian objects are equal.
(Radian to Single) | Cast a Radian object to Single.
(Radian to Decimal) | Cast a Radian object to Decimal.
GreaterThan | Determine whether the left-hand Radian object is greater than the right.
GreaterThanOrEqual | Determine whether the left-hand Radian object is greater than or equal to the right.
(Double to Radian) | Cast a double to a Radian object.
(Degree to Radian) | Cast a Degree object to a Radian object.
(Radian to Double) | Cast a Radian object to double.
Inequality | Determine whether two Radian objects are not equal.
LessThan | Determine whether the left-hand Radian object is less than the right.
LessThanOrEqual | Determine whether the left-hand Radian object is less than or equal to the right.
Multiply(Double, Radian) | Multiplication of a double by a Radian object.
Multiply(Radian, Radian) | Multiplication of two Radian objects.
Multiply(Radian, Double) | Multiplication of a Radian object by a double.
Subtraction | Subtract one Radian object from another.
UnaryNegation | Negates the current value of the angle.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.Addition Operator

RadianAddition Operator

Overload List
Name | Description
Addition(String, Radian) | Concatenates a string with the string representation of a Radian object.
Addition(Radian, Radian) | Add one Radian object to another.
Addition(Radian, String) | Concatenates the string representation of a Radian object with a string.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.Addition Operator (String, Radian)

RadianAddition Operator (String, Radian)

Concatenates a string with the string representation of a Radian object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string operator +(
    string left,
    Radian right
)
Public Shared Operator + (
    left As String,
    right As Radian
) As String

Parameters

left
Type: SystemString
String with which to concatenate a Radian object.
right
Type: Autodesk.GeometryRadian
Radian object to concatenate .

Return Value

Type: String
Returns a string containing the result of the concatenation.
See Also

Reference

Radian Structure
Addition Overload
Autodesk.Geometry Namespace


Radian.Addition Operator (Radian, Radian)

RadianAddition Operator (Radian, Radian)

Add one Radian object to another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Radian operator +(
    Radian left,
    Radian right
)
Public Shared Operator + (
    left As Radian,
    right As Radian
) As Radian

Parameters

left
Type: Autodesk.GeometryRadian
First of two Radian objects to be summed.
right
Type: Autodesk.GeometryRadian
Second of two Radian objects to be summed.

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Addition Overload
Autodesk.Geometry Namespace


Radian.Addition Operator (Radian, String)

RadianAddition Operator (Radian, String)

Concatenates the string representation of a Radian object with a string.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string operator +(
    Radian left,
    string right
)
Public Shared Operator + (
    left As Radian,
    right As String
) As String

Parameters

left
Type: Autodesk.GeometryRadian
Radian object with which to concatenate a string.
right
Type: SystemString
String to concatenate .

Return Value

Type: String
Returns a string containing the result of the concatenation.
See Also

Reference

Radian Structure
Addition Overload
Autodesk.Geometry Namespace


Radian.Division Operator

RadianDivision Operator

Overload List
Name | Description
Division(Radian, Radian) | Division of one Radian object by another.
Division(Radian, Double) | Division of one Radian object by a double.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.Division Operator (Radian, Radian)

RadianDivision Operator (Radian, Radian)

Division of one Radian object by another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Radian operator /(
    Radian left,
    Radian right
)
Public Shared Operator / (
    left As Radian,
    right As Radian
) As Radian

Parameters

left
Type: Autodesk.GeometryRadian
Radian object to be divided (dividend).
right
Type: Autodesk.GeometryRadian
Radian object to divide with (divisor).

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Division Overload
Autodesk.Geometry Namespace


Radian.Division Operator (Radian, Double)

RadianDivision Operator (Radian, Double)

Division of one Radian object by a double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Radian operator /(
    Radian left,
    double right
)
Public Shared Operator / (
    left As Radian,
    right As Double
) As Radian

Parameters

left
Type: Autodesk.GeometryRadian
Radian object to be divided (dividend).
right
Type: SystemDouble
Double to divide by (divisor).

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Division Overload
Autodesk.Geometry Namespace


Radian.Equality Operator

RadianEquality Operator

Determine whether two Radian objects are equal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator ==(
    Radian left,
    Radian right
)
Public Shared Operator = (
    left As Radian,
    right As Radian
) As Boolean

Parameters

left
Type: Autodesk.GeometryRadian
First of two Radian objects to compare.
right
Type: Autodesk.GeometryRadian
Second of two Radian objects to compare.

Return Value

Type: Boolean
Returns True if the two Radian objects are equivalent; false otherwise.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian Explicit Conversion Operators

Radian Conversion Operators

Overload List
Name | Description
(Radian to Single) | Cast a Radian object to Single.
(Radian to Decimal) | Cast a Radian object to Decimal.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian Explicit Conversion (Radian to Single)

Radian Conversion (Radian to Single)

Cast a Radian object to Single.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator float (
    Radian left
)
Public Shared Narrowing Operator CType (
    left As Radian
) As Single

Parameters

left
Type: Autodesk.GeometryRadian
Radian object to cast.

Return Value

Type: Single
Single representation of the Radian object.
See Also

Reference

Radian Structure
Overload
Autodesk.Geometry Namespace


Radian Explicit Conversion (Radian to Decimal)

Radian Conversion (Radian to Decimal)

Cast a Radian object to Decimal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static explicit operator decimal (
    Radian left
)
Public Shared Narrowing Operator CType (
    left As Radian
) As Decimal

Parameters

left
Type: Autodesk.GeometryRadian
Radian object to cast.

Return Value

Type: Decimal
Decimal representation of the Radian object.
See Also

Reference

Radian Structure
Overload
Autodesk.Geometry Namespace


Radian.GreaterThan Operator

RadianGreaterThan Operator

Determine whether the left-hand Radian object is greater than the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >(
    Radian left,
    Radian right
)
Public Shared Operator > (
    left As Radian,
    right As Radian
) As Boolean

Parameters

left
Type: Autodesk.GeometryRadian
First of two Radian objects to compare.
right
Type: Autodesk.GeometryRadian
Second of two Radian objects to compare.

Return Value

Type: Boolean
Returns True if the left-hand Radian object is greater than the right; false otherwise.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.GreaterThanOrEqual Operator

RadianGreaterThanOrEqual Operator

Determine whether the left-hand Radian object is greater than or equal to the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator >=(
    Radian left,
    Radian right
)
Public Shared Operator >= (
    left As Radian,
    right As Radian
) As Boolean

Parameters

left
Type: Autodesk.GeometryRadian
First of two Radian objects to compare.
right
Type: Autodesk.GeometryRadian
Second of two Radian objects to compare.

Return Value

Type: Boolean
Returns True if the left-hand Radian object is greater than or equal to the right; false otherwise.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian Implicit Conversion Operators

Radian Conversion Operators

Overload List
Name | Description
(Double to Radian) | Cast a double to a Radian object.
(Degree to Radian) | Cast a Degree object to a Radian object.
(Radian to Double) | Cast a Radian object to double.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian Implicit Conversion (Double to Radian)

Radian Conversion (Double to Radian)

Cast a double to a Radian object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator Radian (
    double left
)
Public Shared Widening Operator CType (
    left As Double
) As Radian

Parameters

left
Type: SystemDouble
Double to cast.

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Overload
Autodesk.Geometry Namespace


Radian Implicit Conversion (Degree to Radian)

Radian Conversion (Degree to Radian)

Cast a Degree object to a Radian object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator Radian (
    Degree left
)
Public Shared Widening Operator CType (
    left As Degree
) As Radian

Parameters

left
Type: Autodesk.GeometryDegree
Degree object to cast.

Return Value

Type: Radian
Radian representation of the Degree object.
See Also

Reference

Radian Structure
Overload
Autodesk.Geometry Namespace


Radian Implicit Conversion (Radian to Double)

Radian Conversion (Radian to Double)

Cast a Radian object to double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static implicit operator double (
    Radian left
)
Public Shared Widening Operator CType (
    left As Radian
) As Double

Parameters

left
Type: Autodesk.GeometryRadian
Radian object to cast.

Return Value

Type: Double
Double representation of the Radian object.
See Also

Reference

Radian Structure
Overload
Autodesk.Geometry Namespace


Radian.Inequality Operator

RadianInequality Operator

Determine whether two Radian objects are not equal.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator !=(
    Radian left,
    Radian right
)
Public Shared Operator <> (
    left As Radian,
    right As Radian
) As Boolean

Parameters

left
Type: Autodesk.GeometryRadian
First of two Radian objects to compare.
right
Type: Autodesk.GeometryRadian
Second of two Radian objects to compare.

Return Value

Type: Boolean
Returns True if the two Radian objects are unquivalent; false otherwise.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.LessThan Operator

RadianLessThan Operator

Determine whether the left-hand Radian object is less than the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <(
    Radian left,
    Radian right
)
Public Shared Operator < (
    left As Radian,
    right As Radian
) As Boolean

Parameters

left
Type: Autodesk.GeometryRadian
First of two Radian objects to compare.
right
Type: Autodesk.GeometryRadian
Second of two Radian objects to compare.

Return Value

Type: Boolean
Returns True if the left-hand Radian object is less than the right; false otherwise.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.LessThanOrEqual Operator

RadianLessThanOrEqual Operator

Determine whether the left-hand Radian object is less than or equal to the right.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator <=(
    Radian left,
    Radian right
)
Public Shared Operator <= (
    left As Radian,
    right As Radian
) As Boolean

Parameters

left
Type: Autodesk.GeometryRadian
First of two Radian objects to compare.
right
Type: Autodesk.GeometryRadian
Second of two Radian objects to compare.

Return Value

Type: Boolean
Returns True if the left-hand Radian object is less than or equal to the right; false otherwise.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.Multiply Operator

RadianMultiply Operator

Overload List
Name | Description
Multiply(Double, Radian) | Multiplication of a double by a Radian object.
Multiply(Radian, Radian) | Multiplication of two Radian objects.
Multiply(Radian, Double) | Multiplication of a Radian object by a double.
Top
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.Multiply Operator (Double, Radian)

RadianMultiply Operator (Double, Radian)

Multiplication of a double by a Radian object.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Radian operator *(
    double left,
    Radian right
)
Public Shared Operator * (
    left As Double,
    right As Radian
) As Radian

Parameters

left
Type: SystemDouble
First of two parameters to multiply (multiplicand).
right
Type: Autodesk.GeometryRadian
Second of two parameters to multiply (multiplier).

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Multiply Overload
Autodesk.Geometry Namespace


Radian.Multiply Operator (Radian, Radian)

RadianMultiply Operator (Radian, Radian)

Multiplication of two Radian objects.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Radian operator *(
    Radian left,
    Radian right
)
Public Shared Operator * (
    left As Radian,
    right As Radian
) As Radian

Parameters

left
Type: Autodesk.GeometryRadian
First of two Radian objects to be multiplied (multiplicand).
right
Type: Autodesk.GeometryRadian
Second of two Radian objects to be multiplied (multiplier).

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Multiply Overload
Autodesk.Geometry Namespace


Radian.Multiply Operator (Radian, Double)

RadianMultiply Operator (Radian, Double)

Multiplication of a Radian object by a double.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Radian operator *(
    Radian left,
    double right
)
Public Shared Operator * (
    left As Radian,
    right As Double
) As Radian

Parameters

left
Type: Autodesk.GeometryRadian
First of two parameters to multiply (multiplicand).
right
Type: SystemDouble
Second of two parameters to multiply (multiplier).

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Multiply Overload
Autodesk.Geometry Namespace


Radian.Subtraction Operator

RadianSubtraction Operator

Subtract one Radian object from another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Radian operator -(
    Radian left,
    Radian right
)
Public Shared Operator - (
    left As Radian,
    right As Radian
) As Radian

Parameters

left
Type: Autodesk.GeometryRadian
Radian object from which to subtract (minuend).
right
Type: Autodesk.GeometryRadian
Radian object to subtract (subtrahend).

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Radian.UnaryNegation Operator

RadianUnaryNegation Operator

Negates the current value of the angle.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Radian operator -(
    Radian right
)
Public Shared Operator - (
    right As Radian
) As Radian

Parameters

right
Type: Autodesk.GeometryRadian
Radian object to negate.

Return Value

Type: Radian
New Radian object containing the result of the operation.
See Also

Reference

Radian Structure
Autodesk.Geometry Namespace


Spline Class

Encapsulates a Spline Curve.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList SplinePoint
Autodesk.GeometrySpline

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Spline : List<SplinePoint>
<SerializableAttribute>
Public Class Spline
    Inherits List(Of SplinePoint)

The Spline type exposes the following members.

Constructors
 | Name | Description
Public method | Spline | Constructs an empty curve.
Public method | Spline(SplinePoint) | Constructs a new spline curve from an array of spline points
Public method | Spline(ListSplinePoint) | Constructs a new spline curve from a list of spline points.
Public method | Spline(ListPoint, Boolean) | Constructs a best-fit spline curve through the specified ordered points.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List SplinePoint .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List SplinePoint .)
Public property | IsClosed | True if spline is closed; false otherwise.
Public property | Item | Gets or sets the element at the specified index. (Inherited from List SplinePoint .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List SplinePoint .)
Public method | AddPointToEndOfSpline | Adds a point to the end of this spline.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List SplinePoint .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List SplinePoint .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List SplinePoint .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List SplinePoint .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List SplinePoint .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List SplinePoint .)
Public method | Clone | Returns a clone of this spline.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List SplinePoint .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List SplinePoint .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List SplinePoint .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List SplinePoint .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List SplinePoint .)
 | CubicBezier | Evaluates the specific point on a cubic bezier curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List SplinePoint .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List SplinePoint .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List SplinePoint .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List SplinePoint .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List SplinePoint .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List SplinePoint .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List SplinePoint .)
Public method | FreeChordMagnitudes | Frees chord magnitudes for the specified span.
Public method | FreeCurveDirections | Frees the tangent directions through all points on the curve.
Public method | FreeCurveMagnitudes | Frees the magnitudes through all points on the curve.
Public method | FreePointDirections | Frees the entry and exit direction of a point
Public method | FreePointMagnitudes | Frees magnitude for the specified point. This is a variation of the FreeChordMagnitudes() method.
Public method | FreeTangentsAndMagnitudes | Frees the tangent directions and magnitudes through all points on the curve.
Public method | GetBezierCurve | The specified span as a CubicBezier.
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List SplinePoint .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLengthBetweenPoints | Approximates the length between the two specified points along the path of the spline.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List SplinePoint .)
Public method | GetSpanControlPoint | Control point for the specified span and index.
Public method | GetSpanControlPoints | Control points of the specified span.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List SplinePoint .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List SplinePoint .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List SplinePoint .)
Public method | InsertPoint | Inserts the specified point into this spline. If inserted in the middle, then no control points in the existing spline are changed. If inserted at the beginning or end of the spline, the join is smoothed without altering the shape of the original spline.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List SplinePoint .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List SplinePoint .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List SplinePoint .)
Public method | LinearExtension | Applies a linear extension to either the start or to the end of this spline.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadFromDUCTPictureFile | Extracts spline curves from a DUCT picture file and returns them to the caller.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List SplinePoint .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List SplinePoint .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List SplinePoint .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List SplinePoint .)
Public method | ReorderClosedSpline | If closed, reorders this spline so that it has a new start point.
Public method | Reverse | Reverses the curve
Public method | Reverse(Int32, Int32) | Reverses the curve between the points specified
Public method | SetSpanControlPoint |
Public method | SetSpanControlPoints |
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List SplinePoint .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List SplinePoint .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List SplinePoint .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List SplinePoint .)
Public method | SplitSpan | Splits the Bezier curve span at the specified index at the point infered from the specified t parameter.
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List SplinePoint .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List SplinePoint .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List SplinePoint .)
Public method | WriteToDUCTPictureFile | Writes this spline to the specified DUCT picture file. The file is written in units of MM as this is the unit of points that constitute the line.
Top
Remarks
A spline curve is similar to a Polyline except every point on the curve has a before and after distance and magnitude value used to control the direction of the curve through the point.
See Also

Reference

Autodesk.Geometry Namespace


Spline Constructor

Overload List
 | Name | Description
Public method | Spline | Constructs an empty curve.
Public method | Spline(SplinePoint) | Constructs a new spline curve from an array of spline points
Public method | Spline(ListSplinePoint) | Constructs a new spline curve from a list of spline points.
Public method | Spline(ListPoint, Boolean) | Constructs a best-fit spline curve through the specified ordered points.
Top
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline Constructor

Constructs an empty curve.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Spline()
Public Sub New
See Also

Reference

Spline Class
Spline Overload
Autodesk.Geometry Namespace


Spline Constructor (SplinePoint[])

Spline Constructor (SplinePoint)

Constructs a new spline curve from an array of spline points

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Spline(
    SplinePoint[] orderedSplinePoints
)
Public Sub New (
    orderedSplinePoints As SplinePoint()
)

Parameters

orderedSplinePoints
Type: Autodesk.GeometrySplinePoint
The spline points through which to create a curve
See Also

Reference

Spline Class
Spline Overload
Autodesk.Geometry Namespace


Spline Constructor (List(SplinePoint))

Spline Constructor (ListSplinePoint)

Constructs a new spline curve from a list of spline points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Spline(
    List<SplinePoint> orderedSplinePoints
)
Public Sub New (
    orderedSplinePoints As List(Of SplinePoint)
)

Parameters

orderedSplinePoints
Type: System.Collections.GenericList SplinePoint
Spline points through which to create the curve.
See Also

Reference

Spline Class
Spline Overload
Autodesk.Geometry Namespace


Spline Constructor (List(Point), Boolean)

Spline Constructor (ListPoint, Boolean)

Constructs a best-fit spline curve through the specified ordered points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Spline(
    List<Point> orderedBestFitPoints,
    bool autoFree = true
)
Public Sub New (
    orderedBestFitPoints As List(Of Point),
    Optional autoFree As Boolean = true
)

Parameters

orderedBestFitPoints
Type: System.Collections.GenericList Point
Ordered list of points to fit.
autoFree (Optional)
Type: SystemBoolean
If true, joins will be smoothed; otherwise points are added to the spline with straight lines.
See Also

Reference

Spline Class
Spline Overload
Autodesk.Geometry Namespace


Spline Properties

The Spline type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List SplinePoint .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List SplinePoint .)
Public property | IsClosed | True if spline is closed; false otherwise.
Public property | Item | Gets or sets the element at the specified index. (Inherited from List SplinePoint .)
Top
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.IsClosed Property

SplineIsClosed Property

True if spline is closed; false otherwise.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsClosed { get; set; }
Public Property IsClosed As Boolean
    Get
    Set

Property Value

Type: Boolean
Exceptions
Exception | Condition
Exception | Thrown if the setting of this property fails to either open or close the spline.
Remarks
The spline is closed if the distance from its first point to its last is zero.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline Methods

The Spline type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List SplinePoint .)
Public method | AddPointToEndOfSpline | Adds a point to the end of this spline.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List SplinePoint .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List SplinePoint .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List SplinePoint .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List SplinePoint .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List SplinePoint .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List SplinePoint .)
Public method | Clone | Returns a clone of this spline.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List SplinePoint .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List SplinePoint .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List SplinePoint .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List SplinePoint .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List SplinePoint .)
 | CubicBezier | Evaluates the specific point on a cubic bezier curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List SplinePoint .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List SplinePoint .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List SplinePoint .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List SplinePoint .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List SplinePoint .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List SplinePoint .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List SplinePoint .)
Public method | FreeChordMagnitudes | Frees chord magnitudes for the specified span.
Public method | FreeCurveDirections | Frees the tangent directions through all points on the curve.
Public method | FreeCurveMagnitudes | Frees the magnitudes through all points on the curve.
Public method | FreePointDirections | Frees the entry and exit direction of a point
Public method | FreePointMagnitudes | Frees magnitude for the specified point. This is a variation of the FreeChordMagnitudes() method.
Public method | FreeTangentsAndMagnitudes | Frees the tangent directions and magnitudes through all points on the curve.
Public method | GetBezierCurve | The specified span as a CubicBezier.
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List SplinePoint .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLengthBetweenPoints | Approximates the length between the two specified points along the path of the spline.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List SplinePoint .)
Public method | GetSpanControlPoint | Control point for the specified span and index.
Public method | GetSpanControlPoints | Control points of the specified span.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List SplinePoint .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List SplinePoint .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List SplinePoint .)
Public method | InsertPoint | Inserts the specified point into this spline. If inserted in the middle, then no control points in the existing spline are changed. If inserted at the beginning or end of the spline, the join is smoothed without altering the shape of the original spline.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List SplinePoint .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List SplinePoint .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List SplinePoint .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List SplinePoint .)
Public method | LinearExtension | Applies a linear extension to either the start or to the end of this spline.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadFromDUCTPictureFile | Extracts spline curves from a DUCT picture file and returns them to the caller.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List SplinePoint .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List SplinePoint .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List SplinePoint .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List SplinePoint .)
Public method | ReorderClosedSpline | If closed, reorders this spline so that it has a new start point.
Public method | Reverse | Reverses the curve
Public method | Reverse(Int32, Int32) | Reverses the curve between the points specified
Public method | SetSpanControlPoint |
Public method | SetSpanControlPoints |
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List SplinePoint .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List SplinePoint .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List SplinePoint .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List SplinePoint .)
Public method | SplitSpan | Splits the Bezier curve span at the specified index at the point infered from the specified t parameter.
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List SplinePoint .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List SplinePoint .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List SplinePoint .)
Public method | WriteToDUCTPictureFile | Writes this spline to the specified DUCT picture file. The file is written in units of MM as this is the unit of points that constitute the line.
Top
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.AddPointToEndOfSpline Method

SplineAddPointToEndOfSpline Method

Adds a point to the end of this spline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddPointToEndOfSpline(
    Point point,
    bool autoFree = true
)
Public Sub AddPointToEndOfSpline (
    point As Point,
    Optional autoFree As Boolean = true
)

Parameters

point
Type: Autodesk.GeometryPoint
Point to be added to the end of the spline.
autoFree (Optional)
Type: SystemBoolean
If true (default), join will be smoothed; otherwise point is added to the spline with a straight line.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.Clone Method

SplineClone Method

Returns a clone of this spline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Spline Clone()
Public Function Clone As Spline

Return Value

Type: Spline
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.CubicBezier Method

SplineCubicBezier Method

Evaluates the specific point on a cubic bezier curve.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Point CubicBezier(
    Point p0,
    Point p1,
    Point p2,
    Point p3,
    double t
)
Public Shared Function CubicBezier (
    p0 As Point,
    p1 As Point,
    p2 As Point,
    p3 As Point,
    t As Double
) As Point

Parameters

p0
Type: Autodesk.GeometryPoint
Control point 1 of the bezier curve.
p1
Type: Autodesk.GeometryPoint
Control point 2 of the bezier curve.
p2
Type: Autodesk.GeometryPoint
Control point 3 of the bezier curve.
p3
Type: Autodesk.GeometryPoint
Control point 4 of the bezier curve.
t
Type: SystemDouble
Position of the points needs to be evaluated on Cubic Bezier curver. Ranges from 0 to 1.

Return Value

Type: Point
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.FreeChordMagnitudes Method

SplineFreeChordMagnitudes Method

Frees chord magnitudes for the specified span.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FreeChordMagnitudes(
    int spanIndex
)
Public Sub FreeChordMagnitudes (
    spanIndex As Integer
)

Parameters

spanIndex
Type: SystemInt32
Index of span within this spline.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.FreeCurveDirections Method

SplineFreeCurveDirections Method

Frees the tangent directions through all points on the curve.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FreeCurveDirections()
Public Sub FreeCurveDirections
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.FreeCurveMagnitudes Method

SplineFreeCurveMagnitudes Method

Frees the magnitudes through all points on the curve.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FreeCurveMagnitudes()
Public Sub FreeCurveMagnitudes
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.FreePointDirections Method

SplineFreePointDirections Method

Frees the entry and exit direction of a point

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FreePointDirections(
    int pointIndex
)
Public Sub FreePointDirections (
    pointIndex As Integer
)

Parameters

pointIndex
Type: SystemInt32
Index of the point to free.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.FreePointMagnitudes Method

SplineFreePointMagnitudes Method

Frees magnitude for the specified point. This is a variation of the FreeChordMagnitudes() method.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FreePointMagnitudes(
    int pointIndex
)
Public Sub FreePointMagnitudes (
    pointIndex As Integer
)

Parameters

pointIndex
Type: SystemInt32
Index of the point to be freed.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.FreeTangentsAndMagnitudes Method

SplineFreeTangentsAndMagnitudes Method

Frees the tangent directions and magnitudes through all points on the curve.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FreeTangentsAndMagnitudes()
Public Sub FreeTangentsAndMagnitudes
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.GetBezierCurve Method

SplineGetBezierCurve Method

The specified span as a CubicBezier.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public CubicBezier GetBezierCurve(
    int spanIndex
)
Public Function GetBezierCurve (
    spanIndex As Integer
) As CubicBezier

Parameters

spanIndex
Type: SystemInt32
Zero-based span index.

Return Value

Type: CubicBezier
Exceptions
Exception | Condition
IndexOutOfRangeException | Thrown if the specified span index does not identify a valid span in the spline. i.e. 0 > spanIndex or spanIndex - 1 >= number of spans.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.GetLengthBetweenPoints Method

SplineGetLengthBetweenPoints Method

Approximates the length between the two specified points along the path of the spline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetLengthBetweenPoints(
    double chunkingTolerance,
    double pointProximityTolerance,
    int startPoint = 0,
    int endPoint = 0
)
Public Function GetLengthBetweenPoints (
    chunkingTolerance As Double,
    pointProximityTolerance As Double,
    Optional startPoint As Integer = 0,
    Optional endPoint As Integer = 0
) As Double

Parameters

chunkingTolerance
Type: SystemDouble
Measure of acceptable error.
pointProximityTolerance
Type: SystemDouble
Prevents points from being considered in the calculation if they are in too close a proximity to one another.
startPoint (Optional)
Type: SystemInt32
Point on curve at which to commence length calculation.
endPoint (Optional)
Type: SystemInt32
Point on curve at which to end length calculation.

Return Value

Type: Double
Calculated length.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.GetSpanControlPoint Method

SplineGetSpanControlPoint Method

Control point for the specified span and index.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point GetSpanControlPoint(
    int spanIndex,
    int controlPointIndex
)
Public Function GetSpanControlPoint (
    spanIndex As Integer,
    controlPointIndex As Integer
) As Point

Parameters

spanIndex
Type: SystemInt32
Zero-based span index.
controlPointIndex
Type: SystemInt32
Zero-based control point index.

Return Value

Type: Point
Exceptions
Exception | Condition
IndexOutOfRangeException | Thrown in either of the following two cases: The specified span index does not identify a valid span in the spline. i.e. 0 > spanIndex or spanIndex - 1 >= number of spans. The control point index fails to meet the condition: 0 >= controlPointIndex <= 3.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.GetSpanControlPoints Method

SplineGetSpanControlPoints Method

Control points of the specified span.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Point> GetSpanControlPoints(
    int spanIndex
)
Public Function GetSpanControlPoints (
    spanIndex As Integer
) As List(Of Point)

Parameters

spanIndex
Type: SystemInt32
Zero-based span index.

Return Value

Type: List Point
Exceptions
Exception | Condition
IndexOutOfRangeException | Thrown if the specified span index does not identify a valid span in the spline. i.e. 0 > spanIndex or spanIndex - 1 >= number of spans.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.InsertPoint Method

SplineInsertPoint Method

Inserts the specified point into this spline. If inserted in the middle, then no control points in the existing spline are changed. If inserted at the beginning or end of the spline, the join is smoothed without altering the shape of the original spline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool InsertPoint(
    int pointIndex,
    Point point,
    double pointProximityTolerance = 0
)
Public Function InsertPoint (
    pointIndex As Integer,
    point As Point,
    Optional pointProximityTolerance As Double = 0
) As Boolean

Parameters

pointIndex
Type: SystemInt32
Index of the point to be added. An index of zero adds the point to the front of the spline. An index equal to or exceeding the maximum current point index will add the point to the end of the line.
point
Type: Autodesk.GeometryPoint
Point to insert.
pointProximityTolerance (Optional)
Type: SystemDouble
Optional tolerance. Prevents a point from being added in too close a proximity to a neighbouring point.

Return Value

Type: Boolean
Sets to True if the operation succeeded; false otherwise.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.LinearExtension Method

SplineLinearExtension Method

Applies a linear extension to either the start or to the end of this spline.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool LinearExtension(
    double extensionDistance,
    SplineSplineExtensionEnd selectEndOfSpline,
    double pointProximityTolerance = 0
)
Public Function LinearExtension (
    extensionDistance As Double,
    selectEndOfSpline As SplineSplineExtensionEnd,
    Optional pointProximityTolerance As Double = 0
) As Boolean

Parameters

extensionDistance
Type: SystemDouble
Distance by which to extend the spline.
selectEndOfSpline
Type: Autodesk.GeometrySplineSplineExtensionEnd
Indicates either the start or the end of the line.
pointProximityTolerance (Optional)
Type: SystemDouble
Optional tolerance. Prevents a point from being added in too close a proximity to a neighbouring point.

Return Value

Type: Boolean
True if the operation succeeds; false otherwise.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.ReadFromDUCTPictureFile Method

SplineReadFromDUCTPictureFile Method

Extracts spline curves from a DUCT picture file and returns them to the caller.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<Spline> ReadFromDUCTPictureFile(
    File file
)
Public Shared Function ReadFromDUCTPictureFile (
    file As File
) As List(Of Spline)

Parameters

file
Type: Autodesk.FileSystemFile
Path to the DUCT picture file.

Return Value

Type: List Spline
A list of spline curves.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.ReorderClosedSpline Method

SplineReorderClosedSpline Method

If closed, reorders this spline so that it has a new start point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ReorderClosedSpline(
    int newStartIndex
)
Public Sub ReorderClosedSpline (
    newStartIndex As Integer
)

Parameters

newStartIndex
Type: SystemInt32
Index of the point to set as start.
Exceptions
Exception | Condition
Exception | Thrown if newStartIndex is out of range or the spline is open.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.Reverse Method

SplineReverse Method

Overload List
 | Name | Description
Public method | Reverse | Reverses the curve
Public method | Reverse(Int32, Int32) | Reverses the curve between the points specified
Top
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.Reverse Method

SplineReverse Method

Reverses the curve

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Reverse()
Public Sub Reverse
See Also

Reference

Spline Class
Reverse Overload
Autodesk.Geometry Namespace


Spline.Reverse Method (Int32, Int32)

SplineReverse Method (Int32, Int32)

Reverses the curve between the points specified

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Reverse(
    int index,
    int count
)
Public Sub Reverse (
    index As Integer,
    count As Integer
)

Parameters

index
Type: SystemInt32
The point to start the reversing from
count
Type: SystemInt32
The number of points to reverse
See Also

Reference

Spline Class
Reverse Overload
Autodesk.Geometry Namespace


Spline.SetSpanControlPoint Method

SplineSetSpanControlPoint Method

[Missing <summary> documentation for "M:Autodesk.Geometry.Spline.SetSpanControlPoint(Autodesk.Geometry.Point,System.Int32,System.Int32)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetSpanControlPoint(
    Point value,
    int spanIndex,
    int controlPointIndex
)
Public Sub SetSpanControlPoint (
    value As Point,
    spanIndex As Integer,
    controlPointIndex As Integer
)

Parameters

value
Type: Autodesk.GeometryPoint

[Missing <param name="value"/> documentation for "M:Autodesk.Geometry.Spline.SetSpanControlPoint(Autodesk.Geometry.Point,System.Int32,System.Int32)"]

spanIndex
Type: SystemInt32

[Missing <param name="spanIndex"/> documentation for "M:Autodesk.Geometry.Spline.SetSpanControlPoint(Autodesk.Geometry.Point,System.Int32,System.Int32)"]

controlPointIndex
Type: SystemInt32

[Missing <param name="controlPointIndex"/> documentation for "M:Autodesk.Geometry.Spline.SetSpanControlPoint(Autodesk.Geometry.Point,System.Int32,System.Int32)"]

See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.SetSpanControlPoints Method

SplineSetSpanControlPoints Method

[Missing <summary> documentation for "M:Autodesk.Geometry.Spline.SetSpanControlPoints(System.Collections.Generic.List{Autodesk.Geometry.Point},System.Int32)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetSpanControlPoints(
    List<Point> value,
    int spanIndex
)
Public Sub SetSpanControlPoints (
    value As List(Of Point),
    spanIndex As Integer
)

Parameters

value
Type: System.Collections.GenericList Point

[Missing <param name="value"/> documentation for "M:Autodesk.Geometry.Spline.SetSpanControlPoints(System.Collections.Generic.List{Autodesk.Geometry.Point},System.Int32)"]

spanIndex
Type: SystemInt32

[Missing <param name="spanIndex"/> documentation for "M:Autodesk.Geometry.Spline.SetSpanControlPoints(System.Collections.Generic.List{Autodesk.Geometry.Point},System.Int32)"]

See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.SplitSpan Method

SplineSplitSpan Method

Splits the Bezier curve span at the specified index at the point infered from the specified t parameter.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool SplitSpan(
    int spanIndex,
    double t,
    double pointProximityTolerance = 0
)
Public Function SplitSpan (
    spanIndex As Integer,
    t As Double,
    Optional pointProximityTolerance As Double = 0
) As Boolean

Parameters

spanIndex
Type: SystemInt32
Index of the span.
t
Type: SystemDouble
Value of t on which to split where 0 >= t <= 1.
pointProximityTolerance (Optional)
Type: SystemDouble
Optional tolerance. Prevents a point from being added in too close a proximity to a neighbouring point.

Return Value

Type: Boolean
True if the operation succeeds; false otherwise.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.WriteToDUCTPictureFile Method

SplineWriteToDUCTPictureFile Method

Writes this spline to the specified DUCT picture file. The file is written in units of MM as this is the unit of points that constitute the line.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToDUCTPictureFile(
    File file
)
Public Sub WriteToDUCTPictureFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
File to write.
Exceptions
Exception | Condition
Exception | Thrown if the curve possesses fewer than two points.
See Also

Reference

Spline Class
Autodesk.Geometry Namespace


Spline.SplineExtensionEnd Enumeration

SplineSplineExtensionEnd Enumeration

Used to specify endedness for extension operations.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SplineExtensionEnd
Public Enumeration SplineExtensionEnd
Members
Member name | Value | Description
StartOfSpline | 0 |
EndOfSpline | 1 |
See Also

Reference

Autodesk.Geometry Namespace


SplinePoint Class

SplinePoint inherits from Point. In addition to possessing location, a spline point also has direction and magnitude before and after the point.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryPoint
Autodesk.GeometrySplinePoint

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SplinePoint : Point
<SerializableAttribute>
Public Class SplinePoint
    Inherits Point

The SplinePoint type exposes the following members.

Constructors
 | Name | Description
Public method | SplinePoint(Point) | Constructs a new SplinePoint about the specified point argument. Directions and magnitudes are unspecified.
Public method | SplinePoint(Point, Point, Point) | Constructs a new SplinePoint with the specified position. If present, directions and magnitudes are inferred from the supplied control points.
Public method | SplinePoint(Point, Vector, MM, Vector, MM) | Constructs a new SplinePoint with the specified position, directions and magnitudes.
Top
Properties
 | Name | Description
Public property | DirectionAfter | Vector specifying direction after the point.
Public property | DirectionBefore | Vector specifying direction prior to the point.
Public property | MagnitudeAfter | Magnitude after the point.
Public property | MagnitudeBefore | Magnitude prior to the point.
Public property | X | X coordinate. (Inherited from Point.)
Public property | Y | Y coordinate. (Inherited from Point.)
Public property | Z | Z coordinate. (Inherited from Point.)
Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of the spline point.
Public method | DistanceToPoint | Returns the distance between this and another Point. (Inherited from Point.)
Public method | Equals(Object) | (Overrides PointEquals(Object).)
Public method | Equals(SplinePoint) |
Public method | Equals(Object, Int32) | Returns true if the Point is equal to the specified object with at least the specified precision. If the the object is not a point or is not equivalent to the Point, the operation returns False. (Inherited from Point.)
Public method | EulerRotation | Rotates the Point by the specified Euler Angles. (Inherited from Point.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides PointGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInsideTriangle | Returns true if the point is inside the triangle, otherwise it returns false. It uses Barycentric coordinates of the point to return the result. (Inherited from Point.)
Public method | IsRayInterceptTriangleTest | Returns true if a ray with given direction from the point intercepts the triangle, otherwise it returns false. Uses ray triangle intersection algorithm by Moller Haines. (Inherited from Point.)
Public method | LiesOnLine | Determines whether this Point lies on the straight line between two Points specified in the input arguments. (Inherited from Point.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectToPlane | This operation projects a point onto a Plane (Inherited from Point.)
Public method | RebaseFromWorkplane | Rebases the Point from the specified workplane to the world. (Inherited from Point.)
Public method | RebaseToWorkplane | Rebases Point from the world to the specified Workplane (Inherited from Point.)
Public method | RotateAboutVector | Rotates Point by the specified angle in radians about the specified Vector. (Inherited from Point.)
Public method | RotateAboutXAxis | Rotates Point by the specified angle in radians about the specified Point in the X axis. (Inherited from Point.)
Public method | RotateAboutYAxis | Rotates Point by the specified angle in radians about the specified Point in the Y axis. (Inherited from Point.)
Public method | RotateAboutZAxis | Rotates Point by the specified angle in radians about the specified Point in the Z axis. (Inherited from Point.)
Public method | ToString | Returns a string representation of the Point in the form: X.XXX Y.YYY Z.ZZZ. (Inherited from Point.)
Public method | ToString(Char) | Returns a string representation of the point with a custom delimiter between the three coordinates. If, for example, a comma were chosen as the delimeter, the resultant output would be of the form: X.XXX,Y.YYY,Z.ZZZ (Inherited from Point.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Fields
 | Name | Description
Protected field | _x | X coordinate. (Inherited from Point.)
Protected field | _y | Y coordinate. (Inherited from Point.)
Protected field | _z | Z coordinate. (Inherited from Point.)
Top
See Also

Reference

Autodesk.Geometry Namespace


SplinePoint Constructor

Overload List
 | Name | Description
Public method | SplinePoint(Point) | Constructs a new SplinePoint about the specified point argument. Directions and magnitudes are unspecified.
Public method | SplinePoint(Point, Point, Point) | Constructs a new SplinePoint with the specified position. If present, directions and magnitudes are inferred from the supplied control points.
Public method | SplinePoint(Point, Vector, MM, Vector, MM) | Constructs a new SplinePoint with the specified position, directions and magnitudes.
Top
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint Constructor (Point)

Constructs a new SplinePoint about the specified point argument. Directions and magnitudes are unspecified.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SplinePoint(
    Point point
)
Public Sub New (
    point As Point
)

Parameters

point
Type: Autodesk.GeometryPoint
Point about which to base the new SplinePoint.
See Also

Reference

SplinePoint Class
SplinePoint Overload
Autodesk.Geometry Namespace


SplinePoint Constructor (Point, Point, Point)

Constructs a new SplinePoint with the specified position. If present, directions and magnitudes are inferred from the supplied control points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SplinePoint(
    Point position,
    Point controlPointBefore = null,
    Point controlPointAfter = null
)
Public Sub New (
    position As Point,
    Optional controlPointBefore As Point = Nothing,
    Optional controlPointAfter As Point = Nothing
)

Parameters

position
Type: Autodesk.GeometryPoint
Position of the point.
controlPointBefore (Optional)
Type: Autodesk.GeometryPoint
Control point before position.
controlPointAfter (Optional)
Type: Autodesk.GeometryPoint
Control point after position.
See Also

Reference

SplinePoint Class
SplinePoint Overload
Autodesk.Geometry Namespace


SplinePoint Constructor (Point, Vector, MM, Vector, MM)

Constructs a new SplinePoint with the specified position, directions and magnitudes.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SplinePoint(
    Point point,
    Vector directionBefore = null,
    MM magnitudeBefore = null,
    Vector directionAfter = null,
    MM magnitudeAfter = null
)
Public Sub New (
    point As Point,
    Optional directionBefore As Vector = Nothing,
    Optional magnitudeBefore As MM = Nothing,
    Optional directionAfter As Vector = Nothing,
    Optional magnitudeAfter As MM = Nothing
)

Parameters

point
Type: Autodesk.GeometryPoint
Position of the point.
directionBefore (Optional)
Type: Autodesk.GeometryVector
Direction before the point.
magnitudeBefore (Optional)
Type: Autodesk.GeometryMM
Magnitude before the point.
directionAfter (Optional)
Type: Autodesk.GeometryVector
Magnitude after the point.
magnitudeAfter (Optional)
Type: Autodesk.GeometryMM
Direction after the point.
See Also

Reference

SplinePoint Class
SplinePoint Overload
Autodesk.Geometry Namespace


SplinePoint Properties

The SplinePoint type exposes the following members.

Properties
 | Name | Description
Public property | DirectionAfter | Vector specifying direction after the point.
Public property | DirectionBefore | Vector specifying direction prior to the point.
Public property | MagnitudeAfter | Magnitude after the point.
Public property | MagnitudeBefore | Magnitude prior to the point.
Public property | X | X coordinate. (Inherited from Point.)
Public property | Y | Y coordinate. (Inherited from Point.)
Public property | Z | Z coordinate. (Inherited from Point.)
Top
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.DirectionAfter Property

SplinePointDirectionAfter Property

Vector specifying direction after the point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector DirectionAfter { get; set; }
Public Property DirectionAfter As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.DirectionBefore Property

SplinePointDirectionBefore Property

Vector specifying direction prior to the point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector DirectionBefore { get; set; }
Public Property DirectionBefore As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.MagnitudeAfter Property

SplinePointMagnitudeAfter Property

Magnitude after the point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MagnitudeAfter { get; set; }
Public Property MagnitudeAfter As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.MagnitudeBefore Property

SplinePointMagnitudeBefore Property

Magnitude prior to the point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MagnitudeBefore { get; set; }
Public Property MagnitudeBefore As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint Methods

The SplinePoint type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a clone of the spline point.
Public method | DistanceToPoint | Returns the distance between this and another Point. (Inherited from Point.)
Public method | Equals(Object) | (Overrides PointEquals(Object).)
Public method | Equals(SplinePoint) |
Public method | Equals(Object, Int32) | Returns true if the Point is equal to the specified object with at least the specified precision. If the the object is not a point or is not equivalent to the Point, the operation returns False. (Inherited from Point.)
Public method | EulerRotation | Rotates the Point by the specified Euler Angles. (Inherited from Point.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides PointGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInsideTriangle | Returns true if the point is inside the triangle, otherwise it returns false. It uses Barycentric coordinates of the point to return the result. (Inherited from Point.)
Public method | IsRayInterceptTriangleTest | Returns true if a ray with given direction from the point intercepts the triangle, otherwise it returns false. Uses ray triangle intersection algorithm by Moller Haines. (Inherited from Point.)
Public method | LiesOnLine | Determines whether this Point lies on the straight line between two Points specified in the input arguments. (Inherited from Point.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectToPlane | This operation projects a point onto a Plane (Inherited from Point.)
Public method | RebaseFromWorkplane | Rebases the Point from the specified workplane to the world. (Inherited from Point.)
Public method | RebaseToWorkplane | Rebases Point from the world to the specified Workplane (Inherited from Point.)
Public method | RotateAboutVector | Rotates Point by the specified angle in radians about the specified Vector. (Inherited from Point.)
Public method | RotateAboutXAxis | Rotates Point by the specified angle in radians about the specified Point in the X axis. (Inherited from Point.)
Public method | RotateAboutYAxis | Rotates Point by the specified angle in radians about the specified Point in the Y axis. (Inherited from Point.)
Public method | RotateAboutZAxis | Rotates Point by the specified angle in radians about the specified Point in the Z axis. (Inherited from Point.)
Public method | ToString | Returns a string representation of the Point in the form: X.XXX Y.YYY Z.ZZZ. (Inherited from Point.)
Public method | ToString(Char) | Returns a string representation of the point with a custom delimiter between the three coordinates. If, for example, a comma were chosen as the delimeter, the resultant output would be of the form: X.XXX,Y.YYY,Z.ZZZ (Inherited from Point.)
Top
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.Clone Method

SplinePointClone Method

Returns a clone of the spline point.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SplinePoint Clone()
Public Function Clone As SplinePoint

Return Value

Type: SplinePoint
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.Equals Method

SplinePointEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides PointEquals(Object).)
Public method | Equals(SplinePoint) |
Public method | Equals(Object, Int32) | Returns true if the Point is equal to the specified object with at least the specified precision. If the the object is not a point or is not equivalent to the Point, the operation returns False. (Inherited from Point.)
Top
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.Equals Method (Object)

SplinePointEquals Method (Object)

[Missing <summary> documentation for "M:Autodesk.Geometry.SplinePoint.Equals(System.Object)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Autodesk.Geometry.SplinePoint.Equals(System.Object)"]

Return Value

Type: Boolean
See Also

Reference

SplinePoint Class
Equals Overload
Autodesk.Geometry Namespace


SplinePoint.Equals Method (SplinePoint)

SplinePointEquals Method (SplinePoint)

[Missing <summary> documentation for "M:Autodesk.Geometry.SplinePoint.Equals(Autodesk.Geometry.SplinePoint)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    SplinePoint p
)
Public Function Equals (
    p As SplinePoint
) As Boolean

Parameters

p
Type: Autodesk.GeometrySplinePoint

[Missing <param name="p"/> documentation for "M:Autodesk.Geometry.SplinePoint.Equals(Autodesk.Geometry.SplinePoint)"]

Return Value

Type: Boolean
See Also

Reference

SplinePoint Class
Equals Overload
Autodesk.Geometry Namespace


SplinePoint.GetHashCode Method

SplinePointGetHashCode Method

[Missing <summary> documentation for "M:Autodesk.Geometry.SplinePoint.GetHashCode"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint Operators

The SplinePoint type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.Equality Operator

SplinePointEquality Operator

[Missing <summary> documentation for "M:Autodesk.Geometry.SplinePoint.op_Equality(Autodesk.Geometry.SplinePoint,Autodesk.Geometry.SplinePoint)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator ==(
    SplinePoint a,
    SplinePoint b
)
Public Shared Operator = (
    a As SplinePoint,
    b As SplinePoint
) As Boolean

Parameters

a
Type: Autodesk.GeometrySplinePoint

[Missing <param name="a"/> documentation for "M:Autodesk.Geometry.SplinePoint.op_Equality(Autodesk.Geometry.SplinePoint,Autodesk.Geometry.SplinePoint)"]

b
Type: Autodesk.GeometrySplinePoint

[Missing <param name="b"/> documentation for "M:Autodesk.Geometry.SplinePoint.op_Equality(Autodesk.Geometry.SplinePoint,Autodesk.Geometry.SplinePoint)"]

Return Value

Type: Boolean
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint.Inequality Operator

SplinePointInequality Operator

[Missing <summary> documentation for "M:Autodesk.Geometry.SplinePoint.op_Inequality(Autodesk.Geometry.SplinePoint,Autodesk.Geometry.SplinePoint)"]

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator !=(
    SplinePoint a,
    SplinePoint b
)
Public Shared Operator <> (
    a As SplinePoint,
    b As SplinePoint
) As Boolean

Parameters

a
Type: Autodesk.GeometrySplinePoint

[Missing <param name="a"/> documentation for "M:Autodesk.Geometry.SplinePoint.op_Inequality(Autodesk.Geometry.SplinePoint,Autodesk.Geometry.SplinePoint)"]

b
Type: Autodesk.GeometrySplinePoint

[Missing <param name="b"/> documentation for "M:Autodesk.Geometry.SplinePoint.op_Inequality(Autodesk.Geometry.SplinePoint,Autodesk.Geometry.SplinePoint)"]

Return Value

Type: Boolean
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


SplinePoint Fields

The SplinePoint type exposes the following members.

Fields
 | Name | Description
Protected field | _x | X coordinate. (Inherited from Point.)
Protected field | _y | Y coordinate. (Inherited from Point.)
Protected field | _z | Z coordinate. (Inherited from Point.)
Top
See Also

Reference

SplinePoint Class
Autodesk.Geometry Namespace


Vector Class

Encapsulates a three dimensional vector and operations thereon.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryVector

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Vector
<SerializableAttribute>
Public Class Vector

The Vector type exposes the following members.

Constructors
 | Name | Description
Public method | Vector | Constructs a null vector.
Public method | Vector(MM) | Constructor initialises the Vector using an array of MM objects.
Public method | Vector(String, Char) | Constructs a Vector from a single line of text, the magnitudes of which are demarked by the specified delimeter.
Public method | Vector(Point, Point) | Constructs a vector between the specified start and end points.
Public method | Vector(MM, MM, MM) | Constructs a vector initialised to the specified magnitudes.
Top
Properties
 | Name | Description
Public property | I | Magnitude of the vector in the first axis (X)
Public property | J | Magnitude of the vector in the second axis (Y)
Public property | K | Magnitude of the vector in the third axis (Z)
Public property | Magnitude | Magnitude of the vector.
Public property | MagnitudeSquare | Magnitude square of the vector.
Top
Methods
 | Name | Description
Public method | AngleBetween | Returns the angle between this and a second vector.
Public method | AngleTo | Returns the angle from this vector to another.
Public method | Clone | Returns a clone of this Vector.
 | CrossProduct | Calculates the cross product of the two specified vectors. The resultant vector is perpendicular to both a and b, the two vectors used to produce it, with vector a corresponding to the X axis and b the Y.
 | DotProduct | Calculates the dot product of the two specified vectors. If both vectors are unit vectors, the dot product will be the cosine of the angle between them. If only b is a unit vector, the dot product will yield the signed magnitude of the projection of a on b.
Public method | Equals(Object) | Returns True if this Vector is equal to the specified object. I.e. all three axes are equivalent. (Overrides ObjectEquals(Object).)
Public method | Equals(Object, Int32) | Returns true if the Vector is equal to the specified object with at least the specified precision. If the the object is not a Vector or is not equivalent to the Vector, the operation returns False.
Public method | EulerRotation | Rotates the Vector by the specified Euler Angles.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXYVectors | Sets the xVector parameter to be the size of this in the X axis and the yVector parameter to be the size of this in the Y axis.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize | Normalises this vector.
Public method | RebaseFromWorkplane | Rebases this vector from a specified workplane to the world.
Public method | RebaseToWorkplane | Rebases this vector to the specified workplane.
Public method | RotateAboutVector | Rotates this Vector by the specified angle in radians about the specified vector.
Public method | RotateAboutXAxis | Rotates this Vector by the specified angle in Radians about X.
Public method | RotateAboutYAxis | Rotates this Vector by the specified angle in Radians about Y.
Public method | RotateAboutZAxis | Rotates this Vector by the specified angle in Radians about Z.
Public method | ToString | Returns a string representation of the Vector of the form: I.IIII J.JJJ K.KKK (Overrides ObjectToString.)
Top
Operators
Name | Description
Addition | Performs vector addition on its two operands.
Division | Divides a vector by a scalar value.
Equality | Returns true if the two specified vectors are equal; false otherwise.
Inequality | Returns true if the two specified vectors are not equal; false otherwise.
Multiply(Double, Vector) | Multiplies a Vector by a scalar.
Multiply(Vector, Double) | Multiplies a Vector by a scalar.
Subtraction | Subtracts the right-hand of the two specified vectors from the left.
Top
Fields
 | Name | Description
Protected field | _i | Vector i component.
Protected field | _j | Vector j component.
Protected field | _k | Vector k component.
Top
See Also

Reference

Autodesk.Geometry Namespace


Vector Constructor

Overload List
 | Name | Description
Public method | Vector | Constructs a null vector.
Public method | Vector(MM) | Constructor initialises the Vector using an array of MM objects.
Public method | Vector(String, Char) | Constructs a Vector from a single line of text, the magnitudes of which are demarked by the specified delimeter.
Public method | Vector(Point, Point) | Constructs a vector between the specified start and end points.
Public method | Vector(MM, MM, MM) | Constructs a vector initialised to the specified magnitudes.
Top
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector Constructor

Constructs a null vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector()
Public Sub New
See Also

Reference

Vector Class
Vector Overload
Autodesk.Geometry Namespace


Vector Constructor (MM[])

Vector Constructor (MM)

Constructor initialises the Vector using an array of MM objects.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector(
    MM[] componentArray
)
Public Sub New (
    componentArray As MM()
)

Parameters

componentArray
Type: Autodesk.GeometryMM
Array of MM objects from which to create the vector.
Exceptions
Exception | Condition
Exception | Thrown if input array does not contain three coordinates.
See Also

Reference

Vector Class
Vector Overload
Autodesk.Geometry Namespace


Vector Constructor (String, Char)

Constructs a Vector from a single line of text, the magnitudes of which are demarked by the specified delimeter.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector(
    string textLine,
    char delimiter = ''
)
Public Sub New (
    textLine As String,
    Optional delimiter As Char = ""C
)

Parameters

textLine
Type: SystemString
Line of text containing the components and separated by the delimiter.
delimiter (Optional)
Type: SystemChar
Delimiter - defaults to a single space.
Exceptions
Exception | Condition
Exception | Thrown if the string does not contain exactly three components or cannot be parsed.
See Also

Reference

Vector Class
Vector Overload
Autodesk.Geometry Namespace


Vector Constructor (Point, Point)

Constructs a vector between the specified start and end points.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector(
    Point startPoint,
    Point endPoint
)
Public Sub New (
    startPoint As Point,
    endPoint As Point
)

Parameters

startPoint
Type: Autodesk.GeometryPoint
Vector start point.
endPoint
Type: Autodesk.GeometryPoint
Vector end point.
See Also

Reference

Vector Class
Vector Overload
Autodesk.Geometry Namespace


Vector Constructor (MM, MM, MM)

Constructs a vector initialised to the specified magnitudes.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector(
    MM i,
    MM j,
    MM k
)
Public Sub New (
    i As MM,
    j As MM,
    k As MM
)

Parameters

i
Type: Autodesk.GeometryMM
Magnitude in i.
j
Type: Autodesk.GeometryMM
Magnitude in j.
k
Type: Autodesk.GeometryMM
Magnitude in k.
See Also

Reference

Vector Class
Vector Overload
Autodesk.Geometry Namespace


Vector Properties

The Vector type exposes the following members.

Properties
 | Name | Description
Public property | I | Magnitude of the vector in the first axis (X)
Public property | J | Magnitude of the vector in the second axis (Y)
Public property | K | Magnitude of the vector in the third axis (Z)
Public property | Magnitude | Magnitude of the vector.
Public property | MagnitudeSquare | Magnitude square of the vector.
Top
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.I Property

VectorI Property

Magnitude of the vector in the first axis (X)

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM I { get; set; }
Public Property I As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.J Property

VectorJ Property

Magnitude of the vector in the second axis (Y)

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM J { get; set; }
Public Property J As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.K Property

VectorK Property

Magnitude of the vector in the third axis (Z)

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM K { get; set; }
Public Property K As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Magnitude Property

VectorMagnitude Property

Magnitude of the vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Magnitude { get; }
Public ReadOnly Property Magnitude As MM
    Get

Property Value

Type: MM
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.MagnitudeSquare Property

VectorMagnitudeSquare Property

Magnitude square of the vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MagnitudeSquare { get; }
Public ReadOnly Property MagnitudeSquare As MM
    Get

Property Value

Type: MM
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector Methods

The Vector type exposes the following members.

Methods
 | Name | Description
Public method | AngleBetween | Returns the angle between this and a second vector.
Public method | AngleTo | Returns the angle from this vector to another.
Public method | Clone | Returns a clone of this Vector.
 | CrossProduct | Calculates the cross product of the two specified vectors. The resultant vector is perpendicular to both a and b, the two vectors used to produce it, with vector a corresponding to the X axis and b the Y.
 | DotProduct | Calculates the dot product of the two specified vectors. If both vectors are unit vectors, the dot product will be the cosine of the angle between them. If only b is a unit vector, the dot product will yield the signed magnitude of the projection of a on b.
Public method | Equals(Object) | Returns True if this Vector is equal to the specified object. I.e. all three axes are equivalent. (Overrides ObjectEquals(Object).)
Public method | Equals(Object, Int32) | Returns true if the Vector is equal to the specified object with at least the specified precision. If the the object is not a Vector or is not equivalent to the Vector, the operation returns False.
Public method | EulerRotation | Rotates the Vector by the specified Euler Angles.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXYVectors | Sets the xVector parameter to be the size of this in the X axis and the yVector parameter to be the size of this in the Y axis.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Normalize | Normalises this vector.
Public method | RebaseFromWorkplane | Rebases this vector from a specified workplane to the world.
Public method | RebaseToWorkplane | Rebases this vector to the specified workplane.
Public method | RotateAboutVector | Rotates this Vector by the specified angle in radians about the specified vector.
Public method | RotateAboutXAxis | Rotates this Vector by the specified angle in Radians about X.
Public method | RotateAboutYAxis | Rotates this Vector by the specified angle in Radians about Y.
Public method | RotateAboutZAxis | Rotates this Vector by the specified angle in Radians about Z.
Public method | ToString | Returns a string representation of the Vector of the form: I.IIII J.JJJ K.KKK (Overrides ObjectToString.)
Top
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.AngleBetween Method

VectorAngleBetween Method

Returns the angle between this and a second vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Radian AngleBetween(
    Vector otherVector
)
Public Function AngleBetween (
    otherVector As Vector
) As Radian

Parameters

otherVector
Type: Autodesk.GeometryVector
Vector with which to measure angle.

Return Value

Type: Radian
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.AngleTo Method

VectorAngleTo Method

Returns the angle from this vector to another.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Radian AngleTo(
    Vector otherVector
)
Public Function AngleTo (
    otherVector As Vector
) As Radian

Parameters

otherVector
Type: Autodesk.GeometryVector
Second vector against which to measure angle.

Return Value

Type: Radian
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Clone Method

VectorClone Method

Returns a clone of this Vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector Clone()
Public Function Clone As Vector

Return Value

Type: Vector
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.CrossProduct Method

VectorCrossProduct Method

Calculates the cross product of the two specified vectors. The resultant vector is perpendicular to both a and b, the two vectors used to produce it, with vector a corresponding to the X axis and b the Y.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Vector CrossProduct(
    Vector a,
    Vector b
)
Public Shared Function CrossProduct (
    a As Vector,
    b As Vector
) As Vector

Parameters

a
Type: Autodesk.GeometryVector
First input vector.
b
Type: Autodesk.GeometryVector
Second input vector.

Return Value

Type: Vector
Vector result of the operation.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.DotProduct Method

VectorDotProduct Method

Calculates the dot product of the two specified vectors. If both vectors are unit vectors, the dot product will be the cosine of the angle between them. If only b is a unit vector, the dot product will yield the signed magnitude of the projection of a on b.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static MM DotProduct(
    Vector a,
    Vector b
)
Public Shared Function DotProduct (
    a As Vector,
    b As Vector
) As MM

Parameters

a
Type: Autodesk.GeometryVector
First of two vectors.
b
Type: Autodesk.GeometryVector
Second of two vectors.

Return Value

Type: MM
Scalar result of the operation.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Equals Method

VectorEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Returns True if this Vector is equal to the specified object. I.e. all three axes are equivalent. (Overrides ObjectEquals(Object).)
Public method | Equals(Object, Int32) | Returns true if the Vector is equal to the specified object with at least the specified precision. If the the object is not a Vector or is not equivalent to the Vector, the operation returns False.
Top
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Equals Method (Object)

VectorEquals Method (Object)

Returns True if this Vector is equal to the specified object. I.e. all three axes are equivalent.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Object to compare against.

Return Value

Type: Boolean
True if vector and object are equivalent; false otherwwise.
See Also

Reference

Vector Class
Equals Overload
Autodesk.Geometry Namespace


Vector.Equals Method (Object, Int32)

VectorEquals Method (Object, Int32)

Returns true if the Vector is equal to the specified object with at least the specified precision. If the the object is not a Vector or is not equivalent to the Vector, the operation returns False.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    Object obj,
    int nDecPts
)
Public Function Equals (
    obj As Object,
    nDecPts As Integer
) As Boolean

Parameters

obj
Type: SystemObject
Object to comare against.
nDecPts
Type: SystemInt32
Number of decimal places to compare.

Return Value

Type: Boolean
True if the operands are deemed equal.
See Also

Reference

Vector Class
Equals Overload
Autodesk.Geometry Namespace


Vector.EulerRotation Method

VectorEulerRotation Method

Rotates the Vector by the specified Euler Angles.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EulerRotation(
    Angles eulerAngles
)
Public Sub EulerRotation (
    eulerAngles As Angles
)

Parameters

eulerAngles
Type: Autodesk.Geometry.EulerAngles
Angles to rotate.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.GetXYVectors Method

VectorGetXYVectors Method

Sets the xVector parameter to be the size of this in the X axis and the yVector parameter to be the size of this in the Y axis.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void GetXYVectors(
    ref Vector xVector,
    ref Vector yVector
)
Public Sub GetXYVectors (
    ByRef xVector As Vector,
    ByRef yVector As Vector
)

Parameters

xVector
Type: Autodesk.GeometryVector
Vector to populate as X.
yVector
Type: Autodesk.GeometryVector
Vector to populate as Y.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Normalize Method

VectorNormalize Method

Normalises this vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Normalize()
Public Sub Normalize
Exceptions
Exception | Condition
Exception | Thrown if this is of zero length: a zero length vector cannot be converted to a unit vector.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.RebaseFromWorkplane Method

VectorRebaseFromWorkplane Method

Rebases this vector from a specified workplane to the world.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RebaseFromWorkplane(
    Workplane fromWorkplane
)
Public Sub RebaseFromWorkplane (
    fromWorkplane As Workplane
)

Parameters

fromWorkplane
Type: Autodesk.GeometryWorkplane
Workplane from which to rebase vector.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.RebaseToWorkplane Method

VectorRebaseToWorkplane Method

Rebases this vector to the specified workplane.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RebaseToWorkplane(
    Workplane toWorkplane
)
Public Sub RebaseToWorkplane (
    toWorkplane As Workplane
)

Parameters

toWorkplane
Type: Autodesk.GeometryWorkplane
Workplane to rebase to.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.RotateAboutVector Method

VectorRotateAboutVector Method

Rotates this Vector by the specified angle in radians about the specified vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutVector(
    Vector vectorToRotateAbout,
    Radian angle
)
Public Sub RotateAboutVector (
    vectorToRotateAbout As Vector,
    angle As Radian
)

Parameters

vectorToRotateAbout
Type: Autodesk.GeometryVector
Vector to rotate about.
angle
Type: Autodesk.GeometryRadian
Angle to rotate.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.RotateAboutXAxis Method

VectorRotateAboutXAxis Method

Rotates this Vector by the specified angle in Radians about X.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutXAxis(
    Radian angle
)
Public Sub RotateAboutXAxis (
    angle As Radian
)

Parameters

angle
Type: Autodesk.GeometryRadian
Angle to rotate.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.RotateAboutYAxis Method

VectorRotateAboutYAxis Method

Rotates this Vector by the specified angle in Radians about Y.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutYAxis(
    Radian angle
)
Public Sub RotateAboutYAxis (
    angle As Radian
)

Parameters

angle
Type: Autodesk.GeometryRadian
Angle to rotate.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.RotateAboutZAxis Method

VectorRotateAboutZAxis Method

Rotates this Vector by the specified angle in Radians about Z.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutZAxis(
    Radian angle
)
Public Sub RotateAboutZAxis (
    angle As Radian
)

Parameters

angle
Type: Autodesk.GeometryRadian
Angle to rotate.
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.ToString Method

VectorToString Method

Returns a string representation of the Vector of the form: I.IIII J.JJJ K.KKK

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector Operators

The Vector type exposes the following members.

Operators
Name | Description
Addition | Performs vector addition on its two operands.
Division | Divides a vector by a scalar value.
Equality | Returns true if the two specified vectors are equal; false otherwise.
Inequality | Returns true if the two specified vectors are not equal; false otherwise.
Multiply(Double, Vector) | Multiplies a Vector by a scalar.
Multiply(Vector, Double) | Multiplies a Vector by a scalar.
Subtraction | Subtracts the right-hand of the two specified vectors from the left.
Top
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Addition Operator

VectorAddition Operator

Performs vector addition on its two operands.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Vector operator +(
    Vector left,
    Vector right
)
Public Shared Operator + (
    left As Vector,
    right As Vector
) As Vector

Parameters

left
Type: Autodesk.GeometryVector
First vector to add.
right
Type: Autodesk.GeometryVector
Second vector to add.

Return Value

Type: Vector
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Division Operator

VectorDivision Operator

Divides a vector by a scalar value.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Vector operator /(
    Vector left,
    double scalar
)
Public Shared Operator / (
    left As Vector,
    scalar As Double
) As Vector

Parameters

left
Type: Autodesk.GeometryVector
Vector to be divided.
scalar
Type: SystemDouble
Dividing scalar.

Return Value

Type: Vector
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Equality Operator

VectorEquality Operator

Returns true if the two specified vectors are equal; false otherwise.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator ==(
    Vector left,
    Vector right
)
Public Shared Operator = (
    left As Vector,
    right As Vector
) As Boolean

Parameters

left
Type: Autodesk.GeometryVector
First of two vectors.
right
Type: Autodesk.GeometryVector
Second of two vectors.

Return Value

Type: Boolean
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Inequality Operator

VectorInequality Operator

Returns true if the two specified vectors are not equal; false otherwise.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static bool operator !=(
    Vector left,
    Vector right
)
Public Shared Operator <> (
    left As Vector,
    right As Vector
) As Boolean

Parameters

left
Type: Autodesk.GeometryVector
First of two vectors.
right
Type: Autodesk.GeometryVector
Second of two vectors.

Return Value

Type: Boolean
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Multiply Operator

VectorMultiply Operator

Overload List
Name | Description
Multiply(Double, Vector) | Multiplies a Vector by a scalar.
Multiply(Vector, Double) | Multiplies a Vector by a scalar.
Top
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector.Multiply Operator (Double, Vector)

VectorMultiply Operator (Double, Vector)

Multiplies a Vector by a scalar.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Vector operator *(
    double scalar,
    Vector right
)
Public Shared Operator * (
    scalar As Double,
    right As Vector
) As Vector

Parameters

scalar
Type: SystemDouble
Scalar value with which to multiply vector.
right
Type: Autodesk.GeometryVector
Vector to multiply.

Return Value

Type: Vector
See Also

Reference

Vector Class
Multiply Overload
Autodesk.Geometry Namespace


Vector.Multiply Operator (Vector, Double)

VectorMultiply Operator (Vector, Double)

Multiplies a Vector by a scalar.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Vector operator *(
    Vector left,
    double scalar
)
Public Shared Operator * (
    left As Vector,
    scalar As Double
) As Vector

Parameters

left
Type: Autodesk.GeometryVector
Vector to multiply.
scalar
Type: SystemDouble
Scalar value with which to multiply vector.

Return Value

Type: Vector
See Also

Reference

Vector Class
Multiply Overload
Autodesk.Geometry Namespace


Vector.Subtraction Operator

VectorSubtraction Operator

Subtracts the right-hand of the two specified vectors from the left.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Vector operator -(
    Vector left,
    Vector right
)
Public Shared Operator - (
    left As Vector,
    right As Vector
) As Vector

Parameters

left
Type: Autodesk.GeometryVector
Vector from which to subtract (minuend).
right
Type: Autodesk.GeometryVector
Vector to subtract (subtrahend).

Return Value

Type: Vector
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector Fields

The Vector type exposes the following members.

Fields
 | Name | Description
Protected field | _i | Vector i component.
Protected field | _j | Vector j component.
Protected field | _k | Vector k component.
Top
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector._i Field

Vector_i Field

Vector i component.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected MM _i
Protected _i As MM

Field Value

Type: MM
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector._j Field

Vector_j Field

Vector j component.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected MM _j
Protected _j As MM

Field Value

Type: MM
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Vector._k Field

Vector_k Field

Vector k component.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected MM _k
Protected _k As MM

Field Value

Type: MM
See Also

Reference

Vector Class
Autodesk.Geometry Namespace


Workplane Class

Encapsulates a Workplane. A workplane consists of three vectors that describe the orientation of a model in respect to the world.
Inheritance Hierarchy
SystemObject
Autodesk.GeometryWorkplane

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Workplane
<SerializableAttribute>
Public Class Workplane

The Workplane type exposes the following members.

Constructors
 | Name | Description
Public method | Workplane | Constructor a workplane to match the orientation of the world.
Public method | Workplane(File) | Creates workplane from MAT, a TRX or a MATRIX file.
Public method | Workplane(Point, Vector, Vector) | Constructs workplane from two vectors and point
Public method | Workplane(Point, Vector, Vector, Vector) | Constructs a workplane with orientation relative to the world using the specified values.
Top
Properties
 | Name | Description
Public property | Origin | Workplane origin.
Public property | XAxis | Vector representing the workplane in X.
Public property | YAxis | Vector representing the workplane in Y.
Public property | ZAxis | Vector representing the workplane in Z.
Top
Methods
 | Name | Description
Public method | Clone | Returns a clone of this Workplane.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransformationMatrix | Gets Transformation Matrix from workplane.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the workplane by the specified Vector.
Public method | RotateAboutXAxis | Rotates workplane by the specified angle about the X axis and the specified origin.
Public method | RotateAboutYAxis | Rotates workplane by the specified angle about the Y axis and the specified origin.
Public method | RotateAboutZAxis | Rotates workplane by the specified angle about the Z axis and the specified origin.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToMat | Writes workplane to MAT file.
Public method | WriteToMatrix | Writes workplane to a MATRIX file.
Public method | WriteToTrx | Writes workplane to TRX file.
Top
See Also

Reference

Autodesk.Geometry Namespace


Workplane Constructor

Overload List
 | Name | Description
Public method | Workplane | Constructor a workplane to match the orientation of the world.
Public method | Workplane(File) | Creates workplane from MAT, a TRX or a MATRIX file.
Public method | Workplane(Point, Vector, Vector) | Constructs workplane from two vectors and point
Public method | Workplane(Point, Vector, Vector, Vector) | Constructs a workplane with orientation relative to the world using the specified values.
Top
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane Constructor

Constructor a workplane to match the orientation of the world.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Workplane()
Public Sub New
See Also

Reference

Workplane Class
Workplane Overload
Autodesk.Geometry Namespace


Workplane Constructor (File)

Creates workplane from MAT, a TRX or a MATRIX file.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Workplane(
    File file
)
Public Sub New (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The file to create the workplane from.
See Also

Reference

Workplane Class
Workplane Overload
Autodesk.Geometry Namespace


Workplane Constructor (Point, Vector, Vector)

Constructs workplane from two vectors and point

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Workplane(
    Point origin,
    Vector xAxis,
    Vector yAxis
)
Public Sub New (
    origin As Point,
    xAxis As Vector,
    yAxis As Vector
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin of the coordinate system.
xAxis
Type: Autodesk.GeometryVector
Vector representing the X axis.
yAxis
Type: Autodesk.GeometryVector
Vector representing the Y axis.
See Also

Reference

Workplane Class
Workplane Overload
Autodesk.Geometry Namespace


Workplane Constructor (Point, Vector, Vector, Vector)

Constructs a workplane with orientation relative to the world using the specified values.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Workplane(
    Point origin,
    Vector xAxis,
    Vector yAxis,
    Vector zAxis
)
Public Sub New (
    origin As Point,
    xAxis As Vector,
    yAxis As Vector,
    zAxis As Vector
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin of the coordinate system.
xAxis
Type: Autodesk.GeometryVector
Vector representing the X axis.
yAxis
Type: Autodesk.GeometryVector
Vector representing the Y axis.
zAxis
Type: Autodesk.GeometryVector
Vector representing the Z axis.
See Also

Reference

Workplane Class
Workplane Overload
Autodesk.Geometry Namespace


Workplane Properties

The Workplane type exposes the following members.

Properties
 | Name | Description
Public property | Origin | Workplane origin.
Public property | XAxis | Vector representing the workplane in X.
Public property | YAxis | Vector representing the workplane in Y.
Public property | ZAxis | Vector representing the workplane in Z.
Top
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.Origin Property

WorkplaneOrigin Property

Workplane origin.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Origin { get; set; }
Public Property Origin As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.XAxis Property

WorkplaneXAxis Property

Vector representing the workplane in X.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector XAxis { get; set; }
Public Property XAxis As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.YAxis Property

WorkplaneYAxis Property

Vector representing the workplane in Y.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector YAxis { get; set; }
Public Property YAxis As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.ZAxis Property

WorkplaneZAxis Property

Vector representing the workplane in Z.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector ZAxis { get; set; }
Public Property ZAxis As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane Methods

The Workplane type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a clone of this Workplane.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransformationMatrix | Gets Transformation Matrix from workplane.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the workplane by the specified Vector.
Public method | RotateAboutXAxis | Rotates workplane by the specified angle about the X axis and the specified origin.
Public method | RotateAboutYAxis | Rotates workplane by the specified angle about the Y axis and the specified origin.
Public method | RotateAboutZAxis | Rotates workplane by the specified angle about the Z axis and the specified origin.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToMat | Writes workplane to MAT file.
Public method | WriteToMatrix | Writes workplane to a MATRIX file.
Public method | WriteToTrx | Writes workplane to TRX file.
Top
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.Clone Method

WorkplaneClone Method

Returns a clone of this Workplane.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Workplane Clone()
Public Function Clone As Workplane

Return Value

Type: Workplane
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.GetTransformationMatrix Method

WorkplaneGetTransformationMatrix Method

Gets Transformation Matrix from workplane.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double[,] GetTransformationMatrix()
Public Function GetTransformationMatrix As Double(,)

Return Value

Type: Double
Returns the Transformation Matrix.
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.Move Method

WorkplaneMove Method

Moves the workplane by the specified Vector.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Move(
    Vector offset
)
Public Sub Move (
    offset As Vector
)

Parameters

offset
Type: Autodesk.GeometryVector
Vector by which to offset workplane.
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.RotateAboutXAxis Method

WorkplaneRotateAboutXAxis Method

Rotates workplane by the specified angle about the X axis and the specified origin.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutXAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutXAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin of rotation.
angle
Type: Autodesk.GeometryRadian
Angle through which to rotate.
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.RotateAboutYAxis Method

WorkplaneRotateAboutYAxis Method

Rotates workplane by the specified angle about the Y axis and the specified origin.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutYAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutYAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin of rotation.
angle
Type: Autodesk.GeometryRadian
Angle through which to rotate.
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.RotateAboutZAxis Method

WorkplaneRotateAboutZAxis Method

Rotates workplane by the specified angle about the Z axis and the specified origin.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RotateAboutZAxis(
    Point origin,
    Radian angle
)
Public Sub RotateAboutZAxis (
    origin As Point,
    angle As Radian
)

Parameters

origin
Type: Autodesk.GeometryPoint
Origin of rotation.
angle
Type: Autodesk.GeometryRadian
Angle through which to rotate.
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.WriteToMat Method

WorkplaneWriteToMat Method

Writes workplane to MAT file.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToMat(
    File matFile
)
Public Sub WriteToMat (
    matFile As File
)

Parameters

matFile
Type: Autodesk.FileSystemFile
MAT file path.
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.WriteToMatrix Method

WorkplaneWriteToMatrix Method

Writes workplane to a MATRIX file.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToMatrix(
    File matrixFile
)
Public Sub WriteToMatrix (
    matrixFile As File
)

Parameters

matrixFile
Type: Autodesk.FileSystemFile
The file path to the '.matrix' file.
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Workplane.WriteToTrx Method

WorkplaneWriteToTrx Method

Writes workplane to TRX file.

Namespace: Autodesk.Geometry
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToTrx(
    File trxFile
)
Public Sub WriteToTrx (
    trxFile As File
)

Parameters

trxFile
Type: Autodesk.FileSystemFile
TRX file path.
See Also

Reference

Workplane Class
Autodesk.Geometry Namespace


Autodesk.Geometry.Euler Namespace

Classes
 | Class | Description
Public class | Angles | Constructs Euler rotational matrices.
Enumerations
 | Enumeration | Description
Public enumeration | Conventions | Euler angle conventions supported by Autodesk.Geometry.


Angles Class

Constructs Euler rotational matrices.
Inheritance Hierarchy
SystemObject
Autodesk.Geometry.EulerAngles

Namespace: Autodesk.Geometry.Euler
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Angles
<SerializableAttribute>
Public Class Angles

The Angles type exposes the following members.

Constructors
 | Name | Description
Public method | Angles | Constructs a Euler rotation matrix based on the specified angles and convention.
Top
Properties
 | Name | Description
Public property | Matrix | Euler rotational matrix.
Public property | MatrixInverse | The inverse of Euler rotational matrix.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRotationsFromMatrixXYZ | Computes Euler angles from a MatrixXYZ.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry.Euler Namespace


Angles Constructor

Constructs a Euler rotation matrix based on the specified angles and convention.

Namespace: Autodesk.Geometry.Euler
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Angles(
    Radian alpha,
    Radian beta,
    Radian gamma,
    Conventions convention
)
Public Sub New (
    alpha As Radian,
    beta As Radian,
    gamma As Radian,
    convention As Conventions
)

Parameters

alpha
Type: Autodesk.GeometryRadian
First angle of rotation.
beta
Type: Autodesk.GeometryRadian
Second angle of rotation.
gamma
Type: Autodesk.GeometryRadian
Third angle of rotation.
convention
Type: Autodesk.Geometry.EulerConventions
Specifies the axes of rotation and the order in which rotations are performed about the axes.
See Also

Reference

Angles Class
Autodesk.Geometry.Euler Namespace


Angles Properties

The Angles type exposes the following members.

Properties
 | Name | Description
Public property | Matrix | Euler rotational matrix.
Public property | MatrixInverse | The inverse of Euler rotational matrix.
Top
See Also

Reference

Angles Class
Autodesk.Geometry.Euler Namespace


Angles.Matrix Property

AnglesMatrix Property

Euler rotational matrix.

Namespace: Autodesk.Geometry.Euler
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double[,] Matrix { get; }
Public ReadOnly Property Matrix As Double(,)
    Get

Property Value

Type: Double
See Also

Reference

Angles Class
Autodesk.Geometry.Euler Namespace


Angles.MatrixInverse Property

AnglesMatrixInverse Property

The inverse of Euler rotational matrix.

Namespace: Autodesk.Geometry.Euler
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double[,] MatrixInverse { get; }
Public ReadOnly Property MatrixInverse As Double(,)
    Get

Property Value

Type: Double
See Also

Reference

Angles Class
Autodesk.Geometry.Euler Namespace


Angles Methods

The Angles type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRotationsFromMatrixXYZ | Computes Euler angles from a MatrixXYZ.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Angles Class
Autodesk.Geometry.Euler Namespace


Angles.GetRotationsFromMatrixXYZ Method

AnglesGetRotationsFromMatrixXYZ Method

Computes Euler angles from a MatrixXYZ.

Namespace: Autodesk.Geometry.Euler
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static Degree[] GetRotationsFromMatrixXYZ(
    double[,] rotationMatrix
)
Public Shared Function GetRotationsFromMatrixXYZ (
    rotationMatrix As Double(,)
) As Degree()

Parameters

rotationMatrix
Type: SystemDouble

[Missing <param name="rotationMatrix"/> documentation for "M:Autodesk.Geometry.Euler.Angles.GetRotationsFromMatrixXYZ(System.Double[0:,0:])"]

Return Value

Type: Degree
The rotation around z, the rotation around y and the rotation around x, by this order.
See Also

Reference

Angles Class
Autodesk.Geometry.Euler Namespace


Conventions Enumeration

Euler angle conventions supported by Autodesk.Geometry.

Namespace: Autodesk.Geometry.Euler
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum Conventions
Public Enumeration Conventions
Members
Member name | Value | Description
XZX | 0 |
XYX | 1 |
YXY | 2 |
YZY | 3 |
ZYZ | 4 |
ZXZ | 5 |
XZY | 6 |
YXZ | 7 |
XYZ | 8 |
YZX | 9 |
ZYX | 10 |
ZXY | 11 |
See Also

Reference

Autodesk.Geometry.Euler Namespace


Autodesk.Geometry.GeometricEntities Namespace

Classes
 | Class | Description
Public class | Surface | Represents a non-primitive surface defined by a network of curves.


Surface Class

Represents a non-primitive surface defined by a network of curves.
Inheritance Hierarchy
SystemObject
Autodesk.Geometry.GeometricEntitiesSurface

Namespace: Autodesk.Geometry.GeometricEntities
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class Surface
Public Class Surface

The Surface type exposes the following members.

Constructors
 | Name | Description
Public method | Surface(ListSpline, Boolean) | Creates a surface from the surface curves provided. The other set of surface curves is calculated by joining the network.
Public method | Surface(ListSpline, ListSpline) | Creates a surface from the laterals and longitudinals provided.
Top
Properties
 | Name | Description
Public property | Laterals | Gets the list of laterals.
Public property | Longitudinals | Gets the list of longitudinals.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormal | Gets the normal of the Surface at the specified point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.Geometry.GeometricEntities Namespace


Surface Constructor

Overload List
 | Name | Description
Public method | Surface(ListSpline, Boolean) | Creates a surface from the surface curves provided. The other set of surface curves is calculated by joining the network.
Public method | Surface(ListSpline, ListSpline) | Creates a surface from the laterals and longitudinals provided.
Top
See Also

Reference

Surface Class
Autodesk.Geometry.GeometricEntities Namespace


Surface Constructor (List(Spline), Boolean)

Surface Constructor (ListSpline, Boolean)

Creates a surface from the surface curves provided. The other set of surface curves is calculated by joining the network.

Namespace: Autodesk.Geometry.GeometricEntities
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Surface(
    List<Spline> surfaceCurves,
    bool areLaterals
)
Public Sub New (
    surfaceCurves As List(Of Spline),
    areLaterals As Boolean
)

Parameters

surfaceCurves
Type: System.Collections.GenericList Spline
The laterals or longitudinals of the surface.
areLaterals
Type: SystemBoolean
True if the curves are the laterals, false if they are the longitudinals of the surface.
Exceptions
Exception | Condition
ArgumentException | Thrown when the provided surface curves don't have the same number of points.
ArgumentException | Thrown when the number of surface curves is below 2.
ArgumentNullException | Thrown when surface curves are null.
See Also

Reference

Surface Class
Surface Overload
Autodesk.Geometry.GeometricEntities Namespace


Surface Constructor (List(Spline), List(Spline))

Surface Constructor (ListSpline, ListSpline)

Creates a surface from the laterals and longitudinals provided.

Namespace: Autodesk.Geometry.GeometricEntities
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Surface(
    List<Spline> laterals,
    List<Spline> longitudinals
)
Public Sub New (
    laterals As List(Of Spline),
    longitudinals As List(Of Spline)
)

Parameters

laterals
Type: System.Collections.GenericList Spline
The lateral curves.
longitudinals
Type: System.Collections.GenericList Spline
The longitudinal curves.
Exceptions
Exception | Condition
ArgumentException | Thrown when the provided surface curves don't have the same number of points.
ArgumentException | Thrown if the coincident nodes constraint of a network is not met by the provided laterals and longitudinals.
ArgumentException | Thrown when the number of laterals is below 2.
ArgumentException | Thrown when the number of longitudinals is below 2.
ArgumentNullException | Thrown when laterals or longitudinals are null.
See Also

Reference

Surface Class
Surface Overload
Autodesk.Geometry.GeometricEntities Namespace


Surface Properties

The Surface type exposes the following members.

Properties
 | Name | Description
Public property | Laterals | Gets the list of laterals.
Public property | Longitudinals | Gets the list of longitudinals.
Top
See Also

Reference

Surface Class
Autodesk.Geometry.GeometricEntities Namespace


Surface.Laterals Property

SurfaceLaterals Property

Gets the list of laterals.

Namespace: Autodesk.Geometry.GeometricEntities
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Spline> Laterals { get; }
Public ReadOnly Property Laterals As List(Of Spline)
    Get

Property Value

Type: List Spline
See Also

Reference

Surface Class
Autodesk.Geometry.GeometricEntities Namespace


Surface.Longitudinals Property

SurfaceLongitudinals Property

Gets the list of longitudinals.

Namespace: Autodesk.Geometry.GeometricEntities
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Spline> Longitudinals { get; }
Public ReadOnly Property Longitudinals As List(Of Spline)
    Get

Property Value

Type: List Spline
See Also

Reference

Surface Class
Autodesk.Geometry.GeometricEntities Namespace


Surface Methods

The Surface type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormal | Gets the normal of the Surface at the specified point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Surface Class
Autodesk.Geometry.GeometricEntities Namespace


Surface.GetNormal Method

SurfaceGetNormal Method

Gets the normal of the Surface at the specified point.

Namespace: Autodesk.Geometry.GeometricEntities
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetNormal(
    int lateralIndex,
    int longitudinalIndex
)
Public Function GetNormal (
    lateralIndex As Integer,
    longitudinalIndex As Integer
) As Vector

Parameters

lateralIndex
Type: SystemInt32
Lateral index of point on surface.
longitudinalIndex
Type: SystemInt32
Longitudinal index of point on surface.

Return Value

Type: Vector
The normal vector at the specified point.
See Also

Reference

Surface Class
Autodesk.Geometry.GeometricEntities Namespace


Autodesk.Matrix Namespace

Classes
 | Class | Description
Public class | Matrix | Contains Matrix helper methods.


Matrix Class

Contains Matrix helper methods.
Inheritance Hierarchy
SystemObject
Autodesk.MatrixMatrix

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static class Matrix
<ExtensionAttribute>
Public NotInheritable Class Matrix

The Matrix type exposes the following members.

Methods
Name | Description
Add | Adds the current matrix (a) to matrix b.
Copy | Copies matrix a.
Create | Creates a matrix of a given size with a default value.
HadamardProduct | Hadamard product of the current matrix by b.
Identity | Creates an Identity matrix.
Multiply(Double, Double) | Multiplies the current matrix (a) by b.
Multiply(Double, Double) | Multiplies the current matrix (a) by b.
Multiply(Double, Double) | Multiplies the current matrix (a) by column vector.
Subtract | Subtracts matrix b to the current matrix (a).
Transpose | Gets the transpose of the matrix (a).
Top
See Also

Reference

Autodesk.Matrix Namespace


Matrix Methods

The Matrix type exposes the following members.

Methods
Name | Description
Add | Adds the current matrix (a) to matrix b.
Copy | Copies matrix a.
Create | Creates a matrix of a given size with a default value.
HadamardProduct | Hadamard product of the current matrix by b.
Identity | Creates an Identity matrix.
Multiply(Double, Double) | Multiplies the current matrix (a) by b.
Multiply(Double, Double) | Multiplies the current matrix (a) by b.
Multiply(Double, Double) | Multiplies the current matrix (a) by column vector.
Subtract | Subtracts matrix b to the current matrix (a).
Transpose | Gets the transpose of the matrix (a).
Top
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Matrix.Add Method

MatrixAdd Method

Adds the current matrix (a) to matrix b.

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] Add(
    this double[,] a,
    double[,] b
)
<ExtensionAttribute>
Public Shared Function Add (
    a As Double(,),
    b As Double(,)
) As Double(,)

Parameters

a
Type: SystemDouble
The current matrix.
b
Type: SystemDouble
Matrix to add.

Return Value

Type: Double
The sum of matrix the current matrix and matrix b.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Matrix.Copy Method

MatrixCopy Method

Copies matrix a.

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] Copy(
    this double[,] a
)
<ExtensionAttribute>
Public Shared Function Copy (
    a As Double(,)
) As Double(,)

Parameters

a
Type: SystemDouble
The matrix to copy from.

Return Value

Type: Double
The new matrix copy.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Matrix.Create Method

MatrixCreate Method

Creates a matrix of a given size with a default value.

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] Create(
    int numberOfRows,
    int numberOfColumns,
    double value
)
Public Shared Function Create (
    numberOfRows As Integer,
    numberOfColumns As Integer,
    value As Double
) As Double(,)

Parameters

numberOfRows
Type: SystemInt32
The number of rows.
numberOfColumns
Type: SystemInt32
The number of columns.
value
Type: SystemDouble
The default value for each matrix element.

Return Value

Type: Double
Returns the matrix.
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Matrix.HadamardProduct Method

MatrixHadamardProduct Method

Hadamard product of the current matrix by b.

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] HadamardProduct(
    this double[,] a,
    double[,] b
)
<ExtensionAttribute>
Public Shared Function HadamardProduct (
    a As Double(,),
    b As Double(,)
) As Double(,)

Parameters

a
Type: SystemDouble
The current matrix.
b
Type: SystemDouble
The matrix to multiply by.

Return Value

Type: Double
The Hadamard product of the current matrix by b.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown when matrices don't have the same dimensions.
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Matrix.Identity Method

MatrixIdentity Method

Creates an Identity matrix.

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] Identity(
    int size
)
Public Shared Function Identity (
    size As Integer
) As Double(,)

Parameters

size
Type: SystemInt32
The size of the Identity matrix.

Return Value

Type: Double
The Identity matrix.
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Matrix.Multiply Method

MatrixMultiply Method

Overload List
Name | Description
Multiply(Double, Double) | Multiplies the current matrix (a) by b.
Multiply(Double, Double) | Multiplies the current matrix (a) by b.
Multiply(Double, Double) | Multiplies the current matrix (a) by column vector.
Top
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Matrix.Multiply Method (Double[,], Double)

MatrixMultiply Method (Double, Double)

Multiplies the current matrix (a) by b.

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] Multiply(
    this double[,] a,
    double b
)
<ExtensionAttribute>
Public Shared Function Multiply (
    a As Double(,),
    b As Double
) As Double(,)

Parameters

a
Type: SystemDouble
The current matrix.
b
Type: SystemDouble
The number to multiply by.

Return Value

Type: Double
The multiplication of matrix the current matrix by b.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix Class
Multiply Overload
Autodesk.Matrix Namespace


Matrix.Multiply Method (Double[,], Double[,])

MatrixMultiply Method (Double, Double)

Multiplies the current matrix (a) by b.

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] Multiply(
    this double[,] a,
    double[,] b
)
<ExtensionAttribute>
Public Shared Function Multiply (
    a As Double(,),
    b As Double(,)
) As Double(,)

Parameters

a
Type: SystemDouble
The current matrix.
b
Type: SystemDouble
The matrix to multiply by.

Return Value

Type: Double
The multiplication of matrix the current matrix by matrix b.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix Class
Multiply Overload
Autodesk.Matrix Namespace


Matrix.Multiply Method (Double[,], Double[])

MatrixMultiply Method (Double, Double)

Multiplies the current matrix (a) by column vector.

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[] Multiply(
    this double[,] a,
    double[] columnVector
)
<ExtensionAttribute>
Public Shared Function Multiply (
    a As Double(,),
    columnVector As Double()
) As Double()

Parameters

a
Type: SystemDouble
The current matrix.
columnVector
Type: SystemDouble
The column vector to multiply by.

Return Value

Type: Double
The multiplication of matrix the current matrix by b.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix Class
Multiply Overload
Autodesk.Matrix Namespace


Matrix.Subtract Method

MatrixSubtract Method

Subtracts matrix b to the current matrix (a).

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] Subtract(
    this double[,] a,
    double[,] b
)
<ExtensionAttribute>
Public Shared Function Subtract (
    a As Double(,),
    b As Double(,)
) As Double(,)

Parameters

a
Type: SystemDouble
The current matrix.
b
Type: SystemDouble
The matrix to subtract.

Return Value

Type: Double
The result of the subtraction.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Matrix.Transpose Method

MatrixTranspose Method

Gets the transpose of the matrix (a).

Namespace: Autodesk.Matrix
Assembly: Autodesk.Geometry (in Autodesk.Geometry.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static double[,] Transpose(
    this double[,] a
)
<ExtensionAttribute>
Public Shared Function Transpose (
    a As Double(,)
) As Double(,)

Parameters

a
Type: SystemDouble
The matrix to transpose from.

Return Value

Type: Double
The transpose of the given matrix.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix Class
Autodesk.Matrix Namespace


Autodesk.ProductInterface Namespace

Classes
 | Class | Description
Public class | Automation | Base class for all Automation.
Public class | CommandBusyFlag | Allows CopyCAD to signal to PowerSHAPE that it is busy.
Public class | Macro | Abstract base class for encapsulating a Macro and all operations thereon.
Public class | MacroStepEventArgs | Encapsulates data used to report the progress of the Macro.
Public class | PSCancelPointPicker | Cancel point picker helper.
Public class | SharedMemory | Provides a minimal .Net interface around unmanaged shared memory resources.
Public class | WindowHider | Facilitates the hiding of a named window.
Interfaces
 | Interface | Description
Public interface | ICancelPointPickCheck | Cancel point picker helper interface.
Delegates
 | Delegate | Description
Public delegate | MacroStepProcessedEventHandler |
Enumerations
 | Enumeration | Description
Public enumeration | InstanceReuse | Specifies how an executable instance is to be obtained.


Automation Class

Base class for all Automation.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceAutomation
Autodesk.ProductInterface.PowerMILLPMAutomation
Autodesk.ProductInterface.PowerSHAPEPSAutomation

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class Automation
Public MustInherit Class Automation

The Automation type exposes the following members.

Constructors
 | Name | Description
Protected method | Automation | Initializes a new instance of the Automation class
Top
Properties
 | Name | Description
Protected property | ExecutableName | Name of the process.
Public property | IsGUIVisible | If True, the GUI (toolbars etc) is visible; False otherwise.
Public property | IsRunning | True if the process is running; false otherwise.
Public property | IsVisible | If True, the application is visible; False otherwise.
Public property | MainWindowId | Handle of the main window of this application instance.
Public property | ProcessId | Process id of the application instance.
Public property | Version | Version of the current application.
Top
Methods
 | Name | Description
Protected method | CloseAllInstancesOf | Closes all instances of a process with the specified name.
Protected method | CreateNewInstance | Should create a new application instance alongside existing instances.
Protected method | CreateSingleInstance | Should close all other instances and create a new one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecutablePath | Retrieves from the registry the path to the specified application. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then the path to this executable will be returned. Should maximumVersion be unspecified, only the path to the absolute version specified in version will be returned.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialise(InstanceReuse) | Specifies whether an existing instance of the application be used or a new one created. This implementation is version non-specific and either the first existing instance of the application found or the latest installed version will be used.
Protected method | Initialise(InstanceReuse, Version, Version) | Specifies whether an existing instance of the application be used or a new one created. The application version must be specified and, optionally, a maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Quit | Should close this instance of the application.
Public method | RecordMacro | Should implement macro recording.
Public method | SetViewAngle | Sets the view angle of the current project based on the Active Workplane.
Protected method | StartByClassId | Creates and returns a reference to a COM object as specified by the ClassId argument. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.
Protected method | StartExecutable | Launches the executable located at the path retrieved from the registry for the specified application name, version and maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.
Public method | StopMacroRecording | Should stop macro recording.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UseExistingInstance | Should attempt to connect to a running application instance of the correct version. If it cannot, then it should start a new one.
Top
Fields
 | Name | Description
Protected field | _instanceReuse | Indicates whether a new instance of the application should be launched or an existing one be used.
Protected field | _isGUIVisible | If True, the GUI is shown; false otherwise.
Protected field | _processId | Application process id.
Protected field | _version | Specifies the application version to use.
Top
See Also

Reference

Autodesk.ProductInterface Namespace


Automation Constructor

Initializes a new instance of the Automation class

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected Automation()
Protected Sub New
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation Properties

The Automation type exposes the following members.

Properties
 | Name | Description
Protected property | ExecutableName | Name of the process.
Public property | IsGUIVisible | If True, the GUI (toolbars etc) is visible; False otherwise.
Public property | IsRunning | True if the process is running; false otherwise.
Public property | IsVisible | If True, the application is visible; False otherwise.
Public property | MainWindowId | Handle of the main window of this application instance.
Public property | ProcessId | Process id of the application instance.
Public property | Version | Version of the current application.
Top
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.ExecutableName Property

AutomationExecutableName Property

Name of the process.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected abstract Object ExecutableName { get; }
Protected MustOverride ReadOnly Property ExecutableName As Object
    Get

Property Value

Type: Object
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.IsGUIVisible Property

AutomationIsGUIVisible Property

If True, the GUI (toolbars etc) is visible; False otherwise.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract bool IsGUIVisible { get; set; }
Public MustOverride Property IsGUIVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.IsRunning Property

AutomationIsRunning Property

True if the process is running; false otherwise.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.IsVisible Property

AutomationIsVisible Property

If True, the application is visible; False otherwise.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract bool IsVisible { get; set; }
Public MustOverride Property IsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.MainWindowId Property

AutomationMainWindowId Property

Handle of the main window of this application instance.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual int MainWindowId { get; }
Public Overridable ReadOnly Property MainWindowId As Integer
    Get

Property Value

Type: Int32
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.ProcessId Property

AutomationProcessId Property

Process id of the application instance.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int ProcessId { get; }
Public ReadOnly Property ProcessId As Integer
    Get

Property Value

Type: Int32
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.Version Property

AutomationVersion Property

Version of the current application.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual Version Version { get; }
Public Overridable ReadOnly Property Version As Version
    Get

Property Value

Type: Version
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation Methods

The Automation type exposes the following members.

Methods
 | Name | Description
Protected method | CloseAllInstancesOf | Closes all instances of a process with the specified name.
Protected method | CreateNewInstance | Should create a new application instance alongside existing instances.
Protected method | CreateSingleInstance | Should close all other instances and create a new one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecutablePath | Retrieves from the registry the path to the specified application. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then the path to this executable will be returned. Should maximumVersion be unspecified, only the path to the absolute version specified in version will be returned.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialise(InstanceReuse) | Specifies whether an existing instance of the application be used or a new one created. This implementation is version non-specific and either the first existing instance of the application found or the latest installed version will be used.
Protected method | Initialise(InstanceReuse, Version, Version) | Specifies whether an existing instance of the application be used or a new one created. The application version must be specified and, optionally, a maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Quit | Should close this instance of the application.
Public method | RecordMacro | Should implement macro recording.
Public method | SetViewAngle | Sets the view angle of the current project based on the Active Workplane.
Protected method | StartByClassId | Creates and returns a reference to a COM object as specified by the ClassId argument. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.
Protected method | StartExecutable | Launches the executable located at the path retrieved from the registry for the specified application name, version and maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.
Public method | StopMacroRecording | Should stop macro recording.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UseExistingInstance | Should attempt to connect to a running application instance of the correct version. If it cannot, then it should start a new one.
Top
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.CloseAllInstancesOf Method

AutomationCloseAllInstancesOf Method

Closes all instances of a process with the specified name.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void CloseAllInstancesOf(
    string name
)
Protected Sub CloseAllInstancesOf (
    name As String
)

Parameters

name
Type: SystemString
Name of the process.
Exceptions
Exception | Condition
Exception | Thrown if it was not possible to close all instances with the specified name.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.CreateNewInstance Method

AutomationCreateNewInstance Method

Should create a new application instance alongside existing instances.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected abstract void CreateNewInstance(
    Version version,
    Version maximumVersion
)
Protected MustOverride Sub CreateNewInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
Nominal application version to use.
maximumVersion
Type: SystemVersion
Maximum application version to use.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.CreateSingleInstance Method

AutomationCreateSingleInstance Method

Should close all other instances and create a new one.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected abstract void CreateSingleInstance(
    Version version,
    Version maximumVersion
)
Protected MustOverride Sub CreateSingleInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
Nominal application version to use.
maximumVersion
Type: SystemVersion
Maximum application version to use.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.ExecutablePath Method

AutomationExecutablePath Method

Retrieves from the registry the path to the specified application. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then the path to this executable will be returned. Should maximumVersion be unspecified, only the path to the absolute version specified in version will be returned.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected string ExecutablePath(
    string application,
    Version version,
    Version maximumVersion
)
Protected Function ExecutablePath (
    application As String,
    version As Version,
    maximumVersion As Version
) As String

Parameters

application
Type: SystemString
Application name.
version
Type: SystemVersion
Nominal application version to use.
maximumVersion
Type: SystemVersion
Maximum application version to use.

Return Value

Type: String
Path to requested executable.
Exceptions
Exception | Condition
Exception | Thrown if no version found.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.Initialise Method

AutomationInitialise Method

Overload List
 | Name | Description
Protected method | Initialise(InstanceReuse) | Specifies whether an existing instance of the application be used or a new one created. This implementation is version non-specific and either the first existing instance of the application found or the latest installed version will be used.
Protected method | Initialise(InstanceReuse, Version, Version) | Specifies whether an existing instance of the application be used or a new one created. The application version must be specified and, optionally, a maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.
Top
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.Initialise Method (InstanceReuse)

AutomationInitialise Method (InstanceReuse)

Specifies whether an existing instance of the application be used or a new one created. This implementation is version non-specific and either the first existing instance of the application found or the latest installed version will be used.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void Initialise(
    InstanceReuse instanceReuse
)
Protected Sub Initialise (
    instanceReuse As InstanceReuse
)

Parameters

instanceReuse
Type: Autodesk.ProductInterfaceInstanceReuse
Specifies re-use or new instance.
See Also

Reference

Automation Class
Initialise Overload
Autodesk.ProductInterface Namespace


Automation.Initialise Method (InstanceReuse, Version, Version)

AutomationInitialise Method (InstanceReuse, Version, Version)

Specifies whether an existing instance of the application be used or a new one created. The application version must be specified and, optionally, a maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void Initialise(
    InstanceReuse instanceReuse,
    Version version,
    Version maximumVersion
)
Protected Sub Initialise (
    instanceReuse As InstanceReuse,
    version As Version,
    maximumVersion As Version
)

Parameters

instanceReuse
Type: Autodesk.ProductInterfaceInstanceReuse
Specifies re-use or new instance.
version
Type: SystemVersion
Nominal application version to use.
maximumVersion
Type: SystemVersion
Maximum application version to use.
See Also

Reference

Automation Class
Initialise Overload
Autodesk.ProductInterface Namespace


Automation.Quit Method

AutomationQuit Method

Should close this instance of the application.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void Quit()
Public MustOverride Sub Quit
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.RecordMacro Method

AutomationRecordMacro Method

Should implement macro recording.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void RecordMacro(
    string macroFilename
)
Public MustOverride Sub RecordMacro (
    macroFilename As String
)

Parameters

macroFilename
Type: SystemString
Name of file in which macro will be recorded.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.SetViewAngle Method

AutomationSetViewAngle Method

Sets the view angle of the current project based on the Active Workplane.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void SetViewAngle(
    ViewAngles viewAngle
)
Public MustOverride Sub SetViewAngle (
    viewAngle As ViewAngles
)

Parameters

viewAngle
Type: AutodeskViewAngles
Angle of view.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.StartByClassId Method

AutomationStartByClassId Method

Creates and returns a reference to a COM object as specified by the ClassId argument. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected Object StartByClassId(
    string classId,
    string processName,
    Version version,
    Version maximumVersion
)
Protected Function StartByClassId (
    classId As String,
    processName As String,
    version As Version,
    maximumVersion As Version
) As Object

Parameters

classId
Type: SystemString
Program Id of object to create e.g. PowerSHAPE.Application.
processName
Type: SystemString
Name of the executable e.g. powershape.
version
Type: SystemVersion
Nominal application version to use.
maximumVersion
Type: SystemVersion
Maximum application version to use.

Return Value

Type: Object
Reference to COM object.
Exceptions
Exception | Condition
Exception | Thrown if the executable cannot be started.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.StartExecutable Method

AutomationStartExecutable Method

Launches the executable located at the path retrieved from the registry for the specified application name, version and maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected virtual void StartExecutable(
    string application,
    Version version,
    Version maximumVersion,
    string classId,
    bool showWindow,
    string arguments = "",
    bool runRegServer = false
)
Protected Overridable Sub StartExecutable (
    application As String,
    version As Version,
    maximumVersion As Version,
    classId As String,
    showWindow As Boolean,
    Optional arguments As String = "",
    Optional runRegServer As Boolean = false
)

Parameters

application
Type: SystemString
Name of the application to be launched.
version
Type: SystemVersion
Nominal application version to use.
maximumVersion
Type: SystemVersion
Maximum application version to use.
classId
Type: SystemString
Represents the class of a COM object and takes the form appname.objecttype, where appname is the name of the application providing the object and objecttype is the type or class of object to create.
showWindow
Type: SystemBoolean
Specify True if the main application window is to be displayed; false otherwise.
arguments (Optional)
Type: SystemString
Arguments to be passed to the application.
runRegServer (Optional)
Type: SystemBoolean
If True, COM component will be registered. Assumes administrative rights are avaiable.
Exceptions
Exception | Condition
Exception | Thrown if the executable cannot be started.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.StopMacroRecording Method

AutomationStopMacroRecording Method

Should stop macro recording.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void StopMacroRecording()
Public MustOverride Sub StopMacroRecording
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation.UseExistingInstance Method

AutomationUseExistingInstance Method

Should attempt to connect to a running application instance of the correct version. If it cannot, then it should start a new one.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected abstract void UseExistingInstance(
    Version version,
    Version maximumVersion
)
Protected MustOverride Sub UseExistingInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
Nominal application version to use.
maximumVersion
Type: SystemVersion
Maximum application version to use.
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation Fields

The Automation type exposes the following members.

Fields
 | Name | Description
Protected field | _instanceReuse | Indicates whether a new instance of the application should be launched or an existing one be used.
Protected field | _isGUIVisible | If True, the GUI is shown; false otherwise.
Protected field | _processId | Application process id.
Protected field | _version | Specifies the application version to use.
Top
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation._instanceReuse Field

Automation_instanceReuse Field

Indicates whether a new instance of the application should be launched or an existing one be used.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected InstanceReuse _instanceReuse
Protected _instanceReuse As InstanceReuse

Field Value

Type: InstanceReuse
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation._isGUIVisible Field

Automation_isGUIVisible Field

If True, the GUI is shown; false otherwise.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected bool _isGUIVisible
Protected _isGUIVisible As Boolean

Field Value

Type: Boolean
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation._processId Field

Automation_processId Field

Application process id.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected int _processId
Protected _processId As Integer

Field Value

Type: Int32
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


Automation._version Field

Automation_version Field

Specifies the application version to use.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected Version _version
Protected _version As Version

Field Value

Type: Version
See Also

Reference

Automation Class
Autodesk.ProductInterface Namespace


CommandBusyFlag Class

Allows CopyCAD to signal to PowerSHAPE that it is busy.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceCommandBusyFlag

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class CommandBusyFlag
Public Class CommandBusyFlag

The CommandBusyFlag type exposes the following members.

Constructors
 | Name | Description
Public method | CommandBusyFlag | Creates the flag object and maps into this process shared memory of the corresponding name. If it does not already exist then it is created.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | is_set | Returns True if the flag has been set; False otherwise.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | set_flag | Sets the flag.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | unset_flag | Resets the flag.
Top
See Also

Reference

Autodesk.ProductInterface Namespace


CommandBusyFlag Constructor

Creates the flag object and maps into this process shared memory of the corresponding name. If it does not already exist then it is created.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public CommandBusyFlag(
    string flag
)
Public Sub New (
    flag As String
)

Parameters

flag
Type: SystemString
Flag name and the name of the shared memory to be mapped/created.
Remarks
See Also

Reference

CommandBusyFlag Class
Autodesk.ProductInterface Namespace


CommandBusyFlag Methods

The CommandBusyFlag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | is_set | Returns True if the flag has been set; False otherwise.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | set_flag | Sets the flag.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | unset_flag | Resets the flag.
Top
See Also

Reference

CommandBusyFlag Class
Autodesk.ProductInterface Namespace


CommandBusyFlag.is_set Method

CommandBusyFlagis_set Method

Returns True if the flag has been set; False otherwise.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Object is_set()
Public Function is_set As Object

Return Value

Type: Object
See Also

Reference

CommandBusyFlag Class
Autodesk.ProductInterface Namespace


CommandBusyFlag.set_flag Method

CommandBusyFlagset_flag Method

Sets the flag.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void set_flag()
Public Sub set_flag
See Also

Reference

CommandBusyFlag Class
Autodesk.ProductInterface Namespace


CommandBusyFlag.unset_flag Method

CommandBusyFlagunset_flag Method

Resets the flag.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void unset_flag()
Public Sub unset_flag
See Also

Reference

CommandBusyFlag Class
Autodesk.ProductInterface Namespace


ICancelPointPickCheck Interface

Cancel point picker helper interface.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface ICancelPointPickCheck
Public Interface ICancelPointPickCheck

The ICancelPointPickCheck type exposes the following members.

Methods
 | Name | Description
Public method | CanelPointPicking | Cancels point picking.
Public method | IsCancelPointPick | Gets CancelPointPick state.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface Namespace


ICancelPointPickCheck Methods

The ICancelPointPickCheck type exposes the following members.

Methods
 | Name | Description
Public method | CanelPointPicking | Cancels point picking.
Public method | IsCancelPointPick | Gets CancelPointPick state.
Top
See Also

Reference

ICancelPointPickCheck Interface
Autodesk.ProductInterface Namespace


ICancelPointPickCheck.CanelPointPicking Method

ICancelPointPickCheckCanelPointPicking Method

Cancels point picking.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
void CanelPointPicking()
Sub CanelPointPicking
Remarks
See Also

Reference

ICancelPointPickCheck Interface
Autodesk.ProductInterface Namespace


ICancelPointPickCheck.IsCancelPointPick Method

ICancelPointPickCheckIsCancelPointPick Method

Gets CancelPointPick state.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
bool IsCancelPointPick()
Function IsCancelPointPick As Boolean

Return Value

Type: Boolean
Remarks
See Also

Reference

ICancelPointPickCheck Interface
Autodesk.ProductInterface Namespace


InstanceReuse Enumeration

Specifies how an executable instance is to be obtained.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum InstanceReuse
Public Enumeration InstanceReuse
Members
Member name | Value | Description
UseExistingInstance | 0 | Will use an existing running instance
CreateNewInstance | 1 | Will create a new instance alongside any existing instances
CreateSingleInstance | 2 | Will close any existing instances and open a new instance
See Also

Reference

Autodesk.ProductInterface Namespace


Macro Class

Abstract base class for encapsulating a Macro and all operations thereon.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceMacro
Autodesk.ProductInterface.PowerMILLPMMacro
Autodesk.ProductInterface.PowerSHAPEPSMacro

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class Macro
Public MustInherit Class Macro

The Macro type exposes the following members.

Constructors
 | Name | Description
Protected method | Macro | Initializes a new instance of the Macro class
Top
Properties
 | Name | Description
Protected property | _childMacro |
Public property | Cancel | If True, Macro will be cancelled; False otherwise.
Public property | ExecutedCommands | Commands that have been executed by this Macro.
Public property | Index | Index of the next line to be executed in this Macro.
Public property | Line | Line at the specified index of this Macro.
Public property | LocalCount | Number of lines in this macro, excluding children.
Public property | Text | All lines of the Macro in a string.
Public property | TotalCount | Number of lines in this macro including children.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseStepProcessedEvent | Raises the step processed event.
Public method | Run | Will run the macro.
Public method | RunComplete | Will Run the Macro from start to finish rather then line by line. Substitution strings will be replaced before the macro is run.
Public method | RunStep | Will execute the next step in the Macro.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | StepProcessed | Raised when a Macro line is processed.
Top
Fields
 | Name | Description
Protected field | _cancel | If True, indicates that a Macro cancellation is pending.
Protected field | _executedCommands | List of commands that have been executed.
Protected field | _lines | Macro command lines.
Protected field | _localIndex | Current index within this Macro.
Protected field | _totalIndex | Current index within this file - including all sub macros.
Top
See Also

Reference

Autodesk.ProductInterface Namespace


Macro Constructor

Initializes a new instance of the Macro class

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected Macro()
Protected Sub New
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro Properties

The Macro type exposes the following members.

Properties
 | Name | Description
Protected property | _childMacro |
Public property | Cancel | If True, Macro will be cancelled; False otherwise.
Public property | ExecutedCommands | Commands that have been executed by this Macro.
Public property | Index | Index of the next line to be executed in this Macro.
Public property | Line | Line at the specified index of this Macro.
Public property | LocalCount | Number of lines in this macro, excluding children.
Public property | Text | All lines of the Macro in a string.
Public property | TotalCount | Number of lines in this macro including children.
Top
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro._childMacro Property

Macro_childMacro Property

[Missing <summary> documentation for "P:Autodesk.ProductInterface.Macro._childMacro"]

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected virtual Macro _childMacro { get; set; }
Protected Overridable Property _childMacro As Macro
    Get
    Set

Property Value

Type: Macro
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.Cancel Property

MacroCancel Property

If True, Macro will be cancelled; False otherwise.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.ExecutedCommands Property

MacroExecutedCommands Property

Commands that have been executed by this Macro.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<string> ExecutedCommands { get; }
Public ReadOnly Property ExecutedCommands As List(Of String)
    Get

Return Value

Type: List String
The commands that have been executed by this macro
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.Index Property

MacroIndex Property

Index of the next line to be executed in this Macro.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.Line Property

MacroLine Property

Line at the specified index of this Macro.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string this[
    int index
] { get; set; }
Public Property Line (
    index As Integer
) As String
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: String
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.LocalCount Property

MacroLocalCount Property

Number of lines in this macro, excluding children.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int LocalCount { get; }
Public ReadOnly Property LocalCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.Text Property

MacroText Property

All lines of the Macro in a string.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.TotalCount Property

MacroTotalCount Property

Number of lines in this macro including children.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual int TotalCount { get; }
Public Overridable ReadOnly Property TotalCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro Methods

The Macro type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseStepProcessedEvent | Raises the step processed event.
Public method | Run | Will run the macro.
Public method | RunComplete | Will Run the Macro from start to finish rather then line by line. Substitution strings will be replaced before the macro is run.
Public method | RunStep | Will execute the next step in the Macro.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.RaiseStepProcessedEvent Method

MacroRaiseStepProcessedEvent Method

Raises the step processed event.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void RaiseStepProcessedEvent(
    Object sender,
    MacroStepEventArgs e
)
Protected Sub RaiseStepProcessedEvent (
    sender As Object,
    e As MacroStepEventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: Autodesk.ProductInterfaceMacroStepEventArgs
Macro step event arguments.
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.Run Method

MacroRun Method

Will run the macro.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void Run(
    bool giveProgress = true,
    bool hideDialogs = true
)
Public MustOverride Sub Run (
    Optional giveProgress As Boolean = true,
    Optional hideDialogs As Boolean = true
)

Parameters

giveProgress (Optional)
Type: SystemBoolean
If True, events will be raised reporting the Macro's progress; False otherwise.
hideDialogs (Optional)
Type: SystemBoolean
If True, dialogs will be hidden; False otherwise.
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.RunComplete Method

MacroRunComplete Method

Will Run the Macro from start to finish rather then line by line. Substitution strings will be replaced before the macro is run.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void RunComplete()
Public MustOverride Sub RunComplete
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.RunStep Method

MacroRunStep Method

Will execute the next step in the Macro.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void RunStep(
    bool hideDialogs = true
)
Public MustOverride Sub RunStep (
    Optional hideDialogs As Boolean = true
)

Parameters

hideDialogs (Optional)
Type: SystemBoolean
If True, dialogs will be hidden; False otherwise.
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro Events

The Macro type exposes the following members.

Events
 | Name | Description
Public event | StepProcessed | Raised when a Macro line is processed.
Top
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.StepProcessed Event

MacroStepProcessed Event

Raised when a Macro line is processed.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public event MacroStepProcessedEventHandler StepProcessed
Public Event StepProcessed As MacroStepProcessedEventHandler

Value

Type: Autodesk.ProductInterfaceMacroStepProcessedEventHandler
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro Fields

The Macro type exposes the following members.

Fields
 | Name | Description
Protected field | _cancel | If True, indicates that a Macro cancellation is pending.
Protected field | _executedCommands | List of commands that have been executed.
Protected field | _lines | Macro command lines.
Protected field | _localIndex | Current index within this Macro.
Protected field | _totalIndex | Current index within this file - including all sub macros.
Top
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro._cancel Field

Macro_cancel Field

If True, indicates that a Macro cancellation is pending.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected bool _cancel
Protected _cancel As Boolean

Field Value

Type: Boolean
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro._executedCommands Field

Macro_executedCommands Field

List of commands that have been executed.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected List<string> _executedCommands
Protected _executedCommands As List(Of String)

Field Value

Type: List String
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro._lines Field

Macro_lines Field

Macro command lines.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected List<string> _lines
Protected _lines As List(Of String)

Field Value

Type: List String
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro._localIndex Field

Macro_localIndex Field

Current index within this Macro.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected int _localIndex
Protected _localIndex As Integer

Field Value

Type: Int32
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro._totalIndex Field

Macro_totalIndex Field

Current index within this file - including all sub macros.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected int _totalIndex
Protected _totalIndex As Integer

Field Value

Type: Int32
See Also

Reference

Macro Class
Autodesk.ProductInterface Namespace


Macro.StepProcessedEventHandler Delegate

MacroStepProcessedEventHandler Delegate

[Missing <summary> documentation for "T:Autodesk.ProductInterface.Macro.StepProcessedEventHandler"]

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public delegate void StepProcessedEventHandler(
    Object sender,
    MacroStepEventArgs e
)
Public Delegate Sub StepProcessedEventHandler (
    sender As Object,
    e As MacroStepEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Autodesk.ProductInterfaceMacroStepEventArgs
See Also

Reference

Autodesk.ProductInterface Namespace


MacroStepEventArgs Class

Encapsulates data used to report the progress of the Macro.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceMacroStepEventArgs

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class MacroStepEventArgs
Public Class MacroStepEventArgs

The MacroStepEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MacroStepEventArgs | Initialises the attributes of the EventArgs to the specified values.
Top
Properties
 | Name | Description
Public property | Index | Current step index in the Macro.
Public property | Percentage | Percentage complete: 0.0 - 100.0.
Public property | TotalSteps | Total number of steps in the Macro.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.ProductInterface Namespace


MacroStepEventArgs Constructor

Initialises the attributes of the EventArgs to the specified values.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MacroStepEventArgs(
    int index,
    int totalSteps
)
Public Sub New (
    index As Integer,
    totalSteps As Integer
)

Parameters

index
Type: SystemInt32
Start index.
totalSteps
Type: SystemInt32
Total number of steps.
See Also

Reference

MacroStepEventArgs Class
Autodesk.ProductInterface Namespace


MacroStepEventArgs Properties

The MacroStepEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Index | Current step index in the Macro.
Public property | Percentage | Percentage complete: 0.0 - 100.0.
Public property | TotalSteps | Total number of steps in the Macro.
Top
See Also

Reference

MacroStepEventArgs Class
Autodesk.ProductInterface Namespace


MacroStepEventArgs.Index Property

MacroStepEventArgsIndex Property

Current step index in the Macro.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
See Also

Reference

MacroStepEventArgs Class
Autodesk.ProductInterface Namespace


MacroStepEventArgs.Percentage Property

MacroStepEventArgsPercentage Property

Percentage complete: 0.0 - 100.0.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Percentage { get; }
Public ReadOnly Property Percentage As Double
    Get

Property Value

Type: Double
See Also

Reference

MacroStepEventArgs Class
Autodesk.ProductInterface Namespace


MacroStepEventArgs.TotalSteps Property

MacroStepEventArgsTotalSteps Property

Total number of steps in the Macro.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int TotalSteps { get; }
Public ReadOnly Property TotalSteps As Integer
    Get

Property Value

Type: Int32
See Also

Reference

MacroStepEventArgs Class
Autodesk.ProductInterface Namespace


MacroStepEventArgs Methods

The MacroStepEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MacroStepEventArgs Class
Autodesk.ProductInterface Namespace


PSCancelPointPicker Class

Cancel point picker helper.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfacePSCancelPointPicker

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSCancelPointPicker : ICancelPointPickCheck
Public Class PSCancelPointPicker
    Implements ICancelPointPickCheck

The PSCancelPointPicker type exposes the following members.

Constructors
 | Name | Description
Public method | PSCancelPointPicker | Initializes a new instance of the PSCancelPointPicker class
Top
Methods
 | Name | Description
Public method | CanelPointPicking | Sets IsCancelled flag to true.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelPointPick | Returns IsCancelled flag state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface Namespace


PSCancelPointPicker Constructor

Initializes a new instance of the PSCancelPointPicker class

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCancelPointPicker()
Public Sub New
See Also

Reference

PSCancelPointPicker Class
Autodesk.ProductInterface Namespace


PSCancelPointPicker Methods

The PSCancelPointPicker type exposes the following members.

Methods
 | Name | Description
Public method | CanelPointPicking | Sets IsCancelled flag to true.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelPointPick | Returns IsCancelled flag state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSCancelPointPicker Class
Autodesk.ProductInterface Namespace


PSCancelPointPicker.CanelPointPicking Method

PSCancelPointPickerCanelPointPicking Method

Sets IsCancelled flag to true.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CanelPointPicking()
Public Sub CanelPointPicking

Implements

ICancelPointPickCheckCanelPointPicking
Remarks
See Also

Reference

PSCancelPointPicker Class
Autodesk.ProductInterface Namespace


PSCancelPointPicker.IsCancelPointPick Method

PSCancelPointPickerIsCancelPointPick Method

Returns IsCancelled flag state.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsCancelPointPick()
Public Function IsCancelPointPick As Boolean

Return Value

Type: Boolean

Implements

ICancelPointPickCheckIsCancelPointPick
Remarks
See Also

Reference

PSCancelPointPicker Class
Autodesk.ProductInterface Namespace


SharedMemory Class

Provides a minimal .Net interface around unmanaged shared memory resources.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceSharedMemory

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class SharedMemory
Public Class SharedMemory

The SharedMemory type exposes the following members.

Constructors
 | Name | Description
Public method | SharedMemory | Initializes a new instance of the SharedMemory class
Top
Methods
 | Name | Description
Public method | Close | Unmaps the shared memory file from the address space of this application.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Clears up unmanaged resources. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Maps a shared memory file into the address space of this application. If the file does not already exist, it is created.
Public method | Peek | Returns to the caller the first UTF8 encoded byte of data held in the shared memory buffer.
Public method | Put | Writes data to the shared memory file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface Namespace


SharedMemory Constructor

Initializes a new instance of the SharedMemory class

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SharedMemory()
Public Sub New
See Also

Reference

SharedMemory Class
Autodesk.ProductInterface Namespace


SharedMemory Methods

The SharedMemory type exposes the following members.

Methods
 | Name | Description
Public method | Close | Unmaps the shared memory file from the address space of this application.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Clears up unmanaged resources. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Maps a shared memory file into the address space of this application. If the file does not already exist, it is created.
Public method | Peek | Returns to the caller the first UTF8 encoded byte of data held in the shared memory buffer.
Public method | Put | Writes data to the shared memory file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SharedMemory Class
Autodesk.ProductInterface Namespace


SharedMemory.Close Method

SharedMemoryClose Method

Unmaps the shared memory file from the address space of this application.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

SharedMemory Class
Autodesk.ProductInterface Namespace


SharedMemory.Finalize Method

SharedMemoryFinalize Method

Clears up unmanaged resources.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
Remarks
See Also

Reference

SharedMemory Class
Autodesk.ProductInterface Namespace


SharedMemory.Open Method

SharedMemoryOpen Method

Maps a shared memory file into the address space of this application. If the file does not already exist, it is created.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Open(
    string MemoryName,
    int Size
)
Public Function Open (
    MemoryName As String,
    Size As Integer
) As Boolean

Parameters

MemoryName
Type: SystemString
Name of the memory file.
Size
Type: SystemInt32
Size in bytes of the memory file.

Return Value

Type: Boolean
True if the operation is successful; False otherwise.
See Also

Reference

SharedMemory Class
Autodesk.ProductInterface Namespace


SharedMemory.Peek Method

SharedMemoryPeek Method

Returns to the caller the first UTF8 encoded byte of data held in the shared memory buffer.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Peek()
Public Function Peek As String

Return Value

Type: String
See Also

Reference

SharedMemory Class
Autodesk.ProductInterface Namespace


SharedMemory.Put Method

SharedMemoryPut Method

Writes data to the shared memory file.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Put(
    string Data
)
Public Sub Put (
    Data As String
)

Parameters

Data
Type: SystemString
Data to be written.
See Also

Reference

SharedMemory Class
Autodesk.ProductInterface Namespace


WindowHider Class

Facilitates the hiding of a named window.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceWindowHider

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class WindowHider
Public Class WindowHider

The WindowHider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HideWindow | Attempts to hide the window with the specified title.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.ProductInterface Namespace


WindowHider Methods

The WindowHider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HideWindow | Attempts to hide the window with the specified title.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WindowHider Class
Autodesk.ProductInterface Namespace


WindowHider.HideWindow Method

WindowHiderHideWindow Method

Attempts to hide the window with the specified title.

Namespace: Autodesk.ProductInterface
Assembly: Autodesk.ProductInterface (in Autodesk.ProductInterface.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void HideWindow(
    string windowTitle
)
Public Shared Sub HideWindow (
    windowTitle As String
)

Parameters

windowTitle
Type: SystemString
Title of window to hide.
See Also

Reference

WindowHider Class
Autodesk.ProductInterface Namespace


Autodesk.ProductInterface.PowerMILL Namespace

Classes
 | Class | Description
Public class | InvalidPowerMillParameterException |
Public class | InvalidPowerMillVersionException |
Public class | PMAutomation | This is the root class of a PowerMILL instance. When it is created it creates its own instance of PowerMILL. When it is destroyed the instance of PowerMILL will also be destroyed.
Public class | PMBoundariesCollection | Represents a collection of Boundary objects in the Active PowerMILL Project.
Public class | PMBoundary | Captures a Boundary object in PowerMILL.
Public class | PMBoundaryBlock | Represents a boundary at the extents of the block in PowerMILL.
Public class | PMBoundaryBooleanOperation | Represents a boundary created using a boolean operation in PowerMILL.
Public class | PMBoundaryCollisionSafe | Represents a boundary that is collision safe in PowerMILL.
Public class | PMBoundaryContactConversion | Represents a contact conversion boundary in PowerMILL.
Public class | PMBoundaryContactPoint | Represents a contact point boundary in PowerMILL.
Public class | PMBoundaryRest | Represents a rest boundary in PowerMILL.
Public class | PMBoundarySelectedSurface | Represents a selected surface boundary in PowerMILL.
Public class | PMBoundaryShallow | Represents a shallow boundary in PowerMILL.
Public class | PMBoundarySilhouette | Represents a silhouette boundary in PowerMILL.
Public class | PMBoundaryStockModelRest | Represents a stock model rest boundary in PowerMILL.
Public class | PMBoundaryUserDefined | Represents a user defined boundary in PowerMill.
Public class | PMCollectionT | Base class for all PowerMill Product Interface collections which items are not PMEntities. It controls the addition of items to PowerMill collections.
Public class | PMConnections | Home for PMLead and options that affect all leads on PMToolpath
Public class | PMEntitiesCollectionT | Represents the base class for all collection classes for PowerMILL.
Public class | PMEntity | Abstract base class that represents an item in PowerMILL.
Public class | PMFeatureSet | Captures a FeatureSet object in PowerMILL.
Public class | PMFeatureSetsCollection | Represents the collection of FeatureSet objects in the Active PowerMILL Project.
Public class | PMGroup | Captures a Group object in PowerMILL.
Public class | PMGroupsCollection | Represents the Collection of Group objects in the Active PowerMILL Project.
Public class | PMLead | Represent a Lead in PMToolpath.
Public class | PMLeadExtension | Represent a Lead extension in PMToolpath.
Public class | PMLevelOrSet | Captures a Level or Set object in PowerMILL.
Public class | PMLevelOrSetsCollection | Represents a collection of Level or Set objects in the Active PowerMILL Project.
Public class | PMMachineTool | Captures a Machine Tool object in PowerMILL.
Public class | PMMachineToolsCollection | Collection of Machine Tool objects in the Active PowerMILL Project.
Public class | PMMacro | Handles Macros in PowerMILL.
Public class | PMModel | Captures a Model object in PowerMILL.
Public class | PMModelsCollection | Collection of Model objects in the Active PowerMILL Project.
Public class | PMNCProgram | Captures a NCProgram object in PowerMILL
Public class | PMNCProgramsCollection | Collection of NCProgram objects in the Active PowerMILL Project.
Public class | PMPattern | Captures a Pattern object in PowerMILL
Public class | PMPatternsCollection | Collection of Pattern objects in the Active PowerMILL Project.
Public class | PMProject | Captures a PowerMILL project and gives access to the collections of objects in it.
Public class | PMRamp | PMRamp encapsulate the option that enables you to specify how the tool ramps into the stock.
Public class | PMStockModel | Captures a Stock Model object in PowerMILL.
Public class | PMStockModelsCollection | Collection of Stock Model objects in the Active PowerMILL Project.
Public class | PMSubstitutionToken | Captures a substitution token. When running PowerMILLMacros occurrences of the token will be replaced with the specified value.
Public class | PMSubstitutionTokensCollection | Collection of SubstitutionTokens that can be used by a PowerMILLMacro
Public class | PMTool | Captures a Tool object in PowerMILL.
Public class | PMToolBallNosed | Represents a ball nosed tool in PowerMILL.
Public class | PMToolBarrel | Represents a barrel tool in PowerMILL.
Public class | PMToolDovetail | Represents a Dovetail tool in PowerMILL.
Public class | PMToolDrill | Represents a drill tool in PowerMILL.
Public class | PMToolEndMill | Represents a EndMill tool.
Public class | PMToolForm | Represents a form tool in PowerMILL.
Public class | PMToolOffCentreTipRadiused | Represents a off centre tip radiused tool.
Public class | PMToolpath | Captures a Toolpath in PowerMILL.
Public class | PMToolpath3DOffsetFinishing | Represents a 3D offset finishing toolpath in PowerMill.
Public class | PMToolpathAdaptiveAreaClearance | Represents an adaptive area clearance toolpath strategy in PowerMill.
Public class | PMToolpathAlongCornerFinishing | Represents an along corner finishing toolpath in PowerMill.
Public class | PMToolpathBladeFinishing | Represents a blade finishing toolpath in PowerMill.
Public class | PMToolpathBladeMachining | Represents a blade machining toolpath strategy in PowerMill.
Public class | PMToolpathBliskAreaClearance | Represents a Blisk Area Clearance toolpath in PowerMill.
Public class | PMToolpathChamferMilling | Represents a chamfer milling toolpath in PowerMill.
Public class | PMToolpathConstantZFinishing | Represents a constant Z finishing toolpath in PowerMill.
Public class | PMToolpathCornerClearance | Represents a corner clearance toolpath strategy in PowerMill.
Public class | PMToolpathCornerFinishing | Represents a Corner Finishing toolpath strategy in PowerMill.
Public class | PMToolpathCurveAreaClearance | Represents a curve area clearance toolpath strategy in PowerMill.
Public class | PMToolpathCurveProfile | Represents a curve profile toolpath strategy in PowerMill.
Public class | PMToolpathCurveProjectionFinishing | Represents a curve projection finishing toolpath strategy in PowerMill.
Public class | PMToolpathDiscProfileFinishing | Represents a disc profile finishing toolpath strategy in PowerMill.
Public class | PMToolpathDrilling | Represents a drilling toolpath strategy in PowerMill.
Public class | PMToolpathEmbeddedPatternFinishing | Represents a embedded pattern finishing toolpath strategy in PowerMill.
Public class | PMToolpathFaceMilling | Represents a Face Milling toolpath strategy in PowerMill.
Public class | PMToolpathFlowlineFinishing | Represents a flowline finishing toolpath strategy in PowerMill.
Public class | PMToolpathHubFinishing | Represents a hub finishing toolpath strategy in PowerMill.
Public class | PMToolpathLineProjectionFinishing | Represents a line projection finishing strategy in PowerMill.
Public class | PMToolpathMethod | Represents a method toolpath strategy in PowerMill.
Public class | PMToolpathMultiPencilCornerFinishing | Represents a corner multi-pencil finishing toolpath strategy in PowerMill.
Public class | PMToolpathOffsetAreaClearance | Represents an offset area clearance toolpath strategy in PowerMill.
Public class | PMToolpathOffsetFlatFinishing | Represents an offset flat finishing toolpath strategy in PowerMill.
Public class | PMToolpathOptimisedConstantZFinishing | Represents an optimised constant Z finishing toolpath strategy in PowerMill.
Public class | PMToolpathParametricOffsetFinishing | Represents a parametric offset finishing toolpath strategy in PowerMill.
Public class | PMToolpathParametricSpiralFinishing | Represents a parametric spiral finishing toolpath strategy in PowerMill.
Public class | PMToolpathPatternFinishing | Represents a pattern finishing toolpath strategy in PowerMill.
Public class | PMToolpathPencilCornerFinishing | Represents a corner finishing pencil toolpath strategy in PowerMill.
Public class | PMToolpathPlaneProjectionFinishing | Represents a plane projection finishing toolpath strategy in PowerMill.
Public class | PMToolpathPlungeMilling | Represents a plunge milling toolpath strategy in PowerMill.
Public class | PMToolpathPointProjectionFinishing | Represents a point projection finishing toolpath strategy in PowerMill.
Public class | PMToolpathPortAreaClearance | Represents a Port Area Clearance toolpath strategy in PowerMill.
Public class | PMToolpathPortPlungeFinishing | Represents a Port Plunge Finishing toolpath strategy in PowerMill.
Public class | PMToolpathPortSpiralFinishing | Represents a Port Spiral Finishing toolpath strategy in PowerMill.
Public class | PMToolpathProfileAreaClearance | Represents a profiling area clearance toolpath strategy in PowerMill.
Public class | PMToolpathProfileFinishing | Represents a profile finishing toolpath strategy in PowerMill.
Public class | PMToolpathRadialFinishing | Represents a radial finishing toolpath strategy in PowerMill.
Public class | PMToolpathRasterAreaClearance | Represents a raster area clearance toolpath strategy in PowerMill.
Public class | PMToolpathRasterFinishing | Represents a raster finishing toolpath strategy in PowerMill.
Public class | PMToolpathRasterFlatFinishing | Represents a raster flat finishing toolpath strategy in PowerMill.
Public class | PMToolpathRibMachining | Represents a rib machining toolpath strategy in PowerMill.
Public class | PMToolpathRotaryFinishing | Represents a rotary finishing toolpath strategy in PowerMill.
Public class | PMToolpathsCollection | Collection of Toolpaths objects in the Active PowerMILL Project
Public class | PMToolpathSpiralFinishing | Represents a Spiral Finishing toolpath strategy in PowerMill.
Public class | PMToolpathSteepAndShallowFinishing | Represents a steep and shallow finishing toolpath strategy in PowerMill.
Public class | PMToolpathStitchCornerFinishing | Represents a Stitch Corner Finishing toolpath strategy in PowerMill.
Public class | PMToolpathSurfaceFinishing | Represents a surface finishing toolpath strategy in PowerMill.
Public class | PMToolpathSurfaceProjectionFinishing | Represents a Surface projection finishing toolpath strategy in PowerMill.
Public class | PMToolpathSwarfMachining | Represents a swarf machining toolpath strategy in PowerMill.
Public class | PMToolpathWireframeProfileMachining | Represents a Wireframe Profile Machining toolpath strategy in PowerMill.
Public class | PMToolpathWireframeSwarfMachining | Represents a wireframe swarf finishing toolpath strategy in PowerMill.
Public class | PMToolRouting | Represents a routing tool in PowerMILL.
Public class | PMToolsCollection | Collection of Tool objects in the Active PowerMILL Project.
Public class | PMToolTap | Represents a tapping tool in PowerMill.
Public class | PMToolTaperedSpherical | Represents a tapered spherical tool in PowerMill.
Public class | PMToolTaperedTipped | Represents a tapered tipped tool in PowerMill.
Public class | PMToolThreadMill | Represents a thread mill tool in PowerMill.
Public class | PMToolTippedDisc | Represents a tipped disc tool in PowerMill.
Public class | PMToolTipRadiused | Represents a tip radiused tool in PowerMill.
Public class | PMWorkplane | Captures the a Workplane in PowerMILL.
Public class | PMWorkplanesCollection | Collection of Workpath objects in the Active PowerMILL Project
Public class | PowerMillException |
Enumerations
 | Enumeration | Description
Public enumeration | CoolantOptions | Represents the coolant options in PowerMill. PowerMILL turns the coolant off at the end of a toolpath.
Public enumeration | DefaultLinkTypes | Type of link moves
Public enumeration | DrillCycleTypes |
Public enumeration | EndPointMethod | Specifies the location of the tool at the end of the toolpath.
Public enumeration | ExtensionLeadMoveTypes | a PMLead's move type to be used before each cutting move
Public enumeration | LeadTypes | Type of leads to configure PMLead settings.
Public enumeration | LinkTypes | The type of link moves to connect consecutive cutting passes for links shorter than the Short/Long threshold value.
Public enumeration | Modes | Represents the GUi option in PowerMill.
Public enumeration | MoveDirection | The orientation of the links.
Public enumeration | MoveType | a PMLead's move type to be used before each cutting move
Public enumeration | PMMacroSubMacroRunOptions | Determines whether a macro is run sub macro directly with no substitution (RunAsSingleLine) or send all macro lines as individual command (RunAllLines).
Public enumeration | PointApproach | Direction in which to define the incremental move.
Public enumeration | RampFollow | Direction of PMRamp.
Public enumeration | RampHeight | Select how to determine the height from which the ramp descends
Public enumeration | StartPointMethod | Defines how the start point is set.
Public enumeration | ToolChangePositions | Represents the tool change positions in PowerMill.
Public enumeration | ToolChanges | Represents the Tool changes in PowerMill.
Public enumeration | ToolNumberings | Represents the tool numberings in PowerMill.
Public enumeration | ToolpathSafety | Indicates the safety of various parts of the toolpath.
Public enumeration | ToolValues | Represents tool values in PowerMill.


CoolantOptions Enumeration

Represents the coolant options in PowerMill. PowerMILL turns the coolant off at the end of a toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum CoolantOptions
Public Enumeration CoolantOptions
Members
Member name | Value | Description
None | 0 | There is no coolant output.
Standard | 1 | Turns the coolant on.
Flood | 2 | Turns the coolant to flood.
Mist | 3 | Turns the coolant to mist.
Tap | 4 | Turns the coolant to tap.
Air | 5 | Turns the coolant to air blast.
Through | 6 | Turns the coolant to through spindle.
Double | 7 | Enables two coolant codes.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


DefaultLinkTypes Enumeration

Type of link moves

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum DefaultLinkTypes
Public Enumeration DefaultLinkTypes
Members
Member name | Value | Description
Incremental | 0 | The tool descends at rapid feed from the safe area to the specified incremental distance above the target point, and then plunges the remaining distance. If you have a multi-axis toolpath, the tool retracts a set distance along the tool axis and then retracts to the safe area. It comes down from the safe area and completes the approach along the tool axis
Safe | 1 | The tool moves to the safe area before making the link move.
Skim | 2 | The links traverse clear of the part by the specified incremental distance, descend at rapid feed to the specified incremental distance above the contact point, and then plunge the remaining distance.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


DrillCycleTypes Enumeration

[Missing <summary> documentation for "T:Autodesk.ProductInterface.PowerMILL.DrillCycleTypes"]

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum DrillCycleTypes
Public Enumeration DrillCycleTypes
Members
Member name | Value | Description
BreakChip | 0 | Drills the holes in several stages (multiple peck) only retracting a small amount after each peck.
CounterBore | 1 | The second of the boring cycles (G86).
DeepDrill | 2 | Drills the holes in several stages (multiple peck).
ExternalThread | 3 | Creates an external thread on a boss.
FineBoring | 4 | An alternative deep drilling cycle, so may be used for machines with a variety of deep drilling cycles.
Helical | 5 | Bores out a large hole with a small tool. The concept is similar to trochoidal milling. The difference between the two is that trochoidal milling machines a slot (no variation in Z) and helical milling drills a hole (machines down the Z axis).
Profile | 6 | Drills the hole using circular moves. A tool smaller than the size of the hole is required. At each depth, the tool moves on to the edge of the hole using a circular arc lead with a straight extension, cuts a circle, and then moves back to the centre with a circular arc lead and straight extension. You may use a thickness value to create a smaller hole.
Ream | 7 | The first of the boring cycles (G85).
RigidTapping | 8 | Enables you to enter a Peck depth as well as a Pitch.
SinglePeck | 9 | Drills the holes in one operation.
Tap | 10 | Drills the holes in one direction and reverses out.
ThreadMill | 11 | A cycle similar to reverse helical but with improved leads in and out for thread creation.
Bore | 12 | These correspond to the third, fourth, and fifth type of boring cycle (G87-G89) normally found on a machine tool. The difference between the boring operations varies from machine tool to machine tool.
ReverseHelical | 13 | A second helical drill cycle. This bores out a large hole with a small tool. It performs a helical movement from the bottom of the hole. Use this for finishing a hole as you can use it only with a pre-drilled hole.
HelicalClockwise | 14 |
ReverseHelicalClockwise | 15 |
ProfileClockwise | 16 |
TapClockwise | 17 |
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


EndPointMethod Enumeration

Specifies the location of the tool at the end of the toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum EndPointMethod
Public Enumeration EndPointMethod
Members
Member name | Value | Description
Absolute | 0 | Use an absolute position.
BlockCentre | 1 | The end point is at Safe Z above the block centre:
LastPoint | 2 | Position end point at specified distance above the end of the last segment or leadout in the toolpath.
LastPointSafe | 3 | Position end point on the safe area above the end of the last segment or leadout in the toolpath.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


ExtensionLeadMoveTypes Enumeration

a PMLead's move type to be used before each cutting move

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ExtensionLeadMoveTypes
Public Enumeration ExtensionLeadMoveTypes
Members
Member name | Value | Description
None | 0 | There are no leads in or out applied to the toolpath. This is the default option.
Straight | 1 | This inserts a straight move at the end of each cutting move. The direction of the move is determined by the Angle.
SurfaceNormalArc | 2 | This inserts a tangential arc move at the end of each cutting path. This arc lies in the plane defined by the toolpath's tangent direction and the surface normal.
VerticalArc | 3 | This inserts a tangential arc move at the end of each cutting path. This arc lies in a plane containing the tangent direction and the tool axis.
HorizontalArc | 4 | This inserts a tangential arc move at the end of each cutting path. This arc lies in the plane containing the tool axis and the tangent direction, rotated by 90DegreesSymbol about the tangent direction.
HorizontalArcLeft | 5 |
HorizontalArcRight | 6 |
ExtendedMove | 7 | This inserts a straight tangential move at the end of each cutting move.
Boxed | 8 | This inserts a horizontal move at the end of each cutting move.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillParameterException Class

[Missing <summary> documentation for "T:Autodesk.ProductInterface.PowerMILL.InvalidPowerMillParameterException"]

Inheritance Hierarchy
SystemObject
SystemException
Autodesk.ProductInterface.PowerMILLInvalidPowerMillParameterException

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class InvalidPowerMillParameterException : Exception
Public Class InvalidPowerMillParameterException
    Inherits Exception

The InvalidPowerMillParameterException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidPowerMillParameterException | Initializes a new instance of the InvalidPowerMillParameterException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillParameterException Constructor

Initializes a new instance of the InvalidPowerMillParameterException class

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public InvalidPowerMillParameterException(
    Version version,
    string parameterName
)
Public Sub New (
    version As Version,
    parameterName As String
)

Parameters

version
Type: SystemVersion

[Missing <param name="version"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.InvalidPowerMillParameterException.#ctor(System.Version,System.String)"]

parameterName
Type: SystemString

[Missing <param name="parameterName"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.InvalidPowerMillParameterException.#ctor(System.Version,System.String)"]

See Also

Reference

InvalidPowerMillParameterException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillParameterException Properties

The InvalidPowerMillParameterException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPowerMillParameterException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillParameterException.Message Property

InvalidPowerMillParameterExceptionMessage Property

[Missing <summary> documentation for "P:Autodesk.ProductInterface.PowerMILL.InvalidPowerMillParameterException.Message"]

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

InvalidPowerMillParameterException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillParameterException Methods

The InvalidPowerMillParameterException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPowerMillParameterException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillParameterException Events

The InvalidPowerMillParameterException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPowerMillParameterException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillVersionException Class

[Missing <summary> documentation for "T:Autodesk.ProductInterface.PowerMILL.InvalidPowerMillVersionException"]

Inheritance Hierarchy
SystemObject
SystemException
Autodesk.ProductInterface.PowerMILLInvalidPowerMillVersionException

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class InvalidPowerMillVersionException : Exception
Public Class InvalidPowerMillVersionException
    Inherits Exception

The InvalidPowerMillVersionException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidPowerMillVersionException | Initializes a new instance of the InvalidPowerMillVersionException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillVersionException Constructor

Initializes a new instance of the InvalidPowerMillVersionException class

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public InvalidPowerMillVersionException(
    Version version,
    string option
)
Public Sub New (
    version As Version,
    option As String
)

Parameters

version
Type: SystemVersion

[Missing <param name="version"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.InvalidPowerMillVersionException.#ctor(System.Version,System.String)"]

option
Type: SystemString

[Missing <param name="option"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.InvalidPowerMillVersionException.#ctor(System.Version,System.String)"]

See Also

Reference

InvalidPowerMillVersionException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillVersionException Properties

The InvalidPowerMillVersionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPowerMillVersionException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillVersionException.Message Property

InvalidPowerMillVersionExceptionMessage Property

[Missing <summary> documentation for "P:Autodesk.ProductInterface.PowerMILL.InvalidPowerMillVersionException.Message"]

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

InvalidPowerMillVersionException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillVersionException Methods

The InvalidPowerMillVersionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPowerMillVersionException Class
Autodesk.ProductInterface.PowerMILL Namespace


InvalidPowerMillVersionException Events

The InvalidPowerMillVersionException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPowerMillVersionException Class
Autodesk.ProductInterface.PowerMILL Namespace


LeadTypes Enumeration

Type of leads to configure PMLead settings.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum LeadTypes
Public Enumeration LeadTypes
Members
Member name | Value | Description
LeadIn | 0 | Lead in first choice, Settings to control the movement of the tool as it approaches the stock, before beginning a cutting move.
LeadInSecond | 1 | Lead in second choice,Settings to control the movement of the tool as it approaches the stock, before beginning a cutting move. which is used if 1st choice gouges.
LeadOut | 2 | Settings to control the movement of the tool after it leaves the stock, at the end of a cutting move.
LeadOutSecond | 3 | Settings to control the movement of the tool after it leaves the stock, at the end of a cutting move. which is used if 1st choice gouges.
FirstLeadIn | 4 | Settings to specify a First Lead In move that is different from the subsequent lead in moves.
LastLeadOut | 5 | Settings to specify a Last Lead Out move that is different from the previous lead out moves.
LeadInExtension | 6 | These options add an additional Lead In before the existing one.
LeadOutExtension | 7 | These options add an additional Lead Out after the existing one.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


LinkTypes Enumeration

The type of link moves to connect consecutive cutting passes for links shorter than the Short/Long threshold value.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum LinkTypes
Public Enumeration LinkTypes
Members
Member name | Value | Description
Safe | 0 | The tool moves to the safe area before making the link move.
Incremental | 1 | The tool descends at rapid feed from the safe area to the specified incremental distance above the target point, and then plunges the remaining distance. If you have a multi-axis toolpath, the tool retracts a set distance along the tool axis and then retracts to the safe area. It comes down from the safe area and completes the approach along the tool axis. The distance moved along the tool axis is controlled by the Plunge Distance on the Z Heights
Skim | 2 | The links traverse clear of the part by the specified incremental distance, descend at rapid feed to the specified incremental distance above the contact point, and then plunge the remaining distance
OnSurface | 3 | The links follow the surface of the triangulated model, and so prevent gouging.
Stepdown | 4 | The links traverse clear of the part by an amount, so that with the specified Stepdown the vertical descent will reach the next contact point
Straight | 5 | Straight-line moves are used. These straight moves between raster paths could cause gouging over curved areas of the model.
CircularArc | 6 | The tool moves are circular.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


Modes Enumeration

Represents the GUi option in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum Modes
Public Enumeration Modes
Members
Member name | Value | Description
WithGui | 0 |
WithoutGui | 1 |
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


MoveDirection Enumeration

The orientation of the links.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum MoveDirection
Public Enumeration MoveDirection
Members
Member name | Value | Description
ToolAxis | 0 | The retract and approach moves have the same orientation as the tool axis.
Normal | 1 | The retract and approach moves are normal to the contact point (or normal to the Leads In/Out). This can be particularly useful for tipped disc cutters where moving along the tool axis may not be possible (for example, when undercutting).
Tangent | 2 | The retract and approach moves are tangential to the toolpath.
Radial | 3 | The retract and approach moves are perpendicular to both the tool axis and the tangent direction of the toolpath.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


MoveType Enumeration

a PMLead's move type to be used before each cutting move

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum MoveType
Public Enumeration MoveType
Members
Member name | Value | Description
None | 0 | There are no leads in or out applied to the toolpath. This is the default option.
Straight | 1 | This inserts a straight move at the end of each cutting move. The direction of the move is determined by the Angle.
SurfaceNormalArc | 2 | This inserts a tangential arc move at the end of each cutting path. This arc lies in the plane defined by the toolpath's tangent direction and the surface normal.
VerticalArc | 3 | This inserts a tangential arc move at the end of each cutting path. This arc lies in a plane containing the tangent direction and the tool axis.
HorizontalArc | 4 | This inserts a tangential arc move at the end of each cutting path. This arc lies in the plane containing the tool axis and the tangent direction, rotated by 90DegreesSymbol about the tangent direction.
HorizontalArcLeft | 5 |
HorizontalArcRight | 6 |
ExtendedMove | 7 | This inserts a straight tangential move at the end of each cutting move.
Boxed | 8 | This inserts a horizontal move at the end of each cutting move.
Ramp | 9 | This ramps the tool into the model at a specified angle. This enables you to use a non-plunging tool, but is dependent on the tool and the material. Selecting this option enables the Ramp options button.
PocketCentre | 10 | Pocket centre — This produces a tangential lead move that, in the case of a Lead In, starts at the centre of the pocket ( a Lead Out finishes at the centre). The centre is the centre of the box that encloses the closed segment. This option is particularly useful when profiling pocket features which have been pre-drilled at the centre, although it can be used with any closed segment.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation Class

This is the root class of a PowerMILL instance. When it is created it creates its own instance of PowerMILL. When it is destroyed the instance of PowerMILL will also be destroyed.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceAutomation
Autodesk.ProductInterface.PowerMILLPMAutomation

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMAutomation : Automation,
    IDisposable
Public Class PMAutomation
    Inherits Automation
    Implements IDisposable

The PMAutomation type exposes the following members.

Constructors
 | Name | Description
Public method | PMAutomation(Object) | Connect to an instance of PowerMill that is passed in (this should be the COM object)
Public method | PMAutomation(InstanceReuse, Modes) | Calls down to the base class to start PowerMILL based on the specified option.
Public method | PMAutomation(InstanceReuse, Version, Version, Modes) | Calls down to the base class to start PowerMILL based on the specified options.
Top
Properties
 | Name | Description
Public property | ActiveProject | Gets the Active Project in PowerMILL.
Protected property | ExecutableName | Gets the name of the process in the process list. (Overrides AutomationExecutableName.)
Public property | IsBlockVisible | Sets whether the block is visible or not.
Public property | IsBusy | Gets whether PowerMill is busy doing something or not
Public property | IsGUIVisible | Shows/Hides the User Interface (toolbars etc). (Overrides AutomationIsGUIVisible.)
Public property | IsRunning | True if the process is running; false otherwise. (Inherited from Automation.)
Public property | IssueEchoOffCommands | Determines whether powermill echo off commmand should be fired prior to an ExecuteEx command to avoid issue of retrieving information when the PM echo window is displayed.
Public property | IsVisible | Gets or sets the property showing whether PowerMILL is visible or not. (Overrides AutomationIsVisible.)
Public property | MainWindowId | Gets the main window ID. (Overrides AutomationMainWindowId.)
Public property | ProcessId | Process id of the application instance. (Inherited from Automation.)
Public property | SubstitutionTokens | Gets and sets the collection of SubstitutionTokens that will be used by executing macros.
Public property | Units | Gets and sets the units of the active project.
Public property | Version | (Overrides AutomationVersion.)
Top
Methods
 | Name | Description
Public method | CheckCollisionStatus | Checking collision status
Protected method | CloseAllInstancesOf | Closes all instances of a process with the specified name. (Inherited from Automation.)
Public method | CloseProject | Closes the current Project without saving changes.
Public method | CollisionsOff | Turns off the collision checking in PowerMILL.
Public method | CollisionsOn | Turns on the collision checking in PowerMILL.
Protected method | CreateNewInstance | This operation is not allowed as PowerMILL does not support creating instances via ClassId. (Overrides AutomationCreateNewInstance(Version, Version).)
Protected method | CreateSingleInstance | Closes all running instance of PowerMILL and start a new one. (Overrides AutomationCreateSingleInstance(Version, Version).)
Public method | DialogsOff | Turns off the warnings and error messages in PowerMILL.
Public method | DialogsOn | Turns on the warnings and error messages in PowerMILL.
Public method | Dispose | Implements the IDisposable interface.
Protected method | Dispose(Boolean) | Implements the IDisposable interface.
Public method | EchoCommandsOff | Turns command echoing on.
Public method | EchoCommandsOn | Turns command echoing on.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecutablePath | Retrieves from the registry the path to the specified application. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then the path to this executable will be returned. Should maximumVersion be unspecified, only the path to the absolute version specified in version will be returned. (Inherited from Automation.)
Public method | Execute | Obsolete. Runs an array of commands in PowerMILL. It is marked as obsolete as all commands should be available as functions in this Automation Interface.
Public method | ExecuteEx | Obsolete. Runs the given command in PowerMILL. It is marked as obsolete as all commands should be available as functions in this Automation Interface.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialise(InstanceReuse) | Specifies whether an existing instance of the application be used or a new one created. This implementation is version non-specific and either the first existing instance of the application found or the latest installed version will be used. (Inherited from Automation.)
Protected method | Initialise(InstanceReuse, Version, Version) | Specifies whether an existing instance of the application be used or a new one created. The application version must be specified and, optionally, a maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Public method | LoadMacro(String) | Create a macro from a string.
Public method | LoadMacro(File) | Loads a macro from the specified file that can be stepped through or run with progress feedback.
Public method | LoadProject | Loads the project in the specified path into PowerMILL.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Quit | Closes the instance of the PowerMILL. (Overrides AutomationQuit.)
Public method | RecordMacro | Starts recording a macro. (Overrides AutomationRecordMacro(String).)
Public method | RefreshOff | Turns graphics updates off.
Public method | RefreshOn | Turns graphics updates on.
Public method | Reset | Closes the open project and resets PowerMILL back to an empty initial state.
Public method | RunMacro(String) | Runs the Macro at the given location.
Public method | RunMacro(File) | Runs the Macro at the given location.
Public method | RunMacro(PMMacro) | Runs the specified Macro.
Public method | SetActivePlane | Sets the active plane in PowerMILL.
Public method | SetViewAngle | Sets the view angle of the current project based on the Active Workplane. (Overrides AutomationSetViewAngle(ViewAngles).)
Protected method | StartByClassId | Creates and returns a reference to a COM object as specified by the ClassId argument. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Protected method | StartExecutable | Launches the executable located at the path retrieved from the registry for the specified application name, version and maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Public method | StopMacroRecording | Stops recording macro. (Overrides AutomationStopMacroRecording.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UseExistingInstance | Attempts to connect to an existing version of PowerMILL or create a new one if no version has been passed. (Overrides AutomationUseExistingInstance(Version, Version).)
Top
Fields
 | Name | Description
Protected field | _instanceReuse | Indicates whether a new instance of the application should be launched or an existing one be used. (Inherited from Automation.)
Protected field | _isGUIVisible | If True, the GUI is shown; false otherwise. (Inherited from Automation.)
Protected field | _processId | Application process id. (Inherited from Automation.)
Protected field | _version | Specifies the application version to use. (Inherited from Automation.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation Constructor

Overload List
 | Name | Description
Public method | PMAutomation(Object) | Connect to an instance of PowerMill that is passed in (this should be the COM object)
Public method | PMAutomation(InstanceReuse, Modes) | Calls down to the base class to start PowerMILL based on the specified option.
Public method | PMAutomation(InstanceReuse, Version, Version, Modes) | Calls down to the base class to start PowerMILL based on the specified options.
Top
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation Constructor (Object)

Connect to an instance of PowerMill that is passed in (this should be the COM object)

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMAutomation(
    Object powerMillComObject
)
Public Sub New (
    powerMillComObject As Object
)

Parameters

powerMillComObject
Type: SystemObject
The COM object of PowerMill to connect to.
See Also

Reference

PMAutomation Class
PMAutomation Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation Constructor (InstanceReuse, Modes)

Calls down to the base class to start PowerMILL based on the specified option.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMAutomation(
    InstanceReuse instanceReuse,
    Modes applicationMode = Modes.WithoutGui
)
Public Sub New (
    instanceReuse As InstanceReuse,
    Optional applicationMode As Modes = Modes.WithoutGui
)

Parameters

instanceReuse
Type: Autodesk.ProductInterfaceInstanceReuse
Specifies how to start the application (e.g. use the running instance, create a new instance).
applicationMode (Optional)
Type: Autodesk.ProductInterface.PowerMILLModes
Represents the GUI option in PowerMill.
Remarks
See Also

Reference

PMAutomation Class
PMAutomation Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation Constructor (InstanceReuse, Version, Version, Modes)

Calls down to the base class to start PowerMILL based on the specified options.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMAutomation(
    InstanceReuse instanceReuse,
    Version version,
    Version maximumVersion = null,
    Modes applicationMode = Modes.WithoutGui
)
Public Sub New (
    instanceReuse As InstanceReuse,
    version As Version,
    Optional maximumVersion As Version = Nothing,
    Optional applicationMode As Modes = Modes.WithoutGui
)

Parameters

instanceReuse
Type: Autodesk.ProductInterfaceInstanceReuse
Specifies how to start the application (e.g. use the running instance, create a new instance).
version
Type: SystemVersion
The PowerMill version to start.
maximumVersion (Optional)
Type: SystemVersion
It will ensure that the PowerMill version to run will be below maximumVersion.
applicationMode (Optional)
Type: Autodesk.ProductInterface.PowerMILLModes
Represents the GUI option in PowerMill.
Remarks
See Also

Reference

PMAutomation Class
PMAutomation Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation Properties

The PMAutomation type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProject | Gets the Active Project in PowerMILL.
Protected property | ExecutableName | Gets the name of the process in the process list. (Overrides AutomationExecutableName.)
Public property | IsBlockVisible | Sets whether the block is visible or not.
Public property | IsBusy | Gets whether PowerMill is busy doing something or not
Public property | IsGUIVisible | Shows/Hides the User Interface (toolbars etc). (Overrides AutomationIsGUIVisible.)
Public property | IsRunning | True if the process is running; false otherwise. (Inherited from Automation.)
Public property | IssueEchoOffCommands | Determines whether powermill echo off commmand should be fired prior to an ExecuteEx command to avoid issue of retrieving information when the PM echo window is displayed.
Public property | IsVisible | Gets or sets the property showing whether PowerMILL is visible or not. (Overrides AutomationIsVisible.)
Public property | MainWindowId | Gets the main window ID. (Overrides AutomationMainWindowId.)
Public property | ProcessId | Process id of the application instance. (Inherited from Automation.)
Public property | SubstitutionTokens | Gets and sets the collection of SubstitutionTokens that will be used by executing macros.
Public property | Units | Gets and sets the units of the active project.
Public property | Version | (Overrides AutomationVersion.)
Top
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.ActiveProject Property

PMAutomationActiveProject Property

Gets the Active Project in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMProject ActiveProject { get; }
Public ReadOnly Property ActiveProject As PMProject
    Get

Property Value

Type: PMProject
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.ExecutableName Property

PMAutomationExecutableName Property

Gets the name of the process in the process list.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override Object ExecutableName { get; }
Protected Overrides ReadOnly Property ExecutableName As Object
    Get

Property Value

Type: Object
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.IsBlockVisible Property

PMAutomationIsBlockVisible Property

Sets whether the block is visible or not.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsBlockVisible { set; }
Public WriteOnly Property IsBlockVisible As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.IsBusy Property

PMAutomationIsBusy Property

Gets whether PowerMill is busy doing something or not

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsBusy { get; }
Public ReadOnly Property IsBusy As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.IsGUIVisible Property

PMAutomationIsGUIVisible Property

Shows/Hides the User Interface (toolbars etc).

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool IsGUIVisible { get; set; }
Public Overrides Property IsGUIVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.IssueEchoOffCommands Property

PMAutomationIssueEchoOffCommands Property

Determines whether powermill echo off commmand should be fired prior to an ExecuteEx command to avoid issue of retrieving information when the PM echo window is displayed.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IssueEchoOffCommands { get; set; }
Public Property IssueEchoOffCommands As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.IsVisible Property

PMAutomationIsVisible Property

Gets or sets the property showing whether PowerMILL is visible or not.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool IsVisible { get; set; }
Public Overrides Property IsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.MainWindowId Property

PMAutomationMainWindowId Property

Gets the main window ID.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int MainWindowId { get; }
Public Overrides ReadOnly Property MainWindowId As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.SubstitutionTokens Property

PMAutomationSubstitutionTokens Property

Gets and sets the collection of SubstitutionTokens that will be used by executing macros.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMSubstitutionTokensCollection SubstitutionTokens { get; set; }
Public Property SubstitutionTokens As PMSubstitutionTokensCollection
    Get
    Set

Property Value

Type: PMSubstitutionTokensCollection
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.Units Property

PMAutomationUnits Property

Gets and sets the units of the active project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public LengthUnits Units { get; set; }
Public Property Units As LengthUnits
    Get
    Set

Property Value

Type: LengthUnits
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.Version Property

PMAutomationVersion Property

[Missing <summary> documentation for "P:Autodesk.ProductInterface.PowerMILL.PMAutomation.Version"]

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Version Version { get; }
Public Overrides ReadOnly Property Version As Version
    Get

Property Value

Type: Version
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation Methods

The PMAutomation type exposes the following members.

Methods
 | Name | Description
Public method | CheckCollisionStatus | Checking collision status
Protected method | CloseAllInstancesOf | Closes all instances of a process with the specified name. (Inherited from Automation.)
Public method | CloseProject | Closes the current Project without saving changes.
Public method | CollisionsOff | Turns off the collision checking in PowerMILL.
Public method | CollisionsOn | Turns on the collision checking in PowerMILL.
Protected method | CreateNewInstance | This operation is not allowed as PowerMILL does not support creating instances via ClassId. (Overrides AutomationCreateNewInstance(Version, Version).)
Protected method | CreateSingleInstance | Closes all running instance of PowerMILL and start a new one. (Overrides AutomationCreateSingleInstance(Version, Version).)
Public method | DialogsOff | Turns off the warnings and error messages in PowerMILL.
Public method | DialogsOn | Turns on the warnings and error messages in PowerMILL.
Public method | Dispose | Implements the IDisposable interface.
Protected method | Dispose(Boolean) | Implements the IDisposable interface.
Public method | EchoCommandsOff | Turns command echoing on.
Public method | EchoCommandsOn | Turns command echoing on.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecutablePath | Retrieves from the registry the path to the specified application. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then the path to this executable will be returned. Should maximumVersion be unspecified, only the path to the absolute version specified in version will be returned. (Inherited from Automation.)
Public method | Execute | Obsolete. Runs an array of commands in PowerMILL. It is marked as obsolete as all commands should be available as functions in this Automation Interface.
Public method | ExecuteEx | Obsolete. Runs the given command in PowerMILL. It is marked as obsolete as all commands should be available as functions in this Automation Interface.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialise(InstanceReuse) | Specifies whether an existing instance of the application be used or a new one created. This implementation is version non-specific and either the first existing instance of the application found or the latest installed version will be used. (Inherited from Automation.)
Protected method | Initialise(InstanceReuse, Version, Version) | Specifies whether an existing instance of the application be used or a new one created. The application version must be specified and, optionally, a maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Public method | LoadMacro(String) | Create a macro from a string.
Public method | LoadMacro(File) | Loads a macro from the specified file that can be stepped through or run with progress feedback.
Public method | LoadProject | Loads the project in the specified path into PowerMILL.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Quit | Closes the instance of the PowerMILL. (Overrides AutomationQuit.)
Public method | RecordMacro | Starts recording a macro. (Overrides AutomationRecordMacro(String).)
Public method | RefreshOff | Turns graphics updates off.
Public method | RefreshOn | Turns graphics updates on.
Public method | Reset | Closes the open project and resets PowerMILL back to an empty initial state.
Public method | RunMacro(String) | Runs the Macro at the given location.
Public method | RunMacro(File) | Runs the Macro at the given location.
Public method | RunMacro(PMMacro) | Runs the specified Macro.
Public method | SetActivePlane | Sets the active plane in PowerMILL.
Public method | SetViewAngle | Sets the view angle of the current project based on the Active Workplane. (Overrides AutomationSetViewAngle(ViewAngles).)
Protected method | StartByClassId | Creates and returns a reference to a COM object as specified by the ClassId argument. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Protected method | StartExecutable | Launches the executable located at the path retrieved from the registry for the specified application name, version and maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Public method | StopMacroRecording | Stops recording macro. (Overrides AutomationStopMacroRecording.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UseExistingInstance | Attempts to connect to an existing version of PowerMILL or create a new one if no version has been passed. (Overrides AutomationUseExistingInstance(Version, Version).)
Top
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.CheckCollisionStatus Method

PMAutomationCheckCollisionStatus Method

Checking collision status

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool CheckCollisionStatus()
Public Function CheckCollisionStatus As Boolean

Return Value

Type: Boolean
returns true if the collision status = ON / returns false if the collision status = OFF
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.CloseProject Method

PMAutomationCloseProject Method

Closes the current Project without saving changes.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CloseProject()
Public Sub CloseProject
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.CollisionsOff Method

PMAutomationCollisionsOff Method

Turns off the collision checking in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CollisionsOff()
Public Sub CollisionsOff
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.CollisionsOn Method

PMAutomationCollisionsOn Method

Turns on the collision checking in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CollisionsOn()
Public Sub CollisionsOn
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.CreateNewInstance Method

PMAutomationCreateNewInstance Method

This operation is not allowed as PowerMILL does not support creating instances via ClassId.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override void CreateNewInstance(
    Version version,
    Version maximumVersion
)
Protected Overrides Sub CreateNewInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
The PowerMill version to start.
maximumVersion
Type: SystemVersion
If filled, it will ensure that the PowerMill version to run will be below maximumVersion.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.CreateSingleInstance Method

PMAutomationCreateSingleInstance Method

Closes all running instance of PowerMILL and start a new one.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override void CreateSingleInstance(
    Version version,
    Version maximumVersion
)
Protected Overrides Sub CreateSingleInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
The PowerMill version to start.
maximumVersion
Type: SystemVersion
If filled, it will ensure that the PowerMill version to run will be below maximumVersion.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.DialogsOff Method

PMAutomationDialogsOff Method

Turns off the warnings and error messages in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DialogsOff()
Public Sub DialogsOff
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.DialogsOn Method

PMAutomationDialogsOn Method

Turns on the warnings and error messages in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DialogsOn()
Public Sub DialogsOn
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.Dispose Method

PMAutomationDispose Method

Overload List
 | Name | Description
Public method | Dispose | Implements the IDisposable interface.
Protected method | Dispose(Boolean) | Implements the IDisposable interface.
Top
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.Dispose Method

PMAutomationDispose Method

Implements the IDisposable interface.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PMAutomation Class
Dispose Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.Dispose Method (Boolean)

PMAutomationDispose Method (Boolean)

Implements the IDisposable interface.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PMAutomation Class
Dispose Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.EchoCommandsOff Method

PMAutomationEchoCommandsOff Method

Turns command echoing on.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EchoCommandsOff()
Public Sub EchoCommandsOff
Remarks
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.EchoCommandsOn Method

PMAutomationEchoCommandsOn Method

Turns command echoing on.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EchoCommandsOn()
Public Sub EchoCommandsOn
Remarks
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.Execute Method

PMAutomationExecute Method

Note: This API is now obsolete.

Runs an array of commands in PowerMILL. It is marked as obsolete as all commands should be available as functions in this Automation Interface.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[ObsoleteAttribute("")]
public void Execute(
    params string[] commands
)
<ObsoleteAttribute("")>
Public Sub Execute (
    ParamArray commands As String()
)

Parameters

commands
Type: SystemString
The commands to run.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.ExecuteEx Method

PMAutomationExecuteEx Method

Note: This API is now obsolete.

Runs the given command in PowerMILL. It is marked as obsolete as all commands should be available as functions in this Automation Interface.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[ObsoleteAttribute("")]
public Object ExecuteEx(
    string command
)
<ObsoleteAttribute("")>
Public Function ExecuteEx (
    command As String
) As Object

Parameters

command
Type: SystemString
The command to run in PowerMILL.

Return Value

Type: Object
The value returned by PowerMill.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.LoadMacro Method

PMAutomationLoadMacro Method

Overload List
 | Name | Description
Public method | LoadMacro(String) | Create a macro from a string.
Public method | LoadMacro(File) | Loads a macro from the specified file that can be stepped through or run with progress feedback.
Top
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.LoadMacro Method (String[])

PMAutomationLoadMacro Method (String)

Create a macro from a string.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMMacro LoadMacro(
    params string[] macro
)
Public Function LoadMacro (
    ParamArray macro As String()
) As PMMacro

Parameters

macro
Type: SystemString
macro list.

Return Value

Type: PMMacro
The new PMMacro.
See Also

Reference

PMAutomation Class
LoadMacro Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.LoadMacro Method (File)

PMAutomationLoadMacro Method (File)

Loads a macro from the specified file that can be stepped through or run with progress feedback.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMMacro LoadMacro(
    File macroFile
)
Public Function LoadMacro (
    macroFile As File
) As PMMacro

Parameters

macroFile
Type: Autodesk.FileSystemFile
The file path to the macro.

Return Value

Type: PMMacro
The new PMMacro.
See Also

Reference

PMAutomation Class
LoadMacro Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.LoadProject Method

PMAutomationLoadProject Method

Loads the project in the specified path into PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMProject LoadProject(
    Directory projectDirectory,
    bool openReadOnly = false
)
Public Function LoadProject (
    projectDirectory As Directory,
    Optional openReadOnly As Boolean = false
) As PMProject

Parameters

projectDirectory
Type: Autodesk.FileSystemDirectory
The project directory path for the PowerMILL project.
openReadOnly (Optional)
Type: SystemBoolean
If true it will open as read only.

Return Value

Type: PMProject
The loaded project.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.Quit Method

PMAutomationQuit Method

Closes the instance of the PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Quit()
Public Overrides Sub Quit
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.RecordMacro Method

PMAutomationRecordMacro Method

Starts recording a macro.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RecordMacro(
    string macroFilename
)
Public Overrides Sub RecordMacro (
    macroFilename As String
)

Parameters

macroFilename
Type: SystemString
The file path to which save the macro.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.RefreshOff Method

PMAutomationRefreshOff Method

Turns graphics updates off.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RefreshOff()
Public Sub RefreshOff
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.RefreshOn Method

PMAutomationRefreshOn Method

Turns graphics updates on.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RefreshOn()
Public Sub RefreshOn
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.Reset Method

PMAutomationReset Method

Closes the open project and resets PowerMILL back to an empty initial state.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMProject Reset()
Public Function Reset As PMProject

Return Value

Type: PMProject
Remarks
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.RunMacro Method

PMAutomationRunMacro Method

Overload List
 | Name | Description
Public method | RunMacro(String) | Runs the Macro at the given location.
Public method | RunMacro(File) | Runs the Macro at the given location.
Public method | RunMacro(PMMacro) | Runs the specified Macro.
Top
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.RunMacro Method (String[])

PMAutomationRunMacro Method (String)

Runs the Macro at the given location.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RunMacro(
    params string[] macro
)
Public Sub RunMacro (
    ParamArray macro As String()
)

Parameters

macro
Type: SystemString
The mocro lines.
See Also

Reference

PMAutomation Class
RunMacro Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.RunMacro Method (File)

PMAutomationRunMacro Method (File)

Runs the Macro at the given location.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RunMacro(
    File macroFile
)
Public Sub RunMacro (
    macroFile As File
)

Parameters

macroFile
Type: Autodesk.FileSystemFile
The file path to the macro.
See Also

Reference

PMAutomation Class
RunMacro Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.RunMacro Method (PMMacro)

PMAutomationRunMacro Method (PMMacro)

Runs the specified Macro.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RunMacro(
    PMMacro macro
)
Public Sub RunMacro (
    macro As PMMacro
)

Parameters

macro
Type: Autodesk.ProductInterface.PowerMILLPMMacro
The macro to be run
See Also

Reference

PMAutomation Class
RunMacro Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.SetActivePlane Method

PMAutomationSetActivePlane Method

Sets the active plane in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetActivePlane(
    Planes desiredPlane
)
Public Sub SetActivePlane (
    desiredPlane As Planes
)

Parameters

desiredPlane
Type: AutodeskPlanes
Plane to activate.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.SetViewAngle Method

PMAutomationSetViewAngle Method

Sets the view angle of the current project based on the Active Workplane.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void SetViewAngle(
    ViewAngles viewAngle
)
Public Overrides Sub SetViewAngle (
    viewAngle As ViewAngles
)

Parameters

viewAngle
Type: AutodeskViewAngles
The view orientation to set in PowerMill.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.StopMacroRecording Method

PMAutomationStopMacroRecording Method

Stops recording macro.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void StopMacroRecording()
Public Overrides Sub StopMacroRecording
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation.UseExistingInstance Method

PMAutomationUseExistingInstance Method

Attempts to connect to an existing version of PowerMILL or create a new one if no version has been passed.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override void UseExistingInstance(
    Version version,
    Version maximumVersion
)
Protected Overrides Sub UseExistingInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
The PowerMill version to start.
maximumVersion
Type: SystemVersion
If filled, it will ensure that the PowerMill version to run will be below maximumVersion.
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMAutomation Fields

The PMAutomation type exposes the following members.

Fields
 | Name | Description
Protected field | _instanceReuse | Indicates whether a new instance of the application should be launched or an existing one be used. (Inherited from Automation.)
Protected field | _isGUIVisible | If True, the GUI is shown; false otherwise. (Inherited from Automation.)
Protected field | _processId | Application process id. (Inherited from Automation.)
Protected field | _version | Specifies the application version to use. (Inherited from Automation.)
Top
See Also

Reference

PMAutomation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundariesCollection Class

Represents a collection of Boundary objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMBoundary
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundariesCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundariesCollection : PMEntitiesCollection<PMBoundary>
Public Class PMBoundariesCollection
    Inherits PMEntitiesCollection(Of PMBoundary)

The PMBoundariesCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateBoundary | Imports a file as a Boundary into PowerMill and adds it to the boundaries collection.
Public method | CreateEmptyBoundary | Creates an empty Boundary in PowerMill and adds it to the boundaries collection.
Public method | CreateSilhouetteBoundary | Creates a Silhouette Boundary in PowerMill.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundariesCollection Properties

The PMBoundariesCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMBoundariesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundariesCollection Methods

The PMBoundariesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateBoundary | Imports a file as a Boundary into PowerMill and adds it to the boundaries collection.
Public method | CreateEmptyBoundary | Creates an empty Boundary in PowerMill and adds it to the boundaries collection.
Public method | CreateSilhouetteBoundary | Creates a Silhouette Boundary in PowerMill.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMBoundariesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundariesCollection.CreateBoundary Method

PMBoundariesCollectionCreateBoundary Method

Imports a file as a Boundary into PowerMill and adds it to the boundaries collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMBoundary CreateBoundary(
    File file
)
Public Function CreateBoundary (
    file As File
) As PMBoundary

Parameters

file
Type: Autodesk.FileSystemFile
The file path of the boundary to import.

Return Value

Type: PMBoundary
The new PMBoundary.
See Also

Reference

PMBoundariesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundariesCollection.CreateEmptyBoundary Method

PMBoundariesCollectionCreateEmptyBoundary Method

Creates an empty Boundary in PowerMill and adds it to the boundaries collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMBoundary CreateEmptyBoundary()
Public Function CreateEmptyBoundary As PMBoundary

Return Value

Type: PMBoundary
The new PMBoundary.
See Also

Reference

PMBoundariesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundariesCollection.CreateSilhouetteBoundary Method

PMBoundariesCollectionCreateSilhouetteBoundary Method

Creates a Silhouette Boundary in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMBoundarySilhouette CreateSilhouetteBoundary(
    string partName,
    double blockExpansion,
    double partBorder,
    double boundaryTolerance
)
Public Function CreateSilhouetteBoundary (
    partName As String,
    blockExpansion As Double,
    partBorder As Double,
    boundaryTolerance As Double
) As PMBoundarySilhouette

Parameters

partName
Type: SystemString
The name of the model around which the boundary will be created.
blockExpansion
Type: SystemDouble
Offsets the minimum block size by blockExpansion. If this parameter is 0 the block used to calculate the silhouette boundary will have the minimum size to embed the part.
partBorder
Type: SystemDouble
The distance between the silhouette boundary and the part. To achieve this, internally the tool diameter used to calculate the silhouette will be partBorder * 2.
boundaryTolerance
Type: SystemDouble
The boundary tolerance.

Return Value

Type: PMBoundarySilhouette
See Also

Reference

PMBoundariesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundariesCollection Fields

The PMBoundariesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMBoundariesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary Class

Captures a Boundary object in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
More...

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PMBoundary : PMEntity
Public MustInherit Class PMBoundary
    Inherits PMEntity

The PMBoundary type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary.
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance.
Public method | ToPolylines | Converts the PMPattern to a list of Polylines.
Public method | ToSplines | Converts the PMPattern to a list of Splines.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryBlock
Autodesk.ProductInterface.PowerMILLPMBoundaryBooleanOperation
Autodesk.ProductInterface.PowerMILLPMBoundaryCollisionSafe
Autodesk.ProductInterface.PowerMILLPMBoundaryContactConversion
Autodesk.ProductInterface.PowerMILLPMBoundaryContactPoint
Autodesk.ProductInterface.PowerMILLPMBoundaryRest
Autodesk.ProductInterface.PowerMILLPMBoundarySelectedSurface
Autodesk.ProductInterface.PowerMILLPMBoundaryShallow
Autodesk.ProductInterface.PowerMILLPMBoundarySilhouette
Autodesk.ProductInterface.PowerMILLPMBoundaryStockModelRest
Autodesk.ProductInterface.PowerMILLPMBoundaryUserDefined


PMBoundary Properties

The PMBoundary type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary Methods

The PMBoundary type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary.
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance.
Public method | ToPolylines | Converts the PMPattern to a list of Polylines.
Public method | ToSplines | Converts the PMPattern to a list of Splines.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic
Top
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary.Delete Method

PMBoundaryDelete Method

Deletes boundary from PowerMill and from the active project boundaries list.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary.Flat Method

PMBoundaryFlat Method

Fatten the boundary onto the XY Plane at Z = 0.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Flat()
Public Sub Flat
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary.InsertFile Method

PMBoundaryInsertFile Method

Inserts the specified file into this Boundary.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InsertFile(
    File file
)
Public Sub InsertFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The file to insert into this Boundary.
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary.InsertToolpath Method

PMBoundaryInsertToolpath Method

Inserts the specified toolpath into this Boundary.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InsertToolpath(
    PMToolpath toolpath
)
Public Sub InsertToolpath (
    toolpath As PMToolpath
)

Parameters

toolpath
Type: Autodesk.ProductInterface.PowerMILLPMToolpath
The toolpath to insert into this Boundary.
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary.Smash Method

PMBoundarySmash Method

Polygonise a boundary to a specified tolerance.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Smash(
    double smashTolerance
)
Public Sub Smash (
    smashTolerance As Double
)

Parameters

smashTolerance
Type: SystemDouble
The tolerance used to polygonise boundary.
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary.ToPolylines Method

PMBoundaryToPolylines Method

Converts the PMPattern to a list of Polylines.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Polyline> ToPolylines()
Public Function ToPolylines As List(Of Polyline)

Return Value

Type: List Polyline
A list of Polylines
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary.ToSplines Method

PMBoundaryToSplines Method

Converts the PMPattern to a list of Splines.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Spline> ToSplines()
Public Function ToSplines As List(Of Spline)

Return Value

Type: List Spline
A list of Splines
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary.WriteToFile Method

PMBoundaryWriteToFile Method

Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToFile(
    File file
)
Public Sub WriteToFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The file to write to.
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundary Fields

The PMBoundary type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundary Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryBlock Class

Represents a boundary at the extents of the block in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryBlock

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryBlock : PMBoundary
Public Class PMBoundaryBlock
    Inherits PMBoundary

The PMBoundaryBlock type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryBlock Properties

The PMBoundaryBlock type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryBlock Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryBlock Methods

The PMBoundaryBlock type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryBlock Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryBlock Fields

The PMBoundaryBlock type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryBlock Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryBooleanOperation Class

Represents a boundary created using a boolean operation in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryBooleanOperation

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryBooleanOperation : PMBoundary
Public Class PMBoundaryBooleanOperation
    Inherits PMBoundary

The PMBoundaryBooleanOperation type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryBooleanOperation Properties

The PMBoundaryBooleanOperation type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryBooleanOperation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryBooleanOperation Methods

The PMBoundaryBooleanOperation type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryBooleanOperation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryBooleanOperation Fields

The PMBoundaryBooleanOperation type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryBooleanOperation Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryCollisionSafe Class

Represents a boundary that is collision safe in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryCollisionSafe

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryCollisionSafe : PMBoundary
Public Class PMBoundaryCollisionSafe
    Inherits PMBoundary

The PMBoundaryCollisionSafe type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryCollisionSafe Properties

The PMBoundaryCollisionSafe type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryCollisionSafe Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryCollisionSafe Methods

The PMBoundaryCollisionSafe type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryCollisionSafe Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryCollisionSafe Fields

The PMBoundaryCollisionSafe type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryCollisionSafe Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryContactConversion Class

Represents a contact conversion boundary in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryContactConversion

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryContactConversion : PMBoundary
Public Class PMBoundaryContactConversion
    Inherits PMBoundary

The PMBoundaryContactConversion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryContactConversion Properties

The PMBoundaryContactConversion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryContactConversion Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryContactConversion Methods

The PMBoundaryContactConversion type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryContactConversion Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryContactConversion Fields

The PMBoundaryContactConversion type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryContactConversion Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryContactPoint Class

Represents a contact point boundary in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryContactPoint

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryContactPoint : PMBoundary
Public Class PMBoundaryContactPoint
    Inherits PMBoundary

The PMBoundaryContactPoint type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryContactPoint Properties

The PMBoundaryContactPoint type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryContactPoint Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryContactPoint Methods

The PMBoundaryContactPoint type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryContactPoint Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryContactPoint Fields

The PMBoundaryContactPoint type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryContactPoint Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryRest Class

Represents a rest boundary in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryRest

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryRest : PMBoundary
Public Class PMBoundaryRest
    Inherits PMBoundary

The PMBoundaryRest type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryRest Properties

The PMBoundaryRest type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryRest Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryRest Methods

The PMBoundaryRest type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryRest Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryRest Fields

The PMBoundaryRest type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryRest Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundarySelectedSurface Class

Represents a selected surface boundary in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundarySelectedSurface

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundarySelectedSurface : PMBoundary
Public Class PMBoundarySelectedSurface
    Inherits PMBoundary

The PMBoundarySelectedSurface type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundarySelectedSurface Properties

The PMBoundarySelectedSurface type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundarySelectedSurface Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundarySelectedSurface Methods

The PMBoundarySelectedSurface type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundarySelectedSurface Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundarySelectedSurface Fields

The PMBoundarySelectedSurface type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundarySelectedSurface Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryShallow Class

Represents a shallow boundary in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryShallow

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryShallow : PMBoundary
Public Class PMBoundaryShallow
    Inherits PMBoundary

The PMBoundaryShallow type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryShallow Properties

The PMBoundaryShallow type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryShallow Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryShallow Methods

The PMBoundaryShallow type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryShallow Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryShallow Fields

The PMBoundaryShallow type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryShallow Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundarySilhouette Class

Represents a silhouette boundary in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundarySilhouette

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundarySilhouette : PMBoundary
Public Class PMBoundarySilhouette
    Inherits PMBoundary

The PMBoundarySilhouette type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundarySilhouette Properties

The PMBoundarySilhouette type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundarySilhouette Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundarySilhouette Methods

The PMBoundarySilhouette type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundarySilhouette Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundarySilhouette Fields

The PMBoundarySilhouette type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundarySilhouette Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryStockModelRest Class

Represents a stock model rest boundary in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryStockModelRest

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryStockModelRest : PMBoundary
Public Class PMBoundaryStockModelRest
    Inherits PMBoundary

The PMBoundaryStockModelRest type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryStockModelRest Properties

The PMBoundaryStockModelRest type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryStockModelRest Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryStockModelRest Methods

The PMBoundaryStockModelRest type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryStockModelRest Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryStockModelRest Fields

The PMBoundaryStockModelRest type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryStockModelRest Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryUserDefined Class

Represents a user defined boundary in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMBoundaryUserDefined

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMBoundaryUserDefined : PMBoundary
Public Class PMBoundaryUserDefined
    Inherits PMBoundary

The PMBoundaryUserDefined type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryUserDefined Properties

The PMBoundaryUserDefined type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryUserDefined Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryUserDefined Methods

The PMBoundaryUserDefined type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes boundary from PowerMill and from the active project boundaries list. (Inherited from PMBoundary.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flat | Fatten the boundary onto the XY Plane at Z = 0. (Inherited from PMBoundary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Boundary. (Inherited from PMBoundary.)
Public method | InsertToolpath | Inserts the specified toolpath into this Boundary. (Inherited from PMBoundary.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Smash | Polygonise a boundary to a specified tolerance. (Inherited from PMBoundary.)
Public method | ToPolylines | Converts the PMPattern to a list of Polylines. (Inherited from PMBoundary.)
Public method | ToSplines | Converts the PMPattern to a list of Splines. (Inherited from PMBoundary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Boundary to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic (Inherited from PMBoundary.)
Top
See Also

Reference

PMBoundaryUserDefined Class
Autodesk.ProductInterface.PowerMILL Namespace


PMBoundaryUserDefined Fields

The PMBoundaryUserDefined type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMBoundaryUserDefined Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T) Class

PMCollectionT Class

Base class for all PowerMill Product Interface collections which items are not PMEntities. It controls the addition of items to PowerMill collections.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollectionT
Autodesk.ProductInterface.PowerMILLPMEntitiesCollectionT
Autodesk.ProductInterface.PowerMILLPMSubstitutionTokensCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMCollection<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Public Class PMCollection(Of T)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable

Type Parameters

T

The PMCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | IsReadOnly | PSCollection is not readonly.
Public property | Item | Gets and sets the desired indexed item.
Top
Methods
 | Name | Description
Public method | Add | Adds a new item to the List.
Public method | Clear | Removes all entities in the list.
Public method | Contains | Determines whether the indicated item is contained within the collection.
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items.
Public method | IndexOf | Index of item in the list.
Public method | Insert | Inserts the specified item into the desired position within the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified item.
Public method | RemoveAt | Removes the item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T) Properties

PMCollectionT Properties

The PMCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | IsReadOnly | PSCollection is not readonly.
Public property | Item | Gets and sets the desired indexed item.
Top
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).Count Property

PMCollectionTCount Property

Gets the number of items in the collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).IsReadOnly Property

PMCollectionTIsReadOnly Property

PSCollection is not readonly.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).Item Property

PMCollectionTItem Property

Gets and sets the desired indexed item.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual T this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As T
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the desired item.

Property Value

Type: T
The desired item.

Return Value

Type: T
The desired item.

Implements

IListTItemInt32
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T) Methods

PMCollectionT Methods

The PMCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new item to the List.
Public method | Clear | Removes all entities in the list.
Public method | Contains | Determines whether the indicated item is contained within the collection.
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items.
Public method | IndexOf | Index of item in the list.
Public method | Insert | Inserts the specified item into the desired position within the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified item.
Public method | RemoveAt | Removes the item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).Add Method

PMCollectionTAdd Method

Adds a new item to the List.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void Add(
    T item
)
Public Overridable Sub Add (
    item As T
)

Parameters

item
Type: T
The item to add.

Implements

ICollectionTAdd(T)
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).Clear Method

PMCollectionTClear Method

Removes all entities in the list.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void Clear()
Public Overridable Sub Clear

Implements

ICollectionTClear
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).Contains Method

PMCollectionTContains Method

Determines whether the indicated item is contained within the collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean

Parameters

item
Type: T
The item to check for.

Return Value

Type: Boolean
A boolean indicating the item's presence in the collection.

Implements

ICollectionTContains(T)
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).CopyTo Method

PMCollectionTCopyTo Method

Copies the contents of the collection to the specified list, starting at the specified index.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)

Parameters

array
Type: T
The destination of the elements copied.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).GetEnumerator Method

PMCollectionTGetEnumerator Method

Returns an enumerator of items.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).IEnumerable_GetEnumerator Method

PMCollectionTIEnumerable_GetEnumerator Method

Returns an enumerator of items.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public IEnumerator<T> IEnumerable_GetEnumerator()
Public Function IEnumerable_GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumerator T
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).IndexOf Method

PMCollectionTIndexOf Method

Index of item in the list.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    T item
)
Public Overridable Function IndexOf (
    item As T
) As Integer

Parameters

item
Type: T
The item to get the index from.

Return Value

Type: Int32
The index of the item.

Implements

IListTIndexOf(T)
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).Insert Method

PMCollectionTInsert Method

Inserts the specified item into the desired position within the collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    T item
)
Public Sub Insert (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The position into which the item is to be inserted.
item
Type: T
The entity to be inserted.

Implements

IListTInsert(Int32, T)
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).Remove Method

PMCollectionTRemove Method

Removes the specified item.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual bool Remove(
    T item
)
Public Overridable Function Remove (
    item As T
) As Boolean

Parameters

item
Type: T
The item to be removed.

Return Value

Type: Boolean
A boolean indicating whether the item has been removed.

Implements

ICollectionTRemove(T)
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T).RemoveAt Method

PMCollectionTRemoveAt Method

Removes the item at the specified index.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
Remarks
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T) Fields

PMCollectionT Fields

The PMCollectionT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList.
Top
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMCollection(T)._list Field

PMCollectionT_list Field

The list used to implement the interface IList.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected List<T> _list
Protected _list As List(Of T)

Field Value

Type: List T
See Also

Reference

PMCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections Class

Home for PMLead and options that affect all leads on PMToolpath
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMConnections

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMConnections
Public Class PMConnections

The PMConnections type exposes the following members.

Properties
 | Name | Description
Public property | AddLeadsAtToolAxisDiscontinuities | Inserts leads and links between continuous segments where there is an angular change in tool axis between neighboring segments. This ensures that any reorientation of the tool axis at a specific point takes place away from the part.
Public property | AddLeadsToShortLinks | When selected, this option adds leads to short links. By default, leads are applied to all link moves. However, for reasons of efficiency and/or quality, there can be occasions where you want leads on long link moves and on the moves at the start and end of the toolpath, but don't want leads on short link moves. This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | AllowStartPointToBeMoved | When selected, this option moves the start points on closed toolpath segments to try and find a non-gouging position. When deselected, PowerMILL will not move the start points - this means that if you carefully position a start point, you can prevent PowerMILL from moving it.
Public property | AngularThreshold | Enter the minimum angle required before leads and links are inserted. The angle is the change in the tool axis between neighbouring segments.
Public property | ApproachDistance | The length of the Approach move.
Public property | ArcFitRadius | The TDU radius to control the ArcFitRapidMove.
Public property | ArcFitRapidMove | Use these options to place arcs on the corners of link moves as the tool rapids across the part. This avoids sudden changes in direction and is useful when high speed machining. Remarks When the option is deselected, rapid moves are linear and form right-angles with the link moves When the option is selected, rapid moves are curved and form arcs with the link moves. The arc radius is controlled by the ArcFitRadiusTDU
Public property | AutomaticallyExtend | Select to lengthen the retract and approach moves made within rapid links. This enables the moves to reach the surface, over which the rapid or skim moves are made. This also lengthens the initial move at the start, and the final move at the end.
Public property | DefaultLink | First choice The type of link moves to be used if ShortLink or LongLink types gouge, or in version 2017 the type of link moves from the list to be used if the constraint criteria for both the Link1st choice and Link2nd choice links are not met, or if they gouge
Public property | DefaultLinkSecond | Second choice The type of link moves to be used if ShortLink or LongLink types gouge.
Public property | FirstLeadIn | Settings to specify a First Lead In move that is different from the subsequent lead in moves.
Public property | GougeCheck | Select this option for Powermill to gouge-check all leads and links.
Public property | LastLeadOut | Settings to specify a Last Lead Out move that is different from the previous lead out moves.
Public property | LeadIn | Lead in first choice, Settings to control the tool's movement as it approaches the stock, before beginning a cutting move.
Public property | LeadInExtension | These options add an additional Lead In before the existing one.
Public property | LeadInSecond | Lead in second choice, Settings to control the tool's movement as it approaches the stock, before beginning a cutting move.
Public property | LeadOut | Lead out first choice, Settings to control the tool's movement after it leaves the stock, at the end of a cutting move.
Public property | LeadOutExtension | These options add an additional Lead Out after the existing one.
Public property | LeadOutSecond | Lead out second choice, Settings to control the tool's movement after it leaves the stock, at the end of a cutting move.
Public property | Link1st | First choice the type of link moves to connect consecutive cutting passes for your first choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | Link2nd | Second choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | Link3rd | Third choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | Link4th | Forth choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | Link5th | Fifth choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | LongLink | First choice The type of link moves to connect consecutive cutting passes for links longer than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | LongLinkSecond | Second choice The type of link moves to connect consecutive cutting passes for links longer than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | MaxMoveExtension | The maximum length of the extension.
Public property | OverlapDistance | Enter the distance by which a Lead in or Lead out can overlap a closed toolpath segment.
Public property | RetractAndApproachMoves | The length and orientation of the link moves.
Public property | RetractDistance | The length of the Retract move.
Public property | ShortLink | First choice The type of link moves to connect consecutive cutting passes for links shorter than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | ShortLinkSecond | Second choice The type of link moves to connect consecutive cutting passes for links shorter than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | ShortLinkToLongLinkThreshold | The distance at which a short link becomes a long link.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMConnections Properties

The PMConnections type exposes the following members.

Properties
 | Name | Description
Public property | AddLeadsAtToolAxisDiscontinuities | Inserts leads and links between continuous segments where there is an angular change in tool axis between neighboring segments. This ensures that any reorientation of the tool axis at a specific point takes place away from the part.
Public property | AddLeadsToShortLinks | When selected, this option adds leads to short links. By default, leads are applied to all link moves. However, for reasons of efficiency and/or quality, there can be occasions where you want leads on long link moves and on the moves at the start and end of the toolpath, but don't want leads on short link moves. This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | AllowStartPointToBeMoved | When selected, this option moves the start points on closed toolpath segments to try and find a non-gouging position. When deselected, PowerMILL will not move the start points - this means that if you carefully position a start point, you can prevent PowerMILL from moving it.
Public property | AngularThreshold | Enter the minimum angle required before leads and links are inserted. The angle is the change in the tool axis between neighbouring segments.
Public property | ApproachDistance | The length of the Approach move.
Public property | ArcFitRadius | The TDU radius to control the ArcFitRapidMove.
Public property | ArcFitRapidMove | Use these options to place arcs on the corners of link moves as the tool rapids across the part. This avoids sudden changes in direction and is useful when high speed machining. Remarks When the option is deselected, rapid moves are linear and form right-angles with the link moves When the option is selected, rapid moves are curved and form arcs with the link moves. The arc radius is controlled by the ArcFitRadiusTDU
Public property | AutomaticallyExtend | Select to lengthen the retract and approach moves made within rapid links. This enables the moves to reach the surface, over which the rapid or skim moves are made. This also lengthens the initial move at the start, and the final move at the end.
Public property | DefaultLink | First choice The type of link moves to be used if ShortLink or LongLink types gouge, or in version 2017 the type of link moves from the list to be used if the constraint criteria for both the Link1st choice and Link2nd choice links are not met, or if they gouge
Public property | DefaultLinkSecond | Second choice The type of link moves to be used if ShortLink or LongLink types gouge.
Public property | FirstLeadIn | Settings to specify a First Lead In move that is different from the subsequent lead in moves.
Public property | GougeCheck | Select this option for Powermill to gouge-check all leads and links.
Public property | LastLeadOut | Settings to specify a Last Lead Out move that is different from the previous lead out moves.
Public property | LeadIn | Lead in first choice, Settings to control the tool's movement as it approaches the stock, before beginning a cutting move.
Public property | LeadInExtension | These options add an additional Lead In before the existing one.
Public property | LeadInSecond | Lead in second choice, Settings to control the tool's movement as it approaches the stock, before beginning a cutting move.
Public property | LeadOut | Lead out first choice, Settings to control the tool's movement after it leaves the stock, at the end of a cutting move.
Public property | LeadOutExtension | These options add an additional Lead Out after the existing one.
Public property | LeadOutSecond | Lead out second choice, Settings to control the tool's movement after it leaves the stock, at the end of a cutting move.
Public property | Link1st | First choice the type of link moves to connect consecutive cutting passes for your first choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | Link2nd | Second choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | Link3rd | Third choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | Link4th | Forth choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | Link5th | Fifth choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception
Public property | LongLink | First choice The type of link moves to connect consecutive cutting passes for links longer than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | LongLinkSecond | Second choice The type of link moves to connect consecutive cutting passes for links longer than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | MaxMoveExtension | The maximum length of the extension.
Public property | OverlapDistance | Enter the distance by which a Lead in or Lead out can overlap a closed toolpath segment.
Public property | RetractAndApproachMoves | The length and orientation of the link moves.
Public property | RetractDistance | The length of the Retract move.
Public property | ShortLink | First choice The type of link moves to connect consecutive cutting passes for links shorter than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | ShortLinkSecond | Second choice The type of link moves to connect consecutive cutting passes for links shorter than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown
Public property | ShortLinkToLongLinkThreshold | The distance at which a short link becomes a long link.
Top
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.AddLeadsAtToolAxisDiscontinuities Property

PMConnectionsAddLeadsAtToolAxisDiscontinuities Property

Inserts leads and links between continuous segments where there is an angular change in tool axis between neighboring segments. This ensures that any reorientation of the tool axis at a specific point takes place away from the part.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool AddLeadsAtToolAxisDiscontinuities { get; set; }
Public Property AddLeadsAtToolAxisDiscontinuities As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.AddLeadsToShortLinks Property

PMConnectionsAddLeadsToShortLinks Property

When selected, this option adds leads to short links. By default, leads are applied to all link moves. However, for reasons of efficiency and/or quality, there can be occasions where you want leads on long link moves and on the moves at the start and end of the toolpath, but don't want leads on short link moves. This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool AddLeadsToShortLinks { get; set; }
Public Property AddLeadsToShortLinks As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.AllowStartPointToBeMoved Property

PMConnectionsAllowStartPointToBeMoved Property

When selected, this option moves the start points on closed toolpath segments to try and find a non-gouging position. When deselected, PowerMILL will not move the start points - this means that if you carefully position a start point, you can prevent PowerMILL from moving it.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool AllowStartPointToBeMoved { get; set; }
Public Property AllowStartPointToBeMoved As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.AngularThreshold Property

PMConnectionsAngularThreshold Property

Enter the minimum angle required before leads and links are inserted. The angle is the change in the tool axis between neighbouring segments.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree AngularThreshold { get; set; }
Public Property AngularThreshold As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.ApproachDistance Property

PMConnectionsApproachDistance Property

The length of the Approach move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ApproachDistance { get; set; }
Public Property ApproachDistance As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.ArcFitRadius Property

PMConnectionsArcFitRadius Property

The TDU radius to control the ArcFitRapidMove.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree ArcFitRadius { get; set; }
Public Property ArcFitRadius As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.ArcFitRapidMove Property

PMConnectionsArcFitRapidMove Property

Use these options to place arcs on the corners of link moves as the tool rapids across the part. This avoids sudden changes in direction and is useful when high speed machining.
Remarks
When the option is deselected, rapid moves are linear and form right-angles with the link moves When the option is selected, rapid moves are curved and form arcs with the link moves. The arc radius is controlled by the ArcFitRadiusTDU

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool ArcFitRapidMove { get; set; }
Public Property ArcFitRapidMove As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.AutomaticallyExtend Property

PMConnectionsAutomaticallyExtend Property

Select to lengthen the retract and approach moves made within rapid links. This enables the moves to reach the surface, over which the rapid or skim moves are made. This also lengthens the initial move at the start, and the final move at the end.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool AutomaticallyExtend { get; set; }
Public Property AutomaticallyExtend As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.DefaultLink Property

PMConnectionsDefaultLink Property

First choice The type of link moves to be used if ShortLink or LongLink types gouge, or in version 2017 the type of link moves from the list to be used if the constraint criteria for both the Link1st choice and Link2nd choice links are not met, or if they gouge

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DefaultLinkTypes DefaultLink { get; set; }
Public Property DefaultLink As DefaultLinkTypes
    Get
    Set

Property Value

Type: DefaultLinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.DefaultLinkSecond Property

PMConnectionsDefaultLinkSecond Property

Second choice The type of link moves to be used if ShortLink or LongLink types gouge.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DefaultLinkTypes DefaultLinkSecond { get; set; }
Public Property DefaultLinkSecond As DefaultLinkTypes
    Get
    Set

Property Value

Type: DefaultLinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.FirstLeadIn Property

PMConnectionsFirstLeadIn Property

Settings to specify a First Lead In move that is different from the subsequent lead in moves.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLead FirstLeadIn { get; }
Public ReadOnly Property FirstLeadIn As PMLead
    Get

Property Value

Type: PMLead
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.GougeCheck Property

PMConnectionsGougeCheck Property

Select this option for Powermill to gouge-check all leads and links.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool GougeCheck { get; set; }
Public Property GougeCheck As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LastLeadOut Property

PMConnectionsLastLeadOut Property

Settings to specify a Last Lead Out move that is different from the previous lead out moves.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLead LastLeadOut { get; }
Public ReadOnly Property LastLeadOut As PMLead
    Get

Property Value

Type: PMLead
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LeadIn Property

PMConnectionsLeadIn Property

Lead in first choice, Settings to control the tool's movement as it approaches the stock, before beginning a cutting move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLead LeadIn { get; }
Public ReadOnly Property LeadIn As PMLead
    Get

Property Value

Type: PMLead
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LeadInExtension Property

PMConnectionsLeadInExtension Property

These options add an additional Lead In before the existing one.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLeadExtension LeadInExtension { get; }
Public ReadOnly Property LeadInExtension As PMLeadExtension
    Get

Property Value

Type: PMLeadExtension
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LeadInSecond Property

PMConnectionsLeadInSecond Property

Lead in second choice, Settings to control the tool's movement as it approaches the stock, before beginning a cutting move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLead LeadInSecond { get; }
Public ReadOnly Property LeadInSecond As PMLead
    Get

Property Value

Type: PMLead
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LeadOut Property

PMConnectionsLeadOut Property

Lead out first choice, Settings to control the tool's movement after it leaves the stock, at the end of a cutting move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLead LeadOut { get; }
Public ReadOnly Property LeadOut As PMLead
    Get

Property Value

Type: PMLead
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LeadOutExtension Property

PMConnectionsLeadOutExtension Property

These options add an additional Lead Out after the existing one.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLeadExtension LeadOutExtension { get; }
Public ReadOnly Property LeadOutExtension As PMLeadExtension
    Get

Property Value

Type: PMLeadExtension
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LeadOutSecond Property

PMConnectionsLeadOutSecond Property

Lead out second choice, Settings to control the tool's movement after it leaves the stock, at the end of a cutting move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLead LeadOutSecond { get; }
Public ReadOnly Property LeadOutSecond As PMLead
    Get

Property Value

Type: PMLead
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.Link1st Property

PMConnectionsLink1st Property

First choice the type of link moves to connect consecutive cutting passes for your first choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public LinkTypes Link1st { get; set; }
Public Property Link1st As LinkTypes
    Get
    Set

Property Value

Type: LinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.Link2nd Property

PMConnectionsLink2nd Property

Second choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public LinkTypes Link2nd { get; set; }
Public Property Link2nd As LinkTypes
    Get
    Set

Property Value

Type: LinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.Link3rd Property

PMConnectionsLink3rd Property

Third choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public LinkTypes Link3rd { get; set; }
Public Property Link3rd As LinkTypes
    Get
    Set

Property Value

Type: LinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.Link4th Property

PMConnectionsLink4th Property

Forth choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public LinkTypes Link4th { get; set; }
Public Property Link4th As LinkTypes
    Get
    Set

Property Value

Type: LinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.Link5th Property

PMConnectionsLink5th Property

Fifth choice The type of link moves to connect consecutive cutting passes for your second choice. PowerMill applies this link where its constraint criteria are met. This feature minimum version is PowerMill 2017 This feature become available on PowerMILL 2017, therefore older versions will throw exception

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public LinkTypes Link5th { get; set; }
Public Property Link5th As LinkTypes
    Get
    Set

Property Value

Type: LinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LongLink Property

PMConnectionsLongLink Property

First choice The type of link moves to connect consecutive cutting passes for links longer than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DefaultLinkTypes LongLink { get; set; }
Public Property LongLink As DefaultLinkTypes
    Get
    Set

Property Value

Type: DefaultLinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.LongLinkSecond Property

PMConnectionsLongLinkSecond Property

Second choice The type of link moves to connect consecutive cutting passes for links longer than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DefaultLinkTypes LongLinkSecond { get; set; }
Public Property LongLinkSecond As DefaultLinkTypes
    Get
    Set

Property Value

Type: DefaultLinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.MaxMoveExtension Property

PMConnectionsMaxMoveExtension Property

The maximum length of the extension.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM MaxMoveExtension { get; set; }
Public Property MaxMoveExtension As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.OverlapDistance Property

PMConnectionsOverlapDistance Property

Enter the distance by which a Lead in or Lead out can overlap a closed toolpath segment.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM OverlapDistance { get; set; }
Public Property OverlapDistance As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.RetractAndApproachMoves Property

PMConnectionsRetractAndApproachMoves Property

The length and orientation of the link moves.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MoveDirection RetractAndApproachMoves { get; set; }
Public Property RetractAndApproachMoves As MoveDirection
    Get
    Set

Property Value

Type: MoveDirection
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.RetractDistance Property

PMConnectionsRetractDistance Property

The length of the Retract move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM RetractDistance { get; set; }
Public Property RetractDistance As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.ShortLink Property

PMConnectionsShortLink Property

First choice The type of link moves to connect consecutive cutting passes for links shorter than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public LinkTypes ShortLink { get; set; }
Public Property ShortLink As LinkTypes
    Get
    Set

Property Value

Type: LinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.ShortLinkSecond Property

PMConnectionsShortLinkSecond Property

Second choice The type of link moves to connect consecutive cutting passes for links shorter than the Short/Long threshold value. This feature maximum version is PowerMill 2016 This feature available on PowerMILL 2016 and lower versions, otherwise exception will be thrown

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public LinkTypes ShortLinkSecond { get; set; }
Public Property ShortLinkSecond As LinkTypes
    Get
    Set

Property Value

Type: LinkTypes
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections.ShortLinkToLongLinkThreshold Property

PMConnectionsShortLinkToLongLinkThreshold Property

The distance at which a short link becomes a long link.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ShortLinkToLongLinkThreshold { get; set; }
Public Property ShortLinkToLongLinkThreshold As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMConnections Methods

The PMConnections type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMConnections Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T) Class

PMEntitiesCollectionT Class

Represents the base class for all collection classes for PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection T
Autodesk.ProductInterface.PowerMILLPMEntitiesCollectionT
More...

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PMEntitiesCollection<T> : PMCollection<T>
where T : PMEntity

Public MustInherit Class PMEntitiesCollection(Of T As PMEntity)
    Inherits PMCollection(Of T)

Type Parameters

T
The type of elements in the list.

The PMEntitiesCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem |
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Overrides PMCollectionTAdd(T).)
Public method | Clear | Removes all entities in the list and in PowerMill. (Overrides PMCollectionTClear.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill.
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true.
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Overrides PMCollectionTRemoveAt(Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection T
Autodesk.ProductInterface.PowerMILLPMEntitiesCollectionT
Autodesk.ProductInterface.PowerMILLPMBoundariesCollection
Autodesk.ProductInterface.PowerMILLPMFeatureSetsCollection
Autodesk.ProductInterface.PowerMILLPMGroupsCollection
Autodesk.ProductInterface.PowerMILLPMLevelOrSetsCollection
Autodesk.ProductInterface.PowerMILLPMMachineToolsCollection
Autodesk.ProductInterface.PowerMILLPMModelsCollection
Autodesk.ProductInterface.PowerMILLPMNCProgramsCollection
Autodesk.ProductInterface.PowerMILLPMPatternsCollection
Autodesk.ProductInterface.PowerMILLPMStockModelsCollection
Autodesk.ProductInterface.PowerMILLPMToolpathsCollection
Autodesk.ProductInterface.PowerMILLPMToolsCollection
Autodesk.ProductInterface.PowerMILLPMWorkplanesCollection


PMEntitiesCollection(T) Properties

PMEntitiesCollectionT Properties

The PMEntitiesCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem |
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.
Top
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).ActiveItem Property

PMEntitiesCollectionTActiveItem Property

[Missing <summary> documentation for "P:Autodesk.ProductInterface.PowerMILL.PMEntitiesCollection`1.ActiveItem"]

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T ActiveItem { get; }
Public ReadOnly Property ActiveItem As T
    Get

Property Value

Type: T
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).Item Property

PMEntitiesCollectionTItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.
Top
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).Item Property (String)

PMEntitiesCollectionTItem Property (String)

Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As T
    Get

Parameters

name
Type: SystemString

Property Value

Type: T
See Also

Reference

PMEntitiesCollectionT Class
Item Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T) Methods

PMEntitiesCollectionT Methods

The PMEntitiesCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Overrides PMCollectionTAdd(T).)
Public method | Clear | Removes all entities in the list and in PowerMill. (Overrides PMCollectionTClear.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill.
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true.
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Overrides PMCollectionTRemoveAt(Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).Add Method

PMEntitiesCollectionTAdd Method

Adds a new Entity to the List.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Add(
    T entity
)
Public Overrides Sub Add (
    entity As T
)

Parameters

entity
Type: T

[Missing <param name="entity"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMEntitiesCollection`1.Add(`0)"]

Implements

ICollectionTAdd(T)
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).Clear Method

PMEntitiesCollectionTClear Method

Removes all entities in the list and in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Clear()
Public Overrides Sub Clear

Implements

ICollectionTClear
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).GetByName Method

PMEntitiesCollectionTGetByName Method

Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T GetByName(
    string name
)
Public Function GetByName (
    name As String
) As T

Parameters

name
Type: SystemString
The name of the entity.

Return Value

Type: T
It may return Nothing if entity is not found.
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).LastItem Method

PMEntitiesCollectionTLastItem Method

Gets the last entity in the List.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T LastItem()
Public Function LastItem As T

Return Value

Type: T
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).Remove Method

PMEntitiesCollectionTRemove Method

Overload List
 | Name | Description
Public method | Remove(T) | Removes the specified item from the list and from PowerMill.
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true.
Top
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).Remove Method (T)

PMEntitiesCollectionTRemove Method (T)

Removes the specified item from the list and from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Remove(
    T entity
)
Public Function Remove (
    entity As T
) As Boolean

Parameters

entity
Type: T
The entity to remove.

Return Value

Type: Boolean
True if item is successfully removed; otherwise, false. This method also returns false if item was not found in the System.Collections.Generic.List(Of T).
See Also

Reference

PMEntitiesCollectionT Class
Remove Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).Remove Method (T, Boolean)

PMEntitiesCollectionTRemove Method (T, Boolean)

Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Remove(
    T entity,
    bool useNoQuibble
)
Public Function Remove (
    entity As T,
    useNoQuibble As Boolean
) As Boolean

Parameters

entity
Type: T
The entity to remove
useNoQuibble
Type: SystemBoolean
The 'NOQUIBBLE' option is applied if set to true

Return Value

Type: Boolean
See Also

Reference

PMEntitiesCollectionT Class
Remove Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T).RemoveAt Method

PMEntitiesCollectionTRemoveAt Method

Removes the entity at the specified index on the list and it also removes it from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RemoveAt(
    int index
)
Public Overrides Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T) Fields

PMEntitiesCollectionT Fields

The PMEntitiesCollectionT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object
Top
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntitiesCollection(T)._powerMILL Field

PMEntitiesCollectionT_powerMILL Field

PowerMILL Automation object

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMAutomation _powerMILL
Protected _powerMILL As PMAutomation

Field Value

Type: PMAutomation
See Also

Reference

PMEntitiesCollectionT Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity Class

Abstract base class that represents an item in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
More...

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PMEntity
Public MustInherit Class PMEntity

The PMEntity type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity
Public property | Exists | Gets whether or not the entity exists in PowerMILL
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill.
Public property | Version | Version of current Power mill.
Top
Methods
 | Name | Description
Public method | Delete | Deletes an entity.
Public method | Duplicate | Duplicates an entity. It also updates PowerMill.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
 | POWER_MILL_2016 | Powermill 2016 version
 | POWER_MILL_2017 | Powermill 2017 version
Protected field | PowerMill | The PowerMill Automation object.
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMBoundary
Autodesk.ProductInterface.PowerMILLPMFeatureSet
Autodesk.ProductInterface.PowerMILLPMGroup
Autodesk.ProductInterface.PowerMILLPMLevelOrSet
Autodesk.ProductInterface.PowerMILLPMMachineTool
Autodesk.ProductInterface.PowerMILLPMModel
Autodesk.ProductInterface.PowerMILLPMNCProgram
Autodesk.ProductInterface.PowerMILLPMPattern
Autodesk.ProductInterface.PowerMILLPMStockModel
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMWorkplane


PMEntity Properties

The PMEntity type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity
Public property | Exists | Gets whether or not the entity exists in PowerMILL
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill.
Public property | Version | Version of current Power mill.
Top
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.BoundingBox Property

PMEntityBoundingBox Property

Get the bounding box of the entity

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual BoundingBox BoundingBox { get; }
Public Overridable ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.Exists Property

PMEntityExists Property

Gets whether or not the entity exists in PowerMILL

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get

Return Value

Type: Boolean
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.IsActive Property

PMEntityIsActive Property

Gets and sets whether the entity is active. It also updates PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual bool IsActive { get; set; }
Public Overridable Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.Name Property

PMEntityName Property

Gets and sets the name of the entity. It also updates PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.Version Property

PMEntityVersion Property

Version of current Power mill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get

Property Value

Type: Version
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity Methods

The PMEntity type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes an entity.
Public method | Duplicate | Duplicates an entity. It also updates PowerMill.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.Delete Method

PMEntityDelete Method

Deletes an entity.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void Delete()
Public MustOverride Sub Delete
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.Duplicate Method

PMEntityDuplicate Method

Duplicates an entity. It also updates PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual PMEntity Duplicate()
Public Overridable Function Duplicate As PMEntity

Return Value

Type: PMEntity
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity Fields

The PMEntity type exposes the following members.

Fields
 | Name | Description
 | POWER_MILL_2016 | Powermill 2016 version
 | POWER_MILL_2017 | Powermill 2017 version
Protected field | PowerMill | The PowerMill Automation object.
Top
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.POWER_MILL_2016 Field

PMEntityPOWER_MILL_2016 Field

Powermill 2016 version

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static readonly Version POWER_MILL_2016
Public Shared ReadOnly POWER_MILL_2016 As Version

Field Value

Type: Version
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.POWER_MILL_2017 Field

PMEntityPOWER_MILL_2017 Field

Powermill 2017 version

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static readonly Version POWER_MILL_2017
Public Shared ReadOnly POWER_MILL_2017 As Version

Field Value

Type: Version
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMEntity.PowerMill Field

PMEntityPowerMill Field

The PowerMill Automation object.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMAutomation PowerMill
Protected PowerMill As PMAutomation

Field Value

Type: PMAutomation
See Also

Reference

PMEntity Class
Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSet Class

Captures a FeatureSet object in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMFeatureSet

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMFeatureSet : PMEntity
Public Class PMFeatureSet
    Inherits PMEntity

The PMFeatureSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes FeatureSet. It also updates PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSet Properties

The PMFeatureSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMFeatureSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSet Methods

The PMFeatureSet type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes FeatureSet. It also updates PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMFeatureSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSet.Delete Method

PMFeatureSetDelete Method

Deletes FeatureSet. It also updates PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PMFeatureSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSet Fields

The PMFeatureSet type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMFeatureSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSetsCollection Class

Represents the collection of FeatureSet objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMFeatureSet
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMFeatureSet
Autodesk.ProductInterface.PowerMILLPMFeatureSetsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMFeatureSetsCollection : PMEntitiesCollection<PMFeatureSet>
Public Class PMFeatureSetsCollection
    Inherits PMEntitiesCollection(Of PMFeatureSet)

The PMFeatureSetsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSetsCollection Properties

The PMFeatureSetsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMFeatureSetsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSetsCollection Methods

The PMFeatureSetsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMFeatureSetsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMFeatureSetsCollection Fields

The PMFeatureSetsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMFeatureSetsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMGroup Class

Captures a Group object in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMGroup

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMGroup : PMEntity
Public Class PMGroup
    Inherits PMEntity

The PMGroup type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type (Overrides PMEntityBoundingBox.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes Group from active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMGroup Properties

The PMGroup type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type (Overrides PMEntityBoundingBox.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMGroup Class
Autodesk.ProductInterface.PowerMILL Namespace


PMGroup.BoundingBox Property

PMGroupBoundingBox Property

BoundingBox property is not valid for this type

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PMGroup Class
Autodesk.ProductInterface.PowerMILL Namespace


PMGroup Methods

The PMGroup type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes Group from active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMGroup Class
Autodesk.ProductInterface.PowerMILL Namespace


PMGroup.Delete Method

PMGroupDelete Method

Deletes Group from active project and from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Remarks
See Also

Reference

PMGroup Class
Autodesk.ProductInterface.PowerMILL Namespace


PMGroup Fields

The PMGroup type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMGroup Class
Autodesk.ProductInterface.PowerMILL Namespace


PMGroupsCollection Class

Represents the Collection of Group objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMGroup
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMGroup
Autodesk.ProductInterface.PowerMILLPMGroupsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMGroupsCollection : PMEntitiesCollection<PMGroup>
Public Class PMGroupsCollection
    Inherits PMEntitiesCollection(Of PMGroup)

The PMGroupsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMGroupsCollection Properties

The PMGroupsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMGroupsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMGroupsCollection Methods

The PMGroupsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMGroupsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMGroupsCollection Fields

The PMGroupsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMGroupsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead Class

Represent a Lead in PMToolpath.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMLead
Autodesk.ProductInterface.PowerMILLPMLeadExtension

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMLead
Public Class PMLead

The PMLead type exposes the following members.

Properties
 | Name | Description
Public property | Angle | The angle of the Lead move relative to the toolpath segment. For arcs, this is the angle spanned by the arc. For lines, it is the orientation relative to the cutting move.
Public property | Distance | The length to extend the Lead move before the cutting move starts. If this is an arc move, then the distance is the length of the linear tangential move between the arc and the cutting portion of the toolpath.
Public property | MoveType | The type of move to use after each cutting move
Public property | Radius | The radius of the Lead arc move
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPropertyFullName | PMToolpath that own this PMLead
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | LeadType | Define LeadType of this lead.
Public field | Ramp | enables you to specify how the tool ramps into the stock.
Protected field | Toolpath | PMToolpath that own this PMLead
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMLead Properties

The PMLead type exposes the following members.

Properties
 | Name | Description
Public property | Angle | The angle of the Lead move relative to the toolpath segment. For arcs, this is the angle spanned by the arc. For lines, it is the orientation relative to the cutting move.
Public property | Distance | The length to extend the Lead move before the cutting move starts. If this is an arc move, then the distance is the length of the linear tangential move between the arc and the cutting portion of the toolpath.
Public property | MoveType | The type of move to use after each cutting move
Public property | Radius | The radius of the Lead arc move
Top
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead.Angle Property

PMLeadAngle Property

The angle of the Lead move relative to the toolpath segment. For arcs, this is the angle spanned by the arc. For lines, it is the orientation relative to the cutting move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree Angle { get; set; }
Public Property Angle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead.Distance Property

PMLeadDistance Property

The length to extend the Lead move before the cutting move starts. If this is an arc move, then the distance is the length of the linear tangential move between the arc and the cutting portion of the toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Distance { get; set; }
Public Property Distance As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead.MoveType Property

PMLeadMoveType Property

The type of move to use after each cutting move

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MoveType MoveType { get; set; }
Public Property MoveType As MoveType
    Get
    Set

Property Value

Type: MoveType
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead.Radius Property

PMLeadRadius Property

The radius of the Lead arc move

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Radius { get; set; }
Public Property Radius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead Methods

The PMLead type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPropertyFullName | PMToolpath that own this PMLead
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead.GetPropertyFullName Method

PMLeadGetPropertyFullName Method

PMToolpath that own this PMLead

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected string GetPropertyFullName(
    string property
)
Protected Function GetPropertyFullName (
    property As String
) As String

Parameters

property
Type: SystemString
property name

Return Value

Type: String
Full qualified powermill parameter name/>
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead Fields

The PMLead type exposes the following members.

Fields
 | Name | Description
Public field | LeadType | Define LeadType of this lead.
Public field | Ramp | enables you to specify how the tool ramps into the stock.
Protected field | Toolpath | PMToolpath that own this PMLead
Top
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead.LeadType Field

PMLeadLeadType Field

Define LeadType of this lead.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public readonly LeadTypes LeadType
Public ReadOnly LeadType As LeadTypes

Field Value

Type: LeadTypes
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead.Ramp Field

PMLeadRamp Field

enables you to specify how the tool ramps into the stock.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public readonly PMRamp Ramp
Public ReadOnly Ramp As PMRamp

Field Value

Type: PMRamp
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLead.Toolpath Field

PMLeadToolpath Field

PMToolpath that own this PMLead

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected readonly PMToolpath Toolpath
Protected ReadOnly Toolpath As PMToolpath

Field Value

Type: PMToolpath
See Also

Reference

PMLead Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLeadExtension Class

Represent a Lead extension in PMToolpath.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMLead
Autodesk.ProductInterface.PowerMILLPMLeadExtension

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMLeadExtension : PMLead
Public Class PMLeadExtension
    Inherits PMLead

The PMLeadExtension type exposes the following members.

Constructors
 | Name | Description
Public method | PMLeadExtension | Initializes a new instance of the PMLeadExtension class
Top
Properties
 | Name | Description
Public property | Angle | The angle of the Lead move relative to the toolpath segment. For arcs, this is the angle spanned by the arc. For lines, it is the orientation relative to the cutting move. (Inherited from PMLead.)
Public property | Distance | The length to extend the Lead move before the cutting move starts. If this is an arc move, then the distance is the length of the linear tangential move between the arc and the cutting portion of the toolpath. (Inherited from PMLead.)
Public property | MoveType | The type of move to use after each cutting move
Public property | Radius | The radius of the Lead arc move (Inherited from PMLead.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPropertyFullName | PMToolpath that own this PMLead (Inherited from PMLead.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | LeadType | Define LeadType of this lead. (Inherited from PMLead.)
Public field | Ramp | enables you to specify how the tool ramps into the stock. (Inherited from PMLead.)
Protected field | Toolpath | PMToolpath that own this PMLead (Inherited from PMLead.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMLeadExtension Constructor

Initializes a new instance of the PMLeadExtension class

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLeadExtension(
    LeadTypes leadInExtension,
    PMToolpath toolpath
)
Public Sub New (
    leadInExtension As LeadTypes,
    toolpath As PMToolpath
)

Parameters

leadInExtension
Type: Autodesk.ProductInterface.PowerMILLLeadTypes

[Missing <param name="leadInExtension"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMLeadExtension.#ctor(Autodesk.ProductInterface.PowerMILL.LeadTypes,Autodesk.ProductInterface.PowerMILL.PMToolpath)"]

toolpath
Type: Autodesk.ProductInterface.PowerMILLPMToolpath

[Missing <param name="toolpath"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMLeadExtension.#ctor(Autodesk.ProductInterface.PowerMILL.LeadTypes,Autodesk.ProductInterface.PowerMILL.PMToolpath)"]

See Also

Reference

PMLeadExtension Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLeadExtension Properties

The PMLeadExtension type exposes the following members.

Properties
 | Name | Description
Public property | Angle | The angle of the Lead move relative to the toolpath segment. For arcs, this is the angle spanned by the arc. For lines, it is the orientation relative to the cutting move. (Inherited from PMLead.)
Public property | Distance | The length to extend the Lead move before the cutting move starts. If this is an arc move, then the distance is the length of the linear tangential move between the arc and the cutting portion of the toolpath. (Inherited from PMLead.)
Public property | MoveType | The type of move to use after each cutting move
Public property | Radius | The radius of the Lead arc move (Inherited from PMLead.)
Top
See Also

Reference

PMLeadExtension Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLeadExtension.MoveType Property

PMLeadExtensionMoveType Property

The type of move to use after each cutting move

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ExtensionLeadMoveTypes MoveType { get; set; }
Public Property MoveType As ExtensionLeadMoveTypes
    Get
    Set

Property Value

Type: ExtensionLeadMoveTypes
See Also

Reference

PMLeadExtension Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLeadExtension Methods

The PMLeadExtension type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPropertyFullName | PMToolpath that own this PMLead (Inherited from PMLead.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMLeadExtension Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLeadExtension Fields

The PMLeadExtension type exposes the following members.

Fields
 | Name | Description
Public field | LeadType | Define LeadType of this lead. (Inherited from PMLead.)
Public field | Ramp | enables you to specify how the tool ramps into the stock. (Inherited from PMLead.)
Protected field | Toolpath | PMToolpath that own this PMLead (Inherited from PMLead.)
Top
See Also

Reference

PMLeadExtension Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSet Class

Captures a Level or Set object in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMLevelOrSet

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMLevelOrSet : PMEntity
Public Class PMLevelOrSet
    Inherits PMEntity

The PMLevelOrSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Overrides PMEntityBoundingBox.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | Visible | Sets the visibility of the level or set in PowerMill.
Top
Methods
 | Name | Description
Public method | Delete | Deletes Level or Set. It also updates PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSet Properties

The PMLevelOrSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Overrides PMEntityBoundingBox.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | Visible | Sets the visibility of the level or set in PowerMill.
Top
See Also

Reference

PMLevelOrSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSet.BoundingBox Property

PMLevelOrSetBoundingBox Property

BoundingBox property is not valid for this type.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PMLevelOrSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSet.Visible Property

PMLevelOrSetVisible Property

Sets the visibility of the level or set in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Visible { set; }
Public WriteOnly Property Visible As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PMLevelOrSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSet Methods

The PMLevelOrSet type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes Level or Set. It also updates PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMLevelOrSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSet.Delete Method

PMLevelOrSetDelete Method

Deletes Level or Set. It also updates PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Remarks
See Also

Reference

PMLevelOrSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSet Fields

The PMLevelOrSet type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMLevelOrSet Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSetsCollection Class

Represents a collection of Level or Set objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMLevelOrSet
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMLevelOrSet
Autodesk.ProductInterface.PowerMILLPMLevelOrSetsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMLevelOrSetsCollection : PMEntitiesCollection<PMLevelOrSet>
Public Class PMLevelOrSetsCollection
    Inherits PMEntitiesCollection(Of PMLevelOrSet)

The PMLevelOrSetsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateLevel | Creates a new Level with the specified name.
Public method | CreateSet | Creates a new set with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSetsCollection Properties

The PMLevelOrSetsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMLevelOrSetsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSetsCollection Methods

The PMLevelOrSetsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateLevel | Creates a new Level with the specified name.
Public method | CreateSet | Creates a new set with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMLevelOrSetsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSetsCollection.CreateLevel Method

PMLevelOrSetsCollectionCreateLevel Method

Creates a new Level with the specified name.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLevelOrSet CreateLevel(
    string name
)
Public Function CreateLevel (
    name As String
) As PMLevelOrSet

Parameters

name
Type: SystemString
The name of the level.

Return Value

Type: PMLevelOrSet
See Also

Reference

PMLevelOrSetsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSetsCollection.CreateSet Method

PMLevelOrSetsCollectionCreateSet Method

Creates a new set with the specified name.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLevelOrSet CreateSet(
    string name
)
Public Function CreateSet (
    name As String
) As PMLevelOrSet

Parameters

name
Type: SystemString
The name of the set.

Return Value

Type: PMLevelOrSet
See Also

Reference

PMLevelOrSetsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMLevelOrSetsCollection Fields

The PMLevelOrSetsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMLevelOrSetsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMachineTool Class

Captures a Machine Tool object in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMMachineTool

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMMachineTool : PMEntity
Public Class PMMachineTool
    Inherits PMEntity

The PMMachineTool type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the machine tool from the active project. It also updates PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMMachineTool Properties

The PMMachineTool type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMMachineTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMachineTool Methods

The PMMachineTool type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the machine tool from the active project. It also updates PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMMachineTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMachineTool.Delete Method

PMMachineToolDelete Method

Deletes the machine tool from the active project. It also updates PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Remarks
See Also

Reference

PMMachineTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMachineTool Fields

The PMMachineTool type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMMachineTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMachineToolsCollection Class

Collection of Machine Tool objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMMachineTool
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMMachineTool
Autodesk.ProductInterface.PowerMILLPMMachineToolsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMMachineToolsCollection : PMEntitiesCollection<PMMachineTool>
Public Class PMMachineToolsCollection
    Inherits PMEntitiesCollection(Of PMMachineTool)

The PMMachineToolsCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PMMachineToolsCollection | Creates a new collection.
Top
Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMMachineToolsCollection Constructor

Creates a new collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMMachineToolsCollection(
    PMAutomation powerMILL
)
Public Sub New (
    powerMILL As PMAutomation
)

Parameters

powerMILL
Type: Autodesk.ProductInterface.PowerMILLPMAutomation
The base instance to interact with PowerMILL.
See Also

Reference

PMMachineToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMachineToolsCollection Properties

The PMMachineToolsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMMachineToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMachineToolsCollection Methods

The PMMachineToolsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMMachineToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMachineToolsCollection Fields

The PMMachineToolsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMMachineToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro Class

Handles Macros in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceMacro
Autodesk.ProductInterface.PowerMILLPMMacro

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMMacro : Macro
Public Class PMMacro
    Inherits Macro

The PMMacro type exposes the following members.

Constructors
 | Name | Description
Protected method | PMMacro(PMAutomation, File) | Creates a new macro and reads the Macro File in.
Protected method | PMMacro(PMAutomation, String) | Creates a new macro from a list of strings.
Top
Properties
 | Name | Description
Protected property | _childMacro | (Inherited from Macro.)
Public property | Cancel | If True, Macro will be cancelled; False otherwise. (Inherited from Macro.)
Public property | DoNotExecuteCommentsOrBlankLines | If true then if the macro step to be run is a comment or a blank line then it does not send the command to PowerMill.
Public property | ExecutedCommands | Commands that have been executed by this Macro. (Inherited from Macro.)
Public property | Index | Index of the next line to be executed in this Macro. (Inherited from Macro.)
Public property | Line | Line at the specified index of this Macro. (Inherited from Macro.)
Public property | LocalCount | Number of lines in this macro, excluding children. (Inherited from Macro.)
Public property | RunSubMacrosOption | Gets, sets whether an embedded macro is run as a single command or treated as a sub macro and stepped through.
Public property | Text | All lines of the Macro in a string. (Inherited from Macro.)
Public property | TotalCount | Gets the number of lines in the macro (includes lines in called macros). (Overrides MacroTotalCount.)
Public property | UseExecuteEx | If true then macro commands in the macro is sent to PowerMill using the ExecuteEX() command. This can be used to capture the result of the command being sent for debugging purposes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseStepProcessedEvent | Raises the step processed event. (Inherited from Macro.)
Protected method | ReplaceTokens | Replaces the tokens in the passed in command and returns the result.
Public method | Run | Executes the macro until the end, optionally feeding back progress as it goes. (Overrides MacroRun(Boolean, Boolean).)
Public method | RunComplete | Executes the macro in one go rather than line by line. (Overrides MacroRunComplete.)
Public method | RunStep | Executes the next line in the macro and increments the index marker. (Overrides MacroRunStep(Boolean).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | StepProcessed | Raised when a Macro line is processed. (Inherited from Macro.)
Top
Fields
 | Name | Description
Protected field | _cancel | If True, indicates that a Macro cancellation is pending. (Inherited from Macro.)
Protected field | _executedCommands | List of commands that have been executed. (Inherited from Macro.)
Protected field | _lines | Macro command lines. (Inherited from Macro.)
Protected field | _localIndex | Current index within this Macro. (Inherited from Macro.)
Protected field | _powerMILL | The instance of PowerMILL used to run the macro.
Protected field | _RunSubMacrosOption | The options to run a macro. By default is set to send all macro lines as individual commands.
Protected field | _totalIndex | Current index within this file - including all sub macros. (Inherited from Macro.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMMacro Constructor

Overload List
 | Name | Description
Protected method | PMMacro(PMAutomation, File) | Creates a new macro and reads the Macro File in.
Protected method | PMMacro(PMAutomation, String) | Creates a new macro from a list of strings.
Top
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro Constructor (PMAutomation, File)

Creates a new macro and reads the Macro File in.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMMacro(
    PMAutomation powerMILL,
    File macroFile
)
Protected Sub New (
    powerMILL As PMAutomation,
    macroFile As File
)

Parameters

powerMILL
Type: Autodesk.ProductInterface.PowerMILLPMAutomation
The base instance to interact with PowerMILL.
macroFile
Type: Autodesk.FileSystemFile
The file with the macro to be loaded.
See Also

Reference

PMMacro Class
PMMacro Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro Constructor (PMAutomation, String[])

PMMacro Constructor (PMAutomation, String)

Creates a new macro from a list of strings.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMMacro(
    PMAutomation powerMILL,
    params string[] macros
)
Protected Sub New (
    powerMILL As PMAutomation,
    ParamArray macros As String()
)

Parameters

powerMILL
Type: Autodesk.ProductInterface.PowerMILLPMAutomation
The base instance to interact with PowerMILL.
macros
Type: SystemString
a list of macros to be loaded.
See Also

Reference

PMMacro Class
PMMacro Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro Properties

The PMMacro type exposes the following members.

Properties
 | Name | Description
Protected property | _childMacro | (Inherited from Macro.)
Public property | Cancel | If True, Macro will be cancelled; False otherwise. (Inherited from Macro.)
Public property | DoNotExecuteCommentsOrBlankLines | If true then if the macro step to be run is a comment or a blank line then it does not send the command to PowerMill.
Public property | ExecutedCommands | Commands that have been executed by this Macro. (Inherited from Macro.)
Public property | Index | Index of the next line to be executed in this Macro. (Inherited from Macro.)
Public property | Line | Line at the specified index of this Macro. (Inherited from Macro.)
Public property | LocalCount | Number of lines in this macro, excluding children. (Inherited from Macro.)
Public property | RunSubMacrosOption | Gets, sets whether an embedded macro is run as a single command or treated as a sub macro and stepped through.
Public property | Text | All lines of the Macro in a string. (Inherited from Macro.)
Public property | TotalCount | Gets the number of lines in the macro (includes lines in called macros). (Overrides MacroTotalCount.)
Public property | UseExecuteEx | If true then macro commands in the macro is sent to PowerMill using the ExecuteEX() command. This can be used to capture the result of the command being sent for debugging purposes.
Top
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.DoNotExecuteCommentsOrBlankLines Property

PMMacroDoNotExecuteCommentsOrBlankLines Property

If true then if the macro step to be run is a comment or a blank line then it does not send the command to PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool DoNotExecuteCommentsOrBlankLines { get; set; }
Public Property DoNotExecuteCommentsOrBlankLines As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.RunSubMacrosOption Property

PMMacroRunSubMacrosOption Property

Gets, sets whether an embedded macro is run as a single command or treated as a sub macro and stepped through.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMMacroSubMacroRunOptions RunSubMacrosOption { get; set; }
Public Property RunSubMacrosOption As PMMacroSubMacroRunOptions
    Get
    Set

Property Value

Type: PMMacroSubMacroRunOptions
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.TotalCount Property

PMMacroTotalCount Property

Gets the number of lines in the macro (includes lines in called macros).

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int TotalCount { get; }
Public Overrides ReadOnly Property TotalCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.UseExecuteEx Property

PMMacroUseExecuteEx Property

If true then macro commands in the macro is sent to PowerMill using the ExecuteEX() command. This can be used to capture the result of the command being sent for debugging purposes.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool UseExecuteEx { get; set; }
Public Property UseExecuteEx As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro Methods

The PMMacro type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseStepProcessedEvent | Raises the step processed event. (Inherited from Macro.)
Protected method | ReplaceTokens | Replaces the tokens in the passed in command and returns the result.
Public method | Run | Executes the macro until the end, optionally feeding back progress as it goes. (Overrides MacroRun(Boolean, Boolean).)
Public method | RunComplete | Executes the macro in one go rather than line by line. (Overrides MacroRunComplete.)
Public method | RunStep | Executes the next line in the macro and increments the index marker. (Overrides MacroRunStep(Boolean).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.ReplaceTokens Method

PMMacroReplaceTokens Method

Replaces the tokens in the passed in command and returns the result.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected virtual List<string> ReplaceTokens(
    string command
)
Protected Overridable Function ReplaceTokens (
    command As String
) As List(Of String)

Parameters

command
Type: SystemString
The command to be modified.

Return Value

Type: List String
The modified command.
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.Run Method

PMMacroRun Method

Executes the macro until the end, optionally feeding back progress as it goes.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Run(
    bool giveProgress = true,
    bool hideDialogs = true
)
Public Overrides Sub Run (
    Optional giveProgress As Boolean = true,
    Optional hideDialogs As Boolean = true
)

Parameters

giveProgress (Optional)
Type: SystemBoolean
If true it gives a progress status.
hideDialogs (Optional)
Type: SystemBoolean
If true it hides any dialogs.
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.RunComplete Method

PMMacroRunComplete Method

Executes the macro in one go rather than line by line.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RunComplete()
Public Overrides Sub RunComplete
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.RunStep Method

PMMacroRunStep Method

Executes the next line in the macro and increments the index marker.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RunStep(
    bool hideDialogs = true
)
Public Overrides Sub RunStep (
    Optional hideDialogs As Boolean = true
)

Parameters

hideDialogs (Optional)
Type: SystemBoolean
If true, hides all dialogs.
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro Events

The PMMacro type exposes the following members.

Events
 | Name | Description
Public event | StepProcessed | Raised when a Macro line is processed. (Inherited from Macro.)
Top
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro Fields

The PMMacro type exposes the following members.

Fields
 | Name | Description
Protected field | _cancel | If True, indicates that a Macro cancellation is pending. (Inherited from Macro.)
Protected field | _executedCommands | List of commands that have been executed. (Inherited from Macro.)
Protected field | _lines | Macro command lines. (Inherited from Macro.)
Protected field | _localIndex | Current index within this Macro. (Inherited from Macro.)
Protected field | _powerMILL | The instance of PowerMILL used to run the macro.
Protected field | _RunSubMacrosOption | The options to run a macro. By default is set to send all macro lines as individual commands.
Protected field | _totalIndex | Current index within this file - including all sub macros. (Inherited from Macro.)
Top
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro._powerMILL Field

PMMacro_powerMILL Field

The instance of PowerMILL used to run the macro.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMAutomation _powerMILL
Protected _powerMILL As PMAutomation

Field Value

Type: PMAutomation
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro._RunSubMacrosOption Field

PMMacro_RunSubMacrosOption Field

The options to run a macro. By default is set to send all macro lines as individual commands.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMMacroSubMacroRunOptions _RunSubMacrosOption
Protected _RunSubMacrosOption As PMMacroSubMacroRunOptions

Field Value

Type: PMMacroSubMacroRunOptions
See Also

Reference

PMMacro Class
Autodesk.ProductInterface.PowerMILL Namespace


PMMacro.SubMacroRunOptions Enumeration

PMMacroSubMacroRunOptions Enumeration

Determines whether a macro is run sub macro directly with no substitution (RunAsSingleLine) or send all macro lines as individual command (RunAllLines).

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SubMacroRunOptions
Public Enumeration SubMacroRunOptions
Members
Member name | Value | Description
RunAsSingleLine | 0 | Macro is run sub macro directly with no substitution
RunAllLines | 1 | Send all macro lines as individual command
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMModel Class

Captures a Model object in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMModel

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMModel : PMEntity
Public Class PMModel
    Inherits PMEntity

The PMModel type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets the active state of the Model. (Overrides PMEntityIsActive.)
Public property | Level | Sets the Level in PowerMill that this Model is assigned to.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Path | Gets the path of the model.
Public property | Transparency | Sets the transparency of the Model in PowerMill. 0 displays a solid model and 100 displays a transparent one. Values outside these ranges will be limited.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | AddToSelection | Selects the model, optionally removing everything else from the selection first.
Public method | Delete | Deletes model from the active project. It updates PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvertSelection | Inverts the selection of surfaces. Those surfaces that were selected are no longer selected. Those that were previously unselected are now selected.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MirrorInPlane | Mirrors the model in the plane.
Public method | Move | Moves the model by the specified vector.
Public method | Reimport | Reimports a file into PowerMill.
Public method | RemoveFromSelection | Removes the model from the selection.
Public method | ToDMTModel | Exports the model into a DMT file and then reads the DMT model into a DMTModel object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the model to the specified file.
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMModel Properties

The PMModel type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets the active state of the Model. (Overrides PMEntityIsActive.)
Public property | Level | Sets the Level in PowerMill that this Model is assigned to.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Path | Gets the path of the model.
Public property | Transparency | Sets the transparency of the Model in PowerMill. 0 displays a solid model and 100 displays a transparent one. Values outside these ranges will be limited.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.IsActive Property

PMModelIsActive Property

Gets and sets the active state of the Model.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool IsActive { get; set; }
Public Overrides Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.Level Property

PMModelLevel Property

Sets the Level in PowerMill that this Model is assigned to.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLevelOrSet Level { set; }
Public WriteOnly Property Level As PMLevelOrSet
    Set

Property Value

Type: PMLevelOrSet
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.Path Property

PMModelPath Property

Gets the path of the model.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.Transparency Property

PMModelTransparency Property

Sets the transparency of the Model in PowerMill. 0 displays a solid model and 100 displays a transparent one. Values outside these ranges will be limited.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Transparency { set; }
Public WriteOnly Property Transparency As Integer
    Set

Property Value

Type: Int32
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel Methods

The PMModel type exposes the following members.

Methods
 | Name | Description
Public method | AddToSelection | Selects the model, optionally removing everything else from the selection first.
Public method | Delete | Deletes model from the active project. It updates PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvertSelection | Inverts the selection of surfaces. Those surfaces that were selected are no longer selected. Those that were previously unselected are now selected.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MirrorInPlane | Mirrors the model in the plane.
Public method | Move | Moves the model by the specified vector.
Public method | Reimport | Reimports a file into PowerMill.
Public method | RemoveFromSelection | Removes the model from the selection.
Public method | ToDMTModel | Exports the model into a DMT file and then reads the DMT model into a DMTModel object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the model to the specified file.
Top
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.AddToSelection Method

PMModelAddToSelection Method

Selects the model, optionally removing everything else from the selection first.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddToSelection(
    bool clearSelectionFirst = false
)
Public Sub AddToSelection (
    Optional clearSelectionFirst As Boolean = false
)

Parameters

clearSelectionFirst (Optional)
Type: SystemBoolean
If true unselects everything else before selecting this model.
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.Delete Method

PMModelDelete Method

Deletes model from the active project. It updates PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.InvertSelection Method

PMModelInvertSelection Method

Inverts the selection of surfaces. Those surfaces that were selected are no longer selected. Those that were previously unselected are now selected.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InvertSelection()
Public Sub InvertSelection
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.MirrorInPlane Method

PMModelMirrorInPlane Method

Mirrors the model in the plane.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MirrorInPlane(
    Planes plane
)
Public Sub MirrorInPlane (
    plane As Planes
)

Parameters

plane
Type: AutodeskPlanes
The plane used to mirror the model.
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.Move Method

PMModelMove Method

Moves the model by the specified vector.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Move(
    Vector moveVector
)
Public Sub Move (
    moveVector As Vector
)

Parameters

moveVector
Type: Autodesk.GeometryVector
The vector of how to move the model in X, Y, Z.
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.Reimport Method

PMModelReimport Method

Reimports a file into PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Reimport(
    File file
)
Public Sub Reimport (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The file to import.
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.RemoveFromSelection Method

PMModelRemoveFromSelection Method

Removes the model from the selection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RemoveFromSelection()
Public Sub RemoveFromSelection
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.ToDMTModel Method

PMModelToDMTModel Method

Exports the model into a DMT file and then reads the DMT model into a DMTModel object.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTModel ToDMTModel()
Public Function ToDMTModel As DMTModel

Return Value

Type: DMTModel
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel.WriteToDMTFile Method

PMModelWriteToDMTFile Method

Exports the model to the specified file.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToDMTFile(
    File file
)
Public Sub WriteToDMTFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The file to which the model will be exported.
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModel Fields

The PMModel type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection Class

Collection of Model objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMModel
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMModel
Autodesk.ProductInterface.PowerMILLPMModelsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMModelsCollection : PMEntitiesCollection<PMModel>
Public Class PMModelsCollection
    Inherits PMEntitiesCollection(Of PMModel)

The PMModelsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateModel(DMTModel) | Adds the DMT Model into PowerMILL and adds the Model to the collection.
Public method | CreateModel(File) | Imports the specified DMT file into PowerMILL and adds the model to the collection.
Public method | CreateReferenceModel(DMTModel) | Creates a reference surface model from a DMTModel.
Public method | CreateReferenceModel(File) | Creates a reference surface model from a file.
Public method | DeleteEmptyModels | Deletes any empty models within PowerMILL.
Public method | DeleteSelectedSurfaces | Deletes the selected surfaces. Note that this does not delete the models that are now empty. To do this you should call DeleteEmptyModels.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportAllModels | Exports all the models to the selected file. The files should typically be DGK, DDX, DDZ or DMT.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection Properties

The PMModelsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection Methods

The PMModelsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateModel(DMTModel) | Adds the DMT Model into PowerMILL and adds the Model to the collection.
Public method | CreateModel(File) | Imports the specified DMT file into PowerMILL and adds the model to the collection.
Public method | CreateReferenceModel(DMTModel) | Creates a reference surface model from a DMTModel.
Public method | CreateReferenceModel(File) | Creates a reference surface model from a file.
Public method | DeleteEmptyModels | Deletes any empty models within PowerMILL.
Public method | DeleteSelectedSurfaces | Deletes the selected surfaces. Note that this does not delete the models that are now empty. To do this you should call DeleteEmptyModels.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportAllModels | Exports all the models to the selected file. The files should typically be DGK, DDX, DDZ or DMT.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.CreateModel Method

PMModelsCollectionCreateModel Method

Overload List
 | Name | Description
Public method | CreateModel(DMTModel) | Adds the DMT Model into PowerMILL and adds the Model to the collection.
Public method | CreateModel(File) | Imports the specified DMT file into PowerMILL and adds the model to the collection.
Top
See Also

Reference

PMModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.CreateModel Method (DMTModel)

PMModelsCollectionCreateModel Method (DMTModel)

Adds the DMT Model into PowerMILL and adds the Model to the collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMModel CreateModel(
    DMTModel DMT
)
Public Function CreateModel (
    DMT As DMTModel
) As PMModel

Parameters

DMT
Type: Autodesk.GeometryDMTModel
The DMTModel to add.

Return Value

Type: PMModel
See Also

Reference

PMModelsCollection Class
CreateModel Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.CreateModel Method (File)

PMModelsCollectionCreateModel Method (File)

Imports the specified DMT file into PowerMILL and adds the model to the collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMModel CreateModel(
    File file
)
Public Function CreateModel (
    file As File
) As PMModel

Parameters

file
Type: Autodesk.FileSystemFile
The DMT file to import.

Return Value

Type: PMModel
See Also

Reference

PMModelsCollection Class
CreateModel Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.CreateReferenceModel Method

PMModelsCollectionCreateReferenceModel Method

Overload List
 | Name | Description
Public method | CreateReferenceModel(DMTModel) | Creates a reference surface model from a DMTModel.
Public method | CreateReferenceModel(File) | Creates a reference surface model from a file.
Top
See Also

Reference

PMModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.CreateReferenceModel Method (DMTModel)

PMModelsCollectionCreateReferenceModel Method (DMTModel)

Creates a reference surface model from a DMTModel.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMModel CreateReferenceModel(
    DMTModel DMT
)
Public Function CreateReferenceModel (
    DMT As DMTModel
) As PMModel

Parameters

DMT
Type: Autodesk.GeometryDMTModel
The DMTModel to set as a reference surface model.

Return Value

Type: PMModel
See Also

Reference

PMModelsCollection Class
CreateReferenceModel Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.CreateReferenceModel Method (File)

PMModelsCollectionCreateReferenceModel Method (File)

Creates a reference surface model from a file.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMModel CreateReferenceModel(
    File file
)
Public Function CreateReferenceModel (
    file As File
) As PMModel

Parameters

file
Type: Autodesk.FileSystemFile
The DMT file imported to create the reference surface model.

Return Value

Type: PMModel
See Also

Reference

PMModelsCollection Class
CreateReferenceModel Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.DeleteEmptyModels Method

PMModelsCollectionDeleteEmptyModels Method

Deletes any empty models within PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeleteEmptyModels()
Public Sub DeleteEmptyModels
See Also

Reference

PMModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.DeleteSelectedSurfaces Method

PMModelsCollectionDeleteSelectedSurfaces Method

Deletes the selected surfaces. Note that this does not delete the models that are now empty. To do this you should call DeleteEmptyModels.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeleteSelectedSurfaces()
Public Sub DeleteSelectedSurfaces
See Also

Reference

PMModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection.ExportAllModels Method

PMModelsCollectionExportAllModels Method

Exports all the models to the selected file. The files should typically be DGK, DDX, DDZ or DMT.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ExportAllModels(
    File exportFile
)
Public Sub ExportAllModels (
    exportFile As File
)

Parameters

exportFile
Type: Autodesk.FileSystemFile

[Missing <param name="exportFile"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMModelsCollection.ExportAllModels(Autodesk.FileSystem.File)"]

See Also

Reference

PMModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMModelsCollection Fields

The PMModelsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram Class

Captures a NCProgram object in PowerMILL
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMNCProgram

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMNCProgram : PMEntity
Public Class PMNCProgram
    Inherits PMEntity

The PMNCProgram type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | MachineOptionFileName | Gets and sets in PowerMill the Option File name assigned to the NC program.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | OutputFileName | Gets and sets in PowerMill the Output file name generated by the NC program.
Public property | OutputWorkplaneName | Gets and sets in PowerMill the ouput workplane.
Public property | PartName | Gets and sets in PowerMill the part number.
Public property | ProgramNumber | Gets and sets in PowerMill the program number.
Public property | ToolChange | Gets and sets the tool change mode.
Public property | ToolChangePosition | Gets and sets the tool change position in PowerMill.
Public property | ToolNumbering | Gets and sets the tool numbering in PowerMill.
Public property | Toolpaths | Gets the list of all the toolpaths that are in this NCProgram.
Public property | ToolValue | Gets and sets in PowerMill the tool coordinates.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | AddToolpath | Adds a Toolpath to the NC Program.
Public method | Delete | Deletes program. It also update PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveToolpath | Removes toolpath from NC program in PowerMill.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes the NCProgram. Post-processor and option file must have been specified already.
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram Properties

The PMNCProgram type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | MachineOptionFileName | Gets and sets in PowerMill the Option File name assigned to the NC program.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | OutputFileName | Gets and sets in PowerMill the Output file name generated by the NC program.
Public property | OutputWorkplaneName | Gets and sets in PowerMill the ouput workplane.
Public property | PartName | Gets and sets in PowerMill the part number.
Public property | ProgramNumber | Gets and sets in PowerMill the program number.
Public property | ToolChange | Gets and sets the tool change mode.
Public property | ToolChangePosition | Gets and sets the tool change position in PowerMill.
Public property | ToolNumbering | Gets and sets the tool numbering in PowerMill.
Public property | Toolpaths | Gets the list of all the toolpaths that are in this NCProgram.
Public property | ToolValue | Gets and sets in PowerMill the tool coordinates.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.MachineOptionFileName Property

PMNCProgramMachineOptionFileName Property

Gets and sets in PowerMill the Option File name assigned to the NC program.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string MachineOptionFileName { get; set; }
Public Property MachineOptionFileName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.OutputFileName Property

PMNCProgramOutputFileName Property

Gets and sets in PowerMill the Output file name generated by the NC program.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string OutputFileName { get; set; }
Public Property OutputFileName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.OutputWorkplaneName Property

PMNCProgramOutputWorkplaneName Property

Gets and sets in PowerMill the ouput workplane.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string OutputWorkplaneName { get; set; }
Public Property OutputWorkplaneName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.PartName Property

PMNCProgramPartName Property

Gets and sets in PowerMill the part number.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string PartName { get; set; }
Public Property PartName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.ProgramNumber Property

PMNCProgramProgramNumber Property

Gets and sets in PowerMill the program number.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int ProgramNumber { get; set; }
Public Property ProgramNumber As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.ToolChange Property

PMNCProgramToolChange Property

Gets and sets the tool change mode.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolChanges ToolChange { get; set; }
Public Property ToolChange As ToolChanges
    Get
    Set

Property Value

Type: ToolChanges
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.ToolChangePosition Property

PMNCProgramToolChangePosition Property

Gets and sets the tool change position in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolChangePositions ToolChangePosition { get; set; }
Public Property ToolChangePosition As ToolChangePositions
    Get
    Set

Property Value

Type: ToolChangePositions
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.ToolNumbering Property

PMNCProgramToolNumbering Property

Gets and sets the tool numbering in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolNumberings ToolNumbering { get; set; }
Public Property ToolNumbering As ToolNumberings
    Get
    Set

Property Value

Type: ToolNumberings
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.Toolpaths Property

PMNCProgramToolpaths Property

Gets the list of all the toolpaths that are in this NCProgram.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PMToolpath> Toolpaths { get; }
Public ReadOnly Property Toolpaths As List(Of PMToolpath)
    Get

Property Value

Type: List PMToolpath
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.ToolValue Property

PMNCProgramToolValue Property

Gets and sets in PowerMill the tool coordinates.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolValues ToolValue { get; set; }
Public Property ToolValue As ToolValues
    Get
    Set

Property Value

Type: ToolValues
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram Methods

The PMNCProgram type exposes the following members.

Methods
 | Name | Description
Public method | AddToolpath | Adds a Toolpath to the NC Program.
Public method | Delete | Deletes program. It also update PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveToolpath | Removes toolpath from NC program in PowerMill.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes the NCProgram. Post-processor and option file must have been specified already.
Top
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.AddToolpath Method

PMNCProgramAddToolpath Method

Adds a Toolpath to the NC Program.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddToolpath(
    string toolpathName,
    bool insertAtFront = false,
    int insertAfterIndexPosition = -1
)
Public Sub AddToolpath (
    toolpathName As String,
    Optional insertAtFront As Boolean = false,
    Optional insertAfterIndexPosition As Integer = -1
)

Parameters

toolpathName
Type: SystemString
The toolpath name to add.
insertAtFront (Optional)
Type: SystemBoolean
If true it will to insert at front.
insertAfterIndexPosition (Optional)
Type: SystemInt32
The index position aftger which the Toolpath will be added.
Remarks
Does not check that toolpath exists or already added
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.Delete Method

PMNCProgramDelete Method

Deletes program. It also update PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.RemoveToolpath Method

PMNCProgramRemoveToolpath Method

Removes toolpath from NC program in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RemoveToolpath(
    string toolpathName
)
Public Sub RemoveToolpath (
    toolpathName As String
)

Parameters

toolpathName
Type: SystemString
The toolpath name.
Remarks
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram.Write Method

PMNCProgramWrite Method

Writes the NCProgram. Post-processor and option file must have been specified already.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Write()
Public Sub Write
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgram Fields

The PMNCProgram type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMNCProgram Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgramsCollection Class

Collection of NCProgram objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMNCProgram
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMNCProgram
Autodesk.ProductInterface.PowerMILLPMNCProgramsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMNCProgramsCollection : PMEntitiesCollection<PMNCProgram>
Public Class PMNCProgramsCollection
    Inherits PMEntitiesCollection(Of PMNCProgram)

The PMNCProgramsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateNCProgram | Creates a new NC program with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgramsCollection Properties

The PMNCProgramsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMNCProgramsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgramsCollection Methods

The PMNCProgramsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateNCProgram | Creates a new NC program with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMNCProgramsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgramsCollection.CreateNCProgram Method

PMNCProgramsCollectionCreateNCProgram Method

Creates a new NC program with the specified name.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMNCProgram CreateNCProgram(
    string name
)
Public Function CreateNCProgram (
    name As String
) As PMNCProgram

Parameters

name
Type: SystemString
The name for the new NC Program

Return Value

Type: PMNCProgram
See Also

Reference

PMNCProgramsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMNCProgramsCollection Fields

The PMNCProgramsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMNCProgramsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern Class

Captures a Pattern object in PowerMILL
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMPattern

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMPattern : PMEntity
Public Class PMPattern
    Inherits PMEntity

The PMPattern type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsVisible | Sets the visibility of the pattern in PowerMill.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | ArcFitAll | Fits an Arc to all the sections of the Pattern.
Public method | ArcFitSelected | Fits an arc to the selected sections of the Pattern.
Public method | CloseAll | Closes all the sections of the Pattern.
Public method | CloseSelected | Closes the selected sections of the Pattern.
Public method | Delete | Deletes the pattern from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Pattern.
Public method | InsertToolpath | Inserts the specified toolpath into this Pattern.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeAll | Merges all the sections of the Pattern.
Public method | MergeSelected | Merges the selected sections of the Pattern.
Public method | PolygoniseAll | Polygonises all the sections of the Pattern.
Public method | PolygoniseSelected | Polygonises the selected sections of the Pattern.
Public method | ReverseAll | Reverses all the sections of the Pattern.
Public method | ReverseSelected | Reverses the selected sections of the Pattern in PowerMill.
Public method | SelectAll | Selects all sections of the Pattern.
Public method | SplineAll | Splines all the sections of the Pattern.
Public method | SplineSelected | Splines the selected sections of the Pattern.
Public method | SplitAll | Splits all the sections of the Pattern.
Public method | SplitSelected | Splits the selected sections of the Pattern.
Public method | ToPolylines | Converts the PMPattern to a list of Polylines.
Public method | ToSplines | Converts the PMPattern to a list of Splines.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Pattern to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMPattern Properties

The PMPattern type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsVisible | Sets the visibility of the pattern in PowerMill.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.IsVisible Property

PMPatternIsVisible Property

Sets the visibility of the pattern in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsVisible { set; }
Public WriteOnly Property IsVisible As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern Methods

The PMPattern type exposes the following members.

Methods
 | Name | Description
Public method | ArcFitAll | Fits an Arc to all the sections of the Pattern.
Public method | ArcFitSelected | Fits an arc to the selected sections of the Pattern.
Public method | CloseAll | Closes all the sections of the Pattern.
Public method | CloseSelected | Closes the selected sections of the Pattern.
Public method | Delete | Deletes the pattern from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertFile | Inserts the specified file into this Pattern.
Public method | InsertToolpath | Inserts the specified toolpath into this Pattern.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeAll | Merges all the sections of the Pattern.
Public method | MergeSelected | Merges the selected sections of the Pattern.
Public method | PolygoniseAll | Polygonises all the sections of the Pattern.
Public method | PolygoniseSelected | Polygonises the selected sections of the Pattern.
Public method | ReverseAll | Reverses all the sections of the Pattern.
Public method | ReverseSelected | Reverses the selected sections of the Pattern in PowerMill.
Public method | SelectAll | Selects all sections of the Pattern.
Public method | SplineAll | Splines all the sections of the Pattern.
Public method | SplineSelected | Splines the selected sections of the Pattern.
Public method | SplitAll | Splits all the sections of the Pattern.
Public method | SplitSelected | Splits the selected sections of the Pattern.
Public method | ToPolylines | Converts the PMPattern to a list of Polylines.
Public method | ToSplines | Converts the PMPattern to a list of Splines.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToFile | Write the Pattern to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic
Top
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.ArcFitAll Method

PMPatternArcFitAll Method

Fits an Arc to all the sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ArcFitAll(
    double dblTolerance
)
Public Sub ArcFitAll (
    dblTolerance As Double
)

Parameters

dblTolerance
Type: SystemDouble
The Arc fitting tolerance.
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.ArcFitSelected Method

PMPatternArcFitSelected Method

Fits an arc to the selected sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ArcFitSelected(
    double tolerance
)
Public Sub ArcFitSelected (
    tolerance As Double
)

Parameters

tolerance
Type: SystemDouble
The Arc fitting tolerance.
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.CloseAll Method

PMPatternCloseAll Method

Closes all the sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CloseAll()
Public Sub CloseAll
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.CloseSelected Method

PMPatternCloseSelected Method

Closes the selected sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CloseSelected()
Public Sub CloseSelected
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.Delete Method

PMPatternDelete Method

Deletes the pattern from the active project and from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.InsertFile Method

PMPatternInsertFile Method

Inserts the specified file into this Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InsertFile(
    File file
)
Public Sub InsertFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
File to insert into this Pattern
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.InsertToolpath Method

PMPatternInsertToolpath Method

Inserts the specified toolpath into this Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InsertToolpath(
    PMToolpath toolpath
)
Public Sub InsertToolpath (
    toolpath As PMToolpath
)

Parameters

toolpath
Type: Autodesk.ProductInterface.PowerMILLPMToolpath
The toolpath to insert into this Pattern.
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.MergeAll Method

PMPatternMergeAll Method

Merges all the sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MergeAll()
Public Sub MergeAll
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.MergeSelected Method

PMPatternMergeSelected Method

Merges the selected sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MergeSelected()
Public Sub MergeSelected
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.PolygoniseAll Method

PMPatternPolygoniseAll Method

Polygonises all the sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void PolygoniseAll(
    double dblTolerance
)
Public Sub PolygoniseAll (
    dblTolerance As Double
)

Parameters

dblTolerance
Type: SystemDouble
The Polygonisation tolerance.
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.PolygoniseSelected Method

PMPatternPolygoniseSelected Method

Polygonises the selected sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void PolygoniseSelected(
    double dblTolerance
)
Public Sub PolygoniseSelected (
    dblTolerance As Double
)

Parameters

dblTolerance
Type: SystemDouble
The Polygonisation tolerance.
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.ReverseAll Method

PMPatternReverseAll Method

Reverses all the sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ReverseAll()
Public Sub ReverseAll
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.ReverseSelected Method

PMPatternReverseSelected Method

Reverses the selected sections of the Pattern in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ReverseSelected()
Public Sub ReverseSelected
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.SelectAll Method

PMPatternSelectAll Method

Selects all sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SelectAll()
Public Sub SelectAll
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.SplineAll Method

PMPatternSplineAll Method

Splines all the sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SplineAll(
    double dblTolerance
)
Public Sub SplineAll (
    dblTolerance As Double
)

Parameters

dblTolerance
Type: SystemDouble
The Spline fitting tolerance.
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.SplineSelected Method

PMPatternSplineSelected Method

Splines the selected sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SplineSelected(
    double dblTolerance
)
Public Sub SplineSelected (
    dblTolerance As Double
)

Parameters

dblTolerance
Type: SystemDouble
The spline fitting tolerance.
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.SplitAll Method

PMPatternSplitAll Method

Splits all the sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SplitAll()
Public Sub SplitAll
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.SplitSelected Method

PMPatternSplitSelected Method

Splits the selected sections of the Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SplitSelected()
Public Sub SplitSelected
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.ToPolylines Method

PMPatternToPolylines Method

Converts the PMPattern to a list of Polylines.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Polyline> ToPolylines()
Public Function ToPolylines As List(Of Polyline)

Return Value

Type: List Polyline
A list of Polylines
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.ToSplines Method

PMPatternToSplines Method

Converts the PMPattern to a list of Splines.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<Spline> ToSplines()
Public Function ToSplines As List(Of Spline)

Return Value

Type: List Spline
A list of Splines
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern.WriteToFile Method

PMPatternWriteToFile Method

Write the Pattern to the specified file. Supported file types are: dgk, ddz, ddx, dxf, pic

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToFile(
    File file
)
Public Sub WriteToFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The file to write to.
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPattern Fields

The PMPattern type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMPattern Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPatternsCollection Class

Collection of Pattern objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMPattern
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMPattern
Autodesk.ProductInterface.PowerMILLPMPatternsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMPatternsCollection : PMEntitiesCollection<PMPattern>
Public Class PMPatternsCollection
    Inherits PMEntitiesCollection(Of PMPattern)

The PMPatternsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateEmptyPattern | Creates an empty Pattern in PowerMill and adds it to the boundaries collection.
Public method | CreatePattern(File) | Imports the DUCT Picture file into PowerMILL as a Pattern and adds it to the collection.
Public method | CreatePattern(Polyline) | Adds the specified Polyline to PowerMILL as a Pattern.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMPatternsCollection Properties

The PMPatternsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMPatternsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPatternsCollection Methods

The PMPatternsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateEmptyPattern | Creates an empty Pattern in PowerMill and adds it to the boundaries collection.
Public method | CreatePattern(File) | Imports the DUCT Picture file into PowerMILL as a Pattern and adds it to the collection.
Public method | CreatePattern(Polyline) | Adds the specified Polyline to PowerMILL as a Pattern.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMPatternsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPatternsCollection.CreateEmptyPattern Method

PMPatternsCollectionCreateEmptyPattern Method

Creates an empty Pattern in PowerMill and adds it to the boundaries collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMPattern CreateEmptyPattern()
Public Function CreateEmptyPattern As PMPattern

Return Value

Type: PMPattern
The new PMPattern.
See Also

Reference

PMPatternsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPatternsCollection.CreatePattern Method

PMPatternsCollectionCreatePattern Method

Overload List
 | Name | Description
Public method | CreatePattern(File) | Imports the DUCT Picture file into PowerMILL as a Pattern and adds it to the collection.
Public method | CreatePattern(Polyline) | Adds the specified Polyline to PowerMILL as a Pattern.
Top
See Also

Reference

PMPatternsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMPatternsCollection.CreatePattern Method (File)

PMPatternsCollectionCreatePattern Method (File)

Imports the DUCT Picture file into PowerMILL as a Pattern and adds it to the collection.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMPattern CreatePattern(
    File file
)
Public Function CreatePattern (
    file As File
) As PMPattern

Parameters

file
Type: Autodesk.FileSystemFile
the DUCT Picture file to import.

Return Value

Type: PMPattern
See Also

Reference

PMPatternsCollection Class
CreatePattern Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMPatternsCollection.CreatePattern Method (Polyline)

PMPatternsCollectionCreatePattern Method (Polyline)

Adds the specified Polyline to PowerMILL as a Pattern.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMPattern CreatePattern(
    Polyline polyline
)
Public Function CreatePattern (
    polyline As Polyline
) As PMPattern

Parameters

polyline
Type: Autodesk.GeometryPolyline
The polyline to add.

Return Value

Type: PMPattern
See Also

Reference

PMPatternsCollection Class
CreatePattern Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMPatternsCollection Fields

The PMPatternsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMPatternsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject Class

Captures a PowerMILL project and gives access to the collections of objects in it.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMProject

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMProject
Public Class PMProject

The PMProject type exposes the following members.

Properties
 | Name | Description
Public property | Boundaries | Gets the collection of Boundaries currently in PowerMILL.
Public property | Directory | Gets the PowerMILL directory of the active project.
Public property | FeatureSets | Gets the collection of FeatureSets currently in PowerMILL.
Public property | Groups | Gets the collection of Groups currently in PowerMILL.
Public property | LevelsAndSets | Gets the collection of Levels and Sets currently in PowerMILL.
Public property | MachineTools | Gets the collection of Machine Tools currently in PowerMILL.
Public property | Models | Gets the collection of Models currently in PowerMILL.
Public property | NCPrograms | Gets the collection of NCPrograms currently in PowerMILL.
Public property | Patterns | Gets the collection of Patterns currently in PowerMILL.
Public property | StockModels | Gets the collection of Stock Models currently in PowerMILL.
Public property | Toolpaths | Gets the collection of Toolpaths currently in PowerMILL.
Public property | Tools | Gets the collection of Tools currently in PowerMILL.
Public property | Workplanes | Gets the collection of Workplanes currently in PowerMILL.
Top
Methods
 | Name | Description
Public method | CreateBlock(File) | This operation creates a Block in PowerMILL from a DMT file.
Public method | CreateBlock(String, Double) | This operation creates a Block in PowerMILL from an existing model.
Public method | DeleteBlock | This operation deletes the Block from PowerMill.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImportTemplateFile | Imports the specified PowerMILL Template File.
Public method | Initialise | Initialises the project collections based on what is currently in PowerMILL.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | This operation refreshes the information available in the current project. Refresh should retain any existing items in the lists, add new ones and remove old ones. This function would be used by someone after they have used the "Execute" functionality.
Public method | Save | Saves the project. The project must have been opened from a directory or previously saved using the SaveAs operation otherwise an exception will be thrown. Saves currently loaded project in Powermill.
Public method | SaveAs | Saves the project to the specified directory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _boundaries | The list of Boundaries in the Project.
Protected field | _featureSets | The list of FeatureSets in the Project.
Protected field | _groups | The list of Groups in the Project.
Protected field | _levelsOrSets | The list of Levels and Sets in the Project.
Protected field | _machineTools | The list of tools in the Project.
Protected field | _models | The list of Models in the Project.
Protected field | _NCPrograms | The list of NC Programs in the Project.
Protected field | _patterns | The list of Patterns in the Project.
Protected field | _powerMILL | The PowerMILL Automation object.
Protected field | _projectDirectory | The directory for the PowerMILL Project.
Protected field | _stockModels | The list of Stock Models in the Project.
Protected field | _toolpaths | The list of Toolpaths in the Project.
Protected field | _tools | The list of Tools in the Project.
Protected field | _workplanes | The list of Workplanes in the Project.
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMProject Properties

The PMProject type exposes the following members.

Properties
 | Name | Description
Public property | Boundaries | Gets the collection of Boundaries currently in PowerMILL.
Public property | Directory | Gets the PowerMILL directory of the active project.
Public property | FeatureSets | Gets the collection of FeatureSets currently in PowerMILL.
Public property | Groups | Gets the collection of Groups currently in PowerMILL.
Public property | LevelsAndSets | Gets the collection of Levels and Sets currently in PowerMILL.
Public property | MachineTools | Gets the collection of Machine Tools currently in PowerMILL.
Public property | Models | Gets the collection of Models currently in PowerMILL.
Public property | NCPrograms | Gets the collection of NCPrograms currently in PowerMILL.
Public property | Patterns | Gets the collection of Patterns currently in PowerMILL.
Public property | StockModels | Gets the collection of Stock Models currently in PowerMILL.
Public property | Toolpaths | Gets the collection of Toolpaths currently in PowerMILL.
Public property | Tools | Gets the collection of Tools currently in PowerMILL.
Public property | Workplanes | Gets the collection of Workplanes currently in PowerMILL.
Top
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Boundaries Property

PMProjectBoundaries Property

Gets the collection of Boundaries currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMBoundariesCollection Boundaries { get; }
Public ReadOnly Property Boundaries As PMBoundariesCollection
    Get

Property Value

Type: PMBoundariesCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Directory Property

PMProjectDirectory Property

Gets the PowerMILL directory of the active project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Directory Directory { get; }
Public ReadOnly Property Directory As Directory
    Get

Return Value

Type: Directory
Nothing if project has not been saved.
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.FeatureSets Property

PMProjectFeatureSets Property

Gets the collection of FeatureSets currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMFeatureSetsCollection FeatureSets { get; }
Public ReadOnly Property FeatureSets As PMFeatureSetsCollection
    Get

Property Value

Type: PMFeatureSetsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Groups Property

PMProjectGroups Property

Gets the collection of Groups currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMGroupsCollection Groups { get; }
Public ReadOnly Property Groups As PMGroupsCollection
    Get

Property Value

Type: PMGroupsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.LevelsAndSets Property

PMProjectLevelsAndSets Property

Gets the collection of Levels and Sets currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMLevelOrSetsCollection LevelsAndSets { get; }
Public ReadOnly Property LevelsAndSets As PMLevelOrSetsCollection
    Get

Property Value

Type: PMLevelOrSetsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.MachineTools Property

PMProjectMachineTools Property

Gets the collection of Machine Tools currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMMachineToolsCollection MachineTools { get; }
Public ReadOnly Property MachineTools As PMMachineToolsCollection
    Get

Property Value

Type: PMMachineToolsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Models Property

PMProjectModels Property

Gets the collection of Models currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMModelsCollection Models { get; }
Public ReadOnly Property Models As PMModelsCollection
    Get

Property Value

Type: PMModelsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.NCPrograms Property

PMProjectNCPrograms Property

Gets the collection of NCPrograms currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMNCProgramsCollection NCPrograms { get; }
Public ReadOnly Property NCPrograms As PMNCProgramsCollection
    Get

Property Value

Type: PMNCProgramsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Patterns Property

PMProjectPatterns Property

Gets the collection of Patterns currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMPatternsCollection Patterns { get; }
Public ReadOnly Property Patterns As PMPatternsCollection
    Get

Property Value

Type: PMPatternsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.StockModels Property

PMProjectStockModels Property

Gets the collection of Stock Models currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMStockModelsCollection StockModels { get; }
Public ReadOnly Property StockModels As PMStockModelsCollection
    Get

Property Value

Type: PMStockModelsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Toolpaths Property

PMProjectToolpaths Property

Gets the collection of Toolpaths currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathsCollection Toolpaths { get; }
Public ReadOnly Property Toolpaths As PMToolpathsCollection
    Get

Property Value

Type: PMToolpathsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Tools Property

PMProjectTools Property

Gets the collection of Tools currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolsCollection Tools { get; }
Public ReadOnly Property Tools As PMToolsCollection
    Get

Property Value

Type: PMToolsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Workplanes Property

PMProjectWorkplanes Property

Gets the collection of Workplanes currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMWorkplanesCollection Workplanes { get; }
Public ReadOnly Property Workplanes As PMWorkplanesCollection
    Get

Property Value

Type: PMWorkplanesCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject Methods

The PMProject type exposes the following members.

Methods
 | Name | Description
Public method | CreateBlock(File) | This operation creates a Block in PowerMILL from a DMT file.
Public method | CreateBlock(String, Double) | This operation creates a Block in PowerMILL from an existing model.
Public method | DeleteBlock | This operation deletes the Block from PowerMill.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImportTemplateFile | Imports the specified PowerMILL Template File.
Public method | Initialise | Initialises the project collections based on what is currently in PowerMILL.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | This operation refreshes the information available in the current project. Refresh should retain any existing items in the lists, add new ones and remove old ones. This function would be used by someone after they have used the "Execute" functionality.
Public method | Save | Saves the project. The project must have been opened from a directory or previously saved using the SaveAs operation otherwise an exception will be thrown. Saves currently loaded project in Powermill.
Public method | SaveAs | Saves the project to the specified directory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.CreateBlock Method

PMProjectCreateBlock Method

Overload List
 | Name | Description
Public method | CreateBlock(File) | This operation creates a Block in PowerMILL from a DMT file.
Public method | CreateBlock(String, Double) | This operation creates a Block in PowerMILL from an existing model.
Top
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.CreateBlock Method (File)

PMProjectCreateBlock Method (File)

This operation creates a Block in PowerMILL from a DMT file.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CreateBlock(
    File blockFile
)
Public Sub CreateBlock (
    blockFile As File
)

Parameters

blockFile
Type: Autodesk.FileSystemFile
The DMT file from which to create the block.
See Also

Reference

PMProject Class
CreateBlock Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.CreateBlock Method (String, Double)

PMProjectCreateBlock Method (String, Double)

This operation creates a Block in PowerMILL from an existing model.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CreateBlock(
    string modelName,
    double blockExpansion
)
Public Sub CreateBlock (
    modelName As String,
    blockExpansion As Double
)

Parameters

modelName
Type: SystemString
The name of the model from which to create the block.
blockExpansion
Type: SystemDouble
Offsets the minimum block size by blockExpansion. If this parameter is 0 the block used to calculat ethe silhouette boundary will have the minimum size to embed the part.
See Also

Reference

PMProject Class
CreateBlock Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.DeleteBlock Method

PMProjectDeleteBlock Method

This operation deletes the Block from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeleteBlock()
Public Sub DeleteBlock
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.ImportTemplateFile Method

PMProjectImportTemplateFile Method

Imports the specified PowerMILL Template File.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ImportTemplateFile(
    File templateFile
)
Public Sub ImportTemplateFile (
    templateFile As File
)

Parameters

templateFile
Type: Autodesk.FileSystemFile
The template file to be imported
Exceptions
Exception | Condition
Exception | If the file does not exist then an exception is thrown.
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Initialise Method

PMProjectInitialise Method

Initialises the project collections based on what is currently in PowerMILL.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Initialise()
Public Sub Initialise
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Refresh Method

PMProjectRefresh Method

This operation refreshes the information available in the current project. Refresh should retain any existing items in the lists, add new ones and remove old ones. This function would be used by someone after they have used the "Execute" functionality.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.Save Method

PMProjectSave Method

Saves the project. The project must have been opened from a directory or previously saved using the SaveAs operation otherwise an exception will be thrown. Saves currently loaded project in Powermill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Save()
Public Sub Save
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject.SaveAs Method

PMProjectSaveAs Method

Saves the project to the specified directory.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SaveAs(
    Directory projectDirectory
)
Public Sub SaveAs (
    projectDirectory As Directory
)

Parameters

projectDirectory
Type: Autodesk.FileSystemDirectory
The directory to save the project to.
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject Fields

The PMProject type exposes the following members.

Fields
 | Name | Description
Protected field | _boundaries | The list of Boundaries in the Project.
Protected field | _featureSets | The list of FeatureSets in the Project.
Protected field | _groups | The list of Groups in the Project.
Protected field | _levelsOrSets | The list of Levels and Sets in the Project.
Protected field | _machineTools | The list of tools in the Project.
Protected field | _models | The list of Models in the Project.
Protected field | _NCPrograms | The list of NC Programs in the Project.
Protected field | _patterns | The list of Patterns in the Project.
Protected field | _powerMILL | The PowerMILL Automation object.
Protected field | _projectDirectory | The directory for the PowerMILL Project.
Protected field | _stockModels | The list of Stock Models in the Project.
Protected field | _toolpaths | The list of Toolpaths in the Project.
Protected field | _tools | The list of Tools in the Project.
Protected field | _workplanes | The list of Workplanes in the Project.
Top
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._boundaries Field

PMProject_boundaries Field

The list of Boundaries in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMBoundariesCollection _boundaries
Protected _boundaries As PMBoundariesCollection

Field Value

Type: PMBoundariesCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._featureSets Field

PMProject_featureSets Field

The list of FeatureSets in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMFeatureSetsCollection _featureSets
Protected _featureSets As PMFeatureSetsCollection

Field Value

Type: PMFeatureSetsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._groups Field

PMProject_groups Field

The list of Groups in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMGroupsCollection _groups
Protected _groups As PMGroupsCollection

Field Value

Type: PMGroupsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._levelsOrSets Field

PMProject_levelsOrSets Field

The list of Levels and Sets in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMLevelOrSetsCollection _levelsOrSets
Protected _levelsOrSets As PMLevelOrSetsCollection

Field Value

Type: PMLevelOrSetsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._machineTools Field

PMProject_machineTools Field

The list of tools in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMMachineToolsCollection _machineTools
Protected _machineTools As PMMachineToolsCollection

Field Value

Type: PMMachineToolsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._models Field

PMProject_models Field

The list of Models in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMModelsCollection _models
Protected _models As PMModelsCollection

Field Value

Type: PMModelsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._NCPrograms Field

PMProject_NCPrograms Field

The list of NC Programs in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMNCProgramsCollection _NCPrograms
Protected _NCPrograms As PMNCProgramsCollection

Field Value

Type: PMNCProgramsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._patterns Field

PMProject_patterns Field

The list of Patterns in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMPatternsCollection _patterns
Protected _patterns As PMPatternsCollection

Field Value

Type: PMPatternsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._powerMILL Field

PMProject_powerMILL Field

The PowerMILL Automation object.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMAutomation _powerMILL
Protected _powerMILL As PMAutomation

Field Value

Type: PMAutomation
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._projectDirectory Field

PMProject_projectDirectory Field

The directory for the PowerMILL Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected Directory _projectDirectory
Protected _projectDirectory As Directory

Field Value

Type: Directory
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._stockModels Field

PMProject_stockModels Field

The list of Stock Models in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMStockModelsCollection _stockModels
Protected _stockModels As PMStockModelsCollection

Field Value

Type: PMStockModelsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._toolpaths Field

PMProject_toolpaths Field

The list of Toolpaths in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMToolpathsCollection _toolpaths
Protected _toolpaths As PMToolpathsCollection

Field Value

Type: PMToolpathsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._tools Field

PMProject_tools Field

The list of Tools in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMToolsCollection _tools
Protected _tools As PMToolsCollection

Field Value

Type: PMToolsCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMProject._workplanes Field

PMProject_workplanes Field

The list of Workplanes in the Project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PMWorkplanesCollection _workplanes
Protected _workplanes As PMWorkplanesCollection

Field Value

Type: PMWorkplanesCollection
See Also

Reference

PMProject Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp Class

PMRamp encapsulate the option that enables you to specify how the tool ramps into the stock.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMRamp

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMRamp
Public Class PMRamp

The PMRamp type exposes the following members.

Constructors
 | Name | Description
Public method | PMRamp | PMRamp encapsulate the option that enables you to specify how the tool ramps into the stock.
Top
Properties
 | Name | Description
Public property | CircleDiameter | The diameter of the circle using tool diameter units (TDUs). Tool diameter units is the distance relative to the tool diameter. So, a 10 mm tool and a TDU of 2, gives an actual value of 20 mm.
Public property | ClosedSegments | When selected, the ramp moves are inserted only into closed PMToolpath segments.
Public property | Extend | Select to extend the ramp moves at the start or end of a toolpath. If you select a RampFollow of PMToolpath, this option extends a Ramp Lead In (or Lead Out) to the end (or start) of its associated toolpath segment.
Public property | FiniteRamp | When selected, enter a maximum ramp length.When deselected, the tool ramps down in a single pass
Public property | FiniteRampLenght | Enter the maximum ramp length. This determines the number of zig and zag moves required in the ramp. This value is represented in TDUs. Tool diameter units is the distance relative to the tool diameter. So, a 10 mm tool and a TDU of 2, gives an actual value of 20 mm.
Public property | Follow | Select how to control the direction of the PMRamp.
Public property | MaxZigAngle | The angle of descent formed as the tool ramps into the block.
Public property | RampHeight | This is measured with respect to the tool axis. For 3-axis machining, the tool axis is the Z axis. For multi-axis machining, Ramp hight height the tool axis is specified on the Tool Axis dialog.
Public property | RampHeightValue | the height of the start of the ramp above the option selected in the Type field
Public property | ZagAngle | When selected, you can enter a different Zag Angle from the Zig Angle. When deselected, the Zag Angle is the same as the Zig Angle. The second angle of descent is used if the tool doesn't reach the start of the toolpath segment in a single pass.
Public property | ZagAngleMaximum | Enter the angle of descent formed as the tool ramps into the block. This is specified in the same way as the Zig Angle.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMRamp Constructor

PMRamp encapsulate the option that enables you to specify how the tool ramps into the stock.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMRamp(
    LeadTypes leadType,
    PMToolpath toolpath
)
Public Sub New (
    leadType As LeadTypes,
    toolpath As PMToolpath
)

Parameters

leadType
Type: Autodesk.ProductInterface.PowerMILLLeadTypes
LeadTypes that PMRamp is based on
toolpath
Type: Autodesk.ProductInterface.PowerMILLPMToolpath
PMToolpath to allow access to powermill macro
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp Properties

The PMRamp type exposes the following members.

Properties
 | Name | Description
Public property | CircleDiameter | The diameter of the circle using tool diameter units (TDUs). Tool diameter units is the distance relative to the tool diameter. So, a 10 mm tool and a TDU of 2, gives an actual value of 20 mm.
Public property | ClosedSegments | When selected, the ramp moves are inserted only into closed PMToolpath segments.
Public property | Extend | Select to extend the ramp moves at the start or end of a toolpath. If you select a RampFollow of PMToolpath, this option extends a Ramp Lead In (or Lead Out) to the end (or start) of its associated toolpath segment.
Public property | FiniteRamp | When selected, enter a maximum ramp length.When deselected, the tool ramps down in a single pass
Public property | FiniteRampLenght | Enter the maximum ramp length. This determines the number of zig and zag moves required in the ramp. This value is represented in TDUs. Tool diameter units is the distance relative to the tool diameter. So, a 10 mm tool and a TDU of 2, gives an actual value of 20 mm.
Public property | Follow | Select how to control the direction of the PMRamp.
Public property | MaxZigAngle | The angle of descent formed as the tool ramps into the block.
Public property | RampHeight | This is measured with respect to the tool axis. For 3-axis machining, the tool axis is the Z axis. For multi-axis machining, Ramp hight height the tool axis is specified on the Tool Axis dialog.
Public property | RampHeightValue | the height of the start of the ramp above the option selected in the Type field
Public property | ZagAngle | When selected, you can enter a different Zag Angle from the Zig Angle. When deselected, the Zag Angle is the same as the Zig Angle. The second angle of descent is used if the tool doesn't reach the start of the toolpath segment in a single pass.
Public property | ZagAngleMaximum | Enter the angle of descent formed as the tool ramps into the block. This is specified in the same way as the Zig Angle.
Top
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.CircleDiameter Property

PMRampCircleDiameter Property

The diameter of the circle using tool diameter units (TDUs). Tool diameter units is the distance relative to the tool diameter. So, a 10 mm tool and a TDU of 2, gives an actual value of 20 mm.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM CircleDiameter { get; set; }
Public Property CircleDiameter As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.ClosedSegments Property

PMRampClosedSegments Property

When selected, the ramp moves are inserted only into closed PMToolpath segments.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool ClosedSegments { get; set; }
Public Property ClosedSegments As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.Extend Property

PMRampExtend Property

Select to extend the ramp moves at the start or end of a toolpath. If you select a RampFollow of PMToolpath, this option extends a Ramp Lead In (or Lead Out) to the end (or start) of its associated toolpath segment.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Extend { get; set; }
Public Property Extend As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.FiniteRamp Property

PMRampFiniteRamp Property

When selected, enter a maximum ramp length.When deselected, the tool ramps down in a single pass

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool FiniteRamp { get; set; }
Public Property FiniteRamp As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.FiniteRampLenght Property

PMRampFiniteRampLenght Property

Enter the maximum ramp length. This determines the number of zig and zag moves required in the ramp. This value is represented in TDUs. Tool diameter units is the distance relative to the tool diameter. So, a 10 mm tool and a TDU of 2, gives an actual value of 20 mm.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM FiniteRampLenght { get; set; }
Public Property FiniteRampLenght As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.Follow Property

PMRampFollow Property

Select how to control the direction of the PMRamp.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public RampFollow Follow { get; set; }
Public Property Follow As RampFollow
    Get
    Set

Property Value

Type: RampFollow
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.MaxZigAngle Property

PMRampMaxZigAngle Property

The angle of descent formed as the tool ramps into the block.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree MaxZigAngle { get; set; }
Public Property MaxZigAngle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.RampHeight Property

PMRampRampHeight Property

This is measured with respect to the tool axis. For 3-axis machining, the tool axis is the Z axis. For multi-axis machining, Ramp hight height the tool axis is specified on the Tool Axis dialog.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public RampHeight RampHeight { get; set; }
Public Property RampHeight As RampHeight
    Get
    Set

Property Value

Type: RampHeight
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.RampHeightValue Property

PMRampRampHeightValue Property

the height of the start of the ramp above the option selected in the Type field

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM RampHeightValue { get; set; }
Public Property RampHeightValue As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.ZagAngle Property

PMRampZagAngle Property

When selected, you can enter a different Zag Angle from the Zig Angle. When deselected, the Zag Angle is the same as the Zig Angle. The second angle of descent is used if the tool doesn't reach the start of the toolpath segment in a single pass.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool ZagAngle { get; set; }
Public Property ZagAngle As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp.ZagAngleMaximum Property

PMRampZagAngleMaximum Property

Enter the angle of descent formed as the tool ramps into the block. This is specified in the same way as the Zig Angle.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree ZagAngleMaximum { get; set; }
Public Property ZagAngleMaximum As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMRamp Methods

The PMRamp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMRamp Class
Autodesk.ProductInterface.PowerMILL Namespace


PMStockModel Class

Captures a Stock Model object in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMStockModel

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMStockModel : PMEntity
Public Class PMStockModel
    Inherits PMEntity

The PMStockModel type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the stock model from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMStockModel Properties

The PMStockModel type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMStockModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMStockModel Methods

The PMStockModel type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the stock model from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMStockModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMStockModel.Delete Method

PMStockModelDelete Method

Deletes the stock model from the active project and from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Remarks
See Also

Reference

PMStockModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMStockModel Fields

The PMStockModel type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMStockModel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMStockModelsCollection Class

Collection of Stock Model objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMStockModel
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMStockModel
Autodesk.ProductInterface.PowerMILLPMStockModelsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMStockModelsCollection : PMEntitiesCollection<PMStockModel>
Public Class PMStockModelsCollection
    Inherits PMEntitiesCollection(Of PMStockModel)

The PMStockModelsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMStockModelsCollection Properties

The PMStockModelsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMStockModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMStockModelsCollection Methods

The PMStockModelsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMStockModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMStockModelsCollection Fields

The PMStockModelsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMStockModelsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken Class

Captures a substitution token. When running PowerMILLMacros occurrences of the token will be replaced with the specified value.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMSubstitutionToken

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMSubstitutionToken
Public Class PMSubstitutionToken

The PMSubstitutionToken type exposes the following members.

Constructors
 | Name | Description
Public method | PMSubstitutionToken | Initialises the token and replacement value to the specified values.
Top
Properties
 | Name | Description
Public property | Token | Gets and sets the Token to search for.
Public property | Value | Gets and sets the Value the Token will be replaced by.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _token | The token to be replaced.
Protected field | _value | The value to replace the token with.
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken Constructor

Initialises the token and replacement value to the specified values.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMSubstitutionToken(
    string token,
    string value
)
Public Sub New (
    token As String,
    value As String
)

Parameters

token
Type: SystemString
The Token to search for.
value
Type: SystemString
The value the Token will be replaced by.
Remarks
See Also

Reference

PMSubstitutionToken Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken Properties

The PMSubstitutionToken type exposes the following members.

Properties
 | Name | Description
Public property | Token | Gets and sets the Token to search for.
Public property | Value | Gets and sets the Value the Token will be replaced by.
Top
See Also

Reference

PMSubstitutionToken Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken.Token Property

PMSubstitutionTokenToken Property

Gets and sets the Token to search for.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Token { get; set; }
Public Property Token As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMSubstitutionToken Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken.Value Property

PMSubstitutionTokenValue Property

Gets and sets the Value the Token will be replaced by.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMSubstitutionToken Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken Methods

The PMSubstitutionToken type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMSubstitutionToken Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken Fields

The PMSubstitutionToken type exposes the following members.

Fields
 | Name | Description
Protected field | _token | The token to be replaced.
Protected field | _value | The value to replace the token with.
Top
See Also

Reference

PMSubstitutionToken Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken._token Field

PMSubstitutionToken_token Field

The token to be replaced.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected string _token
Protected _token As String

Field Value

Type: String
See Also

Reference

PMSubstitutionToken Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionToken._value Field

PMSubstitutionToken_value Field

The value to replace the token with.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected string _value
Protected _value As String

Field Value

Type: String
See Also

Reference

PMSubstitutionToken Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionTokensCollection Class

Collection of SubstitutionTokens that can be used by a PowerMILLMacro
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMSubstitutionToken
Autodesk.ProductInterface.PowerMILLPMSubstitutionTokensCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMSubstitutionTokensCollection : PMCollection<PMSubstitutionToken>
Public Class PMSubstitutionTokensCollection
    Inherits PMCollection(Of PMSubstitutionToken)

The PMSubstitutionTokensCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PMSubstitutionTokensCollection | Initializes a new instance of the PMSubstitutionTokensCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | Item | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds the SubstitutionToken to the collection. If one with the same token already exists then change its replacement value, else it will add the token. (Overrides PMCollectionTAdd(T).)
Public method | Clear | Removes all entities in the list. (Inherited from PMCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified item. (Inherited from PMCollectionT.)
Public method | RemoveAt | Removes the item at the specified index. (Inherited from PMCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionTokensCollection Constructor

Initializes a new instance of the PMSubstitutionTokensCollection class

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMSubstitutionTokensCollection()
Public Sub New
See Also

Reference

PMSubstitutionTokensCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionTokensCollection Properties

The PMSubstitutionTokensCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | Item | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Top
See Also

Reference

PMSubstitutionTokensCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionTokensCollection Methods

The PMSubstitutionTokensCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the SubstitutionToken to the collection. If one with the same token already exists then change its replacement value, else it will add the token. (Overrides PMCollectionTAdd(T).)
Public method | Clear | Removes all entities in the list. (Inherited from PMCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified item. (Inherited from PMCollectionT.)
Public method | RemoveAt | Removes the item at the specified index. (Inherited from PMCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMSubstitutionTokensCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionTokensCollection.Add Method

PMSubstitutionTokensCollectionAdd Method

Adds the SubstitutionToken to the collection. If one with the same token already exists then change its replacement value, else it will add the token.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Add(
    PMSubstitutionToken token
)
Public Overrides Sub Add (
    token As PMSubstitutionToken
)

Parameters

token
Type: Autodesk.ProductInterface.PowerMILLPMSubstitutionToken
The token to add.

Implements

ICollectionTAdd(T)
See Also

Reference

PMSubstitutionTokensCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMSubstitutionTokensCollection Fields

The PMSubstitutionTokensCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Top
See Also

Reference

PMSubstitutionTokensCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool Class

Captures a Tool object in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
More...

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PMTool : PMEntity
Public MustInherit Class PMTool
    Inherits PMEntity

The PMTool type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Overrides PMEntityBoundingBox.)
Public property | Coolant | Gets and sets the tool coolant type.
Public property | Description | Gets and sets the tool description.
Public property | Diameter | Gets and sets the tool diameter.
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name.
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill.
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder.
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank.
Public property | Overhang | Gets and sets the holder overhang.
Public property | ToolNumber | Gets and sets the tool number in PowerMill.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component.
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component.
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component.
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component.
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolBallNosed
Autodesk.ProductInterface.PowerMILLPMToolBarrel
Autodesk.ProductInterface.PowerMILLPMToolDovetail
Autodesk.ProductInterface.PowerMILLPMToolDrill
Autodesk.ProductInterface.PowerMILLPMToolEndMill
Autodesk.ProductInterface.PowerMILLPMToolForm
Autodesk.ProductInterface.PowerMILLPMToolOffCentreTipRadiused
Autodesk.ProductInterface.PowerMILLPMToolRouting
Autodesk.ProductInterface.PowerMILLPMToolTap
Autodesk.ProductInterface.PowerMILLPMToolTaperedSpherical
Autodesk.ProductInterface.PowerMILLPMToolTaperedTipped
Autodesk.ProductInterface.PowerMILLPMToolThreadMill
Autodesk.ProductInterface.PowerMILLPMToolTippedDisc
Autodesk.ProductInterface.PowerMILLPMToolTipRadiused


PMTool Properties

The PMTool type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Overrides PMEntityBoundingBox.)
Public property | Coolant | Gets and sets the tool coolant type.
Public property | Description | Gets and sets the tool description.
Public property | Diameter | Gets and sets the tool diameter.
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name.
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill.
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder.
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank.
Public property | Overhang | Gets and sets the holder overhang.
Public property | ToolNumber | Gets and sets the tool number in PowerMill.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.BoundingBox Property

PMToolBoundingBox Property

BoundingBox property is not valid for this type.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.Coolant Property

PMToolCoolant Property

Gets and sets the tool coolant type.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public CoolantOptions Coolant { get; set; }
Public Property Coolant As CoolantOptions
    Get
    Set

Property Value

Type: CoolantOptions
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.Description Property

PMToolDescription Property

Gets and sets the tool description.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.Diameter Property

PMToolDiameter Property

Gets and sets the tool diameter.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Diameter { get; set; }
Public Property Diameter As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.HolderName Property

PMToolHolderName Property

Gets and sets the tool holder name.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string HolderName { get; set; }
Public Property HolderName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.Length Property

PMToolLength Property

Gets and sets the tool length in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.NumberOfFlutes Property

PMToolNumberOfFlutes Property

Gets and sets the number of flutes in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfFlutes { get; set; }
Public Property NumberOfFlutes As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.NumberOfHolderElements Property

PMToolNumberOfHolderElements Property

Gets and sets the number of elements in the holder.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfHolderElements { get; }
Public ReadOnly Property NumberOfHolderElements As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.NumberOfShankElements Property

PMToolNumberOfShankElements Property

Gets and sets the number of elements in the shank.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfShankElements { get; }
Public ReadOnly Property NumberOfShankElements As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.Overhang Property

PMToolOverhang Property

Gets and sets the holder overhang.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Overhang { get; set; }
Public Property Overhang As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.ToolNumber Property

PMToolToolNumber Property

Gets and sets the tool number in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int ToolNumber { get; set; }
Public Property ToolNumber As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool Methods

The PMTool type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component.
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component.
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component.
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component.
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.Delete Method

PMToolDelete Method

Deletes the tool from the active project and from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Remarks
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.HolderElementLength Method

PMToolHolderElementLength Method

Gets and sets the length of the requested holder component.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM HolderElementLength(
    int index
)
Public Function HolderElementLength (
    index As Integer
) As MM

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMTool.HolderElementLength(System.Int32)"]

Return Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.HolderElementLowerDiameter Method

PMToolHolderElementLowerDiameter Method

Gets and sets the lower diameter of the requested holder component.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM HolderElementLowerDiameter(
    int index
)
Public Function HolderElementLowerDiameter (
    index As Integer
) As MM

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMTool.HolderElementLowerDiameter(System.Int32)"]

Return Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.HolderElementUpperDiameter Method

PMToolHolderElementUpperDiameter Method

Gets and sets the upper diameter of the requested holder component.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM HolderElementUpperDiameter(
    int index
)
Public Function HolderElementUpperDiameter (
    index As Integer
) As MM

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMTool.HolderElementUpperDiameter(System.Int32)"]

Return Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.ShankElementLength Method

PMToolShankElementLength Method

Gets and sets the length of the requested shank component.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ShankElementLength(
    int index
)
Public Function ShankElementLength (
    index As Integer
) As MM

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMTool.ShankElementLength(System.Int32)"]

Return Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.ShankElementLowerDiameter Method

PMToolShankElementLowerDiameter Method

Gets and sets the lower diameter of the requested shank component.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ShankElementLowerDiameter(
    int index
)
Public Function ShankElementLowerDiameter (
    index As Integer
) As MM

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMTool.ShankElementLowerDiameter(System.Int32)"]

Return Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool.ShankElementUpperDiameter Method

PMToolShankElementUpperDiameter Method

Gets and sets the upper diameter of the requested shank component.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ShankElementUpperDiameter(
    int index
)
Public Function ShankElementUpperDiameter (
    index As Integer
) As MM

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMTool.ShankElementUpperDiameter(System.Int32)"]

Return Value

Type: MM
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMTool Fields

The PMTool type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMTool Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolBallNosed Class

Represents a ball nosed tool in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolBallNosed

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolBallNosed : PMTool
Public Class PMToolBallNosed
    Inherits PMTool

The PMToolBallNosed type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolBallNosed Properties

The PMToolBallNosed type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolBallNosed Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolBallNosed Methods

The PMToolBallNosed type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolBallNosed Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolBallNosed Fields

The PMToolBallNosed type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolBallNosed Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolBarrel Class

Represents a barrel tool in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolBarrel

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolBarrel : PMTool
Public Class PMToolBarrel
    Inherits PMTool

The PMToolBarrel type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolBarrel Properties

The PMToolBarrel type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolBarrel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolBarrel Methods

The PMToolBarrel type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolBarrel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolBarrel Fields

The PMToolBarrel type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolBarrel Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolDovetail Class

Represents a Dovetail tool in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolDovetail

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolDovetail : PMTool
Public Class PMToolDovetail
    Inherits PMTool

The PMToolDovetail type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolDovetail Properties

The PMToolDovetail type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolDovetail Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolDovetail Methods

The PMToolDovetail type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolDovetail Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolDovetail Fields

The PMToolDovetail type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolDovetail Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolDrill Class

Represents a drill tool in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolDrill

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolDrill : PMTool
Public Class PMToolDrill
    Inherits PMTool

The PMToolDrill type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | TaperAngle | Gets and sets the taper angle of a Tapered Tipped or Drill tool
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolDrill Properties

The PMToolDrill type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | TaperAngle | Gets and sets the taper angle of a Tapered Tipped or Drill tool
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolDrill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolDrill.TaperAngle Property

PMToolDrillTaperAngle Property

Gets and sets the taper angle of a Tapered Tipped or Drill tool

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree TaperAngle { get; set; }
Public Property TaperAngle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PMToolDrill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolDrill Methods

The PMToolDrill type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolDrill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolDrill Fields

The PMToolDrill type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolDrill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolEndMill Class

Represents a EndMill tool.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolEndMill

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolEndMill : PMTool
Public Class PMToolEndMill
    Inherits PMTool

The PMToolEndMill type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolEndMill Properties

The PMToolEndMill type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolEndMill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolEndMill Methods

The PMToolEndMill type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolEndMill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolEndMill Fields

The PMToolEndMill type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolEndMill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolForm Class

Represents a form tool in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolForm

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolForm : PMTool
Public Class PMToolForm
    Inherits PMTool

The PMToolForm type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolForm Properties

The PMToolForm type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolForm Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolForm Methods

The PMToolForm type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolForm Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolForm Fields

The PMToolForm type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolForm Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolOffCentreTipRadiused Class

Represents a off centre tip radiused tool.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolOffCentreTipRadiused

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolOffCentreTipRadiused : PMTool
Public Class PMToolOffCentreTipRadiused
    Inherits PMTool

The PMToolOffCentreTipRadiused type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolOffCentreTipRadiused Properties

The PMToolOffCentreTipRadiused type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolOffCentreTipRadiused Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolOffCentreTipRadiused Methods

The PMToolOffCentreTipRadiused type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolOffCentreTipRadiused Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolOffCentreTipRadiused Fields

The PMToolOffCentreTipRadiused type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolOffCentreTipRadiused Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath Class

Captures a Toolpath in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
More...

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpath : PMEntity
Public Class PMToolpath
    Inherits PMEntity

The PMToolpath type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath.
Public property | EndPointMethod | Select the location of the end point.
Public property | EndPointPositionX | X Coordinate of the tool at the end
Public property | EndPointPositionY | Y Coordinate of the tool at the end
Public property | EndPointPositionZ | Z Coordinate of the tool at the end
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves.
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads.
Public property | HolderLinksSafety | Gets the safety of the holder during Links.
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated.
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move.
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath
Public property | NumberOfLinks | Gets the number of links in the toolpath
Public property | NumberOfSegments | Gets the number of segments in the toolpath
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves.
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate.
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change.
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath.
Public property | StartPointMethod | Select the location of the start point.
Public property | StartPointPositionX | X Coordinate of the tool at the start
Public property | StartPointPositionY | Y Coordinate of the tool at the start
Public property | StartPointPositionZ | X Coordinate of the tool at the start
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate.
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves.
Public property | ToolDescription | Gets the tool description from PowerMill.
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath.
Public property | ToolFlutes | Gets the tool flutes from PowerMill.
Public property | ToolIndentifier | Gets the tool identifier from PowerMill.
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads.
Public property | ToolLength | Gets the tool length from PowerMill.
Public property | ToolLinksSafety | Gets the safety of the tool during Links.
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill.
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill.
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill.
Public property | ToolType | Gets the type of the tool associated with this toolpath.
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane.
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information.
Public property | WorkplaneName | Gets the workplane from PowerMill.
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath.
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause.
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath.
Public method | MakeInvalid | Invalidates the toolpath.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath.
Public method | SegmentLength |
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position.
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position.
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position.
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position.
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpath3DOffsetFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathAdaptiveAreaClearance
Autodesk.ProductInterface.PowerMILLPMToolpathAlongCornerFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathBladeFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathBladeMachining
Autodesk.ProductInterface.PowerMILLPMToolpathBliskAreaClearance
Autodesk.ProductInterface.PowerMILLPMToolpathChamferMilling
Autodesk.ProductInterface.PowerMILLPMToolpathConstantZFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathCornerClearance
Autodesk.ProductInterface.PowerMILLPMToolpathCornerFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathCurveAreaClearance
Autodesk.ProductInterface.PowerMILLPMToolpathCurveProfile
Autodesk.ProductInterface.PowerMILLPMToolpathCurveProjectionFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathDiscProfileFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathDrilling
Autodesk.ProductInterface.PowerMILLPMToolpathEmbeddedPatternFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathFaceMilling
Autodesk.ProductInterface.PowerMILLPMToolpathFlowlineFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathHubFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathLineProjectionFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathMethod
Autodesk.ProductInterface.PowerMILLPMToolpathMultiPencilCornerFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathOffsetAreaClearance
Autodesk.ProductInterface.PowerMILLPMToolpathOffsetFlatFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathOptimisedConstantZFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathParametricOffsetFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathParametricSpiralFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathPatternFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathPencilCornerFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathPlaneProjectionFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathPlungeMilling
Autodesk.ProductInterface.PowerMILLPMToolpathPointProjectionFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathPortAreaClearance
Autodesk.ProductInterface.PowerMILLPMToolpathPortPlungeFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathPortSpiralFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathProfileAreaClearance
Autodesk.ProductInterface.PowerMILLPMToolpathProfileFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathRadialFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathRasterAreaClearance
Autodesk.ProductInterface.PowerMILLPMToolpathRasterFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathRasterFlatFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathRibMachining
Autodesk.ProductInterface.PowerMILLPMToolpathRotaryFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathSpiralFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathSteepAndShallowFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathStitchCornerFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathSurfaceFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathSurfaceProjectionFinishing
Autodesk.ProductInterface.PowerMILLPMToolpathSwarfMachining
Autodesk.ProductInterface.PowerMILLPMToolpathWireframeProfileMachining
Autodesk.ProductInterface.PowerMILLPMToolpathWireframeSwarfMachining


PMToolpath Properties

The PMToolpath type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath.
Public property | EndPointMethod | Select the location of the end point.
Public property | EndPointPositionX | X Coordinate of the tool at the end
Public property | EndPointPositionY | Y Coordinate of the tool at the end
Public property | EndPointPositionZ | Z Coordinate of the tool at the end
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves.
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads.
Public property | HolderLinksSafety | Gets the safety of the holder during Links.
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated.
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move.
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move.
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath
Public property | NumberOfLinks | Gets the number of links in the toolpath
Public property | NumberOfSegments | Gets the number of segments in the toolpath
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves.
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate.
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change.
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath.
Public property | StartPointMethod | Select the location of the start point.
Public property | StartPointPositionX | X Coordinate of the tool at the start
Public property | StartPointPositionY | Y Coordinate of the tool at the start
Public property | StartPointPositionZ | X Coordinate of the tool at the start
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate.
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves.
Public property | ToolDescription | Gets the tool description from PowerMill.
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath.
Public property | ToolFlutes | Gets the tool flutes from PowerMill.
Public property | ToolIndentifier | Gets the tool identifier from PowerMill.
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads.
Public property | ToolLength | Gets the tool length from PowerMill.
Public property | ToolLinksSafety | Gets the safety of the tool during Links.
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill.
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill.
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill.
Public property | ToolType | Gets the type of the tool associated with this toolpath.
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane.
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information.
Public property | WorkplaneName | Gets the workplane from PowerMill.
Top
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.Connections Property

PMToolpathConnections Property

PMLeads container, and base for common PMLead options

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMConnections Connections { get; }
Public ReadOnly Property Connections As PMConnections
    Get

Property Value

Type: PMConnections
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.CuttingFeed Property

PMToolpathCuttingFeed Property

Cutting feed rate.
Remarks
Any changes made to CuttingFeed value updates FeedPerTooth

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double CuttingFeed { get; set; }
Public Property CuttingFeed As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.EndPointApproachAlong Property

PMToolpathEndPointApproachAlong Property

These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointApproach EndPointApproachAlong { get; set; }
Public Property EndPointApproachAlong As PointApproach
    Get
    Set

Return Value

Type: PointApproach
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.EndPointApproachDistance Property

PMToolpathEndPointApproachDistance Property

Enter the length of the approach move at the retract move at the end of the toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM EndPointApproachDistance { get; set; }
Public Property EndPointApproachDistance As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.EndPointMethod Property

PMToolpathEndPointMethod Property

Select the location of the end point.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public EndPointMethod EndPointMethod { get; set; }
Public Property EndPointMethod As EndPointMethod
    Get
    Set

Return Value

Type: EndPointMethod
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.EndPointPositionX Property

PMToolpathEndPointPositionX Property

X Coordinate of the tool at the end

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double EndPointPositionX { get; }
Public ReadOnly Property EndPointPositionX As Double
    Get

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.EndPointPositionY Property

PMToolpathEndPointPositionY Property

Y Coordinate of the tool at the end

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double EndPointPositionY { get; }
Public ReadOnly Property EndPointPositionY As Double
    Get

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.EndPointPositionZ Property

PMToolpathEndPointPositionZ Property

Z Coordinate of the tool at the end

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double EndPointPositionZ { get; }
Public ReadOnly Property EndPointPositionZ As Double
    Get

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.FeedPerTooth Property

PMToolpathFeedPerTooth Property

Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf.
Remarks
Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM FeedPerTooth { get; set; }
Public Property FeedPerTooth As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.HolderCuttingMovesSafety Property

PMToolpathHolderCuttingMovesSafety Property

Gets safety of the holder during Cutting Moves.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolpathSafety HolderCuttingMovesSafety { get; }
Public ReadOnly Property HolderCuttingMovesSafety As ToolpathSafety
    Get

Property Value

Type: ToolpathSafety
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.HolderLeadsSafety Property

PMToolpathHolderLeadsSafety Property

Gets the safety of the holder during Leads.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolpathSafety HolderLeadsSafety { get; }
Public ReadOnly Property HolderLeadsSafety As ToolpathSafety
    Get

Property Value

Type: ToolpathSafety
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.HolderLinksSafety Property

PMToolpathHolderLinksSafety Property

Gets the safety of the holder during Links.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolpathSafety HolderLinksSafety { get; }
Public ReadOnly Property HolderLinksSafety As ToolpathSafety
    Get

Property Value

Type: ToolpathSafety
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.IsCalculated Property

PMToolpathIsCalculated Property

Gets whether or not this toolpath has been calculated.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsCalculated { get; }
Public ReadOnly Property IsCalculated As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.LeadInFactor Property

PMToolpathLeadInFactor Property

Controls the speed of the tool as it approaches the stock, before beginning a cutting move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double LeadInFactor { get; set; }
Public Property LeadInFactor As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.LeadOutFactor Property

PMToolpathLeadOutFactor Property

Controls the speed of the tool after it leaves the stock, at the end of a cutting move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double LeadOutFactor { get; set; }
Public Property LeadOutFactor As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.NumberOfLeads Property

PMToolpathNumberOfLeads Property

Gets the number of leads in the toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfLeads { get; }
Public ReadOnly Property NumberOfLeads As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.NumberOfLinks Property

PMToolpathNumberOfLinks Property

Gets the number of links in the toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfLinks { get; }
Public ReadOnly Property NumberOfLinks As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.NumberOfSegments Property

PMToolpathNumberOfSegments Property

Gets the number of segments in the toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfSegments { get; }
Public ReadOnly Property NumberOfSegments As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.PlungingFeed Property

PMToolpathPlungingFeed Property

Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double PlungingFeed { get; set; }
Public Property PlungingFeed As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SkimFeed Property

PMToolpathSkimFeed Property

Feed rate for straight line moves from point A to point B.
Remarks
If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double SkimFeed { get; set; }
Public Property SkimFeed As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SpindleSpeed Property

PMToolpathSpindleSpeed Property

Rotation of the spindle, measured in revolutions per minute.
Remarks
If you edit this value then SurfaceSpeed value automatically updates to reflect your change.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double SpindleSpeed { get; set; }
Public Property SpindleSpeed As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.StartPointApproachAlong Property

PMToolpathStartPointApproachAlong Property

These options determine the orientation of the First approach. This is equivalent to the Links functionality

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PointApproach StartPointApproachAlong { get; set; }
Public Property StartPointApproachAlong As PointApproach
    Get
    Set

Return Value

Type: PointApproach
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.StartPointApproachDistance Property

PMToolpathStartPointApproachDistance Property

Enter the length of the approach move at the start of the toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM StartPointApproachDistance { get; set; }
Public Property StartPointApproachDistance As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.StartPointMethod Property

PMToolpathStartPointMethod Property

Select the location of the start point.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public StartPointMethod StartPointMethod { get; set; }
Public Property StartPointMethod As StartPointMethod
    Get
    Set

Return Value

Type: StartPointMethod
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.StartPointPositionX Property

PMToolpathStartPointPositionX Property

X Coordinate of the tool at the start

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double StartPointPositionX { get; }
Public ReadOnly Property StartPointPositionX As Double
    Get

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.StartPointPositionY Property

PMToolpathStartPointPositionY Property

Y Coordinate of the tool at the start

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double StartPointPositionY { get; }
Public ReadOnly Property StartPointPositionY As Double
    Get

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.StartPointPositionZ Property

PMToolpathStartPointPositionZ Property

X Coordinate of the tool at the start

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double StartPointPositionZ { get; }
Public ReadOnly Property StartPointPositionZ As Double
    Get

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SurfaceSpeed Property

PMToolpathSurfaceSpeed Property

Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material.
Remarks
Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double SurfaceSpeed { get; set; }
Public Property SurfaceSpeed As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolCuttingMovesSafety Property

PMToolpathToolCuttingMovesSafety Property

Gets the safety of the tool during Cutting Moves.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolpathSafety ToolCuttingMovesSafety { get; }
Public ReadOnly Property ToolCuttingMovesSafety As ToolpathSafety
    Get

Property Value

Type: ToolpathSafety
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolDescription Property

PMToolpathToolDescription Property

Gets the tool description from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToolDescription { get; }
Public ReadOnly Property ToolDescription As String
    Get

Property Value

Type: String
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolDiameter Property

PMToolpathToolDiameter Property

Gets the diameter of the tool associated with this toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ToolDiameter { get; }
Public ReadOnly Property ToolDiameter As MM
    Get

Property Value

Type: MM
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolFlutes Property

PMToolpathToolFlutes Property

Gets the tool flutes from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int ToolFlutes { get; }
Public ReadOnly Property ToolFlutes As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolIndentifier Property

PMToolpathToolIndentifier Property

Gets the tool identifier from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToolIndentifier { get; }
Public ReadOnly Property ToolIndentifier As String
    Get

Property Value

Type: String
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolLeadsSafety Property

PMToolpathToolLeadsSafety Property

Gets the safety of the tool during Leads.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolpathSafety ToolLeadsSafety { get; }
Public ReadOnly Property ToolLeadsSafety As ToolpathSafety
    Get

Property Value

Type: ToolpathSafety
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolLength Property

PMToolpathToolLength Property

Gets the tool length from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ToolLength { get; }
Public ReadOnly Property ToolLength As MM
    Get

Property Value

Type: MM
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolLinksSafety Property

PMToolpathToolLinksSafety Property

Gets the safety of the tool during Links.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ToolpathSafety ToolLinksSafety { get; }
Public ReadOnly Property ToolLinksSafety As ToolpathSafety
    Get

Property Value

Type: ToolpathSafety
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolName Property

PMToolpathToolName Property

Gets the name of the tool associated with this toolpath from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToolName { get; }
Public ReadOnly Property ToolName As String
    Get

Property Value

Type: String
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolNumber Property

PMToolpathToolNumber Property

Gets the number of the tool associated with this toolpath from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int ToolNumber { get; }
Public ReadOnly Property ToolNumber As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolTipRadius Property

PMToolpathToolTipRadius Property

Gets the tool tip radius from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM ToolTipRadius { get; }
Public ReadOnly Property ToolTipRadius As MM
    Get

Property Value

Type: MM
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolType Property

PMToolpathToolType Property

Gets the type of the tool associated with this toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToolType { get; }
Public ReadOnly Property ToolType As String
    Get

Property Value

Type: String
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolZAxisVector Property

PMToolpathToolZAxisVector Property

Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector ToolZAxisVector { get; }
Public ReadOnly Property ToolZAxisVector As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.TotalCutLength Property

PMToolpathTotalCutLength Property

Gets the total cut length of the Toolpath from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TotalCutLength { get; }
Public ReadOnly Property TotalCutLength As MM
    Get

Property Value

Type: MM
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.WorkplaneInformation Property

PMToolpathWorkplaneInformation Property

Gets workplane information.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMWorkplane WorkplaneInformation { get; }
Public ReadOnly Property WorkplaneInformation As PMWorkplane
    Get

Property Value

Type: PMWorkplane
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.WorkplaneName Property

PMToolpathWorkplaneName Property

Gets the workplane from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string WorkplaneName { get; }
Public ReadOnly Property WorkplaneName As String
    Get

Property Value

Type: String
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath Methods

The PMToolpath type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath.
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause.
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath.
Public method | MakeInvalid | Invalidates the toolpath.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath.
Public method | SegmentLength |
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position.
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position.
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position.
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position.
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.Calculate Method

PMToolpathCalculate Method

Calculates the toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Calculate()
Public Sub Calculate
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.Delete Method

PMToolpathDelete Method

Deletes the toolpath from the active project and from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.DetectHolderCollisions Method

PMToolpathDetectHolderCollisions Method

Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool DetectHolderCollisions()
Public Function DetectHolderCollisions As Boolean

Return Value

Type: Boolean
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.DetectToolGouges Method

PMToolpathDetectToolGouges Method

Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool DetectToolGouges()
Public Function DetectToolGouges As Boolean

Return Value

Type: Boolean
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.HolderSafetyReport Method

PMToolpathHolderSafetyReport Method

Reports the holder safety for the Toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string HolderSafetyReport()
Public Function HolderSafetyReport As String

Return Value

Type: String
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.MakeInvalid Method

PMToolpathMakeInvalid Method

Invalidates the toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MakeInvalid()
Public Sub MakeInvalid
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.NumberOfPointsInSegment Method

PMToolpathNumberOfPointsInSegment Method

Gets the number of points in the specified segment of the toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfPointsInSegment(
    int segmentNumber
)
Public Function NumberOfPointsInSegment (
    segmentNumber As Integer
) As Integer

Parameters

segmentNumber
Type: SystemInt32

[Missing <param name="segmentNumber"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMToolpath.NumberOfPointsInSegment(System.Int32)"]

Return Value

Type: Int32
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SafetyReport Method

PMToolpathSafetyReport Method

Reports the tool and holder safety of the Toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string SafetyReport()
Public Function SafetyReport As String

Return Value

Type: String
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SegmentLength Method

PMToolpathSegmentLength Method

[Missing <summary> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMToolpath.SegmentLength(System.Int32)"]

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM SegmentLength(
    int segmentNumber
)
Public Function SegmentLength (
    segmentNumber As Integer
) As MM

Parameters

segmentNumber
Type: SystemInt32

[Missing <param name="segmentNumber"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PMToolpath.SegmentLength(System.Int32)"]

Return Value

Type: MM
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SetEndPointMethod Method

PMToolpathSetEndPointMethod Method

Overload List
 | Name | Description
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position.
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position.
Top
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SetEndPointMethod Method (EndPointMethod, Point)

PMToolpathSetEndPointMethod Method (EndPointMethod, Point)

Set the tool's end position.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetEndPointMethod(
    EndPointMethod method,
    Point point
)
Public Sub SetEndPointMethod (
    method As EndPointMethod,
    point As Point
)

Parameters

method
Type: Autodesk.ProductInterface.PowerMILLEndPointMethod
EndPointMethod
point
Type: Autodesk.GeometryPoint
tool's point of x,y,z axis
See Also

Reference

PMToolpath Class
SetEndPointMethod Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SetEndPointMethod Method (EndPointMethod, Double, Double, Double)

PMToolpathSetEndPointMethod Method (EndPointMethod, Double, Double, Double)

Set the tool's end position.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetEndPointMethod(
    EndPointMethod method,
    double x = 0,
    double y = 0,
    double z = 0
)
Public Sub SetEndPointMethod (
    method As EndPointMethod,
    Optional x As Double = 0,
    Optional y As Double = 0,
    Optional z As Double = 0
)

Parameters

method
Type: Autodesk.ProductInterface.PowerMILLEndPointMethod
EndPointMethod
x (Optional)
Type: SystemDouble
tool's x position axis
y (Optional)
Type: SystemDouble
tool's y position axis
z (Optional)
Type: SystemDouble
tool's z position axis
See Also

Reference

PMToolpath Class
SetEndPointMethod Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SetStartPointMethod Method

PMToolpathSetStartPointMethod Method

Overload List
 | Name | Description
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position.
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position.
Top
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SetStartPointMethod Method (StartPointMethod, Point)

PMToolpathSetStartPointMethod Method (StartPointMethod, Point)

Set the tool's start position.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetStartPointMethod(
    StartPointMethod method,
    Point point
)
Public Sub SetStartPointMethod (
    method As StartPointMethod,
    point As Point
)

Parameters

method
Type: Autodesk.ProductInterface.PowerMILLStartPointMethod
StartPointMethod
point
Type: Autodesk.GeometryPoint
tool's point of x,y,z axis
See Also

Reference

PMToolpath Class
SetStartPointMethod Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.SetStartPointMethod Method (StartPointMethod, Double, Double, Double)

PMToolpathSetStartPointMethod Method (StartPointMethod, Double, Double, Double)

Set the tool's start position.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetStartPointMethod(
    StartPointMethod method,
    double x = 0,
    double y = 0,
    double z = 0
)
Public Sub SetStartPointMethod (
    method As StartPointMethod,
    Optional x As Double = 0,
    Optional y As Double = 0,
    Optional z As Double = 0
)

Parameters

method
Type: Autodesk.ProductInterface.PowerMILLStartPointMethod
StartPointMethod
x (Optional)
Type: SystemDouble
tool's x position axis
y (Optional)
Type: SystemDouble
tool's y position axis
z (Optional)
Type: SystemDouble
tool's z position axis
See Also

Reference

PMToolpath Class
SetStartPointMethod Overload
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolpathPointOrientationVector Method

PMToolpathToolpathPointOrientationVector Method

Gets the orientation vector for the specified point in the specified segment

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector ToolpathPointOrientationVector(
    int segmentNumber,
    int pointNumber
)
Public Function ToolpathPointOrientationVector (
    segmentNumber As Integer,
    pointNumber As Integer
) As Vector

Parameters

segmentNumber
Type: SystemInt32
The segment number of the toolpath (indexed from zero)
pointNumber
Type: SystemInt32
The point number in the specified segment (indexed from zero)

Return Value

Type: Vector
The orientation vector
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolpathPointPosition Method

PMToolpathToolpathPointPosition Method

Gets the position of the specified point in the specified segment

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point ToolpathPointPosition(
    int segmentNumber,
    int pointNumber
)
Public Function ToolpathPointPosition (
    segmentNumber As Integer,
    pointNumber As Integer
) As Point

Parameters

segmentNumber
Type: SystemInt32
The segment number of the toolpath (indexed from zero)
pointNumber
Type: SystemInt32
The point number in the specified segment (indexed from zero)

Return Value

Type: Point
The point position
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolpathPointToolAxis Method

PMToolpathToolpathPointToolAxis Method

Gets the tool axis vector for the specified point in the specified segment

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector ToolpathPointToolAxis(
    int segmentNumber,
    int pointNumber
)
Public Function ToolpathPointToolAxis (
    segmentNumber As Integer,
    pointNumber As Integer
) As Vector

Parameters

segmentNumber
Type: SystemInt32
The segment number of the toolpath (indexed from zero)
pointNumber
Type: SystemInt32
The point number in the specified segment (indexed from zero)

Return Value

Type: Vector
The tool axis vector
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath.ToolSafetyReport Method

PMToolpathToolSafetyReport Method

Reports the tool safety for the Toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string ToolSafetyReport()
Public Function ToolSafetyReport As String

Return Value

Type: String
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath Fields

The PMToolpath type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpath Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath3DOffsetFinishing Class

Represents a 3D offset finishing toolpath in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpath3DOffsetFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpath3DOffsetFinishing : PMToolpath
Public Class PMToolpath3DOffsetFinishing
    Inherits PMToolpath

The PMToolpath3DOffsetFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath3DOffsetFinishing Properties

The PMToolpath3DOffsetFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpath3DOffsetFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath3DOffsetFinishing Methods

The PMToolpath3DOffsetFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpath3DOffsetFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpath3DOffsetFinishing Fields

The PMToolpath3DOffsetFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpath3DOffsetFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathAdaptiveAreaClearance Class

Represents an adaptive area clearance toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathAdaptiveAreaClearance

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathAdaptiveAreaClearance : PMToolpath
Public Class PMToolpathAdaptiveAreaClearance
    Inherits PMToolpath

The PMToolpathAdaptiveAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathAdaptiveAreaClearance Properties

The PMToolpathAdaptiveAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathAdaptiveAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathAdaptiveAreaClearance Methods

The PMToolpathAdaptiveAreaClearance type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathAdaptiveAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathAdaptiveAreaClearance Fields

The PMToolpathAdaptiveAreaClearance type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathAdaptiveAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathAlongCornerFinishing Class

Represents an along corner finishing toolpath in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathAlongCornerFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathAlongCornerFinishing : PMToolpath
Public Class PMToolpathAlongCornerFinishing
    Inherits PMToolpath

The PMToolpathAlongCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathAlongCornerFinishing Properties

The PMToolpathAlongCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathAlongCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathAlongCornerFinishing Methods

The PMToolpathAlongCornerFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathAlongCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathAlongCornerFinishing Fields

The PMToolpathAlongCornerFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathAlongCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBladeFinishing Class

Represents a blade finishing toolpath in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathBladeFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathBladeFinishing : PMToolpath
Public Class PMToolpathBladeFinishing
    Inherits PMToolpath

The PMToolpathBladeFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBladeFinishing Properties

The PMToolpathBladeFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathBladeFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBladeFinishing Methods

The PMToolpathBladeFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathBladeFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBladeFinishing Fields

The PMToolpathBladeFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathBladeFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBladeMachining Class

Represents a blade machining toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathBladeMachining

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathBladeMachining : PMToolpath
Public Class PMToolpathBladeMachining
    Inherits PMToolpath

The PMToolpathBladeMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBladeMachining Properties

The PMToolpathBladeMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathBladeMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBladeMachining Methods

The PMToolpathBladeMachining type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathBladeMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBladeMachining Fields

The PMToolpathBladeMachining type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathBladeMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBliskAreaClearance Class

Represents a Blisk Area Clearance toolpath in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathBliskAreaClearance

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathBliskAreaClearance : PMToolpath
Public Class PMToolpathBliskAreaClearance
    Inherits PMToolpath

The PMToolpathBliskAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBliskAreaClearance Properties

The PMToolpathBliskAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathBliskAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBliskAreaClearance Methods

The PMToolpathBliskAreaClearance type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathBliskAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathBliskAreaClearance Fields

The PMToolpathBliskAreaClearance type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathBliskAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathChamferMilling Class

Represents a chamfer milling toolpath in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathChamferMilling

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathChamferMilling : PMToolpath
Public Class PMToolpathChamferMilling
    Inherits PMToolpath

The PMToolpathChamferMilling type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathChamferMilling Properties

The PMToolpathChamferMilling type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathChamferMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathChamferMilling Methods

The PMToolpathChamferMilling type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathChamferMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathChamferMilling Fields

The PMToolpathChamferMilling type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathChamferMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathConstantZFinishing Class

Represents a constant Z finishing toolpath in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathConstantZFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathConstantZFinishing : PMToolpath
Public Class PMToolpathConstantZFinishing
    Inherits PMToolpath

The PMToolpathConstantZFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathConstantZFinishing Properties

The PMToolpathConstantZFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathConstantZFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathConstantZFinishing Methods

The PMToolpathConstantZFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathConstantZFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathConstantZFinishing Fields

The PMToolpathConstantZFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathConstantZFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCornerClearance Class

Represents a corner clearance toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathCornerClearance

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathCornerClearance : PMToolpath
Public Class PMToolpathCornerClearance
    Inherits PMToolpath

The PMToolpathCornerClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCornerClearance Properties

The PMToolpathCornerClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathCornerClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCornerClearance Methods

The PMToolpathCornerClearance type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathCornerClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCornerClearance Fields

The PMToolpathCornerClearance type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathCornerClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCornerFinishing Class

Represents a Corner Finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathCornerFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathCornerFinishing : PMToolpath
Public Class PMToolpathCornerFinishing
    Inherits PMToolpath

The PMToolpathCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCornerFinishing Properties

The PMToolpathCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCornerFinishing Methods

The PMToolpathCornerFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCornerFinishing Fields

The PMToolpathCornerFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveAreaClearance Class

Represents a curve area clearance toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathCurveAreaClearance

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathCurveAreaClearance : PMToolpath
Public Class PMToolpathCurveAreaClearance
    Inherits PMToolpath

The PMToolpathCurveAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveAreaClearance Properties

The PMToolpathCurveAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathCurveAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveAreaClearance Methods

The PMToolpathCurveAreaClearance type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathCurveAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveAreaClearance Fields

The PMToolpathCurveAreaClearance type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathCurveAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveProfile Class

Represents a curve profile toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathCurveProfile

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathCurveProfile : PMToolpath
Public Class PMToolpathCurveProfile
    Inherits PMToolpath

The PMToolpathCurveProfile type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveProfile Properties

The PMToolpathCurveProfile type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathCurveProfile Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveProfile Methods

The PMToolpathCurveProfile type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathCurveProfile Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveProfile Fields

The PMToolpathCurveProfile type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathCurveProfile Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveProjectionFinishing Class

Represents a curve projection finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathCurveProjectionFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathCurveProjectionFinishing : PMToolpath
Public Class PMToolpathCurveProjectionFinishing
    Inherits PMToolpath

The PMToolpathCurveProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveProjectionFinishing Properties

The PMToolpathCurveProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathCurveProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveProjectionFinishing Methods

The PMToolpathCurveProjectionFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathCurveProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathCurveProjectionFinishing Fields

The PMToolpathCurveProjectionFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathCurveProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDiscProfileFinishing Class

Represents a disc profile finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathDiscProfileFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathDiscProfileFinishing : PMToolpath
Public Class PMToolpathDiscProfileFinishing
    Inherits PMToolpath

The PMToolpathDiscProfileFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDiscProfileFinishing Properties

The PMToolpathDiscProfileFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathDiscProfileFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDiscProfileFinishing Methods

The PMToolpathDiscProfileFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathDiscProfileFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDiscProfileFinishing Fields

The PMToolpathDiscProfileFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathDiscProfileFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDrilling Class

Represents a drilling toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathDrilling

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathDrilling : PMToolpath
Public Class PMToolpathDrilling
    Inherits PMToolpath

The PMToolpathDrilling type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | CycleType |
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDrilling Properties

The PMToolpathDrilling type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | CycleType |
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathDrilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDrilling.CycleType Property

PMToolpathDrillingCycleType Property

[Missing <summary> documentation for "P:Autodesk.ProductInterface.PowerMILL.PMToolpathDrilling.CycleType"]

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DrillCycleTypes CycleType { get; set; }
Public Property CycleType As DrillCycleTypes
    Get
    Set

Property Value

Type: DrillCycleTypes
See Also

Reference

PMToolpathDrilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDrilling Methods

The PMToolpathDrilling type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathDrilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathDrilling Fields

The PMToolpathDrilling type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathDrilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathEmbeddedPatternFinishing Class

Represents a embedded pattern finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathEmbeddedPatternFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathEmbeddedPatternFinishing : PMToolpath
Public Class PMToolpathEmbeddedPatternFinishing
    Inherits PMToolpath

The PMToolpathEmbeddedPatternFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathEmbeddedPatternFinishing Properties

The PMToolpathEmbeddedPatternFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathEmbeddedPatternFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathEmbeddedPatternFinishing Methods

The PMToolpathEmbeddedPatternFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathEmbeddedPatternFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathEmbeddedPatternFinishing Fields

The PMToolpathEmbeddedPatternFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathEmbeddedPatternFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathFaceMilling Class

Represents a Face Milling toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathFaceMilling

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathFaceMilling : PMToolpath
Public Class PMToolpathFaceMilling
    Inherits PMToolpath

The PMToolpathFaceMilling type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathFaceMilling Properties

The PMToolpathFaceMilling type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathFaceMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathFaceMilling Methods

The PMToolpathFaceMilling type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathFaceMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathFaceMilling Fields

The PMToolpathFaceMilling type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathFaceMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathFlowlineFinishing Class

Represents a flowline finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathFlowlineFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathFlowlineFinishing : PMToolpath
Public Class PMToolpathFlowlineFinishing
    Inherits PMToolpath

The PMToolpathFlowlineFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathFlowlineFinishing Properties

The PMToolpathFlowlineFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathFlowlineFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathFlowlineFinishing Methods

The PMToolpathFlowlineFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathFlowlineFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathFlowlineFinishing Fields

The PMToolpathFlowlineFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathFlowlineFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathHubFinishing Class

Represents a hub finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathHubFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathHubFinishing : PMToolpath
Public Class PMToolpathHubFinishing
    Inherits PMToolpath

The PMToolpathHubFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathHubFinishing Properties

The PMToolpathHubFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathHubFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathHubFinishing Methods

The PMToolpathHubFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathHubFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathHubFinishing Fields

The PMToolpathHubFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathHubFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathLineProjectionFinishing Class

Represents a line projection finishing strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathLineProjectionFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathLineProjectionFinishing : PMToolpath
Public Class PMToolpathLineProjectionFinishing
    Inherits PMToolpath

The PMToolpathLineProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathLineProjectionFinishing Properties

The PMToolpathLineProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathLineProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathLineProjectionFinishing Methods

The PMToolpathLineProjectionFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathLineProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathLineProjectionFinishing Fields

The PMToolpathLineProjectionFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathLineProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathMethod Class

Represents a method toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathMethod

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathMethod : PMToolpath
Public Class PMToolpathMethod
    Inherits PMToolpath

The PMToolpathMethod type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathMethod Properties

The PMToolpathMethod type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathMethod Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathMethod Methods

The PMToolpathMethod type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathMethod Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathMethod Fields

The PMToolpathMethod type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathMethod Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathMultiPencilCornerFinishing Class

Represents a corner multi-pencil finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathMultiPencilCornerFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathMultiPencilCornerFinishing : PMToolpath
Public Class PMToolpathMultiPencilCornerFinishing
    Inherits PMToolpath

The PMToolpathMultiPencilCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathMultiPencilCornerFinishing Properties

The PMToolpathMultiPencilCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathMultiPencilCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathMultiPencilCornerFinishing Methods

The PMToolpathMultiPencilCornerFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathMultiPencilCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathMultiPencilCornerFinishing Fields

The PMToolpathMultiPencilCornerFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathMultiPencilCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOffsetAreaClearance Class

Represents an offset area clearance toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathOffsetAreaClearance

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathOffsetAreaClearance : PMToolpath
Public Class PMToolpathOffsetAreaClearance
    Inherits PMToolpath

The PMToolpathOffsetAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOffsetAreaClearance Properties

The PMToolpathOffsetAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathOffsetAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOffsetAreaClearance Methods

The PMToolpathOffsetAreaClearance type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathOffsetAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOffsetAreaClearance Fields

The PMToolpathOffsetAreaClearance type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathOffsetAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOffsetFlatFinishing Class

Represents an offset flat finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathOffsetFlatFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathOffsetFlatFinishing : PMToolpath
Public Class PMToolpathOffsetFlatFinishing
    Inherits PMToolpath

The PMToolpathOffsetFlatFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOffsetFlatFinishing Properties

The PMToolpathOffsetFlatFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathOffsetFlatFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOffsetFlatFinishing Methods

The PMToolpathOffsetFlatFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathOffsetFlatFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOffsetFlatFinishing Fields

The PMToolpathOffsetFlatFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathOffsetFlatFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOptimisedConstantZFinishing Class

Represents an optimised constant Z finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathOptimisedConstantZFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathOptimisedConstantZFinishing : PMToolpath
Public Class PMToolpathOptimisedConstantZFinishing
    Inherits PMToolpath

The PMToolpathOptimisedConstantZFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOptimisedConstantZFinishing Properties

The PMToolpathOptimisedConstantZFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathOptimisedConstantZFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOptimisedConstantZFinishing Methods

The PMToolpathOptimisedConstantZFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathOptimisedConstantZFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathOptimisedConstantZFinishing Fields

The PMToolpathOptimisedConstantZFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathOptimisedConstantZFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathParametricOffsetFinishing Class

Represents a parametric offset finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathParametricOffsetFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathParametricOffsetFinishing : PMToolpath
Public Class PMToolpathParametricOffsetFinishing
    Inherits PMToolpath

The PMToolpathParametricOffsetFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathParametricOffsetFinishing Properties

The PMToolpathParametricOffsetFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathParametricOffsetFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathParametricOffsetFinishing Methods

The PMToolpathParametricOffsetFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathParametricOffsetFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathParametricOffsetFinishing Fields

The PMToolpathParametricOffsetFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathParametricOffsetFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathParametricSpiralFinishing Class

Represents a parametric spiral finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathParametricSpiralFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathParametricSpiralFinishing : PMToolpath
Public Class PMToolpathParametricSpiralFinishing
    Inherits PMToolpath

The PMToolpathParametricSpiralFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathParametricSpiralFinishing Properties

The PMToolpathParametricSpiralFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathParametricSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathParametricSpiralFinishing Methods

The PMToolpathParametricSpiralFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathParametricSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathParametricSpiralFinishing Fields

The PMToolpathParametricSpiralFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathParametricSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPatternFinishing Class

Represents a pattern finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathPatternFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathPatternFinishing : PMToolpath
Public Class PMToolpathPatternFinishing
    Inherits PMToolpath

The PMToolpathPatternFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPatternFinishing Properties

The PMToolpathPatternFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathPatternFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPatternFinishing Methods

The PMToolpathPatternFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathPatternFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPatternFinishing Fields

The PMToolpathPatternFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathPatternFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPencilCornerFinishing Class

Represents a corner finishing pencil toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathPencilCornerFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathPencilCornerFinishing : PMToolpath
Public Class PMToolpathPencilCornerFinishing
    Inherits PMToolpath

The PMToolpathPencilCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPencilCornerFinishing Properties

The PMToolpathPencilCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathPencilCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPencilCornerFinishing Methods

The PMToolpathPencilCornerFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathPencilCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPencilCornerFinishing Fields

The PMToolpathPencilCornerFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathPencilCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPlaneProjectionFinishing Class

Represents a plane projection finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathPlaneProjectionFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathPlaneProjectionFinishing : PMToolpath
Public Class PMToolpathPlaneProjectionFinishing
    Inherits PMToolpath

The PMToolpathPlaneProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPlaneProjectionFinishing Properties

The PMToolpathPlaneProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathPlaneProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPlaneProjectionFinishing Methods

The PMToolpathPlaneProjectionFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathPlaneProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPlaneProjectionFinishing Fields

The PMToolpathPlaneProjectionFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathPlaneProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPlungeMilling Class

Represents a plunge milling toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathPlungeMilling

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathPlungeMilling : PMToolpath
Public Class PMToolpathPlungeMilling
    Inherits PMToolpath

The PMToolpathPlungeMilling type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPlungeMilling Properties

The PMToolpathPlungeMilling type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathPlungeMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPlungeMilling Methods

The PMToolpathPlungeMilling type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathPlungeMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPlungeMilling Fields

The PMToolpathPlungeMilling type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathPlungeMilling Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPointProjectionFinishing Class

Represents a point projection finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathPointProjectionFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathPointProjectionFinishing : PMToolpath
Public Class PMToolpathPointProjectionFinishing
    Inherits PMToolpath

The PMToolpathPointProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPointProjectionFinishing Properties

The PMToolpathPointProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathPointProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPointProjectionFinishing Methods

The PMToolpathPointProjectionFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathPointProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPointProjectionFinishing Fields

The PMToolpathPointProjectionFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathPointProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortAreaClearance Class

Represents a Port Area Clearance toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathPortAreaClearance

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathPortAreaClearance : PMToolpath
Public Class PMToolpathPortAreaClearance
    Inherits PMToolpath

The PMToolpathPortAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortAreaClearance Properties

The PMToolpathPortAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathPortAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortAreaClearance Methods

The PMToolpathPortAreaClearance type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathPortAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortAreaClearance Fields

The PMToolpathPortAreaClearance type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathPortAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortPlungeFinishing Class

Represents a Port Plunge Finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathPortPlungeFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathPortPlungeFinishing : PMToolpath
Public Class PMToolpathPortPlungeFinishing
    Inherits PMToolpath

The PMToolpathPortPlungeFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortPlungeFinishing Properties

The PMToolpathPortPlungeFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathPortPlungeFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortPlungeFinishing Methods

The PMToolpathPortPlungeFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathPortPlungeFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortPlungeFinishing Fields

The PMToolpathPortPlungeFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathPortPlungeFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortSpiralFinishing Class

Represents a Port Spiral Finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathPortSpiralFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathPortSpiralFinishing : PMToolpath
Public Class PMToolpathPortSpiralFinishing
    Inherits PMToolpath

The PMToolpathPortSpiralFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortSpiralFinishing Properties

The PMToolpathPortSpiralFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathPortSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortSpiralFinishing Methods

The PMToolpathPortSpiralFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathPortSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathPortSpiralFinishing Fields

The PMToolpathPortSpiralFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathPortSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathProfileAreaClearance Class

Represents a profiling area clearance toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathProfileAreaClearance

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathProfileAreaClearance : PMToolpath
Public Class PMToolpathProfileAreaClearance
    Inherits PMToolpath

The PMToolpathProfileAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathProfileAreaClearance Properties

The PMToolpathProfileAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathProfileAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathProfileAreaClearance Methods

The PMToolpathProfileAreaClearance type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathProfileAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathProfileAreaClearance Fields

The PMToolpathProfileAreaClearance type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathProfileAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathProfileFinishing Class

Represents a profile finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathProfileFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathProfileFinishing : PMToolpath
Public Class PMToolpathProfileFinishing
    Inherits PMToolpath

The PMToolpathProfileFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathProfileFinishing Properties

The PMToolpathProfileFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathProfileFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathProfileFinishing Methods

The PMToolpathProfileFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathProfileFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathProfileFinishing Fields

The PMToolpathProfileFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathProfileFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRadialFinishing Class

Represents a radial finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathRadialFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathRadialFinishing : PMToolpath
Public Class PMToolpathRadialFinishing
    Inherits PMToolpath

The PMToolpathRadialFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRadialFinishing Properties

The PMToolpathRadialFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathRadialFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRadialFinishing Methods

The PMToolpathRadialFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathRadialFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRadialFinishing Fields

The PMToolpathRadialFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathRadialFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterAreaClearance Class

Represents a raster area clearance toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathRasterAreaClearance

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathRasterAreaClearance : PMToolpath
Public Class PMToolpathRasterAreaClearance
    Inherits PMToolpath

The PMToolpathRasterAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterAreaClearance Properties

The PMToolpathRasterAreaClearance type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathRasterAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterAreaClearance Methods

The PMToolpathRasterAreaClearance type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathRasterAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterAreaClearance Fields

The PMToolpathRasterAreaClearance type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathRasterAreaClearance Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterFinishing Class

Represents a raster finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathRasterFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathRasterFinishing : PMToolpath
Public Class PMToolpathRasterFinishing
    Inherits PMToolpath

The PMToolpathRasterFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterFinishing Properties

The PMToolpathRasterFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathRasterFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterFinishing Methods

The PMToolpathRasterFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathRasterFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterFinishing Fields

The PMToolpathRasterFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathRasterFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterFlatFinishing Class

Represents a raster flat finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathRasterFlatFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathRasterFlatFinishing : PMToolpath
Public Class PMToolpathRasterFlatFinishing
    Inherits PMToolpath

The PMToolpathRasterFlatFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterFlatFinishing Properties

The PMToolpathRasterFlatFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathRasterFlatFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterFlatFinishing Methods

The PMToolpathRasterFlatFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathRasterFlatFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRasterFlatFinishing Fields

The PMToolpathRasterFlatFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathRasterFlatFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRibMachining Class

Represents a rib machining toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathRibMachining

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathRibMachining : PMToolpath
Public Class PMToolpathRibMachining
    Inherits PMToolpath

The PMToolpathRibMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRibMachining Properties

The PMToolpathRibMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathRibMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRibMachining Methods

The PMToolpathRibMachining type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathRibMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRibMachining Fields

The PMToolpathRibMachining type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathRibMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRotaryFinishing Class

Represents a rotary finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathRotaryFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathRotaryFinishing : PMToolpath
Public Class PMToolpathRotaryFinishing
    Inherits PMToolpath

The PMToolpathRotaryFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRotaryFinishing Properties

The PMToolpathRotaryFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathRotaryFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRotaryFinishing Methods

The PMToolpathRotaryFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathRotaryFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathRotaryFinishing Fields

The PMToolpathRotaryFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathRotaryFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection Class

Collection of Toolpaths objects in the Active PowerMILL Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMToolpath
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathsCollection : PMEntitiesCollection<PMToolpath>
Public Class PMToolpathsCollection
    Inherits PMEntitiesCollection(Of PMToolpath)

The PMToolpathsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Create3DOffsetFinishingToolpath | Creates a 3DOffsetFinishing Toolpath
Public method | CreateAdaptiveAreaClearanceToolpath | Creates an AdaptiveAreaClearance Toolpath
Public method | CreateAlongCornerFinishingToolpath | Creates an AlongCornerFinishing Toolpath
Public method | CreateBladeFinishingToolpath | Creates a BladeFinishing Toolpath
Public method | CreateBladeMachiningToolpath | Creates a Blade Machining Toolpath
Public method | CreateBliskAreaClearanceToolpath | Creates a BliskAreaClearance Toolpath
Public method | CreateBreakChipDrillingToolpath | Creates a BreakChipDrilling Toolpath
Public method | CreateChamferMillingToolpath | Creates a ChamferMilling Toolpath
Public method | CreateConstantZFinishingToolpath | Creates a ConstantZFinishing Toolpath
Public method | CreateCornerClearanceToolpath | Creates a CornerClearance Toolpath
Public method | CreateCornerFinishingToolpath | Creates a CornerFinishing Toolpath
Public method | CreateCounterBoreDrillingToolpath | Creates a CounterBoreDrilling Toolpath
Public method | CreateCurveAreaClearanceToolpath | Creates a CurveAreaClearance Toolpath
Public method | CreateCurveProfileToolpath | Creates a CurveProfile Toolpath
Public method | CreateCurveProjectionFinishingToolpath | Creates a CurveProjectionFinishing Toolpath
Public method | CreateDeepDrillDrillingToolpath | Creates a DeepDrillDrilling Toolpath
Public method | CreateDiscProfileFinishingToolpath | Creates a DiscProfileFinishing Toolpath
Public method | CreateDrillingToolpath | Creates a Drilling Toolpath
Public method | CreateEmbeddedPatternFinishingToolpath | Creates a EmbeddedPatternFinishing Toolpath
Public method | CreateExternalThreadDrillingToolpath | Creates a ExternalThreadDrilling Toolpath
Public method | CreateFaceMillingToolpath | Creates a FaceMilling Toolpath
Public method | CreateFineBoringDrillingToolpath | Creates a FineBoringDrilling Toolpath
Public method | CreateFlowlineFinishingToolpath | Creates a FlowlineFinishing Toolpath
Public method | CreateHelicalDrillingToolpath | Creates a HelicalDrilling Toolpath
Public method | CreateHubFinishingToolpath | Creates a HubFinishing Toolpath
Public method | CreateLineProjectionFinishingToolpath | Creates a LineProjectionFinishing Toolpath
Public method | CreateMultiPencilCornerFinishingToolpath | Creates a MultiPencilCornerFinishing Toolpath
Public method | CreateOffsetAreaClearanceToolpath | Creates an OffsetAreaClearance Toolpath
Public method | CreateOffsetFlatFinishingToolpath | Creates an OffsetFlatFinishing Toolpath
Public method | CreateOptimisedConstantZFinishingToolpath | Creates an OptimisedConstantZFinishing Toolpath
Public method | CreateParametricOffsetFinishingToolpath | Creates a ParametricOffsetFinishing Toolpath
Public method | CreateParametricSpiralFinishingToolpath | Creates a ParametricSpiralFinishing Toolpath
Public method | CreatePatternFinishingToolpath | Creates a PatternFinishing Toolpath
Public method | CreatePencilCornerFinishingToolpath | Creates a PencilCornerFinishing Toolpath
Public method | CreatePlaneProjectionFinishingToolpath | Creates a PlaneProjectionFinishing Toolpath
Public method | CreatePlungeMillingToolpath | Creates a PlungeMilling Toolpath
Public method | CreatePointProjectionFinishingToolpath | Creates a PointProjectionFinishing Toolpath
Public method | CreatePortAreaClearanceToolpath | Creates a PortAreaClearance Toolpath
Public method | CreatePortPlungeFinishingToolpath | Creates a PortPlungeFinishing Toolpath
Public method | CreatePortSpiralFinishingToolpath | Creates a PortSpiralFinishing Toolpath
Public method | CreateProfileAreaClearanceToolpath | Creates a ProfileAreaClearance Toolpath
Public method | CreateProfileDrillingToolpath | Creates a ProfileDrilling Toolpath
Public method | CreateProfileFinishingToolpath | Creates a ProfileFinishing Toolpath
Public method | CreateRadialFinishingToolpath | Creates a RadialFinishing Toolpath
Public method | CreateRasterAreaClearanceToolpath | Creates a RasterAreaClearance Toolpath
Public method | CreateRasterFinishingToolpath | Creates a RasterFinishing Toolpath
Public method | CreateRasterFlatFinishingToolpath | Creates a RasterFlatFinishing Toolpath
Public method | CreateReamDrillingToolpath | Creates a ReamDrilling Toolpath
Public method | CreateRibMachiningToolpath | Creates a Rib Machining Toolpath
Public method | CreateRigidTappingDrillingToolpath | Creates a RigidTappingDrilling Toolpath
Public method | CreateRotaryFinishingToolpath | Creates a RotaryFinishing Toolpath
Public method | CreateSinglePeckDrillingToolpath | Creates a SinglePeckDrilling Toolpath
Public method | CreateSpiralFinishingToolpath | Creates a SpiralFinishing Toolpath
Public method | CreateSteepAndShallowFinishingToolpath | Creates a SteepAndShallowFinishingToolpath
Public method | CreateStitchCornerFinishingToolpath | Creates a StitchCornerFinishing Toolpath
Public method | CreateSurfaceFinishingToolpath | Creates a SurfaceFinishing Toolpath
Public method | CreateSurfaceProjectionFinishingToolpath | Creates a SurfaceProjectionFinishingToolpath
Public method | CreateSwarfMachiningToolpath | Creates a SwarfMachining Toolpath
Public method | CreateTapDrillingToolpath | Creates a TapDrilling Toolpath
Public method | CreateThreadMillDrillingToolpath | Creates a ThreadMillDrilling Toolpath
Public method | CreateWireframeProfileMachiningToolpath | Creates a WireframeProfileMachining Toolpath
Public method | CreateWireframeSwarfMachiningToolpath | Creates a WireframeSwarfMachining Toolpath
Public method | DeleteToolpath | Deletes the toolpath from active project.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection Properties

The PMToolpathsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection Methods

The PMToolpathsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | Create3DOffsetFinishingToolpath | Creates a 3DOffsetFinishing Toolpath
Public method | CreateAdaptiveAreaClearanceToolpath | Creates an AdaptiveAreaClearance Toolpath
Public method | CreateAlongCornerFinishingToolpath | Creates an AlongCornerFinishing Toolpath
Public method | CreateBladeFinishingToolpath | Creates a BladeFinishing Toolpath
Public method | CreateBladeMachiningToolpath | Creates a Blade Machining Toolpath
Public method | CreateBliskAreaClearanceToolpath | Creates a BliskAreaClearance Toolpath
Public method | CreateBreakChipDrillingToolpath | Creates a BreakChipDrilling Toolpath
Public method | CreateChamferMillingToolpath | Creates a ChamferMilling Toolpath
Public method | CreateConstantZFinishingToolpath | Creates a ConstantZFinishing Toolpath
Public method | CreateCornerClearanceToolpath | Creates a CornerClearance Toolpath
Public method | CreateCornerFinishingToolpath | Creates a CornerFinishing Toolpath
Public method | CreateCounterBoreDrillingToolpath | Creates a CounterBoreDrilling Toolpath
Public method | CreateCurveAreaClearanceToolpath | Creates a CurveAreaClearance Toolpath
Public method | CreateCurveProfileToolpath | Creates a CurveProfile Toolpath
Public method | CreateCurveProjectionFinishingToolpath | Creates a CurveProjectionFinishing Toolpath
Public method | CreateDeepDrillDrillingToolpath | Creates a DeepDrillDrilling Toolpath
Public method | CreateDiscProfileFinishingToolpath | Creates a DiscProfileFinishing Toolpath
Public method | CreateDrillingToolpath | Creates a Drilling Toolpath
Public method | CreateEmbeddedPatternFinishingToolpath | Creates a EmbeddedPatternFinishing Toolpath
Public method | CreateExternalThreadDrillingToolpath | Creates a ExternalThreadDrilling Toolpath
Public method | CreateFaceMillingToolpath | Creates a FaceMilling Toolpath
Public method | CreateFineBoringDrillingToolpath | Creates a FineBoringDrilling Toolpath
Public method | CreateFlowlineFinishingToolpath | Creates a FlowlineFinishing Toolpath
Public method | CreateHelicalDrillingToolpath | Creates a HelicalDrilling Toolpath
Public method | CreateHubFinishingToolpath | Creates a HubFinishing Toolpath
Public method | CreateLineProjectionFinishingToolpath | Creates a LineProjectionFinishing Toolpath
Public method | CreateMultiPencilCornerFinishingToolpath | Creates a MultiPencilCornerFinishing Toolpath
Public method | CreateOffsetAreaClearanceToolpath | Creates an OffsetAreaClearance Toolpath
Public method | CreateOffsetFlatFinishingToolpath | Creates an OffsetFlatFinishing Toolpath
Public method | CreateOptimisedConstantZFinishingToolpath | Creates an OptimisedConstantZFinishing Toolpath
Public method | CreateParametricOffsetFinishingToolpath | Creates a ParametricOffsetFinishing Toolpath
Public method | CreateParametricSpiralFinishingToolpath | Creates a ParametricSpiralFinishing Toolpath
Public method | CreatePatternFinishingToolpath | Creates a PatternFinishing Toolpath
Public method | CreatePencilCornerFinishingToolpath | Creates a PencilCornerFinishing Toolpath
Public method | CreatePlaneProjectionFinishingToolpath | Creates a PlaneProjectionFinishing Toolpath
Public method | CreatePlungeMillingToolpath | Creates a PlungeMilling Toolpath
Public method | CreatePointProjectionFinishingToolpath | Creates a PointProjectionFinishing Toolpath
Public method | CreatePortAreaClearanceToolpath | Creates a PortAreaClearance Toolpath
Public method | CreatePortPlungeFinishingToolpath | Creates a PortPlungeFinishing Toolpath
Public method | CreatePortSpiralFinishingToolpath | Creates a PortSpiralFinishing Toolpath
Public method | CreateProfileAreaClearanceToolpath | Creates a ProfileAreaClearance Toolpath
Public method | CreateProfileDrillingToolpath | Creates a ProfileDrilling Toolpath
Public method | CreateProfileFinishingToolpath | Creates a ProfileFinishing Toolpath
Public method | CreateRadialFinishingToolpath | Creates a RadialFinishing Toolpath
Public method | CreateRasterAreaClearanceToolpath | Creates a RasterAreaClearance Toolpath
Public method | CreateRasterFinishingToolpath | Creates a RasterFinishing Toolpath
Public method | CreateRasterFlatFinishingToolpath | Creates a RasterFlatFinishing Toolpath
Public method | CreateReamDrillingToolpath | Creates a ReamDrilling Toolpath
Public method | CreateRibMachiningToolpath | Creates a Rib Machining Toolpath
Public method | CreateRigidTappingDrillingToolpath | Creates a RigidTappingDrilling Toolpath
Public method | CreateRotaryFinishingToolpath | Creates a RotaryFinishing Toolpath
Public method | CreateSinglePeckDrillingToolpath | Creates a SinglePeckDrilling Toolpath
Public method | CreateSpiralFinishingToolpath | Creates a SpiralFinishing Toolpath
Public method | CreateSteepAndShallowFinishingToolpath | Creates a SteepAndShallowFinishingToolpath
Public method | CreateStitchCornerFinishingToolpath | Creates a StitchCornerFinishing Toolpath
Public method | CreateSurfaceFinishingToolpath | Creates a SurfaceFinishing Toolpath
Public method | CreateSurfaceProjectionFinishingToolpath | Creates a SurfaceProjectionFinishingToolpath
Public method | CreateSwarfMachiningToolpath | Creates a SwarfMachining Toolpath
Public method | CreateTapDrillingToolpath | Creates a TapDrilling Toolpath
Public method | CreateThreadMillDrillingToolpath | Creates a ThreadMillDrilling Toolpath
Public method | CreateWireframeProfileMachiningToolpath | Creates a WireframeProfileMachining Toolpath
Public method | CreateWireframeSwarfMachiningToolpath | Creates a WireframeSwarfMachining Toolpath
Public method | DeleteToolpath | Deletes the toolpath from active project.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.Create3DOffsetFinishingToolpath Method

PMToolpathsCollectionCreate3DOffsetFinishingToolpath Method

Creates a 3DOffsetFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpath3DOffsetFinishing Create3DOffsetFinishingToolpath()
Public Function Create3DOffsetFinishingToolpath As PMToolpath3DOffsetFinishing

Return Value

Type: PMToolpath3DOffsetFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateAdaptiveAreaClearanceToolpath Method

PMToolpathsCollectionCreateAdaptiveAreaClearanceToolpath Method

Creates an AdaptiveAreaClearance Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathAdaptiveAreaClearance CreateAdaptiveAreaClearanceToolpath()
Public Function CreateAdaptiveAreaClearanceToolpath As PMToolpathAdaptiveAreaClearance

Return Value

Type: PMToolpathAdaptiveAreaClearance
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateAlongCornerFinishingToolpath Method

PMToolpathsCollectionCreateAlongCornerFinishingToolpath Method

Creates an AlongCornerFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathAlongCornerFinishing CreateAlongCornerFinishingToolpath()
Public Function CreateAlongCornerFinishingToolpath As PMToolpathAlongCornerFinishing

Return Value

Type: PMToolpathAlongCornerFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateBladeFinishingToolpath Method

PMToolpathsCollectionCreateBladeFinishingToolpath Method

Creates a BladeFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathBladeFinishing CreateBladeFinishingToolpath()
Public Function CreateBladeFinishingToolpath As PMToolpathBladeFinishing

Return Value

Type: PMToolpathBladeFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateBladeMachiningToolpath Method

PMToolpathsCollectionCreateBladeMachiningToolpath Method

Creates a Blade Machining Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathBladeMachining CreateBladeMachiningToolpath()
Public Function CreateBladeMachiningToolpath As PMToolpathBladeMachining

Return Value

Type: PMToolpathBladeMachining
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateBliskAreaClearanceToolpath Method

PMToolpathsCollectionCreateBliskAreaClearanceToolpath Method

Creates a BliskAreaClearance Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathBliskAreaClearance CreateBliskAreaClearanceToolpath()
Public Function CreateBliskAreaClearanceToolpath As PMToolpathBliskAreaClearance

Return Value

Type: PMToolpathBliskAreaClearance
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateBreakChipDrillingToolpath Method

PMToolpathsCollectionCreateBreakChipDrillingToolpath Method

Creates a BreakChipDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateBreakChipDrillingToolpath()
Public Function CreateBreakChipDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateChamferMillingToolpath Method

PMToolpathsCollectionCreateChamferMillingToolpath Method

Creates a ChamferMilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathChamferMilling CreateChamferMillingToolpath()
Public Function CreateChamferMillingToolpath As PMToolpathChamferMilling

Return Value

Type: PMToolpathChamferMilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateConstantZFinishingToolpath Method

PMToolpathsCollectionCreateConstantZFinishingToolpath Method

Creates a ConstantZFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathConstantZFinishing CreateConstantZFinishingToolpath()
Public Function CreateConstantZFinishingToolpath As PMToolpathConstantZFinishing

Return Value

Type: PMToolpathConstantZFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateCornerClearanceToolpath Method

PMToolpathsCollectionCreateCornerClearanceToolpath Method

Creates a CornerClearance Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathCornerClearance CreateCornerClearanceToolpath()
Public Function CreateCornerClearanceToolpath As PMToolpathCornerClearance

Return Value

Type: PMToolpathCornerClearance
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateCornerFinishingToolpath Method

PMToolpathsCollectionCreateCornerFinishingToolpath Method

Creates a CornerFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathCornerFinishing CreateCornerFinishingToolpath()
Public Function CreateCornerFinishingToolpath As PMToolpathCornerFinishing

Return Value

Type: PMToolpathCornerFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateCounterBoreDrillingToolpath Method

PMToolpathsCollectionCreateCounterBoreDrillingToolpath Method

Creates a CounterBoreDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateCounterBoreDrillingToolpath()
Public Function CreateCounterBoreDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateCurveAreaClearanceToolpath Method

PMToolpathsCollectionCreateCurveAreaClearanceToolpath Method

Creates a CurveAreaClearance Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathCurveAreaClearance CreateCurveAreaClearanceToolpath()
Public Function CreateCurveAreaClearanceToolpath As PMToolpathCurveAreaClearance

Return Value

Type: PMToolpathCurveAreaClearance
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateCurveProfileToolpath Method

PMToolpathsCollectionCreateCurveProfileToolpath Method

Creates a CurveProfile Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathCurveProfile CreateCurveProfileToolpath()
Public Function CreateCurveProfileToolpath As PMToolpathCurveProfile

Return Value

Type: PMToolpathCurveProfile
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateCurveProjectionFinishingToolpath Method

PMToolpathsCollectionCreateCurveProjectionFinishingToolpath Method

Creates a CurveProjectionFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathCurveProjectionFinishing CreateCurveProjectionFinishingToolpath()
Public Function CreateCurveProjectionFinishingToolpath As PMToolpathCurveProjectionFinishing

Return Value

Type: PMToolpathCurveProjectionFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateDeepDrillDrillingToolpath Method

PMToolpathsCollectionCreateDeepDrillDrillingToolpath Method

Creates a DeepDrillDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateDeepDrillDrillingToolpath()
Public Function CreateDeepDrillDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateDiscProfileFinishingToolpath Method

PMToolpathsCollectionCreateDiscProfileFinishingToolpath Method

Creates a DiscProfileFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDiscProfileFinishing CreateDiscProfileFinishingToolpath()
Public Function CreateDiscProfileFinishingToolpath As PMToolpathDiscProfileFinishing

Return Value

Type: PMToolpathDiscProfileFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateDrillingToolpath Method

PMToolpathsCollectionCreateDrillingToolpath Method

Creates a Drilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateDrillingToolpath()
Public Function CreateDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateEmbeddedPatternFinishingToolpath Method

PMToolpathsCollectionCreateEmbeddedPatternFinishingToolpath Method

Creates a EmbeddedPatternFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathEmbeddedPatternFinishing CreateEmbeddedPatternFinishingToolpath()
Public Function CreateEmbeddedPatternFinishingToolpath As PMToolpathEmbeddedPatternFinishing

Return Value

Type: PMToolpathEmbeddedPatternFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateExternalThreadDrillingToolpath Method

PMToolpathsCollectionCreateExternalThreadDrillingToolpath Method

Creates a ExternalThreadDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateExternalThreadDrillingToolpath()
Public Function CreateExternalThreadDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateFaceMillingToolpath Method

PMToolpathsCollectionCreateFaceMillingToolpath Method

Creates a FaceMilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathFaceMilling CreateFaceMillingToolpath()
Public Function CreateFaceMillingToolpath As PMToolpathFaceMilling

Return Value

Type: PMToolpathFaceMilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateFineBoringDrillingToolpath Method

PMToolpathsCollectionCreateFineBoringDrillingToolpath Method

Creates a FineBoringDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateFineBoringDrillingToolpath()
Public Function CreateFineBoringDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateFlowlineFinishingToolpath Method

PMToolpathsCollectionCreateFlowlineFinishingToolpath Method

Creates a FlowlineFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathFlowlineFinishing CreateFlowlineFinishingToolpath()
Public Function CreateFlowlineFinishingToolpath As PMToolpathFlowlineFinishing

Return Value

Type: PMToolpathFlowlineFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateHelicalDrillingToolpath Method

PMToolpathsCollectionCreateHelicalDrillingToolpath Method

Creates a HelicalDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateHelicalDrillingToolpath()
Public Function CreateHelicalDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateHubFinishingToolpath Method

PMToolpathsCollectionCreateHubFinishingToolpath Method

Creates a HubFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathHubFinishing CreateHubFinishingToolpath()
Public Function CreateHubFinishingToolpath As PMToolpathHubFinishing

Return Value

Type: PMToolpathHubFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateLineProjectionFinishingToolpath Method

PMToolpathsCollectionCreateLineProjectionFinishingToolpath Method

Creates a LineProjectionFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathLineProjectionFinishing CreateLineProjectionFinishingToolpath()
Public Function CreateLineProjectionFinishingToolpath As PMToolpathLineProjectionFinishing

Return Value

Type: PMToolpathLineProjectionFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateMultiPencilCornerFinishingToolpath Method

PMToolpathsCollectionCreateMultiPencilCornerFinishingToolpath Method

Creates a MultiPencilCornerFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathMultiPencilCornerFinishing CreateMultiPencilCornerFinishingToolpath()
Public Function CreateMultiPencilCornerFinishingToolpath As PMToolpathMultiPencilCornerFinishing

Return Value

Type: PMToolpathMultiPencilCornerFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateOffsetAreaClearanceToolpath Method

PMToolpathsCollectionCreateOffsetAreaClearanceToolpath Method

Creates an OffsetAreaClearance Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathOffsetAreaClearance CreateOffsetAreaClearanceToolpath()
Public Function CreateOffsetAreaClearanceToolpath As PMToolpathOffsetAreaClearance

Return Value

Type: PMToolpathOffsetAreaClearance
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateOffsetFlatFinishingToolpath Method

PMToolpathsCollectionCreateOffsetFlatFinishingToolpath Method

Creates an OffsetFlatFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathOffsetFlatFinishing CreateOffsetFlatFinishingToolpath()
Public Function CreateOffsetFlatFinishingToolpath As PMToolpathOffsetFlatFinishing

Return Value

Type: PMToolpathOffsetFlatFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateOptimisedConstantZFinishingToolpath Method

PMToolpathsCollectionCreateOptimisedConstantZFinishingToolpath Method

Creates an OptimisedConstantZFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathOptimisedConstantZFinishing CreateOptimisedConstantZFinishingToolpath()
Public Function CreateOptimisedConstantZFinishingToolpath As PMToolpathOptimisedConstantZFinishing

Return Value

Type: PMToolpathOptimisedConstantZFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateParametricOffsetFinishingToolpath Method

PMToolpathsCollectionCreateParametricOffsetFinishingToolpath Method

Creates a ParametricOffsetFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathParametricOffsetFinishing CreateParametricOffsetFinishingToolpath()
Public Function CreateParametricOffsetFinishingToolpath As PMToolpathParametricOffsetFinishing

Return Value

Type: PMToolpathParametricOffsetFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateParametricSpiralFinishingToolpath Method

PMToolpathsCollectionCreateParametricSpiralFinishingToolpath Method

Creates a ParametricSpiralFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathParametricSpiralFinishing CreateParametricSpiralFinishingToolpath()
Public Function CreateParametricSpiralFinishingToolpath As PMToolpathParametricSpiralFinishing

Return Value

Type: PMToolpathParametricSpiralFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreatePatternFinishingToolpath Method

PMToolpathsCollectionCreatePatternFinishingToolpath Method

Creates a PatternFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathPatternFinishing CreatePatternFinishingToolpath()
Public Function CreatePatternFinishingToolpath As PMToolpathPatternFinishing

Return Value

Type: PMToolpathPatternFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreatePencilCornerFinishingToolpath Method

PMToolpathsCollectionCreatePencilCornerFinishingToolpath Method

Creates a PencilCornerFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathPencilCornerFinishing CreatePencilCornerFinishingToolpath()
Public Function CreatePencilCornerFinishingToolpath As PMToolpathPencilCornerFinishing

Return Value

Type: PMToolpathPencilCornerFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreatePlaneProjectionFinishingToolpath Method

PMToolpathsCollectionCreatePlaneProjectionFinishingToolpath Method

Creates a PlaneProjectionFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathPlaneProjectionFinishing CreatePlaneProjectionFinishingToolpath()
Public Function CreatePlaneProjectionFinishingToolpath As PMToolpathPlaneProjectionFinishing

Return Value

Type: PMToolpathPlaneProjectionFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreatePlungeMillingToolpath Method

PMToolpathsCollectionCreatePlungeMillingToolpath Method

Creates a PlungeMilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathPlungeMilling CreatePlungeMillingToolpath()
Public Function CreatePlungeMillingToolpath As PMToolpathPlungeMilling

Return Value

Type: PMToolpathPlungeMilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreatePointProjectionFinishingToolpath Method

PMToolpathsCollectionCreatePointProjectionFinishingToolpath Method

Creates a PointProjectionFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathPointProjectionFinishing CreatePointProjectionFinishingToolpath()
Public Function CreatePointProjectionFinishingToolpath As PMToolpathPointProjectionFinishing

Return Value

Type: PMToolpathPointProjectionFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreatePortAreaClearanceToolpath Method

PMToolpathsCollectionCreatePortAreaClearanceToolpath Method

Creates a PortAreaClearance Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathPortAreaClearance CreatePortAreaClearanceToolpath()
Public Function CreatePortAreaClearanceToolpath As PMToolpathPortAreaClearance

Return Value

Type: PMToolpathPortAreaClearance
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreatePortPlungeFinishingToolpath Method

PMToolpathsCollectionCreatePortPlungeFinishingToolpath Method

Creates a PortPlungeFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathPortPlungeFinishing CreatePortPlungeFinishingToolpath()
Public Function CreatePortPlungeFinishingToolpath As PMToolpathPortPlungeFinishing

Return Value

Type: PMToolpathPortPlungeFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreatePortSpiralFinishingToolpath Method

PMToolpathsCollectionCreatePortSpiralFinishingToolpath Method

Creates a PortSpiralFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathPortSpiralFinishing CreatePortSpiralFinishingToolpath()
Public Function CreatePortSpiralFinishingToolpath As PMToolpathPortSpiralFinishing

Return Value

Type: PMToolpathPortSpiralFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateProfileAreaClearanceToolpath Method

PMToolpathsCollectionCreateProfileAreaClearanceToolpath Method

Creates a ProfileAreaClearance Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathProfileAreaClearance CreateProfileAreaClearanceToolpath()
Public Function CreateProfileAreaClearanceToolpath As PMToolpathProfileAreaClearance

Return Value

Type: PMToolpathProfileAreaClearance
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateProfileDrillingToolpath Method

PMToolpathsCollectionCreateProfileDrillingToolpath Method

Creates a ProfileDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateProfileDrillingToolpath()
Public Function CreateProfileDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateProfileFinishingToolpath Method

PMToolpathsCollectionCreateProfileFinishingToolpath Method

Creates a ProfileFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathProfileFinishing CreateProfileFinishingToolpath()
Public Function CreateProfileFinishingToolpath As PMToolpathProfileFinishing

Return Value

Type: PMToolpathProfileFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateRadialFinishingToolpath Method

PMToolpathsCollectionCreateRadialFinishingToolpath Method

Creates a RadialFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathRadialFinishing CreateRadialFinishingToolpath()
Public Function CreateRadialFinishingToolpath As PMToolpathRadialFinishing

Return Value

Type: PMToolpathRadialFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateRasterAreaClearanceToolpath Method

PMToolpathsCollectionCreateRasterAreaClearanceToolpath Method

Creates a RasterAreaClearance Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathRasterAreaClearance CreateRasterAreaClearanceToolpath()
Public Function CreateRasterAreaClearanceToolpath As PMToolpathRasterAreaClearance

Return Value

Type: PMToolpathRasterAreaClearance
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateRasterFinishingToolpath Method

PMToolpathsCollectionCreateRasterFinishingToolpath Method

Creates a RasterFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathRasterFinishing CreateRasterFinishingToolpath()
Public Function CreateRasterFinishingToolpath As PMToolpathRasterFinishing

Return Value

Type: PMToolpathRasterFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateRasterFlatFinishingToolpath Method

PMToolpathsCollectionCreateRasterFlatFinishingToolpath Method

Creates a RasterFlatFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathRasterFlatFinishing CreateRasterFlatFinishingToolpath()
Public Function CreateRasterFlatFinishingToolpath As PMToolpathRasterFlatFinishing

Return Value

Type: PMToolpathRasterFlatFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateReamDrillingToolpath Method

PMToolpathsCollectionCreateReamDrillingToolpath Method

Creates a ReamDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateReamDrillingToolpath()
Public Function CreateReamDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateRibMachiningToolpath Method

PMToolpathsCollectionCreateRibMachiningToolpath Method

Creates a Rib Machining Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathRibMachining CreateRibMachiningToolpath()
Public Function CreateRibMachiningToolpath As PMToolpathRibMachining

Return Value

Type: PMToolpathRibMachining
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateRigidTappingDrillingToolpath Method

PMToolpathsCollectionCreateRigidTappingDrillingToolpath Method

Creates a RigidTappingDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateRigidTappingDrillingToolpath()
Public Function CreateRigidTappingDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateRotaryFinishingToolpath Method

PMToolpathsCollectionCreateRotaryFinishingToolpath Method

Creates a RotaryFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathRotaryFinishing CreateRotaryFinishingToolpath()
Public Function CreateRotaryFinishingToolpath As PMToolpathRotaryFinishing

Return Value

Type: PMToolpathRotaryFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateSinglePeckDrillingToolpath Method

PMToolpathsCollectionCreateSinglePeckDrillingToolpath Method

Creates a SinglePeckDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateSinglePeckDrillingToolpath()
Public Function CreateSinglePeckDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateSpiralFinishingToolpath Method

PMToolpathsCollectionCreateSpiralFinishingToolpath Method

Creates a SpiralFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathSpiralFinishing CreateSpiralFinishingToolpath()
Public Function CreateSpiralFinishingToolpath As PMToolpathSpiralFinishing

Return Value

Type: PMToolpathSpiralFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateSteepAndShallowFinishingToolpath Method

PMToolpathsCollectionCreateSteepAndShallowFinishingToolpath Method

Creates a SteepAndShallowFinishingToolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathSteepAndShallowFinishing CreateSteepAndShallowFinishingToolpath()
Public Function CreateSteepAndShallowFinishingToolpath As PMToolpathSteepAndShallowFinishing

Return Value

Type: PMToolpathSteepAndShallowFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateStitchCornerFinishingToolpath Method

PMToolpathsCollectionCreateStitchCornerFinishingToolpath Method

Creates a StitchCornerFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathStitchCornerFinishing CreateStitchCornerFinishingToolpath()
Public Function CreateStitchCornerFinishingToolpath As PMToolpathStitchCornerFinishing

Return Value

Type: PMToolpathStitchCornerFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateSurfaceFinishingToolpath Method

PMToolpathsCollectionCreateSurfaceFinishingToolpath Method

Creates a SurfaceFinishing Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathSurfaceFinishing CreateSurfaceFinishingToolpath()
Public Function CreateSurfaceFinishingToolpath As PMToolpathSurfaceFinishing

Return Value

Type: PMToolpathSurfaceFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateSurfaceProjectionFinishingToolpath Method

PMToolpathsCollectionCreateSurfaceProjectionFinishingToolpath Method

Creates a SurfaceProjectionFinishingToolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathSurfaceProjectionFinishing CreateSurfaceProjectionFinishingToolpath()
Public Function CreateSurfaceProjectionFinishingToolpath As PMToolpathSurfaceProjectionFinishing

Return Value

Type: PMToolpathSurfaceProjectionFinishing
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateSwarfMachiningToolpath Method

PMToolpathsCollectionCreateSwarfMachiningToolpath Method

Creates a SwarfMachining Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathSwarfMachining CreateSwarfMachiningToolpath()
Public Function CreateSwarfMachiningToolpath As PMToolpathSwarfMachining

Return Value

Type: PMToolpathSwarfMachining
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateTapDrillingToolpath Method

PMToolpathsCollectionCreateTapDrillingToolpath Method

Creates a TapDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateTapDrillingToolpath()
Public Function CreateTapDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateThreadMillDrillingToolpath Method

PMToolpathsCollectionCreateThreadMillDrillingToolpath Method

Creates a ThreadMillDrilling Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathDrilling CreateThreadMillDrillingToolpath()
Public Function CreateThreadMillDrillingToolpath As PMToolpathDrilling

Return Value

Type: PMToolpathDrilling
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateWireframeProfileMachiningToolpath Method

PMToolpathsCollectionCreateWireframeProfileMachiningToolpath Method

Creates a WireframeProfileMachining Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathWireframeProfileMachining CreateWireframeProfileMachiningToolpath()
Public Function CreateWireframeProfileMachiningToolpath As PMToolpathWireframeProfileMachining

Return Value

Type: PMToolpathWireframeProfileMachining
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.CreateWireframeSwarfMachiningToolpath Method

PMToolpathsCollectionCreateWireframeSwarfMachiningToolpath Method

Creates a WireframeSwarfMachining Toolpath

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolpathWireframeSwarfMachining CreateWireframeSwarfMachiningToolpath()
Public Function CreateWireframeSwarfMachiningToolpath As PMToolpathWireframeSwarfMachining

Return Value

Type: PMToolpathWireframeSwarfMachining
The created toolpath
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection.DeleteToolpath Method

PMToolpathsCollectionDeleteToolpath Method

Deletes the toolpath from active project.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeleteToolpath(
    string toolpathName,
    bool useNoQuibble = false
)
Public Sub DeleteToolpath (
    toolpathName As String,
    Optional useNoQuibble As Boolean = false
)

Parameters

toolpathName
Type: SystemString
The toolpath name.
useNoQuibble (Optional)
Type: SystemBoolean
Force deletion
Remarks
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathsCollection Fields

The PMToolpathsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMToolpathsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSpiralFinishing Class

Represents a Spiral Finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathSpiralFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathSpiralFinishing : PMToolpath
Public Class PMToolpathSpiralFinishing
    Inherits PMToolpath

The PMToolpathSpiralFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSpiralFinishing Properties

The PMToolpathSpiralFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSpiralFinishing Methods

The PMToolpathSpiralFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSpiralFinishing Fields

The PMToolpathSpiralFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathSpiralFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSteepAndShallowFinishing Class

Represents a steep and shallow finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathSteepAndShallowFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathSteepAndShallowFinishing : PMToolpath
Public Class PMToolpathSteepAndShallowFinishing
    Inherits PMToolpath

The PMToolpathSteepAndShallowFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSteepAndShallowFinishing Properties

The PMToolpathSteepAndShallowFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathSteepAndShallowFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSteepAndShallowFinishing Methods

The PMToolpathSteepAndShallowFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathSteepAndShallowFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSteepAndShallowFinishing Fields

The PMToolpathSteepAndShallowFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathSteepAndShallowFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathStitchCornerFinishing Class

Represents a Stitch Corner Finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathStitchCornerFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathStitchCornerFinishing : PMToolpath
Public Class PMToolpathStitchCornerFinishing
    Inherits PMToolpath

The PMToolpathStitchCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathStitchCornerFinishing Properties

The PMToolpathStitchCornerFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathStitchCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathStitchCornerFinishing Methods

The PMToolpathStitchCornerFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathStitchCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathStitchCornerFinishing Fields

The PMToolpathStitchCornerFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathStitchCornerFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSurfaceFinishing Class

Represents a surface finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathSurfaceFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathSurfaceFinishing : PMToolpath
Public Class PMToolpathSurfaceFinishing
    Inherits PMToolpath

The PMToolpathSurfaceFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSurfaceFinishing Properties

The PMToolpathSurfaceFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathSurfaceFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSurfaceFinishing Methods

The PMToolpathSurfaceFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathSurfaceFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSurfaceFinishing Fields

The PMToolpathSurfaceFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathSurfaceFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSurfaceProjectionFinishing Class

Represents a Surface projection finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathSurfaceProjectionFinishing

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathSurfaceProjectionFinishing : PMToolpath
Public Class PMToolpathSurfaceProjectionFinishing
    Inherits PMToolpath

The PMToolpathSurfaceProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSurfaceProjectionFinishing Properties

The PMToolpathSurfaceProjectionFinishing type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathSurfaceProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSurfaceProjectionFinishing Methods

The PMToolpathSurfaceProjectionFinishing type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathSurfaceProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSurfaceProjectionFinishing Fields

The PMToolpathSurfaceProjectionFinishing type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathSurfaceProjectionFinishing Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSwarfMachining Class

Represents a swarf machining toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathSwarfMachining

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathSwarfMachining : PMToolpath
Public Class PMToolpathSwarfMachining
    Inherits PMToolpath

The PMToolpathSwarfMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSwarfMachining Properties

The PMToolpathSwarfMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathSwarfMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSwarfMachining Methods

The PMToolpathSwarfMachining type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathSwarfMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathSwarfMachining Fields

The PMToolpathSwarfMachining type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathSwarfMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathWireframeProfileMachining Class

Represents a Wireframe Profile Machining toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathWireframeProfileMachining

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathWireframeProfileMachining : PMToolpath
Public Class PMToolpathWireframeProfileMachining
    Inherits PMToolpath

The PMToolpathWireframeProfileMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathWireframeProfileMachining Properties

The PMToolpathWireframeProfileMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathWireframeProfileMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathWireframeProfileMachining Methods

The PMToolpathWireframeProfileMachining type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathWireframeProfileMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathWireframeProfileMachining Fields

The PMToolpathWireframeProfileMachining type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathWireframeProfileMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathWireframeSwarfMachining Class

Represents a wireframe swarf finishing toolpath strategy in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMToolpath
Autodesk.ProductInterface.PowerMILLPMToolpathWireframeSwarfMachining

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolpathWireframeSwarfMachining : PMToolpath
Public Class PMToolpathWireframeSwarfMachining
    Inherits PMToolpath

The PMToolpathWireframeSwarfMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathWireframeSwarfMachining Properties

The PMToolpathWireframeSwarfMachining type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Get the bounding box of the entity (Inherited from PMEntity.)
Public property | Connections | PMLeads container, and base for common PMLead options (Inherited from PMToolpath.)
Public property | CuttingFeed | Cutting feed rate. Remarks Any changes made to CuttingFeed value updates FeedPerTooth (Inherited from PMToolpath.)
Public property | EndPointApproachAlong | These options determine the orientation of the Final retract moves. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | EndPointApproachDistance | Enter the length of the approach move at the retract move at the end of the toolpath. (Inherited from PMToolpath.)
Public property | EndPointMethod | Select the location of the end point. (Inherited from PMToolpath.)
Public property | EndPointPositionX | X Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionY | Y Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | EndPointPositionZ | Z Coordinate of the tool at the end (Inherited from PMToolpath.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | FeedPerTooth | Cutting feed per tooth, FeedPerTooth is determined by the construction of the tool, and may be limited by the strength of the cutting edges or the capacity of the tool to remove swarf. Remarks Any changes made to FeedPerTooth value recalculates CuttingFeed Rate and PlungingFeed Rate (Inherited from PMToolpath.)
Public property | HolderCuttingMovesSafety | Gets safety of the holder during Cutting Moves. (Inherited from PMToolpath.)
Public property | HolderLeadsSafety | Gets the safety of the holder during Leads. (Inherited from PMToolpath.)
Public property | HolderLinksSafety | Gets the safety of the holder during Links. (Inherited from PMToolpath.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | IsCalculated | Gets whether or not this toolpath has been calculated. (Inherited from PMToolpath.)
Public property | LeadInFactor | Controls the speed of the tool as it approaches the stock, before beginning a cutting move. (Inherited from PMToolpath.)
Public property | LeadOutFactor | Controls the speed of the tool after it leaves the stock, at the end of a cutting move. (Inherited from PMToolpath.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfLeads | Gets the number of leads in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfLinks | Gets the number of links in the toolpath (Inherited from PMToolpath.)
Public property | NumberOfSegments | Gets the number of segments in the toolpath (Inherited from PMToolpath.)
Public property | PlungingFeed | Speed of the tool when entering the material ready for its cutting moves. When 3-axis machining, these are vertical moves. (Inherited from PMToolpath.)
Public property | SkimFeed | Feed rate for straight line moves from point A to point B. Remarks If everything is totally safe, the machine moves at rapid which usually appears as G0 in the output file. For skim moves, the machine performs a linear move (which G0 moves do not guarantee), normally G1 in the output file, at a very high feed rate. (Inherited from PMToolpath.)
Public property | SpindleSpeed | Rotation of the spindle, measured in revolutions per minute. Remarks If you edit this value then SurfaceSpeed value automatically updates to reflect your change. (Inherited from PMToolpath.)
Public property | StartPointApproachAlong | These options determine the orientation of the First approach. This is equivalent to the Links functionality (Inherited from PMToolpath.)
Public property | StartPointApproachDistance | Enter the length of the approach move at the start of the toolpath. (Inherited from PMToolpath.)
Public property | StartPointMethod | Select the location of the start point. (Inherited from PMToolpath.)
Public property | StartPointPositionX | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionY | Y Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | StartPointPositionZ | X Coordinate of the tool at the start (Inherited from PMToolpath.)
Public property | SurfaceSpeed | Speed of the tool during material removal, SurfaceSpeed represents the rate at which the cutting edges of the tool can be driven through the material. Remarks Any changes made to SurfaceSpeed value recalculates SpindleSpeed, CuttingFeed Rate, and PlungingFeed Rate. (Inherited from PMToolpath.)
Public property | ToolCuttingMovesSafety | Gets the safety of the tool during Cutting Moves. (Inherited from PMToolpath.)
Public property | ToolDescription | Gets the tool description from PowerMill. (Inherited from PMToolpath.)
Public property | ToolDiameter | Gets the diameter of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolFlutes | Gets the tool flutes from PowerMill. (Inherited from PMToolpath.)
Public property | ToolIndentifier | Gets the tool identifier from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLeadsSafety | Gets the safety of the tool during Leads. (Inherited from PMToolpath.)
Public property | ToolLength | Gets the tool length from PowerMill. (Inherited from PMToolpath.)
Public property | ToolLinksSafety | Gets the safety of the tool during Links. (Inherited from PMToolpath.)
Public property | ToolName | Gets the name of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolNumber | Gets the number of the tool associated with this toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | ToolTipRadius | Gets the tool tip radius from PowerMill. (Inherited from PMToolpath.)
Public property | ToolType | Gets the type of the tool associated with this toolpath. (Inherited from PMToolpath.)
Public property | ToolZAxisVector | Gets Tool Z axis vector based on the workplane of the toolpath. Returns 0 0 1 if can not find workplane. (Inherited from PMToolpath.)
Public property | TotalCutLength | Gets the total cut length of the Toolpath from PowerMill. (Inherited from PMToolpath.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | WorkplaneInformation | Gets workplane information. (Inherited from PMToolpath.)
Public property | WorkplaneName | Gets the workplane from PowerMill. (Inherited from PMToolpath.)
Top
See Also

Reference

PMToolpathWireframeSwarfMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathWireframeSwarfMachining Methods

The PMToolpathWireframeSwarfMachining type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the toolpath. (Inherited from PMToolpath.)
Public method | Delete | Deletes the toolpath from the active project and from PowerMill. (Inherited from PMToolpath.)
Public method | DetectHolderCollisions | Checks if there are any collisions. If it returns true the three status indicators can then be inspected to determine the cause (Inherited from PMToolpath.)
Public method | DetectToolGouges | Detects if there are any gouges. If it returns true the three status indicators can then be inspected to determine the cause. (Inherited from PMToolpath.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderSafetyReport | Reports the holder safety for the Toolpath. (Inherited from PMToolpath.)
Public method | MakeInvalid | Invalidates the toolpath. (Inherited from PMToolpath.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfPointsInSegment | Gets the number of points in the specified segment of the toolpath (Inherited from PMToolpath.)
Public method | SafetyReport | Reports the tool and holder safety of the Toolpath. (Inherited from PMToolpath.)
Public method | SegmentLength | (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Point) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetEndPointMethod(EndPointMethod, Double, Double, Double) | Set the tool's end position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Point) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | SetStartPointMethod(StartPointMethod, Double, Double, Double) | Set the tool's start position. (Inherited from PMToolpath.)
Public method | ToolpathPointOrientationVector | Gets the orientation vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointPosition | Gets the position of the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolpathPointToolAxis | Gets the tool axis vector for the specified point in the specified segment (Inherited from PMToolpath.)
Public method | ToolSafetyReport | Reports the tool safety for the Toolpath. (Inherited from PMToolpath.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolpathWireframeSwarfMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolpathWireframeSwarfMachining Fields

The PMToolpathWireframeSwarfMachining type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolpathWireframeSwarfMachining Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolRouting Class

Represents a routing tool in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolRouting

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolRouting : PMTool
Public Class PMToolRouting
    Inherits PMTool

The PMToolRouting type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolRouting Properties

The PMToolRouting type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolRouting Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolRouting Methods

The PMToolRouting type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolRouting Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolRouting Fields

The PMToolRouting type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolRouting Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection Class

Collection of Tool objects in the Active PowerMILL Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMTool
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMTool
Autodesk.ProductInterface.PowerMILLPMToolsCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolsCollection : PMEntitiesCollection<PMTool>
Public Class PMToolsCollection
    Inherits PMEntitiesCollection(Of PMTool)

The PMToolsCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PMToolsCollection | Initialises the item.
Top
Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateBallNosedTool | Creates a new ball nosed tool.
Public method | CreateBarrelTool | Creates a new barrel tool.
Public method | CreateDovetailTool | Creates a new dovetail tool.
Public method | CreateDrillTool | Creates a new drill tool.
Public method | CreateEndMillTool | Creates a new end mill tool.
Public method | CreateFormTool | Creates a new form tool.
Public method | CreateOffCentreTipRadiusedTool | Creates a new off centre tip radiused tool.
Public method | CreateRoutingTool | Creates a new routing tool.
Public method | CreateTaperedSphericalTool | Creates a new tapered spherical tool.
Public method | CreateTaperedTippedTool | Creates a new tapered tipped tool.
Public method | CreateTapTool | Creates a new tap tool.
Public method | CreateThreadMillTool | Creates a new thread mill tool.
Public method | CreateTippedDiscTool | Creates a new tipped disc tool.
Public method | CreateTipRadiusedTool | Creates a new tip radiused tool.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection Constructor

Initialises the item.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolsCollection(
    PMAutomation powerMILL
)
Public Sub New (
    powerMILL As PMAutomation
)

Parameters

powerMILL
Type: Autodesk.ProductInterface.PowerMILLPMAutomation
The base instance to interact with PowerMILL.
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection Properties

The PMToolsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection Methods

The PMToolsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateBallNosedTool | Creates a new ball nosed tool.
Public method | CreateBarrelTool | Creates a new barrel tool.
Public method | CreateDovetailTool | Creates a new dovetail tool.
Public method | CreateDrillTool | Creates a new drill tool.
Public method | CreateEndMillTool | Creates a new end mill tool.
Public method | CreateFormTool | Creates a new form tool.
Public method | CreateOffCentreTipRadiusedTool | Creates a new off centre tip radiused tool.
Public method | CreateRoutingTool | Creates a new routing tool.
Public method | CreateTaperedSphericalTool | Creates a new tapered spherical tool.
Public method | CreateTaperedTippedTool | Creates a new tapered tipped tool.
Public method | CreateTapTool | Creates a new tap tool.
Public method | CreateThreadMillTool | Creates a new thread mill tool.
Public method | CreateTippedDiscTool | Creates a new tipped disc tool.
Public method | CreateTipRadiusedTool | Creates a new tip radiused tool.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateBallNosedTool Method

PMToolsCollectionCreateBallNosedTool Method

Creates a new ball nosed tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolBallNosed CreateBallNosedTool()
Public Function CreateBallNosedTool As PMToolBallNosed

Return Value

Type: PMToolBallNosed
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateBarrelTool Method

PMToolsCollectionCreateBarrelTool Method

Creates a new barrel tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolBarrel CreateBarrelTool()
Public Function CreateBarrelTool As PMToolBarrel

Return Value

Type: PMToolBarrel
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateDovetailTool Method

PMToolsCollectionCreateDovetailTool Method

Creates a new dovetail tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolDovetail CreateDovetailTool()
Public Function CreateDovetailTool As PMToolDovetail

Return Value

Type: PMToolDovetail
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateDrillTool Method

PMToolsCollectionCreateDrillTool Method

Creates a new drill tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolDrill CreateDrillTool()
Public Function CreateDrillTool As PMToolDrill

Return Value

Type: PMToolDrill
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateEndMillTool Method

PMToolsCollectionCreateEndMillTool Method

Creates a new end mill tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolEndMill CreateEndMillTool()
Public Function CreateEndMillTool As PMToolEndMill

Return Value

Type: PMToolEndMill
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateFormTool Method

PMToolsCollectionCreateFormTool Method

Creates a new form tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolForm CreateFormTool()
Public Function CreateFormTool As PMToolForm

Return Value

Type: PMToolForm
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateOffCentreTipRadiusedTool Method

PMToolsCollectionCreateOffCentreTipRadiusedTool Method

Creates a new off centre tip radiused tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolOffCentreTipRadiused CreateOffCentreTipRadiusedTool()
Public Function CreateOffCentreTipRadiusedTool As PMToolOffCentreTipRadiused

Return Value

Type: PMToolOffCentreTipRadiused
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateRoutingTool Method

PMToolsCollectionCreateRoutingTool Method

Creates a new routing tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolRouting CreateRoutingTool()
Public Function CreateRoutingTool As PMToolRouting

Return Value

Type: PMToolRouting
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateTaperedSphericalTool Method

PMToolsCollectionCreateTaperedSphericalTool Method

Creates a new tapered spherical tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolTaperedSpherical CreateTaperedSphericalTool()
Public Function CreateTaperedSphericalTool As PMToolTaperedSpherical

Return Value

Type: PMToolTaperedSpherical
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateTaperedTippedTool Method

PMToolsCollectionCreateTaperedTippedTool Method

Creates a new tapered tipped tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolTaperedTipped CreateTaperedTippedTool()
Public Function CreateTaperedTippedTool As PMToolTaperedTipped

Return Value

Type: PMToolTaperedTipped
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateTapTool Method

PMToolsCollectionCreateTapTool Method

Creates a new tap tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolTap CreateTapTool()
Public Function CreateTapTool As PMToolTap

Return Value

Type: PMToolTap
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateThreadMillTool Method

PMToolsCollectionCreateThreadMillTool Method

Creates a new thread mill tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolThreadMill CreateThreadMillTool()
Public Function CreateThreadMillTool As PMToolThreadMill

Return Value

Type: PMToolThreadMill
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateTippedDiscTool Method

PMToolsCollectionCreateTippedDiscTool Method

Creates a new tipped disc tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolTippedDisc CreateTippedDiscTool()
Public Function CreateTippedDiscTool As PMToolTippedDisc

Return Value

Type: PMToolTippedDisc
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection.CreateTipRadiusedTool Method

PMToolsCollectionCreateTipRadiusedTool Method

Creates a new tip radiused tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMToolTipRadiused CreateTipRadiusedTool()
Public Function CreateTipRadiusedTool As PMToolTipRadiused

Return Value

Type: PMToolTipRadiused
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolsCollection Fields

The PMToolsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMToolsCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTap Class

Represents a tapping tool in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolTap

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolTap : PMTool
Public Class PMToolTap
    Inherits PMTool

The PMToolTap type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | Pitch | Gets and sets the pitch of a Thread Mill or Tapping tool
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolTap Properties

The PMToolTap type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | Pitch | Gets and sets the pitch of a Thread Mill or Tapping tool
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTap Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTap.Pitch Property

PMToolTapPitch Property

Gets and sets the pitch of a Thread Mill or Tapping tool

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Pitch { set; }
Public WriteOnly Property Pitch As MM
    Set

Property Value

Type: MM
See Also

Reference

PMToolTap Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTap Methods

The PMToolTap type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolTap Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTap Fields

The PMToolTap type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTap Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedSpherical Class

Represents a tapered spherical tool in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolTaperedSpherical

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolTaperedSpherical : PMTool
Public Class PMToolTaperedSpherical
    Inherits PMTool

The PMToolTaperedSpherical type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedSpherical Properties

The PMToolTaperedSpherical type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTaperedSpherical Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedSpherical Methods

The PMToolTaperedSpherical type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolTaperedSpherical Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedSpherical Fields

The PMToolTaperedSpherical type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTaperedSpherical Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedTipped Class

Represents a tapered tipped tool in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolTaperedTipped

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolTaperedTipped : PMTool
Public Class PMToolTaperedTipped
    Inherits PMTool

The PMToolTaperedTipped type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | TaperAngle | Gets and sets the taper angle of a Tapered Tipped tool.
Public property | TaperDiameter | Gets and sets the taper diameter of a Tapered Tipped tool.
Public property | TaperHeight | Gets and sets the taper height of a Tapered Tipped tool.
Public property | TipRadius | Gets and sets the tip radius of a Tapered Tipped tool.
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedTipped Properties

The PMToolTaperedTipped type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | TaperAngle | Gets and sets the taper angle of a Tapered Tipped tool.
Public property | TaperDiameter | Gets and sets the taper diameter of a Tapered Tipped tool.
Public property | TaperHeight | Gets and sets the taper height of a Tapered Tipped tool.
Public property | TipRadius | Gets and sets the tip radius of a Tapered Tipped tool.
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTaperedTipped Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedTipped.TaperAngle Property

PMToolTaperedTippedTaperAngle Property

Gets and sets the taper angle of a Tapered Tipped tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree TaperAngle { get; set; }
Public Property TaperAngle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PMToolTaperedTipped Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedTipped.TaperDiameter Property

PMToolTaperedTippedTaperDiameter Property

Gets and sets the taper diameter of a Tapered Tipped tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TaperDiameter { get; set; }
Public Property TaperDiameter As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMToolTaperedTipped Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedTipped.TaperHeight Property

PMToolTaperedTippedTaperHeight Property

Gets and sets the taper height of a Tapered Tipped tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TaperHeight { get; set; }
Public Property TaperHeight As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMToolTaperedTipped Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedTipped.TipRadius Property

PMToolTaperedTippedTipRadius Property

Gets and sets the tip radius of a Tapered Tipped tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TipRadius { get; set; }
Public Property TipRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMToolTaperedTipped Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedTipped Methods

The PMToolTaperedTipped type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolTaperedTipped Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTaperedTipped Fields

The PMToolTaperedTipped type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTaperedTipped Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolThreadMill Class

Represents a thread mill tool in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolThreadMill

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolThreadMill : PMTool
Public Class PMToolThreadMill
    Inherits PMTool

The PMToolThreadMill type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | Pitch | Gets and sets the pitch of a Thread Mill tool.
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolThreadMill Properties

The PMToolThreadMill type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | Pitch | Gets and sets the pitch of a Thread Mill tool.
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolThreadMill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolThreadMill.Pitch Property

PMToolThreadMillPitch Property

Gets and sets the pitch of a Thread Mill tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Pitch { get; set; }
Public Property Pitch As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMToolThreadMill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolThreadMill Methods

The PMToolThreadMill type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolThreadMill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolThreadMill Fields

The PMToolThreadMill type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolThreadMill Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTippedDisc Class

Represents a tipped disc tool in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolTippedDisc

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolTippedDisc : PMTool
Public Class PMToolTippedDisc
    Inherits PMTool

The PMToolTippedDisc type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | TipRadius | Gets and sets the tip radius of a Tipped Disc tool.
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolTippedDisc Properties

The PMToolTippedDisc type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | TipRadius | Gets and sets the tip radius of a Tipped Disc tool.
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTippedDisc Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTippedDisc.TipRadius Property

PMToolTippedDiscTipRadius Property

Gets and sets the tip radius of a Tipped Disc tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TipRadius { get; set; }
Public Property TipRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PMToolTippedDisc Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTippedDisc Methods

The PMToolTippedDisc type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolTippedDisc Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTippedDisc Fields

The PMToolTippedDisc type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTippedDisc Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTipRadiused Class

Represents a tip radiused tool in PowerMill.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMTool
Autodesk.ProductInterface.PowerMILLPMToolTipRadiused

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMToolTipRadiused : PMTool
Public Class PMToolTipRadiused
    Inherits PMTool

The PMToolTipRadiused type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | TipRadius | Gets and sets the tip radius of a tip radiused tool.
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMToolTipRadiused Properties

The PMToolTipRadiused type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Inherited from PMTool.)
Public property | Coolant | Gets and sets the tool coolant type. (Inherited from PMTool.)
Public property | Description | Gets and sets the tool description. (Inherited from PMTool.)
Public property | Diameter | Gets and sets the tool diameter. (Inherited from PMTool.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | HolderName | Gets and sets the tool holder name. (Inherited from PMTool.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Length | Gets and sets the tool length in PowerMill. (Inherited from PMTool.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | NumberOfFlutes | Gets and sets the number of flutes in PowerMill. (Inherited from PMTool.)
Public property | NumberOfHolderElements | Gets and sets the number of elements in the holder. (Inherited from PMTool.)
Public property | NumberOfShankElements | Gets and sets the number of elements in the shank. (Inherited from PMTool.)
Public property | Overhang | Gets and sets the holder overhang. (Inherited from PMTool.)
Public property | TipRadius | Gets and sets the tip radius of a tip radiused tool.
Public property | ToolNumber | Gets and sets the tool number in PowerMill. (Inherited from PMTool.)
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTipRadiused Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTipRadiused.TipRadius Property

PMToolTipRadiusedTipRadius Property

Gets and sets the tip radius of a tip radiused tool.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TipRadius { get; }
Public ReadOnly Property TipRadius As MM
    Get

Property Value

Type: MM
See Also

Reference

PMToolTipRadiused Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTipRadiused Methods

The PMToolTipRadiused type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the tool from the active project and from PowerMill. (Inherited from PMTool.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HolderElementLength | Gets and sets the length of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementLowerDiameter | Gets and sets the lower diameter of the requested holder component. (Inherited from PMTool.)
Public method | HolderElementUpperDiameter | Gets and sets the upper diameter of the requested holder component. (Inherited from PMTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShankElementLength | Gets and sets the length of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementLowerDiameter | Gets and sets the lower diameter of the requested shank component. (Inherited from PMTool.)
Public method | ShankElementUpperDiameter | Gets and sets the upper diameter of the requested shank component. (Inherited from PMTool.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMToolTipRadiused Class
Autodesk.ProductInterface.PowerMILL Namespace


PMToolTipRadiused Fields

The PMToolTipRadiused type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMToolTipRadiused Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane Class

Captures the a Workplane in PowerMILL.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMEntity
Autodesk.ProductInterface.PowerMILLPMWorkplane

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMWorkplane : PMEntity
Public Class PMWorkplane
    Inherits PMEntity

The PMWorkplane type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Overrides PMEntityBoundingBox.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Origin | Gets the Origin of Workplane.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | XAxisVector | Gets the XAxis vector.
Public property | YAxisVector | Gets the YAxis vector.
Public property | ZAxisVector | Gets the ZAxis vector.
Top
Methods
 | Name | Description
Public method | Delete | Deletes the workplane from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToWorkplane | Returns a Workplane representation of this PMWorkplane
Top
Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane Properties

The PMWorkplane type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type. (Overrides PMEntityBoundingBox.)
Public property | Exists | Gets whether or not the entity exists in PowerMILL (Inherited from PMEntity.)
Public property | IsActive | Gets and sets whether the entity is active. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Name | Gets and sets the name of the entity. It also updates PowerMill. (Inherited from PMEntity.)
Public property | Origin | Gets the Origin of Workplane.
Public property | Version | Version of current Power mill. (Inherited from PMEntity.)
Public property | XAxisVector | Gets the XAxis vector.
Public property | YAxisVector | Gets the YAxis vector.
Public property | ZAxisVector | Gets the ZAxis vector.
Top
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane.BoundingBox Property

PMWorkplaneBoundingBox Property

BoundingBox property is not valid for this type.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane.Origin Property

PMWorkplaneOrigin Property

Gets the Origin of Workplane.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Origin { get; }
Public ReadOnly Property Origin As Point
    Get

Property Value

Type: Point
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane.XAxisVector Property

PMWorkplaneXAxisVector Property

Gets the XAxis vector.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector XAxisVector { get; }
Public ReadOnly Property XAxisVector As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane.YAxisVector Property

PMWorkplaneYAxisVector Property

Gets the YAxis vector.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector YAxisVector { get; }
Public ReadOnly Property YAxisVector As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane.ZAxisVector Property

PMWorkplaneZAxisVector Property

Gets the ZAxis vector.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector ZAxisVector { get; }
Public ReadOnly Property ZAxisVector As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane Methods

The PMWorkplane type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the workplane from the active project and from PowerMill. (Overrides PMEntityDelete.)
Public method | Duplicate | Duplicates an entity. It also updates PowerMill. (Inherited from PMEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToWorkplane | Returns a Workplane representation of this PMWorkplane
Top
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane.Delete Method

PMWorkplaneDelete Method

Deletes the workplane from the active project and from PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Remarks
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane.ToWorkplane Method

PMWorkplaneToWorkplane Method

Returns a Workplane representation of this PMWorkplane

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Workplane ToWorkplane()
Public Function ToWorkplane As Workplane

Return Value

Type: Workplane
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplane Fields

The PMWorkplane type exposes the following members.

Fields
 | Name | Description
Protected field | PowerMill | The PowerMill Automation object. (Inherited from PMEntity.)
Top
See Also

Reference

PMWorkplane Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplanesCollection Class

Collection of Workpath objects in the Active PowerMILL Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerMILLPMCollection PMWorkplane
Autodesk.ProductInterface.PowerMILLPMEntitiesCollection PMWorkplane
Autodesk.ProductInterface.PowerMILLPMWorkplanesCollection

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PMWorkplanesCollection : PMEntitiesCollection<PMWorkplane>
Public Class PMWorkplanesCollection
    Inherits PMEntitiesCollection(Of PMWorkplane)

The PMWorkplanesCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateWorkplane | Creates a Workplane in PowerMILL based on the specified workplane.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplanesCollection Properties

The PMWorkplanesCollection type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from PMEntitiesCollectionT.)
Public property | Count | Gets the number of items in the collection. (Inherited from PMCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PMCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PMCollectionT.)
Public property | ItemString | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMWorkplanesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplanesCollection Methods

The PMWorkplanesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Entity to the List. (Inherited from PMEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list and in PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PMCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PMCollectionT.)
Public method | CreateWorkplane | Creates a Workplane in PowerMILL based on the specified workplane.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PMEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PMCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PMCollectionT.)
Public method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PMCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PMEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the specified item from the list and from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | Remove(T, Boolean) | Removes the specified item from the list and from PowerMill and applies 'NOQUIBBLE' option if 'useNoQuibble' is set to true. (Inherited from PMEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index on the list and it also removes it from PowerMill. (Inherited from PMEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PMWorkplanesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplanesCollection.CreateWorkplane Method

PMWorkplanesCollectionCreateWorkplane Method

Creates a Workplane in PowerMILL based on the specified workplane.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMWorkplane CreateWorkplane(
    Workplane workplaneToCreate
)
Public Function CreateWorkplane (
    workplaneToCreate As Workplane
) As PMWorkplane

Parameters

workplaneToCreate
Type: Autodesk.GeometryWorkplane
The workplane to create in PowerMILL.

Return Value

Type: PMWorkplane
See Also

Reference

PMWorkplanesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PMWorkplanesCollection Fields

The PMWorkplanesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The list used to implement the interface IList. (Inherited from PMCollectionT.)
Protected field | _powerMILL | PowerMILL Automation object (Inherited from PMEntitiesCollectionT.)
Top
See Also

Reference

PMWorkplanesCollection Class
Autodesk.ProductInterface.PowerMILL Namespace


PointApproach Enumeration

Direction in which to define the incremental move.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum PointApproach
Public Enumeration PointApproach
Members
Member name | Value | Description
ToolAxis | 0 | Move along tool axis.
Normal | 1 | Move along contact normal.
Tangent | 2 | Move along contact normal.
Radial | 3 | Move along contact normal.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PowerMillException Class

[Missing <summary> documentation for "T:Autodesk.ProductInterface.PowerMILL.PowerMillException"]

Inheritance Hierarchy
SystemObject
SystemException
Autodesk.ProductInterface.PowerMILLPowerMillException

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PowerMillException : Exception
Public Class PowerMillException
    Inherits Exception

The PowerMillException type exposes the following members.

Constructors
 | Name | Description
Public method | PowerMillException | Initializes a new instance of the PowerMillException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


PowerMillException Constructor

Initializes a new instance of the PowerMillException class

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PowerMillException(
    Version version,
    string message
)
Public Sub New (
    version As Version,
    message As String
)

Parameters

version
Type: SystemVersion

[Missing <param name="version"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PowerMillException.#ctor(System.Version,System.String)"]

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Autodesk.ProductInterface.PowerMILL.PowerMillException.#ctor(System.Version,System.String)"]

See Also

Reference

PowerMillException Class
Autodesk.ProductInterface.PowerMILL Namespace


PowerMillException Properties

The PowerMillException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PowerMillException Class
Autodesk.ProductInterface.PowerMILL Namespace


PowerMillException.Message Property

PowerMillExceptionMessage Property

[Missing <summary> documentation for "P:Autodesk.ProductInterface.PowerMILL.PowerMillException.Message"]

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

PowerMillException Class
Autodesk.ProductInterface.PowerMILL Namespace


PowerMillException Methods

The PowerMillException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PowerMillException Class
Autodesk.ProductInterface.PowerMILL Namespace


PowerMillException Events

The PowerMillException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PowerMillException Class
Autodesk.ProductInterface.PowerMILL Namespace


RampFollow Enumeration

Direction of PMRamp.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum RampFollow
Public Enumeration RampFollow
Members
Member name | Value | Description
ToolPath | 0 | The ramp moves follow the profile of the toolpath.
Line | 1 | The ramp moves are normal to the cutting direction at that point. If the requested line cannot be fitted into the area, then the Toolpath option is used automatically.
Circle | 2 | The ramp moves are circular. If the requested circle cannot be fitted into the area, then the Line method is used automatically.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


RampHeight Enumeration

Select how to determine the height from which the ramp descends

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum RampHeight
Public Enumeration RampHeight
Members
Member name | Value | Description
IncrementalRamp | 0 | The height above the cleared stock for the start of the ramp.
Segment | 1 | The start of the ramp is at the same height as the end of the previous toolpath segment, provided that this is higher than the toolpath segment by the amount specified in the Height field.
SegmentIncremental | 2 | The start of the ramp is at the same height as the end of the previous toolpath segment plus the height specified in the Height field.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


StartPointMethod Enumeration

Defines how the start point is set.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum StartPointMethod
Public Enumeration StartPointMethod
Members
Member name | Value | Description
Absolute | 0 | The start point is positioned independently of all other properties at the point defined by the Coordinates field.
BlockCentre | 1 | The start point is at Safe Z above the block centre:
FirstPoint | 2 | The start point is positioned at the specified distance from the first point in the toolpath, measured along its tool axis.
FirstPointSafe | 3 | The start point is at Safe Z above the first point in the toolpath. For multi-axis toolpaths, the start point is set by considering a point that is the specified distance from the first point on the toolpath, measured along the tool axis, and projecting this onto the Safe Z area.
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


ToolChangePositions Enumeration

Represents the tool change positions in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ToolChangePositions
Public Enumeration ToolChangePositions
Members
Member name | Value | Description
Before | 0 |
After | 1 |
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


ToolChanges Enumeration

Represents the Tool changes in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ToolChanges
Public Enumeration ToolChanges
Members
Member name | Value | Description
Change | 0 |
Always | 1 |
New | 2 |
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


ToolNumberings Enumeration

Represents the tool numberings in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ToolNumberings
Public Enumeration ToolNumberings
Members
Member name | Value | Description
Automatic | 0 |
On | 1 |
Sequential | 2 |
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


ToolpathSafety Enumeration

Indicates the safety of various parts of the toolpath.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ToolpathSafety
Public Enumeration ToolpathSafety
Members
Member name | Value | Description
NotChecked | 0 | Safty unchecked
Safe | 1 | Tool does not gouge .
Collides | 2 | Tool gouges
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


ToolValues Enumeration

Represents tool values in PowerMill.

Namespace: Autodesk.ProductInterface.PowerMILL
Assembly: Autodesk.ProductInterface.PowerMILL (in Autodesk.ProductInterface.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ToolValues
Public Enumeration ToolValues
Members
Member name | Value | Description
Tip | 0 |
Centre | 1 |
See Also

Reference

Autodesk.ProductInterface.PowerMILL Namespace


Autodesk.ProductInterface.PowerSHAPE Namespace

Classes
 | Class | Description
Public class | AutomaticFitSurfacesToMeshTool | Helps to create surfaces from meshes.
Public class | ManualFitSurfaceToMeshTool | Helper to manual fit a surface to a mesh.
Public class | PSAnnotation | Captures an Annotation object in PowerSHAPE
Public class | PSAnnotationsCollection | Captures the collection of Annotations in a Project
Public class | PSArc | Captures an Arc object in PowerSHAPE
Public class | PSArcsCollection | Captures the collection of Arcs in a Project
Public class | PSAutomation | This is the root class of a PowerSHAPE instance. When it is created it creates its own instance of PowerSHAPE. When it is destroyed the instance of PowerSHAPE will also be destroyed.
Public class | PSCollectionT | Base class for all PowerShape Product Interface collections which items are not PSEntities. It controls the addition of items to PowerShape collections.
Public class | PSCompCurve | Captures a CompCurve object in PowerSHAPE
Public class | PSCompCurvesCollection | Captures the collection of CompCurves in a Project
Public class | PSCurve | Captures a Curve object in PowerSHAPE
Public class | PSCurvesCollection | Captures a collection of Curves in a Project
Public class | PSDatabaseEntitiesCollectionT | Base class for curve collections.
Public class | PSDatabaseEntity | Abstract class captures a database entity in PowerSHAPE.
Public class | PSElectrode | Captures an Electrode object in PowerSHAPE
Public class | PSElectrodesCollection | Captures a collection of Electrodes in a Project
Public class | PSEntitiesCollectionT | Abstract base class that all list classes are based on.
Public class | PSEntity | Abstract class to capture an entity in PowerSHAPE
Public class | PSEntityCutter | Entity cutter helper.
Public class | PSEntityLimiter | Contains the necessary code to limit entities.
Public class | PSEntityMirrorer | Helps to mirror entities.
Public class | PSEntityMorpher |
Public class | PSEntityMover | Helps to move entities.
Public class | PSEntityOffseter | Offseter helper for entities.
Public class | PSEntityRotater | Helper to rotate entities.
Public class | PSEntityScaler | Helper to scale an entity.
Public class | PSGenericCurve | Base class for curves in PowerSHAPE.
Public class | PSGenericCurvesCollectionT | Base class for curve collections
Public class | PSLateral | Captures a Surface Lateral object in PowerSHAPE
Public class | PSLateralsCollection | Captures a collection of laterals in a project
Public class | PSLevel | Captures a Level in PowerSHAPE.
Public class | PSLevelsCollection | Captures the collection of Levels in a Project.
Public class | PSLine | Captures a Line object in PowerSHAPE.
Public class | PSLinesCollection | Captures a collection of Lines in a Project
Public class | PSLongitudinal | Captures a Surface Longitudinal object in PowerSHAPE
Public class | PSLongitudinalsCollection | Captures a collection of Longitudinals in a project
Public class | PSMacro | Handles Macros in PowerSHAPE.
Public class | PSMaterial | Captures a Material in PowerSHAPE. A Material is used to give colour and texture to a surface.
Public class | PSMaterialsCollection | Captures the collection of Materials in PowerSHAPE.
Public class | PSMesh | Captures a Mesh object in PowerSHAPE
Public class | PSMeshesCollection | Captures a collection of Meshes in a Project
Public class | PSMeshTrianglePicker | This class allows the user to select triangles in a mesh using a variety of methods, and perform 3 separate actions on the selection.
Public class | PSModel | Captures a Model in PowerSHAPE.
Public class | PSModelsCollection | Captures the list of open models in PowerSHAPE.
Public class | PSpCurve | Captures a Curve object in PowerSHAPE
Public class | PSPoint | Captures a Point in PowerSHAPE
Public class | PSPointsCollection | Captures the collection of Points in a Project.
Public class | PSPrimitive | Base class for PowerSHAPE primitives
Public class | PSSolid | Captures an Solid object in PowerSHAPE
Public class | PSSolidBlock | Captures a solid block in PowerSHAPE
Public class | PSSolidCone | Captures a solid cone in PowerSHAPE
Public class | PSSolidCylinder | Captures a solid cylinder in PowerSHAPE
Public class | PSSolidExtrusion | Captures a solid extrusion in PowerSHAPE
Public class | PSSolidPlane | Captures a solid plane in PowerSHAPE
Public class | PSSolidRevolution | Captures a solid revolution in PowerSHAPE
Public class | PSSolidsCollection | Captures the collection of Solids in a Project.
Public class | PSSolidSphere | Captures a solid sphere in PowerSHAPE
Public class | PSSolidSpring | Captures a solid spring in PowerSHAPE
Public class | PSSolidTorus | Captures a solid torus in PowerSHAPE
Public class | PSSpine | Captures a Spine object in PowerSHAPE. The spine is a reference curve that may be used to define the overall shape of a surface. It was widely used in DUCT, but PowerSHAPE users need not normally be concerned with it.
Public class | PSSurface | Captures an Surface object in PowerSHAPE
Public class | PSSurfaceBlock | Captures a Surface Block object in PowerSHAPE
Public class | PSSurfaceCone | Captures a Surface Cone object in PowerSHAPE
Public class | PSSurfaceCurve | Base class for Surface Curves.
Public class | PSSurfaceCurvesCollectionT | Base class for PSLateralsCollection and PSLongitudinalsCollection.
Public class | PSSurfaceCylinder | Captures a Surface Cylinder object in PowerSHAPE
Public class | PSSurfaceExtrusion | Captures a Surface Extrusion object in PowerSHAPE
Public class | PSSurfacePlane | Captures a Surface Plane object in PowerSHAPE
Public class | PSSurfaceRevolution | Captures a Surface Revolution object in PowerSHAPE
Public class | PSSurfacesCollection | Captures the collection of Surfaces in a Project.
Public class | PSSurfaceSphere | Captures a Surface Sphere object in PowerSHAPE
Public class | PSSurfaceSpring | Captures a Surface Spring object in PowerSHAPE
Public class | PSSurfaceTorus | Captures a Surface Torus object in PowerSHAPE
Public class | PSWindow | Represents a window in PowerShape.
Public class | PSWindowsCollection | Collection of Windows in CustomCore.
Public class | PSWireframe | Captures a wire frame model in PowerSHAPE
Public class | PSWorkplane | Captures an Workplane object in PowerSHAPE
Public class | PSWorkplanesCollection | Captures the collection of Workplanes in a Project.
Public class | SurfaceAdvancedOptions | Contains advanced surface options that can be used when creating surfaces.
Public class | SurfaceCurveTypesExtensions | Contains all extension methods for the SurfaceCurveTypes enumeration.
Interfaces
 | Interface | Description
Public interface | IPSAddable | Allows to add an entity to another entity.
Public interface | IPSCuttable | Allows an entity to be divided into two entities.
Public interface | IPSIntersectable | Allows intersectable behaviour between entities.
Public interface | IPSLimitable | Allows an entity to be limited by another entity or entities.
Public interface | IPSMirrorable | Allows an entity to be mirrored.
Public interface | IPSMoveable | Allows an entity to be moved.
Public interface | IPSOffsetable | Allows the offset of an entity.
Public interface | IPSRotateable | Allows entities rotation.
Public interface | IPSScalable | Allows scaleable behaviour.
Public interface | IPSSubtractable | Allows an entity to be subtracted.
Enumerations
 | Enumeration | Description
Public enumeration | AdvancedInteriorInterpolationMethods | Interior interpolation methods option for surface creation.
Public enumeration | AutomaticSurfaceOptions | Edge matching options to control how PowerSHAPE adds extra surface points and curves to the initial network so that each point lies at the junction of a lateral and a longitudinal.
Public enumeration | AutomaticSurfaceTypes | Surface types in PowerShape.
Public enumeration | AutomaticSurfacingMethods | Methods for creating a surface from wireframe.
Public enumeration | CornerBehaviours | Used when repointing a curve.
Public enumeration | CurveTypes | Curve types.
Public enumeration | DecayDefinitionBlend |
Public enumeration | DecayDefinitionOptions |
Public enumeration | ExportItemsOptions | Used when exporting options from PowerSHAPE.
Public enumeration | ExportWorkplanes | Used to select the workplane when exporting from PowerSHAPE.
Public enumeration | ExtensionEdges | Surface extension edges options.
Public enumeration | ExtensionEnd | Used to specify the end of the curve to be extended.
Public enumeration | ExtensionType | Extensions types.
Public enumeration | FeatureTypes | Feature types.
Public enumeration | FilletCornerTypes | Fillet surface corner types.
Public enumeration | FilletCreaseOptions | Fillet along creases options.
Public enumeration | FilletRouteOptions | Fillet all routes options.
Public enumeration | FilletTrimOptions | Fillet trim options.
Public enumeration | FilletTypes | Fillet surface types.
Public enumeration | LimitingKeepOptions | Keep options for limiting operations.
Public enumeration | LimitingModes | The mode in which to carry out the limiting operation.
Public enumeration | LimitingTrimOptions | Trim Options for a limiting operation. Whether to trim one or all of the entities.
Public enumeration | MeshDoctorFixOptions | Options for MeshDoctor operation that will be performed.
Public enumeration | MeshDoctorRepairTypes | Repair types for MeshDoctor operation that will be performed.
Public enumeration | Modes | Shows the various modes in which PowerSHAPE can run.
Public enumeration | MultipleViewAngles | Multiple view angles that can be set.
Public enumeration | NewWorkplaneInEntityPositions | Defines the positions in an entity a new workplane can be created.
Public enumeration | OffsetCornerTypes | Behaviour off the offset surface at corners.
Public enumeration | OffsetSplitAtDiscontinuity | Options of the offset surface when the operation produces a discontinuity.
Public enumeration | ProjectionType | Used when projecting a curve onto a surface.
Public enumeration | SculptTypes | Type of sculpting operation that will be performed.
Public enumeration | SolidTypes | Used to specify all Solid Types.
Public enumeration | SolidVersions | Used to distinguish between a version 8 solid and parasolid in PowerSHAPE.
Public enumeration | StitchDirectionAcross | Indicates whether the points should be matched across the seam.
Public enumeration | StitchDirectionAlong | Indicates whether the points should be matched along the seam.
Public enumeration | StitchTypes | Allows you to choose the type of the target from one of the following.
Public enumeration | SurfaceCurveInsertionMethod | Surface curve insertion methods.
Public enumeration | SurfaceCurveTypes | Surface direction options for a surface curve.
Public enumeration | SurfaceShapes | Surface shape options.
Public enumeration | SurfaceTypes | Surface types.
Public enumeration | TextJustifications | Alignment option for the text.
Public enumeration | TextOrigins | Defines the origin of the text.
Public enumeration | TrianglePickMode | Triangle pick modes.
Public enumeration | TriangleStitchIterationModes | The iteration mode used when stitching triangle meshes.
Public enumeration | TrimRegionEditingModes | Defining the two possible trim region editing modes.
Public enumeration | ViewRelationships | Used when setting relationships between multiple views.
Public enumeration | WindowTypes | Windows types.


AdvancedInteriorInterpolationMethods Enumeration

Interior interpolation methods option for surface creation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum AdvancedInteriorInterpolationMethods
Public Enumeration AdvancedInteriorInterpolationMethods
Members
Member name | Value | Description
Tangential | 0 |
Linear | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool Class

Helps to create surfaces from meshes.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEAutomaticFitSurfacesToMeshTool

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class AutomaticFitSurfacesToMeshTool
Public Class AutomaticFitSurfacesToMeshTool

The AutomaticFitSurfacesToMeshTool type exposes the following members.

Constructors
 | Name | Description
Public method | AutomaticFitSurfacesToMeshTool | Creates a new instance. Initialises the mesh and the base instance to interact with PowerShape.
Top
Properties
 | Name | Description
Public property | BlankKeptFeatures | If TRUE, features are blanked when they are persisted.
Public property | DisplayFeaturesAsTransparent | If TRUE, features will be transparent, preventing them obscuring each other. However this can result in selection conflicts, when clicking in an area of multiple entities. Set to FALSE to prevent selection conflicts.
Public property | FeatureTypesToRecognise | Gets the previous set value and sets the feature types to recognise in PowerShape.
Public property | GenerateFeaturesAsSolids | Set to TRUE to generate features as solids; FALSE to generate surfaces.
Public property | SimilarityAngle | Gets the previous set value and sets the 'Similarity Sliderval' in PowerShape.
Public property | Tolerance | Gets the previous set value and sets the 'Tolerance' in PowerShape.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractSelectedFeatures | Persist the selected features.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Close the tool.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | Generate and display the features.
Public method | Start | Start operation.
Public method | StopTool | Stop the tool.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool Constructor

Creates a new instance. Initialises the mesh and the base instance to interact with PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public AutomaticFitSurfacesToMeshTool(
    PSMesh mesh
)
Public Sub New (
    mesh As PSMesh
)

Parameters

mesh
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
Initialises with the mesh used to create the surfaces.
Remarks
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool Properties

The AutomaticFitSurfacesToMeshTool type exposes the following members.

Properties
 | Name | Description
Public property | BlankKeptFeatures | If TRUE, features are blanked when they are persisted.
Public property | DisplayFeaturesAsTransparent | If TRUE, features will be transparent, preventing them obscuring each other. However this can result in selection conflicts, when clicking in an area of multiple entities. Set to FALSE to prevent selection conflicts.
Public property | FeatureTypesToRecognise | Gets the previous set value and sets the feature types to recognise in PowerShape.
Public property | GenerateFeaturesAsSolids | Set to TRUE to generate features as solids; FALSE to generate surfaces.
Public property | SimilarityAngle | Gets the previous set value and sets the 'Similarity Sliderval' in PowerShape.
Public property | Tolerance | Gets the previous set value and sets the 'Tolerance' in PowerShape.
Top
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.BlankKeptFeatures Property

AutomaticFitSurfacesToMeshToolBlankKeptFeatures Property

If TRUE, features are blanked when they are persisted.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool BlankKeptFeatures { get; set; }
Public Property BlankKeptFeatures As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.DisplayFeaturesAsTransparent Property

AutomaticFitSurfacesToMeshToolDisplayFeaturesAsTransparent Property

If TRUE, features will be transparent, preventing them obscuring each other. However this can result in selection conflicts, when clicking in an area of multiple entities. Set to FALSE to prevent selection conflicts.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool DisplayFeaturesAsTransparent { get; set; }
Public Property DisplayFeaturesAsTransparent As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.FeatureTypesToRecognise Property

AutomaticFitSurfacesToMeshToolFeatureTypesToRecognise Property

Gets the previous set value and sets the feature types to recognise in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public HashSet<FeatureTypes> FeatureTypesToRecognise { get; set; }
Public Property FeatureTypesToRecognise As HashSet(Of FeatureTypes)
    Get
    Set

Property Value

Type: HashSet FeatureTypes

Return Value

Type: HashSet FeatureTypes
Remarks
Feature types to recognise will only be updated in PowerShape if _isToolCurrentlyActive is true.
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.GenerateFeaturesAsSolids Property

AutomaticFitSurfacesToMeshToolGenerateFeaturesAsSolids Property

Set to TRUE to generate features as solids; FALSE to generate surfaces.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool GenerateFeaturesAsSolids { get; set; }
Public Property GenerateFeaturesAsSolids As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.SimilarityAngle Property

AutomaticFitSurfacesToMeshToolSimilarityAngle Property

Gets the previous set value and sets the 'Similarity Sliderval' in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double SimilarityAngle { get; set; }
Public Property SimilarityAngle As Double
    Get
    Set

Property Value

Type: Double

Return Value

Type: Double
Remarks
Similarity Sliderval will only be updated in PowerShape if _isToolCurrentlyActive is true.
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.Tolerance Property

AutomaticFitSurfacesToMeshToolTolerance Property

Gets the previous set value and sets the 'Tolerance' in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set

Property Value

Type: Double

Return Value

Type: Double
Tolerance will only be updated in PowerShape if _isToolCurrentlyActive is true.
Remarks
.
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool Methods

The AutomaticFitSurfacesToMeshTool type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractSelectedFeatures | Persist the selected features.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Close the tool.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | Generate and display the features.
Public method | Start | Start operation.
Public method | StopTool | Stop the tool.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.ExtractSelectedFeatures Method

AutomaticFitSurfacesToMeshToolExtractSelectedFeatures Method

Persist the selected features.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSurface> ExtractSelectedFeatures()
Public Function ExtractSelectedFeatures As List(Of PSSurface)

Return Value

Type: List PSSurface
Remarks
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.Finish Method

AutomaticFitSurfacesToMeshToolFinish Method

Close the tool.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSurface> Finish()
Public Function Finish As List(Of PSSurface)

Return Value

Type: List PSSurface
The features that were extracted from the mesh.
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.Preview Method

AutomaticFitSurfacesToMeshToolPreview Method

Generate and display the features.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Preview()
Public Sub Preview
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.Start Method

AutomaticFitSurfacesToMeshToolStart Method

Start operation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Start()
Public Sub Start
Remarks
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticFitSurfacesToMeshTool.StopTool Method

AutomaticFitSurfacesToMeshToolStopTool Method

Stop the tool.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StopTool()
Public Sub StopTool
See Also

Reference

AutomaticFitSurfacesToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticSurfaceOptions Enumeration

Edge matching options to control how PowerSHAPE adds extra surface points and curves to the initial network so that each point lies at the junction of a lateral and a longitudinal.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum AutomaticSurfaceOptions
Public Enumeration AutomaticSurfaceOptions
Members
Member name | Value | Description
None | 0 |
TangentDirection | 1 |
WidthOfCurve | 2 |
ArcLength | 3 |
Repoint | 4 |
BSpline | 5 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticSurfaceTypes Enumeration

Surface types in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum AutomaticSurfaceTypes
Public Enumeration AutomaticSurfaceTypes
Members
Member name | Value | Description
PowerSurface | 9 |
NURB | 11 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


AutomaticSurfacingMethods Enumeration

Methods for creating a surface from wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum AutomaticSurfacingMethods
Public Enumeration AutomaticSurfacingMethods
Members
Member name | Value | Description
FromNetwork | 0 |
FromSeparate | 1 |
Developable | 2 |
DriveCurve | 3 |
TwoRails | 4 |
PlaneOfBestFit | 5 |
FromTriangles | 6 |
NetworkOverTriangles | 7 |
Fill | 8 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


CornerBehaviours Enumeration

Used when repointing a curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum CornerBehaviours
Public Enumeration CornerBehaviours
Members
Member name | Value | Description
RemoveAllCorners | 0 |
KeepAllDiscontinuities | 1 |
SelectCorners | 2 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


CurveTypes Enumeration

Curve types.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum CurveTypes
Public Enumeration CurveTypes
Members
Member name | Value | Description
Bezier | 0 |
g2 | 1 |
bSpline | 2 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


DecayDefinitionBlend Enumeration

[Missing <summary> documentation for "T:Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend"]

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum DecayDefinitionBlend
Public Enumeration DecayDefinitionBlend
Members
Member name | Value | Description
Linear | 0 |
Parabolic | 1 |
Cubic | 2 |
Quartic | 3 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


DecayDefinitionOptions Enumeration

[Missing <summary> documentation for "T:Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions"]

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum DecayDefinitionOptions
Public Enumeration DecayDefinitionOptions
Members
Member name | Value | Description
None | 0 |
Distance | 1 |
Curve | 2 |
Surface | 3 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ExportItemsOptions Enumeration

Used when exporting options from PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ExportItemsOptions
Public Enumeration ExportItemsOptions
Members
Member name | Value | Description
All | 0 | Exports all items that are in the model regardless of selection or visibility.
Selected | 1 | Exports only those items that are selected. If no items are selection an exception shall be raised.
Visible | 2 | Exports only those items that are visible.
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ExportWorkplanes Enumeration

Used to select the workplane when exporting from PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ExportWorkplanes
Public Enumeration ExportWorkplanes
Members
Member name | Value | Description
World | 0 | Allows the user to export using the World.
Active | 1 | Allows the user to export using the active workplane.
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ExtensionEdges Enumeration

Surface extension edges options.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ExtensionEdges
Public Enumeration ExtensionEdges
Members
Member name | Value | Description
ONE | 1 |
TWO | 2 |
THREE | 3 |
FOUR | 4 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ExtensionEnd Enumeration

Used to specify the end of the curve to be extended.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ExtensionEnd
Public Enumeration ExtensionEnd
Members
Member name | Value | Description
ONE | 1 |
TWO | 2 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ExtensionType Enumeration

Extensions types.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ExtensionType
Public Enumeration ExtensionType
Members
Member name | Value | Description
Curvature | 0 |
Linear | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


FeatureTypes Enumeration

Feature types.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum FeatureTypes
Public Enumeration FeatureTypes
Members
Member name | Value | Description
Cone | 0 |
Cylinder | 1 |
Extrusion | 2 |
Plane | 3 |
RevolvedSurface | 4 |
ShrinkWrap | 5 |
Sphere | 6 |
Tori | 7 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


FilletCornerTypes Enumeration

Fillet surface corner types.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum FilletCornerTypes
Public Enumeration FilletCornerTypes
Members
Member name | Value | Description
ROLL | 0 |
MITRE | 1 |
ROUND | 2 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


FilletCreaseOptions Enumeration

Fillet along creases options.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum FilletCreaseOptions
Public Enumeration FilletCreaseOptions
Members
Member name | Value | Description
CREASEON | 0 |
CREASEOFF | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


FilletRouteOptions Enumeration

Fillet all routes options.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum FilletRouteOptions
Public Enumeration FilletRouteOptions
Members
Member name | Value | Description
ALLON | 0 |
ALLOFF | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


FilletTrimOptions Enumeration

Fillet trim options.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum FilletTrimOptions
Public Enumeration FilletTrimOptions
Members
Member name | Value | Description
TRIMOFF | 0 |
TRIMON | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


FilletTypes Enumeration

Fillet surface types.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum FilletTypes
Public Enumeration FilletTypes
Members
Member name | Value | Description
CONCAVE | 0 |
CONVEX | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSAddable Interface

Allows to add an entity to another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSAddable
Public Interface IPSAddable

The IPSAddable type exposes the following members.

Methods
 | Name | Description
Public method | AddEntitiesToEntity | Add a group of entities to another entity.
Public method | AddEntityToEntity | Add two entities together.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSAddable Methods

The IPSAddable type exposes the following members.

Methods
 | Name | Description
Public method | AddEntitiesToEntity | Add a group of entities to another entity.
Public method | AddEntityToEntity | Add two entities together.
Top
See Also

Reference

IPSAddable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSAddable.AddEntitiesToEntity Method

IPSAddableAddEntitiesToEntity Method

Add a group of entities to another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
PSEntity AddEntitiesToEntity(
    IEnumerable<IPSAddable> entitiesToAdd,
    bool copeWithCoincidentFaces = false
)
Function AddEntitiesToEntity (
    entitiesToAdd As IEnumerable(Of IPSAddable),
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entitiesToAdd
Type: System.Collections.GenericIEnumerable IPSAddable
Entities to be added.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
If it should cope with coincident faces.

Return Value

Type: PSEntity
Entity created from the addition.
Remarks
See Also

Reference

IPSAddable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSAddable.AddEntityToEntity Method

IPSAddableAddEntityToEntity Method

Add two entities together.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
PSEntity AddEntityToEntity(
    IPSAddable entityToAdd,
    bool copeWithCoincidentFaces = false
)
Function AddEntityToEntity (
    entityToAdd As IPSAddable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToAdd
Type: Autodesk.ProductInterface.PowerSHAPEIPSAddable
Entity to be added.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
If it should cope with coincident faces.

Return Value

Type: PSEntity
Entity created from the addition.
Remarks
See Also

Reference

IPSAddable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSCuttable Interface

Allows an entity to be divided into two entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSCuttable
Public Interface IPSCuttable

The IPSCuttable type exposes the following members.

Methods
 | Name | Description
Public method | Cut | Cuts an entity.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSCuttable Methods

The IPSCuttable type exposes the following members.

Methods
 | Name | Description
Public method | Cut | Cuts an entity.
Top
See Also

Reference

IPSCuttable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSCuttable.Cut Method

IPSCuttableCut Method

Cuts an entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
PSEntity Cut(
    Point pointAtWhichToCut
)
Function Cut (
    pointAtWhichToCut As Point
) As PSEntity

Parameters

pointAtWhichToCut
Type: Autodesk.GeometryPoint
The point used to cut the entity.

Return Value

Type: PSEntity
The new created entity.
Remarks
See Also

Reference

IPSCuttable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSIntersectable Interface

Allows intersectable behaviour between entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSIntersectable
Public Interface IPSIntersectable

The IPSIntersectable type exposes the following members.

Methods
 | Name | Description
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity.
Public method | IntersectEntityWithEntity | Intersects an entity with another entity.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSIntersectable Methods

The IPSIntersectable type exposes the following members.

Methods
 | Name | Description
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity.
Public method | IntersectEntityWithEntity | Intersects an entity with another entity.
Top
See Also

Reference

IPSIntersectable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSIntersectable.IntersectEntitiesWithEntity Method

IPSIntersectableIntersectEntitiesWithEntity Method

Intersects a collection of entities with another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
List<PSEntity> IntersectEntitiesWithEntity(
    IEnumerable<IPSIntersectable> entitiesToIntersect,
    bool copeWithCoincidentFaces = false
)
Function IntersectEntitiesWithEntity (
    entitiesToIntersect As IEnumerable(Of IPSIntersectable),
    Optional copeWithCoincidentFaces As Boolean = false
) As List(Of PSEntity)

Parameters

entitiesToIntersect
Type: System.Collections.GenericIEnumerable IPSIntersectable
The entity to intersect.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Cope with coincident faces value.

Return Value

Type: List PSEntity
The entity created from the intersection.
Remarks
See Also

Reference

IPSIntersectable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSIntersectable.IntersectEntityWithEntity Method

IPSIntersectableIntersectEntityWithEntity Method

Intersects an entity with another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
PSEntity IntersectEntityWithEntity(
    IPSIntersectable entityToIntersect,
    bool copeWithCoincidentFaces = false
)
Function IntersectEntityWithEntity (
    entityToIntersect As IPSIntersectable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToIntersect
Type: Autodesk.ProductInterface.PowerSHAPEIPSIntersectable
The entity to intersect.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Cope with coincident faces value.

Return Value

Type: PSEntity
The entity created from the intersection.
Remarks
See Also

Reference

IPSIntersectable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSLimitable Interface

Allows an entity to be limited by another entity or entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSLimitable
Public Interface IPSLimitable

The IPSLimitable type exposes the following members.

Methods
 | Name | Description
Public method | LimitToEntities | Limits an entity by other entities.
Public method | LimitToEntity | Limits an entity by other entity.
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSLimitable Methods

The IPSLimitable type exposes the following members.

Methods
 | Name | Description
Public method | LimitToEntities | Limits an entity by other entities.
Public method | LimitToEntity | Limits an entity by other entity.
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Top
See Also

Reference

IPSLimitable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSLimitable.LimitToEntities Method

IPSLimitableLimitToEntities Method

Limits an entity by other entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
List<PSEntity> LimitToEntities(
    List<PSEntity> limitingEntities,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Function LimitToEntities (
    limitingEntities As List(Of PSEntity),
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntities
Type: System.Collections.GenericList PSEntity
Entities to limit with.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
Mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities
finishOperation (Optional)
Type: SystemBoolean
Whether the operation should be ended.

Return Value

Type: List PSEntity
A list containing the new entities.
Remarks
See Also

Reference

IPSLimitable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSLimitable.LimitToEntity Method

IPSLimitableLimitToEntity Method

Limits an entity by other entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
List<PSEntity> LimitToEntity(
    PSEntity limitingEntity,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Function LimitToEntity (
    limitingEntity As PSEntity,
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
Entity with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
Mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
Whether the operation should be ended.

Return Value

Type: List PSEntity
A list containing the new entities.
Remarks
See Also

Reference

IPSLimitable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSLimitable.LimitUsingDynamicCutter Method

IPSLimitableLimitUsingDynamicCutter Method

Limits using the dynamic cutter option.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
PSEntity LimitUsingDynamicCutter(
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne
)
Function LimitUsingDynamicCutter (
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne
) As PSEntity

Parameters

keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.

Return Value

Type: PSEntity
Remarks
See Also

Reference

IPSLimitable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSMirrorable Interface

Allows an entity to be mirrored.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSMirrorable
Public Interface IPSMirrorable

The IPSMirrorable type exposes the following members.

Methods
 | Name | Description
Public method | Mirror | Mirrors an entity in a specified plane.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSMirrorable Methods

The IPSMirrorable type exposes the following members.

Methods
 | Name | Description
Public method | Mirror | Mirrors an entity in a specified plane.
Top
See Also

Reference

IPSMirrorable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSMirrorable.Mirror Method

IPSMirrorableMirror Method

Mirrors an entity in a specified plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror.
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane.
Remarks
See Also

Reference

IPSMirrorable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSMoveable Interface

Allows an entity to be moved.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSMoveable
Public Interface IPSMoveable

The IPSMoveable type exposes the following members.

Methods
 | Name | Description
Public method | MoveBetweenPoints | Moves an entity by the relative distance between two absolute positions.
Public method | MoveByVector | Moves an entity by a specified relative amount.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSMoveable Methods

The IPSMoveable type exposes the following members.

Methods
 | Name | Description
Public method | MoveBetweenPoints | Moves an entity by the relative distance between two absolute positions.
Public method | MoveByVector | Moves an entity by a specified relative amount.
Top
See Also

Reference

IPSMoveable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSMoveable.MoveBetweenPoints Method

IPSMoveableMoveBetweenPoints Method

Moves an entity by the relative distance between two absolute positions.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
First of the two absolute positions.
pointToMoveTo
Type: Autodesk.GeometryPoint
Second of the two absolute positions.
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation.

Return Value

Type: List PSEntity
A list of the copied entities that have been created. If numberOfCopies was 0, an empty list is returned.
Remarks
See Also

Reference

IPSMoveable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSMoveable.MoveByVector Method

IPSMoveableMoveByVector Method

Moves an entity by a specified relative amount.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
Relative amount by which the entity will be moved.
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation.

Return Value

Type: List PSEntity
A list of the copied entities that have been created. If numberOfCopies was 0, an empty list is returned.
Remarks
See Also

Reference

IPSMoveable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSOffsetable Interface

Allows the offset of an entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSOffsetable
Public Interface IPSOffsetable

The IPSOffsetable type exposes the following members.

Methods
 | Name | Description
Public method | Offset | Offsets a single entity by a specified distance.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSOffsetable Methods

The IPSOffsetable type exposes the following members.

Methods
 | Name | Description
Public method | Offset | Offsets a single entity by a specified distance.
Top
See Also

Reference

IPSOffsetable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSOffsetable.Offset Method

IPSOffsetableOffset Method

Offsets a single entity by a specified distance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
List<PSEntity> Offset(
    MM offsetDistance,
    int copiesToCreate
)
Function Offset (
    offsetDistance As MM,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

offsetDistance
Type: Autodesk.GeometryMM
Distance by which to offset the curve.
copiesToCreate
Type: SystemInt32
Number of copies to be created from the operation.

Return Value

Type: List PSEntity
A list of the copied entities that have been created. If numberOfCopies was 0, an empty list is returned.
Remarks
See Also

Reference

IPSOffsetable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSRotateable Interface

Allows entities rotation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSRotateable
Public Interface IPSRotateable

The IPSRotateable type exposes the following members.

Methods
 | Name | Description
Public method | Rotate | Rotates an entity arc by a specified angle around a specified axis.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSRotateable Methods

The IPSRotateable type exposes the following members.

Methods
 | Name | Description
Public method | Rotate | Rotates an entity arc by a specified angle around a specified axis.
Top
See Also

Reference

IPSRotateable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSRotateable.Rotate Method

IPSRotateableRotate Method

Rotates an entity arc by a specified angle around a specified axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the arc is are to be rotated.
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the arc is to be rotated.
copiesToCreate
Type: SystemInt32
The number of copies to create of the original arc.
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis.

Return Value

Type: List PSEntity
A list of entities created by the operation. If numberOfCopies is 0, an empty list is returned.
Remarks
See Also

Reference

IPSRotateable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSScalable Interface

Allows scaleable behaviour.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSScalable
Public Interface IPSScalable

The IPSScalable type exposes the following members.

Methods
 | Name | Description
Public method | ScaleNonUniform | Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.
Public method | ScaleProjectedVolume | Resizes entities according to their volume as projected on to the active workplane.
Public method | ScaleUniform | Scales entity by a single value. Axis can be locked to prevent scaling on that axis.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSScalable Methods

The IPSScalable type exposes the following members.

Methods
 | Name | Description
Public method | ScaleNonUniform | Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.
Public method | ScaleProjectedVolume | Resizes entities according to their volume as projected on to the active workplane.
Public method | ScaleUniform | Scales entity by a single value. Axis can be locked to prevent scaling on that axis.
Top
See Also

Reference

IPSScalable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSScalable.ScaleNonUniform Method

IPSScalableScaleNonUniform Method

Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
void ScaleNonUniform(
    double scaleFactorX,
    double scaleFactorY,
    double scaleFactorZ,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Sub ScaleNonUniform (
    scaleFactorX As Double,
    scaleFactorY As Double,
    scaleFactorZ As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactorX
Type: SystemDouble
The x scale factor.
scaleFactorY
Type: SystemDouble
The y scale factor.
scaleFactorZ
Type: SystemDouble
The z scale factor.
lockX
Type: SystemBoolean
Locked in x if true.
lockY
Type: SystemBoolean
Locked in y if true.
lockZ
Type: SystemBoolean
Locked in z if true.
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Objects are scaled relative to the scale origin.
Remarks
See Also

Reference

IPSScalable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSScalable.ScaleProjectedVolume Method

IPSScalableScaleProjectedVolume Method

Resizes entities according to their volume as projected on to the active workplane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
void ScaleProjectedVolume(
    double newVolume,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Sub ScaleProjectedVolume (
    newVolume As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

newVolume
Type: SystemDouble
The projected volume.
lockX
Type: SystemBoolean
Locked in x if true.
lockY
Type: SystemBoolean
Locked in y if true.
lockZ
Type: SystemBoolean
Locked in z if true.
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Objects are scaled relative to the scale origin.
Remarks
See Also

Reference

IPSScalable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSScalable.ScaleUniform Method

IPSScalableScaleUniform Method

Scales entity by a single value. Axis can be locked to prevent scaling on that axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
void ScaleUniform(
    double scaleFactor,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Sub ScaleUniform (
    scaleFactor As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactor
Type: SystemDouble
The scale factor.
lockX
Type: SystemBoolean
Locks X axis to prevent scaling.
lockY
Type: SystemBoolean
Locks Y axis to prevent scaling.
lockZ
Type: SystemBoolean
Locks Z axis to prevent scaling.
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Objects are scaled relative to the scale origin.
Remarks
See Also

Reference

IPSScalable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSSubtractable Interface

Allows an entity to be subtracted.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public interface IPSSubtractable
Public Interface IPSSubtractable

The IPSSubtractable type exposes the following members.

Methods
 | Name | Description
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity.
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


IPSSubtractable Methods

The IPSSubtractable type exposes the following members.

Methods
 | Name | Description
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity.
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity.
Top
See Also

Reference

IPSSubtractable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSSubtractable.SubtractEntitiesFromEntity Method

IPSSubtractableSubtractEntitiesFromEntity Method

Subtracts a collection of entities from another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
PSEntity SubtractEntitiesFromEntity(
    IEnumerable<IPSSubtractable> entitiesToSubtract,
    bool copeWithCoincidentFaces = false
)
Function SubtractEntitiesFromEntity (
    entitiesToSubtract As IEnumerable(Of IPSSubtractable),
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entitiesToSubtract
Type: System.Collections.GenericIEnumerable IPSSubtractable
Entities to subtract.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Cope with coincident faces option.

Return Value

Type: PSEntity
Entity created from the subtraction.
Remarks
See Also

Reference

IPSSubtractable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


IPSSubtractable.SubtractEntityFromEntity Method

IPSSubtractableSubtractEntityFromEntity Method

Subtracts an entity from another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
PSEntity SubtractEntityFromEntity(
    IPSSubtractable entityToSubtract,
    bool copeWithCoincidentFaces = false
)
Function SubtractEntityFromEntity (
    entityToSubtract As IPSSubtractable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToSubtract
Type: Autodesk.ProductInterface.PowerSHAPEIPSSubtractable
Entity to subtract.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Cope with coincident faces option.

Return Value

Type: PSEntity
Entity created from the subtraction.
Remarks
See Also

Reference

IPSSubtractable Interface
Autodesk.ProductInterface.PowerSHAPE Namespace


LimitingKeepOptions Enumeration

Keep options for limiting operations.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum LimitingKeepOptions
Public Enumeration LimitingKeepOptions
Members
Member name | Value | Description
KeepOne | 0 |
KeepBoth | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


LimitingModes Enumeration

The mode in which to carry out the limiting operation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum LimitingModes
Public Enumeration LimitingModes
Members
Member name | Value | Description
LimitMode | 0 |
ProjectMode | 1 |
ProjectViewMode | 2 |
ProjectSurfaceNormalMode | 3 |
IntersectCurveMode | 4 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


LimitingTrimOptions Enumeration

Trim Options for a limiting operation. Whether to trim one or all of the entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum LimitingTrimOptions
Public Enumeration LimitingTrimOptions
Members
Member name | Value | Description
LimitOne | 0 |
LimitBoth | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool Class

Helper to manual fit a surface to a mesh.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEManualFitSurfaceToMeshTool

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class ManualFitSurfaceToMeshTool
Public Class ManualFitSurfaceToMeshTool

The ManualFitSurfaceToMeshTool type exposes the following members.

Constructors
 | Name | Description
Public method | ManualFitSurfaceToMeshTool | Initialises the new instance with the mesh to work with and the base instance to interact with PowerShape. The feature type to recognise is set to plane.
Top
Properties
 | Name | Description
Public property | BlankKeptFeatures | If TRUE, features are blanked when they are persisted.
Public property | DisplayFeaturesAsTransparent | If TRUE, features will be transparent, preventing them obscuring each other. However this can result in selection conflicts, when clicking in an area of multiple entities. Set to FALSE to prevent selection conflicts.
Public property | FeatureTypeToRecognise | Gets the previous set value and sets the feature type to recognise in PowerShape.
Public property | GenerateFeaturesAsSolids | Set to TRUE to generate features as solids; FALSE to generate surfaces.
Public property | TrianglePicker | Gets the mesh triangle picker instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Extract | Return the last generated surface.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the manual fit operation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | Generate and display the features.
Public method | StartTool | Starts manual segment mesh operation in PowerShape.
Public method | StopTool | Stop the tool.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool Constructor

Initialises the new instance with the mesh to work with and the base instance to interact with PowerShape. The feature type to recognise is set to plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public ManualFitSurfaceToMeshTool(
    PSMesh mesh
)
Public Sub New (
    mesh As PSMesh
)

Parameters

mesh
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
The mesh to fit a surface to.
Remarks
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool Properties

The ManualFitSurfaceToMeshTool type exposes the following members.

Properties
 | Name | Description
Public property | BlankKeptFeatures | If TRUE, features are blanked when they are persisted.
Public property | DisplayFeaturesAsTransparent | If TRUE, features will be transparent, preventing them obscuring each other. However this can result in selection conflicts, when clicking in an area of multiple entities. Set to FALSE to prevent selection conflicts.
Public property | FeatureTypeToRecognise | Gets the previous set value and sets the feature type to recognise in PowerShape.
Public property | GenerateFeaturesAsSolids | Set to TRUE to generate features as solids; FALSE to generate surfaces.
Public property | TrianglePicker | Gets the mesh triangle picker instance.
Top
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.BlankKeptFeatures Property

ManualFitSurfaceToMeshToolBlankKeptFeatures Property

If TRUE, features are blanked when they are persisted.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool BlankKeptFeatures { get; set; }
Public Property BlankKeptFeatures As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.DisplayFeaturesAsTransparent Property

ManualFitSurfaceToMeshToolDisplayFeaturesAsTransparent Property

If TRUE, features will be transparent, preventing them obscuring each other. However this can result in selection conflicts, when clicking in an area of multiple entities. Set to FALSE to prevent selection conflicts.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool DisplayFeaturesAsTransparent { get; set; }
Public Property DisplayFeaturesAsTransparent As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.FeatureTypeToRecognise Property

ManualFitSurfaceToMeshToolFeatureTypeToRecognise Property

Gets the previous set value and sets the feature type to recognise in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public FeatureTypes FeatureTypeToRecognise { get; set; }
Public Property FeatureTypeToRecognise As FeatureTypes
    Get
    Set

Property Value

Type: FeatureTypes

Return Value

Type: FeatureTypes
Remarks
Feature type to recognise will only be updated in PowerShape if _isToolCurrentlyActive is true.
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.GenerateFeaturesAsSolids Property

ManualFitSurfaceToMeshToolGenerateFeaturesAsSolids Property

Set to TRUE to generate features as solids; FALSE to generate surfaces.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool GenerateFeaturesAsSolids { get; set; }
Public Property GenerateFeaturesAsSolids As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.TrianglePicker Property

ManualFitSurfaceToMeshToolTrianglePicker Property

Gets the mesh triangle picker instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMeshTrianglePicker TrianglePicker { get; }
Public ReadOnly Property TrianglePicker As PSMeshTrianglePicker
    Get

Property Value

Type: PSMeshTrianglePicker

Return Value

Type: PSMeshTrianglePicker
Remarks
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool Methods

The ManualFitSurfaceToMeshTool type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Extract | Return the last generated surface.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the manual fit operation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | Generate and display the features.
Public method | StartTool | Starts manual segment mesh operation in PowerShape.
Public method | StopTool | Stop the tool.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.Extract Method

ManualFitSurfaceToMeshToolExtract Method

Return the last generated surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface Extract()
Public Function Extract As PSSurface

Return Value

Type: PSSurface
The last surface that was generated from the mesh.
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.Finish Method

ManualFitSurfaceToMeshToolFinish Method

Finishes the manual fit operation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSurface> Finish()
Public Function Finish As List(Of PSSurface)

Return Value

Type: List PSSurface
Remarks
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.Preview Method

ManualFitSurfaceToMeshToolPreview Method

Generate and display the features.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Preview()
Public Sub Preview
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.StartTool Method

ManualFitSurfaceToMeshToolStartTool Method

Starts manual segment mesh operation in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StartTool()
Public Sub StartTool
Remarks
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


ManualFitSurfaceToMeshTool.StopTool Method

ManualFitSurfaceToMeshToolStopTool Method

Stop the tool.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StopTool()
Public Sub StopTool
See Also

Reference

ManualFitSurfaceToMeshTool Class
Autodesk.ProductInterface.PowerSHAPE Namespace


MeshDoctorFixOptions Enumeration

Options for MeshDoctor operation that will be performed.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum MeshDoctorFixOptions
Public Enumeration MeshDoctorFixOptions
Members
Member name | Value | Description
All | 0 |
RestrictBadConnection | 1 |
RestrictBoundary | 2 |
RestrictAspect | 3 |
RestrictSmall | 4 |
RestrictIntersect | 5 |
RestrictOverlap | 6 |
Status | 7 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


MeshDoctorRepairTypes Enumeration

Repair types for MeshDoctor operation that will be performed.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum MeshDoctorRepairTypes
Public Enumeration MeshDoctorRepairTypes
Members
Member name | Value | Description
AttemptAutomaticRepair | 0 |
ExpandSuperfault | 1 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


Modes Enumeration

Shows the various modes in which PowerSHAPE can run.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum Modes
Public Enumeration Modes
Members
Member name | Value | Description
ArmMode | 0 |
DraftMode | 1 |
ElectrodemakerMode | 2 |
EstimatorMode | 3 |
EvaluationMode | 4 |
JewelsmithMode | 5 |
MoldmakerMode | 6 |
PMillModellingMode | 7 |
PressmakerMode | 8 |
ProMode | 9 |
PShapeMode | 10 |
ShoemakerMode | 11 |
SurfacerMode | 12 |
LicenceCheckMode | 13 |
Unknown | 14 |
PShapeNoParaSolidMode | 15 |
ProNoParaSolidMode | 16 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


MultipleViewAngles Enumeration

Multiple view angles that can be set.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum MultipleViewAngles
Public Enumeration MultipleViewAngles
Members
Member name | Value | Description
FirstAngle | 0 |
FirstAnglePlusISO | 1 |
ThirdAngle | 2 |
ThirdAnglePlusISO | 3 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


NewWorkplaneInEntityPositions Enumeration

Defines the positions in an entity a new workplane can be created.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum NewWorkplaneInEntityPositions
Public Enumeration NewWorkplaneInEntityPositions
Members
Member name | Value | Description
Centre | 0 |
Bottom | 1 |
Top | 2 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


OffsetCornerTypes Enumeration

Behaviour off the offset surface at corners.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum OffsetCornerTypes
Public Enumeration OffsetCornerTypes
Members
Member name | Value | Description
SHARP | 0 |
ROUNDED | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


OffsetSplitAtDiscontinuity Enumeration

Options of the offset surface when the operation produces a discontinuity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum OffsetSplitAtDiscontinuity
Public Enumeration OffsetSplitAtDiscontinuity
Members
Member name | Value | Description
SPLITON | 0 |
SPLITOFF | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ProjectionType Enumeration

Used when projecting a curve onto a surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ProjectionType
Public Enumeration ProjectionType
Members
Member name | Value | Description
AlongPrincipalAxis | 0 |
ThroughSurface | 1 |
AlongSurfaceNormal | 2 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation Class

Captures an Annotation object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSAnnotation

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSAnnotation : PSEntity
Public Class PSAnnotation
    Inherits PSEntity

The PSAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets and sets the text Angle.
Public property | Bold | Sets whether the text is Bold or not. A True value will set it to Bold.
Public property | BoundingBox | BoundingBox property is not valid for this type (Overrides PSEntityBoundingBox.)
Public property | Colour | Gets the number of the colour used by the text.
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Font | Gets and sets the font type name of the Annotation.
Public property | Height | Gets and sets the height of the characters.
Public property | Horizontal | Gets and sets if text characters are Horizontal.
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Italic | Gets and sets whether the Annotation is italic.
Public property | Justification | Gets and sets the Justification of the Annotation. This is how the text in the block aligns with the left and right margins.
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Origin | Gets and sets the Origin of the Annotation. The origin is the 'anchor point' used to position the text and can be set at any of the four corners of the text box, the mid points of the sides of the text box or the centre of the text box.
Public property | Pitch | Sets the Pitch of the Annotation.
Public property | Position | Gets and sets the position of the Annotation. Point with the position at which the text was placed.
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Spacing | Sets the Spacing of the Annotation. Spacing between lines of text.
Public property | Text | Gets and sets the text of the Annotation.
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Underline | Sets whether the Annotation is underlined.
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | This operation deletes the Annotation from PowerSHAPE and removes it from the Annotations collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation Properties

The PSAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets and sets the text Angle.
Public property | Bold | Sets whether the text is Bold or not. A True value will set it to Bold.
Public property | BoundingBox | BoundingBox property is not valid for this type (Overrides PSEntityBoundingBox.)
Public property | Colour | Gets the number of the colour used by the text.
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Font | Gets and sets the font type name of the Annotation.
Public property | Height | Gets and sets the height of the characters.
Public property | Horizontal | Gets and sets if text characters are Horizontal.
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Italic | Gets and sets whether the Annotation is italic.
Public property | Justification | Gets and sets the Justification of the Annotation. This is how the text in the block aligns with the left and right margins.
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Origin | Gets and sets the Origin of the Annotation. The origin is the 'anchor point' used to position the text and can be set at any of the four corners of the text box, the mid points of the sides of the text box or the centre of the text box.
Public property | Pitch | Sets the Pitch of the Annotation.
Public property | Position | Gets and sets the position of the Annotation. Point with the position at which the text was placed.
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Spacing | Sets the Spacing of the Annotation. Spacing between lines of text.
Public property | Text | Gets and sets the text of the Annotation.
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Underline | Sets whether the Annotation is underlined.
Top
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Angle Property

PSAnnotationAngle Property

Gets and sets the text Angle.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree Angle { get; set; }
Public Property Angle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Bold Property

PSAnnotationBold Property

Sets whether the text is Bold or not. A True value will set it to Bold.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Bold { set; }
Public WriteOnly Property Bold As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.BoundingBox Property

PSAnnotationBoundingBox Property

BoundingBox property is not valid for this type

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Colour Property

PSAnnotationColour Property

Gets the number of the colour used by the text.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Colour { get; }
Public ReadOnly Property Colour As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Font Property

PSAnnotationFont Property

Gets and sets the font type name of the Annotation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Font { get; set; }
Public Property Font As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Height Property

PSAnnotationHeight Property

Gets and sets the height of the characters.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Height { get; set; }
Public Property Height As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Horizontal Property

PSAnnotationHorizontal Property

Gets and sets if text characters are Horizontal.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Horizontal { get; }
Public ReadOnly Property Horizontal As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Italic Property

PSAnnotationItalic Property

Gets and sets whether the Annotation is italic.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Italic { get; set; }
Public Property Italic As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Justification Property

PSAnnotationJustification Property

Gets and sets the Justification of the Annotation. This is how the text in the block aligns with the left and right margins.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public TextJustifications Justification { get; set; }
Public Property Justification As TextJustifications
    Get
    Set

Property Value

Type: TextJustifications
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Origin Property

PSAnnotationOrigin Property

Gets and sets the Origin of the Annotation. The origin is the 'anchor point' used to position the text and can be set at any of the four corners of the text box, the mid points of the sides of the text box or the centre of the text box.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public TextOrigins Origin { get; set; }
Public Property Origin As TextOrigins
    Get
    Set

Property Value

Type: TextOrigins
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Pitch Property

PSAnnotationPitch Property

Sets the Pitch of the Annotation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Pitch { set; }
Public WriteOnly Property Pitch As Double
    Set

Property Value

Type: Double
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Position Property

PSAnnotationPosition Property

Gets and sets the position of the Annotation. Point with the position at which the text was placed.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Position { get; }
Public ReadOnly Property Position As Point
    Get

Property Value

Type: Point
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Spacing Property

PSAnnotationSpacing Property

Sets the Spacing of the Annotation. Spacing between lines of text.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Spacing { get; set; }
Public Property Spacing As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Text Property

PSAnnotationText Property

Gets and sets the text of the Annotation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Underline Property

PSAnnotationUnderline Property

Sets whether the Annotation is underlined.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Underline { set; }
Public WriteOnly Property Underline As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation Methods

The PSAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | This operation deletes the Annotation from PowerSHAPE and removes it from the Annotations collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation.Delete Method

PSAnnotationDelete Method

This operation deletes the Annotation from PowerSHAPE and removes it from the Annotations collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotation Fields

The PSAnnotation type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSAnnotation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotationsCollection Class

Captures the collection of Annotations in a Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSAnnotation
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSAnnotation
Autodesk.ProductInterface.PowerSHAPEPSAnnotationsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSAnnotationsCollection : PSEntitiesCollection<PSAnnotation>
Public Class PSAnnotationsCollection
    Inherits PSEntitiesCollection(Of PSAnnotation)

The PSAnnotationsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateAnnotation(String, String, Double, Point) | Creates a new annotation in PowwerSHAPE and adds it to the annotations collection.
Public method | CreateAnnotation(String, String, Double, Point, Double, TextJustifications, TextOrigins) | Creates a new annotation in PowwerSHAPE.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotationsCollection Properties

The PSAnnotationsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSAnnotationsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotationsCollection Methods

The PSAnnotationsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateAnnotation(String, String, Double, Point) | Creates a new annotation in PowwerSHAPE and adds it to the annotations collection.
Public method | CreateAnnotation(String, String, Double, Point, Double, TextJustifications, TextOrigins) | Creates a new annotation in PowwerSHAPE.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSAnnotationsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotationsCollection.CreateAnnotation Method

PSAnnotationsCollectionCreateAnnotation Method

Overload List
 | Name | Description
Public method | CreateAnnotation(String, String, Double, Point) | Creates a new annotation in PowwerSHAPE and adds it to the annotations collection.
Public method | CreateAnnotation(String, String, Double, Point, Double, TextJustifications, TextOrigins) | Creates a new annotation in PowwerSHAPE.
Top
See Also

Reference

PSAnnotationsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotationsCollection.CreateAnnotation Method (String, String, Double, Point)

PSAnnotationsCollectionCreateAnnotation Method (String, String, Double, Point)

Creates a new annotation in PowwerSHAPE and adds it to the annotations collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSAnnotation CreateAnnotation(
    string text,
    string fontName,
    double height,
    Point position
)
Public Function CreateAnnotation (
    text As String,
    fontName As String,
    height As Double,
    position As Point
) As PSAnnotation

Parameters

text
Type: SystemString
The text to introduce in PowerShape.
fontName
Type: SystemString
The font type for the text (e.g. Arial, Times New Roman). The font Type must exist in PowerShape.
height
Type: SystemDouble
The font height.
position
Type: Autodesk.GeometryPoint
The position of the text in the active workplane.

Return Value

Type: PSAnnotation
Remarks
The created text will have pitch of 0, text origin will be 'CENTRE' and text justification will be 'LEFT'.
See Also

Reference

PSAnnotationsCollection Class
CreateAnnotation Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotationsCollection.CreateAnnotation Method (String, String, Double, Point, Double, TextJustifications, TextOrigins)

PSAnnotationsCollectionCreateAnnotation Method (String, String, Double, Point, Double, TextJustifications, TextOrigins)

Creates a new annotation in PowwerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSAnnotation CreateAnnotation(
    string text,
    string fontName,
    double height,
    Point position,
    double pitch,
    TextJustifications textJustification,
    TextOrigins textOrigin
)
Public Function CreateAnnotation (
    text As String,
    fontName As String,
    height As Double,
    position As Point,
    pitch As Double,
    textJustification As TextJustifications,
    textOrigin As TextOrigins
) As PSAnnotation

Parameters

text
Type: SystemString
The text to introduce in PowerShape.
fontName
Type: SystemString
The font type for the text (e.g. Arial, Times New Roman). The font Type must exist in PowerShape.
height
Type: SystemDouble
The font height.
position
Type: Autodesk.GeometryPoint
The position of the text in the active workplane.
pitch
Type: SystemDouble
The distance between each character in a line.
textJustification
Type: Autodesk.ProductInterface.PowerSHAPETextJustifications
The wanted justify option. This is how the text in the block aligns with the left and right margins.
textOrigin
Type: Autodesk.ProductInterface.PowerSHAPETextOrigins
The origin of the text block. The origin is the 'anchor point' used to position the text and can be set at any of the four corners of the text box, the mid points of the sides of the text box or the centre of the text box. Use the option menu to change the origin of the text.

Return Value

Type: PSAnnotation
Remarks
See Also

Reference

PSAnnotationsCollection Class
CreateAnnotation Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAnnotationsCollection Fields

The PSAnnotationsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSAnnotationsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc Class

Captures an Arc object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSArc

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSArc : PSWireframe, IPSMoveable,
    IPSRotateable, IPSMirrorable, IPSLimitable, IPSCuttable, IPSOffsetable
Public Class PSArc
    Inherits PSWireframe
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSLimitable,
    IPSCuttable, IPSOffsetable

The PSArc type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Centre | Gets and sets the centre of the Arc
Public property | CentreNormal | Gets the vector of the normal to the arc plane
Public property | CentreOfGravity | Gets the Centre of Gravity of the arc (Overrides PSWireframeCentreOfGravity.)
Public property | EndAngle | Gets and sets the end angle of the Arc in Degrees
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | MidPoint | Gets the midpoint of the Arc
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Overrides the NumberPoints property, as an arc will always have 2 points (Overrides PSWireframeNumberPoints.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Arc (Overrides PSWireframePoints.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and sets the Radius of the Arc
Public property | Span | Gets and sets the span of the Arc in Degrees
Public property | StartAngle | Gets and sets the start angle of the Arc in Degrees
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Through | Gets and sets the Through point of the Arc (approximately the mid point of the Arc)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Cut | Cuts an arc at a specified point
Public method | Delete | Deletes the Arc from PowerSHAPE and removes it from the Arcs collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Full | Completes the Arc (equivalent of setting the span to 360 degrees)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LimitToEntities | Limits an arc by a specified list of entities.
Public method | LimitToEntity | Limits an arc by a specified list of entities
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single arc in a specified plane
Public method | MoveBetweenPoints | Moves a single arc by the relative distance between two absolute positions
Public method | MoveByVector | Moves a single arc by a specified relative amount
Public method | Offset | This operation offsets a single arc by a specified distance
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Reverse | Reverses the direction of the Arc
Public method | Rotate | Rotates a single arc by a specified angle around a specified axis
Public method | ScaleToCurve | Scales an arc within PowerSHAPE, returning a curve. This deletes the current arc.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc Properties

The PSArc type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Centre | Gets and sets the centre of the Arc
Public property | CentreNormal | Gets the vector of the normal to the arc plane
Public property | CentreOfGravity | Gets the Centre of Gravity of the arc (Overrides PSWireframeCentreOfGravity.)
Public property | EndAngle | Gets and sets the end angle of the Arc in Degrees
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | MidPoint | Gets the midpoint of the Arc
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Overrides the NumberPoints property, as an arc will always have 2 points (Overrides PSWireframeNumberPoints.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Arc (Overrides PSWireframePoints.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and sets the Radius of the Arc
Public property | Span | Gets and sets the span of the Arc in Degrees
Public property | StartAngle | Gets and sets the start angle of the Arc in Degrees
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Through | Gets and sets the Through point of the Arc (approximately the mid point of the Arc)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Centre Property

PSArcCentre Property

Gets and sets the centre of the Arc

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Centre { get; set; }
Public Property Centre As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.CentreNormal Property

PSArcCentreNormal Property

Gets the vector of the normal to the arc plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector CentreNormal { get; }
Public ReadOnly Property CentreNormal As Vector
    Get

Return Value

Type: Vector
Vector of the normal to the arc plane
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.CentreOfGravity Property

PSArcCentreOfGravity Property

Gets the Centre of Gravity of the arc

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point CentreOfGravity { get; }
Public Overrides ReadOnly Property CentreOfGravity As Point
    Get

Property Value

Type: Point
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.EndAngle Property

PSArcEndAngle Property

Gets and sets the end angle of the Arc in Degrees

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree EndAngle { get; }
Public ReadOnly Property EndAngle As Degree
    Get

Return Value

Type: Degree
Angle in degrees
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.MidPoint Property

PSArcMidPoint Property

Gets the midpoint of the Arc

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point MidPoint { get; }
Public ReadOnly Property MidPoint As Point
    Get

Property Value

Type: Point
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.NumberPoints Property

PSArcNumberPoints Property

Overrides the NumberPoints property, as an arc will always have 2 points

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int NumberPoints { get; }
Public Overrides ReadOnly Property NumberPoints As Integer
    Get

Return Value

Type: Int32
Always returns 2 as arcs have two points
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Points Property

PSArcPoints Property

Gets the points on the Arc

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override List<Point> Points { get; }
Public Overrides ReadOnly Property Points As List(Of Point)
    Get

Property Value

Type: List Point
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Radius Property

PSArcRadius Property

Gets and sets the Radius of the Arc

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Radius { get; set; }
Public Property Radius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Span Property

PSArcSpan Property

Gets and sets the span of the Arc in Degrees

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree Span { get; set; }
Public Property Span As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.StartAngle Property

PSArcStartAngle Property

Gets and sets the start angle of the Arc in Degrees

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree StartAngle { get; }
Public ReadOnly Property StartAngle As Degree
    Get

Return Value

Type: Degree
Angle in degrees
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Through Property

PSArcThrough Property

Gets and sets the Through point of the Arc (approximately the mid point of the Arc)

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Through { get; set; }
Public Property Through As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc Methods

The PSArc type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Cut | Cuts an arc at a specified point
Public method | Delete | Deletes the Arc from PowerSHAPE and removes it from the Arcs collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Full | Completes the Arc (equivalent of setting the span to 360 degrees)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LimitToEntities | Limits an arc by a specified list of entities.
Public method | LimitToEntity | Limits an arc by a specified list of entities
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single arc in a specified plane
Public method | MoveBetweenPoints | Moves a single arc by the relative distance between two absolute positions
Public method | MoveByVector | Moves a single arc by a specified relative amount
Public method | Offset | This operation offsets a single arc by a specified distance
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Reverse | Reverses the direction of the Arc
Public method | Rotate | Rotates a single arc by a specified angle around a specified axis
Public method | ScaleToCurve | Scales an arc within PowerSHAPE, returning a curve. This deletes the current arc.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Cut Method

PSArcCut Method

Cuts an arc at a specified point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity Cut(
    Point pointAtWhichToCut
)
Public Function Cut (
    pointAtWhichToCut As Point
) As PSEntity

Parameters

pointAtWhichToCut
Type: Autodesk.GeometryPoint
The point at which to cut the arc - this must lie on the arc

Return Value

Type: PSEntity
The cut piece of the original arc

Implements

IPSCuttableCut(Point)
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Delete Method

PSArcDelete Method

Deletes the Arc from PowerSHAPE and removes it from the Arcs collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Full Method

PSArcFull Method

Completes the Arc (equivalent of setting the span to 360 degrees)

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Full()
Public Sub Full
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.LimitToEntities Method

PSArcLimitToEntities Method

Limits an arc by a specified list of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntities(
    List<PSEntity> limitingEntities,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntities (
    limitingEntities As List(Of PSEntity),
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntities
Type: System.Collections.GenericList PSEntity
The entities with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
A list of limited entities.

Implements

IPSLimitableLimitToEntities(ListPSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.LimitToEntity Method

PSArcLimitToEntity Method

Limits an arc by a specified list of entities

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntity(
    PSEntity limitingEntity,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntity (
    limitingEntity As PSEntity,
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity with which to perform the limiting operation
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
A list of limited entities

Implements

IPSLimitableLimitToEntity(PSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.LimitUsingDynamicCutter Method

PSArcLimitUsingDynamicCutter Method

Limits using the dynamic cutter option.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity LimitUsingDynamicCutter(
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne
)
Public Function LimitUsingDynamicCutter (
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne
) As PSEntity

Parameters

keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.

Return Value

Type: PSEntity
Limited entity

Implements

IPSLimitableLimitUsingDynamicCutter(LimitingKeepOptions)
Remarks
To be used with PSEntityLimiter.NextSolution
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Mirror Method

PSArcMirror Method

Mirrors a single arc in a specified plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the arc
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.MoveBetweenPoints Method

PSArcMoveBetweenPoints Method

Moves a single arc by the relative distance between two absolute positions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
First of the two absolute positions
pointToMoveTo
Type: Autodesk.GeometryPoint
Second of the two absolute positions
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation

Return Value

Type: List PSEntity
A list of arcs created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.MoveByVector Method

PSArcMoveByVector Method

Moves a single arc by a specified relative amount

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
The relative amount by which the arc will be moved
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity
A list of arcs created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Offset Method

PSArcOffset Method

This operation offsets a single arc by a specified distance

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Offset(
    MM offsetDistance,
    int copiesToCreate
)
Public Function Offset (
    offsetDistance As MM,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

offsetDistance
Type: Autodesk.GeometryMM
The distance by which to offset the mesh
copiesToCreate
Type: SystemInt32
The number of copies to be created from the operation

Return Value

Type: List PSEntity
A list of offset arcs

Implements

IPSOffsetableOffset(MM, Int32)
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Reverse Method

PSArcReverse Method

Reverses the direction of the Arc

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Reverse()
Public Sub Reverse
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.Rotate Method

PSArcRotate Method

Rotates a single arc by a specified angle around a specified axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the arc is are to be rotated
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the arc is to be rotated
copiesToCreate
Type: SystemInt32
The number of copies to create of the original arc
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis

Return Value

Type: List PSEntity
A list of arcs created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc.ScaleToCurve Method

PSArcScaleToCurve Method

Scales an arc within PowerSHAPE, returning a curve. This deletes the current arc.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCurve ScaleToCurve(
    double offsetX,
    double offsetY,
    double offsetZ,
    Point scaleOrigin = null
)
Public Function ScaleToCurve (
    offsetX As Double,
    offsetY As Double,
    offsetZ As Double,
    Optional scaleOrigin As Point = Nothing
) As PSCurve

Parameters

offsetX
Type: SystemDouble
Scale value in X
offsetY
Type: SystemDouble
Scale value in Y
offsetZ
Type: SystemDouble
Scale value in Z
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Scale origin, workplane origin if none specified

Return Value

Type: PSCurve
Created arc
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArc Fields

The PSArc type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSArc Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection Class

Captures the collection of Arcs in a Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSArc
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSArc
Autodesk.ProductInterface.PowerSHAPEPSArcsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSArcsCollection : PSEntitiesCollection<PSArc>
Public Class PSArcsCollection
    Inherits PSEntitiesCollection(Of PSArc)

The PSArcsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateArcCircle | Creates an arc with the specified start point and radius.
Public method | CreateArcSpanExplicit | Creates an arc from the start point, with the specified radius, and with the specified span.
Public method | CreateArcSpanImplicit | Creates an arc between the start and end points, inferring the radius from the start point.
Public method | CreateArcThroughThreePoints | Creates an arc from the start point to the end point with a specified intermediate point. To subsequently change the radius to mimic PowerShape functionality, the Radius property should be used.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | SketchArcThroughThreePoints | Creates an Arc by allowing the user to sketch through three points
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection Properties

The PSArcsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSArcsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection Methods

The PSArcsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateArcCircle | Creates an arc with the specified start point and radius.
Public method | CreateArcSpanExplicit | Creates an arc from the start point, with the specified radius, and with the specified span.
Public method | CreateArcSpanImplicit | Creates an arc between the start and end points, inferring the radius from the start point.
Public method | CreateArcThroughThreePoints | Creates an arc from the start point to the end point with a specified intermediate point. To subsequently change the radius to mimic PowerShape functionality, the Radius property should be used.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | SketchArcThroughThreePoints | Creates an Arc by allowing the user to sketch through three points
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSArcsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection.CreateArcCircle Method

PSArcsCollectionCreateArcCircle Method

Creates an arc with the specified start point and radius.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSArc CreateArcCircle(
    Point centre,
    Point start,
    double radius
)
Public Function CreateArcCircle (
    centre As Point,
    start As Point,
    radius As Double
) As PSArc

Parameters

centre
Type: Autodesk.GeometryPoint
Centre point for arc
start
Type: Autodesk.GeometryPoint
Start point for arc
radius
Type: SystemDouble
Radius for arc

Return Value

Type: PSArc
Arc created by the operation
See Also

Reference

PSArcsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection.CreateArcSpanExplicit Method

PSArcsCollectionCreateArcSpanExplicit Method

Creates an arc from the start point, with the specified radius, and with the specified span.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSArc CreateArcSpanExplicit(
    Point centre,
    Point start,
    double radius,
    Degree span
)
Public Function CreateArcSpanExplicit (
    centre As Point,
    start As Point,
    radius As Double,
    span As Degree
) As PSArc

Parameters

centre
Type: Autodesk.GeometryPoint
Centre point for arc
start
Type: Autodesk.GeometryPoint
Start point for arc
radius
Type: SystemDouble
Radius for arc
span
Type: Autodesk.GeometryDegree
Span for arc

Return Value

Type: PSArc
Arc created by the operation
See Also

Reference

PSArcsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection.CreateArcSpanImplicit Method

PSArcsCollectionCreateArcSpanImplicit Method

Creates an arc between the start and end points, inferring the radius from the start point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSArc CreateArcSpanImplicit(
    Point centre,
    Point startPoint,
    Point endPoint
)
Public Function CreateArcSpanImplicit (
    centre As Point,
    startPoint As Point,
    endPoint As Point
) As PSArc

Parameters

centre
Type: Autodesk.GeometryPoint
Centre point for arc
startPoint
Type: Autodesk.GeometryPoint
Start point for arc
endPoint
Type: Autodesk.GeometryPoint
End point for arc

Return Value

Type: PSArc
Arc created by the operation
See Also

Reference

PSArcsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection.CreateArcThroughThreePoints Method

PSArcsCollectionCreateArcThroughThreePoints Method

Creates an arc from the start point to the end point with a specified intermediate point. To subsequently change the radius to mimic PowerShape functionality, the Radius property should be used.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSArc CreateArcThroughThreePoints(
    Point startPoint,
    Point endPoint,
    Point intermediatePoint
)
Public Function CreateArcThroughThreePoints (
    startPoint As Point,
    endPoint As Point,
    intermediatePoint As Point
) As PSArc

Parameters

startPoint
Type: Autodesk.GeometryPoint
The start point of the arc.
endPoint
Type: Autodesk.GeometryPoint
The end point of the arc.
intermediatePoint
Type: Autodesk.GeometryPoint
An intermediate point on the span of the arc between the start and end point.

Return Value

Type: PSArc
See Also

Reference

PSArcsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection.SketchArcThroughThreePoints Method

PSArcsCollectionSketchArcThroughThreePoints Method

Creates an Arc by allowing the user to sketch through three points

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSArc SketchArcThroughThreePoints(
    double interval = 500
)
Public Function SketchArcThroughThreePoints (
    Optional interval As Double = 500
) As PSArc

Parameters

interval (Optional)
Type: SystemDouble
The time in milliseconds between each check to see if the curve has been created yet

Return Value

Type: PSArc
Arc created by the operation
See Also

Reference

PSArcsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSArcsCollection Fields

The PSArcsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSArcsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation Class

This is the root class of a PowerSHAPE instance. When it is created it creates its own instance of PowerSHAPE. When it is destroyed the instance of PowerSHAPE will also be destroyed.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceAutomation
Autodesk.ProductInterface.PowerSHAPEPSAutomation

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSAutomation : Automation,
    IDisposable
Public Class PSAutomation
    Inherits Automation
    Implements IDisposable

The PSAutomation type exposes the following members.

Constructors
 | Name | Description
Public method | PSAutomation(Object) | Connect to an instance of PowerShape that is passed in (this should be the COM object)
Public method | PSAutomation(InstanceReuse, Modes) | Calls down to the base class to start PowerSHAPE based on the specified startup option.
Public method | PSAutomation(InstanceReuse, Version, Version, Modes) | Calls down to the base class to start PowerSHAPE based on the specified options.
Top
Properties
 | Name | Description
Public property | ActiveModel | Gets the Active Model from within PowerSHAPE.
Public property | ActiveWindow | Gets the active window from within PowerSHAPE.
Public property | ArcFitPicFiles | Sets whether to arc fit comp curves when importing DUCT Picture files
Public property | DrawingTolerance | Gets and sets the drawing tolerance of all models.
Protected property | ExecutableName | The name of the process in the process list. (Overrides AutomationExecutableName.)
Public property | IsCurveApplySmoothness | Sets whether the Curve apply smoothing to end points is enabled.
Public property | IsCurveCurvatureCombsVisible | Sets whether the Curvature Combs are visible or not.
Public property | IsCurvePointLabelsVisible | Sets whether the Point Labels are visible or not.
Public property | IsGUIVisible | Shows/Hides the User Interface (toolbars, etc.). (Overrides AutomationIsGUIVisible.)
Public property | IsIntelligentCursorOn | Gets and sets whether the intelligent cursor is on or off.
Public property | IsInTrimRegionEditing | Gets/sets whether PowerSHAPE is in surface trim region editing mode.
Public property | IsPlanesLocked | Sets whether or not planes are locked.
Public property | IsRunning | True if the process is running; false otherwise. (Inherited from Automation.)
Public property | IsVisible | Gets or sets the property showing whether PowerSHAPE is visible or not. (Overrides AutomationIsVisible.)
Public property | MainWindowId | Gets the handle of the main window for PowerSHAPE. (Overrides AutomationMainWindowId.)
Public property | Mode | Gets the mode in which PowerSHAPE is running.
Public property | Models | Gets the list of Models currently open in PowerSHAPE.
Public property | ProcessId | Process id of the application instance. (Inherited from Automation.)
Public property | TrimRegionEditingMode | Toggles the current trim editing mode between boundary editing and pCurve editing.
Public property | UserLogin | The user's login
Public property | UserName | The user's name
Public property | Version | Version of the current application. (Inherited from Automation.)
Public property | Windows | Gets the list of Windows currently open in PowerSHAPE.
Top
Methods
 | Name | Description
Protected method | CloseAllInstancesOf | Closes all instances of a process with the specified name. (Inherited from Automation.)
Public method | CloseDynamicSectioning | Closes the Dynamic Sectioning view.
Protected method | CreateNewInstance | Creates a new instance of PowerShape. (Overrides AutomationCreateNewInstance(Version, Version).)
Protected method | CreateSingleInstance | Closes all running instance of PowerSHAPE and start a new one. (Overrides AutomationCreateSingleInstance(Version, Version).)
Public method | CreateWireframeAtFrontPlane | Creates composite curves through the model at the front plane for Dynamic Sectioning.
Public method | CreateWireframeAtRearPlane | Creates composite curves through the model at the rear plane for Dynamic Sectioning.
Public method | CreateWorkplaneAtFrontPlane | Creates a workplane at the centre of the front plane for Dynamic Sectioning.
Public method | CreateWorkplaneAtRearPlane | Creates a workplane at the centre of the rear plane for Dynamic Sectioning.
Public method | DialogsOff | Switches the dialogs off in PowerSHAPE.
Public method | DialogsOn | Switches the dialogs on in PowerSHAPE.
Public method | Dispose | Releases all resources used by the PSAutomation
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PSAutomation and optionally releases the managed resources
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecutablePath | Retrieves from the registry the path to the specified application. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then the path to this executable will be returned. Should maximumVersion be unspecified, only the path to the absolute version specified in version will be returned. (Inherited from Automation.)
Public method | Execute | Obsolete. Runs an array of commands in PowerSHAPE. It is marked as obsolete as all commands should be available as functions in this Automation Interface.
Public method | ExecuteEx | Obsolete. Evaluates the given command in PowerSHAPE. It is marked as obsolete as all commands should be available as functions in this Automation Interface.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormUpdateOff | Turns Forms off. Any forms raised will not be shown.
Public method | FormUpdateOn | Turns Forms on. Any forms raised will be shown on screen.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialise(InstanceReuse) | Specifies whether an existing instance of the application be used or a new one created. This implementation is version non-specific and either the first existing instance of the application found or the latest installed version will be used. (Inherited from Automation.)
Protected method | Initialise(InstanceReuse, Version, Version) | Specifies whether an existing instance of the application be used or a new one created. The application version must be specified and, optionally, a maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Public method | LoadMacro(String) | Create a macro from a string.
Public method | LoadMacro(File) | Loads a macro from the specified file that can be stepped through or run with progress feedback.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PickPoint | Starts a point picking function in PowerSHAPE and will wait until the point is picked.
Public method | Quit | Closes the instance of the PowerSHAPE. (Overrides AutomationQuit.)
Public method | RecordMacro | Records the macro into file path. (Overrides AutomationRecordMacro(String).)
Public method | RefreshOff | Turns graphics updates off.
Public method | RefreshOn | Turns graphics updates on.
Public method | RefreshWindowsAndModelsList | Refresh the list of windows and models. Use it if a model has been added manually.
Public method | Reset | Closes all Models in PowerSHAPE and create a new one.
Public method | ResetDynamicSectioning | Open/Reset the Dynamic Sectioning view.
Public method | ResizeViewToFit | Resize the view to fit all visible items.
Public method | RunMacro(String) | Runs the Macro at the given location.
Public method | RunMacro(File) | Runs the Macro at the given location.
Public method | RunMacro(PSMacro) | Runs the specified Macro.
Public method | SetActivePlane | Sets the active plane of PowerSHAPE.
Public method | SetDynamicSectioningCapSolids | Sets whether cap solids are draw in dynamic sectioning mode.
Public method | SetDynamicSectioningDrawEdges | Sets whether edges are draw in dynamic sectioning mode.
Public method | SetDynamicSectioningFrontPlane | Set the position of the front plane for Dynamic Sectioning.
Public method | SetDynamicSectioningRearPlane | Sets the position of the rear plane for Dynamic Sectioning.
Public method | SetDynamicSectioningTranslucency | Sets whether transparency is shown in dynamic sectioning mode.
Public method | SetEnhancedShading | Sets the view to enhanced shading.
Public method | SetHiddenWireframeView | Sets the view to show wireframes including hidden wireframe.
Public method | SetMeshViewOpenAndInteriorEdgesAndNodesHollow | Sets the view for a Mesh to show open edges and triangle edges and triangle nodes with the triangles hollow.
Public method | SetMeshViewOpenAndInteriorEdgesAndNodesShaded | Sets the view for a Mesh to show open edges and triangle edges and triangle nodes with the triangles shaded.
Public method | SetMeshViewOpenAndInteriorEdgesHollow | Sets the view for a Mesh to show open edges and triangle edges with the triangles hollow.
Public method | SetMeshViewOpenAndInteriorEdgesShaded | Sets the view for a Mesh to show open edges and triangle edges with the triangles shaded.
Public method | SetMeshViewOpenEdgesOnlyShaded | Sets the view for a Mesh to show open edges with the triangles shaded.
Public method | SetMultipleViewAngle | Sets a multiple view angle rather than a single view angle. This will split the screen into three or four views.
Public method | SetShadedAndWireframeView | Sets the view to show shaded wireframe.
Public method | SetShadedView | Sets the view to normal shading.
Public method | SetShadedWireframeView | Sets the view to show wireframes with a shaded model.
Public method | SetShadingTolerance | Sets the shading tolerance for PowerSHAPE and regenerates triangles
Public method | SetSplit2ViewAngle | Sets the view angles and relationships for a 2 split view. The relationship locks the child's rotation to that of the parent.
Public method | SetSplit4ViewAngle | Sets the view angles and relationships for a 4 split view. The relationship locks the child's rotation to that of the parent.
Public method | SetViewAngle | Sets the View Angle of PowerSHAPE. (Overrides AutomationSetViewAngle(ViewAngles).)
Public method | SetWireframeView | Sets the view to show wireframes.
Protected method | StartByClassId | Creates and returns a reference to a COM object as specified by the ClassId argument. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Protected method | StartExecutable | Launches the executable located at the path retrieved from the registry for the specified application name, version and maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Public method | StopMacroRecording | Stops recording macro. (Overrides AutomationStopMacroRecording.)
Public method | ToggleTransparentView | Toggles transparent shading.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UseExistingInstance | Attempts to connect to an existing version of PowerSHAPE or create a new one. (Overrides AutomationUseExistingInstance(Version, Version).)
Top
Fields
 | Name | Description
Protected field | _instanceReuse | Indicates whether a new instance of the application should be launched or an existing one be used. (Inherited from Automation.)
Protected field | _isGUIVisible | If True, the GUI is shown; false otherwise. (Inherited from Automation.)
Protected field | _processId | Application process id. (Inherited from Automation.)
Protected field | _version | Specifies the application version to use. (Inherited from Automation.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation Constructor

Overload List
 | Name | Description
Public method | PSAutomation(Object) | Connect to an instance of PowerShape that is passed in (this should be the COM object)
Public method | PSAutomation(InstanceReuse, Modes) | Calls down to the base class to start PowerSHAPE based on the specified startup option.
Public method | PSAutomation(InstanceReuse, Version, Version, Modes) | Calls down to the base class to start PowerSHAPE based on the specified options.
Top
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation Constructor (Object)

Connect to an instance of PowerShape that is passed in (this should be the COM object)

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSAutomation(
    Object powerShapeComObject
)
Public Sub New (
    powerShapeComObject As Object
)

Parameters

powerShapeComObject
Type: SystemObject
The COM object of PowerShape to connect to.
See Also

Reference

PSAutomation Class
PSAutomation Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation Constructor (InstanceReuse, Modes)

Calls down to the base class to start PowerSHAPE based on the specified startup option.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSAutomation(
    InstanceReuse instanceReuse,
    Modes applicationMode = Modes.PShapeMode
)
Public Sub New (
    instanceReuse As InstanceReuse,
    Optional applicationMode As Modes = Modes.PShapeMode
)

Parameters

instanceReuse
Type: Autodesk.ProductInterfaceInstanceReuse
Specifies how to start the application (e.g. use existing running PowerShape instance, create a new instance alongside any existing instances, etc.)
applicationMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPEModes
The mode in which PowerSHAPE will run.
Remarks
See Also

Reference

PSAutomation Class
PSAutomation Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation Constructor (InstanceReuse, Version, Version, Modes)

Calls down to the base class to start PowerSHAPE based on the specified options.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSAutomation(
    InstanceReuse instanceReuse,
    Version version,
    Version maximumVersion = null,
    Modes applicationMode = Modes.PShapeMode
)
Public Sub New (
    instanceReuse As InstanceReuse,
    version As Version,
    Optional maximumVersion As Version = Nothing,
    Optional applicationMode As Modes = Modes.PShapeMode
)

Parameters

instanceReuse
Type: Autodesk.ProductInterfaceInstanceReuse
Specifies how to start the application (e.g. use existing running PowerShape instance, create a new instance alongside any existing instances, etc.)
version
Type: SystemVersion
The version to run.
maximumVersion (Optional)
Type: SystemVersion
If filled, the version of PowerShape to run has to be less of equal to 'maximumVersion'.
applicationMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPEModes
The mode in which PowerSHAPE will run.
Remarks
See Also

Reference

PSAutomation Class
PSAutomation Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation Properties

The PSAutomation type exposes the following members.

Properties
 | Name | Description
Public property | ActiveModel | Gets the Active Model from within PowerSHAPE.
Public property | ActiveWindow | Gets the active window from within PowerSHAPE.
Public property | ArcFitPicFiles | Sets whether to arc fit comp curves when importing DUCT Picture files
Public property | DrawingTolerance | Gets and sets the drawing tolerance of all models.
Protected property | ExecutableName | The name of the process in the process list. (Overrides AutomationExecutableName.)
Public property | IsCurveApplySmoothness | Sets whether the Curve apply smoothing to end points is enabled.
Public property | IsCurveCurvatureCombsVisible | Sets whether the Curvature Combs are visible or not.
Public property | IsCurvePointLabelsVisible | Sets whether the Point Labels are visible or not.
Public property | IsGUIVisible | Shows/Hides the User Interface (toolbars, etc.). (Overrides AutomationIsGUIVisible.)
Public property | IsIntelligentCursorOn | Gets and sets whether the intelligent cursor is on or off.
Public property | IsInTrimRegionEditing | Gets/sets whether PowerSHAPE is in surface trim region editing mode.
Public property | IsPlanesLocked | Sets whether or not planes are locked.
Public property | IsRunning | True if the process is running; false otherwise. (Inherited from Automation.)
Public property | IsVisible | Gets or sets the property showing whether PowerSHAPE is visible or not. (Overrides AutomationIsVisible.)
Public property | MainWindowId | Gets the handle of the main window for PowerSHAPE. (Overrides AutomationMainWindowId.)
Public property | Mode | Gets the mode in which PowerSHAPE is running.
Public property | Models | Gets the list of Models currently open in PowerSHAPE.
Public property | ProcessId | Process id of the application instance. (Inherited from Automation.)
Public property | TrimRegionEditingMode | Toggles the current trim editing mode between boundary editing and pCurve editing.
Public property | UserLogin | The user's login
Public property | UserName | The user's name
Public property | Version | Version of the current application. (Inherited from Automation.)
Public property | Windows | Gets the list of Windows currently open in PowerSHAPE.
Top
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.ActiveModel Property

PSAutomationActiveModel Property

Gets the Active Model from within PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSModel ActiveModel { get; }
Public ReadOnly Property ActiveModel As PSModel
    Get

Property Value

Type: PSModel
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.ActiveWindow Property

PSAutomationActiveWindow Property

Gets the active window from within PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWindow ActiveWindow { get; }
Public ReadOnly Property ActiveWindow As PSWindow
    Get

Property Value

Type: PSWindow
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.ArcFitPicFiles Property

PSAutomationArcFitPicFiles Property

Sets whether to arc fit comp curves when importing DUCT Picture files

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool ArcFitPicFiles { set; }
Public WriteOnly Property ArcFitPicFiles As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.DrawingTolerance Property

PSAutomationDrawingTolerance Property

Gets and sets the drawing tolerance of all models.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double DrawingTolerance { get; set; }
Public Property DrawingTolerance As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.ExecutableName Property

PSAutomationExecutableName Property

The name of the process in the process list.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override Object ExecutableName { get; }
Protected Overrides ReadOnly Property ExecutableName As Object
    Get

Property Value

Type: Object
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.IsCurveApplySmoothness Property

PSAutomationIsCurveApplySmoothness Property

Sets whether the Curve apply smoothing to end points is enabled.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsCurveApplySmoothness { set; }
Public WriteOnly Property IsCurveApplySmoothness As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.IsCurveCurvatureCombsVisible Property

PSAutomationIsCurveCurvatureCombsVisible Property

Sets whether the Curvature Combs are visible or not.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsCurveCurvatureCombsVisible { set; }
Public WriteOnly Property IsCurveCurvatureCombsVisible As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.IsCurvePointLabelsVisible Property

PSAutomationIsCurvePointLabelsVisible Property

Sets whether the Point Labels are visible or not.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsCurvePointLabelsVisible { set; }
Public WriteOnly Property IsCurvePointLabelsVisible As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.IsGUIVisible Property

PSAutomationIsGUIVisible Property

Shows/Hides the User Interface (toolbars, etc.).

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool IsGUIVisible { get; set; }
Public Overrides Property IsGUIVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.IsIntelligentCursorOn Property

PSAutomationIsIntelligentCursorOn Property

Gets and sets whether the intelligent cursor is on or off.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsIntelligentCursorOn { get; set; }
Public Property IsIntelligentCursorOn As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.IsInTrimRegionEditing Property

PSAutomationIsInTrimRegionEditing Property

Gets/sets whether PowerSHAPE is in surface trim region editing mode.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsInTrimRegionEditing { get; set; }
Public Property IsInTrimRegionEditing As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.IsPlanesLocked Property

PSAutomationIsPlanesLocked Property

Sets whether or not planes are locked.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsPlanesLocked { set; }
Public WriteOnly Property IsPlanesLocked As Boolean
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.IsVisible Property

PSAutomationIsVisible Property

Gets or sets the property showing whether PowerSHAPE is visible or not.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool IsVisible { get; set; }
Public Overrides Property IsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.MainWindowId Property

PSAutomationMainWindowId Property

Gets the handle of the main window for PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int MainWindowId { get; }
Public Overrides ReadOnly Property MainWindowId As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Mode Property

PSAutomationMode Property

Gets the mode in which PowerSHAPE is running.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Modes Mode { get; }
Public ReadOnly Property Mode As Modes
    Get

Property Value

Type: Modes
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Models Property

PSAutomationModels Property

Gets the list of Models currently open in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSModelsCollection Models { get; }
Public ReadOnly Property Models As PSModelsCollection
    Get

Return Value

Type: PSModelsCollection
The list of Models currently open in PowerSHAPE.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.TrimRegionEditingMode Property

PSAutomationTrimRegionEditingMode Property

Toggles the current trim editing mode between boundary editing and pCurve editing.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public TrimRegionEditingModes TrimRegionEditingMode { get; set; }
Public Property TrimRegionEditingMode As TrimRegionEditingModes
    Get
    Set

Property Value

Type: TrimRegionEditingModes
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.UserLogin Property

PSAutomationUserLogin Property

The user's login

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string UserLogin { get; }
Public ReadOnly Property UserLogin As String
    Get

Return Value

Type: String
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.UserName Property

PSAutomationUserName Property

The user's name

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get

Return Value

Type: String
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Windows Property

PSAutomationWindows Property

Gets the list of Windows currently open in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWindowsCollection Windows { get; }
Public ReadOnly Property Windows As PSWindowsCollection
    Get

Property Value

Type: PSWindowsCollection

Return Value

Type: PSWindowsCollection
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation Methods

The PSAutomation type exposes the following members.

Methods
 | Name | Description
Protected method | CloseAllInstancesOf | Closes all instances of a process with the specified name. (Inherited from Automation.)
Public method | CloseDynamicSectioning | Closes the Dynamic Sectioning view.
Protected method | CreateNewInstance | Creates a new instance of PowerShape. (Overrides AutomationCreateNewInstance(Version, Version).)
Protected method | CreateSingleInstance | Closes all running instance of PowerSHAPE and start a new one. (Overrides AutomationCreateSingleInstance(Version, Version).)
Public method | CreateWireframeAtFrontPlane | Creates composite curves through the model at the front plane for Dynamic Sectioning.
Public method | CreateWireframeAtRearPlane | Creates composite curves through the model at the rear plane for Dynamic Sectioning.
Public method | CreateWorkplaneAtFrontPlane | Creates a workplane at the centre of the front plane for Dynamic Sectioning.
Public method | CreateWorkplaneAtRearPlane | Creates a workplane at the centre of the rear plane for Dynamic Sectioning.
Public method | DialogsOff | Switches the dialogs off in PowerSHAPE.
Public method | DialogsOn | Switches the dialogs on in PowerSHAPE.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecutablePath | Retrieves from the registry the path to the specified application. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then the path to this executable will be returned. Should maximumVersion be unspecified, only the path to the absolute version specified in version will be returned. (Inherited from Automation.)
Public method | Execute | Obsolete. Runs an array of commands in PowerSHAPE. It is marked as obsolete as all commands should be available as functions in this Automation Interface.
Public method | ExecuteEx | Obsolete. Evaluates the given command in PowerSHAPE. It is marked as obsolete as all commands should be available as functions in this Automation Interface.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormUpdateOff | Turns Forms off. Any forms raised will not be shown.
Public method | FormUpdateOn | Turns Forms on. Any forms raised will be shown on screen.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialise(InstanceReuse) | Specifies whether an existing instance of the application be used or a new one created. This implementation is version non-specific and either the first existing instance of the application found or the latest installed version will be used. (Inherited from Automation.)
Protected method | Initialise(InstanceReuse, Version, Version) | Specifies whether an existing instance of the application be used or a new one created. The application version must be specified and, optionally, a maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Public method | LoadMacro(String) | Create a macro from a string.
Public method | LoadMacro(File) | Loads a macro from the specified file that can be stepped through or run with progress feedback.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PickPoint | Starts a point picking function in PowerSHAPE and will wait until the point is picked.
Public method | Quit | Closes the instance of the PowerSHAPE. (Overrides AutomationQuit.)
Public method | RecordMacro | Records the macro into file path. (Overrides AutomationRecordMacro(String).)
Public method | RefreshOff | Turns graphics updates off.
Public method | RefreshOn | Turns graphics updates on.
Public method | RefreshWindowsAndModelsList | Refresh the list of windows and models. Use it if a model has been added manually.
Public method | Reset | Closes all Models in PowerSHAPE and create a new one.
Public method | ResetDynamicSectioning | Open/Reset the Dynamic Sectioning view.
Public method | ResizeViewToFit | Resize the view to fit all visible items.
Public method | RunMacro(String) | Runs the Macro at the given location.
Public method | RunMacro(File) | Runs the Macro at the given location.
Public method | RunMacro(PSMacro) | Runs the specified Macro.
Public method | SetActivePlane | Sets the active plane of PowerSHAPE.
Public method | SetDynamicSectioningCapSolids | Sets whether cap solids are draw in dynamic sectioning mode.
Public method | SetDynamicSectioningDrawEdges | Sets whether edges are draw in dynamic sectioning mode.
Public method | SetDynamicSectioningFrontPlane | Set the position of the front plane for Dynamic Sectioning.
Public method | SetDynamicSectioningRearPlane | Sets the position of the rear plane for Dynamic Sectioning.
Public method | SetDynamicSectioningTranslucency | Sets whether transparency is shown in dynamic sectioning mode.
Public method | SetEnhancedShading | Sets the view to enhanced shading.
Public method | SetHiddenWireframeView | Sets the view to show wireframes including hidden wireframe.
Public method | SetMeshViewOpenAndInteriorEdgesAndNodesHollow | Sets the view for a Mesh to show open edges and triangle edges and triangle nodes with the triangles hollow.
Public method | SetMeshViewOpenAndInteriorEdgesAndNodesShaded | Sets the view for a Mesh to show open edges and triangle edges and triangle nodes with the triangles shaded.
Public method | SetMeshViewOpenAndInteriorEdgesHollow | Sets the view for a Mesh to show open edges and triangle edges with the triangles hollow.
Public method | SetMeshViewOpenAndInteriorEdgesShaded | Sets the view for a Mesh to show open edges and triangle edges with the triangles shaded.
Public method | SetMeshViewOpenEdgesOnlyShaded | Sets the view for a Mesh to show open edges with the triangles shaded.
Public method | SetMultipleViewAngle | Sets a multiple view angle rather than a single view angle. This will split the screen into three or four views.
Public method | SetShadedAndWireframeView | Sets the view to show shaded wireframe.
Public method | SetShadedView | Sets the view to normal shading.
Public method | SetShadedWireframeView | Sets the view to show wireframes with a shaded model.
Public method | SetShadingTolerance | Sets the shading tolerance for PowerSHAPE and regenerates triangles
Public method | SetSplit2ViewAngle | Sets the view angles and relationships for a 2 split view. The relationship locks the child's rotation to that of the parent.
Public method | SetSplit4ViewAngle | Sets the view angles and relationships for a 4 split view. The relationship locks the child's rotation to that of the parent.
Public method | SetViewAngle | Sets the View Angle of PowerSHAPE. (Overrides AutomationSetViewAngle(ViewAngles).)
Public method | SetWireframeView | Sets the view to show wireframes.
Protected method | StartByClassId | Creates and returns a reference to a COM object as specified by the ClassId argument. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Protected method | StartExecutable | Launches the executable located at the path retrieved from the registry for the specified application name, version and maximum version. If a version greater than that specified in version, but less than or equal to that specified by maximumVersion is found, then this will be used. Should maximumVersion be unspecified, only the absolute version specified in version will be used. (Inherited from Automation.)
Public method | StopMacroRecording | Stops recording macro. (Overrides AutomationStopMacroRecording.)
Public method | ToggleTransparentView | Toggles transparent shading.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UseExistingInstance | Attempts to connect to an existing version of PowerSHAPE or create a new one. (Overrides AutomationUseExistingInstance(Version, Version).)
Top
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.CloseDynamicSectioning Method

PSAutomationCloseDynamicSectioning Method

Closes the Dynamic Sectioning view.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CloseDynamicSectioning()
Public Sub CloseDynamicSectioning
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.CreateNewInstance Method

PSAutomationCreateNewInstance Method

Creates a new instance of PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override void CreateNewInstance(
    Version version,
    Version maximumVersion
)
Protected Overrides Sub CreateNewInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
The version to run.
maximumVersion
Type: SystemVersion
If filled, the version of PowerShape to run has to be less of equal to 'maximumVersion'.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.CreateSingleInstance Method

PSAutomationCreateSingleInstance Method

Closes all running instance of PowerSHAPE and start a new one.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override void CreateSingleInstance(
    Version version,
    Version maximumVersion
)
Protected Overrides Sub CreateSingleInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
The version to run.
maximumVersion
Type: SystemVersion
If filled, the version of PowerShape to run has to be less of equal to 'maximumVersion'.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.CreateWireframeAtFrontPlane Method

PSAutomationCreateWireframeAtFrontPlane Method

Creates composite curves through the model at the front plane for Dynamic Sectioning.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateWireframeAtFrontPlane()
Public Function CreateWireframeAtFrontPlane As List(Of PSCompCurve)

Return Value

Type: List PSCompCurve
A list of created curves
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.CreateWireframeAtRearPlane Method

PSAutomationCreateWireframeAtRearPlane Method

Creates composite curves through the model at the rear plane for Dynamic Sectioning.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateWireframeAtRearPlane()
Public Function CreateWireframeAtRearPlane As List(Of PSCompCurve)

Return Value

Type: List PSCompCurve
The list of created curves.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.CreateWorkplaneAtFrontPlane Method

PSAutomationCreateWorkplaneAtFrontPlane Method

Creates a workplane at the centre of the front plane for Dynamic Sectioning.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplaneAtFrontPlane()
Public Function CreateWorkplaneAtFrontPlane As PSWorkplane

Return Value

Type: PSWorkplane
The created Workplane or Nothing if this failed.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.CreateWorkplaneAtRearPlane Method

PSAutomationCreateWorkplaneAtRearPlane Method

Creates a workplane at the centre of the rear plane for Dynamic Sectioning.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplaneAtRearPlane()
Public Function CreateWorkplaneAtRearPlane As PSWorkplane

Return Value

Type: PSWorkplane
The created Workplane or Nothing if this failed.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.DialogsOff Method

PSAutomationDialogsOff Method

Switches the dialogs off in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DialogsOff()
Public Sub DialogsOff
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.DialogsOn Method

PSAutomationDialogsOn Method

Switches the dialogs on in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DialogsOn()
Public Sub DialogsOn
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Dispose Method

PSAutomationDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PSAutomation
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PSAutomation and optionally releases the managed resources
Top
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Dispose Method

PSAutomationDispose Method

Releases all resources used by the PSAutomation

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PSAutomation Class
Dispose Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Dispose Method (Boolean)

PSAutomationDispose Method (Boolean)

Releases the unmanaged resources used by the PSAutomation and optionally releases the managed resources

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PSAutomation Class
Dispose Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Execute Method

PSAutomationExecute Method

Note: This API is now obsolete.

Runs an array of commands in PowerSHAPE. It is marked as obsolete as all commands should be available as functions in this Automation Interface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[ObsoleteAttribute("")]
public void Execute(
    params string[] commands
)
<ObsoleteAttribute("")>
Public Sub Execute (
    ParamArray commands As String()
)

Parameters

commands
Type: SystemString
The commands to execute.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.ExecuteEx Method

PSAutomationExecuteEx Method

Note: This API is now obsolete.

Evaluates the given command in PowerSHAPE. It is marked as obsolete as all commands should be available as functions in this Automation Interface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
[ObsoleteAttribute("")]
public Object ExecuteEx(
    string command
)
<ObsoleteAttribute("")>
Public Function ExecuteEx (
    command As String
) As Object

Parameters

command
Type: SystemString
The commands to execute.

Return Value

Type: Object
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.FormUpdateOff Method

PSAutomationFormUpdateOff Method

Turns Forms off. Any forms raised will not be shown.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FormUpdateOff()
Public Sub FormUpdateOff
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.FormUpdateOn Method

PSAutomationFormUpdateOn Method

Turns Forms on. Any forms raised will be shown on screen.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FormUpdateOn()
Public Sub FormUpdateOn
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.LoadMacro Method

PSAutomationLoadMacro Method

Overload List
 | Name | Description
Public method | LoadMacro(String) | Create a macro from a string.
Public method | LoadMacro(File) | Loads a macro from the specified file that can be stepped through or run with progress feedback.
Top
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.LoadMacro Method (String[])

PSAutomationLoadMacro Method (String)

Create a macro from a string.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMacro LoadMacro(
    params string[] macro
)
Public Function LoadMacro (
    ParamArray macro As String()
) As PSMacro

Parameters

macro
Type: SystemString
macro list.

Return Value

Type: PSMacro
The new PMMacro.
See Also

Reference

PSAutomation Class
LoadMacro Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.LoadMacro Method (File)

PSAutomationLoadMacro Method (File)

Loads a macro from the specified file that can be stepped through or run with progress feedback.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMacro LoadMacro(
    File macroFile
)
Public Function LoadMacro (
    macroFile As File
) As PSMacro

Parameters

macroFile
Type: Autodesk.FileSystemFile
The file path from which to load the macro.

Return Value

Type: PSMacro
The new loaded macro.
Remarks
See Also

Reference

PSAutomation Class
LoadMacro Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.PickPoint Method

PSAutomationPickPoint Method

Starts a point picking function in PowerSHAPE and will wait until the point is picked.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point PickPoint(
    ICancelPointPickCheck cancelPointPickingCheck = null
)
Public Function PickPoint (
    Optional cancelPointPickingCheck As ICancelPointPickCheck = Nothing
) As Point

Parameters

cancelPointPickingCheck (Optional)
Type: Autodesk.ProductInterfaceICancelPointPickCheck
Contains a previous state of CancelPointPickCheck.

Return Value

Type: Point
The point picked by the user or nothing if cancelled.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Quit Method

PSAutomationQuit Method

Closes the instance of the PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Quit()
Public Overrides Sub Quit
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.RecordMacro Method

PSAutomationRecordMacro Method

Records the macro into file path.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RecordMacro(
    string macroFilename
)
Public Overrides Sub RecordMacro (
    macroFilename As String
)

Parameters

macroFilename
Type: SystemString
The file path to save the macro.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.RefreshOff Method

PSAutomationRefreshOff Method

Turns graphics updates off.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RefreshOff()
Public Sub RefreshOff
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.RefreshOn Method

PSAutomationRefreshOn Method

Turns graphics updates on.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RefreshOn()
Public Sub RefreshOn
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.RefreshWindowsAndModelsList Method

PSAutomationRefreshWindowsAndModelsList Method

Refresh the list of windows and models. Use it if a model has been added manually.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RefreshWindowsAndModelsList()
Public Sub RefreshWindowsAndModelsList
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.Reset Method

PSAutomationReset Method

Closes all Models in PowerSHAPE and create a new one.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSModel Reset()
Public Function Reset As PSModel

Return Value

Type: PSModel
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.ResetDynamicSectioning Method

PSAutomationResetDynamicSectioning Method

Open/Reset the Dynamic Sectioning view.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ResetDynamicSectioning(
    bool drawEdges = false,
    bool translucency = false,
    bool capSolids = false
)
Public Sub ResetDynamicSectioning (
    Optional drawEdges As Boolean = false,
    Optional translucency As Boolean = false,
    Optional capSolids As Boolean = false
)

Parameters

drawEdges (Optional)
Type: SystemBoolean
Select this option to draw the edges of the section.
translucency (Optional)
Type: SystemBoolean
Select this option to draw the section translucent.
capSolids (Optional)
Type: SystemBoolean
Select this option to display a cap on the solid where it is intersects with the clipping plane.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.ResizeViewToFit Method

PSAutomationResizeViewToFit Method

Resize the view to fit all visible items.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ResizeViewToFit()
Public Sub ResizeViewToFit
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.RunMacro Method

PSAutomationRunMacro Method

Overload List
 | Name | Description
Public method | RunMacro(String) | Runs the Macro at the given location.
Public method | RunMacro(File) | Runs the Macro at the given location.
Public method | RunMacro(PSMacro) | Runs the specified Macro.
Top
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.RunMacro Method (String[])

PSAutomationRunMacro Method (String)

Runs the Macro at the given location.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RunMacro(
    params string[] macro
)
Public Sub RunMacro (
    ParamArray macro As String()
)

Parameters

macro
Type: SystemString
The macro lines.
See Also

Reference

PSAutomation Class
RunMacro Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.RunMacro Method (File)

PSAutomationRunMacro Method (File)

Runs the Macro at the given location.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RunMacro(
    File macroFile
)
Public Sub RunMacro (
    macroFile As File
)

Parameters

macroFile
Type: Autodesk.FileSystemFile
The file path to the macro.
Remarks
See Also

Reference

PSAutomation Class
RunMacro Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.RunMacro Method (PSMacro)

PSAutomationRunMacro Method (PSMacro)

Runs the specified Macro.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RunMacro(
    PSMacro macro
)
Public Sub RunMacro (
    macro As PSMacro
)

Parameters

macro
Type: Autodesk.ProductInterface.PowerSHAPEPSMacro
The macro to be run.
See Also

Reference

PSAutomation Class
RunMacro Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetActivePlane Method

PSAutomationSetActivePlane Method

Sets the active plane of PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetActivePlane(
    Planes desiredPlane
)
Public Sub SetActivePlane (
    desiredPlane As Planes
)

Parameters

desiredPlane
Type: AutodeskPlanes
The plane to activate.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetDynamicSectioningCapSolids Method

PSAutomationSetDynamicSectioningCapSolids Method

Sets whether cap solids are draw in dynamic sectioning mode.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetDynamicSectioningCapSolids(
    bool capSolids
)
Public Sub SetDynamicSectioningCapSolids (
    capSolids As Boolean
)

Parameters

capSolids
Type: SystemBoolean
Draw cap solids in dynamic sectioning mode.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetDynamicSectioningDrawEdges Method

PSAutomationSetDynamicSectioningDrawEdges Method

Sets whether edges are draw in dynamic sectioning mode.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetDynamicSectioningDrawEdges(
    bool drawEdges
)
Public Sub SetDynamicSectioningDrawEdges (
    drawEdges As Boolean
)

Parameters

drawEdges
Type: SystemBoolean
Draw edges in dynamic sectioning mode.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetDynamicSectioningFrontPlane Method

PSAutomationSetDynamicSectioningFrontPlane Method

Set the position of the front plane for Dynamic Sectioning.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetDynamicSectioningFrontPlane(
    double planePosition
)
Public Sub SetDynamicSectioningFrontPlane (
    planePosition As Double
)

Parameters

planePosition
Type: SystemDouble
The position of the front plane.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetDynamicSectioningRearPlane Method

PSAutomationSetDynamicSectioningRearPlane Method

Sets the position of the rear plane for Dynamic Sectioning.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetDynamicSectioningRearPlane(
    double planePosition
)
Public Sub SetDynamicSectioningRearPlane (
    planePosition As Double
)

Parameters

planePosition
Type: SystemDouble
The position of the rear plane.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetDynamicSectioningTranslucency Method

PSAutomationSetDynamicSectioningTranslucency Method

Sets whether transparency is shown in dynamic sectioning mode.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetDynamicSectioningTranslucency(
    bool translucency
)
Public Sub SetDynamicSectioningTranslucency (
    translucency As Boolean
)

Parameters

translucency
Type: SystemBoolean
Shows transparency in dynamic sectioning mode.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetEnhancedShading Method

PSAutomationSetEnhancedShading Method

Sets the view to enhanced shading.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetEnhancedShading()
Public Sub SetEnhancedShading
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetHiddenWireframeView Method

PSAutomationSetHiddenWireframeView Method

Sets the view to show wireframes including hidden wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetHiddenWireframeView()
Public Sub SetHiddenWireframeView
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetMeshViewOpenAndInteriorEdgesAndNodesHollow Method

PSAutomationSetMeshViewOpenAndInteriorEdgesAndNodesHollow Method

Sets the view for a Mesh to show open edges and triangle edges and triangle nodes with the triangles hollow.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetMeshViewOpenAndInteriorEdgesAndNodesHollow()
Public Sub SetMeshViewOpenAndInteriorEdgesAndNodesHollow
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetMeshViewOpenAndInteriorEdgesAndNodesShaded Method

PSAutomationSetMeshViewOpenAndInteriorEdgesAndNodesShaded Method

Sets the view for a Mesh to show open edges and triangle edges and triangle nodes with the triangles shaded.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetMeshViewOpenAndInteriorEdgesAndNodesShaded()
Public Sub SetMeshViewOpenAndInteriorEdgesAndNodesShaded
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetMeshViewOpenAndInteriorEdgesHollow Method

PSAutomationSetMeshViewOpenAndInteriorEdgesHollow Method

Sets the view for a Mesh to show open edges and triangle edges with the triangles hollow.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetMeshViewOpenAndInteriorEdgesHollow()
Public Sub SetMeshViewOpenAndInteriorEdgesHollow
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetMeshViewOpenAndInteriorEdgesShaded Method

PSAutomationSetMeshViewOpenAndInteriorEdgesShaded Method

Sets the view for a Mesh to show open edges and triangle edges with the triangles shaded.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetMeshViewOpenAndInteriorEdgesShaded()
Public Sub SetMeshViewOpenAndInteriorEdgesShaded
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetMeshViewOpenEdgesOnlyShaded Method

PSAutomationSetMeshViewOpenEdgesOnlyShaded Method

Sets the view for a Mesh to show open edges with the triangles shaded.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetMeshViewOpenEdgesOnlyShaded()
Public Sub SetMeshViewOpenEdgesOnlyShaded
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetMultipleViewAngle Method

PSAutomationSetMultipleViewAngle Method

Sets a multiple view angle rather than a single view angle. This will split the screen into three or four views.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetMultipleViewAngle(
    MultipleViewAngles viewAngle
)
Public Sub SetMultipleViewAngle (
    viewAngle As MultipleViewAngles
)

Parameters

viewAngle
Type: Autodesk.ProductInterface.PowerSHAPEMultipleViewAngles
The view angle required.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetShadedAndWireframeView Method

PSAutomationSetShadedAndWireframeView Method

Sets the view to show shaded wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetShadedAndWireframeView()
Public Sub SetShadedAndWireframeView
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetShadedView Method

PSAutomationSetShadedView Method

Sets the view to normal shading.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetShadedView()
Public Sub SetShadedView
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetShadedWireframeView Method

PSAutomationSetShadedWireframeView Method

Sets the view to show wireframes with a shaded model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetShadedWireframeView()
Public Sub SetShadedWireframeView
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetShadingTolerance Method

PSAutomationSetShadingTolerance Method

Sets the shading tolerance for PowerSHAPE and regenerates triangles

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetShadingTolerance(
    double tolerance
)
Public Sub SetShadingTolerance (
    tolerance As Double
)

Parameters

tolerance
Type: SystemDouble
The required shading tolerance
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetSplit2ViewAngle Method

PSAutomationSetSplit2ViewAngle Method

Sets the view angles and relationships for a 2 split view. The relationship locks the child's rotation to that of the parent.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetSplit2ViewAngle(
    ViewAngles leftAngle,
    ViewAngles rightAngle,
    ViewRelationships leftRelationship,
    ViewRelationships rightRelationship
)
Public Sub SetSplit2ViewAngle (
    leftAngle As ViewAngles,
    rightAngle As ViewAngles,
    leftRelationship As ViewRelationships,
    rightRelationship As ViewRelationships
)

Parameters

leftAngle
Type: AutodeskViewAngles
The view angle for the left pane.
rightAngle
Type: AutodeskViewAngles
The view angle for the right pane.
leftRelationship
Type: Autodesk.ProductInterface.PowerSHAPEViewRelationships
The relationship of the left pane to the right.
rightRelationship
Type: Autodesk.ProductInterface.PowerSHAPEViewRelationships
The relationship of the right pane to the left.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetSplit4ViewAngle Method

PSAutomationSetSplit4ViewAngle Method

Sets the view angles and relationships for a 4 split view. The relationship locks the child's rotation to that of the parent.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetSplit4ViewAngle(
    ViewAngles topLeftAngle,
    ViewAngles topRightAngle,
    ViewAngles bottomLeftAngle,
    ViewAngles bottomRightAngle,
    ViewRelationships topLeftRelationship,
    ViewRelationships topRightRelationship,
    ViewRelationships bottomLeftRelationship,
    ViewRelationships bottomRightRelationship
)
Public Sub SetSplit4ViewAngle (
    topLeftAngle As ViewAngles,
    topRightAngle As ViewAngles,
    bottomLeftAngle As ViewAngles,
    bottomRightAngle As ViewAngles,
    topLeftRelationship As ViewRelationships,
    topRightRelationship As ViewRelationships,
    bottomLeftRelationship As ViewRelationships,
    bottomRightRelationship As ViewRelationships
)

Parameters

topLeftAngle
Type: AutodeskViewAngles
The view angle for the top left pane.
topRightAngle
Type: AutodeskViewAngles
The view angle for the top right pane.
bottomLeftAngle
Type: AutodeskViewAngles
The view angle for the bottom left pane.
bottomRightAngle
Type: AutodeskViewAngles
The view angle for the bottom right pane.
topLeftRelationship
Type: Autodesk.ProductInterface.PowerSHAPEViewRelationships
The relationship of the top left pane to the other panes.
topRightRelationship
Type: Autodesk.ProductInterface.PowerSHAPEViewRelationships
The relationship of the top right pane to the other panes.
bottomLeftRelationship
Type: Autodesk.ProductInterface.PowerSHAPEViewRelationships
The relationship of the bottom left pane to the other panes.
bottomRightRelationship
Type: Autodesk.ProductInterface.PowerSHAPEViewRelationships
The relationship of the bottom right pane to the other panes.
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetViewAngle Method

PSAutomationSetViewAngle Method

Sets the View Angle of PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void SetViewAngle(
    ViewAngles viewAngle
)
Public Overrides Sub SetViewAngle (
    viewAngle As ViewAngles
)

Parameters

viewAngle
Type: AutodeskViewAngles
The view angle to set.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.SetWireframeView Method

PSAutomationSetWireframeView Method

Sets the view to show wireframes.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetWireframeView()
Public Sub SetWireframeView
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.StopMacroRecording Method

PSAutomationStopMacroRecording Method

Stops recording macro.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void StopMacroRecording()
Public Overrides Sub StopMacroRecording
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.ToggleTransparentView Method

PSAutomationToggleTransparentView Method

Toggles transparent shading.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ToggleTransparentView()
Public Sub ToggleTransparentView
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation.UseExistingInstance Method

PSAutomationUseExistingInstance Method

Attempts to connect to an existing version of PowerSHAPE or create a new one.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected override void UseExistingInstance(
    Version version,
    Version maximumVersion
)
Protected Overrides Sub UseExistingInstance (
    version As Version,
    maximumVersion As Version
)

Parameters

version
Type: SystemVersion
The version to run.
maximumVersion
Type: SystemVersion
If filled, the version of PowerShape to run has to be less of equal to 'maximumVersion'.
Remarks
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSAutomation Fields

The PSAutomation type exposes the following members.

Fields
 | Name | Description
Protected field | _instanceReuse | Indicates whether a new instance of the application should be launched or an existing one be used. (Inherited from Automation.)
Protected field | _isGUIVisible | If True, the GUI is shown; false otherwise. (Inherited from Automation.)
Protected field | _processId | Application process id. (Inherited from Automation.)
Protected field | _version | Specifies the application version to use. (Inherited from Automation.)
Top
See Also

Reference

PSAutomation Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T) Class

PSCollectionT Class

Base class for all PowerShape Product Interface collections which items are not PSEntities. It controls the addition of items to PowerShape collections.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSCollectionT
Autodesk.ProductInterface.PowerSHAPEPSLevelsCollection
Autodesk.ProductInterface.PowerSHAPEPSMaterialsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSCollection<T> : IList<T>

Public MustInherit Class PSCollection(Of T)
    Implements IList(Of T)

Type Parameters

T
The type of the item. It can be a PSEntity, a PSLevel, etc.

The PSCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | IsReadOnly | PSCollection is not readonly.
Public property | Item | Gets and sets the desired indexed item.
Top
Methods
 | Name | Description
Protected method | Add | Adds a new item to the List.
Public method | Clear | Removes all entities in the list.
Public method | Contains | Determines whether the indicated item is contained within the collection.
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items.
Public method | IndexOf | Index of item in the list.
Protected method | Insert | Inserts the specified item into the desired position within the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified item.
Public method | RemoveAt | Removes the item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T) Properties

PSCollectionT Properties

The PSCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | IsReadOnly | PSCollection is not readonly.
Public property | Item | Gets and sets the desired indexed item.
Top
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).Count Property

PSCollectionTCount Property

Gets the number of items in the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).IsReadOnly Property

PSCollectionTIsReadOnly Property

PSCollection is not readonly.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).Item Property

PSCollectionTItem Property

Gets and sets the desired indexed item.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual T this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As T
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the desired item.

Property Value

Type: T
The desired item.

Return Value

Type: T
The desired item.

Implements

IListTItemInt32
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T) Methods

PSCollectionT Methods

The PSCollectionT generic type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new item to the List.
Public method | Clear | Removes all entities in the list.
Public method | Contains | Determines whether the indicated item is contained within the collection.
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items.
Public method | IndexOf | Index of item in the list.
Protected method | Insert | Inserts the specified item into the desired position within the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified item.
Public method | RemoveAt | Removes the item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).Add Method

PSCollectionTAdd Method

Adds a new item to the List.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
internal void Add(
    T item
)
Friend Sub Add (
    item As T
)

Parameters

item
Type: T
The item to add.

Implements

ICollectionTAdd(T)
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).Clear Method

PSCollectionTClear Method

Removes all entities in the list.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void Clear()
Public Overridable Sub Clear

Implements

ICollectionTClear
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).Contains Method

PSCollectionTContains Method

Determines whether the indicated item is contained within the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean

Parameters

item
Type: T
The item to check for.

Return Value

Type: Boolean
A boolean indicating the item's presence in the collection.

Implements

ICollectionTContains(T)
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).CopyTo Method

PSCollectionTCopyTo Method

Copies the contents of the collection to the specified list, starting at the specified index.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)

Parameters

array
Type: T
The destination of the elements copied.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).GetEnumerator Method

PSCollectionTGetEnumerator Method

Returns an enumerator of items.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).IEnumerable_GetEnumerator Method

PSCollectionTIEnumerable_GetEnumerator Method

Returns an enumerator of items.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public IEnumerator<T> IEnumerable_GetEnumerator()
Public Function IEnumerable_GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumerator T

Implements

IEnumerableTGetEnumerator
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).IndexOf Method

PSCollectionTIndexOf Method

Index of item in the list.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    T item
)
Public Overridable Function IndexOf (
    item As T
) As Integer

Parameters

item
Type: T
The item to get the index from.

Return Value

Type: Int32
The index of the item.

Implements

IListTIndexOf(T)
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).Insert Method

PSCollectionTInsert Method

Inserts the specified item into the desired position within the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
internal void Insert(
    int index,
    T item
)
Friend Sub Insert (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The position into which the item is to be inserted.
item
Type: T
The entity to be inserted.

Implements

IListTInsert(Int32, T)
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).Remove Method

PSCollectionTRemove Method

Removes the specified item.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual bool Remove(
    T item
)
Public Overridable Function Remove (
    item As T
) As Boolean

Parameters

item
Type: T
The item to be removed.

Return Value

Type: Boolean
A boolean indicating whether the item has been removed.

Implements

ICollectionTRemove(T)
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T).RemoveAt Method

PSCollectionTRemoveAt Method

Removes the item at the specified index.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
Remarks
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T) Fields

PSCollectionT Fields

The PSCollectionT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'.
Top
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCollection(T)._list Field

PSCollectionT_list Field

The DatabaseEntitiesCollection as a list and is used in place of 'Me'.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected List<T> _list
Protected _list As List(Of T)

Field Value

Type: List T
See Also

Reference

PSCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve Class

Captures a CompCurve object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSGenericCurve
Autodesk.ProductInterface.PowerSHAPEPSCompCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSCompCurve : PSGenericCurve,
    IPSMoveable, IPSRotateable, IPSMirrorable, IPSOffsetable, IPSScalable
Public Class PSCompCurve
    Inherits PSGenericCurve
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSOffsetable,
    IPSScalable

The PSCompCurve type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the curve. If it's closed, the area is the enclosed space. If it's open, the area is the enclosed space were it to be closed with a straight line. If the wireframe is not on a plane, the area is calculated supposing that it has been projected onto the principal plane. (Inherited from PSGenericCurve.)
Public property | BoundingBox | Gets the bounding box of the GenericCurve in PowerSHAPE. (Inherited from PSGenericCurve.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe (Inherited from PSWireframe.)
Public property | EndPoint | Gets the start point of a CompCurve (Overrides PSWireframeEndPoint.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosed | Gets and sets whether the curve is closed or not. (Inherited from PSGenericCurve.)
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberCurveItems | Gets the number of items that make up the CompCurve
Public property | NumberPoints | Gets the number of points in the CompCurve (Overrides PSWireframeNumberPoints.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe (Inherited from PSWireframe.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of a CompCurve (Overrides PSWireframeStartPoint.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the CompCurve from PowerSHAPE and removes it from the CompCurves collection (Overrides PSEntityDelete.)
Public method | DeleteCurvePoints | Deletes the specified points. (Inherited from PSGenericCurve.)
Public method | DeleteDependencies | Deletes any dependencies. Useful when trying to duplicate a curve which is dependent on a mesh. It must be added to the selection for this to work! (Inherited from PSGenericCurve.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditCurvePointTangency | Edits the entry and exit tangencies at a defined point. (Inherited from PSGenericCurve.)
Public method | EditCurvePointTangencyMagnitude | Edits the entry and exit tangency magnitudes at a defined point. (Inherited from PSGenericCurve.)
Public method | EditPositionOfPointAbsolute | Moves a curve point to a new point position. (Inherited from PSGenericCurve.)
Public method | EditPositionOfPointRelative | Moves a selected Point on a curve by a direction vector. (Inherited from PSGenericCurve.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one end of the curve. (Inherited from PSGenericCurve.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FreeMagnitudesAndDirections | Frees the magnitudes and directions of the entire wireframe. (Inherited from PSGenericCurve.)
Public method | FreeMagnitudesDirections | Frees the magnitudes and directions of the selected points on the wireframe. (Inherited from PSGenericCurve.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryTangentOfPoint | Entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitAzimuthAngleOfPoint | Gets the azimuth angle of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points. (Inherited from PSGenericCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPointAtPositionBetweenPoints | Inserts a new point. (Inherited from PSGenericCurve.)
Public method | InsertPointByProximity | Inserts a new point by proximal point. (Inherited from PSGenericCurve.)
Public method | InsertPointRelativeToPointOnCurve | Inserts a new relative point. (Inherited from PSGenericCurve.)
Public method | InsertPointsAtPlaneIntersections | Inserts a new point at an offset from the plane intersection. (Inherited from PSGenericCurve.)
Public method | LimitToEntities | Limits a curve by a specified list of entities. (Inherited from PSGenericCurve.)
Public method | LimitToEntity | Limits a curve by a specified list of entities. (Inherited from PSGenericCurve.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSGenericCurve.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeAndSpline | Merges and splines the curve. (Inherited from PSGenericCurve.)
Public method | Mirror | Mirrors curve in a specified plane
Public method | MoveBetweenPoints | Moves curve by the relative distance between two absolute positions
Public method | MoveByVector | Moves curve by a specified relative amount
Public method | Offset | Offsets curve by a specified distance
Public method | ProjectOntoPlane | Projects the curve onto the specified plane at the specified position on the plane. (Inherited from PSGenericCurve.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | RenumberCurvePoints | Renumbers the points from the specified start point. (Inherited from PSGenericCurve.)
Public method | RepointCurveBetweenPoints | Repoints the curve between the specified points creating the specified number of points. (Inherited from PSGenericCurve.)
Public method | Reverse | Reverses the curve. (Inherited from PSGenericCurve.)
Public method | Rotate | Rotates curve by a specified angle around a specified axis
Public method | Scale | Scales a curve within PowerSHAPE. (Inherited from PSGenericCurve.)
Public method | ScaleNonUniform | Scales curve by individual values for X, Y, and Z. Axis can be locked to prevent scaling on that axis
Public method | ScaleProjectedVolume | Scales curve by projected volume. Axis can be locked to prevent scaling on that axis
Public method | ScaleUniform | Scales curve by a single value. Axis can be locked to prevent scaling on that axis
Public method | SelectCurvePoints | Selects the specified points. (Inherited from PSGenericCurve.)
Public method | ToPolyline | Creates a single polyline from a generic curve. (Inherited from PSGenericCurve.)
Public method | ToSpline | Creates a single spline from a generic curve. (Inherited from PSGenericCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve Properties

The PSCompCurve type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the curve. If it's closed, the area is the enclosed space. If it's open, the area is the enclosed space were it to be closed with a straight line. If the wireframe is not on a plane, the area is calculated supposing that it has been projected onto the principal plane. (Inherited from PSGenericCurve.)
Public property | BoundingBox | Gets the bounding box of the GenericCurve in PowerSHAPE. (Inherited from PSGenericCurve.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe (Inherited from PSWireframe.)
Public property | EndPoint | Gets the start point of a CompCurve (Overrides PSWireframeEndPoint.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosed | Gets and sets whether the curve is closed or not. (Inherited from PSGenericCurve.)
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberCurveItems | Gets the number of items that make up the CompCurve
Public property | NumberPoints | Gets the number of points in the CompCurve (Overrides PSWireframeNumberPoints.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe (Inherited from PSWireframe.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of a CompCurve (Overrides PSWireframeStartPoint.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.EndPoint Property

PSCompCurveEndPoint Property

Gets the start point of a CompCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point EndPoint { get; }
Public Overrides ReadOnly Property EndPoint As Point
    Get

Property Value

Type: Point
Remarks
Overriden because the syntax is different
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.NumberCurveItems Property

PSCompCurveNumberCurveItems Property

Gets the number of items that make up the CompCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberCurveItems { get; }
Public ReadOnly Property NumberCurveItems As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.NumberPoints Property

PSCompCurveNumberPoints Property

Gets the number of points in the CompCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int NumberPoints { get; }
Public Overrides ReadOnly Property NumberPoints As Integer
    Get

Property Value

Type: Int32
Remarks
Overriden because the syntax is different
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.StartPoint Property

PSCompCurveStartPoint Property

Gets the start point of a CompCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point StartPoint { get; }
Public Overrides ReadOnly Property StartPoint As Point
    Get

Property Value

Type: Point
Remarks
Overriden because the syntax is different
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve Methods

The PSCompCurve type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the CompCurve from PowerSHAPE and removes it from the CompCurves collection (Overrides PSEntityDelete.)
Public method | DeleteCurvePoints | Deletes the specified points. (Inherited from PSGenericCurve.)
Public method | DeleteDependencies | Deletes any dependencies. Useful when trying to duplicate a curve which is dependent on a mesh. It must be added to the selection for this to work! (Inherited from PSGenericCurve.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditCurvePointTangency | Edits the entry and exit tangencies at a defined point. (Inherited from PSGenericCurve.)
Public method | EditCurvePointTangencyMagnitude | Edits the entry and exit tangency magnitudes at a defined point. (Inherited from PSGenericCurve.)
Public method | EditPositionOfPointAbsolute | Moves a curve point to a new point position. (Inherited from PSGenericCurve.)
Public method | EditPositionOfPointRelative | Moves a selected Point on a curve by a direction vector. (Inherited from PSGenericCurve.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one end of the curve. (Inherited from PSGenericCurve.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FreeMagnitudesAndDirections | Frees the magnitudes and directions of the entire wireframe. (Inherited from PSGenericCurve.)
Public method | FreeMagnitudesDirections | Frees the magnitudes and directions of the selected points on the wireframe. (Inherited from PSGenericCurve.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryTangentOfPoint | Entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitAzimuthAngleOfPoint | Gets the azimuth angle of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points. (Inherited from PSGenericCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPointAtPositionBetweenPoints | Inserts a new point. (Inherited from PSGenericCurve.)
Public method | InsertPointByProximity | Inserts a new point by proximal point. (Inherited from PSGenericCurve.)
Public method | InsertPointRelativeToPointOnCurve | Inserts a new relative point. (Inherited from PSGenericCurve.)
Public method | InsertPointsAtPlaneIntersections | Inserts a new point at an offset from the plane intersection. (Inherited from PSGenericCurve.)
Public method | LimitToEntities | Limits a curve by a specified list of entities. (Inherited from PSGenericCurve.)
Public method | LimitToEntity | Limits a curve by a specified list of entities. (Inherited from PSGenericCurve.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSGenericCurve.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeAndSpline | Merges and splines the curve. (Inherited from PSGenericCurve.)
Public method | Mirror | Mirrors curve in a specified plane
Public method | MoveBetweenPoints | Moves curve by the relative distance between two absolute positions
Public method | MoveByVector | Moves curve by a specified relative amount
Public method | Offset | Offsets curve by a specified distance
Public method | ProjectOntoPlane | Projects the curve onto the specified plane at the specified position on the plane. (Inherited from PSGenericCurve.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | RenumberCurvePoints | Renumbers the points from the specified start point. (Inherited from PSGenericCurve.)
Public method | RepointCurveBetweenPoints | Repoints the curve between the specified points creating the specified number of points. (Inherited from PSGenericCurve.)
Public method | Reverse | Reverses the curve. (Inherited from PSGenericCurve.)
Public method | Rotate | Rotates curve by a specified angle around a specified axis
Public method | Scale | Scales a curve within PowerSHAPE. (Inherited from PSGenericCurve.)
Public method | ScaleNonUniform | Scales curve by individual values for X, Y, and Z. Axis can be locked to prevent scaling on that axis
Public method | ScaleProjectedVolume | Scales curve by projected volume. Axis can be locked to prevent scaling on that axis
Public method | ScaleUniform | Scales curve by a single value. Axis can be locked to prevent scaling on that axis
Public method | SelectCurvePoints | Selects the specified points. (Inherited from PSGenericCurve.)
Public method | ToPolyline | Creates a single polyline from a generic curve. (Inherited from PSGenericCurve.)
Public method | ToSpline | Creates a single spline from a generic curve. (Inherited from PSGenericCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.Delete Method

PSCompCurveDelete Method

Deletes the CompCurve from PowerSHAPE and removes it from the CompCurves collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.Mirror Method

PSCompCurveMirror Method

Mirrors curve in a specified plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
Plane about which to mirror the curve
mirrorPoint
Type: Autodesk.GeometryPoint
Origin of the mirror plane

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.MoveBetweenPoints Method

PSCompCurveMoveBetweenPoints Method

Moves curve by the relative distance between two absolute positions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
First of the two absolute positions
pointToMoveTo
Type: Autodesk.GeometryPoint
Second of the two absolute positions
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.MoveByVector Method

PSCompCurveMoveByVector Method

Moves curve by a specified relative amount

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
Relative amount by which the curve will be moved
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.Offset Method

PSCompCurveOffset Method

Offsets curve by a specified distance

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Offset(
    MM offsetDistance,
    int copiesToCreate
)
Public Function Offset (
    offsetDistance As MM,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

offsetDistance
Type: Autodesk.GeometryMM
Distance by which to offset the curve
copiesToCreate
Type: SystemInt32
Number of copies to be created from the operation

Return Value

Type: List PSEntity
List of offset curves

Implements

IPSOffsetableOffset(MM, Int32)
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.Rotate Method

PSCompCurveRotate Method

Rotates curve by a specified angle around a specified axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
Axis around which the curve is are to be rotated
rotationAngle
Type: Autodesk.GeometryDegree
Angle by which the curve is to be rotated
copiesToCreate
Type: SystemInt32
Number of copies to create of the original curve
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin of the rotation axis

Return Value

Type: List PSEntity
List of curves created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.ScaleNonUniform Method

PSCompCurveScaleNonUniform Method

Scales curve by individual values for X, Y, and Z. Axis can be locked to prevent scaling on that axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleNonUniform(
    double scaleFactorX,
    double scaleFactorY,
    double scaleFactorZ,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleNonUniform (
    scaleFactorX As Double,
    scaleFactorY As Double,
    scaleFactorZ As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactorX
Type: SystemDouble
Factor to scale by along X
scaleFactorY
Type: SystemDouble
Factor to scale by along Y
scaleFactorZ
Type: SystemDouble
Factor to scale by along Z
lockX
Type: SystemBoolean
Optionally locks X axis to prevent scaling
lockY
Type: SystemBoolean
Optionally locks Y axis to prevent scaling
lockZ
Type: SystemBoolean
Optionally locks Z axis to prevent scaling
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin to scale round

Implements

IPSScalableScaleNonUniform(Double, Double, Double, Boolean, Boolean, Boolean, Point)
Remarks
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.ScaleProjectedVolume Method

PSCompCurveScaleProjectedVolume Method

Scales curve by projected volume. Axis can be locked to prevent scaling on that axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleProjectedVolume(
    double newVolume,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleProjectedVolume (
    newVolume As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

newVolume
Type: SystemDouble
New projectd volume
lockX
Type: SystemBoolean
Optionally locks X axis to prevent scaling
lockY
Type: SystemBoolean
Optionally locks Y axis to prevent scaling
lockZ
Type: SystemBoolean
Optionally locks Z axis to prevent scaling
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin to scale round

Implements

IPSScalableScaleProjectedVolume(Double, Boolean, Boolean, Boolean, Point)
Remarks
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve.ScaleUniform Method

PSCompCurveScaleUniform Method

Scales curve by a single value. Axis can be locked to prevent scaling on that axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleUniform(
    double scaleFactor,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleUniform (
    scaleFactor As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactor
Type: SystemDouble
Factor to scale by
lockX
Type: SystemBoolean
Optionally locks X axis to prevent scaling
lockY
Type: SystemBoolean
Optionally locks Y axis to prevent scaling
lockZ
Type: SystemBoolean
Optionally locks Z axis to prevent scaling
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin to scale round

Implements

IPSScalableScaleUniform(Double, Boolean, Boolean, Boolean, Point)
Remarks
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurve Fields

The PSCompCurve type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSCompCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection Class

Captures the collection of CompCurves in a Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSCompCurve
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSCompCurve
Autodesk.ProductInterface.PowerSHAPEPSGenericCurvesCollection PSCompCurve
Autodesk.ProductInterface.PowerSHAPEPSCompCurvesCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSCompCurvesCollection : PSGenericCurvesCollection<PSCompCurve>
Public Class PSCompCurvesCollection
    Inherits PSGenericCurvesCollection(Of PSCompCurve)

The PSCompCurvesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateCompCurveFromWireframe | Creates a new compcurve from Wireframe
Public method | CreateCompCurvesFromAnnotation | Converts the specified PSAnnotation into a series of PSCompCurves
Public method | CreateCompCurvesFromAnnotations | Converts the specified PSAnnotations into a series of PSCompCurves
Public method | CreateCompCurvesFromIntersectionOfSurfaceAndMesh | Creates CompCurves from an intersection between a surface and a mesh.
Public method | CreateCompCurvesFromIntersectionOfSurfaceAndSolid | Creates CompCurves from an intersection between a surface and a solid
Public method | CreateCompCurvesFromIntersectionOfTwoSetsOfSurfaces | Creates CompCurves from an intersection between two sets of surfaces
Public method | CreateCompCurvesFromIntersectionOfTwoSolids | Creates CompCurves from an intersection between two solids
Public method | CreateCompCurvesFromIntersectionOfTwoSurfaces | Creates CompCurves from an intersection between two surfaces
Public method | CreateCompCurveThroughPoints | Creates a new compcurve through the specified points
Public method | CreateCurveFromBreakPoint | Breaks a curve at the specified point. The first section of the curve is retained, while the second section becomes a new curve. (Inherited from PSGenericCurvesCollectionT.)
Public method | CreateCurvesFromWrap | Creates new curves and compcurves by projecting wireframe onto a surface (Inherited from PSGenericCurvesCollectionT.)
Public method | CreateObliqueCurve | Creates an Oblique curve against either a mesh, solid or surface.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection Properties

The PSCompCurvesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection Methods

The PSCompCurvesCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateCompCurveFromWireframe | Creates a new compcurve from Wireframe
Public method | CreateCompCurvesFromAnnotation | Converts the specified PSAnnotation into a series of PSCompCurves
Public method | CreateCompCurvesFromAnnotations | Converts the specified PSAnnotations into a series of PSCompCurves
Public method | CreateCompCurvesFromIntersectionOfSurfaceAndMesh | Creates CompCurves from an intersection between a surface and a mesh.
Public method | CreateCompCurvesFromIntersectionOfSurfaceAndSolid | Creates CompCurves from an intersection between a surface and a solid
Public method | CreateCompCurvesFromIntersectionOfTwoSetsOfSurfaces | Creates CompCurves from an intersection between two sets of surfaces
Public method | CreateCompCurvesFromIntersectionOfTwoSolids | Creates CompCurves from an intersection between two solids
Public method | CreateCompCurvesFromIntersectionOfTwoSurfaces | Creates CompCurves from an intersection between two surfaces
Public method | CreateCompCurveThroughPoints | Creates a new compcurve through the specified points
Public method | CreateCurveFromBreakPoint | Breaks a curve at the specified point. The first section of the curve is retained, while the second section becomes a new curve. (Inherited from PSGenericCurvesCollectionT.)
Public method | CreateCurvesFromWrap | Creates new curves and compcurves by projecting wireframe onto a surface (Inherited from PSGenericCurvesCollectionT.)
Public method | CreateObliqueCurve | Creates an Oblique curve against either a mesh, solid or surface.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurveFromWireframe Method

PSCompCurvesCollectionCreateCompCurveFromWireframe Method

Creates a new compcurve from Wireframe

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCompCurve CreateCompCurveFromWireframe(
    PSWireframe[] wireframe
)
Public Function CreateCompCurveFromWireframe (
    wireframe As PSWireframe()
) As PSCompCurve

Parameters

wireframe
Type: Autodesk.ProductInterface.PowerSHAPEPSWireframe
The wireframe to turn into a CompCurve (arc, compcurve, curve or line)

Return Value

Type: PSCompCurve
The CompCurve created from the wireframe
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurvesFromAnnotation Method

PSCompCurvesCollectionCreateCompCurvesFromAnnotation Method

Converts the specified PSAnnotation into a series of PSCompCurves

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateCompCurvesFromAnnotation(
    PSAnnotation annotationToConvert
)
Public Function CreateCompCurvesFromAnnotation (
    annotationToConvert As PSAnnotation
) As List(Of PSCompCurve)

Parameters

annotationToConvert
Type: Autodesk.ProductInterface.PowerSHAPEPSAnnotation
The annotation to convert

Return Value

Type: List PSCompCurve
A list of PSCompCurves
Remarks
The original PSAnnotation will no longer exist after this operation
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurvesFromAnnotations Method

PSCompCurvesCollectionCreateCompCurvesFromAnnotations Method

Converts the specified PSAnnotations into a series of PSCompCurves

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateCompCurvesFromAnnotations(
    List<PSAnnotation> annotationsToConvert
)
Public Function CreateCompCurvesFromAnnotations (
    annotationsToConvert As List(Of PSAnnotation)
) As List(Of PSCompCurve)

Parameters

annotationsToConvert
Type: System.Collections.GenericList PSAnnotation
The annotations to convert

Return Value

Type: List PSCompCurve
A list of PSCompCurves
Remarks
The original PSAnnotations will no longer exist after this operation
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurvesFromIntersectionOfSurfaceAndMesh Method

PSCompCurvesCollectionCreateCompCurvesFromIntersectionOfSurfaceAndMesh Method

Creates CompCurves from an intersection between a surface and a mesh.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateCompCurvesFromIntersectionOfSurfaceAndMesh(
    PSSurface surface,
    PSMesh mesh
)
Public Function CreateCompCurvesFromIntersectionOfSurfaceAndMesh (
    surface As PSSurface,
    mesh As PSMesh
) As List(Of PSCompCurve)

Parameters

surface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface to intersect.
mesh
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
The mesh to intersect.

Return Value

Type: List PSCompCurve
The list of the created CompCurves.
Remarks
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurvesFromIntersectionOfSurfaceAndSolid Method

PSCompCurvesCollectionCreateCompCurvesFromIntersectionOfSurfaceAndSolid Method

Creates CompCurves from an intersection between a surface and a solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateCompCurvesFromIntersectionOfSurfaceAndSolid(
    PSSurface firstSurface,
    PSSolid secondSolid
)
Public Function CreateCompCurvesFromIntersectionOfSurfaceAndSolid (
    firstSurface As PSSurface,
    secondSolid As PSSolid
) As List(Of PSCompCurve)

Parameters

firstSurface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface to intersect
secondSolid
Type: Autodesk.ProductInterface.PowerSHAPEPSSolid
The solid to intersect

Return Value

Type: List PSCompCurve
A list of the created CompCurves
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurvesFromIntersectionOfTwoSetsOfSurfaces Method

PSCompCurvesCollectionCreateCompCurvesFromIntersectionOfTwoSetsOfSurfaces Method

Creates CompCurves from an intersection between two sets of surfaces

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateCompCurvesFromIntersectionOfTwoSetsOfSurfaces(
    List<PSSurface> firstSurfaces,
    List<PSSurface> secondSurfaces
)
Public Function CreateCompCurvesFromIntersectionOfTwoSetsOfSurfaces (
    firstSurfaces As List(Of PSSurface),
    secondSurfaces As List(Of PSSurface)
) As List(Of PSCompCurve)

Parameters

firstSurfaces
Type: System.Collections.GenericList PSSurface
The first set of surfaces to intersect
secondSurfaces
Type: System.Collections.GenericList PSSurface
The second set of surfaces to intersect

Return Value

Type: List PSCompCurve
A list of the created CompCurves
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurvesFromIntersectionOfTwoSolids Method

PSCompCurvesCollectionCreateCompCurvesFromIntersectionOfTwoSolids Method

Creates CompCurves from an intersection between two solids

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateCompCurvesFromIntersectionOfTwoSolids(
    PSSolid firstSolid,
    PSSolid secondSolid
)
Public Function CreateCompCurvesFromIntersectionOfTwoSolids (
    firstSolid As PSSolid,
    secondSolid As PSSolid
) As List(Of PSCompCurve)

Parameters

firstSolid
Type: Autodesk.ProductInterface.PowerSHAPEPSSolid
The first solid to intersect
secondSolid
Type: Autodesk.ProductInterface.PowerSHAPEPSSolid
The second solid to intersect

Return Value

Type: List PSCompCurve
A list of the created CompCurves
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurvesFromIntersectionOfTwoSurfaces Method

PSCompCurvesCollectionCreateCompCurvesFromIntersectionOfTwoSurfaces Method

Creates CompCurves from an intersection between two surfaces

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateCompCurvesFromIntersectionOfTwoSurfaces(
    PSSurface firstSurface,
    PSSurface secondSurface
)
Public Function CreateCompCurvesFromIntersectionOfTwoSurfaces (
    firstSurface As PSSurface,
    secondSurface As PSSurface
) As List(Of PSCompCurve)

Parameters

firstSurface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The first surface to intersect
secondSurface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The second surface to intersect

Return Value

Type: List PSCompCurve
A list of the created CompCurves
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateCompCurveThroughPoints Method

PSCompCurvesCollectionCreateCompCurveThroughPoints Method

Creates a new compcurve through the specified points

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCompCurve CreateCompCurveThroughPoints(
    CurveTypes curveType,
    Point[] points
)
Public Function CreateCompCurveThroughPoints (
    curveType As CurveTypes,
    points As Point()
) As PSCompCurve

Parameters

curveType
Type: Autodesk.ProductInterface.PowerSHAPECurveTypes
CurveTypes enum value for curev type
points
Type: Autodesk.GeometryPoint
Optional array of points or singular point for curve to go through

Return Value

Type: PSCompCurve
A curve created by the operation
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection.CreateObliqueCurve Method

PSCompCurvesCollectionCreateObliqueCurve Method

Creates an Oblique curve against either a mesh, solid or surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateObliqueCurve(
    PSEntity entityToOblique,
    Planes UsePlane,
    MM position
)
Public Function CreateObliqueCurve (
    entityToOblique As PSEntity,
    UsePlane As Planes,
    position As MM
) As List(Of PSCompCurve)

Parameters

entityToOblique
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity to be cut by the oblique curve.
UsePlane
Type: AutodeskPlanes
Sets the principal plane.
position
Type: Autodesk.GeometryMM
Distance along plane to drop curve on.

Return Value

Type: List PSCompCurve
List of CompCurves.
Exceptions
Exception | Condition
ApplicationException | No curves were created from intersection operation.
ApplicationException | Entity must be Mesh, Surface or Solid.
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCompCurvesCollection Fields

The PSCompCurvesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSCompCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve Class

Captures a Curve object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSGenericCurve
Autodesk.ProductInterface.PowerSHAPEPSCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSCurve : PSGenericCurve, IPSMoveable,
    IPSRotateable, IPSMirrorable, IPSOffsetable, IPSScalable
Public Class PSCurve
    Inherits PSGenericCurve
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSOffsetable,
    IPSScalable

The PSCurve type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the curve. If it's closed, the area is the enclosed space. If it's open, the area is the enclosed space were it to be closed with a straight line. If the wireframe is not on a plane, the area is calculated supposing that it has been projected onto the principal plane. (Inherited from PSGenericCurve.)
Public property | BoundingBox | Gets the bounding box of the GenericCurve in PowerSHAPE. (Inherited from PSGenericCurve.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe (Inherited from PSWireframe.)
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosed | Gets and sets whether the curve is closed or not. (Inherited from PSGenericCurve.)
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Gets the number of points in the wireframe (Inherited from PSWireframe.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe (Inherited from PSWireframe.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of a Curve
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Curve from PowerSHAPE and removes it from the Curves collection (Overrides PSEntityDelete.)
Public method | DeleteCurvePoints | Deletes the specified points. (Inherited from PSGenericCurve.)
Public method | DeleteDependencies | Deletes any dependencies. Useful when trying to duplicate a curve which is dependent on a mesh. It must be added to the selection for this to work! (Inherited from PSGenericCurve.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditCurvePointTangency | Edits the entry and exit tangencies at a defined point. (Inherited from PSGenericCurve.)
Public method | EditCurvePointTangencyMagnitude | Edits the entry and exit tangency magnitudes at a defined point. (Inherited from PSGenericCurve.)
Public method | EditPositionOfPointAbsolute | Moves a curve point to a new point position. (Inherited from PSGenericCurve.)
Public method | EditPositionOfPointRelative | Moves a selected Point on a curve by a direction vector. (Inherited from PSGenericCurve.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one end of the curve. (Inherited from PSGenericCurve.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FreeMagnitudesAndDirections | Frees the magnitudes and directions of the entire wireframe. (Inherited from PSGenericCurve.)
Public method | FreeMagnitudesDirections | Frees the magnitudes and directions of the selected points on the wireframe. (Inherited from PSGenericCurve.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryTangentOfPoint | Entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitAzimuthAngleOfPoint | Gets the azimuth angle of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points. (Inherited from PSGenericCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPointAtPositionBetweenPoints | Inserts a new point. (Inherited from PSGenericCurve.)
Public method | InsertPointByProximity | Inserts a new point by proximal point. (Inherited from PSGenericCurve.)
Public method | InsertPointRelativeToPointOnCurve | Inserts a new relative point. (Inherited from PSGenericCurve.)
Public method | InsertPointsAtPlaneIntersections | Inserts a new point at an offset from the plane intersection. (Inherited from PSGenericCurve.)
Public method | LimitToEntities | Limits a curve by a specified list of entities. (Inherited from PSGenericCurve.)
Public method | LimitToEntity | Limits a curve by a specified list of entities. (Inherited from PSGenericCurve.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSGenericCurve.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeAndSpline | Merges and splines the curve. (Inherited from PSGenericCurve.)
Public method | Mirror | Mirrors a single curve in a specified plane
Public method | MoveBetweenPoints | Moves a single curve by the relative distance between two absolute positions
Public method | MoveByVector | Moves a single curve by a specified relative amount
Public method | Offset | Offsets a single curve by a specified distance
Public method | ProjectOntoPlane | Projects the curve onto the specified plane at the specified position on the plane. (Inherited from PSGenericCurve.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | RenumberCurvePoints | Renumbers the points from the specified start point. (Inherited from PSGenericCurve.)
Public method | RepointCurveBetweenPoints | Repoints the curve between the specified points creating the specified number of points. (Inherited from PSGenericCurve.)
Public method | Reverse | Reverses the curve. (Inherited from PSGenericCurve.)
Public method | Rotate | Rotates a single curve by a specified angle around a specified axis
Public method | Scale | Scales a curve within PowerSHAPE. (Inherited from PSGenericCurve.)
Public method | ScaleNonUniform | Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.
Public method | ScaleProjectedVolume | Scales curve by projected volume. Axis can be locked to prevent scaling on that axis.
Public method | ScaleUniform | Scales curve by a single value. Axis can be locked to prevent scaling on that axis
Public method | SelectCurvePoints | Selects the specified points. (Inherited from PSGenericCurve.)
Public method | ToPolyline | Creates a single polyline from a generic curve. (Inherited from PSGenericCurve.)
Public method | ToSpline | Creates a single spline from a generic curve. (Inherited from PSGenericCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve Properties

The PSCurve type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the curve. If it's closed, the area is the enclosed space. If it's open, the area is the enclosed space were it to be closed with a straight line. If the wireframe is not on a plane, the area is calculated supposing that it has been projected onto the principal plane. (Inherited from PSGenericCurve.)
Public property | BoundingBox | Gets the bounding box of the GenericCurve in PowerSHAPE. (Inherited from PSGenericCurve.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe (Inherited from PSWireframe.)
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosed | Gets and sets whether the curve is closed or not. (Inherited from PSGenericCurve.)
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Gets the number of points in the wireframe (Inherited from PSWireframe.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe (Inherited from PSWireframe.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of a Curve
Top
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.Type Property

PSCurveType Property

Gets the type of a Curve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public CurveTypes Type { get; }
Public ReadOnly Property Type As CurveTypes
    Get

Property Value

Type: CurveTypes
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve Methods

The PSCurve type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Curve from PowerSHAPE and removes it from the Curves collection (Overrides PSEntityDelete.)
Public method | DeleteCurvePoints | Deletes the specified points. (Inherited from PSGenericCurve.)
Public method | DeleteDependencies | Deletes any dependencies. Useful when trying to duplicate a curve which is dependent on a mesh. It must be added to the selection for this to work! (Inherited from PSGenericCurve.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditCurvePointTangency | Edits the entry and exit tangencies at a defined point. (Inherited from PSGenericCurve.)
Public method | EditCurvePointTangencyMagnitude | Edits the entry and exit tangency magnitudes at a defined point. (Inherited from PSGenericCurve.)
Public method | EditPositionOfPointAbsolute | Moves a curve point to a new point position. (Inherited from PSGenericCurve.)
Public method | EditPositionOfPointRelative | Moves a selected Point on a curve by a direction vector. (Inherited from PSGenericCurve.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one end of the curve. (Inherited from PSGenericCurve.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FreeMagnitudesAndDirections | Frees the magnitudes and directions of the entire wireframe. (Inherited from PSGenericCurve.)
Public method | FreeMagnitudesDirections | Frees the magnitudes and directions of the selected points on the wireframe. (Inherited from PSGenericCurve.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetEntryTangentOfPoint | Entry tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitAzimuthAngleOfPoint | Gets the azimuth angle of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point. (Inherited from PSGenericCurve.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points. (Inherited from PSGenericCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPointAtPositionBetweenPoints | Inserts a new point. (Inherited from PSGenericCurve.)
Public method | InsertPointByProximity | Inserts a new point by proximal point. (Inherited from PSGenericCurve.)
Public method | InsertPointRelativeToPointOnCurve | Inserts a new relative point. (Inherited from PSGenericCurve.)
Public method | InsertPointsAtPlaneIntersections | Inserts a new point at an offset from the plane intersection. (Inherited from PSGenericCurve.)
Public method | LimitToEntities | Limits a curve by a specified list of entities. (Inherited from PSGenericCurve.)
Public method | LimitToEntity | Limits a curve by a specified list of entities. (Inherited from PSGenericCurve.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSGenericCurve.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeAndSpline | Merges and splines the curve. (Inherited from PSGenericCurve.)
Public method | Mirror | Mirrors a single curve in a specified plane
Public method | MoveBetweenPoints | Moves a single curve by the relative distance between two absolute positions
Public method | MoveByVector | Moves a single curve by a specified relative amount
Public method | Offset | Offsets a single curve by a specified distance
Public method | ProjectOntoPlane | Projects the curve onto the specified plane at the specified position on the plane. (Inherited from PSGenericCurve.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | RenumberCurvePoints | Renumbers the points from the specified start point. (Inherited from PSGenericCurve.)
Public method | RepointCurveBetweenPoints | Repoints the curve between the specified points creating the specified number of points. (Inherited from PSGenericCurve.)
Public method | Reverse | Reverses the curve. (Inherited from PSGenericCurve.)
Public method | Rotate | Rotates a single curve by a specified angle around a specified axis
Public method | Scale | Scales a curve within PowerSHAPE. (Inherited from PSGenericCurve.)
Public method | ScaleNonUniform | Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.
Public method | ScaleProjectedVolume | Scales curve by projected volume. Axis can be locked to prevent scaling on that axis.
Public method | ScaleUniform | Scales curve by a single value. Axis can be locked to prevent scaling on that axis
Public method | SelectCurvePoints | Selects the specified points. (Inherited from PSGenericCurve.)
Public method | ToPolyline | Creates a single polyline from a generic curve. (Inherited from PSGenericCurve.)
Public method | ToSpline | Creates a single spline from a generic curve. (Inherited from PSGenericCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.Delete Method

PSCurveDelete Method

Deletes the Curve from PowerSHAPE and removes it from the Curves collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.Mirror Method

PSCurveMirror Method

Mirrors a single curve in a specified plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
Plane about which to mirror the curve
mirrorPoint
Type: Autodesk.GeometryPoint
Origin of the mirror plane

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.MoveBetweenPoints Method

PSCurveMoveBetweenPoints Method

Moves a single curve by the relative distance between two absolute positions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
First of the two absolute positions
pointToMoveTo
Type: Autodesk.GeometryPoint
Second of the two absolute positions
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.MoveByVector Method

PSCurveMoveByVector Method

Moves a single curve by a specified relative amount

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
Relative amount by which the curve will be moved
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.Offset Method

PSCurveOffset Method

Offsets a single curve by a specified distance

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Offset(
    MM offsetDistance,
    int copiesToCreate
)
Public Function Offset (
    offsetDistance As MM,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

offsetDistance
Type: Autodesk.GeometryMM
Distance by which to offset the curve
copiesToCreate
Type: SystemInt32
Number of copies to be created from the operation

Return Value

Type: List PSEntity
List of offset curves

Implements

IPSOffsetableOffset(MM, Int32)
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.Rotate Method

PSCurveRotate Method

Rotates a single curve by a specified angle around a specified axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
Axis around which the curve is are to be rotated
rotationAngle
Type: Autodesk.GeometryDegree
Angle by which the curve is to be rotated
copiesToCreate
Type: SystemInt32
Number of copies to create of the original curve
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin of the rotation axis

Return Value

Type: List PSEntity
List of curves created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.ScaleNonUniform Method

PSCurveScaleNonUniform Method

Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleNonUniform(
    double scaleFactorX,
    double scaleFactorY,
    double scaleFactorZ,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleNonUniform (
    scaleFactorX As Double,
    scaleFactorY As Double,
    scaleFactorZ As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactorX
Type: SystemDouble
Factor to scale by along X
scaleFactorY
Type: SystemDouble
Factor to scale by along Y
scaleFactorZ
Type: SystemDouble
Factor to scale by along Z
lockX
Type: SystemBoolean
Optionally locks X axis to prevent scaling
lockY
Type: SystemBoolean
Optionally locks Y axis to prevent scaling
lockZ
Type: SystemBoolean
Optionally locks Z axis to prevent scaling
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin to scale round

Implements

IPSScalableScaleNonUniform(Double, Double, Double, Boolean, Boolean, Boolean, Point)
Remarks
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.ScaleProjectedVolume Method

PSCurveScaleProjectedVolume Method

Scales curve by projected volume. Axis can be locked to prevent scaling on that axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleProjectedVolume(
    double newVolume,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleProjectedVolume (
    newVolume As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

newVolume
Type: SystemDouble
New projected volume
lockX
Type: SystemBoolean
Optionally locks X axis to prevent scaling
lockY
Type: SystemBoolean
Optionally locks Y axis to prevent scaling
lockZ
Type: SystemBoolean
Optionally locks Z axis to prevent scaling
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Objects are scaled relative to the scale origin.

Implements

IPSScalableScaleProjectedVolume(Double, Boolean, Boolean, Boolean, Point)
Remarks
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve.ScaleUniform Method

PSCurveScaleUniform Method

Scales curve by a single value. Axis can be locked to prevent scaling on that axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleUniform(
    double scaleFactor,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleUniform (
    scaleFactor As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactor
Type: SystemDouble
Factor to scale by
lockX
Type: SystemBoolean
Optionally locks X axis to prevent scaling
lockY
Type: SystemBoolean
Optionally locks Y axis to prevent scaling
lockZ
Type: SystemBoolean
Optionally locks Z axis to prevent scaling
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin to scale round

Implements

IPSScalableScaleUniform(Double, Boolean, Boolean, Boolean, Point)
Remarks
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurve Fields

The PSCurve type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurvesCollection Class

Captures a collection of Curves in a Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSCurve
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSCurve
Autodesk.ProductInterface.PowerSHAPEPSGenericCurvesCollection PSCurve
Autodesk.ProductInterface.PowerSHAPEPSCurvesCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSCurvesCollection : PSGenericCurvesCollection<PSCurve>
Public Class PSCurvesCollection
    Inherits PSGenericCurvesCollection(Of PSCurve)

The PSCurvesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateCurveFromBreakPoint | Breaks a curve at the specified point. The first section of the curve is retained, while the second section becomes a new curve. (Inherited from PSGenericCurvesCollectionT.)
Public method | CreateCurveFromCompCurve | Creates a Curve from a CompCurve
Public method | CreateCurveFromSketch | Allows the user to sketch a curve.
Public method | CreateCurvesFromMSRFile | Creates new curves from MSR data
Public method | CreateCurvesFromWrap | Creates new curves and compcurves by projecting wireframe onto a surface (Inherited from PSGenericCurvesCollectionT.)
Public method | CreateCurveThroughPoints | Creates a new curve through the specified points
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurvesCollection Properties

The PSCurvesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurvesCollection Methods

The PSCurvesCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateCurveFromBreakPoint | Breaks a curve at the specified point. The first section of the curve is retained, while the second section becomes a new curve. (Inherited from PSGenericCurvesCollectionT.)
Public method | CreateCurveFromCompCurve | Creates a Curve from a CompCurve
Public method | CreateCurveFromSketch | Allows the user to sketch a curve.
Public method | CreateCurvesFromMSRFile | Creates new curves from MSR data
Public method | CreateCurvesFromWrap | Creates new curves and compcurves by projecting wireframe onto a surface (Inherited from PSGenericCurvesCollectionT.)
Public method | CreateCurveThroughPoints | Creates a new curve through the specified points
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurvesCollection.CreateCurveFromCompCurve Method

PSCurvesCollectionCreateCurveFromCompCurve Method

Creates a Curve from a CompCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCurve CreateCurveFromCompCurve(
    PSCompCurve compCurve
)
Public Function CreateCurveFromCompCurve (
    compCurve As PSCompCurve
) As PSCurve

Parameters

compCurve
Type: Autodesk.ProductInterface.PowerSHAPEPSCompCurve
CompCurve to create a curev from

Return Value

Type: PSCurve
Curve created by the operation
See Also

Reference

PSCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurvesCollection.CreateCurveFromSketch Method

PSCurvesCollectionCreateCurveFromSketch Method

Allows the user to sketch a curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCurve CreateCurveFromSketch(
    bool closeCurve,
    double interval = 500
)
Public Function CreateCurveFromSketch (
    closeCurve As Boolean,
    Optional interval As Double = 500
) As PSCurve

Parameters

closeCurve
Type: SystemBoolean
Forces the user to create a curve that is closed
interval (Optional)
Type: SystemDouble
The number of milliseconds to wait before each check for a new curve. Defaults to 0.5seconds

Return Value

Type: PSCurve
Curve created by the operation
See Also

Reference

PSCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurvesCollection.CreateCurvesFromMSRFile Method

PSCurvesCollectionCreateCurvesFromMSRFile Method

Creates new curves from MSR data

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCurve> CreateCurvesFromMSRFile(
    MSRFile msrFile,
    int pointsPerCurve
)
Public Function CreateCurvesFromMSRFile (
    msrFile As MSRFile,
    pointsPerCurve As Integer
) As List(Of PSCurve)

Parameters

msrFile
Type: Autodesk.GeometryMSRFile
The file from which to get the point data
pointsPerCurve
Type: SystemInt32
The number of points in each curve

Return Value

Type: List PSCurve
A list of created curves
See Also

Reference

PSCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurvesCollection.CreateCurveThroughPoints Method

PSCurvesCollectionCreateCurveThroughPoints Method

Creates a new curve through the specified points

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCurve CreateCurveThroughPoints(
    CurveTypes curveType,
    Point[] points
)
Public Function CreateCurveThroughPoints (
    curveType As CurveTypes,
    points As Point()
) As PSCurve

Parameters

curveType
Type: Autodesk.ProductInterface.PowerSHAPECurveTypes
CurveTypes enum value for curev type
points
Type: Autodesk.GeometryPoint
Optional array of points or singular point for curve to go through

Return Value

Type: PSCurve
Curve created by the operation
See Also

Reference

PSCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSCurvesCollection Fields

The PSCurvesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSCurvesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T) Class

PSDatabaseEntitiesCollectionT Class

Base class for curve collections.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollectionT
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollectionT
Autodesk.ProductInterface.PowerSHAPEPSModelsCollection
Autodesk.ProductInterface.PowerSHAPEPSWindowsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSDatabaseEntitiesCollection<T> : IEnumerable<T>,
    IList<T>
where T : PSDatabaseEntity

Public MustInherit Class PSDatabaseEntitiesCollection(Of T As PSDatabaseEntity)
    Implements IEnumerable(Of T), IList(Of T)

Type Parameters

T
The entity type.

The PSDatabaseEntitiesCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection.
Public property | Item | Gets the desired indexed entity from the the collection.
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List.
Public method | Clear | Removes all entities in the list.
Public method | Contains | Determines whether the indicated entity is contained within the collection.
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.
Public method | GetEnumerator | Returns an enumerator of entities.
Public method | GetEnumerator1 | Returns an enumerator of entities.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list.
Protected method | Insert | Inserts the specified entity into the desired position within the collection.
Public method | LastItem | Gets the last entity in the List.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the item with the specified name.
Public method | Remove(T) | Removes the specified entity.
Public method | RemoveAt | Removes the entity at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'.
Protected field | _powerSHAPE | The PowerSHAPE Automation object.
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T) Properties

PSDatabaseEntitiesCollectionT Properties

The PSDatabaseEntitiesCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection.
Public property | Item | Gets the desired indexed entity from the the collection.
Top
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Count Property

PSDatabaseEntitiesCollectionTCount Property

Gets the number of entities in the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Item Property

PSDatabaseEntitiesCollectionTItem Property

Gets the desired indexed entity from the the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: T
The index of the desired entity.

Return Value

Type: T
The desired entity.

Implements

IListTItemInt32
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T) Methods

PSDatabaseEntitiesCollectionT Methods

The PSDatabaseEntitiesCollectionT generic type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List.
Public method | Clear | Removes all entities in the list.
Public method | Contains | Determines whether the indicated entity is contained within the collection.
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.
Public method | GetEnumerator | Returns an enumerator of entities.
Public method | GetEnumerator1 | Returns an enumerator of entities.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list.
Protected method | Insert | Inserts the specified entity into the desired position within the collection.
Public method | LastItem | Gets the last entity in the List.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the item with the specified name.
Public method | Remove(T) | Removes the specified entity.
Public method | RemoveAt | Removes the entity at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Add Method

PSDatabaseEntitiesCollectionTAdd Method

Adds a new DatabaseEntity to the List.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
internal void Add(
    T databaseEntity
)
Friend Sub Add (
    databaseEntity As T
)

Parameters

databaseEntity
Type: T
The entity to add.

Implements

ICollectionTAdd(T)
Remarks
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Clear Method

PSDatabaseEntitiesCollectionTClear Method

Removes all entities in the list.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void Clear()
Public MustOverride Sub Clear

Implements

ICollectionTClear
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Contains Method

PSDatabaseEntitiesCollectionTContains Method

Determines whether the indicated entity is contained within the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean

Parameters

item
Type: T
The entity to check for.

Return Value

Type: Boolean
A boolean indicating the entity's presence in the collection.

Implements

ICollectionTContains(T)
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).CopyTo Method

PSDatabaseEntitiesCollectionTCopyTo Method

Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CopyTo(
    T[] otherCollection,
    int index
)
Public Sub CopyTo (
    otherCollection As T(),
    index As Integer
)

Parameters

otherCollection
Type: T
The destination of the elements copied.
index
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).GetByName Method

PSDatabaseEntitiesCollectionTGetByName Method

Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T GetByName(
    string name
)
Public Function GetByName (
    name As String
) As T

Parameters

name
Type: SystemString
The name of the entity.

Return Value

Type: T
It may return Nothing if entity is not found.
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).GetEnumerator Method

PSDatabaseEntitiesCollectionTGetEnumerator Method

Returns an enumerator of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumerator T

Implements

IEnumerableTGetEnumerator
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).GetEnumerator1 Method

PSDatabaseEntitiesCollectionTGetEnumerator1 Method

Returns an enumerator of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator1()
Public Function GetEnumerator1 As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).IndexOf Method

PSDatabaseEntitiesCollectionTIndexOf Method

Index of item in the list.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    T item
)
Public Overridable Function IndexOf (
    item As T
) As Integer

Parameters

item
Type: T
The item to get the index from.

Return Value

Type: Int32
The index of the item.

Implements

IListTIndexOf(T)
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Insert Method

PSDatabaseEntitiesCollectionTInsert Method

Inserts the specified entity into the desired position within the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
internal void Insert(
    int index,
    T item
)
Friend Sub Insert (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The position into which the entity is to be inserted.
item
Type: T
The entity to be inserted.

Implements

IListTInsert(Int32, T)
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).LastItem Method

PSDatabaseEntitiesCollectionTLastItem Method

Gets the last entity in the List.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T LastItem()
Public Function LastItem As T

Return Value

Type: T
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Remove Method

PSDatabaseEntitiesCollectionTRemove Method

Overload List
 | Name | Description
Public method | Remove(String) | Removes the item with the specified name.
Public method | Remove(T) | Removes the specified entity.
Top
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Remove Method (String)

PSDatabaseEntitiesCollectionTRemove Method (String)

Removes the item with the specified name.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual bool Remove(
    string name
)
Public Overridable Function Remove (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the entity to remove.

Return Value

Type: Boolean
True if item is successfully removed; otherwise, false.
Remarks
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).Remove Method (T)

PSDatabaseEntitiesCollectionTRemove Method (T)

Removes the specified entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual bool Remove(
    T item
)
Public Overridable Function Remove (
    item As T
) As Boolean

Parameters

item
Type: T
The entity to be removed.

Return Value

Type: Boolean
A boolean indicating whether the item has been removed.

Implements

ICollectionTRemove(T)
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T).RemoveAt Method

PSDatabaseEntitiesCollectionTRemoveAt Method

Removes the entity at the specified index.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void RemoveAt(
    int index
)
Public MustOverride Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
Remarks
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T) Fields

PSDatabaseEntitiesCollectionT Fields

The PSDatabaseEntitiesCollectionT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'.
Protected field | _powerSHAPE | The PowerSHAPE Automation object.
Top
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T)._list Field

PSDatabaseEntitiesCollectionT_list Field

The DatabaseEntitiesCollection as a list and is used in place of 'Me'.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected List<T> _list
Protected _list As List(Of T)

Field Value

Type: List T
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntitiesCollection(T)._powerSHAPE Field

PSDatabaseEntitiesCollectionT_powerSHAPE Field

The PowerSHAPE Automation object.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSAutomation _powerSHAPE
Protected _powerSHAPE As PSAutomation

Field Value

Type: PSAutomation
See Also

Reference

PSDatabaseEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity Class

Abstract class captures a database entity in PowerSHAPE.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSModel
Autodesk.ProductInterface.PowerSHAPEPSWindow

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSDatabaseEntity
Public MustInherit Class PSDatabaseEntity

The PSDatabaseEntity type exposes the following members.

Properties
 | Name | Description
Public property | Exists | Checks to see if the entity exists in PowerSHAPE.
Public property | Id | Gets the Id of the entity in PowerSHAPE.
Public property | Name | Gets or Sets the name of the entity.
Public property | PSAutomation | Gets the parent PSAutomation.
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE.
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object.
Protected field | _name | The name of the object.
Protected field | _powerSHAPE | The PowerSHAPE Automation object.
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity Properties

The PSDatabaseEntity type exposes the following members.

Properties
 | Name | Description
Public property | Exists | Checks to see if the entity exists in PowerSHAPE.
Public property | Id | Gets the Id of the entity in PowerSHAPE.
Public property | Name | Gets or Sets the name of the entity.
Public property | PSAutomation | Gets the parent PSAutomation.
Top
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity.Exists Property

PSDatabaseEntityExists Property

Checks to see if the entity exists in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual bool Exists { get; }
Public Overridable ReadOnly Property Exists As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity.Id Property

PSDatabaseEntityId Property

Gets the Id of the entity in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get

Property Value

Type: String
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity.Name Property

PSDatabaseEntityName Property

Gets or Sets the name of the entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract string Name { get; set; }
Public MustOverride Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity.PSAutomation Property

PSDatabaseEntityPSAutomation Property

Gets the parent PSAutomation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSAutomation PSAutomation { get; }
Public ReadOnly Property PSAutomation As PSAutomation
    Get

Property Value

Type: PSAutomation
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity Methods

The PSDatabaseEntity type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE.
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity.AbortIfDoesNotExist Method

PSDatabaseEntityAbortIfDoesNotExist Method

This operation throws an error if the item does not exist in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected virtual void AbortIfDoesNotExist()
Protected Overridable Sub AbortIfDoesNotExist
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity.Equals Method

PSDatabaseEntityEquals Method

Compares the DatabaseEntity to another DatabaseEntity by checking their IDs.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The other DatabaseEntity to compare to.

Return Value

Type: Boolean
Boolean determining whether the IDs match.
Remarks
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity Fields

The PSDatabaseEntity type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object.
Protected field | _name | The name of the object.
Protected field | _powerSHAPE | The PowerSHAPE Automation object.
Top
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity._id Field

PSDatabaseEntity_id Field

The database ID of the object.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected string _id
Protected _id As String

Field Value

Type: String
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity._name Field

PSDatabaseEntity_name Field

The name of the object.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected string _name
Protected _name As String

Field Value

Type: String
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSDatabaseEntity._powerSHAPE Field

PSDatabaseEntity_powerSHAPE Field

The PowerSHAPE Automation object.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSAutomation _powerSHAPE
Protected _powerSHAPE As PSAutomation

Field Value

Type: PSAutomation
See Also

Reference

PSDatabaseEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode Class

Captures an Electrode object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSElectrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSElectrode : PSEntity,
    IPSMoveable, IPSRotateable, IPSMirrorable, IPSScalable
Public Class PSElectrode
    Inherits PSEntity
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSScalable

The PSElectrode type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSolid | Gets the active solid for the Electrode. Returns null if none is selected.
Public property | ActiveWorkplane | Gets the active workplane for the Electrode. Returns null if none is selected.
Public property | AngleA | Gets the A angle. Angle between projected burn vector in XY plane and X axis
Public property | AngleB | Gets the B angle. Angle between projected burn vector and Z axis. Normal Z sinking: B=0. Side sparking: B=90
Public property | AngleC | Gets the C angle. Rotation around burn vector. This is same as "Rotation" if ANGLE.B is 0
Public property | BaseHeight | Gets the height of the electrode base
Public property | BlankDiameter | Gets the diameter of the electrode blank if it is cylindrical
Public property | BlankHeight | Gets the height of the electrode blank
Public property | BlankLength | Gets the length of the electrode blank if it is rectangular
Public property | BlankMaterial | Gets the material of the electrode blank in PowerSHAPE
Public property | BlankName | Gets the name of the blank
Public property | BlankWidth | Gets the width of the electrode blank if it is rectangular
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | BurnVector | Gets the direction of the electrode burn
Public property | Copies | Gets the copies of this electrode
Public property | Datum | Gets the datum of the Electrode in PowerSHAPE based on the active Workplane
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsBlankRectangular | Gets whether or not the electrode is rectangular (or cylindrical)
Public property | IsCopy | Gets whether or not this electrode is a copy of another
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | MachiningWorkplane | Gets the machining workplane for the Electrode. Returns null if none is selected.
Public property | Material | Gets and Sets the material of the Electrode in PowerSHAPE
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Parent | Gets the parent of this electrode. If this electrode is not a copy then null is returned
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | ProjectedArea | Gets the projected area of the Electrode
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | QuantityFinish | Gets and sets the quantity finish value of the electrode
Public property | QuantityRough | Gets and sets the quantity rough value of the electrode
Public property | QuantitySemi | Gets and sets the quantity semi value of the electrode
Public property | Rotation | Gets the rotation of the electrode
Public property | SparkGap | Gets and sets the spark gap of the electrode
Public property | SurfaceFinish | Gets and sets the surface finish of the electrode
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | UndersizeFinish | Gets and sets the undersize finish value of the electrode
Public property | UndersizeRough | Gets and sets the undersize rough value of the electrode
Public property | UndersizeSemi | Gets and sets the undersize semi value of the electrode
Public property | VectorClearance | Gets the clearance distance from beginning of vector motion to start of burn
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Electrode from PowerSHAPE and removes it from the Electrodes collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single Electrode in a specified plane
Public method | MoveBetweenPoints | This operation moves a single Electrode by the relative distance between two absolute positions
Public method | MoveByVector | This operation moves a single Electrode by a specified relative amount
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | This operation rotates a single Electrode by a specified angle around a specified axis
Public method | ScaleNonUniform | Scales the Electrode a different amount in each axis
Public method | ScaleProjectedVolume | Scales the Electrode to a projected volume
Public method | ScaleUniform | Scales the Electrode the same amount in each axis
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode Properties

The PSElectrode type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSolid | Gets the active solid for the Electrode. Returns null if none is selected.
Public property | ActiveWorkplane | Gets the active workplane for the Electrode. Returns null if none is selected.
Public property | AngleA | Gets the A angle. Angle between projected burn vector in XY plane and X axis
Public property | AngleB | Gets the B angle. Angle between projected burn vector and Z axis. Normal Z sinking: B=0. Side sparking: B=90
Public property | AngleC | Gets the C angle. Rotation around burn vector. This is same as "Rotation" if ANGLE.B is 0
Public property | BaseHeight | Gets the height of the electrode base
Public property | BlankDiameter | Gets the diameter of the electrode blank if it is cylindrical
Public property | BlankHeight | Gets the height of the electrode blank
Public property | BlankLength | Gets the length of the electrode blank if it is rectangular
Public property | BlankMaterial | Gets the material of the electrode blank in PowerSHAPE
Public property | BlankName | Gets the name of the blank
Public property | BlankWidth | Gets the width of the electrode blank if it is rectangular
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | BurnVector | Gets the direction of the electrode burn
Public property | Copies | Gets the copies of this electrode
Public property | Datum | Gets the datum of the Electrode in PowerSHAPE based on the active Workplane
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsBlankRectangular | Gets whether or not the electrode is rectangular (or cylindrical)
Public property | IsCopy | Gets whether or not this electrode is a copy of another
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | MachiningWorkplane | Gets the machining workplane for the Electrode. Returns null if none is selected.
Public property | Material | Gets and Sets the material of the Electrode in PowerSHAPE
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Parent | Gets the parent of this electrode. If this electrode is not a copy then null is returned
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | ProjectedArea | Gets the projected area of the Electrode
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | QuantityFinish | Gets and sets the quantity finish value of the electrode
Public property | QuantityRough | Gets and sets the quantity rough value of the electrode
Public property | QuantitySemi | Gets and sets the quantity semi value of the electrode
Public property | Rotation | Gets the rotation of the electrode
Public property | SparkGap | Gets and sets the spark gap of the electrode
Public property | SurfaceFinish | Gets and sets the surface finish of the electrode
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | UndersizeFinish | Gets and sets the undersize finish value of the electrode
Public property | UndersizeRough | Gets and sets the undersize rough value of the electrode
Public property | UndersizeSemi | Gets and sets the undersize semi value of the electrode
Public property | VectorClearance | Gets the clearance distance from beginning of vector motion to start of burn
Top
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.ActiveSolid Property

PSElectrodeActiveSolid Property

Gets the active solid for the Electrode. Returns null if none is selected.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSolid ActiveSolid { get; }
Public ReadOnly Property ActiveSolid As PSSolid
    Get

Property Value

Type: PSSolid
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.ActiveWorkplane Property

PSElectrodeActiveWorkplane Property

Gets the active workplane for the Electrode. Returns null if none is selected.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane ActiveWorkplane { get; }
Public ReadOnly Property ActiveWorkplane As PSWorkplane
    Get

Property Value

Type: PSWorkplane
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.AngleA Property

PSElectrodeAngleA Property

Gets the A angle. Angle between projected burn vector in XY plane and X axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree AngleA { get; }
Public ReadOnly Property AngleA As Degree
    Get

Property Value

Type: Degree
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.AngleB Property

PSElectrodeAngleB Property

Gets the B angle. Angle between projected burn vector and Z axis. Normal Z sinking: B=0. Side sparking: B=90

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree AngleB { get; }
Public ReadOnly Property AngleB As Degree
    Get

Property Value

Type: Degree
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.AngleC Property

PSElectrodeAngleC Property

Gets the C angle. Rotation around burn vector. This is same as "Rotation" if ANGLE.B is 0

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree AngleC { get; }
Public ReadOnly Property AngleC As Degree
    Get

Property Value

Type: Degree
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.BaseHeight Property

PSElectrodeBaseHeight Property

Gets the height of the electrode base

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BaseHeight { get; }
Public ReadOnly Property BaseHeight As MM
    Get

Property Value

Type: MM
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.BlankDiameter Property

PSElectrodeBlankDiameter Property

Gets the diameter of the electrode blank if it is cylindrical

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BlankDiameter { get; }
Public ReadOnly Property BlankDiameter As MM
    Get

Property Value

Type: MM
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.BlankHeight Property

PSElectrodeBlankHeight Property

Gets the height of the electrode blank

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BlankHeight { get; }
Public ReadOnly Property BlankHeight As MM
    Get

Property Value

Type: MM
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.BlankLength Property

PSElectrodeBlankLength Property

Gets the length of the electrode blank if it is rectangular

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BlankLength { get; }
Public ReadOnly Property BlankLength As MM
    Get

Property Value

Type: MM
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.BlankMaterial Property

PSElectrodeBlankMaterial Property

Gets the material of the electrode blank in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMaterial BlankMaterial { get; }
Public ReadOnly Property BlankMaterial As PSMaterial
    Get

Property Value

Type: PSMaterial
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.BlankName Property

PSElectrodeBlankName Property

Gets the name of the blank

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string BlankName { get; }
Public ReadOnly Property BlankName As String
    Get

Property Value

Type: String
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.BlankWidth Property

PSElectrodeBlankWidth Property

Gets the width of the electrode blank if it is rectangular

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BlankWidth { get; }
Public ReadOnly Property BlankWidth As MM
    Get

Property Value

Type: MM
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.BurnVector Property

PSElectrodeBurnVector Property

Gets the direction of the electrode burn

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector BurnVector { get; }
Public ReadOnly Property BurnVector As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.Copies Property

PSElectrodeCopies Property

Gets the copies of this electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSElectrode> Copies { get; }
Public ReadOnly Property Copies As List(Of PSElectrode)
    Get

Property Value

Type: List PSElectrode
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.Datum Property

PSElectrodeDatum Property

Gets the datum of the Electrode in PowerSHAPE based on the active Workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Datum { get; }
Public ReadOnly Property Datum As Point
    Get

Property Value

Type: Point
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.IsBlankRectangular Property

PSElectrodeIsBlankRectangular Property

Gets whether or not the electrode is rectangular (or cylindrical)

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsBlankRectangular { get; }
Public ReadOnly Property IsBlankRectangular As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.IsCopy Property

PSElectrodeIsCopy Property

Gets whether or not this electrode is a copy of another

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsCopy { get; }
Public ReadOnly Property IsCopy As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.MachiningWorkplane Property

PSElectrodeMachiningWorkplane Property

Gets the machining workplane for the Electrode. Returns null if none is selected.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane MachiningWorkplane { get; }
Public ReadOnly Property MachiningWorkplane As PSWorkplane
    Get

Property Value

Type: PSWorkplane
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.Material Property

PSElectrodeMaterial Property

Gets and Sets the material of the Electrode in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMaterial Material { get; set; }
Public Property Material As PSMaterial
    Get
    Set

Property Value

Type: PSMaterial
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.Parent Property

PSElectrodeParent Property

Gets the parent of this electrode. If this electrode is not a copy then null is returned

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSElectrode Parent { get; }
Public ReadOnly Property Parent As PSElectrode
    Get

Property Value

Type: PSElectrode
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.ProjectedArea Property

PSElectrodeProjectedArea Property

Gets the projected area of the Electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double ProjectedArea { get; }
Public ReadOnly Property ProjectedArea As Double
    Get

Property Value

Type: Double
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.QuantityFinish Property

PSElectrodeQuantityFinish Property

Gets and sets the quantity finish value of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int QuantityFinish { get; set; }
Public Property QuantityFinish As Integer
    Get
    Set

Property Value

Type: Int32
The quantity finish value
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.QuantityRough Property

PSElectrodeQuantityRough Property

Gets and sets the quantity rough value of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int QuantityRough { get; set; }
Public Property QuantityRough As Integer
    Get
    Set

Property Value

Type: Int32
The undersize rough value
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.QuantitySemi Property

PSElectrodeQuantitySemi Property

Gets and sets the quantity semi value of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int QuantitySemi { get; set; }
Public Property QuantitySemi As Integer
    Get
    Set

Property Value

Type: Int32
The quantity semi value
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.Rotation Property

PSElectrodeRotation Property

Gets the rotation of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree Rotation { get; }
Public ReadOnly Property Rotation As Degree
    Get

Property Value

Type: Degree
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.SparkGap Property

PSElectrodeSparkGap Property

Gets and sets the spark gap of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double SparkGap { get; set; }
Public Property SparkGap As Double
    Get
    Set

Property Value

Type: Double
The spark gap value
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.SurfaceFinish Property

PSElectrodeSurfaceFinish Property

Gets and sets the surface finish of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string SurfaceFinish { get; set; }
Public Property SurfaceFinish As String
    Get
    Set

Property Value

Type: String
The surface finish value
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.UndersizeFinish Property

PSElectrodeUndersizeFinish Property

Gets and sets the undersize finish value of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double UndersizeFinish { get; set; }
Public Property UndersizeFinish As Double
    Get
    Set

Property Value

Type: Double
The undersize finish value
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.UndersizeRough Property

PSElectrodeUndersizeRough Property

Gets and sets the undersize rough value of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double UndersizeRough { get; set; }
Public Property UndersizeRough As Double
    Get
    Set

Property Value

Type: Double
The undersize rough value
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.UndersizeSemi Property

PSElectrodeUndersizeSemi Property

Gets and sets the undersize semi value of the electrode

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double UndersizeSemi { get; set; }
Public Property UndersizeSemi As Double
    Get
    Set

Property Value

Type: Double
The undersize semi value
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.VectorClearance Property

PSElectrodeVectorClearance Property

Gets the clearance distance from beginning of vector motion to start of burn

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM VectorClearance { get; }
Public ReadOnly Property VectorClearance As MM
    Get

Property Value

Type: MM
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode Methods

The PSElectrode type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Electrode from PowerSHAPE and removes it from the Electrodes collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single Electrode in a specified plane
Public method | MoveBetweenPoints | This operation moves a single Electrode by the relative distance between two absolute positions
Public method | MoveByVector | This operation moves a single Electrode by a specified relative amount
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | This operation rotates a single Electrode by a specified angle around a specified axis
Public method | ScaleNonUniform | Scales the Electrode a different amount in each axis
Public method | ScaleProjectedVolume | Scales the Electrode to a projected volume
Public method | ScaleUniform | Scales the Electrode the same amount in each axis
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.Delete Method

PSElectrodeDelete Method

Deletes the Electrode from PowerSHAPE and removes it from the Electrodes collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.Mirror Method

PSElectrodeMirror Method

This operation mirrors a single Electrode in a specified plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the Electrode
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.MoveBetweenPoints Method

PSElectrodeMoveBetweenPoints Method

This operation moves a single Electrode by the relative distance between two absolute positions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity
A list containing the entity moved

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.MoveByVector Method

PSElectrodeMoveByVector Method

This operation moves a single Electrode by a specified relative amount

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
The relative amount by which the Electrode will be moved
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity
A list containing the entity moved

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.Rotate Method

PSElectrodeRotate Method

This operation rotates a single Electrode by a specified angle around a specified axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the Electrode is are to be rotated
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the Electrode is to be rotated
copiesToCreate
Type: SystemInt32
The number of copies to create of the original Electrode
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis

Return Value

Type: List PSEntity
A list of Electrodes created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.ScaleNonUniform Method

PSElectrodeScaleNonUniform Method

Scales the Electrode a different amount in each axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleNonUniform(
    double scaleFactorX,
    double scaleFactorY,
    double scaleFactorZ,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleNonUniform (
    scaleFactorX As Double,
    scaleFactorY As Double,
    scaleFactorZ As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactorX
Type: SystemDouble
Scale factor for the X axis
scaleFactorY
Type: SystemDouble
Scale factor for the Y axis
scaleFactorZ
Type: SystemDouble
Scale factor for the Z axis
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleNonUniform(Double, Double, Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.ScaleProjectedVolume Method

PSElectrodeScaleProjectedVolume Method

Scales the Electrode to a projected volume

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleProjectedVolume(
    double newVolume,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleProjectedVolume (
    newVolume As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

newVolume
Type: SystemDouble
Volume to scale to
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleProjectedVolume(Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode.ScaleUniform Method

PSElectrodeScaleUniform Method

Scales the Electrode the same amount in each axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleUniform(
    double scaleFactor,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleUniform (
    scaleFactor As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactor
Type: SystemDouble
Scale factor for the axes
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleUniform(Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrode Fields

The PSElectrode type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSElectrode Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrodesCollection Class

Captures a collection of Electrodes in a Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSElectrode
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSElectrode
Autodesk.ProductInterface.PowerSHAPEPSElectrodesCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSElectrodesCollection : PSEntitiesCollection<PSElectrode>
Public Class PSElectrodesCollection
    Inherits PSEntitiesCollection(Of PSElectrode)

The PSElectrodesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the electrodes to the selection. (Overrides PSEntitiesCollectionTAddToSelection(Boolean).)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrodesCollection Properties

The PSElectrodesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSElectrodesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrodesCollection Methods

The PSElectrodesCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the electrodes to the selection. (Overrides PSEntitiesCollectionTAddToSelection(Boolean).)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSElectrodesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrodesCollection.AddToSelection Method

PSElectrodesCollectionAddToSelection Method

Adds all of the electrodes to the selection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void AddToSelection(
    bool emptySelectionFirst = false
)
Public Overrides Sub AddToSelection (
    Optional emptySelectionFirst As Boolean = false
)

Parameters

emptySelectionFirst (Optional)
Type: SystemBoolean
If true it will empty PowerShape selection first.
See Also

Reference

PSElectrodesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSElectrodesCollection Fields

The PSElectrodesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSElectrodesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T) Class

PSEntitiesCollectionT Class

Abstract base class that all list classes are based on.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection T
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollectionT
More...

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSEntitiesCollection<T> : PSDatabaseEntitiesCollection<T>
where T : PSEntity

Public MustInherit Class PSEntitiesCollection(Of T As PSEntity)
    Inherits PSDatabaseEntitiesCollection(Of T)

Type Parameters

T
The type of the PSEntity.

The PSEntitiesCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection.
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection.
Public method | Clear | Removes all entities in the list. (Overrides PSDatabaseEntitiesCollectionTClear.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Overrides PSDatabaseEntitiesCollectionTRemove(String).)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Overrides PSDatabaseEntitiesCollectionTRemove(String).)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Overrides PSDatabaseEntitiesCollectionTRemoveAt(Int32).)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection T
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollectionT
Autodesk.ProductInterface.PowerSHAPEPSAnnotationsCollection
Autodesk.ProductInterface.PowerSHAPEPSArcsCollection
Autodesk.ProductInterface.PowerSHAPEPSElectrodesCollection
Autodesk.ProductInterface.PowerSHAPEPSGenericCurvesCollectionT
Autodesk.ProductInterface.PowerSHAPEPSLinesCollection
Autodesk.ProductInterface.PowerSHAPEPSMeshesCollection
Autodesk.ProductInterface.PowerSHAPEPSPointsCollection
Autodesk.ProductInterface.PowerSHAPEPSSolidsCollection
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurvesCollectionT
Autodesk.ProductInterface.PowerSHAPEPSSurfacesCollection
Autodesk.ProductInterface.PowerSHAPEPSWorkplanesCollection


PSEntitiesCollection(T) Properties

PSEntitiesCollectionT Properties

The PSEntitiesCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection.
Top
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).Item Property

PSEntitiesCollectionTItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection.
Top
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).Item Property (String)

PSEntitiesCollectionTItem Property (String)

Gets the desired indexed entity from the the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T this[
    string name
] { get; set; }
Public Default Property Item (
    name As String
) As T
    Get
    Set

Parameters

name
Type: SystemString

Property Value

Type: T
The index of the desired entity.

Return Value

Type: T
The desired entity.
See Also

Reference

PSEntitiesCollectionT Class
Item Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T) Methods

PSEntitiesCollectionT Methods

The PSEntitiesCollectionT generic type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection.
Public method | Clear | Removes all entities in the list. (Overrides PSDatabaseEntitiesCollectionTClear.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Overrides PSDatabaseEntitiesCollectionTRemove(String).)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Overrides PSDatabaseEntitiesCollectionTRemove(String).)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Overrides PSDatabaseEntitiesCollectionTRemoveAt(Int32).)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).AddToSelection Method

PSEntitiesCollectionTAddToSelection Method

Adds all of the current entity type to the selection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void AddToSelection(
    bool emptySelectionFirst = false
)
Public Overridable Sub AddToSelection (
    Optional emptySelectionFirst As Boolean = false
)

Parameters

emptySelectionFirst (Optional)
Type: SystemBoolean
If true it will empty PowerShape selection first.
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).Clear Method

PSEntitiesCollectionTClear Method

Removes all entities in the list.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Clear()
Public Overrides Sub Clear
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).Remove Method

PSEntitiesCollectionTRemove Method

Overload List
 | Name | Description
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Overrides PSDatabaseEntitiesCollectionTRemove(String).)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Overrides PSDatabaseEntitiesCollectionTRemove(String).)
Top
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).Remove Method (String)

PSEntitiesCollectionTRemove Method (String)

Removes the specified item by name from PowerShape and from the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Remove(
    string entityName
)
Public Overrides Function Remove (
    entityName As String
) As Boolean

Parameters

entityName
Type: SystemString
The name of the entity.

Return Value

Type: Boolean
True if entity was removed from the collection.
See Also

Reference

PSEntitiesCollectionT Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).Remove Method (T)

PSEntitiesCollectionTRemove Method (T)

Removes the specified item from PowerShape and from the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Remove(
    T entity
)
Public Overrides Function Remove (
    entity As T
) As Boolean

Parameters

entity
Type: T
The entity to remove.

Return Value

Type: Boolean
True if entity was removed from the collection.
See Also

Reference

PSEntitiesCollectionT Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).RemoveAt Method

PSEntitiesCollectionTRemoveAt Method

Removes the entity at the specified index from PowerShape and from the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RemoveAt(
    int index
)
Public Overrides Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to get or set.
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T).RemoveFromSelection Method

PSEntitiesCollectionTRemoveFromSelection Method

Removes all of the current entity type from the selection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void RemoveFromSelection()
Public Overridable Sub RemoveFromSelection
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntitiesCollection(T) Fields

PSEntitiesCollectionT Fields

The PSEntitiesCollectionT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSEntitiesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity Class

Abstract class to capture an entity in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
More...

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSEntity : PSDatabaseEntity
Public MustInherit Class PSEntity
    Inherits PSDatabaseEntity

The PSEntity type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE
Public property | Name | Gets the Name of the entity in PowerSHAPE (Overrides PSDatabaseEntityName.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection
Public method | Blank | Blanks the Entity in PowerSHAPE
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE
Public method | Delete | Deletes the item from PowerSHAPE and removes it from the correct collection if it is a member of one
Public method | DistanceTo | Gets the distance between this entity and another
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown.
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another
Public method | RemoveFromSelection | Removes the Entity from the current selection
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber |
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSAnnotation
Autodesk.ProductInterface.PowerSHAPEPSElectrode
Autodesk.ProductInterface.PowerSHAPEPSMesh
Autodesk.ProductInterface.PowerSHAPEPSPoint
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSWorkplane


PSEntity Properties

The PSEntity type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE
Public property | Name | Gets the Name of the entity in PowerSHAPE (Overrides PSDatabaseEntityName.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE
Top
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.BoundingBox Property

PSEntityBoundingBox Property

Gets the bounding box of the Entity in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual BoundingBox BoundingBox { get; }
Public Overridable ReadOnly Property BoundingBox As BoundingBox
    Get

Return Value

Type: BoundingBox
A BoundingBox object representing the bounding box in PowerSHAPE
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.Level Property

PSEntityLevel Property

Gets and Sets the Level the Entity is on in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual PSLevel Level { get; set; }
Public Overridable Property Level As PSLevel
    Get
    Set

Property Value

Type: PSLevel
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.LevelNumber Property

PSEntityLevelNumber Property

Gets and sets the Level Number the Entity is on in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual uint LevelNumber { get; set; }
Public Overridable Property LevelNumber As UInteger
    Get
    Set

Property Value

Type: UInt32
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.Name Property

PSEntityName Property

Gets the Name of the entity in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.PowerSHAPEType Property

PSEntityPowerSHAPEType Property

Gets the PowerSHAPE name of the object

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual string PowerSHAPEType { get; }
Public Overridable ReadOnly Property PowerSHAPEType As String
    Get

Property Value

Type: String
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.Transparency Property

PSEntityTransparency Property

Gets and Sets the transparency of the Entity in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual double Transparency { get; set; }
Public Overridable Property Transparency As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity Methods

The PSEntity type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection
Public method | Blank | Blanks the Entity in PowerSHAPE
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE
Public method | Delete | Deletes the item from PowerSHAPE and removes it from the correct collection if it is a member of one
Public method | DistanceTo | Gets the distance between this entity and another
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown.
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another
Public method | RemoveFromSelection | Removes the Entity from the current selection
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.AddToSelection Method

PSEntityAddToSelection Method

Adds the entity to the selection and optionally clears the current selection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void AddToSelection(
    bool emptySelectionFirst = false
)
Public Overridable Sub AddToSelection (
    Optional emptySelectionFirst As Boolean = false
)

Parameters

emptySelectionFirst (Optional)
Type: SystemBoolean
Optionally clears the current selection
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.Blank Method

PSEntityBlank Method

Blanks the Entity in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void Blank()
Public Overridable Sub Blank
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.BlankExcept Method

PSEntityBlankExcept Method

Blanks everything apart from this Entity in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void BlankExcept()
Public Overridable Sub BlankExcept
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.Delete Method

PSEntityDelete Method

Deletes the item from PowerSHAPE and removes it from the correct collection if it is a member of one

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void Delete()
Public MustOverride Sub Delete
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.DistanceTo Method

PSEntityDistanceTo Method

Gets the distance between this entity and another

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM DistanceTo(
    PSEntity otherEntity
)
Public Function DistanceTo (
    otherEntity As PSEntity
) As MM

Parameters

otherEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The function returns the distance between this entity and the otherEntity

Return Value

Type: MM
Exceptions
Exception | Condition
Exception | Failed to determine distance between objects
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.Duplicate Method

PSEntityDuplicate Method

Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual PSEntity Duplicate()
Public Overridable Function Duplicate As PSEntity

Return Value

Type: PSEntity
Exceptions
Exception | Condition
NotImplementedException | Doesn't yet support multiple pasted objects
Exception | Item in clipboard is not a PowerSHAPE, or the expected object
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.GetHashCode Method

PSEntityGetHashCode Method

Overrides the GetHashCode function to return the ID as an integer

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.RebaseToWorkplane Method

PSEntityRebaseToWorkplane Method

Shifts the entity from being relative to one workplane to being relative to another

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void RebaseToWorkplane(
    PSWorkplane toWorkplane,
    PSWorkplane fromWorkplane = null
)
Public Overridable Sub RebaseToWorkplane (
    toWorkplane As PSWorkplane,
    Optional fromWorkplane As PSWorkplane = Nothing
)

Parameters

toWorkplane
Type: Autodesk.ProductInterface.PowerSHAPEPSWorkplane
The workplane to rebase to
fromWorkplane (Optional)
Type: Autodesk.ProductInterface.PowerSHAPEPSWorkplane
Optional parameter. The workplane to rebase from. Default of Nothing is world.
Exceptions
Exception | Condition
NotImplementedException | Doesn't yet support multiple pasted objects
Exception | Item in clipboard is not a PowerSHAPE, or the expected object
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity.RemoveFromSelection Method

PSEntityRemoveFromSelection Method

Removes the Entity from the current selection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void RemoveFromSelection()
Public Overridable Sub RemoveFromSelection
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity Fields

The PSEntity type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber |
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntity._levelNumber Field

PSEntity_levelNumber Field

[Missing <summary> documentation for "F:Autodesk.ProductInterface.PowerSHAPE.PSEntity._levelNumber"]

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected int _levelNumber
Protected _levelNumber As Integer

Field Value

Type: Int32
See Also

Reference

PSEntity Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityCutter Class

Entity cutter helper.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSEntityCutter

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSEntityCutter
Public Class PSEntityCutter

The PSEntityCutter type exposes the following members.

Constructors
 | Name | Description
Public method | PSEntityCutter | Creates a new entity cutter instance.
Top
Methods
 | Name | Description
 | CutEntity | Cuts a single entity at a defined point.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityCutter Constructor

Creates a new entity cutter instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntityCutter(
    PSAutomation powerSHAPE
)
Public Sub New (
    powerSHAPE As PSAutomation
)

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
Remarks
See Also

Reference

PSEntityCutter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityCutter Methods

The PSEntityCutter type exposes the following members.

Methods
 | Name | Description
 | CutEntity | Cuts a single entity at a defined point.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntityCutter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityCutter.CutEntity Method

PSEntityCutterCutEntity Method

Cuts a single entity at a defined point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static PSEntity CutEntity(
    PSEntity entityToCut,
    Point pointAtWhichToCut
)
Public Shared Function CutEntity (
    entityToCut As PSEntity,
    pointAtWhichToCut As Point
) As PSEntity

Parameters

entityToCut
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity to cut.
pointAtWhichToCut
Type: Autodesk.GeometryPoint
The point at which to cut the entity, which must lie on the entity.

Return Value

Type: PSEntity
A piece of the original entity.
See Also

Reference

PSEntityCutter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityLimiter Class

Contains the necessary code to limit entities.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSEntityLimiter

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSEntityLimiter
Public Class PSEntityLimiter

The PSEntityLimiter type exposes the following members.

Methods
 | Name | Description
 | AcceptLimit | This operation will close the limit operation
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextSolution(IPSLimitable) | This operation will cycle to the next solution for the last limit function. To accept call AcceptLimit.
Public method | NextSolution(IEnumerableIPSLimitable) | This operation will cycle to the next solution for the last limit function. To accept call AcceptLimit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Must be public for the enumerations to be accessible.
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityLimiter Methods

The PSEntityLimiter type exposes the following members.

Methods
 | Name | Description
 | AcceptLimit | This operation will close the limit operation
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextSolution(IPSLimitable) | This operation will cycle to the next solution for the last limit function. To accept call AcceptLimit.
Public method | NextSolution(IEnumerableIPSLimitable) | This operation will cycle to the next solution for the last limit function. To accept call AcceptLimit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntityLimiter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityLimiter.AcceptLimit Method

PSEntityLimiterAcceptLimit Method

This operation will close the limit operation

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void AcceptLimit()
Public Shared Sub AcceptLimit
See Also

Reference

PSEntityLimiter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityLimiter.NextSolution Method

PSEntityLimiterNextSolution Method

Overload List
 | Name | Description
 | NextSolution(IPSLimitable) | This operation will cycle to the next solution for the last limit function. To accept call AcceptLimit.
Public method | NextSolution(IEnumerableIPSLimitable) | This operation will cycle to the next solution for the last limit function. To accept call AcceptLimit.
Top
See Also

Reference

PSEntityLimiter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityLimiter.NextSolution Method (IPSLimitable)

PSEntityLimiterNextSolution Method (IPSLimitable)

This operation will cycle to the next solution for the last limit function. To accept call AcceptLimit.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void NextSolution(
    IPSLimitable entityToLimit
)
Public Shared Sub NextSolution (
    entityToLimit As IPSLimitable
)

Parameters

entityToLimit
Type: Autodesk.ProductInterface.PowerSHAPEIPSLimitable
The entity to limit.
Remarks
See Also

Reference

PSEntityLimiter Class
NextSolution Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityLimiter.NextSolution Method (IEnumerable(IPSLimitable))

PSEntityLimiterNextSolution Method (IEnumerableIPSLimitable)

This operation will cycle to the next solution for the last limit function. To accept call AcceptLimit.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void NextSolution(
    IEnumerable<IPSLimitable> entitiesToLimit
)
Public Sub NextSolution (
    entitiesToLimit As IEnumerable(Of IPSLimitable)
)

Parameters

entitiesToLimit
Type: System.Collections.GenericIEnumerable IPSLimitable
The entity to limit.
Remarks
See Also

Reference

PSEntityLimiter Class
NextSolution Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMirrorer Class

Helps to mirror entities.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSEntityMirrorer

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSEntityMirrorer
Public Class PSEntityMirrorer

The PSEntityMirrorer type exposes the following members.

Constructors
 | Name | Description
Public method | PSEntityMirrorer | Initialises new instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MirrorEntities | Mirrors entities about the specifed plane.
 | MirrorEntity | Mirrors a single entity about the specifed plane.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMirrorer Constructor

Initialises new instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntityMirrorer(
    PSAutomation powerSHAPE
)
Public Sub New (
    powerSHAPE As PSAutomation
)

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
Remarks
See Also

Reference

PSEntityMirrorer Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMirrorer Methods

The PSEntityMirrorer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MirrorEntities | Mirrors entities about the specifed plane.
 | MirrorEntity | Mirrors a single entity about the specifed plane.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntityMirrorer Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMirrorer.MirrorEntities Method

PSEntityMirrorerMirrorEntities Method

Mirrors entities about the specifed plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void MirrorEntities(
    IEnumerable<IPSMirrorable> entitiesToMirror,
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Shared Sub MirrorEntities (
    entitiesToMirror As IEnumerable(Of IPSMirrorable),
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

entitiesToMirror
Type: System.Collections.GenericIEnumerable IPSMirrorable
The entities that are to be mirrored.
mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the entities.
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane.
See Also

Reference

PSEntityMirrorer Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMirrorer.MirrorEntity Method

PSEntityMirrorerMirrorEntity Method

Mirrors a single entity about the specifed plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void MirrorEntity(
    IPSMirrorable entityToMirror,
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Shared Sub MirrorEntity (
    entityToMirror As IPSMirrorable,
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

entityToMirror
Type: Autodesk.ProductInterface.PowerSHAPEIPSMirrorable
The single entity that is to be mirrored.
mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the entity.
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane.
See Also

Reference

PSEntityMirrorer Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMorpher Class

[Missing <summary> documentation for "T:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher"]

Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSEntityMorpher

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSEntityMorpher
Public Class PSEntityMorpher

The PSEntityMorpher type exposes the following members.

Constructors
 | Name | Description
Public method | PSEntityMorpher | Initialises new instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MorphSurfacesBetweenTwoSurfaces | Morphs surfaces between a control and reference surface. Note that you can morph one surface if it is a PowerSurface but you must morph more than one surface if it is not a PowerSurface. Also, the control and reference surfaces must have the same number of laterals and longitudinals
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMorpher Constructor

Initialises new instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntityMorpher(
    PSAutomation powerSHAPE
)
Public Sub New (
    powerSHAPE As PSAutomation
)

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
Remarks
See Also

Reference

PSEntityMorpher Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMorpher Methods

The PSEntityMorpher type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MorphSurfacesBetweenTwoSurfaces | Morphs surfaces between a control and reference surface. Note that you can morph one surface if it is a PowerSurface but you must morph more than one surface if it is not a PowerSurface. Also, the control and reference surfaces must have the same number of laterals and longitudinals
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntityMorpher Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces Method

PSEntityMorpherMorphSurfacesBetweenTwoSurfaces Method

Morphs surfaces between a control and reference surface. Note that you can morph one surface if it is a PowerSurface but you must morph more than one surface if it is not a PowerSurface. Also, the control and reference surfaces must have the same number of laterals and longitudinals

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void MorphSurfacesBetweenTwoSurfaces(
    List<PSSurface> surfacesToMorph,
    PSSurface referenceSurface,
    PSSurface controlSurface,
    DecayDefinitionOptions decayDefinitionOption,
    DecayDefinitionBlend decayDefinitionBlend = DecayDefinitionBlend.Quartic,
    bool keepReferenceAndControlSurfaces = false,
    bool normalOffsetting = false,
    PSSurface decaySurface = null,
    PSGenericCurve decayCurve = null,
    int decayLimit = 100,
    double decayValue = 0.5
)
Public Shared Sub MorphSurfacesBetweenTwoSurfaces (
    surfacesToMorph As List(Of PSSurface),
    referenceSurface As PSSurface,
    controlSurface As PSSurface,
    decayDefinitionOption As DecayDefinitionOptions,
    Optional decayDefinitionBlend As DecayDefinitionBlend = DecayDefinitionBlend.Quartic,
    Optional keepReferenceAndControlSurfaces As Boolean = false,
    Optional normalOffsetting As Boolean = false,
    Optional decaySurface As PSSurface = Nothing,
    Optional decayCurve As PSGenericCurve = Nothing,
    Optional decayLimit As Integer = 100,
    Optional decayValue As Double = 0.5
)

Parameters

surfacesToMorph
Type: System.Collections.GenericList PSSurface
The surfaces to be morphed
referenceSurface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The reference surface
controlSurface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface

[Missing <param name="controlSurface"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

decayDefinitionOption
Type: Autodesk.ProductInterface.PowerSHAPEDecayDefinitionOptions

[Missing <param name="decayDefinitionOption"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

decayDefinitionBlend (Optional)
Type: Autodesk.ProductInterface.PowerSHAPEDecayDefinitionBlend

[Missing <param name="decayDefinitionBlend"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

keepReferenceAndControlSurfaces (Optional)
Type: SystemBoolean

[Missing <param name="keepReferenceAndControlSurfaces"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

normalOffsetting (Optional)
Type: SystemBoolean

[Missing <param name="normalOffsetting"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

decaySurface (Optional)
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface

[Missing <param name="decaySurface"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

decayCurve (Optional)
Type: Autodesk.ProductInterface.PowerSHAPEPSGenericCurve

[Missing <param name="decayCurve"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

decayLimit (Optional)
Type: SystemInt32

[Missing <param name="decayLimit"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

decayValue (Optional)
Type: SystemDouble

[Missing <param name="decayValue"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSEntityMorpher.MorphSurfacesBetweenTwoSurfaces(System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSSurface},Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionOptions,Autodesk.ProductInterface.PowerSHAPE.DecayDefinitionBlend,System.Boolean,System.Boolean,Autodesk.ProductInterface.PowerSHAPE.PSSurface,Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve,System.Int32,System.Double)"]

See Also

Reference

PSEntityMorpher Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMover Class

Helps to move entities.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSEntityMover

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSEntityMover
Public Class PSEntityMover

The PSEntityMover type exposes the following members.

Constructors
 | Name | Description
Public method | PSEntityMover | Creates a new instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveEntitiesBetweenPoints | Moves a group of entities by the relative distance between two absolute positions..
 | MoveEntitiesByVector | Moves a group of entities by a specified relative amount.
 | MoveEntityBetweenPoints | Moves a single entity by the relative distance between two absolute positions.
 | MoveEntityByVector | .Moves a single entity by a specified relative amount.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMover Constructor

Creates a new instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntityMover(
    PSAutomation powerSHAPE
)
Public Sub New (
    powerSHAPE As PSAutomation
)

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
Remarks
See Also

Reference

PSEntityMover Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMover Methods

The PSEntityMover type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveEntitiesBetweenPoints | Moves a group of entities by the relative distance between two absolute positions..
 | MoveEntitiesByVector | Moves a group of entities by a specified relative amount.
 | MoveEntityBetweenPoints | Moves a single entity by the relative distance between two absolute positions.
 | MoveEntityByVector | .Moves a single entity by a specified relative amount.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntityMover Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMover.MoveEntitiesBetweenPoints Method

PSEntityMoverMoveEntitiesBetweenPoints Method

Moves a group of entities by the relative distance between two absolute positions..

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<PSEntity> MoveEntitiesBetweenPoints(
    IEnumerable<IPSMoveable> entitiesToMove,
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Shared Function MoveEntitiesBetweenPoints (
    entitiesToMove As IEnumerable(Of IPSMoveable),
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

entitiesToMove
Type: System.Collections.GenericIEnumerable IPSMoveable
The group of entities that are to be moved.
moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions.
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions.
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation.

Return Value

Type: List PSEntity
A list containing any created copies of the original entities. If copiesToCreate is 0, the operation returns an empty list.
See Also

Reference

PSEntityMover Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMover.MoveEntitiesByVector Method

PSEntityMoverMoveEntitiesByVector Method

Moves a group of entities by a specified relative amount.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<PSEntity> MoveEntitiesByVector(
    IEnumerable<IPSMoveable> entitiesToMove,
    Vector moveVector,
    int copiesToCreate
)
Public Shared Function MoveEntitiesByVector (
    entitiesToMove As IEnumerable(Of IPSMoveable),
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

entitiesToMove
Type: System.Collections.GenericIEnumerable IPSMoveable
The group of entities that are to be moved.
moveVector
Type: Autodesk.GeometryVector
The relative amount by which each entity will be moved.
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation.

Return Value

Type: List PSEntity
A list containing any created copies of the original entities. If copiesToCreate is 0, the operation returns an empty list.
See Also

Reference

PSEntityMover Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMover.MoveEntityBetweenPoints Method

PSEntityMoverMoveEntityBetweenPoints Method

Moves a single entity by the relative distance between two absolute positions.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<PSEntity> MoveEntityBetweenPoints(
    IPSMoveable entityToMove,
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Shared Function MoveEntityBetweenPoints (
    entityToMove As IPSMoveable,
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

entityToMove
Type: Autodesk.ProductInterface.PowerSHAPEIPSMoveable
The single entity that is to be moved.
moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions.
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions.
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation.

Return Value

Type: List PSEntity
See Also

Reference

PSEntityMover Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityMover.MoveEntityByVector Method

PSEntityMoverMoveEntityByVector Method

.Moves a single entity by a specified relative amount.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<PSEntity> MoveEntityByVector(
    IPSMoveable entityToMove,
    Vector moveVector,
    int copiesToCreate
)
Public Shared Function MoveEntityByVector (
    entityToMove As IPSMoveable,
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

entityToMove
Type: Autodesk.ProductInterface.PowerSHAPEIPSMoveable
The single entity that is to be moved.
moveVector
Type: Autodesk.GeometryVector
The relative amount by which the entity will be moved.
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation.

Return Value

Type: List PSEntity
See Also

Reference

PSEntityMover Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityOffseter Class

Offseter helper for entities.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSEntityOffseter

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSEntityOffseter
Public Class PSEntityOffseter

The PSEntityOffseter type exposes the following members.

Constructors
 | Name | Description
Public method | PSEntityOffseter | Creates a new instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OffsetEntities | Offsets a group of entities by a specified distance.
 | OffsetEntity | Offsets a single entity by a specified distance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityOffseter Constructor

Creates a new instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntityOffseter(
    PSAutomation powerSHAPE
)
Public Sub New (
    powerSHAPE As PSAutomation
)

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
Remarks
See Also

Reference

PSEntityOffseter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityOffseter Methods

The PSEntityOffseter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OffsetEntities | Offsets a group of entities by a specified distance.
 | OffsetEntity | Offsets a single entity by a specified distance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntityOffseter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityOffseter.OffsetEntities Method

PSEntityOffseterOffsetEntities Method

Offsets a group of entities by a specified distance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<PSEntity> OffsetEntities(
    IEnumerable<IPSOffsetable> entitiesToOffset,
    MM offsetDistance,
    int copiesToCreate
)
Public Shared Function OffsetEntities (
    entitiesToOffset As IEnumerable(Of IPSOffsetable),
    offsetDistance As MM,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

entitiesToOffset
Type: System.Collections.GenericIEnumerable IPSOffsetable
The group of entities that are to be offset.
offsetDistance
Type: Autodesk.GeometryMM
The distance the entities are to be offset by.
copiesToCreate
Type: SystemInt32
The number of copies to create of the origina.l entities.

Return Value

Type: List PSEntity
A list of entities created by the operation. If numberOfCopies is 0, an empty list is returned.
See Also

Reference

PSEntityOffseter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityOffseter.OffsetEntity Method

PSEntityOffseterOffsetEntity Method

Offsets a single entity by a specified distance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<PSEntity> OffsetEntity(
    IPSOffsetable entityToOffset,
    MM offsetDistance,
    int copiesToCreate
)
Public Shared Function OffsetEntity (
    entityToOffset As IPSOffsetable,
    offsetDistance As MM,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

entityToOffset
Type: Autodesk.ProductInterface.PowerSHAPEIPSOffsetable
The single entity that is to be offset.
offsetDistance
Type: Autodesk.GeometryMM
The offset value to be applied.
copiesToCreate
Type: SystemInt32
The number of copies to create of the original entity.

Return Value

Type: List PSEntity
A list of entities created by the operation. If numberOfCopies is 0, an empty list is returned.
Remarks
See Also

Reference

PSEntityOffseter Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityRotater Class

Helper to rotate entities.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSEntityRotater

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSEntityRotater
Public Class PSEntityRotater

The PSEntityRotater type exposes the following members.

Constructors
 | Name | Description
Public method | PSEntityRotater | Creates new instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RotateEntities | Rotates a group of entities by a specified angle around a specified axis.
 | RotateEntity | Rotates a single entity by a specified angle around a specified axis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityRotater Constructor

Creates new instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntityRotater(
    PSAutomation powerSHAPE
)
Public Sub New (
    powerSHAPE As PSAutomation
)

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
Remarks
See Also

Reference

PSEntityRotater Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityRotater Methods

The PSEntityRotater type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RotateEntities | Rotates a group of entities by a specified angle around a specified axis.
 | RotateEntity | Rotates a single entity by a specified angle around a specified axis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntityRotater Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityRotater.RotateEntities Method

PSEntityRotaterRotateEntities Method

Rotates a group of entities by a specified angle around a specified axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<PSEntity> RotateEntities(
    IEnumerable<IPSRotateable> entitiesToRotate,
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Shared Function RotateEntities (
    entitiesToRotate As IEnumerable(Of IPSRotateable),
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

entitiesToRotate
Type: System.Collections.GenericIEnumerable IPSRotateable
The group of entities that are to be rotated.
rotationAxis
Type: AutodeskAxes
The axis around which the entities are to be rotated.
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the entities are to be rotated.
copiesToCreate
Type: SystemInt32
The number of copies to create of the original entities.
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis.

Return Value

Type: List PSEntity
A list of entities created by the operation. If numberOfCopies is 0, an .empty list is returned.
See Also

Reference

PSEntityRotater Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityRotater.RotateEntity Method

PSEntityRotaterRotateEntity Method

Rotates a single entity by a specified angle around a specified axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static List<PSEntity> RotateEntity(
    IPSRotateable entityToRotate,
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Shared Function RotateEntity (
    entityToRotate As IPSRotateable,
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

entityToRotate
Type: Autodesk.ProductInterface.PowerSHAPEIPSRotateable
The single entity that is to be rotated.
rotationAxis
Type: AutodeskAxes
The axis around which the entity is are to be rotated.
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the entity is to be rotated.
copiesToCreate
Type: SystemInt32
The number of copies to create of the original entity.
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis.

Return Value

Type: List PSEntity
A list of entities created by the operation. If numberOfCopies is 0, an empty list is returned.
See Also

Reference

PSEntityRotater Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityScaler Class

Helper to scale an entity.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSEntityScaler

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSEntityScaler
Public Class PSEntityScaler

The PSEntityScaler type exposes the following members.

Constructors
 | Name | Description
Public method | PSEntityScaler | Creates a new instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ScaleNonUniform | Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.
 | ScaleProjectedVolume | Resizes surfaces and solids according to their volume as projected on to the active workplane.
 | ScaleUniform | Lets you resize selected objects in a uniform manner, making them larger or smaller equally in all directions. You can also lock the scaling factor in any of the directions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityScaler Constructor

Creates a new instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntityScaler(
    PSAutomation powerSHAPE
)
Public Sub New (
    powerSHAPE As PSAutomation
)

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
Remarks
See Also

Reference

PSEntityScaler Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityScaler Methods

The PSEntityScaler type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ScaleNonUniform | Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.
 | ScaleProjectedVolume | Resizes surfaces and solids according to their volume as projected on to the active workplane.
 | ScaleUniform | Lets you resize selected objects in a uniform manner, making them larger or smaller equally in all directions. You can also lock the scaling factor in any of the directions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSEntityScaler Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityScaler.ScaleNonUniform Method

PSEntityScalerScaleNonUniform Method

Resizes selected objects in a non-uniform manner, allowing you to choose the scaling to be applied for each axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void ScaleNonUniform(
    IPSScalable entityToScale,
    double scaleFactorX,
    double scaleFactorY,
    double scaleFactorZ,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Shared Sub ScaleNonUniform (
    entityToScale As IPSScalable,
    scaleFactorX As Double,
    scaleFactorY As Double,
    scaleFactorZ As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

entityToScale
Type: Autodesk.ProductInterface.PowerSHAPEIPSScalable
The entity to scale.
scaleFactorX
Type: SystemDouble
The x scale factor.
scaleFactorY
Type: SystemDouble
The y scale factor.
scaleFactorZ
Type: SystemDouble
The z scale factor.
lockX
Type: SystemBoolean
Locked in x if true.
lockY
Type: SystemBoolean
Locked in y if true.
lockZ
Type: SystemBoolean
Locked in z if true.
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Objects are scaled relative to the scale origin.
Remarks
See Also

Reference

PSEntityScaler Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityScaler.ScaleProjectedVolume Method

PSEntityScalerScaleProjectedVolume Method

Resizes surfaces and solids according to their volume as projected on to the active workplane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void ScaleProjectedVolume(
    IPSScalable entityToScale,
    double newVolume,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Shared Sub ScaleProjectedVolume (
    entityToScale As IPSScalable,
    newVolume As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

entityToScale
Type: Autodesk.ProductInterface.PowerSHAPEIPSScalable
The entity to scale.
newVolume
Type: SystemDouble
The new projected volume.
lockX
Type: SystemBoolean
Locked in x if true.
lockY
Type: SystemBoolean
Locked in y if true.
lockZ
Type: SystemBoolean
Locked in z if true.
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Objects are scaled relative to the scale origin.
Remarks
See Also

Reference

PSEntityScaler Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSEntityScaler.ScaleUniform Method

PSEntityScalerScaleUniform Method

Lets you resize selected objects in a uniform manner, making them larger or smaller equally in all directions. You can also lock the scaling factor in any of the directions.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static void ScaleUniform(
    IPSScalable entityToScale,
    double scaleFactor,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Shared Sub ScaleUniform (
    entityToScale As IPSScalable,
    scaleFactor As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

entityToScale
Type: Autodesk.ProductInterface.PowerSHAPEIPSScalable
The entity to scale.
scaleFactor
Type: SystemDouble
The scale value.
lockX
Type: SystemBoolean
Locked in x if true.
lockY
Type: SystemBoolean
Locked in y if true.
lockZ
Type: SystemBoolean
Locked in z if true.
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Objects are scaled relative to the scale origin.
Remarks
See Also

Reference

PSEntityScaler Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve Class

Base class for curves in PowerSHAPE.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSGenericCurve
Autodesk.ProductInterface.PowerSHAPEPSCompCurve
Autodesk.ProductInterface.PowerSHAPEPSCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSGenericCurve : PSWireframe,
    IPSMoveable, IPSRotateable, IPSMirrorable, IPSLimitable
Public MustInherit Class PSGenericCurve
    Inherits PSWireframe
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSLimitable

The PSGenericCurve type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the curve. If it's closed, the area is the enclosed space. If it's open, the area is the enclosed space were it to be closed with a straight line. If the wireframe is not on a plane, the area is calculated supposing that it has been projected onto the principal plane.
Public property | BoundingBox | Gets the bounding box of the GenericCurve in PowerSHAPE. (Overrides PSEntityBoundingBox.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe (Inherited from PSWireframe.)
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosed | Gets and sets whether the curve is closed or not.
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Gets the number of points in the wireframe (Inherited from PSWireframe.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe (Inherited from PSWireframe.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the item from PowerSHAPE and removes it from the correct collection if it is a member of one (Inherited from PSEntity.)
Public method | DeleteCurvePoints | Deletes the specified points.
Public method | DeleteDependencies | Deletes any dependencies. Useful when trying to duplicate a curve which is dependent on a mesh. It must be added to the selection for this to work!
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditCurvePointTangency | Edits the entry and exit tangencies at a defined point.
Public method | EditCurvePointTangencyMagnitude | Edits the entry and exit tangency magnitudes at a defined point.
Public method | EditPositionOfPointAbsolute | Moves a curve point to a new point position.
Public method | EditPositionOfPointRelative | Moves a selected Point on a curve by a direction vector.
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one end of the curve.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FreeMagnitudesAndDirections | Frees the magnitudes and directions of the entire wireframe.
Public method | FreeMagnitudesDirections | Frees the magnitudes and directions of the selected points on the wireframe.
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point.
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point.
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point.
Public method | GetEntryTangentOfPoint | Entry tangent of the desired point.
Public method | GetExitAzimuthAngleOfPoint | Gets the azimuth angle of the exit tangent of the desired point.
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point.
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point.
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point.
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPointAtPositionBetweenPoints | Inserts a new point.
Public method | InsertPointByProximity | Inserts a new point by proximal point.
Public method | InsertPointRelativeToPointOnCurve | Inserts a new relative point.
Public method | InsertPointsAtPlaneIntersections | Inserts a new point at an offset from the plane intersection.
Public method | LimitToEntities | Limits a curve by a specified list of entities.
Public method | LimitToEntity | Limits a curve by a specified list of entities.
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeAndSpline | Merges and splines the curve.
Public method | Mirror | Mirrors a single curve in a specified plane.
Public method | MoveBetweenPoints | Moves a single curve by the relative distance between two absolute positions.
Public method | MoveByVector | Moves a single curve by a specified relative amount.
Public method | ProjectOntoPlane | Projects the curve onto the specified plane at the specified position on the plane.
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | RenumberCurvePoints | Renumbers the points from the specified start point.
Public method | RepointCurveBetweenPoints | Repoints the curve between the specified points creating the specified number of points.
Public method | Reverse | Reverses the curve.
Public method | Rotate | Rotates a single curve by a specified .angle around a specified axis.
Public method | Scale | Scales a curve within PowerSHAPE.
Public method | SelectCurvePoints | Selects the specified points.
Public method | ToPolyline | Creates a single polyline from a generic curve.
Public method | ToSpline | Creates a single spline from a generic curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve Properties

The PSGenericCurve type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the curve. If it's closed, the area is the enclosed space. If it's open, the area is the enclosed space were it to be closed with a straight line. If the wireframe is not on a plane, the area is calculated supposing that it has been projected onto the principal plane.
Public property | BoundingBox | Gets the bounding box of the GenericCurve in PowerSHAPE. (Overrides PSEntityBoundingBox.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe (Inherited from PSWireframe.)
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosed | Gets and sets whether the curve is closed or not.
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Gets the number of points in the wireframe (Inherited from PSWireframe.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe (Inherited from PSWireframe.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.Area Property

PSGenericCurveArea Property

Gets the area of the curve. If it's closed, the area is the enclosed space. If it's open, the area is the enclosed space were it to be closed with a straight line. If the wireframe is not on a plane, the area is calculated supposing that it has been projected onto the principal plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get

Property Value

Type: Double
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.BoundingBox Property

PSGenericCurveBoundingBox Property

Gets the bounding box of the GenericCurve in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Return Value

Type: BoundingBox
A BoundingBox object representing the bounding box in PowerSHAPE.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.IsClosed Property

PSGenericCurveIsClosed Property

Gets and sets whether the curve is closed or not.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsClosed { get; set; }
Public Property IsClosed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve Methods

The PSGenericCurve type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the item from PowerSHAPE and removes it from the correct collection if it is a member of one (Inherited from PSEntity.)
Public method | DeleteCurvePoints | Deletes the specified points.
Public method | DeleteDependencies | Deletes any dependencies. Useful when trying to duplicate a curve which is dependent on a mesh. It must be added to the selection for this to work!
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditCurvePointTangency | Edits the entry and exit tangencies at a defined point.
Public method | EditCurvePointTangencyMagnitude | Edits the entry and exit tangency magnitudes at a defined point.
Public method | EditPositionOfPointAbsolute | Moves a curve point to a new point position.
Public method | EditPositionOfPointRelative | Moves a selected Point on a curve by a direction vector.
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one end of the curve.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FreeMagnitudesAndDirections | Frees the magnitudes and directions of the entire wireframe.
Public method | FreeMagnitudesDirections | Frees the magnitudes and directions of the selected points on the wireframe.
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point.
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point.
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point.
Public method | GetEntryTangentOfPoint | Entry tangent of the desired point.
Public method | GetExitAzimuthAngleOfPoint | Gets the azimuth angle of the exit tangent of the desired point.
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point.
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point.
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point.
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPointAtPositionBetweenPoints | Inserts a new point.
Public method | InsertPointByProximity | Inserts a new point by proximal point.
Public method | InsertPointRelativeToPointOnCurve | Inserts a new relative point.
Public method | InsertPointsAtPlaneIntersections | Inserts a new point at an offset from the plane intersection.
Public method | LimitToEntities | Limits a curve by a specified list of entities.
Public method | LimitToEntity | Limits a curve by a specified list of entities.
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeAndSpline | Merges and splines the curve.
Public method | Mirror | Mirrors a single curve in a specified plane.
Public method | MoveBetweenPoints | Moves a single curve by the relative distance between two absolute positions.
Public method | MoveByVector | Moves a single curve by a specified relative amount.
Public method | ProjectOntoPlane | Projects the curve onto the specified plane at the specified position on the plane.
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | RenumberCurvePoints | Renumbers the points from the specified start point.
Public method | RepointCurveBetweenPoints | Repoints the curve between the specified points creating the specified number of points.
Public method | Reverse | Reverses the curve.
Public method | Rotate | Rotates a single curve by a specified .angle around a specified axis.
Public method | Scale | Scales a curve within PowerSHAPE.
Public method | SelectCurvePoints | Selects the specified points.
Public method | ToPolyline | Creates a single polyline from a generic curve.
Public method | ToSpline | Creates a single spline from a generic curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.DeleteCurvePoints Method

PSGenericCurveDeleteCurvePoints Method

Deletes the specified points.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeleteCurvePoints(
    int[] pointsIndeces
)
Public Sub DeleteCurvePoints (
    pointsIndeces As Integer()
)

Parameters

pointsIndeces
Type: SystemInt32
The point indexes in PowerShape. Index for the points is zero based.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.DeleteDependencies Method

PSGenericCurveDeleteDependencies Method

Deletes any dependencies. Useful when trying to duplicate a curve which is dependent on a mesh. It must be added to the selection for this to work!

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual void DeleteDependencies()
Public Overridable Sub DeleteDependencies
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.EditCurvePointTangency Method

PSGenericCurveEditCurvePointTangency Method

Edits the entry and exit tangencies at a defined point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EditCurvePointTangency(
    int pointNumber,
    Vector entryTangent,
    Vector exitTangent
)
Public Sub EditCurvePointTangency (
    pointNumber As Integer,
    entryTangent As Vector,
    exitTangent As Vector
)

Parameters

pointNumber
Type: SystemInt32
Point at which to carry out the operation. Index starts from zero.
entryTangent
Type: Autodesk.GeometryVector
Desired entry tangent. If this is not to be changed, pass in the current entry tangent.
exitTangent
Type: Autodesk.GeometryVector
Desired exit tangent. If this is not to be changed, pass in the current exit tangent.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.EditCurvePointTangencyMagnitude Method

PSGenericCurveEditCurvePointTangencyMagnitude Method

Edits the entry and exit tangency magnitudes at a defined point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EditCurvePointTangencyMagnitude(
    int pointNumber,
    double entryMagnitude,
    double exitMagnitude
)
Public Sub EditCurvePointTangencyMagnitude (
    pointNumber As Integer,
    entryMagnitude As Double,
    exitMagnitude As Double
)

Parameters

pointNumber
Type: SystemInt32
Point at which to carry out the operation. Index starts from zero.
entryMagnitude
Type: SystemDouble
Desired entry tangent. If this is not to be changed, pass in the current entry tangent.
exitMagnitude
Type: SystemDouble
Desired exit tangent. If this is not to be changed, pass in the current exit tangent.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.EditPositionOfPointAbsolute Method

PSGenericCurveEditPositionOfPointAbsolute Method

Moves a curve point to a new point position.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EditPositionOfPointAbsolute(
    int pointNumber,
    Point newPoint
)
Public Sub EditPositionOfPointAbsolute (
    pointNumber As Integer,
    newPoint As Point
)

Parameters

pointNumber
Type: SystemInt32
The index of the point to move. Index starts from zero.
newPoint
Type: Autodesk.GeometryPoint
The new position.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.EditPositionOfPointRelative Method

PSGenericCurveEditPositionOfPointRelative Method

Moves a selected Point on a curve by a direction vector.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EditPositionOfPointRelative(
    int pointNumber,
    Vector direction
)
Public Sub EditPositionOfPointRelative (
    pointNumber As Integer,
    direction As Vector
)

Parameters

pointNumber
Type: SystemInt32
Starts from zero.
direction
Type: Autodesk.GeometryVector
Vector.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.Extend Method

PSGenericCurveExtend Method

Extends one end of the curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Extend(
    ExtensionEnd curveEnd,
    float length,
    ExtensionType straightCurved
)
Public Sub Extend (
    curveEnd As ExtensionEnd,
    length As Single,
    straightCurved As ExtensionType
)

Parameters

curveEnd
Type: Autodesk.ProductInterface.PowerSHAPEExtensionEnd
The curve end to be extended.
length
Type: SystemSingle
The length to extend by.
straightCurved
Type: Autodesk.ProductInterface.PowerSHAPEExtensionType
The extension type.
Remarks
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.FreeMagnitudesAndDirections Method

PSGenericCurveFreeMagnitudesAndDirections Method

Frees the magnitudes and directions of the entire wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FreeMagnitudesAndDirections()
Public Sub FreeMagnitudesAndDirections
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.FreeMagnitudesDirections Method

PSGenericCurveFreeMagnitudesDirections Method

Frees the magnitudes and directions of the selected points on the wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FreeMagnitudesDirections(
    int[] wireframePoints
)
Public Sub FreeMagnitudesDirections (
    wireframePoints As Integer()
)

Parameters

wireframePoints
Type: SystemInt32
The points to edit the tangents and magnitudes. Index for the points is zero based.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetEntryAzimuthAngleOfPoint Method

PSGenericCurveGetEntryAzimuthAngleOfPoint Method

Gets the azimuth angle of the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetEntryAzimuthAngleOfPoint(
    int pointNumber
)
Public Function GetEntryAzimuthAngleOfPoint (
    pointNumber As Integer
) As Double

Parameters

pointNumber
Type: SystemInt32
Point at which the entry tangency azimuth angle is required. Index starts from zero.

Return Value

Type: Double
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetEntryElevationAngleOfPoint Method

PSGenericCurveGetEntryElevationAngleOfPoint Method

Gets the elevation angle of the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetEntryElevationAngleOfPoint(
    int pointNumber
)
Public Function GetEntryElevationAngleOfPoint (
    pointNumber As Integer
) As Double

Parameters

pointNumber
Type: SystemInt32
Point at which the exit tangency elevation angle is required. Index starts from zero.

Return Value

Type: Double
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetEntryMagnitudeOfPoint Method

PSGenericCurveGetEntryMagnitudeOfPoint Method

Gets the magnitude of the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetEntryMagnitudeOfPoint(
    int pointNumber
)
Public Function GetEntryMagnitudeOfPoint (
    pointNumber As Integer
) As Double

Parameters

pointNumber
Type: SystemInt32
Point at which entry tangency magnitude is require. Index starts from zero.

Return Value

Type: Double
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetEntryTangentOfPoint Method

PSGenericCurveGetEntryTangentOfPoint Method

Entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetEntryTangentOfPoint(
    int pointNumber
)
Public Function GetEntryTangentOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
Point at which entry tangency is required. Index starts from zero.

Return Value

Type: Vector
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetExitAzimuthAngleOfPoint Method

PSGenericCurveGetExitAzimuthAngleOfPoint Method

Gets the azimuth angle of the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetExitAzimuthAngleOfPoint(
    int pointNumber
)
Public Function GetExitAzimuthAngleOfPoint (
    pointNumber As Integer
) As Double

Parameters

pointNumber
Type: SystemInt32
Point at which the exit tangency azimuth angle is required. Index starts from zero.

Return Value

Type: Double
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetExitElevationAngleOfPoint Method

PSGenericCurveGetExitElevationAngleOfPoint Method

Gets the elevation angle of the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetExitElevationAngleOfPoint(
    int pointNumber
)
Public Function GetExitElevationAngleOfPoint (
    pointNumber As Integer
) As Double

Parameters

pointNumber
Type: SystemInt32
Point at which the exit tangency elevation angle is required. Index starts from zero.

Return Value

Type: Double
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetExitMagnitudeOfPoint Method

PSGenericCurveGetExitMagnitudeOfPoint Method

Gets the magnitude of the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetExitMagnitudeOfPoint(
    int pointNumber
)
Public Function GetExitMagnitudeOfPoint (
    pointNumber As Integer
) As Double

Parameters

pointNumber
Type: SystemInt32
Point at which exit tangency magnitude is required. Index starts from zero.

Return Value

Type: Double
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetExitTangentOfPoint Method

PSGenericCurveGetExitTangentOfPoint Method

Gets the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetExitTangentOfPoint(
    int pointNumber
)
Public Function GetExitTangentOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
Point at which exit tangency is required. Index starts from zero.

Return Value

Type: Vector
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.GetLengthBetweenTwoPoints Method

PSGenericCurveGetLengthBetweenTwoPoints Method

Gets the length of curve between two key points.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM GetLengthBetweenTwoPoints(
    double pointA,
    double pointB
)
Public Function GetLengthBetweenTwoPoints (
    pointA As Double,
    pointB As Double
) As MM

Parameters

pointA
Type: SystemDouble
A single representing the chosen start keypoint on the curve. Index starts from zero.
pointB
Type: SystemDouble
A single representing the chosen end keypoint on the curve. Index starts from zero.

Return Value

Type: MM
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.InsertPointAtPositionBetweenPoints Method

PSGenericCurveInsertPointAtPositionBetweenPoints Method

Inserts a new point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InsertPointAtPositionBetweenPoints(
    double position
)
Public Sub InsertPointAtPositionBetweenPoints (
    position As Double
)

Parameters

position
Type: SystemDouble
Position for new point. Index starts at zero.
Exceptions
Exception | Condition
Exception | Position out of range, or failed to insert point.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.InsertPointByProximity Method

PSGenericCurveInsertPointByProximity Method

Inserts a new point by proximal point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InsertPointByProximity(
    Point proximalPoint
)
Public Sub InsertPointByProximity (
    proximalPoint As Point
)

Parameters

proximalPoint
Type: Autodesk.GeometryPoint
Proximal position for point.
Exceptions
Exception | Condition
Exception | Failed to insert point.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.InsertPointRelativeToPointOnCurve Method

PSGenericCurveInsertPointRelativeToPointOnCurve Method

Inserts a new relative point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InsertPointRelativeToPointOnCurve(
    int referencePointIndex,
    double distance
)
Public Sub InsertPointRelativeToPointOnCurve (
    referencePointIndex As Integer,
    distance As Double
)

Parameters

referencePointIndex
Type: SystemInt32
Reference point. Index starting from zero
distance
Type: SystemDouble
Distance from reference point.
Exceptions
Exception | Condition
Exception | Failed to insert point.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.InsertPointsAtPlaneIntersections Method

PSGenericCurveInsertPointsAtPlaneIntersections Method

Inserts a new point at an offset from the plane intersection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void InsertPointsAtPlaneIntersections(
    Planes plane,
    double offset
)
Public Sub InsertPointsAtPlaneIntersections (
    plane As Planes,
    offset As Double
)

Parameters

plane
Type: AutodeskPlanes
Plane intersecting curve.
offset
Type: SystemDouble
Value to offset.
Exceptions
Exception | Condition
Exception | Failed to insert points.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.LimitToEntities Method

PSGenericCurveLimitToEntities Method

Limits a curve by a specified list of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntities(
    List<PSEntity> limitingEntities,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntities (
    limitingEntities As List(Of PSEntity),
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntities
Type: System.Collections.GenericList PSEntity
The entities with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity

Implements

IPSLimitableLimitToEntities(ListPSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.LimitToEntity Method

PSGenericCurveLimitToEntity Method

Limits a curve by a specified list of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntity(
    PSEntity limitingEntity,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntity (
    limitingEntity As PSEntity,
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity

Implements

IPSLimitableLimitToEntity(PSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.LimitUsingDynamicCutter Method

PSGenericCurveLimitUsingDynamicCutter Method

Limits using the dynamic cutter option.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity LimitUsingDynamicCutter(
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne
)
Public Function LimitUsingDynamicCutter (
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne
) As PSEntity

Parameters

keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
The limiting keep option to apply.

Return Value

Type: PSEntity
Limited entity.

Implements

IPSLimitableLimitUsingDynamicCutter(LimitingKeepOptions)
Remarks
To be used with PSEntityLimiter.NextSolution.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.MergeAndSpline Method

PSGenericCurveMergeAndSpline Method

Merges and splines the curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MergeAndSpline()
Public Sub MergeAndSpline
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.Mirror Method

PSGenericCurveMirror Method

Mirrors a single curve in a specified plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the curve.
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane.

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.MoveBetweenPoints Method

PSGenericCurveMoveBetweenPoints Method

Moves a single curve by the relative distance between two absolute positions.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions.
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions.
copiesToCreate
Type: SystemInt32
The number of co.pies that should be created by the operation.

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.MoveByVector Method

PSGenericCurveMoveByVector Method

Moves a single curve by a specified relative amount.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
The relative amount by which the curve will be moved.
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation.

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.ProjectOntoPlane Method

PSGenericCurveProjectOntoPlane Method

Projects the curve onto the specified plane at the specified position on the plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ProjectOntoPlane(
    Planes plane,
    MM positionOnPlane
)
Public Sub ProjectOntoPlane (
    plane As Planes,
    positionOnPlane As MM
)

Parameters

plane
Type: AutodeskPlanes
The plane onto which to project the curve.
positionOnPlane
Type: Autodesk.GeometryMM
The position on the plane at which to project the curve.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.RenumberCurvePoints Method

PSGenericCurveRenumberCurvePoints Method

Renumbers the points from the specified start point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RenumberCurvePoints(
    int intStartPoint
)
Public Sub RenumberCurvePoints (
    intStartPoint As Integer
)

Parameters

intStartPoint
Type: SystemInt32
The new start point for the curve. Index for the points is zero based.
Exceptions
Exception | Condition
Exception | Only closed curves can be renumbered.
Remarks
Curves may be renumbered. One reason for this may be to open a surface at a different location.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.RepointCurveBetweenPoints Method

PSGenericCurveRepointCurveBetweenPoints Method

Repoints the curve between the specified points creating the specified number of points.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RepointCurveBetweenPoints(
    int startPoint,
    int endPoint,
    int numberOfPoints,
    CornerBehaviours cornerBehaviour = CornerBehaviours.SelectCorners
)
Public Sub RepointCurveBetweenPoints (
    startPoint As Integer,
    endPoint As Integer,
    numberOfPoints As Integer,
    Optional cornerBehaviour As CornerBehaviours = CornerBehaviours.SelectCorners
)

Parameters

startPoint
Type: SystemInt32
The index of the start point. Index for the points is zero based.
endPoint
Type: SystemInt32
The index of the end point. Index for the points is zero based.
numberOfPoints
Type: SystemInt32
The number of new points that are added to the curve and evenly distributed between the start and end points.
cornerBehaviour (Optional)
Type: Autodesk.ProductInterface.PowerSHAPECornerBehaviours
You can select points which you don't want to remove. These points are marked as corners.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.Reverse Method

PSGenericCurveReverse Method

Reverses the curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Reverse()
Public Sub Reverse
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.Rotate Method

PSGenericCurveRotate Method

Rotates a single curve by a specified .angle around a specified axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the curve is are to be rotated.
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the curve is to be rotated.
copiesToCreate
Type: SystemInt32
The number of copies to create of the original curve.
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis.

Return Value

Type: List PSEntity
A list of curves created by the operation. If numberOfCopies is 0, an empty list is returned.

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.Scale Method

PSGenericCurveScale Method

Scales a curve within PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Scale(
    double offsetX,
    double offsetY,
    double offsetZ,
    Point scaleOrigin = null
)
Public Sub Scale (
    offsetX As Double,
    offsetY As Double,
    offsetZ As Double,
    Optional scaleOrigin As Point = Nothing
)

Parameters

offsetX
Type: SystemDouble
Scale value in X.
offsetY
Type: SystemDouble
Scale value in Y.
offsetZ
Type: SystemDouble
Scale value in Z.
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Scale origin, workplane origin if none specified.
Exceptions
Exception | Condition
ApplicationException | Scaling operation not completed correctly.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.SelectCurvePoints Method

PSGenericCurveSelectCurvePoints Method

Selects the specified points.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SelectCurvePoints(
    int[] pointsIndeces
)
Public Sub SelectCurvePoints (
    pointsIndeces As Integer()
)

Parameters

pointsIndeces
Type: SystemInt32
The point indexes in PowerShape. Index for the points is zero based.
Exceptions
Exception | Condition
Exception | Point is not defined.
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.ToPolyline Method

PSGenericCurveToPolyline Method

Creates a single polyline from a generic curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Polyline ToPolyline()
Public Function ToPolyline As Polyline

Return Value

Type: Polyline
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve.ToSpline Method

PSGenericCurveToSpline Method

Creates a single spline from a generic curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Spline ToSpline()
Public Function ToSpline As Spline

Return Value

Type: Spline
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurve Fields

The PSGenericCurve type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSGenericCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurvesCollection(T) Class

PSGenericCurvesCollectionT Class

Base class for curve collections
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection T
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection T
Autodesk.ProductInterface.PowerSHAPEPSGenericCurvesCollectionT
Autodesk.ProductInterface.PowerSHAPEPSCompCurvesCollection
Autodesk.ProductInterface.PowerSHAPEPSCurvesCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSGenericCurvesCollection<T> : PSEntitiesCollection<T>
where T : PSGenericCurve

Public MustInherit Class PSGenericCurvesCollection(Of T As PSGenericCurve)
    Inherits PSEntitiesCollection(Of T)

Type Parameters

T

The PSGenericCurvesCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateCurveFromBreakPoint | Breaks a curve at the specified point. The first section of the curve is retained, while the second section becomes a new curve.
Public method | CreateCurvesFromWrap | Creates new curves and compcurves by projecting wireframe onto a surface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurvesCollection(T) Properties

PSGenericCurvesCollectionT Properties

The PSGenericCurvesCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSGenericCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurvesCollection(T) Methods

PSGenericCurvesCollectionT Methods

The PSGenericCurvesCollectionT generic type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateCurveFromBreakPoint | Breaks a curve at the specified point. The first section of the curve is retained, while the second section becomes a new curve.
Public method | CreateCurvesFromWrap | Creates new curves and compcurves by projecting wireframe onto a surface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSGenericCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurvesCollection(T).CreateCurveFromBreakPoint Method

PSGenericCurvesCollectionTCreateCurveFromBreakPoint Method

Breaks a curve at the specified point. The first section of the curve is retained, while the second section becomes a new curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public T CreateCurveFromBreakPoint(
    T initialCurve,
    int breakPoint
)
Public Function CreateCurveFromBreakPoint (
    initialCurve As T,
    breakPoint As Integer
) As T

Parameters

initialCurve
Type: T
The curve to be split.
breakPoint
Type: SystemInt32
The point at which to break the initial curve. Index starts from zero.

Return Value

Type: T
A new curve that is the second portion of the initial.
Remarks
See Also

Reference

PSGenericCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurvesCollection(T).CreateCurvesFromWrap Method

PSGenericCurvesCollectionTCreateCurvesFromWrap Method

Creates new curves and compcurves by projecting wireframe onto a surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSGenericCurve> CreateCurvesFromWrap(
    PSSurface surfaceToWrapTo,
    IEnumerable<PSGenericCurve> wireframeToWrap,
    Degree rotation
)
Public Function CreateCurvesFromWrap (
    surfaceToWrapTo As PSSurface,
    wireframeToWrap As IEnumerable(Of PSGenericCurve),
    rotation As Degree
) As List(Of PSGenericCurve)

Parameters

surfaceToWrapTo
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface that will have wireframe wrapped onto it
wireframeToWrap
Type: System.Collections.GenericIEnumerable PSGenericCurve
The curves and compcurves that will be wrapped
rotation
Type: Autodesk.GeometryDegree
The desired rotation or the wireframe before wrapping

Return Value

Type: List PSGenericCurve
A list of the created curves and compcurves
See Also

Reference

PSGenericCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSGenericCurvesCollection(T) Fields

PSGenericCurvesCollectionT Fields

The PSGenericCurvesCollectionT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSGenericCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateral Class

Captures a Surface Lateral object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
Autodesk.ProductInterface.PowerSHAPEPSLateral

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSLateral : PSSurfaceCurve
Public Class PSLateral
    Inherits PSSurfaceCurve

The PSLateral type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type (Inherited from PSSurfaceCurve.)
Public property | CentreOfGravity | Gets the centre of gravity of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | EndPoint | Gets the end point of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Exists | Overrides Exists() from DatabaseEntity as a surface curve must be analysed using its name. If the surface curve has been deleted, its name will now be 0 and always return False (Inherited from PSSurfaceCurve.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Level | Gets/Sets the level of the surface curve by getting/setting the level of its parent surface. (Inherited from PSSurfaceCurve.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets/Sets the name of the lateral or longitudinal. (Inherited from PSSurfaceCurve.)
Public property | NumberPoints | Gets the number of points on the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | ParentSurface | Gets the parent surface of the surface curve. (Inherited from PSSurfaceCurve.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the surface curve. (Inherited from PSSurfaceCurve.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Transparency | Always returns 0, as a surface curve can only ever be opaque. (Inherited from PSSurfaceCurve.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Calls the parent surface's AddSurfaceCurveToSelection operation. (Inherited from PSSurfaceCurve.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | CreateCompositeCurve | Returns a composite curve of the surface curve. (Inherited from PSSurfaceCurve.)
Public method | Delete | Deletes the Surface Lateral from PowerSHAPE (Overrides PSSurfaceCurveDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditAfterTangencyOfPoint | Edits the after tangent at the selected point. (Inherited from PSSurfaceCurve.)
Public method | EditBeforeTangencyOfPoint | Edits the before tangent at the selected point. (Inherited from PSSurfaceCurve.)
Public method | EditTangencyOfPoint | Edits the entry and exit tangencies at a defined point. (Inherited from PSSurfaceCurve.)
Public method | Equals | Overrides Equals() from DatabaseEntity as the surface curve's name/ID can be changed since the surface curve was initialised. Therefore its unique internal ID is used for comparison. (Inherited from PSSurfaceCurve.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryFlareAngleOfPoint | Gets the flare angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryNormalOfPoint | Gets the entry normal of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryTangentOfPoint | Gets the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryTwistAngleOfPoint | Gets the twist angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitAzimuthAngleOfPOint | Gets the azimuth angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitFlareAngleOfPoint | Gets the flare angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitNormalOfPoint | Gets the exit normal of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitTwistAngleOfPoint | Gets the twist angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points. (Inherited from PSSurfaceCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move(Vector) | Moves a single surfacecurve by a specified relative amount. (Inherited from PSSurfaceCurve.)
Public method | Move(Point, Point) | Moves a single surfacecurve by the relative distance between two absolute positions. (Inherited from PSSurfaceCurve.)
Public method | MoveSurfacePointsAlongVector | Moves the indicated surface points by a vector. (Inherited from PSSurfaceCurve.)
Public method | Offset | Offsets the surface curve by the specified amount. (Inherited from PSSurfaceCurve.)
Public method | OffsetPointsOnCurve | Offsets the indicated points on the surface curve. (Inherited from PSSurfaceCurve.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | Rotates a single surface curve by a specified angle around a specified axis. (Inherited from PSSurfaceCurve.)
Public method | SelectCurvePoints | Selects the indicated points on the surface curve. (Inherited from PSSurfaceCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _internalId | The internal ID of the Surface Curve. (Inherited from PSSurfaceCurve.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _surface | The parent surface of the Surface Curve. (Inherited from PSSurfaceCurve.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateral Properties

The PSLateral type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type (Inherited from PSSurfaceCurve.)
Public property | CentreOfGravity | Gets the centre of gravity of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | EndPoint | Gets the end point of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Exists | Overrides Exists() from DatabaseEntity as a surface curve must be analysed using its name. If the surface curve has been deleted, its name will now be 0 and always return False (Inherited from PSSurfaceCurve.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Level | Gets/Sets the level of the surface curve by getting/setting the level of its parent surface. (Inherited from PSSurfaceCurve.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets/Sets the name of the lateral or longitudinal. (Inherited from PSSurfaceCurve.)
Public property | NumberPoints | Gets the number of points on the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | ParentSurface | Gets the parent surface of the surface curve. (Inherited from PSSurfaceCurve.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the surface curve. (Inherited from PSSurfaceCurve.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Transparency | Always returns 0, as a surface curve can only ever be opaque. (Inherited from PSSurfaceCurve.)
Top
See Also

Reference

PSLateral Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateral Methods

The PSLateral type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Calls the parent surface's AddSurfaceCurveToSelection operation. (Inherited from PSSurfaceCurve.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | CreateCompositeCurve | Returns a composite curve of the surface curve. (Inherited from PSSurfaceCurve.)
Public method | Delete | Deletes the Surface Lateral from PowerSHAPE (Overrides PSSurfaceCurveDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditAfterTangencyOfPoint | Edits the after tangent at the selected point. (Inherited from PSSurfaceCurve.)
Public method | EditBeforeTangencyOfPoint | Edits the before tangent at the selected point. (Inherited from PSSurfaceCurve.)
Public method | EditTangencyOfPoint | Edits the entry and exit tangencies at a defined point. (Inherited from PSSurfaceCurve.)
Public method | Equals | Overrides Equals() from DatabaseEntity as the surface curve's name/ID can be changed since the surface curve was initialised. Therefore its unique internal ID is used for comparison. (Inherited from PSSurfaceCurve.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryFlareAngleOfPoint | Gets the flare angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryNormalOfPoint | Gets the entry normal of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryTangentOfPoint | Gets the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryTwistAngleOfPoint | Gets the twist angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitAzimuthAngleOfPOint | Gets the azimuth angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitFlareAngleOfPoint | Gets the flare angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitNormalOfPoint | Gets the exit normal of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitTwistAngleOfPoint | Gets the twist angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points. (Inherited from PSSurfaceCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move(Vector) | Moves a single surfacecurve by a specified relative amount. (Inherited from PSSurfaceCurve.)
Public method | Move(Point, Point) | Moves a single surfacecurve by the relative distance between two absolute positions. (Inherited from PSSurfaceCurve.)
Public method | MoveSurfacePointsAlongVector | Moves the indicated surface points by a vector. (Inherited from PSSurfaceCurve.)
Public method | Offset | Offsets the surface curve by the specified amount. (Inherited from PSSurfaceCurve.)
Public method | OffsetPointsOnCurve | Offsets the indicated points on the surface curve. (Inherited from PSSurfaceCurve.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | Rotates a single surface curve by a specified angle around a specified axis. (Inherited from PSSurfaceCurve.)
Public method | SelectCurvePoints | Selects the indicated points on the surface curve. (Inherited from PSSurfaceCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSLateral Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateral.Delete Method

PSLateralDelete Method

Deletes the Surface Lateral from PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSLateral Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateral Fields

The PSLateral type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _internalId | The internal ID of the Surface Curve. (Inherited from PSSurfaceCurve.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _surface | The parent surface of the Surface Curve. (Inherited from PSSurfaceCurve.)
Top
See Also

Reference

PSLateral Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateralsCollection Class

Captures a collection of laterals in a project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSLateral
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSLateral
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurvesCollection PSLateral
Autodesk.ProductInterface.PowerSHAPEPSLateralsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSLateralsCollection : PSSurfaceCurvesCollection<PSLateral>
Public Class PSLateralsCollection
    Inherits PSSurfaceCurvesCollection(Of PSLateral)

The PSLateralsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes surface curve from PowerShape and from surface curves collection. (Inherited from PSSurfaceCurvesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _parentSurface | The parent surface of a PSSurface. (Inherited from PSSurfaceCurvesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateralsCollection Properties

The PSLateralsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSLateralsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateralsCollection Methods

The PSLateralsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes surface curve from PowerShape and from surface curves collection. (Inherited from PSSurfaceCurvesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSLateralsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLateralsCollection Fields

The PSLateralsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _parentSurface | The parent surface of a PSSurface. (Inherited from PSSurfaceCurvesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSLateralsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel Class

Captures a Level in PowerSHAPE.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSLevel

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSLevel
Public Class PSLevel

The PSLevel type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Gets and sets whether a level is active or not.
Public property | IsUsed | Gets whether the level is currently in use or not.
Public property | Name | Gets and sets the name of the level. The format of the string should be of the format: [Group : ]Name.
Public property | Number | Gets the number of the level.
Top
Methods
 | Name | Description
Public method | AddContentsToSelection | Adds all entities on this level to the selection.
Public method | Clear | Deletes all entities on this level.
Public method | Equals | Overrides the equals function to compare Levels. Compares levels by number.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _number | The number of the level.
Protected field | _powerSHAPE | The PowerSHAPE Automation object.
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel Properties

The PSLevel type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Gets and sets whether a level is active or not.
Public property | IsUsed | Gets whether the level is currently in use or not.
Public property | Name | Gets and sets the name of the level. The format of the string should be of the format: [Group : ]Name.
Public property | Number | Gets the number of the level.
Top
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel.IsActive Property

PSLevelIsActive Property

Gets and sets whether a level is active or not.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel.IsUsed Property

PSLevelIsUsed Property

Gets whether the level is currently in use or not.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsUsed { get; }
Public ReadOnly Property IsUsed As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel.Name Property

PSLevelName Property

Gets and sets the name of the level. The format of the string should be of the format: [Group : ]Name.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel.Number Property

PSLevelNumber Property

Gets the number of the level.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int Number { get; }
Public ReadOnly Property Number As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel Methods

The PSLevel type exposes the following members.

Methods
 | Name | Description
Public method | AddContentsToSelection | Adds all entities on this level to the selection.
Public method | Clear | Deletes all entities on this level.
Public method | Equals | Overrides the equals function to compare Levels. Compares levels by number.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel.AddContentsToSelection Method

PSLevelAddContentsToSelection Method

Adds all entities on this level to the selection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddContentsToSelection(
    bool keepPreviousSelection = false
)
Public Sub AddContentsToSelection (
    Optional keepPreviousSelection As Boolean = false
)

Parameters

keepPreviousSelection (Optional)
Type: SystemBoolean
If true keeps the previous selection in PowerShape.
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel.Clear Method

PSLevelClear Method

Deletes all entities on this level.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel.Equals Method

PSLevelEquals Method

Overrides the equals function to compare Levels. Compares levels by number.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Equals(
    Object obj
)
Public Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The other level to compare to.

Return Value

Type: Boolean
True if numbers match.
Remarks
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel Fields

The PSLevel type exposes the following members.

Fields
 | Name | Description
Protected field | _number | The number of the level.
Protected field | _powerSHAPE | The PowerSHAPE Automation object.
Top
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel._number Field

PSLevel_number Field

The number of the level.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected int _number
Protected _number As Integer

Field Value

Type: Int32
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevel._powerSHAPE Field

PSLevel_powerSHAPE Field

The PowerSHAPE Automation object.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSAutomation _powerSHAPE
Protected _powerSHAPE As PSAutomation

Field Value

Type: PSAutomation
See Also

Reference

PSLevel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection Class

Captures the collection of Levels in a Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSCollection PSLevel
Autodesk.ProductInterface.PowerSHAPEPSLevelsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSLevelsCollection : PSCollection<PSLevel>
Public Class PSLevelsCollection
    Inherits PSCollection(Of PSLevel)

The PSLevelsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection. (Inherited from PSCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PSCollectionT.)
Public property | ItemInt32 | Gets the level with the specified number. If the specified level does not exist in the collection, then Nothing is returned.
Public property | ItemString | Gets the level with the specified name. If the specified level does not exist in the collection, then Nothing is returned.
Top
Methods
 | Name | Description
Public method | ActivateAllLevels | Activates all Levels.
Protected method | Add | Adds a new item to the List. (Inherited from PSCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PSCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PSCollectionT.)
Public method | DeactivateAllLevels | Deactivates all Levels.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PSCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PSCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PSCollectionT.)
Protected method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PSCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified item. (Inherited from PSCollectionT.)
Public method | RemoveAt | Removes the item at the specified index. (Inherited from PSCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection Properties

The PSLevelsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection. (Inherited from PSCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PSCollectionT.)
Public property | ItemInt32 | Gets the level with the specified number. If the specified level does not exist in the collection, then Nothing is returned.
Public property | ItemString | Gets the level with the specified name. If the specified level does not exist in the collection, then Nothing is returned.
Top
See Also

Reference

PSLevelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection.Item Property

PSLevelsCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets the level with the specified number. If the specified level does not exist in the collection, then Nothing is returned.
Public property | ItemString | Gets the level with the specified name. If the specified level does not exist in the collection, then Nothing is returned.
Top
See Also

Reference

PSLevelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection.Item Property (Int32)

PSLevelsCollectionItem Property (Int32)

Gets the level with the specified number. If the specified level does not exist in the collection, then Nothing is returned.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSLevel this[
    int number
] { get; }
Public ReadOnly Property Item (
    number As Integer
) As PSLevel
    Get

Parameters

number
Type: SystemInt32
The level number.

Return Value

Type: PSLevel
The found level.
Remarks
If none is found, it returns Nothing.
See Also

Reference

PSLevelsCollection Class
Item Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection.Item Property (String)

PSLevelsCollectionItem Property (String)

Gets the level with the specified name. If the specified level does not exist in the collection, then Nothing is returned.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSLevel this[
    string name
] { get; }
Public ReadOnly Property Item (
    name As String
) As PSLevel
    Get

Parameters

name
Type: SystemString
The level name.

Return Value

Type: PSLevel
The found level.
Remarks
If none is found, it returns Nothing.
See Also

Reference

PSLevelsCollection Class
Item Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection Methods

The PSLevelsCollection type exposes the following members.

Methods
 | Name | Description
Public method | ActivateAllLevels | Activates all Levels.
Protected method | Add | Adds a new item to the List. (Inherited from PSCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PSCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PSCollectionT.)
Public method | DeactivateAllLevels | Deactivates all Levels.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PSCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PSCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PSCollectionT.)
Protected method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PSCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified item. (Inherited from PSCollectionT.)
Public method | RemoveAt | Removes the item at the specified index. (Inherited from PSCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSLevelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection.ActivateAllLevels Method

PSLevelsCollectionActivateAllLevels Method

Activates all Levels.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ActivateAllLevels()
Public Sub ActivateAllLevels
See Also

Reference

PSLevelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection.DeactivateAllLevels Method

PSLevelsCollectionDeactivateAllLevels Method

Deactivates all Levels.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeactivateAllLevels()
Public Sub DeactivateAllLevels
See Also

Reference

PSLevelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLevelsCollection Fields

The PSLevelsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSCollectionT.)
Top
See Also

Reference

PSLevelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine Class

Captures a Line object in PowerSHAPE.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSLine

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSLine : PSWireframe, IPSMoveable,
    IPSRotateable, IPSMirrorable, IPSCuttable, IPSLimitable
Public Class PSLine
    Inherits PSWireframe
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSCuttable,
    IPSLimitable

The PSLine type exposes the following members.

Properties
 | Name | Description
Public property | AngleXYApparent | Sets the XY Angle Apparent.
Public property | AngleXYElevation | Sets the XY Angle Elevation.
Public property | AngleYZApparent | Sets the YZ Angle Apparent.
Public property | AngleYZElevation | Sets the YZ Angle Elevation.
Public property | AngleZXApparent | Sets the ZX Angle Apparent.
Public property | AngleZXElevation | Sets the ZX Angle Elevation.
Public property | BoundingBox | Gets the bounding box of the line in PowerSHAPE. (Overrides PSEntityBoundingBox.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe (Inherited from PSWireframe.)
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets and sets the length of the line.
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Overrides the NumberPoints property, as a line will always have 2 points. (Overrides PSWireframeNumberPoints.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe. (Overrides PSWireframePoints.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Cut | Cuts a single line to produce two lines.
Public method | Delete | Deletes the Line from PowerSHAPE and removes it from the Lines collection. (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one end of the line.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenPoints | As a line is always straight, the length between two points can be calculated geometrically.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LimitToEntities | Limits a line by a specified list of entities.
Public method | LimitToEntity | Limits a line by a specified entity.
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single line in a specified plane.
Public method | MoveBetweenPoints | Moves a single line by the relative distance between two absolute positions.
Public method | MoveByVector | Moves a single line by a specified relative amount.
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Reverse | Reverses the direction of the line.
Public method | Rotate | Rotates a single line by a specified angle around a specified axis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine Properties

The PSLine type exposes the following members.

Properties
 | Name | Description
Public property | AngleXYApparent | Sets the XY Angle Apparent.
Public property | AngleXYElevation | Sets the XY Angle Elevation.
Public property | AngleYZApparent | Sets the YZ Angle Apparent.
Public property | AngleYZElevation | Sets the YZ Angle Elevation.
Public property | AngleZXApparent | Sets the ZX Angle Apparent.
Public property | AngleZXElevation | Sets the ZX Angle Elevation.
Public property | BoundingBox | Gets the bounding box of the line in PowerSHAPE. (Overrides PSEntityBoundingBox.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe (Inherited from PSWireframe.)
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets and sets the length of the line.
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Overrides the NumberPoints property, as a line will always have 2 points. (Overrides PSWireframeNumberPoints.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe. (Overrides PSWireframePoints.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.AngleXYApparent Property

PSLineAngleXYApparent Property

Sets the XY Angle Apparent.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree AngleXYApparent { set; }
Public WriteOnly Property AngleXYApparent As Degree
    Set

Property Value

Type: Degree
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.AngleXYElevation Property

PSLineAngleXYElevation Property

Sets the XY Angle Elevation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double AngleXYElevation { set; }
Public WriteOnly Property AngleXYElevation As Double
    Set

Property Value

Type: Double
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.AngleYZApparent Property

PSLineAngleYZApparent Property

Sets the YZ Angle Apparent.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree AngleYZApparent { set; }
Public WriteOnly Property AngleYZApparent As Degree
    Set

Property Value

Type: Degree
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.AngleYZElevation Property

PSLineAngleYZElevation Property

Sets the YZ Angle Elevation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double AngleYZElevation { set; }
Public WriteOnly Property AngleYZElevation As Double
    Set

Property Value

Type: Double
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.AngleZXApparent Property

PSLineAngleZXApparent Property

Sets the ZX Angle Apparent.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree AngleZXApparent { set; }
Public WriteOnly Property AngleZXApparent As Degree
    Set

Property Value

Type: Degree
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.AngleZXElevation Property

PSLineAngleZXElevation Property

Sets the ZX Angle Elevation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double AngleZXElevation { set; }
Public WriteOnly Property AngleZXElevation As Double
    Set

Property Value

Type: Double
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.BoundingBox Property

PSLineBoundingBox Property

Gets the bounding box of the line in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.Length Property

PSLineLength Property

Gets and sets the length of the line.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.NumberPoints Property

PSLineNumberPoints Property

Overrides the NumberPoints property, as a line will always have 2 points.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int NumberPoints { get; }
Public Overrides ReadOnly Property NumberPoints As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.Points Property

PSLinePoints Property

Gets the points on the Wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override List<Point> Points { get; }
Public Overrides ReadOnly Property Points As List(Of Point)
    Get

Property Value

Type: List Point
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine Methods

The PSLine type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Cut | Cuts a single line to produce two lines.
Public method | Delete | Deletes the Line from PowerSHAPE and removes it from the Lines collection. (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one end of the line.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenPoints | As a line is always straight, the length between two points can be calculated geometrically.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LimitToEntities | Limits a line by a specified list of entities.
Public method | LimitToEntity | Limits a line by a specified entity.
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single line in a specified plane.
Public method | MoveBetweenPoints | Moves a single line by the relative distance between two absolute positions.
Public method | MoveByVector | Moves a single line by a specified relative amount.
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Reverse | Reverses the direction of the line.
Public method | Rotate | Rotates a single line by a specified angle around a specified axis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.Cut Method

PSLineCut Method

Cuts a single line to produce two lines.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity Cut(
    Point pointAtWhichToCut
)
Public Function Cut (
    pointAtWhichToCut As Point
) As PSEntity

Parameters

pointAtWhichToCut
Type: Autodesk.GeometryPoint
Point at which to cut the line. This point must lie on the line.

Return Value

Type: PSEntity
A new line

Implements

IPSCuttableCut(Point)
Exceptions
Exception | Condition
ApplicationException | Point does not lie on the line.
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.Delete Method

PSLineDelete Method

Deletes the Line from PowerSHAPE and removes it from the Lines collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.Extend Method

PSLineExtend Method

Extends one end of the line.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Extend(
    ExtensionEnd lineEnd,
    float length,
    ExtensionType straightCurved
)
Public Sub Extend (
    lineEnd As ExtensionEnd,
    length As Single,
    straightCurved As ExtensionType
)

Parameters

lineEnd
Type: Autodesk.ProductInterface.PowerSHAPEExtensionEnd
To specify the end of the curve to be extended.
length
Type: SystemSingle
The extension length.
straightCurved
Type: Autodesk.ProductInterface.PowerSHAPEExtensionType
The straight curved.
Remarks
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.GetLengthBetweenPoints Method

PSLineGetLengthBetweenPoints Method

As a line is always straight, the length between two points can be calculated geometrically.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetLengthBetweenPoints(
    float pointA,
    float pointB
)
Public Function GetLengthBetweenPoints (
    pointA As Single,
    pointB As Single
) As Double

Parameters

pointA
Type: SystemSingle
Point A.
pointB
Type: SystemSingle
Point B.

Return Value

Type: Double
Exceptions
Exception | Condition
NotImplementedException | This feature should be calculated geometrically, and as such is not available in PSline
Remarks
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.LimitToEntities Method

PSLineLimitToEntities Method

Limits a line by a specified list of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntities(
    List<PSEntity> limitingEntities,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntities (
    limitingEntities As List(Of PSEntity),
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntities
Type: System.Collections.GenericList PSEntity
The entities with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
The entities produced by the limiting operation.

Implements

IPSLimitableLimitToEntities(ListPSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
Remarks
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.LimitToEntity Method

PSLineLimitToEntity Method

Limits a line by a specified entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntity(
    PSEntity limitingEntity,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntity (
    limitingEntity As PSEntity,
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
The entities produced by the limiting operation.

Implements

IPSLimitableLimitToEntity(PSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
Remarks
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.LimitUsingDynamicCutter Method

PSLineLimitUsingDynamicCutter Method

Limits using the dynamic cutter option.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity LimitUsingDynamicCutter(
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne
)
Public Function LimitUsingDynamicCutter (
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne
) As PSEntity

Parameters

keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Keep option, by default KeepOne.

Return Value

Type: PSEntity
The limited entity.

Implements

IPSLimitableLimitUsingDynamicCutter(LimitingKeepOptions)
Remarks
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.Mirror Method

PSLineMirror Method

Mirrors a single line in a specified plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
Plane about which to mirror the line.
mirrorPoint
Type: Autodesk.GeometryPoint
Origin of the mirror plane.

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.MoveBetweenPoints Method

PSLineMoveBetweenPoints Method

Moves a single line by the relative distance between two absolute positions.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
First of the two absolute positions.
pointToMoveTo
Type: Autodesk.GeometryPoint
Second of the two absolute positions.
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation.

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.MoveByVector Method

PSLineMoveByVector Method

Moves a single line by a specified relative amount.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
Relative amount by which the line will be moved.
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation.

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.Reverse Method

PSLineReverse Method

Reverses the direction of the line.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Reverse()
Public Sub Reverse
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine.Rotate Method

PSLineRotate Method

Rotates a single line by a specified angle around a specified axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
Axis around which the line is are to be rotated.
rotationAngle
Type: Autodesk.GeometryDegree
Angle by which the line is to be rotated.
copiesToCreate
Type: SystemInt32
Number of copies to create of the original line.
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin of the rotation axis.

Return Value

Type: List PSEntity
List of lines created by the operation. If numberOfCopies is 0, an empty list is returned.

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLine Fields

The PSLine type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSLine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLinesCollection Class

Captures a collection of Lines in a Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSLine
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSLine
Autodesk.ProductInterface.PowerSHAPEPSLinesCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSLinesCollection : PSEntitiesCollection<PSLine>
Public Class PSLinesCollection
    Inherits PSEntitiesCollection(Of PSLine)

The PSLinesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateLine | Creates a line between the specified points.
Public method | CreateLines | Creates lines between the specified points. A line will be created between each two consecutive points (e.g. Line between 1st and 2nd points, line between 2nd and 3rd points, etc.).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSLinesCollection Properties

The PSLinesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSLinesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLinesCollection Methods

The PSLinesCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateLine | Creates a line between the specified points.
Public method | CreateLines | Creates lines between the specified points. A line will be created between each two consecutive points (e.g. Line between 1st and 2nd points, line between 2nd and 3rd points, etc.).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSLinesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLinesCollection.CreateLine Method

PSLinesCollectionCreateLine Method

Creates a line between the specified points.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSLine CreateLine(
    Point startPoint,
    Point endPoint
)
Public Function CreateLine (
    startPoint As Point,
    endPoint As Point
) As PSLine

Parameters

startPoint
Type: Autodesk.GeometryPoint
The start point.
endPoint
Type: Autodesk.GeometryPoint
The end point.

Return Value

Type: PSLine
The new line.
Remarks
See Also

Reference

PSLinesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLinesCollection.CreateLines Method

PSLinesCollectionCreateLines Method

Creates lines between the specified points. A line will be created between each two consecutive points (e.g. Line between 1st and 2nd points, line between 2nd and 3rd points, etc.).

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSLine> CreateLines(
    Point[] points
)
Public Function CreateLines (
    points As Point()
) As List(Of PSLine)

Parameters

points
Type: Autodesk.GeometryPoint
The list of points used to create the lines.

Return Value

Type: List PSLine
The new lines.
Remarks
See Also

Reference

PSLinesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLinesCollection Fields

The PSLinesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSLinesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinal Class

Captures a Surface Longitudinal object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
Autodesk.ProductInterface.PowerSHAPEPSLongitudinal

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSLongitudinal : PSSurfaceCurve
Public Class PSLongitudinal
    Inherits PSSurfaceCurve

The PSLongitudinal type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type (Inherited from PSSurfaceCurve.)
Public property | CentreOfGravity | Gets the centre of gravity of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | EndPoint | Gets the end point of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Exists | Overrides Exists() from DatabaseEntity as a surface curve must be analysed using its name. If the surface curve has been deleted, its name will now be 0 and always return False (Inherited from PSSurfaceCurve.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Level | Gets/Sets the level of the surface curve by getting/setting the level of its parent surface. (Inherited from PSSurfaceCurve.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets/Sets the name of the lateral or longitudinal. (Inherited from PSSurfaceCurve.)
Public property | NumberPoints | Gets the number of points on the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | ParentSurface | Gets the parent surface of the surface curve. (Inherited from PSSurfaceCurve.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the surface curve. (Inherited from PSSurfaceCurve.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Transparency | Always returns 0, as a surface curve can only ever be opaque. (Inherited from PSSurfaceCurve.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Calls the parent surface's AddSurfaceCurveToSelection operation. (Inherited from PSSurfaceCurve.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | CreateCompositeCurve | Returns a composite curve of the surface curve. (Inherited from PSSurfaceCurve.)
Public method | Delete | Deletes the Surface Longitudinal from PowerSHAPE (Overrides PSSurfaceCurveDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditAfterTangencyOfPoint | Edits the after tangent at the selected point. (Inherited from PSSurfaceCurve.)
Public method | EditBeforeTangencyOfPoint | Edits the before tangent at the selected point. (Inherited from PSSurfaceCurve.)
Public method | EditTangencyOfPoint | Edits the entry and exit tangencies at a defined point. (Inherited from PSSurfaceCurve.)
Public method | Equals | Overrides Equals() from DatabaseEntity as the surface curve's name/ID can be changed since the surface curve was initialised. Therefore its unique internal ID is used for comparison. (Inherited from PSSurfaceCurve.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryFlareAngleOfPoint | Gets the flare angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryNormalOfPoint | Gets the entry normal of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryTangentOfPoint | Gets the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryTwistAngleOfPoint | Gets the twist angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitAzimuthAngleOfPOint | Gets the azimuth angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitFlareAngleOfPoint | Gets the flare angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitNormalOfPoint | Gets the exit normal of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitTwistAngleOfPoint | Gets the twist angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points. (Inherited from PSSurfaceCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move(Vector) | Moves a single surfacecurve by a specified relative amount. (Inherited from PSSurfaceCurve.)
Public method | Move(Point, Point) | Moves a single surfacecurve by the relative distance between two absolute positions. (Inherited from PSSurfaceCurve.)
Public method | MoveSurfacePointsAlongVector | Moves the indicated surface points by a vector. (Inherited from PSSurfaceCurve.)
Public method | Offset | Offsets the surface curve by the specified amount. (Inherited from PSSurfaceCurve.)
Public method | OffsetPointsOnCurve | Offsets the indicated points on the surface curve. (Inherited from PSSurfaceCurve.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | Rotates a single surface curve by a specified angle around a specified axis. (Inherited from PSSurfaceCurve.)
Public method | SelectCurvePoints | Selects the indicated points on the surface curve. (Inherited from PSSurfaceCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _internalId | The internal ID of the Surface Curve. (Inherited from PSSurfaceCurve.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _surface | The parent surface of the Surface Curve. (Inherited from PSSurfaceCurve.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinal Properties

The PSLongitudinal type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type (Inherited from PSSurfaceCurve.)
Public property | CentreOfGravity | Gets the centre of gravity of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | EndPoint | Gets the end point of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Exists | Overrides Exists() from DatabaseEntity as a surface curve must be analysed using its name. If the surface curve has been deleted, its name will now be 0 and always return False (Inherited from PSSurfaceCurve.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Level | Gets/Sets the level of the surface curve by getting/setting the level of its parent surface. (Inherited from PSSurfaceCurve.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets/Sets the name of the lateral or longitudinal. (Inherited from PSSurfaceCurve.)
Public property | NumberPoints | Gets the number of points on the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | ParentSurface | Gets the parent surface of the surface curve. (Inherited from PSSurfaceCurve.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the surface curve. (Inherited from PSSurfaceCurve.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the surface curve - overriden because the curve cannot be interrogated using its id. (Inherited from PSSurfaceCurve.)
Public property | Transparency | Always returns 0, as a surface curve can only ever be opaque. (Inherited from PSSurfaceCurve.)
Top
See Also

Reference

PSLongitudinal Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinal Methods

The PSLongitudinal type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Calls the parent surface's AddSurfaceCurveToSelection operation. (Inherited from PSSurfaceCurve.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | CreateCompositeCurve | Returns a composite curve of the surface curve. (Inherited from PSSurfaceCurve.)
Public method | Delete | Deletes the Surface Longitudinal from PowerSHAPE (Overrides PSSurfaceCurveDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditAfterTangencyOfPoint | Edits the after tangent at the selected point. (Inherited from PSSurfaceCurve.)
Public method | EditBeforeTangencyOfPoint | Edits the before tangent at the selected point. (Inherited from PSSurfaceCurve.)
Public method | EditTangencyOfPoint | Edits the entry and exit tangencies at a defined point. (Inherited from PSSurfaceCurve.)
Public method | Equals | Overrides Equals() from DatabaseEntity as the surface curve's name/ID can be changed since the surface curve was initialised. Therefore its unique internal ID is used for comparison. (Inherited from PSSurfaceCurve.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryFlareAngleOfPoint | Gets the flare angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryNormalOfPoint | Gets the entry normal of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryTangentOfPoint | Gets the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetEntryTwistAngleOfPoint | Gets the twist angle of the entry tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitAzimuthAngleOfPOint | Gets the azimuth angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitFlareAngleOfPoint | Gets the flare angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitNormalOfPoint | Gets the exit normal of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetExitTwistAngleOfPoint | Gets the twist angle of the exit tangent of the desired point. (Inherited from PSSurfaceCurve.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points. (Inherited from PSSurfaceCurve.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move(Vector) | Moves a single surfacecurve by a specified relative amount. (Inherited from PSSurfaceCurve.)
Public method | Move(Point, Point) | Moves a single surfacecurve by the relative distance between two absolute positions. (Inherited from PSSurfaceCurve.)
Public method | MoveSurfacePointsAlongVector | Moves the indicated surface points by a vector. (Inherited from PSSurfaceCurve.)
Public method | Offset | Offsets the surface curve by the specified amount. (Inherited from PSSurfaceCurve.)
Public method | OffsetPointsOnCurve | Offsets the indicated points on the surface curve. (Inherited from PSSurfaceCurve.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | Rotates a single surface curve by a specified angle around a specified axis. (Inherited from PSSurfaceCurve.)
Public method | SelectCurvePoints | Selects the indicated points on the surface curve. (Inherited from PSSurfaceCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSLongitudinal Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinal.Delete Method

PSLongitudinalDelete Method

Deletes the Surface Longitudinal from PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Remarks
See Also

Reference

PSLongitudinal Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinal Fields

The PSLongitudinal type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _internalId | The internal ID of the Surface Curve. (Inherited from PSSurfaceCurve.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _surface | The parent surface of the Surface Curve. (Inherited from PSSurfaceCurve.)
Top
See Also

Reference

PSLongitudinal Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinalsCollection Class

Captures a collection of Longitudinals in a project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSLongitudinal
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSLongitudinal
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurvesCollection PSLongitudinal
Autodesk.ProductInterface.PowerSHAPEPSLongitudinalsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSLongitudinalsCollection : PSSurfaceCurvesCollection<PSLongitudinal>
Public Class PSLongitudinalsCollection
    Inherits PSSurfaceCurvesCollection(Of PSLongitudinal)

The PSLongitudinalsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes surface curve from PowerShape and from surface curves collection. (Inherited from PSSurfaceCurvesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _parentSurface | The parent surface of a PSSurface. (Inherited from PSSurfaceCurvesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinalsCollection Properties

The PSLongitudinalsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSLongitudinalsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinalsCollection Methods

The PSLongitudinalsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes surface curve from PowerShape and from surface curves collection. (Inherited from PSSurfaceCurvesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSLongitudinalsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSLongitudinalsCollection Fields

The PSLongitudinalsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _parentSurface | The parent surface of a PSSurface. (Inherited from PSSurfaceCurvesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSLongitudinalsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro Class

Handles Macros in PowerSHAPE.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterfaceMacro
Autodesk.ProductInterface.PowerSHAPEPSMacro

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSMacro : Macro
Public Class PSMacro
    Inherits Macro

The PSMacro type exposes the following members.

Constructors
 | Name | Description
Protected method | PSMacro(PSAutomation, File) | Constructor reads the Macro File in.
Protected method | PSMacro(PSAutomation, String) | Creates a new macro from a list of strings.
Top
Properties
 | Name | Description
Protected property | _childMacro | (Inherited from Macro.)
Public property | Cancel | If True, Macro will be cancelled; False otherwise. (Inherited from Macro.)
Public property | ExecutedCommands | Commands that have been executed by this Macro. (Inherited from Macro.)
Public property | Index | Index of the next line to be executed in this Macro. (Inherited from Macro.)
Public property | Line | Line at the specified index of this Macro. (Inherited from Macro.)
Public property | LocalCount | Number of lines in this macro, excluding children. (Inherited from Macro.)
Public property | Text | All lines of the Macro in a string. (Inherited from Macro.)
Public property | TotalCount | Gets the number of lines in the macro (includes lines in called macros). (Overrides MacroTotalCount.)
Top
Methods
 | Name | Description
Protected method | ConfigureMacro |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseStepProcessedEvent | Raises the step processed event. (Inherited from Macro.)
Public method | Run | Executes the macro until the end, optionally feeding back progress as it goes. (Overrides MacroRun(Boolean, Boolean).)
Public method | RunComplete | Executes the macro in one go rather than line by line. (Overrides MacroRunComplete.)
Public method | RunStep | Executes the next line in the macro and increments the index marker. (Overrides MacroRunStep(Boolean).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | StepProcessed | Raised when a Macro line is processed. (Inherited from Macro.)
Top
Fields
 | Name | Description
Protected field | _cancel | If True, indicates that a Macro cancellation is pending. (Inherited from Macro.)
Protected field | _executedCommands | List of commands that have been executed. (Inherited from Macro.)
Protected field | _lines | Macro command lines. (Inherited from Macro.)
Protected field | _localIndex | Current index within this Macro. (Inherited from Macro.)
Protected field | _powerSHAPE | The instance of PowerSHAPE will run the macro on.
Protected field | _totalIndex | Current index within this file - including all sub macros. (Inherited from Macro.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro Constructor

Overload List
 | Name | Description
Protected method | PSMacro(PSAutomation, File) | Constructor reads the Macro File in.
Protected method | PSMacro(PSAutomation, String) | Creates a new macro from a list of strings.
Top
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro Constructor (PSAutomation, File)

Constructor reads the Macro File in.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSMacro(
    PSAutomation powerSHAPE,
    File macroFile
)
Protected Sub New (
    powerSHAPE As PSAutomation,
    macroFile As File
)

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
macroFile
Type: Autodesk.FileSystemFile
The file path to the macro.
Remarks
See Also

Reference

PSMacro Class
PSMacro Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro Constructor (PSAutomation, String[])

PSMacro Constructor (PSAutomation, String)

Creates a new macro from a list of strings.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSMacro(
    PSAutomation psAutomation,
    params string[] macros
)
Protected Sub New (
    psAutomation As PSAutomation,
    ParamArray macros As String()
)

Parameters

psAutomation
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
macros
Type: SystemString
a list of macros to be loaded.
See Also

Reference

PSMacro Class
PSMacro Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro Properties

The PSMacro type exposes the following members.

Properties
 | Name | Description
Protected property | _childMacro | (Inherited from Macro.)
Public property | Cancel | If True, Macro will be cancelled; False otherwise. (Inherited from Macro.)
Public property | ExecutedCommands | Commands that have been executed by this Macro. (Inherited from Macro.)
Public property | Index | Index of the next line to be executed in this Macro. (Inherited from Macro.)
Public property | Line | Line at the specified index of this Macro. (Inherited from Macro.)
Public property | LocalCount | Number of lines in this macro, excluding children. (Inherited from Macro.)
Public property | Text | All lines of the Macro in a string. (Inherited from Macro.)
Public property | TotalCount | Gets the number of lines in the macro (includes lines in called macros). (Overrides MacroTotalCount.)
Top
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro.TotalCount Property

PSMacroTotalCount Property

Gets the number of lines in the macro (includes lines in called macros).

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int TotalCount { get; }
Public Overrides ReadOnly Property TotalCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro Methods

The PSMacro type exposes the following members.

Methods
 | Name | Description
Protected method | ConfigureMacro |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseStepProcessedEvent | Raises the step processed event. (Inherited from Macro.)
Public method | Run | Executes the macro until the end, optionally feeding back progress as it goes. (Overrides MacroRun(Boolean, Boolean).)
Public method | RunComplete | Executes the macro in one go rather than line by line. (Overrides MacroRunComplete.)
Public method | RunStep | Executes the next line in the macro and increments the index marker. (Overrides MacroRunStep(Boolean).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro.ConfigureMacro Method

PSMacroConfigureMacro Method

[Missing <summary> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSMacro.ConfigureMacro(Autodesk.ProductInterface.PowerSHAPE.PSAutomation)"]

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected void ConfigureMacro(
    PSAutomation powerShape
)
Protected Sub ConfigureMacro (
    powerShape As PSAutomation
)

Parameters

powerShape
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation

[Missing <param name="powerShape"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSMacro.ConfigureMacro(Autodesk.ProductInterface.PowerSHAPE.PSAutomation)"]

See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro.Run Method

PSMacroRun Method

Executes the macro until the end, optionally feeding back progress as it goes.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Run(
    bool giveProgress = true,
    bool hideDialogs = true
)
Public Overrides Sub Run (
    Optional giveProgress As Boolean = true,
    Optional hideDialogs As Boolean = true
)

Parameters

giveProgress (Optional)
Type: SystemBoolean
If true, it will give progress status.
hideDialogs (Optional)
Type: SystemBoolean
If true, hides any dialogs while running commands.
Remarks
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro.RunComplete Method

PSMacroRunComplete Method

Executes the macro in one go rather than line by line.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RunComplete()
Public Overrides Sub RunComplete
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro.RunStep Method

PSMacroRunStep Method

Executes the next line in the macro and increments the index marker.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RunStep(
    bool hideDialogs = true
)
Public Overrides Sub RunStep (
    Optional hideDialogs As Boolean = true
)

Parameters

hideDialogs (Optional)
Type: SystemBoolean
If true, hides any dialogs while running commands.
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro Events

The PSMacro type exposes the following members.

Events
 | Name | Description
Public event | StepProcessed | Raised when a Macro line is processed. (Inherited from Macro.)
Top
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro Fields

The PSMacro type exposes the following members.

Fields
 | Name | Description
Protected field | _cancel | If True, indicates that a Macro cancellation is pending. (Inherited from Macro.)
Protected field | _executedCommands | List of commands that have been executed. (Inherited from Macro.)
Protected field | _lines | Macro command lines. (Inherited from Macro.)
Protected field | _localIndex | Current index within this Macro. (Inherited from Macro.)
Protected field | _powerSHAPE | The instance of PowerSHAPE will run the macro on.
Protected field | _totalIndex | Current index within this file - including all sub macros. (Inherited from Macro.)
Top
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMacro._powerSHAPE Field

PSMacro_powerSHAPE Field

The instance of PowerSHAPE will run the macro on.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSAutomation _powerSHAPE
Protected _powerSHAPE As PSAutomation

Field Value

Type: PSAutomation
See Also

Reference

PSMacro Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial Class

Captures a Material in PowerSHAPE. A Material is used to give colour and texture to a surface.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSMaterial

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSMaterial
Public Class PSMaterial

The PSMaterial type exposes the following members.

Properties
 | Name | Description
Public property | ColourB | Gets and sets the blue colour of the material.
Public property | ColourG | Gets and sets the green colour of the material..
Public property | ColourR | Gets and sets the red colour of the material...
Public property | Emission | Gets and sets the emission of the material.
Public property | Name | Gets the name of the Material.
Public property | Polish | Gets and sets the polish value of the material.
Public property | Reflectance | Gets and sets the reflectance of the material.
Public property | Transparency | Gets and sets the transparency of the material.
Top
Methods
 | Name | Description
Public method | Delete | This operation deletes the Material from PowerSHAPE and removes it from the Materials collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial Properties

The PSMaterial type exposes the following members.

Properties
 | Name | Description
Public property | ColourB | Gets and sets the blue colour of the material.
Public property | ColourG | Gets and sets the green colour of the material..
Public property | ColourR | Gets and sets the red colour of the material...
Public property | Emission | Gets and sets the emission of the material.
Public property | Name | Gets the name of the Material.
Public property | Polish | Gets and sets the polish value of the material.
Public property | Reflectance | Gets and sets the reflectance of the material.
Public property | Transparency | Gets and sets the transparency of the material.
Top
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.ColourB Property

PSMaterialColourB Property

Gets and sets the blue colour of the material.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public byte ColourB { get; set; }
Public Property ColourB As Byte
    Get
    Set

Property Value

Type: Byte
The blue colour of the material.

Return Value

Type: Byte
The blue colour of the material.
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.ColourG Property

PSMaterialColourG Property

Gets and sets the green colour of the material..

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public byte ColourG { get; set; }
Public Property ColourG As Byte
    Get
    Set

Property Value

Type: Byte
The green colour of the material..

Return Value

Type: Byte
The green colour of the material..
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.ColourR Property

PSMaterialColourR Property

Gets and sets the red colour of the material...

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public byte ColourR { get; set; }
Public Property ColourR As Byte
    Get
    Set

Property Value

Type: Byte
The red colour of the material.

Return Value

Type: Byte
The red colour of the material.
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.Emission Property

PSMaterialEmission Property

Gets and sets the emission of the material.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Emission { get; set; }
Public Property Emission As Double
    Get
    Set

Property Value

Type: Double
The emission of the material.

Return Value

Type: Double
The emission of the material.
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.Name Property

PSMaterialName Property

Gets the name of the Material.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Return Value

Type: String
Name of the Material.
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.Polish Property

PSMaterialPolish Property

Gets and sets the polish value of the material.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Polish { get; set; }
Public Property Polish As Double
    Get
    Set

Property Value

Type: Double
The polish of the material.

Return Value

Type: Double
The polish of the material.
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.Reflectance Property

PSMaterialReflectance Property

Gets and sets the reflectance of the material.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Reflectance { get; set; }
Public Property Reflectance As Double
    Get
    Set

Property Value

Type: Double
The reflectance of the material.

Return Value

Type: Double
The reflectance of the material.
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.Transparency Property

PSMaterialTransparency Property

Gets and sets the transparency of the material.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Transparency { get; set; }
Public Property Transparency As Double
    Get
    Set

Property Value

Type: Double
The transparency of the material.

Return Value

Type: Double
The transparency of the material.
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial Methods

The PSMaterial type exposes the following members.

Methods
 | Name | Description
Public method | Delete | This operation deletes the Material from PowerSHAPE and removes it from the Materials collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterial.Delete Method

PSMaterialDelete Method

This operation deletes the Material from PowerSHAPE and removes it from the Materials collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Delete()
Public Sub Delete
See Also

Reference

PSMaterial Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection Class

Captures the collection of Materials in PowerSHAPE.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSCollection PSMaterial
Autodesk.ProductInterface.PowerSHAPEPSMaterialsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSMaterialsCollection : PSCollection<PSMaterial>
Public Class PSMaterialsCollection
    Inherits PSCollection(Of PSMaterial)

The PSMaterialsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection. (Inherited from PSCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PSCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PSCollectionT.)
Public property | ItemString | Gets the material with the specified name. If the specified material does not exist in the collection, then Nothing is returned.
Top
Methods
 | Name | Description
Protected method | Add | Adds a new item to the List. (Inherited from PSCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PSCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PSCollectionT.)
Public method | CreateMaterial | Creates a new material in PowerSHAPE with the specified values.
Public method | CreateMaterials | Create the defined materials.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PSCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PSCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PSCollectionT.)
Protected method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PSCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a material from the collection and from PowerShape. (Overrides PSCollectionTRemove(T).)
Public method | RemoveAt | Removes the item at the specified index. (Inherited from PSCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection Properties

The PSMaterialsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection. (Inherited from PSCollectionT.)
Public property | IsReadOnly | PSCollection is not readonly. (Inherited from PSCollectionT.)
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PSCollectionT.)
Public property | ItemString | Gets the material with the specified name. If the specified material does not exist in the collection, then Nothing is returned.
Top
See Also

Reference

PSMaterialsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection.Item Property

PSMaterialsCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets and sets the desired indexed item. (Inherited from PSCollectionT.)
Public property | ItemString | Gets the material with the specified name. If the specified material does not exist in the collection, then Nothing is returned.
Top
See Also

Reference

PSMaterialsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection.Item Property (String)

PSMaterialsCollectionItem Property (String)

Gets the material with the specified name. If the specified material does not exist in the collection, then Nothing is returned.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMaterial this[
    string name
] { get; }
Public ReadOnly Property Item (
    name As String
) As PSMaterial
    Get

Parameters

name
Type: SystemString
The material name.

Return Value

Type: PSMaterial
The found material.
Remarks
None found, so returns Nothing.
See Also

Reference

PSMaterialsCollection Class
Item Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection Methods

The PSMaterialsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new item to the List. (Inherited from PSCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSCollectionT.)
Public method | Contains | Determines whether the indicated item is contained within the collection. (Inherited from PSCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified list, starting at the specified index. (Inherited from PSCollectionT.)
Public method | CreateMaterial | Creates a new material in PowerSHAPE with the specified values.
Public method | CreateMaterials | Create the defined materials.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator of items. (Inherited from PSCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IEnumerable_GetEnumerator | Returns an enumerator of items. (Inherited from PSCollectionT.)
Public method | IndexOf | Index of item in the list. (Inherited from PSCollectionT.)
Protected method | Insert | Inserts the specified item into the desired position within the collection. (Inherited from PSCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a material from the collection and from PowerShape. (Overrides PSCollectionTRemove(T).)
Public method | RemoveAt | Removes the item at the specified index. (Inherited from PSCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSMaterialsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection.CreateMaterial Method

PSMaterialsCollectionCreateMaterial Method

Creates a new material in PowerSHAPE with the specified values.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMaterial CreateMaterial(
    string name,
    double polish,
    double emission,
    double transparency,
    double reflectance,
    byte colourR,
    byte colourG,
    byte colourB
)
Public Function CreateMaterial (
    name As String,
    polish As Double,
    emission As Double,
    transparency As Double,
    reflectance As Double,
    colourR As Byte,
    colourG As Byte,
    colourB As Byte
) As PSMaterial

Parameters

name
Type: SystemString
The name of the material.
polish
Type: SystemDouble
The polish of the material.
emission
Type: SystemDouble
The emission of the material.
transparency
Type: SystemDouble
The transparency of the material.
reflectance
Type: SystemDouble
The reflectance of the material.
colourR
Type: SystemByte
The red colour of the material. Between 0 and 255.
colourG
Type: SystemByte
The green colour of the material. Between 0 and 255.
colourB
Type: SystemByte
The blue colour of the material.Between 0 and 255.

Return Value

Type: PSMaterial
See Also

Reference

PSMaterialsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection.CreateMaterials Method

PSMaterialsCollectionCreateMaterials Method

Create the defined materials.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSMaterial> CreateMaterials(
    Tuple<string, double, double, double, double, byte[]>[] materialDefinitions
)
Public Function CreateMaterials (
    materialDefinitions As Tuple(Of String, Double, Double, Double, Double, Byte())()
) As List(Of PSMaterial)

Parameters

materialDefinitions
Type: SystemTuple String, Double, Double, Double, Double, Byte
Each definition should be name, polish, emission, transparency, reflectance, byte[R, G, B].

Return Value

Type: List PSMaterial
See Also

Reference

PSMaterialsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection.Remove Method

PSMaterialsCollectionRemove Method

Removes a material from the collection and from PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Remove(
    PSMaterial material
)
Public Overrides Function Remove (
    material As PSMaterial
) As Boolean

Parameters

material
Type: Autodesk.ProductInterface.PowerSHAPEPSMaterial
The material to remove.

Return Value

Type: Boolean
See Also

Reference

PSMaterialsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMaterialsCollection Fields

The PSMaterialsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSCollectionT.)
Top
See Also

Reference

PSMaterialsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh Class

Captures a Mesh object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSMesh

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSMesh : PSEntity, IPSMoveable,
    IPSRotateable, IPSMirrorable, IPSOffsetable, IPSLimitable, IPSAddable,
    IPSIntersectable, IPSSubtractable, IPSScalable
Public Class PSMesh
    Inherits PSEntity
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSOffsetable,
    IPSLimitable, IPSAddable, IPSIntersectable, IPSSubtractable, IPSScalable

The PSMesh type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Mesh
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Centre | Gets and Sets the centre of the Mesh in PowerSHAPE based on the active Workplane
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Mesh in PowerSHAPE
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfNodes | Gets the number of nodes in the mesh
Public property | NumberOfTriangles | Gets the number of triangles in the mesh
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AcceptSculpt | Accepts the last StartSculpt to the mesh
Public method | AddEntitiesToEntity | Adds entities to another entity
Public method | AddEntityToEntity | Adds an entity to another entity
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Append | Appends the specified Mesh to this Mesh. It will leave a single Mesh, deleting the specified one.
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | CancelSculpt | Cancels the last StartSculpt
Public method | CreateBoundary | Creates a boundary curve object
Public method | CreateDraft | Adds draft angles to the mesh down to the origin of the current workplane
Public method | Delete | Deletes the Mesh from PowerSHAPE and removes it from the Meshes collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FillHole | Allows the user to select a hole on the mesh and fill it
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity
Public method | IntersectEntityWithEntity | Intersects an entity with another entity
Public method | LimitToEntities | This operation limits a mesh by a specified list of entities
Public method | LimitToEntity | Limits a mesh by a specified list of entities
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single mesh in a specified plane
Public method | MoveBetweenPoints | This operation moves a single mesh by the relative distance between two absolute positions
Public method | MoveByVector | This operation moves a single mesh by a specified relative amount
Public method | Offset | This operation offsets a single mesh by a specified distance
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | ReduceByPercentage | Reduces the Mesh by the specified percentage
Public method | ReduceToTolerance | Reduces the Mesh maintaining the specified tolerance
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | This operation rotates a single mesh by a specified angle around a specified axis
Public method | RunMeshDoctor | Detects and fixes the faults in the mesh
Public method | ScaleNonUniform | Scales the mesh a different amount in each axis
Public method | ScaleProjectedVolume | Scales the mesh to a projected volume
Public method | ScaleUniform | Scales the mesh the same amount in each axis
Public method | Split | Splits the mesh into seperate meshes. If the mesh cannot be divided further than itself then only one mesh (the start mesh) is returned. Otherwise all the new created meshes are returned and this mesh fails to exist
Public method | StartSculpt | Starts the interactive sculpting tool. It is finished or aborted using the ApplyScult and CancelSculpt operations
Public method | StitchTriangles | Stitches the triangle mesh based on the specified values.
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity
Public method | ToDMTModel | Returns a DMT Model of the mesh
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the mesh to the selected DMT file
Public method | WriteToSTLFile | Exports the mesh to the selected STL file
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh Properties

The PSMesh type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Mesh
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Centre | Gets and Sets the centre of the Mesh in PowerSHAPE based on the active Workplane
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Mesh in PowerSHAPE
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfNodes | Gets the number of nodes in the mesh
Public property | NumberOfTriangles | Gets the number of triangles in the mesh
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Area Property

PSMeshArea Property

Gets the area of the Mesh

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get

Property Value

Type: Double
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Centre Property

PSMeshCentre Property

Gets and Sets the centre of the Mesh in PowerSHAPE based on the active Workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Centre { get; set; }
Public Property Centre As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Material Property

PSMeshMaterial Property

Gets and Sets the material of the Mesh in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMaterial Material { get; set; }
Public Property Material As PSMaterial
    Get
    Set

Property Value

Type: PSMaterial
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.NumberOfNodes Property

PSMeshNumberOfNodes Property

Gets the number of nodes in the mesh

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfNodes { get; }
Public ReadOnly Property NumberOfNodes As Integer
    Get

Return Value

Type: Int32
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.NumberOfTriangles Property

PSMeshNumberOfTriangles Property

Gets the number of triangles in the mesh

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfTriangles { get; }
Public ReadOnly Property NumberOfTriangles As Integer
    Get

Return Value

Type: Int32
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh Methods

The PSMesh type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AcceptSculpt | Accepts the last StartSculpt to the mesh
Public method | AddEntitiesToEntity | Adds entities to another entity
Public method | AddEntityToEntity | Adds an entity to another entity
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Append | Appends the specified Mesh to this Mesh. It will leave a single Mesh, deleting the specified one.
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | CancelSculpt | Cancels the last StartSculpt
Public method | CreateBoundary | Creates a boundary curve object
Public method | CreateDraft | Adds draft angles to the mesh down to the origin of the current workplane
Public method | Delete | Deletes the Mesh from PowerSHAPE and removes it from the Meshes collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FillHole | Allows the user to select a hole on the mesh and fill it
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity
Public method | IntersectEntityWithEntity | Intersects an entity with another entity
Public method | LimitToEntities | This operation limits a mesh by a specified list of entities
Public method | LimitToEntity | Limits a mesh by a specified list of entities
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single mesh in a specified plane
Public method | MoveBetweenPoints | This operation moves a single mesh by the relative distance between two absolute positions
Public method | MoveByVector | This operation moves a single mesh by a specified relative amount
Public method | Offset | This operation offsets a single mesh by a specified distance
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | ReduceByPercentage | Reduces the Mesh by the specified percentage
Public method | ReduceToTolerance | Reduces the Mesh maintaining the specified tolerance
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | This operation rotates a single mesh by a specified angle around a specified axis
Public method | RunMeshDoctor | Detects and fixes the faults in the mesh
Public method | ScaleNonUniform | Scales the mesh a different amount in each axis
Public method | ScaleProjectedVolume | Scales the mesh to a projected volume
Public method | ScaleUniform | Scales the mesh the same amount in each axis
Public method | Split | Splits the mesh into seperate meshes. If the mesh cannot be divided further than itself then only one mesh (the start mesh) is returned. Otherwise all the new created meshes are returned and this mesh fails to exist
Public method | StartSculpt | Starts the interactive sculpting tool. It is finished or aborted using the ApplyScult and CancelSculpt operations
Public method | StitchTriangles | Stitches the triangle mesh based on the specified values.
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity
Public method | ToDMTModel | Returns a DMT Model of the mesh
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the mesh to the selected DMT file
Public method | WriteToSTLFile | Exports the mesh to the selected STL file
Top
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.AcceptSculpt Method

PSMeshAcceptSculpt Method

Accepts the last StartSculpt to the mesh

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AcceptSculpt()
Public Sub AcceptSculpt
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.AddEntitiesToEntity Method

PSMeshAddEntitiesToEntity Method

Adds entities to another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity AddEntitiesToEntity(
    IEnumerable<IPSAddable> entitiesToAdd,
    bool copeWithCoincidentFaces = false
)
Public Function AddEntitiesToEntity (
    entitiesToAdd As IEnumerable(Of IPSAddable),
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entitiesToAdd
Type: System.Collections.GenericIEnumerable IPSAddable
Collection of entities to be added
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the addition

Implements

IPSAddableAddEntitiesToEntity(IEnumerableIPSAddable, Boolean)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.AddEntityToEntity Method

PSMeshAddEntityToEntity Method

Adds an entity to another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity AddEntityToEntity(
    IPSAddable entityToAdd,
    bool copeWithCoincidentFaces = false
)
Public Function AddEntityToEntity (
    entityToAdd As IPSAddable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToAdd
Type: Autodesk.ProductInterface.PowerSHAPEIPSAddable
Entity to be added
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the addition

Implements

IPSAddableAddEntityToEntity(IPSAddable, Boolean)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Append Method

PSMeshAppend Method

Appends the specified Mesh to this Mesh. It will leave a single Mesh, deleting the specified one.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Append(
    PSMesh meshToAppend
)
Public Sub Append (
    meshToAppend As PSMesh
)

Parameters

meshToAppend
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
The mesh to be appended to this mesh
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.CancelSculpt Method

PSMeshCancelSculpt Method

Cancels the last StartSculpt

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CancelSculpt()
Public Sub CancelSculpt
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.CreateBoundary Method

PSMeshCreateBoundary Method

Creates a boundary curve object

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> CreateBoundary(
    int location = 1,
    int smoothness = 0
)
Public Function CreateBoundary (
    Optional location As Integer = 1,
    Optional smoothness As Integer = 0
) As List(Of PSCompCurve)

Parameters

location (Optional)
Type: SystemInt32
Optional location defaulted to 1
smoothness (Optional)
Type: SystemInt32
Optional smoothness defaulted to 0

Return Value

Type: List PSCompCurve
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.CreateDraft Method

PSMeshCreateDraft Method

Adds draft angles to the mesh down to the origin of the current workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CreateDraft(
    double draftAngle,
    bool createWallsOnly
)
Public Sub CreateDraft (
    draftAngle As Double,
    createWallsOnly As Boolean
)

Parameters

draftAngle
Type: SystemDouble
The draft angle to use
createWallsOnly
Type: SystemBoolean
Whether or not to only add the draft walls
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Delete Method

PSMeshDelete Method

Deletes the Mesh from PowerSHAPE and removes it from the Meshes collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.FillHole Method

PSMeshFillHole Method

Allows the user to select a hole on the mesh and fill it

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FillHole()
Public Sub FillHole
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.IntersectEntitiesWithEntity Method

PSMeshIntersectEntitiesWithEntity Method

Intersects a collection of entities with another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> IntersectEntitiesWithEntity(
    IEnumerable<IPSIntersectable> entitiesToIntersect,
    bool copeWithCoincidentFaces = false
)
Public Function IntersectEntitiesWithEntity (
    entitiesToIntersect As IEnumerable(Of IPSIntersectable),
    Optional copeWithCoincidentFaces As Boolean = false
) As List(Of PSEntity)

Parameters

entitiesToIntersect
Type: System.Collections.GenericIEnumerable IPSIntersectable
Entities to intersect
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: List PSEntity
Entity created from the intersection

Implements

IPSIntersectableIntersectEntitiesWithEntity(IEnumerableIPSIntersectable, Boolean)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.IntersectEntityWithEntity Method

PSMeshIntersectEntityWithEntity Method

Intersects an entity with another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity IntersectEntityWithEntity(
    IPSIntersectable entityToIntersect,
    bool copeWithCoincidentFaces = false
)
Public Function IntersectEntityWithEntity (
    entityToIntersect As IPSIntersectable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToIntersect
Type: Autodesk.ProductInterface.PowerSHAPEIPSIntersectable
Entity to intersect
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the intersection

Implements

IPSIntersectableIntersectEntityWithEntity(IPSIntersectable, Boolean)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.LimitToEntities Method

PSMeshLimitToEntities Method

This operation limits a mesh by a specified list of entities

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntities(
    List<PSEntity> limitingEntities,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntities (
    limitingEntities As List(Of PSEntity),
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntities
Type: System.Collections.GenericList PSEntity
The entities with which to perform the limiting operation
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
A list containing the limited entity

Implements

IPSLimitableLimitToEntities(ListPSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.LimitToEntity Method

PSMeshLimitToEntity Method

Limits a mesh by a specified list of entities

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntity(
    PSEntity limitingEntity,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntity (
    limitingEntity As PSEntity,
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity with which to perform the limiting operation
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
A list containing the limited entity

Implements

IPSLimitableLimitToEntity(PSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.LimitUsingDynamicCutter Method

PSMeshLimitUsingDynamicCutter Method

Limits using the dynamic cutter option.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity LimitUsingDynamicCutter(
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne
)
Public Function LimitUsingDynamicCutter (
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne
) As PSEntity

Parameters

keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.

Return Value

Type: PSEntity
Limited entity

Implements

IPSLimitableLimitUsingDynamicCutter(LimitingKeepOptions)
Remarks
To be used with PSEntityLimiter.NextSolution
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Mirror Method

PSMeshMirror Method

This operation mirrors a single mesh in a specified plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the mesh
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.MoveBetweenPoints Method

PSMeshMoveBetweenPoints Method

This operation moves a single mesh by the relative distance between two absolute positions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity
A list containing the entity moved

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.MoveByVector Method

PSMeshMoveByVector Method

This operation moves a single mesh by a specified relative amount

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
The relative amount by which the mesh will be moved
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity
A list containing the entity moved

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Offset Method

PSMeshOffset Method

This operation offsets a single mesh by a specified distance

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Offset(
    MM offsetDistance,
    int copiesToCreate
)
Public Function Offset (
    offsetDistance As MM,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

offsetDistance
Type: Autodesk.GeometryMM
The distance by which to offset the mesh
copiesToCreate
Type: SystemInt32
The number of copies to be created from the operation

Return Value

Type: List PSEntity
A list of offset meshes

Implements

IPSOffsetableOffset(MM, Int32)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.ReduceByPercentage Method

PSMeshReduceByPercentage Method

Reduces the Mesh by the specified percentage

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ReduceByPercentage(
    double percentage
)
Public Sub ReduceByPercentage (
    percentage As Double
)

Parameters

percentage
Type: SystemDouble
Percentage by which to reduce the mesh
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.ReduceToTolerance Method

PSMeshReduceToTolerance Method

Reduces the Mesh maintaining the specified tolerance

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ReduceToTolerance(
    double tolerace,
    bool limitTriangleEdgeLength,
    MM maximumEdgeLength
)
Public Sub ReduceToTolerance (
    tolerace As Double,
    limitTriangleEdgeLength As Boolean,
    maximumEdgeLength As MM
)

Parameters

tolerace
Type: SystemDouble
Tolerance to maintain during reduction
limitTriangleEdgeLength
Type: SystemBoolean
Whether or not to limit the length of edges
maximumEdgeLength
Type: Autodesk.GeometryMM
The maximum edge length to reduce to. Only applies if limitTriangleEdgeLength is true
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Rotate Method

PSMeshRotate Method

This operation rotates a single mesh by a specified angle around a specified axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the mesh is are to be rotated
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the mesh is to be rotated
copiesToCreate
Type: SystemInt32
The number of copies to create of the original mesh
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis

Return Value

Type: List PSEntity
A list of meshs created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.RunMeshDoctor Method

PSMeshRunMeshDoctor Method

Detects and fixes the faults in the mesh

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void RunMeshDoctor(
    MeshDoctorFixOptions fixOption,
    MeshDoctorRepairTypes repairType
)
Public Sub RunMeshDoctor (
    fixOption As MeshDoctorFixOptions,
    repairType As MeshDoctorRepairTypes
)

Parameters

fixOption
Type: Autodesk.ProductInterface.PowerSHAPEMeshDoctorFixOptions
This option determines the type of fix/operation the mesh doctor will do. If 'All' is selected it detects and fixes all types of faults, otherwise the Mesh Doctor identifies and fixes the select fault type. The option 'Status' gives the status of the faults.
repairType
Type: Autodesk.ProductInterface.PowerSHAPEMeshDoctorRepairTypes
This option allows to choose between an automation repair and an expand superfault option.
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.ScaleNonUniform Method

PSMeshScaleNonUniform Method

Scales the mesh a different amount in each axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleNonUniform(
    double scaleFactorX,
    double scaleFactorY,
    double scaleFactorZ,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleNonUniform (
    scaleFactorX As Double,
    scaleFactorY As Double,
    scaleFactorZ As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactorX
Type: SystemDouble
Scale factor for the X axis
scaleFactorY
Type: SystemDouble
Scale factor for the Y axis
scaleFactorZ
Type: SystemDouble
Scale factor for the Z axis
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleNonUniform(Double, Double, Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.ScaleProjectedVolume Method

PSMeshScaleProjectedVolume Method

Scales the mesh to a projected volume

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleProjectedVolume(
    double newVolume,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleProjectedVolume (
    newVolume As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

newVolume
Type: SystemDouble
Volume to scale to
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleProjectedVolume(Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.ScaleUniform Method

PSMeshScaleUniform Method

Scales the mesh the same amount in each axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleUniform(
    double scaleFactor,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleUniform (
    scaleFactor As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactor
Type: SystemDouble
Scale factor for the axes
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleUniform(Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.Split Method

PSMeshSplit Method

Splits the mesh into seperate meshes. If the mesh cannot be divided further than itself then only one mesh (the start mesh) is returned. Otherwise all the new created meshes are returned and this mesh fails to exist

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSMesh> Split()
Public Function Split As List(Of PSMesh)

Return Value

Type: List PSMesh
If the mesh cannot be divided further than itself then only one mesh (the start mesh) is returned. Otherwise all the new created meshes are returned and this mesh fails to exist
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.StartSculpt Method

PSMeshStartSculpt Method

Starts the interactive sculpting tool. It is finished or aborted using the ApplyScult and CancelSculpt operations

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StartSculpt(
    SculptTypes sculptType,
    float brushDiameter,
    float brushStrength,
    float brushSmoothness,
    bool limitDeviation = false,
    double maximumDeviation = 1,
    bool refineTriangles = false,
    float refineTolerance = 10f
)
Public Sub StartSculpt (
    sculptType As SculptTypes,
    brushDiameter As Single,
    brushStrength As Single,
    brushSmoothness As Single,
    Optional limitDeviation As Boolean = false,
    Optional maximumDeviation As Double = 1,
    Optional refineTriangles As Boolean = false,
    Optional refineTolerance As Single = 10F
)

Parameters

sculptType
Type: Autodesk.ProductInterface.PowerSHAPESculptTypes
This is type of sculpt to apply
brushDiameter
Type: SystemSingle
This is the diameter of the brush
brushStrength
Type: SystemSingle
This is the strength of the sculpt
brushSmoothness
Type: SystemSingle
This is the smoothness of the sculpt
limitDeviation (Optional)
Type: SystemBoolean
This determines whether or not to limit the amount the sculpt will change the mesh
maximumDeviation (Optional)
Type: SystemDouble
The maximum distance the sculpt will change the mesh by
refineTriangles (Optional)
Type: SystemBoolean
This determines whether or not to refine the triangles
refineTolerance (Optional)
Type: SystemSingle
In conjunction with refineTriangles specifies the tolerance for refinement
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.StitchTriangles Method

PSMeshStitchTriangles Method

Stitches the triangle mesh based on the specified values.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StitchTriangles(
    TriangleStitchIterationModes iterationMode,
    double startTolerance = 0.1,
    double endTolerance = 0.1,
    uint numberOfSteps = 10,
    bool stitchFullMesh = false,
    bool removeCoincidentNodes = false
)
Public Sub StitchTriangles (
    iterationMode As TriangleStitchIterationModes,
    Optional startTolerance As Double = 0.1,
    Optional endTolerance As Double = 0.1,
    Optional numberOfSteps As UInteger = 10,
    Optional stitchFullMesh As Boolean = false,
    Optional removeCoincidentNodes As Boolean = false
)

Parameters

iterationMode
Type: Autodesk.ProductInterface.PowerSHAPETriangleStitchIterationModes
The iteration mode is either Single or Multipass.
startTolerance (Optional)
Type: SystemDouble
Default 0.1.
endTolerance (Optional)
Type: SystemDouble
Default 0.1.
numberOfSteps (Optional)
Type: SystemUInt32
Default 10.
stitchFullMesh (Optional)
Type: SystemBoolean
If true, executes 'EXTRACTBOUNDARY' turning it off and executes 'REMOVECOINCIDENT' command according with 'removeCoincidentNodes' option.
removeCoincidentNodes (Optional)
Type: SystemBoolean
Executes 'REMOVECOINCIDENT' command turning it on or off.
Remarks
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.SubtractEntitiesFromEntity Method

PSMeshSubtractEntitiesFromEntity Method

Subtracts a collection of entities from another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity SubtractEntitiesFromEntity(
    IEnumerable<IPSSubtractable> entitiesToSubtract,
    bool copeWithCoincidentFaces = false
)
Public Function SubtractEntitiesFromEntity (
    entitiesToSubtract As IEnumerable(Of IPSSubtractable),
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entitiesToSubtract
Type: System.Collections.GenericIEnumerable IPSSubtractable
Entities to subtract
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the subtraction

Implements

IPSSubtractableSubtractEntitiesFromEntity(IEnumerableIPSSubtractable, Boolean)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.SubtractEntityFromEntity Method

PSMeshSubtractEntityFromEntity Method

Subtracts an entity from another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity SubtractEntityFromEntity(
    IPSSubtractable entityToSubtract,
    bool copeWithCoincidentFaces = false
)
Public Function SubtractEntityFromEntity (
    entityToSubtract As IPSSubtractable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToSubtract
Type: Autodesk.ProductInterface.PowerSHAPEIPSSubtractable
Entity to subtract
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the subtraction

Implements

IPSSubtractableSubtractEntityFromEntity(IPSSubtractable, Boolean)
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.ToDMTModel Method

PSMeshToDMTModel Method

Returns a DMT Model of the mesh

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTModel ToDMTModel()
Public Function ToDMTModel As DMTModel

Return Value

Type: DMTModel
A DMT Model of the Mesh
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.WriteToDMTFile Method

PSMeshWriteToDMTFile Method

Exports the mesh to the selected DMT file

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToDMTFile(
    File file
)
Public Sub WriteToDMTFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The DMT file name to export to
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh.WriteToSTLFile Method

PSMeshWriteToSTLFile Method

Exports the mesh to the selected STL file

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToSTLFile(
    File file
)
Public Sub WriteToSTLFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The STL file name to export to
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMesh Fields

The PSMesh type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSMesh Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshesCollection Class

Captures a collection of Meshes in a Project
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSMesh
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSMesh
Autodesk.ProductInterface.PowerSHAPEPSMeshesCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSMeshesCollection : PSEntitiesCollection<PSMesh>
Public Class PSMeshesCollection
    Inherits PSEntitiesCollection(Of PSMesh)

The PSMeshesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateMeshFromDMT | Creates a new Mesh from a DMT Model
Public method | CreateMeshFromFile | Creates a new Mesh from a specified file
Public method | CreateMeshFromSolid | Creates a new Mesh from a Solid
Public method | CreateMeshFromSurface | Creates a new Mesh from a Surface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshesCollection Properties

The PSMeshesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSMeshesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshesCollection Methods

The PSMeshesCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateMeshFromDMT | Creates a new Mesh from a DMT Model
Public method | CreateMeshFromFile | Creates a new Mesh from a specified file
Public method | CreateMeshFromSolid | Creates a new Mesh from a Solid
Public method | CreateMeshFromSurface | Creates a new Mesh from a Surface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSMeshesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshesCollection.CreateMeshFromDMT Method

PSMeshesCollectionCreateMeshFromDMT Method

Creates a new Mesh from a DMT Model

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMesh CreateMeshFromDMT(
    DMTModel model
)
Public Function CreateMeshFromDMT (
    model As DMTModel
) As PSMesh

Parameters

model
Type: Autodesk.GeometryDMTModel
The DMT Model from which to create the mesh

Return Value

Type: PSMesh
Mesh created by operation
See Also

Reference

PSMeshesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshesCollection.CreateMeshFromFile Method

PSMeshesCollectionCreateMeshFromFile Method

Creates a new Mesh from a specified file

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMesh CreateMeshFromFile(
    File file
)
Public Function CreateMeshFromFile (
    file As File
) As PSMesh

Parameters

file
Type: Autodesk.FileSystemFile
The file from which to create the mesh

Return Value

Type: PSMesh
Mesh created by operation
See Also

Reference

PSMeshesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshesCollection.CreateMeshFromSolid Method

PSMeshesCollectionCreateMeshFromSolid Method

Creates a new Mesh from a Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMesh CreateMeshFromSolid(
    PSSolid solid
)
Public Function CreateMeshFromSolid (
    solid As PSSolid
) As PSMesh

Parameters

solid
Type: Autodesk.ProductInterface.PowerSHAPEPSSolid
The Solid from which to create the mesh

Return Value

Type: PSMesh
Mesh created by operation
See Also

Reference

PSMeshesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshesCollection.CreateMeshFromSurface Method

PSMeshesCollectionCreateMeshFromSurface Method

Creates a new Mesh from a Surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMesh CreateMeshFromSurface(
    PSSurface surface
)
Public Function CreateMeshFromSurface (
    surface As PSSurface
) As PSMesh

Parameters

surface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The Surface from which to create the mesh

Return Value

Type: PSMesh
Mesh created by operation
See Also

Reference

PSMeshesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshesCollection Fields

The PSMeshesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSMeshesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker Class

This class allows the user to select triangles in a mesh using a variety of methods, and perform 3 separate actions on the selection.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSMeshTrianglePicker

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSMeshTrianglePicker
Public Class PSMeshTrianglePicker

The PSMeshTrianglePicker type exposes the following members.

Constructors
 | Name | Description
Public method | PSMeshTrianglePicker | Creates new instance.
Top
Properties
 | Name | Description
Public property | AngleForHorizonOrDiscontinuity | Gets the previous set value and Sets the angle for horizon or discontinuity mode in PowerShape.
Public property | Mode | Gets the previous set value and Sets the triangle pick mode in PowerShape.
Top
Methods
 | Name | Description
Public method | DeleteSelectedTriangles | Deletes selected triangles.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MaskSelectedTriangles | Masks selected triangles.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartPicking | Starts the picking operation.
Public method | StopPicking | Stops picking operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnmaskSelectedTriangles | Unmask selected triangles.
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker Constructor

Creates new instance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMeshTrianglePicker(
    PSMesh mesh,
    TrianglePickMode pickMode = TrianglePickMode.ContinuousLasso
)
Public Sub New (
    mesh As PSMesh,
    Optional pickMode As TrianglePickMode = TrianglePickMode.ContinuousLasso
)

Parameters

mesh
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
Initialises the mesh.
pickMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPETrianglePickMode
Initialises the pick mode.
Remarks
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker Properties

The PSMeshTrianglePicker type exposes the following members.

Properties
 | Name | Description
Public property | AngleForHorizonOrDiscontinuity | Gets the previous set value and Sets the angle for horizon or discontinuity mode in PowerShape.
Public property | Mode | Gets the previous set value and Sets the triangle pick mode in PowerShape.
Top
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker.AngleForHorizonOrDiscontinuity Property

PSMeshTrianglePickerAngleForHorizonOrDiscontinuity Property

Gets the previous set value and Sets the angle for horizon or discontinuity mode in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree AngleForHorizonOrDiscontinuity { get; set; }
Public Property AngleForHorizonOrDiscontinuity As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker.Mode Property

PSMeshTrianglePickerMode Property

Gets the previous set value and Sets the triangle pick mode in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public TrianglePickMode Mode { get; set; }
Public Property Mode As TrianglePickMode
    Get
    Set

Property Value

Type: TrianglePickMode

Return Value

Type: TrianglePickMode
Remarks
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker Methods

The PSMeshTrianglePicker type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSelectedTriangles | Deletes selected triangles.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MaskSelectedTriangles | Masks selected triangles.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartPicking | Starts the picking operation.
Public method | StopPicking | Stops picking operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnmaskSelectedTriangles | Unmask selected triangles.
Top
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker.DeleteSelectedTriangles Method

PSMeshTrianglePickerDeleteSelectedTriangles Method

Deletes selected triangles.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeleteSelectedTriangles()
Public Sub DeleteSelectedTriangles
Remarks
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker.MaskSelectedTriangles Method

PSMeshTrianglePickerMaskSelectedTriangles Method

Masks selected triangles.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MaskSelectedTriangles()
Public Sub MaskSelectedTriangles
Remarks
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker.StartPicking Method

PSMeshTrianglePickerStartPicking Method

Starts the picking operation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StartPicking()
Public Sub StartPicking
Remarks
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker.StopPicking Method

PSMeshTrianglePickerStopPicking Method

Stops picking operation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StopPicking()
Public Sub StopPicking
Remarks
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSMeshTrianglePicker.UnmaskSelectedTriangles Method

PSMeshTrianglePickerUnmaskSelectedTriangles Method

Unmask selected triangles.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void UnmaskSelectedTriangles()
Public Sub UnmaskSelectedTriangles
Remarks
See Also

Reference

PSMeshTrianglePicker Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel Class

Captures a Model in PowerSHAPE.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSModel

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSModel : PSDatabaseEntity
Public Class PSModel
    Inherits PSDatabaseEntity

The PSModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveLevels | The currently active Levels.
Public property | ActiveWorkplane | Returns the currently active Workplane or Nothing if World is active.
Public property | Annotations | Gets the collection of Annotations in the Model.
Public property | Arcs | Gets the collection of Arcs in the Model.
Public property | BoundingBoxOfSelectedItems | Gets the BoundingBox of the selection in PowerSHAPE. If no items are currently selected then the return value is null
Public property | CompCurves | Gets the Collection of CompCurves in the Model.
Public property | CreatedItems | Gets the created items in the model.
Public property | Curves | Gets the collection of Curves in the Model.
Public property | Electrodes | Gets the collection of Electrodes in the Model.
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | GeneralTolerance | Gets and sets the general tolerance of the model.
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsCorrupt | Gets whether the Model is corrupt.
Public property | IsLevelActiveFilterOn | Gets and sets the active filter when interrogating Levels.
Public property | IsLevelNamedFilterOn | Gets and sets the named filter when interrogating Levels.
Public property | IsLevelUsedFilterOn | Gets and sets the used filter when interrogating Levels.
Public property | IsSelected | Gets whether the Model is selected.
Public property | Levels | Gets the collection of Levels in the model.
Public property | Lines | Gets the Collection of Lines in the Model.
Public property | Materials | Gets the collection of Materials in the model.
Public property | Meshes | Gets the collection of Meshes in the model.
Public property | Name | Gets the name of the model. (Overrides PSDatabaseEntityName.)
Public property | NamedLevels | The currently named Levels.
Public property | Path | Gets the path to the Model file.
Public property | Points | Gets the collection of Points in the model.
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | SelectedItems | Get the selected items in the model.
Public property | Solids | Gets the collection of Solids in the model.
Public property | Surfaces | Gets the collection of Surfaces in the model.
Public property | TemporaryWorkplane | The model's temporary workplane
Public property | UpdatedItems | Gets the updated items in the model.
Public property | UsedLevels | The currently used Levels.
Public property | Window | Gets the window to which this model is attached.
Public property | Workplanes | Gets the collection of Workplanes in the Model.
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | BlankToggle | This option blanks all visible objects and unblanks all previously blanked objects.
Public method | ClearCreatedItems | Clears the list of created items.
Public method | ClearSelectedItems | Clears the list of selected items.
Public method | ClearUpdatedItems | Clears the list of updated items.
Public method | CreateTemporaryWorkplane | Creates a temporary workplane at the specified origin aligned to the current workplane.
Public method | DeactivateAllSolids | Deactivates the active solid (if there is one), preventing headaches when performing a feature operation.
Public method | Delete | Closes this model
Public method | DeleteTemporaryWorkplane | Deletes the temporary workplane.
Public method | EndSurfaceComparison | Operation exits surface comparison mode.
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Export | Exports the selected geometry to create the desired file.
Public method | ExportScreenshot | Exports a screenshot, using PowerSHAPE's Print To File functionality.
Public method | ExportSurfaceComparisonErrorsFile | Outputs a text file containing the Surface Comparison errors.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNearestSurface | Gets the nearest surface to the specified point as well as the nearest point on that surface
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | This operation imports the desired file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintDrawings | Print the specified drawings to the specified printer
Public method | Redo | Performs a redo in PowerSHAPE.
Public method | Refresh | Refreshes the information available in the current model. Refresh should retain any existing items in the lists, add new ones and remove old ones. This function would be used by someone after they have used the "Execute" functionality.
Public method | ResetUI | Resets the User Interface, cancelling any open dialogs ready for normal operation.
Public method | Retriangulate | Retriangulate model to its current shading tolerance.
Public method | Save | Saves the current model.
Public method | SelectAll | Selects everything in the Model that is currently visible.
Public method | SelectEntities | Selects multiple entities in as few commands as possible.
Public method | SetCreationLevel(Int32) | Sets the creation level for new items
Public method | SetCreationLevel(PSLevel) | Sets the creation level for new items
Public method | SetUndoMarker | Sets an undo marker in PowerSHAPE.
Public method | StartSurfaceComparison(PSMesh, PSMesh) | Compares two meshes in PowerSHAPE and displays any selection errors.
Public method | StartSurfaceComparison(PSSurface, PSMesh) | Compares a surface/mesh in PowerSHAPE and displays any selection errors.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unblank | Unblanks anything that is currently Blanked.
Public method | Undo | Performs an undo in PowerSHAPE.
Top
Fields
 | Name | Description
Protected field | _annotationsCollection | . The List of Annotations in the Model.
Protected field | _arcsCollection | The List of Arcs in the Model.
Protected field | _compCurvesCollection | The List of CompCurves in the Model.
Protected field | _curvesCollection | The List of Curves in the Model.
Protected field | _electrodesCollection | The List of Electrodes in the Model.
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _isListsDirty | This flag indicates that the Lists of items are out of date and need to be rebuilt.
Protected field | _levelsCollection | The List of Levels in the Model.
Protected field | _linesCollection | The List of Lines in the Model.
Protected field | _materialsCollection | The List of Materials in the Model.
Protected field | _meshesCollection | The List of Meshes in the Model.
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _pointsCollection | The List of Points in the Model.
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _solidsCollection | . The List of Solids in the Model.
Protected field | _surfacesCollection | The List of Surfaces in the Model.
Protected field | _workplanesCollection | The List of Workplanes in the Model.
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel Properties

The PSModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveLevels | The currently active Levels.
Public property | ActiveWorkplane | Returns the currently active Workplane or Nothing if World is active.
Public property | Annotations | Gets the collection of Annotations in the Model.
Public property | Arcs | Gets the collection of Arcs in the Model.
Public property | BoundingBoxOfSelectedItems | Gets the BoundingBox of the selection in PowerSHAPE. If no items are currently selected then the return value is null
Public property | CompCurves | Gets the Collection of CompCurves in the Model.
Public property | CreatedItems | Gets the created items in the model.
Public property | Curves | Gets the collection of Curves in the Model.
Public property | Electrodes | Gets the collection of Electrodes in the Model.
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | GeneralTolerance | Gets and sets the general tolerance of the model.
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsCorrupt | Gets whether the Model is corrupt.
Public property | IsLevelActiveFilterOn | Gets and sets the active filter when interrogating Levels.
Public property | IsLevelNamedFilterOn | Gets and sets the named filter when interrogating Levels.
Public property | IsLevelUsedFilterOn | Gets and sets the used filter when interrogating Levels.
Public property | IsSelected | Gets whether the Model is selected.
Public property | Levels | Gets the collection of Levels in the model.
Public property | Lines | Gets the Collection of Lines in the Model.
Public property | Materials | Gets the collection of Materials in the model.
Public property | Meshes | Gets the collection of Meshes in the model.
Public property | Name | Gets the name of the model. (Overrides PSDatabaseEntityName.)
Public property | NamedLevels | The currently named Levels.
Public property | Path | Gets the path to the Model file.
Public property | Points | Gets the collection of Points in the model.
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | SelectedItems | Get the selected items in the model.
Public property | Solids | Gets the collection of Solids in the model.
Public property | Surfaces | Gets the collection of Surfaces in the model.
Public property | TemporaryWorkplane | The model's temporary workplane
Public property | UpdatedItems | Gets the updated items in the model.
Public property | UsedLevels | The currently used Levels.
Public property | Window | Gets the window to which this model is attached.
Public property | Workplanes | Gets the collection of Workplanes in the Model.
Top
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.ActiveLevels Property

PSModelActiveLevels Property

The currently active Levels.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSLevel> ActiveLevels { get; }
Public ReadOnly Property ActiveLevels As List(Of PSLevel)
    Get

Return Value

Type: List PSLevel
The list of the active Levels.
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.ActiveWorkplane Property

PSModelActiveWorkplane Property

Returns the currently active Workplane or Nothing if World is active.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane ActiveWorkplane { get; set; }
Public Property ActiveWorkplane As PSWorkplane
    Get
    Set

Return Value

Type: PSWorkplane
The Active Workplane or Nothing if World is the Active Workplane.
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Annotations Property

PSModelAnnotations Property

Gets the collection of Annotations in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSAnnotationsCollection Annotations { get; }
Public ReadOnly Property Annotations As PSAnnotationsCollection
    Get

Property Value

Type: PSAnnotationsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Arcs Property

PSModelArcs Property

Gets the collection of Arcs in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSArcsCollection Arcs { get; }
Public ReadOnly Property Arcs As PSArcsCollection
    Get

Property Value

Type: PSArcsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.BoundingBoxOfSelectedItems Property

PSModelBoundingBoxOfSelectedItems Property

Gets the BoundingBox of the selection in PowerSHAPE. If no items are currently selected then the return value is null

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public BoundingBox BoundingBoxOfSelectedItems { get; }
Public ReadOnly Property BoundingBoxOfSelectedItems As BoundingBox
    Get

Return Value

Type: BoundingBox
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.CompCurves Property

PSModelCompCurves Property

Gets the Collection of CompCurves in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCompCurvesCollection CompCurves { get; }
Public ReadOnly Property CompCurves As PSCompCurvesCollection
    Get

Property Value

Type: PSCompCurvesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.CreatedItems Property

PSModelCreatedItems Property

Gets the created items in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> CreatedItems { get; }
Public ReadOnly Property CreatedItems As List(Of PSEntity)
    Get

Property Value

Type: List PSEntity
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Curves Property

PSModelCurves Property

Gets the collection of Curves in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCurvesCollection Curves { get; }
Public ReadOnly Property Curves As PSCurvesCollection
    Get

Property Value

Type: PSCurvesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Electrodes Property

PSModelElectrodes Property

Gets the collection of Electrodes in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSElectrodesCollection Electrodes { get; }
Public ReadOnly Property Electrodes As PSElectrodesCollection
    Get

Property Value

Type: PSElectrodesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.GeneralTolerance Property

PSModelGeneralTolerance Property

Gets and sets the general tolerance of the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GeneralTolerance { get; set; }
Public Property GeneralTolerance As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.IsCorrupt Property

PSModelIsCorrupt Property

Gets whether the Model is corrupt.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsCorrupt { get; }
Public ReadOnly Property IsCorrupt As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.IsLevelActiveFilterOn Property

PSModelIsLevelActiveFilterOn Property

Gets and sets the active filter when interrogating Levels.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsLevelActiveFilterOn { get; set; }
Public Property IsLevelActiveFilterOn As Boolean
    Get
    Set

Return Value

Type: Boolean
The status of the active filter.
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.IsLevelNamedFilterOn Property

PSModelIsLevelNamedFilterOn Property

Gets and sets the named filter when interrogating Levels.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsLevelNamedFilterOn { get; set; }
Public Property IsLevelNamedFilterOn As Boolean
    Get
    Set

Return Value

Type: Boolean
The status of the named filter.
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.IsLevelUsedFilterOn Property

PSModelIsLevelUsedFilterOn Property

Gets and sets the used filter when interrogating Levels.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsLevelUsedFilterOn { get; set; }
Public Property IsLevelUsedFilterOn As Boolean
    Get
    Set

Return Value

Type: Boolean
The status of the used filter.
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.IsSelected Property

PSModelIsSelected Property

Gets whether the Model is selected.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsSelected { get; }
Public ReadOnly Property IsSelected As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Levels Property

PSModelLevels Property

Gets the collection of Levels in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSLevelsCollection Levels { get; }
Public ReadOnly Property Levels As PSLevelsCollection
    Get

Property Value

Type: PSLevelsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Lines Property

PSModelLines Property

Gets the Collection of Lines in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSLinesCollection Lines { get; }
Public ReadOnly Property Lines As PSLinesCollection
    Get

Property Value

Type: PSLinesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Materials Property

PSModelMaterials Property

Gets the collection of Materials in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMaterialsCollection Materials { get; }
Public ReadOnly Property Materials As PSMaterialsCollection
    Get

Property Value

Type: PSMaterialsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Meshes Property

PSModelMeshes Property

Gets the collection of Meshes in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMeshesCollection Meshes { get; }
Public ReadOnly Property Meshes As PSMeshesCollection
    Get

Property Value

Type: PSMeshesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Name Property

PSModelName Property

Gets the name of the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.NamedLevels Property

PSModelNamedLevels Property

The currently named Levels.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSLevel> NamedLevels { get; }
Public ReadOnly Property NamedLevels As List(Of PSLevel)
    Get

Property Value

Type: List PSLevel
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Path Property

PSModelPath Property

Gets the path to the Model file.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Points Property

PSModelPoints Property

Gets the collection of Points in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSPointsCollection Points { get; }
Public ReadOnly Property Points As PSPointsCollection
    Get

Property Value

Type: PSPointsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.SelectedItems Property

PSModelSelectedItems Property

Get the selected items in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> SelectedItems { get; }
Public ReadOnly Property SelectedItems As List(Of PSEntity)
    Get

Property Value

Type: List PSEntity
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Solids Property

PSModelSolids Property

Gets the collection of Solids in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSolidsCollection Solids { get; }
Public ReadOnly Property Solids As PSSolidsCollection
    Get

Property Value

Type: PSSolidsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Surfaces Property

PSModelSurfaces Property

Gets the collection of Surfaces in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurfacesCollection Surfaces { get; }
Public ReadOnly Property Surfaces As PSSurfacesCollection
    Get

Property Value

Type: PSSurfacesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.TemporaryWorkplane Property

PSModelTemporaryWorkplane Property

The model's temporary workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane TemporaryWorkplane { get; set; }
Public Property TemporaryWorkplane As PSWorkplane
    Get
    Set

Property Value

Type: PSWorkplane
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.UpdatedItems Property

PSModelUpdatedItems Property

Gets the updated items in the model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> UpdatedItems { get; }
Public ReadOnly Property UpdatedItems As List(Of PSEntity)
    Get

Property Value

Type: List PSEntity
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.UsedLevels Property

PSModelUsedLevels Property

The currently used Levels.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSLevel> UsedLevels { get; }
Public ReadOnly Property UsedLevels As List(Of PSLevel)
    Get

Property Value

Type: List PSLevel
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Window Property

PSModelWindow Property

Gets the window to which this model is attached.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWindow Window { get; }
Public ReadOnly Property Window As PSWindow
    Get

Property Value

Type: PSWindow
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Workplanes Property

PSModelWorkplanes Property

Gets the collection of Workplanes in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplanesCollection Workplanes { get; }
Public ReadOnly Property Workplanes As PSWorkplanesCollection
    Get

Property Value

Type: PSWorkplanesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel Methods

The PSModel type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | BlankToggle | This option blanks all visible objects and unblanks all previously blanked objects.
Public method | ClearCreatedItems | Clears the list of created items.
Public method | ClearSelectedItems | Clears the list of selected items.
Public method | ClearUpdatedItems | Clears the list of updated items.
Public method | CreateTemporaryWorkplane | Creates a temporary workplane at the specified origin aligned to the current workplane.
Public method | DeactivateAllSolids | Deactivates the active solid (if there is one), preventing headaches when performing a feature operation.
Public method | Delete | Closes this model
Public method | DeleteTemporaryWorkplane | Deletes the temporary workplane.
Public method | EndSurfaceComparison | Operation exits surface comparison mode.
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Export | Exports the selected geometry to create the desired file.
Public method | ExportScreenshot | Exports a screenshot, using PowerSHAPE's Print To File functionality.
Public method | ExportSurfaceComparisonErrorsFile | Outputs a text file containing the Surface Comparison errors.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNearestSurface | Gets the nearest surface to the specified point as well as the nearest point on that surface
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | This operation imports the desired file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintDrawings | Print the specified drawings to the specified printer
Public method | Redo | Performs a redo in PowerSHAPE.
Public method | Refresh | Refreshes the information available in the current model. Refresh should retain any existing items in the lists, add new ones and remove old ones. This function would be used by someone after they have used the "Execute" functionality.
Public method | ResetUI | Resets the User Interface, cancelling any open dialogs ready for normal operation.
Public method | Retriangulate | Retriangulate model to its current shading tolerance.
Public method | Save | Saves the current model.
Public method | SelectAll | Selects everything in the Model that is currently visible.
Public method | SelectEntities | Selects multiple entities in as few commands as possible.
Public method | SetCreationLevel(Int32) | Sets the creation level for new items
Public method | SetCreationLevel(PSLevel) | Sets the creation level for new items
Public method | SetUndoMarker | Sets an undo marker in PowerSHAPE.
Public method | StartSurfaceComparison(PSMesh, PSMesh) | Compares two meshes in PowerSHAPE and displays any selection errors.
Public method | StartSurfaceComparison(PSSurface, PSMesh) | Compares a surface/mesh in PowerSHAPE and displays any selection errors.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unblank | Unblanks anything that is currently Blanked.
Public method | Undo | Performs an undo in PowerSHAPE.
Top
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.BlankToggle Method

PSModelBlankToggle Method

This option blanks all visible objects and unblanks all previously blanked objects.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void BlankToggle()
Public Sub BlankToggle
Remarks
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.ClearCreatedItems Method

PSModelClearCreatedItems Method

Clears the list of created items.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ClearCreatedItems()
Public Sub ClearCreatedItems
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.ClearSelectedItems Method

PSModelClearSelectedItems Method

Clears the list of selected items.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ClearSelectedItems()
Public Sub ClearSelectedItems
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.ClearUpdatedItems Method

PSModelClearUpdatedItems Method

Clears the list of updated items.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ClearUpdatedItems()
Public Sub ClearUpdatedItems
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.CreateTemporaryWorkplane Method

PSModelCreateTemporaryWorkplane Method

Creates a temporary workplane at the specified origin aligned to the current workplane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void CreateTemporaryWorkplane(
    Point origin
)
Public Sub CreateTemporaryWorkplane (
    origin As Point
)

Parameters

origin
Type: Autodesk.GeometryPoint
The origin of the temporary workplane.
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.DeactivateAllSolids Method

PSModelDeactivateAllSolids Method

Deactivates the active solid (if there is one), preventing headaches when performing a feature operation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeactivateAllSolids()
Public Sub DeactivateAllSolids
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Delete Method

PSModelDelete Method

Closes this model

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Delete()
Public Sub Delete
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.DeleteTemporaryWorkplane Method

PSModelDeleteTemporaryWorkplane Method

Deletes the temporary workplane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeleteTemporaryWorkplane()
Public Sub DeleteTemporaryWorkplane
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.EndSurfaceComparison Method

PSModelEndSurfaceComparison Method

Operation exits surface comparison mode.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EndSurfaceComparison()
Public Sub EndSurfaceComparison
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Export Method

PSModelExport Method

Exports the selected geometry to create the desired file.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Export(
    File exportFile,
    ExportItemsOptions exportItemsOption = ExportItemsOptions.All,
    ExportWorkplanes exportWorkplaneOption = ExportWorkplanes.World
)
Public Sub Export (
    exportFile As File,
    Optional exportItemsOption As ExportItemsOptions = ExportItemsOptions.All,
    Optional exportWorkplaneOption As ExportWorkplanes = ExportWorkplanes.World
)

Parameters

exportFile
Type: Autodesk.FileSystemFile
The file that will be created after exporting the geometry.
exportItemsOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPEExportItemsOptions
The model items to export.
exportWorkplaneOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPEExportWorkplanes
The workplane to export.
Remarks
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.ExportScreenshot Method

PSModelExportScreenshot Method

Exports a screenshot, using PowerSHAPE's Print To File functionality.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ExportScreenshot(
    File outputLocation
)
Public Sub ExportScreenshot (
    outputLocation As File
)

Parameters

outputLocation
Type: Autodesk.FileSystemFile
A jpg file of the screenshot.
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.ExportSurfaceComparisonErrorsFile Method

PSModelExportSurfaceComparisonErrorsFile Method

Outputs a text file containing the Surface Comparison errors.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ExportSurfaceComparisonErrorsFile(
    File outputFile
)
Public Sub ExportSurfaceComparisonErrorsFile (
    outputFile As File
)

Parameters

outputFile
Type: Autodesk.FileSystemFile
The file path were errors will be written.
Remarks
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.GetNearestSurface Method

PSModelGetNearestSurface Method

Gets the nearest surface to the specified point as well as the nearest point on that surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface GetNearestSurface(
    Point referencePoint,
    ref Point nearestPoint,
    bool useWorldCoordinates = false
)
Public Function GetNearestSurface (
    referencePoint As Point,
    ByRef nearestPoint As Point,
    Optional useWorldCoordinates As Boolean = false
) As PSSurface

Parameters

referencePoint
Type: Autodesk.GeometryPoint
The point to use for finding the nearest surface
nearestPoint
Type: Autodesk.GeometryPoint
Returns the nearest point on the nearest surface. Or null if the nearest surface cannot be found
useWorldCoordinates (Optional)
Type: SystemBoolean
Whether or not to return the nearest point on the surface in world coordinates

Return Value

Type: PSSurface
The nearest surface or null if the nearest surface cannot be found
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Import Method

PSModelImport Method

This operation imports the desired file.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Import(
    File file
)
Public Function Import (
    file As File
) As List(Of PSEntity)

Parameters

file
Type: Autodesk.FileSystemFile
The file to be imported.

Return Value

Type: List PSEntity
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.PrintDrawings Method

PSModelPrintDrawings Method

Print the specified drawings to the specified printer

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void PrintDrawings(
    string printerName,
    string[] drawings
)
Public Sub PrintDrawings (
    printerName As String,
    drawings As String()
)

Parameters

printerName
Type: SystemString
Printer name
drawings
Type: SystemString
Drawings to print
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Redo Method

PSModelRedo Method

Performs a redo in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Redo()
Public Sub Redo
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Refresh Method

PSModelRefresh Method

Refreshes the information available in the current model. Refresh should retain any existing items in the lists, add new ones and remove old ones. This function would be used by someone after they have used the "Execute" functionality.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.ResetUI Method

PSModelResetUI Method

Resets the User Interface, cancelling any open dialogs ready for normal operation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ResetUI()
Public Sub ResetUI
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Retriangulate Method

PSModelRetriangulate Method

Retriangulate model to its current shading tolerance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Retriangulate()
Public Sub Retriangulate
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Save Method

PSModelSave Method

Saves the current model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Save(
    File file = null
)
Public Sub Save (
    Optional file As File = Nothing
)

Parameters

file (Optional)
Type: Autodesk.FileSystemFile
The file path to save the model.
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.SelectAll Method

PSModelSelectAll Method

Selects everything in the Model that is currently visible.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SelectAll(
    bool enableDeactivatedLevels = false
)
Public Sub SelectAll (
    Optional enableDeactivatedLevels As Boolean = false
)

Parameters

enableDeactivatedLevels (Optional)
Type: SystemBoolean
If true, switches filters to be as required.
Remarks
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.SelectEntities Method

PSModelSelectEntities Method

Selects multiple entities in as few commands as possible.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SelectEntities(
    IEnumerable<PSEntity> entities,
    bool emptySelectionFirst = false
)
Public Sub SelectEntities (
    entities As IEnumerable(Of PSEntity),
    Optional emptySelectionFirst As Boolean = false
)

Parameters

entities
Type: System.Collections.GenericIEnumerable PSEntity
The entities to select.
emptySelectionFirst (Optional)
Type: SystemBoolean
If True, empties the selection first.
Remarks
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.SetCreationLevel Method

PSModelSetCreationLevel Method

Overload List
 | Name | Description
Public method | SetCreationLevel(Int32) | Sets the creation level for new items
Public method | SetCreationLevel(PSLevel) | Sets the creation level for new items
Top
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.SetCreationLevel Method (Int32)

PSModelSetCreationLevel Method (Int32)

Sets the creation level for new items

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetCreationLevel(
    int creationLevel
)
Public Sub SetCreationLevel (
    creationLevel As Integer
)

Parameters

creationLevel
Type: SystemInt32
The creation level to be used
Exceptions
Exception | Condition
Exception | The specified level does not exist
See Also

Reference

PSModel Class
SetCreationLevel Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.SetCreationLevel Method (PSLevel)

PSModelSetCreationLevel Method (PSLevel)

Sets the creation level for new items

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetCreationLevel(
    PSLevel creationLevel
)
Public Sub SetCreationLevel (
    creationLevel As PSLevel
)

Parameters

creationLevel
Type: Autodesk.ProductInterface.PowerSHAPEPSLevel
The creation level to be used
See Also

Reference

PSModel Class
SetCreationLevel Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.SetUndoMarker Method

PSModelSetUndoMarker Method

Sets an undo marker in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SetUndoMarker()
Public Sub SetUndoMarker
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.StartSurfaceComparison Method

PSModelStartSurfaceComparison Method

Overload List
 | Name | Description
Public method | StartSurfaceComparison(PSMesh, PSMesh) | Compares two meshes in PowerSHAPE and displays any selection errors.
Public method | StartSurfaceComparison(PSSurface, PSMesh) | Compares a surface/mesh in PowerSHAPE and displays any selection errors.
Top
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.StartSurfaceComparison Method (PSMesh, PSMesh)

PSModelStartSurfaceComparison Method (PSMesh, PSMesh)

Compares two meshes in PowerSHAPE and displays any selection errors.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StartSurfaceComparison(
    PSMesh meshToCompare,
    PSMesh meshToCompareTo
)
Public Sub StartSurfaceComparison (
    meshToCompare As PSMesh,
    meshToCompareTo As PSMesh
)

Parameters

meshToCompare
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
First mesh used in the comparison.
meshToCompareTo
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
Second mesh used in the comparison.
Remarks
See Also

Reference

PSModel Class
StartSurfaceComparison Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.StartSurfaceComparison Method (PSSurface, PSMesh)

PSModelStartSurfaceComparison Method (PSSurface, PSMesh)

Compares a surface/mesh in PowerSHAPE and displays any selection errors.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StartSurfaceComparison(
    PSSurface surfaceToCompare,
    PSMesh meshToCompare
)
Public Sub StartSurfaceComparison (
    surfaceToCompare As PSSurface,
    meshToCompare As PSMesh
)

Parameters

surfaceToCompare
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface to compare.
meshToCompare
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
The mesh to compare.
Remarks
See Also

Reference

PSModel Class
StartSurfaceComparison Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Unblank Method

PSModelUnblank Method

Unblanks anything that is currently Blanked.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Unblank()
Public Sub Unblank
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel.Undo Method

PSModelUndo Method

Performs an undo in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Undo()
Public Sub Undo
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel Fields

The PSModel type exposes the following members.

Fields
 | Name | Description
Protected field | _annotationsCollection | . The List of Annotations in the Model.
Protected field | _arcsCollection | The List of Arcs in the Model.
Protected field | _compCurvesCollection | The List of CompCurves in the Model.
Protected field | _curvesCollection | The List of Curves in the Model.
Protected field | _electrodesCollection | The List of Electrodes in the Model.
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _isListsDirty | This flag indicates that the Lists of items are out of date and need to be rebuilt.
Protected field | _levelsCollection | The List of Levels in the Model.
Protected field | _linesCollection | The List of Lines in the Model.
Protected field | _materialsCollection | The List of Materials in the Model.
Protected field | _meshesCollection | The List of Meshes in the Model.
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _pointsCollection | The List of Points in the Model.
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _solidsCollection | . The List of Solids in the Model.
Protected field | _surfacesCollection | The List of Surfaces in the Model.
Protected field | _workplanesCollection | The List of Workplanes in the Model.
Top
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._annotationsCollection Field

PSModel_annotationsCollection Field

. The List of Annotations in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSAnnotationsCollection _annotationsCollection
Protected _annotationsCollection As PSAnnotationsCollection

Field Value

Type: PSAnnotationsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._arcsCollection Field

PSModel_arcsCollection Field

The List of Arcs in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSArcsCollection _arcsCollection
Protected _arcsCollection As PSArcsCollection

Field Value

Type: PSArcsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._compCurvesCollection Field

PSModel_compCurvesCollection Field

The List of CompCurves in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSCompCurvesCollection _compCurvesCollection
Protected _compCurvesCollection As PSCompCurvesCollection

Field Value

Type: PSCompCurvesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._curvesCollection Field

PSModel_curvesCollection Field

The List of Curves in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSCurvesCollection _curvesCollection
Protected _curvesCollection As PSCurvesCollection

Field Value

Type: PSCurvesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._electrodesCollection Field

PSModel_electrodesCollection Field

The List of Electrodes in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSElectrodesCollection _electrodesCollection
Protected _electrodesCollection As PSElectrodesCollection

Field Value

Type: PSElectrodesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._isListsDirty Field

PSModel_isListsDirty Field

This flag indicates that the Lists of items are out of date and need to be rebuilt.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected bool _isListsDirty
Protected _isListsDirty As Boolean

Field Value

Type: Boolean
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._levelsCollection Field

PSModel_levelsCollection Field

The List of Levels in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSLevelsCollection _levelsCollection
Protected _levelsCollection As PSLevelsCollection

Field Value

Type: PSLevelsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._linesCollection Field

PSModel_linesCollection Field

The List of Lines in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSLinesCollection _linesCollection
Protected _linesCollection As PSLinesCollection

Field Value

Type: PSLinesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._materialsCollection Field

PSModel_materialsCollection Field

The List of Materials in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSMaterialsCollection _materialsCollection
Protected _materialsCollection As PSMaterialsCollection

Field Value

Type: PSMaterialsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._meshesCollection Field

PSModel_meshesCollection Field

The List of Meshes in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSMeshesCollection _meshesCollection
Protected _meshesCollection As PSMeshesCollection

Field Value

Type: PSMeshesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._pointsCollection Field

PSModel_pointsCollection Field

The List of Points in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSPointsCollection _pointsCollection
Protected _pointsCollection As PSPointsCollection

Field Value

Type: PSPointsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._solidsCollection Field

PSModel_solidsCollection Field

. The List of Solids in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSSolidsCollection _solidsCollection
Protected _solidsCollection As PSSolidsCollection

Field Value

Type: PSSolidsCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._surfacesCollection Field

PSModel_surfacesCollection Field

The List of Surfaces in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSSurfacesCollection _surfacesCollection
Protected _surfacesCollection As PSSurfacesCollection

Field Value

Type: PSSurfacesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModel._workplanesCollection Field

PSModel_workplanesCollection Field

The List of Workplanes in the Model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSWorkplanesCollection _workplanesCollection
Protected _workplanesCollection As PSWorkplanesCollection

Field Value

Type: PSWorkplanesCollection
See Also

Reference

PSModel Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection Class

Captures the list of open models in PowerSHAPE.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSModel
Autodesk.ProductInterface.PowerSHAPEPSModelsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSModelsCollection : PSDatabaseEntitiesCollection<PSModel>
Public Class PSModelsCollection
    Inherits PSDatabaseEntitiesCollection(Of PSModel)

The PSModelsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed model from the the collection.
Public property | ItemString | Gets the desired named model from the the collection.
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Clear | Closes and removes all models in the list. Closes all windows. (Overrides PSDatabaseEntitiesCollectionTClear.)
Public method | Contains(T) | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Contains(File) | Checks whether the models collection contains a model of the specified name.
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateEmptyModel | Creates a new empty model in PowerSHAPE.
Public method | CreateModelFromFile | Creates a new Model from a PowerSHAPE model file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the model with the specified name from the collection. Closes all windows associated with the selected model.
Public method | Remove(PSModel) | Removes the specified model. Closes all windows associated with the selected model.
Public method | RemoveAt | Removes the model at the specified index from the collection. Closes all windows associated with the selected model. (Overrides PSDatabaseEntitiesCollectionTRemoveAt(Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection Properties

The PSModelsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed model from the the collection.
Public property | ItemString | Gets the desired named model from the the collection.
Top
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Item Property

PSModelsCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets the desired indexed model from the the collection.
Public property | ItemString | Gets the desired named model from the the collection.
Top
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Item Property (Int32)

PSModelsCollectionItem Property (Int32)

Gets the desired indexed model from the the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSModel this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As PSModel
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: PSModel
The index of the desired model.

Return Value

Type: PSModel
The desired model.
See Also

Reference

PSModelsCollection Class
Item Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Item Property (String)

PSModelsCollectionItem Property (String)

Gets the desired named model from the the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSModel this[
    string name
] { get; set; }
Public Default Property Item (
    name As String
) As PSModel
    Get
    Set

Parameters

name
Type: SystemString

Property Value

Type: PSModel
The name of the desired model.

Return Value

Type: PSModel
The desired model.
See Also

Reference

PSModelsCollection Class
Item Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection Methods

The PSModelsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Clear | Closes and removes all models in the list. Closes all windows. (Overrides PSDatabaseEntitiesCollectionTClear.)
Public method | Contains(T) | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Contains(File) | Checks whether the models collection contains a model of the specified name.
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateEmptyModel | Creates a new empty model in PowerSHAPE.
Public method | CreateModelFromFile | Creates a new Model from a PowerSHAPE model file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the model with the specified name from the collection. Closes all windows associated with the selected model.
Public method | Remove(PSModel) | Removes the specified model. Closes all windows associated with the selected model.
Public method | RemoveAt | Removes the model at the specified index from the collection. Closes all windows associated with the selected model. (Overrides PSDatabaseEntitiesCollectionTRemoveAt(Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Clear Method

PSModelsCollectionClear Method

Closes and removes all models in the list. Closes all windows.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Clear()
Public Overrides Sub Clear
Remarks
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Contains Method

PSModelsCollectionContains Method

Overload List
 | Name | Description
Public method | Contains(T) | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Contains(File) | Checks whether the models collection contains a model of the specified name.
Top
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Contains Method (File)

PSModelsCollectionContains Method (File)

Checks whether the models collection contains a model of the specified name.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Contains(
    File file
)
Public Function Contains (
    file As File
) As Boolean

Parameters

file
Type: Autodesk.FileSystemFile
A Delcam file indicating the model to be found.

Return Value

Type: Boolean
A boolean indicating whether the model has been found.
See Also

Reference

PSModelsCollection Class
Contains Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.CreateEmptyModel Method

PSModelsCollectionCreateEmptyModel Method

Creates a new empty model in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSModel CreateEmptyModel()
Public Function CreateEmptyModel As PSModel

Return Value

Type: PSModel
The created empty model.
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.CreateModelFromFile Method

PSModelsCollectionCreateModelFromFile Method

Creates a new Model from a PowerSHAPE model file.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSModel CreateModelFromFile(
    File file
)
Public Function CreateModelFromFile (
    file As File
) As PSModel

Parameters

file
Type: Autodesk.FileSystemFile
The PowerSHAPE model file to create the model from.

Return Value

Type: PSModel
The created model.
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Remove Method

PSModelsCollectionRemove Method

Overload List
 | Name | Description
Public method | Remove(String) | Removes the model with the specified name from the collection. Closes all windows associated with the selected model.
Public method | Remove(PSModel) | Removes the specified model. Closes all windows associated with the selected model.
Top
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Remove Method (String)

PSModelsCollectionRemove Method (String)

Removes the model with the specified name from the collection. Closes all windows associated with the selected model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Remove(
    string name
)
Public Function Remove (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the model to remove.

Return Value

Type: Boolean
True if succeeds to remove model.
See Also

Reference

PSModelsCollection Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.Remove Method (PSModel)

PSModelsCollectionRemove Method (PSModel)

Removes the specified model. Closes all windows associated with the selected model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Remove(
    PSModel model
)
Public Function Remove (
    model As PSModel
) As Boolean

Parameters

model
Type: Autodesk.ProductInterface.PowerSHAPEPSModel
The model to remove.

Return Value

Type: Boolean
True if succeeds to remove model.
See Also

Reference

PSModelsCollection Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection.RemoveAt Method

PSModelsCollectionRemoveAt Method

Removes the model at the specified index from the collection. Closes all windows associated with the selected model.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RemoveAt(
    int index
)
Public Overrides Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to get or set.
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSModelsCollection Fields

The PSModelsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSModelsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve Class

Captures a Curve object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSpCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSpCurve : PSWireframe
Public Class PSpCurve
    Inherits PSWireframe

The PSpCurve type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the internal polyline (Overrides PSEntityBoundingBox.)
Public property | CentreOfGravity | Gets the volumetric centre of the backend polyline's bounding box (Overrides PSWireframeCentreOfGravity.)
Public property | EndPoint | Gets the end point of the pCurve, overriden from Wireframe because can't interrogate a pCurve using its id (Overrides PSWireframeEndPoint.)
Public property | Exists | This operation checks to see if the pCurve exists in PowerSHAPE (Overrides PSDatabaseEntityExists.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosed | Gets and sets whether the pCurve is closed or not
Public property | IsInBoundary | Gets whether the pCurve is used in a boundary of its parent surface
Public property | IsOnEdge | Gets whether the pCurve is on the edge of its parent surface
Public property | Length | Returns the length of the backend polyline (Overrides PSWireframeLength.)
Public property | Level | Gets and Sets the level of the parent surface (Overrides PSEntityLevel.)
Public property | LevelNumber | Gets and Sets the level number of the parent surface (Overrides PSEntityLevelNumber.)
Public property | Name | As all PCurve evaluation operations in PowerSHAPE need to use the name, this cannot be derived from the id (Overrides PSEntityName.)
Public property | NumberPoints | Gets the number of points on the pCurve - overriden because the pCurve cannot be interrogated using its id (Overrides PSWireframeNumberPoints.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the pCurve - overriden because the pCurve cannot be interrogated in PowerSHAPE using its id (Overrides PSWireframePoints.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the pCurve, overriden from Wireframe because can't interrogate a pCurve using its id (Overrides PSWireframeStartPoint.)
Public property | Surface | Returns the parent surface of the pCurve
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the pCurve from its surface (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve Properties

The PSpCurve type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the internal polyline (Overrides PSEntityBoundingBox.)
Public property | CentreOfGravity | Gets the volumetric centre of the backend polyline's bounding box (Overrides PSWireframeCentreOfGravity.)
Public property | EndPoint | Gets the end point of the pCurve, overriden from Wireframe because can't interrogate a pCurve using its id (Overrides PSWireframeEndPoint.)
Public property | Exists | This operation checks to see if the pCurve exists in PowerSHAPE (Overrides PSDatabaseEntityExists.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosed | Gets and sets whether the pCurve is closed or not
Public property | IsInBoundary | Gets whether the pCurve is used in a boundary of its parent surface
Public property | IsOnEdge | Gets whether the pCurve is on the edge of its parent surface
Public property | Length | Returns the length of the backend polyline (Overrides PSWireframeLength.)
Public property | Level | Gets and Sets the level of the parent surface (Overrides PSEntityLevel.)
Public property | LevelNumber | Gets and Sets the level number of the parent surface (Overrides PSEntityLevelNumber.)
Public property | Name | As all PCurve evaluation operations in PowerSHAPE need to use the name, this cannot be derived from the id (Overrides PSEntityName.)
Public property | NumberPoints | Gets the number of points on the pCurve - overriden because the pCurve cannot be interrogated using its id (Overrides PSWireframeNumberPoints.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the pCurve - overriden because the pCurve cannot be interrogated in PowerSHAPE using its id (Overrides PSWireframePoints.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the pCurve, overriden from Wireframe because can't interrogate a pCurve using its id (Overrides PSWireframeStartPoint.)
Public property | Surface | Returns the parent surface of the pCurve
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.BoundingBox Property

PSpCurveBoundingBox Property

Gets the bounding box of the internal polyline

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.CentreOfGravity Property

PSpCurveCentreOfGravity Property

Gets the volumetric centre of the backend polyline's bounding box

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point CentreOfGravity { get; }
Public Overrides ReadOnly Property CentreOfGravity As Point
    Get

Property Value

Type: Point
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.EndPoint Property

PSpCurveEndPoint Property

Gets the end point of the pCurve, overriden from Wireframe because can't interrogate a pCurve using its id

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point EndPoint { get; }
Public Overrides ReadOnly Property EndPoint As Point
    Get

Property Value

Type: Point
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.Exists Property

PSpCurveExists Property

This operation checks to see if the pCurve exists in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Exists { get; }
Public Overrides ReadOnly Property Exists As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.IsClosed Property

PSpCurveIsClosed Property

Gets and sets whether the pCurve is closed or not

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsClosed { get; set; }
Public Property IsClosed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.IsInBoundary Property

PSpCurveIsInBoundary Property

Gets whether the pCurve is used in a boundary of its parent surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsInBoundary { get; }
Public ReadOnly Property IsInBoundary As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.IsOnEdge Property

PSpCurveIsOnEdge Property

Gets whether the pCurve is on the edge of its parent surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsOnEdge { get; }
Public ReadOnly Property IsOnEdge As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.Length Property

PSpCurveLength Property

Returns the length of the backend polyline

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override MM Length { get; }
Public Overrides ReadOnly Property Length As MM
    Get

Property Value

Type: MM
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.Level Property

PSpCurveLevel Property

Gets and Sets the level of the parent surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override PSLevel Level { get; set; }
Public Overrides Property Level As PSLevel
    Get
    Set

Property Value

Type: PSLevel
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.LevelNumber Property

PSpCurveLevelNumber Property

Gets and Sets the level number of the parent surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override uint LevelNumber { get; set; }
Public Overrides Property LevelNumber As UInteger
    Get
    Set

Property Value

Type: UInt32
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.Name Property

PSpCurveName Property

As all PCurve evaluation operations in PowerSHAPE need to use the name, this cannot be derived from the id

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set

Property Value

Type: String
Exceptions
Exception | Condition
ApplicationException | Cannot set the name of a pCurve
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.NumberPoints Property

PSpCurveNumberPoints Property

Gets the number of points on the pCurve - overriden because the pCurve cannot be interrogated using its id

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int NumberPoints { get; }
Public Overrides ReadOnly Property NumberPoints As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.Points Property

PSpCurvePoints Property

Gets the points on the pCurve - overriden because the pCurve cannot be interrogated in PowerSHAPE using its id

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override List<Point> Points { get; }
Public Overrides ReadOnly Property Points As List(Of Point)
    Get

Property Value

Type: List Point
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.StartPoint Property

PSpCurveStartPoint Property

Gets the start point of the pCurve, overriden from Wireframe because can't interrogate a pCurve using its id

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point StartPoint { get; }
Public Overrides ReadOnly Property StartPoint As Point
    Get

Property Value

Type: Point
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.Surface Property

PSpCurveSurface Property

Returns the parent surface of the pCurve

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface Surface { get; }
Public ReadOnly Property Surface As PSSurface
    Get

Property Value

Type: PSSurface
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve Methods

The PSpCurve type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the pCurve from its surface (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve.Delete Method

PSpCurveDelete Method

Deletes the pCurve from its surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Exceptions
Exception | Condition
NotImplementedException | Cannot currently delete a pCurve through the Automation Interface
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSpCurve Fields

The PSpCurve type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSpCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint Class

Captures a Point in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSPoint

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSPoint : PSEntity, IPSMoveable,
    IPSRotateable, IPSMirrorable
Public Class PSPoint
    Inherits PSEntity
    Implements IPSMoveable, IPSRotateable, IPSMirrorable

The PSPoint type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the point. The bounding box of a point has the same minimum bound as maximum bound (Overrides PSEntityBoundingBox.)
Public property | Centre | Gets and sets the position of the point
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | X | Gets and sets the X coordinate of its relative position
Public property | Y | Gets and sets the Y coordinate of its relative position
Public property | Z | Gets and sets the Z coordinate of its relative position
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Point from PowerSHAPE and removes it from the Points collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetNearestSurface | Gets the nearest surface to this point as well as the nearest point on that surface
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single point in a specified plane
Public method | MoveBetweenPoints | This operation moves a single point by the relative distance between two absolute positions
Public method | MoveByVector | This operation moves a single point by a specified relative amount
Public method | ProjectPointOntoSurface | Projects the Point onto the specified surface
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | This operation rotates a single point by a specified angle around a specified axis
Public method | ToPoint | Returns the Point as a Geometry Point
Public method | ToString | Returns a string representation of the coordinates of the point (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint Properties

The PSPoint type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the point. The bounding box of a point has the same minimum bound as maximum bound (Overrides PSEntityBoundingBox.)
Public property | Centre | Gets and sets the position of the point
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | X | Gets and sets the X coordinate of its relative position
Public property | Y | Gets and sets the Y coordinate of its relative position
Public property | Z | Gets and sets the Z coordinate of its relative position
Top
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.BoundingBox Property

PSPointBoundingBox Property

Gets the bounding box of the point. The bounding box of a point has the same minimum bound as maximum bound

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.Centre Property

PSPointCentre Property

Gets and sets the position of the point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Centre { get; set; }
Public Property Centre As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.X Property

PSPointX Property

Gets and sets the X coordinate of its relative position

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM X { get; set; }
Public Property X As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.Y Property

PSPointY Property

Gets and sets the Y coordinate of its relative position

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Y { get; set; }
Public Property Y As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.Z Property

PSPointZ Property

Gets and sets the Z coordinate of its relative position

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Z { get; set; }
Public Property Z As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint Methods

The PSPoint type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Point from PowerSHAPE and removes it from the Points collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetNearestSurface | Gets the nearest surface to this point as well as the nearest point on that surface
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single point in a specified plane
Public method | MoveBetweenPoints | This operation moves a single point by the relative distance between two absolute positions
Public method | MoveByVector | This operation moves a single point by a specified relative amount
Public method | ProjectPointOntoSurface | Projects the Point onto the specified surface
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | This operation rotates a single point by a specified angle around a specified axis
Public method | ToPoint | Returns the Point as a Geometry Point
Public method | ToString | Returns a string representation of the coordinates of the point (Overrides ObjectToString.)
Top
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.Delete Method

PSPointDelete Method

Deletes the Point from PowerSHAPE and removes it from the Points collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.DistanceTo Method

PSPointDistanceTo Method

Gets the distance between this entity and another

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM DistanceTo(
    PSEntity otherEntity
)
Public Function DistanceTo (
    otherEntity As PSEntity
) As MM

Parameters

otherEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The function returns the distance between this entity and the otherEntity

Return Value

Type: MM
Exceptions
Exception | Condition
Exception | Failed to determine distance between objects
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.GetNearestSurface Method

PSPointGetNearestSurface Method

Gets the nearest surface to this point as well as the nearest point on that surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface GetNearestSurface(
    ref Point nearestPoint,
    bool useWorldCoordinates = false
)
Public Function GetNearestSurface (
    ByRef nearestPoint As Point,
    Optional useWorldCoordinates As Boolean = false
) As PSSurface

Parameters

nearestPoint
Type: Autodesk.GeometryPoint
Returns the nearest point on the nearest surface. Or null if the nearest surface cannot be found
useWorldCoordinates (Optional)
Type: SystemBoolean
Whether or not to return the nearest point on the surface in world coordinates

Return Value

Type: PSSurface
The nearest surface or null if the nearest surface cannot be found
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.Mirror Method

PSPointMirror Method

This operation mirrors a single point in a specified plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
Plane about which to mirror the point
mirrorPoint
Type: Autodesk.GeometryPoint
Origin of the mirror plane

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.MoveBetweenPoints Method

PSPointMoveBetweenPoints Method

This operation moves a single point by the relative distance between two absolute positions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity
List of points created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.MoveByVector Method

PSPointMoveByVector Method

This operation moves a single point by a specified relative amount

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
Relative amount by which the point will be moved
copiesToCreate
Type: SystemInt32
Number of copies that should be created by the operation

Return Value

Type: List PSEntity
A list of points created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.ProjectPointOntoSurface Method

PSPointProjectPointOntoSurface Method

Projects the Point onto the specified surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool ProjectPointOntoSurface(
    PSSurface surface
)
Public Function ProjectPointOntoSurface (
    surface As PSSurface
) As Boolean

Parameters

surface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface onto which the Point is to be projected

Return Value

Type: Boolean
A boolean indicating whether the proection was successful
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.Rotate Method

PSPointRotate Method

This operation rotates a single point by a specified angle around a specified axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
Axis around which the point is are to be rotated
rotationAngle
Type: Autodesk.GeometryDegree
Angle by which the point is to be rotated
copiesToCreate
Type: SystemInt32
Number of copies to create of the original point
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin of the rotation axis

Return Value

Type: List PSEntity
List of points created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.ToPoint Method

PSPointToPoint Method

Returns the Point as a Geometry Point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point ToPoint()
Public Function ToPoint As Point

Return Value

Type: Point
A geometry point representation of this point
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint.ToString Method

PSPointToString Method

Returns a string representation of the coordinates of the point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
String of coordinates the format "X Y Z"
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPoint Fields

The PSPoint type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSPoint Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPointsCollection Class

Captures the collection of Points in a Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSPoint
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSPoint
Autodesk.ProductInterface.PowerSHAPEPSPointsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSPointsCollection : PSEntitiesCollection<PSPoint>
Public Class PSPointsCollection
    Inherits PSEntitiesCollection(Of PSPoint)

The PSPointsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreatePoint | Creates a single point in PowerShape.
Public method | CreatePointAtIntersectionOfSurfaceAndWireframe | This operation creates a new PSPoint at the point of intersection of a surface and a wireframe. Note that if the two do not intersect then a point will be created at the origin of the active workplane. The user should be sure that the surface and wireframe intersect before calling this function
Public method | CreatePointBetweenPoints | This operation creates a new Point using the position dialog.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSPointsCollection Properties

The PSPointsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSPointsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPointsCollection Methods

The PSPointsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreatePoint | Creates a single point in PowerShape.
Public method | CreatePointAtIntersectionOfSurfaceAndWireframe | This operation creates a new PSPoint at the point of intersection of a surface and a wireframe. Note that if the two do not intersect then a point will be created at the origin of the active workplane. The user should be sure that the surface and wireframe intersect before calling this function
Public method | CreatePointBetweenPoints | This operation creates a new Point using the position dialog.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSPointsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPointsCollection.CreatePoint Method

PSPointsCollectionCreatePoint Method

Creates a single point in PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSPoint CreatePoint(
    Point point
)
Public Function CreatePoint (
    point As Point
) As PSPoint

Parameters

point
Type: Autodesk.GeometryPoint
The point to create.

Return Value

Type: PSPoint
The created point.
See Also

Reference

PSPointsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPointsCollection.CreatePointAtIntersectionOfSurfaceAndWireframe Method

PSPointsCollectionCreatePointAtIntersectionOfSurfaceAndWireframe Method

This operation creates a new PSPoint at the point of intersection of a surface and a wireframe. Note that if the two do not intersect then a point will be created at the origin of the active workplane. The user should be sure that the surface and wireframe intersect before calling this function

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSPoint CreatePointAtIntersectionOfSurfaceAndWireframe(
    PSSurface surface,
    PSWireframe wireframe
)
Public Function CreatePointAtIntersectionOfSurfaceAndWireframe (
    surface As PSSurface,
    wireframe As PSWireframe
) As PSPoint

Parameters

surface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface to create a point on where the wireframe intersects
wireframe
Type: Autodesk.ProductInterface.PowerSHAPEPSWireframe
The wireframe that intersects the surface

Return Value

Type: PSPoint
The created PSPoint at the point of intersection
See Also

Reference

PSPointsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPointsCollection.CreatePointBetweenPoints Method

PSPointsCollectionCreatePointBetweenPoints Method

This operation creates a new Point using the position dialog.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSPoint CreatePointBetweenPoints(
    Point firstPoint,
    Point secondPoint
)
Public Function CreatePointBetweenPoints (
    firstPoint As Point,
    secondPoint As Point
) As PSPoint

Parameters

firstPoint
Type: Autodesk.GeometryPoint
The first point to be used.
secondPoint
Type: Autodesk.GeometryPoint
The last point to be used.

Return Value

Type: PSPoint
The point between the first and the second points.
See Also

Reference

PSPointsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPointsCollection Fields

The PSPointsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSPointsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPrimitive Class

Base class for PowerSHAPE primitives
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
More...

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSPrimitive : PSSurface
Public MustInherit Class PSPrimitive
    Inherits PSSurface

The PSPrimitive type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive
Public property | YAxis | Gets the Y axis of the primitive
Public property | ZAxis | Gets the Z axis of the primitive
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceBlock
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCone
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCylinder
Autodesk.ProductInterface.PowerSHAPEPSSurfaceExtrusion
Autodesk.ProductInterface.PowerSHAPEPSSurfacePlane
Autodesk.ProductInterface.PowerSHAPEPSSurfaceRevolution
Autodesk.ProductInterface.PowerSHAPEPSSurfaceSphere
Autodesk.ProductInterface.PowerSHAPEPSSurfaceSpring
Autodesk.ProductInterface.PowerSHAPEPSSurfaceTorus


PSPrimitive Properties

The PSPrimitive type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive
Public property | YAxis | Gets the Y axis of the primitive
Public property | ZAxis | Gets the Z axis of the primitive
Top
See Also

Reference

PSPrimitive Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPrimitive.Origin Property

PSPrimitiveOrigin Property

Gets the origin of the primitive

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Origin { get; }
Public ReadOnly Property Origin As Point
    Get

Property Value

Type: Point
See Also

Reference

PSPrimitive Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPrimitive.XAxis Property

PSPrimitiveXAxis Property

Gets the X axis of the primitive

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector XAxis { get; }
Public ReadOnly Property XAxis As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PSPrimitive Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPrimitive.YAxis Property

PSPrimitiveYAxis Property

Gets the Y axis of the primitive

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector YAxis { get; }
Public ReadOnly Property YAxis As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PSPrimitive Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPrimitive.ZAxis Property

PSPrimitiveZAxis Property

Gets the Z axis of the primitive

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector ZAxis { get; }
Public ReadOnly Property ZAxis As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PSPrimitive Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPrimitive Methods

The PSPrimitive type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSPrimitive Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSPrimitive Fields

The PSPrimitive type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSPrimitive Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid Class

Captures an Solid object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
More...

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolid : PSEntity, IPSMoveable,
    IPSRotateable, IPSMirrorable, IPSOffsetable, IPSScalable, IPSAddable,
    IPSIntersectable, IPSSubtractable, IPSLimitable
Public Class PSSolid
    Inherits PSEntity
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSOffsetable,
    IPSScalable, IPSAddable, IPSIntersectable, IPSSubtractable, IPSLimitable

The PSSolid type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid
Public property | IsClosed | Gets whether the solid is closed
Public property | IsConnected | Gets whether the solid is connected
Public property | IsGhost | Gets whether the solid is a ghost
Public property | IsHidden | Gets whether the Solid is hidden
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid
Public property | IsWatertight | Gets whether the Solid is watertight
Public property | Level | Gets and sets the level the solid is on (Overrides PSEntityLevel.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid
Public property | MomentOfInertia | Gets the moment of inertia of the Solid
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Overrides PSEntityName.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid
Public property | Thickness | Gets the mean thickness of the Solid
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid
Public property | Volume | Gets the volume of the Solid
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity
Public method | AddEntityToEntity | Adds an entity to another entity
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
 | GetSolidType | Gets the solid type, so removing the code from the property and removing the chance that the property can throw an exception
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity
Public method | IntersectEntityWithEntity | Intersects an entity with another entity
Public method | LimitToEntities | Limits a solid by a specified list of entities.
Public method | LimitToEntity | Limits a solid by a specified list of entities
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions
Public method | MoveByVector | This operation moves a single solid by a specified relative amount
Public method | Offset | This operation offsets a single solid by a specified distance
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis
Public method | ScaleNonUniform | Scales the solid a different amount in each axis
Public method | ScaleProjectedVolume | Scales the solid to a projected volume
Public method | ScaleUniform | Scales the solid the same amount in each axis
Public method | SplitSolidWithSurface | Splits the solid with a surface
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity
Public method | ToDMTModel | Returns a DMT Model of the solid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file
Public method | WriteToSTLFile | Exports the solid to the selected STL file
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidBlock
Autodesk.ProductInterface.PowerSHAPEPSSolidCone
Autodesk.ProductInterface.PowerSHAPEPSSolidCylinder
Autodesk.ProductInterface.PowerSHAPEPSSolidExtrusion
Autodesk.ProductInterface.PowerSHAPEPSSolidPlane
Autodesk.ProductInterface.PowerSHAPEPSSolidRevolution
Autodesk.ProductInterface.PowerSHAPEPSSolidSphere
Autodesk.ProductInterface.PowerSHAPEPSSolidSpring
Autodesk.ProductInterface.PowerSHAPEPSSolidTorus


PSSolid Properties

The PSSolid type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid
Public property | IsClosed | Gets whether the solid is closed
Public property | IsConnected | Gets whether the solid is connected
Public property | IsGhost | Gets whether the solid is a ghost
Public property | IsHidden | Gets whether the Solid is hidden
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid
Public property | IsWatertight | Gets whether the Solid is watertight
Public property | Level | Gets and sets the level the solid is on (Overrides PSEntityLevel.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid
Public property | MomentOfInertia | Gets the moment of inertia of the Solid
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Overrides PSEntityName.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid
Public property | Thickness | Gets the mean thickness of the Solid
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid
Public property | Volume | Gets the volume of the Solid
Top
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Area Property

PSSolidArea Property

Gets the area of the surfaces in the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.AverageEdgeTolerance Property

PSSolidAverageEdgeTolerance Property

Gets the average edge tolerance of the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double AverageEdgeTolerance { get; }
Public ReadOnly Property AverageEdgeTolerance As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.CentreOfGravity Property

PSSolidCentreOfGravity Property

Gets the coordinates of the centre of gravity of the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point CentreOfGravity { get; }
Public ReadOnly Property CentreOfGravity As Point
    Get

Property Value

Type: Point
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.HalfEdgeTolerance Property

PSSolidHalfEdgeTolerance Property

Gets the tolerance to which the Solid's half edges are known to link

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double HalfEdgeTolerance { get; }
Public ReadOnly Property HalfEdgeTolerance As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IsActive Property

PSSolidIsActive Property

Gets and sets whether the Solid is the active solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IsClosed Property

PSSolidIsClosed Property

Gets whether the solid is closed

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IsConnected Property

PSSolidIsConnected Property

Gets whether the solid is connected

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IsGhost Property

PSSolidIsGhost Property

Gets whether the solid is a ghost

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsGhost { get; }
Public ReadOnly Property IsGhost As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IsHidden Property

PSSolidIsHidden Property

Gets whether the Solid is hidden

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsHidden { get; }
Public ReadOnly Property IsHidden As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IsTrimmingValid Property

PSSolidIsTrimmingValid Property

Gets whether the Solid boundaries are valid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsTrimmingValid { get; }
Public ReadOnly Property IsTrimmingValid As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IsWatertight Property

PSSolidIsWatertight Property

Gets whether the Solid is watertight

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsWatertight { get; }
Public ReadOnly Property IsWatertight As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Level Property

PSSolidLevel Property

Gets and sets the level the solid is on

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override PSLevel Level { get; set; }
Public Overrides Property Level As PSLevel
    Get
    Set

Property Value

Type: PSLevel

Return Value

Type: PSLevel
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Material Property

PSSolidMaterial Property

Gets and Sets the material of the Solid in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMaterial Material { get; set; }
Public Property Material As PSMaterial
    Get
    Set

Property Value

Type: PSMaterial
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.MaximumEdgeTolerance Property

PSSolidMaximumEdgeTolerance Property

Gets the maximum edge tolerance of the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double MaximumEdgeTolerance { get; }
Public ReadOnly Property MaximumEdgeTolerance As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.MomentOfInertia Property

PSSolidMomentOfInertia Property

Gets the moment of inertia of the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double[] MomentOfInertia { get; }
Public ReadOnly Property MomentOfInertia As Double()
    Get

Property Value

Type: Double
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Name Property

PSSolidName Property

Get and sets solid name in PowerShape and in Custom Core entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
Remarks
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberAnalyticSurfaces Property

PSSolidNumberAnalyticSurfaces Property

Gets the number of analytic surfaces in the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberAnalyticSurfaces { get; }
Public ReadOnly Property NumberAnalyticSurfaces As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberLinkedHalfEdges Property

PSSolidNumberLinkedHalfEdges Property

Gets the number of linked half-edges in the solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberLinkedHalfEdges { get; }
Public ReadOnly Property NumberLinkedHalfEdges As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberOfErrorSuppressedFeatures Property

PSSolidNumberOfErrorSuppressedFeatures Property

Gets the number of error-suppressed features in the solid's tree

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfErrorSuppressedFeatures { get; }
Public ReadOnly Property NumberOfErrorSuppressedFeatures As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberOfFeatures Property

PSSolidNumberOfFeatures Property

Gets the number of features in the solid, not including sub-branches

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfFeatures { get; }
Public ReadOnly Property NumberOfFeatures As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberOfFeaturesInclSubBranches Property

PSSolidNumberOfFeaturesInclSubBranches Property

Gets the number of features in the solid, including sub-branches

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfFeaturesInclSubBranches { get; }
Public ReadOnly Property NumberOfFeaturesInclSubBranches As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberOfGroupFeatures Property

PSSolidNumberOfGroupFeatures Property

Gets the number of group features in the solid, not including sub-branches

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfGroupFeatures { get; }
Public ReadOnly Property NumberOfGroupFeatures As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberOfGroupFeaturesInclSubBranches Property

PSSolidNumberOfGroupFeaturesInclSubBranches Property

Gets the number of group features in the solid, including sub-branches

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfGroupFeaturesInclSubBranches { get; }
Public ReadOnly Property NumberOfGroupFeaturesInclSubBranches As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberOfRedefinedFeatures Property

PSSolidNumberOfRedefinedFeatures Property

Gets the number of features that were replayed during the last tree redefinition

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string NumberOfRedefinedFeatures { get; }
Public ReadOnly Property NumberOfRedefinedFeatures As String
    Get

Property Value

Type: String
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberOfSelectedFeatures Property

PSSolidNumberOfSelectedFeatures Property

Gets the number of features in the solid, not including sub-branches

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfSelectedFeatures { get; }
Public ReadOnly Property NumberOfSelectedFeatures As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberOfSurfaces Property

PSSolidNumberOfSurfaces Property

Gets the number of surfaces in the solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfSurfaces { get; }
Public ReadOnly Property NumberOfSurfaces As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberUnlinkedHalfEdges Property

PSSolidNumberUnlinkedHalfEdges Property

Gets the number of unlinked half-edges in the solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberUnlinkedHalfEdges { get; }
Public ReadOnly Property NumberUnlinkedHalfEdges As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.NumberVerticesAlongEdges Property

PSSolidNumberVerticesAlongEdges Property

Gets the number of vertices along edges in the solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberVerticesAlongEdges { get; }
Public ReadOnly Property NumberVerticesAlongEdges As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.RepresentationNumber Property

PSSolidRepresentationNumber Property

Gets the representation number of the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double RepresentationNumber { get; }
Public ReadOnly Property RepresentationNumber As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Thickness Property

PSSolidThickness Property

Gets the mean thickness of the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Thickness { get; }
Public ReadOnly Property Thickness As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Type Property

PSSolidType Property

Gets the type of the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SolidTypes Type { get; }
Public ReadOnly Property Type As SolidTypes
    Get

Property Value

Type: SolidTypes
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Version Property

PSSolidVersion Property

Gets and sets whether the solid is a version 8 or parasolid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SolidVersions Version { get; set; }
Public Property Version As SolidVersions
    Get
    Set

Property Value

Type: SolidVersions
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Volume Property

PSSolidVolume Property

Gets the volume of the Solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual double Volume { get; }
Public Overridable ReadOnly Property Volume As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid Methods

The PSSolid type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity
Public method | AddEntityToEntity | Adds an entity to another entity
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
 | GetSolidType | Gets the solid type, so removing the code from the property and removing the chance that the property can throw an exception
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity
Public method | IntersectEntityWithEntity | Intersects an entity with another entity
Public method | LimitToEntities | Limits a solid by a specified list of entities.
Public method | LimitToEntity | Limits a solid by a specified list of entities
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions
Public method | MoveByVector | This operation moves a single solid by a specified relative amount
Public method | Offset | This operation offsets a single solid by a specified distance
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis
Public method | ScaleNonUniform | Scales the solid a different amount in each axis
Public method | ScaleProjectedVolume | Scales the solid to a projected volume
Public method | ScaleUniform | Scales the solid the same amount in each axis
Public method | SplitSolidWithSurface | Splits the solid with a surface
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity
Public method | ToDMTModel | Returns a DMT Model of the solid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file
Public method | WriteToSTLFile | Exports the solid to the selected STL file
Top
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.AddEntitiesToEntity Method

PSSolidAddEntitiesToEntity Method

Adds entities to another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity AddEntitiesToEntity(
    IEnumerable<IPSAddable> entitiesToAdd,
    bool copeWithCoincidentFaces = false
)
Public Function AddEntitiesToEntity (
    entitiesToAdd As IEnumerable(Of IPSAddable),
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entitiesToAdd
Type: System.Collections.GenericIEnumerable IPSAddable
Collection of entities to be added
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the addition

Implements

IPSAddableAddEntitiesToEntity(IEnumerableIPSAddable, Boolean)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.AddEntityToEntity Method

PSSolidAddEntityToEntity Method

Adds an entity to another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity AddEntityToEntity(
    IPSAddable entityToAdd,
    bool copeWithCoincidentFaces = false
)
Public Function AddEntityToEntity (
    entityToAdd As IPSAddable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToAdd
Type: Autodesk.ProductInterface.PowerSHAPEIPSAddable
Entity to be added
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the addition

Implements

IPSAddableAddEntityToEntity(IPSAddable, Boolean)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Delete Method

PSSolidDelete Method

Deletes the Solid from PowerSHAPE and removes it from the Solids collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.FilletEdges Method

PSSolidFilletEdges Method

Applies a defined fillet to edges manually selected by the user

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void FilletEdges(
    MM radius
)
Public Sub FilletEdges (
    radius As MM
)

Parameters

radius
Type: Autodesk.GeometryMM
The desired radius of the fillet
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.GetSolidType Method

PSSolidGetSolidType Method

Gets the solid type, so removing the code from the property and removing the chance that the property can throw an exception

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static SolidTypes GetSolidType(
    PSAutomation powerSHAPE,
    string id
)
Public Shared Function GetSolidType (
    powerSHAPE As PSAutomation,
    id As String
) As SolidTypes

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The current instance of PowerSHAPE
id
Type: SystemString
The ID of the solid to interrogate

Return Value

Type: SolidTypes
The type of the solid as a SolidType
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IntersectEntitiesWithEntity Method

PSSolidIntersectEntitiesWithEntity Method

Intersects a collection of entities with another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> IntersectEntitiesWithEntity(
    IEnumerable<IPSIntersectable> entitiesToIntersect,
    bool copeWithCoincidentFaces = false
)
Public Function IntersectEntitiesWithEntity (
    entitiesToIntersect As IEnumerable(Of IPSIntersectable),
    Optional copeWithCoincidentFaces As Boolean = false
) As List(Of PSEntity)

Parameters

entitiesToIntersect
Type: System.Collections.GenericIEnumerable IPSIntersectable
Entities to intersect
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: List PSEntity
Entity created from the intersection

Implements

IPSIntersectableIntersectEntitiesWithEntity(IEnumerableIPSIntersectable, Boolean)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.IntersectEntityWithEntity Method

PSSolidIntersectEntityWithEntity Method

Intersects an entity with another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity IntersectEntityWithEntity(
    IPSIntersectable entityToIntersect,
    bool copeWithCoincidentFaces = false
)
Public Function IntersectEntityWithEntity (
    entityToIntersect As IPSIntersectable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToIntersect
Type: Autodesk.ProductInterface.PowerSHAPEIPSIntersectable
Entity to intersect
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the intersection

Implements

IPSIntersectableIntersectEntityWithEntity(IPSIntersectable, Boolean)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.LimitToEntities Method

PSSolidLimitToEntities Method

Limits a solid by a specified list of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntities(
    List<PSEntity> limitingEntities,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntities (
    limitingEntities As List(Of PSEntity),
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntities
Type: System.Collections.GenericList PSEntity
The entities with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
List of solids created by the operation. If numberOfCopies is 0, an empty list is returned.

Implements

IPSLimitableLimitToEntities(ListPSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.LimitToEntity Method

PSSolidLimitToEntity Method

Limits a solid by a specified list of entities

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntity(
    PSEntity limitingEntity,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntity (
    limitingEntity As PSEntity,
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity with which to perform the limiting operation
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
List of solids created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSLimitableLimitToEntity(PSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.LimitUsingDynamicCutter Method

PSSolidLimitUsingDynamicCutter Method

Limits using the dynamic cutter option.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity LimitUsingDynamicCutter(
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne
)
Public Function LimitUsingDynamicCutter (
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne
) As PSEntity

Parameters

keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.

Return Value

Type: PSEntity
Limited entity

Implements

IPSLimitableLimitUsingDynamicCutter(LimitingKeepOptions)
Remarks
To be used with PSEntityLimiter.NextSolution
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Mirror Method

PSSolidMirror Method

This operation mirrors a single solid in a specified plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the solid
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.MoveBetweenPoints Method

PSSolidMoveBetweenPoints Method

This operation moves a single solid by the relative distance between two absolute positions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity
List of solids created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.MoveByVector Method

PSSolidMoveByVector Method

This operation moves a single solid by a specified relative amount

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
The relative amount by which the solid will be moved
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity
List of solids created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Offset Method

PSSolidOffset Method

This operation offsets a single solid by a specified distance

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Offset(
    MM offsetDistance,
    int copiesToCreate
)
Public Function Offset (
    offsetDistance As MM,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

offsetDistance
Type: Autodesk.GeometryMM
The distance by which to offset the solid
copiesToCreate
Type: SystemInt32
The number of copies to be created from the operation

Return Value

Type: List PSEntity
A list of offset solids

Implements

IPSOffsetableOffset(MM, Int32)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.ReverseNormal Method

PSSolidReverseNormal Method

Reverses the normal of the Surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ReverseNormal()
Public Sub ReverseNormal
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.Rotate Method

PSSolidRotate Method

This operation rotates a single solid by a specified angle around a specified axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the solid is are to be rotated
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the solid is to be rotated
copiesToCreate
Type: SystemInt32
The number of copies to create of the original solid
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis

Return Value

Type: List PSEntity
A list of solids created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.ScaleNonUniform Method

PSSolidScaleNonUniform Method

Scales the solid a different amount in each axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleNonUniform(
    double scaleFactorX,
    double scaleFactorY,
    double scaleFactorZ,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleNonUniform (
    scaleFactorX As Double,
    scaleFactorY As Double,
    scaleFactorZ As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactorX
Type: SystemDouble
Scale factor for the X axis
scaleFactorY
Type: SystemDouble
Scale factor for the Y axis
scaleFactorZ
Type: SystemDouble
Scale factor for the Z axis
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleNonUniform(Double, Double, Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.ScaleProjectedVolume Method

PSSolidScaleProjectedVolume Method

Scales the solid to a projected volume

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleProjectedVolume(
    double newVolume,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleProjectedVolume (
    newVolume As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

newVolume
Type: SystemDouble
Volume to scale to
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleProjectedVolume(Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.ScaleUniform Method

PSSolidScaleUniform Method

Scales the solid the same amount in each axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ScaleUniform(
    double scaleFactor,
    bool lockX,
    bool lockY,
    bool lockZ,
    Point scaleOrigin = null
)
Public Sub ScaleUniform (
    scaleFactor As Double,
    lockX As Boolean,
    lockY As Boolean,
    lockZ As Boolean,
    Optional scaleOrigin As Point = Nothing
)

Parameters

scaleFactor
Type: SystemDouble
Scale factor for the axes
lockX
Type: SystemBoolean
Whether to use the X scale or not
lockY
Type: SystemBoolean
Whether to use the Y scale or not
lockZ
Type: SystemBoolean
Whether to use the Z scale or not
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Origin for the scale operation

Implements

IPSScalableScaleUniform(Double, Boolean, Boolean, Boolean, Point)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.SplitSolidWithSurface Method

PSSolidSplitSolidWithSurface Method

Splits the solid with a surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSolid> SplitSolidWithSurface(
    PSSurface surfaceForSplit
)
Public Function SplitSolidWithSurface (
    surfaceForSplit As PSSurface
) As List(Of PSSolid)

Parameters

surfaceForSplit
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface with which to split the solid

Return Value

Type: List PSSolid
A list of the solid(s) created by the operation
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.SubtractEntitiesFromEntity Method

PSSolidSubtractEntitiesFromEntity Method

Subtracts a collection of entities from another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity SubtractEntitiesFromEntity(
    IEnumerable<IPSSubtractable> entitiesToSubtract,
    bool copeWithCoincidentFaces = false
)
Public Function SubtractEntitiesFromEntity (
    entitiesToSubtract As IEnumerable(Of IPSSubtractable),
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entitiesToSubtract
Type: System.Collections.GenericIEnumerable IPSSubtractable
Entities to subtract
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the subtraction

Implements

IPSSubtractableSubtractEntitiesFromEntity(IEnumerableIPSSubtractable, Boolean)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.SubtractEntityFromEntity Method

PSSolidSubtractEntityFromEntity Method

Subtracts an entity from another entity

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity SubtractEntityFromEntity(
    IPSSubtractable entityToSubtract,
    bool copeWithCoincidentFaces = false
)
Public Function SubtractEntityFromEntity (
    entityToSubtract As IPSSubtractable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToSubtract
Type: Autodesk.ProductInterface.PowerSHAPEIPSSubtractable
Entity to subtract
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False

Return Value

Type: PSEntity
Entity created from the subtraction

Implements

IPSSubtractableSubtractEntityFromEntity(IPSSubtractable, Boolean)
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.ToDMTModel Method

PSSolidToDMTModel Method

Returns a DMT Model of the solid

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DMTModel ToDMTModel()
Public Function ToDMTModel As DMTModel

Return Value

Type: DMTModel
A DMT Model of the solid
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.WriteToDMTFile Method

PSSolidWriteToDMTFile Method

Exports the solid to the selected DMT file

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToDMTFile(
    File file
)
Public Sub WriteToDMTFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The DMT file name to export to
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid.WriteToSTLFile Method

PSSolidWriteToSTLFile Method

Exports the solid to the selected STL file

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void WriteToSTLFile(
    File file
)
Public Sub WriteToSTLFile (
    file As File
)

Parameters

file
Type: Autodesk.FileSystemFile
The STL file name to export to
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolid Fields

The PSSolid type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolid Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock Class

Captures a solid block in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidBlock

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidBlock : PSSolid
Public Class PSSolidBlock
    Inherits PSSolid

The PSSolidBlock type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | DraftAngle1 | Gets and Sets draft angle 1 of the Block
Public property | DraftAngle2 | Gets and Sets draft angle 2 of the Block
Public property | DraftAngle3 | Gets and Sets draft angle 3 of the Block
Public property | DraftAngle4 | Gets and Sets draft angle 4 of the Block
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Height | Gets and Sets the height of the Block
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the Block
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Public property | Width | Gets and Sets the width of the Block
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock Properties

The PSSolidBlock type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | DraftAngle1 | Gets and Sets draft angle 1 of the Block
Public property | DraftAngle2 | Gets and Sets draft angle 2 of the Block
Public property | DraftAngle3 | Gets and Sets draft angle 3 of the Block
Public property | DraftAngle4 | Gets and Sets draft angle 4 of the Block
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Height | Gets and Sets the height of the Block
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the Block
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Public property | Width | Gets and Sets the width of the Block
Top
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock.DraftAngle1 Property

PSSolidBlockDraftAngle1 Property

Gets and Sets draft angle 1 of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle1 { get; set; }
Public Property DraftAngle1 As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock.DraftAngle2 Property

PSSolidBlockDraftAngle2 Property

Gets and Sets draft angle 2 of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle2 { get; set; }
Public Property DraftAngle2 As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock.DraftAngle3 Property

PSSolidBlockDraftAngle3 Property

Gets and Sets draft angle 3 of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle3 { get; set; }
Public Property DraftAngle3 As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock.DraftAngle4 Property

PSSolidBlockDraftAngle4 Property

Gets and Sets draft angle 4 of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle4 { get; set; }
Public Property DraftAngle4 As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock.Height Property

PSSolidBlockHeight Property

Gets and Sets the height of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Height { get; set; }
Public Property Height As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock.Length Property

PSSolidBlockLength Property

Gets and Sets the length of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock.Width Property

PSSolidBlockWidth Property

Gets and Sets the width of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Width { get; set; }
Public Property Width As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock Methods

The PSSolidBlock type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidBlock Fields

The PSSolidBlock type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCone Class

Captures a solid cone in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidCone

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidCone : PSSolid
Public Class PSSolidCone
    Inherits PSSolid

The PSSolidCone type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BaseRadius | Gets and Sets the base radius of the cone
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the cone
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | TopRadius | Gets and Sets the top radius of the cone
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCone Properties

The PSSolidCone type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BaseRadius | Gets and Sets the base radius of the cone
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the cone
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | TopRadius | Gets and Sets the top radius of the cone
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCone.BaseRadius Property

PSSolidConeBaseRadius Property

Gets and Sets the base radius of the cone

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BaseRadius { get; set; }
Public Property BaseRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCone.Length Property

PSSolidConeLength Property

Gets and Sets the length of the cone

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCone.TopRadius Property

PSSolidConeTopRadius Property

Gets and Sets the top radius of the cone

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TopRadius { get; set; }
Public Property TopRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCone Methods

The PSSolidCone type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCone Fields

The PSSolidCone type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCylinder Class

Captures a solid cylinder in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidCylinder

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidCylinder : PSSolid
Public Class PSSolidCylinder
    Inherits PSSolid

The PSSolidCylinder type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the cylinder
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and Sets the radius of the cylinder
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCylinder Properties

The PSSolidCylinder type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the cylinder
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and Sets the radius of the cylinder
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCylinder.Length Property

PSSolidCylinderLength Property

Gets and Sets the length of the cylinder

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCylinder.Radius Property

PSSolidCylinderRadius Property

Gets and Sets the radius of the cylinder

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Radius { get; set; }
Public Property Radius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCylinder Methods

The PSSolidCylinder type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidCylinder Fields

The PSSolidCylinder type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidExtrusion Class

Captures a solid extrusion in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidExtrusion

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidExtrusion : PSSolid
Public Class PSSolidExtrusion
    Inherits PSSolid

The PSSolidExtrusion type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | DraftAngle | Gets and Sets the draft angle of the extrusion
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the extrusion
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NegativeLength | Gets and Sets the negative length of the extrusion
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidExtrusion Properties

The PSSolidExtrusion type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | DraftAngle | Gets and Sets the draft angle of the extrusion
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the extrusion
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NegativeLength | Gets and Sets the negative length of the extrusion
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidExtrusion.DraftAngle Property

PSSolidExtrusionDraftAngle Property

Gets and Sets the draft angle of the extrusion

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle { get; set; }
Public Property DraftAngle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSolidExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidExtrusion.Length Property

PSSolidExtrusionLength Property

Gets and Sets the length of the extrusion

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidExtrusion.NegativeLength Property

PSSolidExtrusionNegativeLength Property

Gets and Sets the negative length of the extrusion

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM NegativeLength { get; set; }
Public Property NegativeLength As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidExtrusion Methods

The PSSolidExtrusion type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidExtrusion Fields

The PSSolidExtrusion type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidPlane Class

Captures a solid plane in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidPlane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidPlane : PSSolid
Public Class PSSolidPlane
    Inherits PSSolid

The PSSolidPlane type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the Plane
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Public property | Width | Gets and Sets the width of the Plane
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidPlane Properties

The PSSolidPlane type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Length | Gets and Sets the length of the Plane
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Public property | Width | Gets and Sets the width of the Plane
Top
See Also

Reference

PSSolidPlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidPlane.Length Property

PSSolidPlaneLength Property

Gets and Sets the length of the Plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidPlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidPlane.Width Property

PSSolidPlaneWidth Property

Gets and Sets the width of the Plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Width { get; set; }
Public Property Width As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidPlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidPlane Methods

The PSSolidPlane type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidPlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidPlane Fields

The PSSolidPlane type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidPlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidRevolution Class

Captures a solid revolution in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidRevolution

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidRevolution : PSSolid
Public Class PSSolidRevolution
    Inherits PSSolid

The PSSolidRevolution type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets and Sets the angle of the revolution
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidRevolution Properties

The PSSolidRevolution type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets and Sets the angle of the revolution
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidRevolution Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidRevolution.Angle Property

PSSolidRevolutionAngle Property

Gets and Sets the angle of the revolution

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree Angle { get; set; }
Public Property Angle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSolidRevolution Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidRevolution Methods

The PSSolidRevolution type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidRevolution Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidRevolution Fields

The PSSolidRevolution type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidRevolution Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection Class

Captures the collection of Solids in a Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSSolid
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidsCollection : PSEntitiesCollection<PSSolid>
Public Class PSSolidsCollection
    Inherits PSEntitiesCollection(Of PSSolid)

The PSSolidsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Selects all solids in the collection.
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateBlock | Creates a new solid block at the specified origin, with the specified height, width, length and draft angle for all walls.
Public method | CreateCylinder | Creates a new solid cylinder at the specified origin, radius and length.
Public method | CreateSolidExtrusionFromWireframe | Creates an extruded solid from wireframe.
Public method | CreateSolidExtrusionsFromWireframes | Creates extruded solids from a list of wireframes.
Public method | CreateSolidFromDriveAndSections | Creates a solid from a drive curve and one or more sections.
Public method | CreateSolidFromMesh | Creates a solid from a mesh.
Public method | CreateSolidsFromSurfaces | Creates a solid from a list of surfaces.
Public method | CreateSphere | Creates a new solid sphere at the specified origin and radius.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection Properties

The PSSolidsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection Methods

The PSSolidsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Selects all solids in the collection.
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateBlock | Creates a new solid block at the specified origin, with the specified height, width, length and draft angle for all walls.
Public method | CreateCylinder | Creates a new solid cylinder at the specified origin, radius and length.
Public method | CreateSolidExtrusionFromWireframe | Creates an extruded solid from wireframe.
Public method | CreateSolidExtrusionsFromWireframes | Creates extruded solids from a list of wireframes.
Public method | CreateSolidFromDriveAndSections | Creates a solid from a drive curve and one or more sections.
Public method | CreateSolidFromMesh | Creates a solid from a mesh.
Public method | CreateSolidsFromSurfaces | Creates a solid from a list of surfaces.
Public method | CreateSphere | Creates a new solid sphere at the specified origin and radius.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.AddToSelection Method

PSSolidsCollectionAddToSelection Method

Selects all solids in the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddToSelection(
    bool emptySelectionFirst = false
)
Public Sub AddToSelection (
    Optional emptySelectionFirst As Boolean = false
)

Parameters

emptySelectionFirst (Optional)
Type: SystemBoolean
If true it will empty the current PowerShape selection.
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.CreateBlock Method

PSSolidsCollectionCreateBlock Method

Creates a new solid block at the specified origin, with the specified height, width, length and draft angle for all walls.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSolidBlock CreateBlock(
    Point origin,
    MM width,
    MM length,
    MM height,
    Degree draftAngle
)
Public Function CreateBlock (
    origin As Point,
    width As MM,
    length As MM,
    height As MM,
    draftAngle As Degree
) As PSSolidBlock

Parameters

origin
Type: Autodesk.GeometryPoint
Origin at which to create the block.
width
Type: Autodesk.GeometryMM
Width of the block.
length
Type: Autodesk.GeometryMM
Length of the block.
height
Type: Autodesk.GeometryMM
Height of the block.
draftAngle
Type: Autodesk.GeometryDegree
Draft angle to use for all walls.

Return Value

Type: PSSolidBlock
The created block.
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.CreateCylinder Method

PSSolidsCollectionCreateCylinder Method

Creates a new solid cylinder at the specified origin, radius and length.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSolidCylinder CreateCylinder(
    Point origin,
    MM radius,
    MM length
)
Public Function CreateCylinder (
    origin As Point,
    radius As MM,
    length As MM
) As PSSolidCylinder

Parameters

origin
Type: Autodesk.GeometryPoint
Origin at which to create the cylinder.
radius
Type: Autodesk.GeometryMM
Radius of the cylinder.
length
Type: Autodesk.GeometryMM
Length of the cylinder.

Return Value

Type: PSSolidCylinder
The created cylinder.
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.CreateSolidExtrusionFromWireframe Method

PSSolidsCollectionCreateSolidExtrusionFromWireframe Method

Creates an extruded solid from wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSolidExtrusion CreateSolidExtrusionFromWireframe(
    PSWireframe wireframe,
    MM length,
    MM negLength
)
Public Function CreateSolidExtrusionFromWireframe (
    wireframe As PSWireframe,
    length As MM,
    negLength As MM
) As PSSolidExtrusion

Parameters

wireframe
Type: Autodesk.ProductInterface.PowerSHAPEPSWireframe
The wireframe from which an extruded solid will be created.
length
Type: Autodesk.GeometryMM
The length of the extruded solid.
negLength
Type: Autodesk.GeometryMM
The negative length of the extruded solid.

Return Value

Type: PSSolidExtrusion
The created solid.
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.CreateSolidExtrusionsFromWireframes Method

PSSolidsCollectionCreateSolidExtrusionsFromWireframes Method

Creates extruded solids from a list of wireframes.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSolidExtrusion> CreateSolidExtrusionsFromWireframes(
    List<PSWireframe> wireframes,
    MM length,
    MM negLength
)
Public Function CreateSolidExtrusionsFromWireframes (
    wireframes As List(Of PSWireframe),
    length As MM,
    negLength As MM
) As List(Of PSSolidExtrusion)

Parameters

wireframes
Type: System.Collections.GenericList PSWireframe
The list of wireframes from which an extruded solid will be created.
length
Type: Autodesk.GeometryMM
The length of the extruded solid.
negLength
Type: Autodesk.GeometryMM
The negative length of the extruded solid.

Return Value

Type: List PSSolidExtrusion
The created solids.
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.CreateSolidFromDriveAndSections Method

PSSolidsCollectionCreateSolidFromDriveAndSections Method

Creates a solid from a drive curve and one or more sections.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSolid CreateSolidFromDriveAndSections(
    PSGenericCurve driveCurve,
    List<PSGenericCurve> sections
)
Public Function CreateSolidFromDriveAndSections (
    driveCurve As PSGenericCurve,
    sections As List(Of PSGenericCurve)
) As PSSolid

Parameters

driveCurve
Type: Autodesk.ProductInterface.PowerSHAPEPSGenericCurve
The drive curve for the solid.
sections
Type: System.Collections.GenericList PSGenericCurve
The sections through which to drive the solid.

Return Value

Type: PSSolid
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.CreateSolidFromMesh Method

PSSolidsCollectionCreateSolidFromMesh Method

Creates a solid from a mesh.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSolid CreateSolidFromMesh(
    PSMesh meshToConvert
)
Public Function CreateSolidFromMesh (
    meshToConvert As PSMesh
) As PSSolid

Parameters

meshToConvert
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
The mesh to be converted to a solid.

Return Value

Type: PSSolid
The solid created from the mesh.
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.CreateSolidsFromSurfaces Method

PSSolidsCollectionCreateSolidsFromSurfaces Method

Creates a solid from a list of surfaces.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSolid> CreateSolidsFromSurfaces(
    List<PSSurface> surfacesToConvert
)
Public Function CreateSolidsFromSurfaces (
    surfacesToConvert As List(Of PSSurface)
) As List(Of PSSolid)

Parameters

surfacesToConvert
Type: System.Collections.GenericList PSSurface
Surfaces to be converted to a solid.

Return Value

Type: List PSSolid
The solid created from the surfaces.
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection.CreateSphere Method

PSSolidsCollectionCreateSphere Method

Creates a new solid sphere at the specified origin and radius.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSolidSphere CreateSphere(
    Point origin,
    MM radius
)
Public Function CreateSphere (
    origin As Point,
    radius As MM
) As PSSolidSphere

Parameters

origin
Type: Autodesk.GeometryPoint
Origin at which to create the sphere.
radius
Type: Autodesk.GeometryMM
Radius of the sphere.

Return Value

Type: PSSolidSphere
The created sphere.
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidsCollection Fields

The PSSolidsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSSolidsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSphere Class

Captures a solid sphere in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidSphere

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidSphere : PSSolid
Public Class PSSolidSphere
    Inherits PSSolid

The PSSolidSphere type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and Sets the radius of the sphere in MM
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSphere Properties

The PSSolidSphere type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and Sets the radius of the sphere in MM
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidSphere Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSphere.Radius Property

PSSolidSphereRadius Property

Gets and Sets the radius of the sphere in MM

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Radius { get; set; }
Public Property Radius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidSphere Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSphere Methods

The PSSolidSphere type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidSphere Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSphere Fields

The PSSolidSphere type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidSphere Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring Class

Captures a solid spring in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidSpring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidSpring : PSSolid
Public Class PSSolidSpring
    Inherits PSSolid

The PSSolidSpring type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BaseRadius | Gets and Sets the base radius of the spring
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Height | Gets and Sets the height of the spring
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | Pitch | Gets and Sets the pitch of the spring
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | TopRadius | Gets and Sets the top radius of the spring
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Turns | Gets and Sets the turns of the spring
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring Properties

The PSSolidSpring type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BaseRadius | Gets and Sets the base radius of the spring
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Height | Gets and Sets the height of the spring
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | Pitch | Gets and Sets the pitch of the spring
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | TopRadius | Gets and Sets the top radius of the spring
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Turns | Gets and Sets the turns of the spring
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring.BaseRadius Property

PSSolidSpringBaseRadius Property

Gets and Sets the base radius of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BaseRadius { get; set; }
Public Property BaseRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring.Height Property

PSSolidSpringHeight Property

Gets and Sets the height of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Height { get; set; }
Public Property Height As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring.Pitch Property

PSSolidSpringPitch Property

Gets and Sets the pitch of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Pitch { get; set; }
Public Property Pitch As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSSolidSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring.TopRadius Property

PSSolidSpringTopRadius Property

Gets and Sets the top radius of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TopRadius { get; set; }
Public Property TopRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSolidSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring.Turns Property

PSSolidSpringTurns Property

Gets and Sets the turns of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Turns { get; set; }
Public Property Turns As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSSolidSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring Methods

The PSSolidSpring type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidSpring Fields

The PSSolidSpring type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidTorus Class

Captures a solid torus in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSolid
Autodesk.ProductInterface.PowerSHAPEPSSolidTorus

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSolidTorus : PSSolid
Public Class PSSolidTorus
    Inherits PSSolid

The PSSolidTorus type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidTorus Properties

The PSSolidTorus type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the surfaces in the Solid (Inherited from PSSolid.)
Public property | AverageEdgeTolerance | Gets the average edge tolerance of the Solid (Inherited from PSSolid.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Solid (Inherited from PSSolid.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HalfEdgeTolerance | Gets the tolerance to which the Solid's half edges are known to link (Inherited from PSSolid.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets and sets whether the Solid is the active solid (Inherited from PSSolid.)
Public property | IsClosed | Gets whether the solid is closed (Inherited from PSSolid.)
Public property | IsConnected | Gets whether the solid is connected (Inherited from PSSolid.)
Public property | IsGhost | Gets whether the solid is a ghost (Inherited from PSSolid.)
Public property | IsHidden | Gets whether the Solid is hidden (Inherited from PSSolid.)
Public property | IsTrimmingValid | Gets whether the Solid boundaries are valid (Inherited from PSSolid.)
Public property | IsWatertight | Gets whether the Solid is watertight (Inherited from PSSolid.)
Public property | Level | Gets and sets the level the solid is on (Inherited from PSSolid.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Material | Gets and Sets the material of the Solid in PowerSHAPE (Inherited from PSSolid.)
Public property | MaximumEdgeTolerance | Gets the maximum edge tolerance of the Solid (Inherited from PSSolid.)
Public property | MomentOfInertia | Gets the moment of inertia of the Solid (Inherited from PSSolid.)
Public property | Name | Get and sets solid name in PowerShape and in Custom Core entity. (Inherited from PSSolid.)
Public property | NumberAnalyticSurfaces | Gets the number of analytic surfaces in the Solid (Inherited from PSSolid.)
Public property | NumberLinkedHalfEdges | Gets the number of linked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberOfErrorSuppressedFeatures | Gets the number of error-suppressed features in the solid's tree (Inherited from PSSolid.)
Public property | NumberOfFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfFeaturesInclSubBranches | Gets the number of features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeatures | Gets the number of group features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfGroupFeaturesInclSubBranches | Gets the number of group features in the solid, including sub-branches (Inherited from PSSolid.)
Public property | NumberOfRedefinedFeatures | Gets the number of features that were replayed during the last tree redefinition (Inherited from PSSolid.)
Public property | NumberOfSelectedFeatures | Gets the number of features in the solid, not including sub-branches (Inherited from PSSolid.)
Public property | NumberOfSurfaces | Gets the number of surfaces in the solid (Inherited from PSSolid.)
Public property | NumberUnlinkedHalfEdges | Gets the number of unlinked half-edges in the solid (Inherited from PSSolid.)
Public property | NumberVerticesAlongEdges | Gets the number of vertices along edges in the solid (Inherited from PSSolid.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | RepresentationNumber | Gets the representation number of the Solid (Inherited from PSSolid.)
Public property | Thickness | Gets the mean thickness of the Solid (Inherited from PSSolid.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Solid (Inherited from PSSolid.)
Public property | Version | Gets and sets whether the solid is a version 8 or parasolid (Inherited from PSSolid.)
Public property | Volume | Gets the volume of the Solid (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidTorus Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidTorus Methods

The PSSolidTorus type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity (Inherited from PSSolid.)
Public method | AddEntityToEntity | Adds an entity to another entity (Inherited from PSSolid.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Solid from PowerSHAPE and removes it from the Solids collection (Inherited from PSSolid.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | FilletEdges | Applies a defined fillet to edges manually selected by the user (Inherited from PSSolid.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity (Inherited from PSSolid.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity (Inherited from PSSolid.)
Public method | LimitToEntities | Limits a solid by a specified list of entities. (Inherited from PSSolid.)
Public method | LimitToEntity | Limits a solid by a specified list of entities (Inherited from PSSolid.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSolid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | This operation mirrors a single solid in a specified plane (Inherited from PSSolid.)
Public method | MoveBetweenPoints | This operation moves a single solid by the relative distance between two absolute positions (Inherited from PSSolid.)
Public method | MoveByVector | This operation moves a single solid by a specified relative amount (Inherited from PSSolid.)
Public method | Offset | This operation offsets a single solid by a specified distance (Inherited from PSSolid.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseNormal | Reverses the normal of the Surface (Inherited from PSSolid.)
Public method | Rotate | This operation rotates a single solid by a specified angle around a specified axis (Inherited from PSSolid.)
Public method | ScaleNonUniform | Scales the solid a different amount in each axis (Inherited from PSSolid.)
Public method | ScaleProjectedVolume | Scales the solid to a projected volume (Inherited from PSSolid.)
Public method | ScaleUniform | Scales the solid the same amount in each axis (Inherited from PSSolid.)
Public method | SplitSolidWithSurface | Splits the solid with a surface (Inherited from PSSolid.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity (Inherited from PSSolid.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity (Inherited from PSSolid.)
Public method | ToDMTModel | Returns a DMT Model of the solid (Inherited from PSSolid.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteToDMTFile | Exports the solid to the selected DMT file (Inherited from PSSolid.)
Public method | WriteToSTLFile | Exports the solid to the selected STL file (Inherited from PSSolid.)
Top
See Also

Reference

PSSolidTorus Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSolidTorus Fields

The PSSolidTorus type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSolidTorus Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine Class

Captures a Spine object in PowerSHAPE. The spine is a reference curve that may be used to define the overall shape of a surface. It was widely used in DUCT, but PowerSHAPE users need not normally be concerned with it.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSSpine

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSpine : PSWireframe
Public Class PSSpine
    Inherits PSWireframe

The PSSpine type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Indicates that the user cannot currently obtain the spine centre of gravity in PowerSHAPE
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets/Sets the level of the surface curve by getting/setting the level of its parent surface (Overrides PSEntityLevel.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Gets the number of points in the wireframe (Inherited from PSWireframe.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe (Inherited from PSWireframe.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Not implemented. (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetPointAzimuthAngle | Gets the azimuth angle of the tangent of the desired point
Public method | GetPointElevationAngle | Gets the elevation angle of the tangent of the desired point
Public method | GetPointTangent | Gets the tangent through the desired point
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _surface | The parent surface of a spine.
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine Properties

The PSSpine type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Indicates that the user cannot currently obtain the spine centre of gravity in PowerSHAPE
Public property | EndPoint | Gets the end point of the wireframe (Inherited from PSWireframe.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the wireframe (Inherited from PSWireframe.)
Public property | Level | Gets/Sets the level of the surface curve by getting/setting the level of its parent surface (Overrides PSEntityLevel.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Gets the number of points in the wireframe (Inherited from PSWireframe.)
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the Wireframe (Inherited from PSWireframe.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe (Inherited from PSWireframe.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine.CentreOfGravity Property

PSSpineCentreOfGravity Property

Indicates that the user cannot currently obtain the spine centre of gravity in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Object CentreOfGravity { get; }
Public ReadOnly Property CentreOfGravity As Object
    Get

Property Value

Type: Object
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine.Level Property

PSSpineLevel Property

Gets/Sets the level of the surface curve by getting/setting the level of its parent surface

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override PSLevel Level { get; set; }
Public Overrides Property Level As PSLevel
    Get
    Set

Property Value

Type: PSLevel
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine Methods

The PSSpine type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Not implemented. (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetPointAzimuthAngle | Gets the azimuth angle of the tangent of the desired point
Public method | GetPointElevationAngle | Gets the elevation angle of the tangent of the desired point
Public method | GetPointTangent | Gets the tangent through the desired point
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine.Delete Method

PSSpineDelete Method

Not implemented.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
Exceptions
Exception | Condition
NotImplementedException | Not implemented.
Remarks
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine.GetPointAzimuthAngle Method

PSSpineGetPointAzimuthAngle Method

Gets the azimuth angle of the tangent of the desired point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetPointAzimuthAngle(
    int pointNumber
)
Public Function GetPointAzimuthAngle (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the tangency azimuth angle is required

Return Value

Type: Vector
Azimuth vector
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine.GetPointElevationAngle Method

PSSpineGetPointElevationAngle Method

Gets the elevation angle of the tangent of the desired point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetPointElevationAngle(
    int pointNumber
)
Public Function GetPointElevationAngle (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the tangency elevation angle is required

Return Value

Type: Vector
Elevation vector
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine.GetPointTangent Method

PSSpineGetPointTangent Method

Gets the tangent through the desired point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetPointTangent(
    int pointNumber
)
Public Function GetPointTangent (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which tangency is required

Return Value

Type: Vector
Tangent vector
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine Fields

The PSSpine type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _surface | The parent surface of a spine.
Top
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSpine._surface Field

PSSpine_surface Field

The parent surface of a spine.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSSurface _surface
Protected _surface As PSSurface

Field Value

Type: PSSurface
Remarks
See Also

Reference

PSSpine Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface Class

Captures an Surface object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurface : PSEntity, IPSMoveable,
    IPSRotateable, IPSMirrorable, IPSLimitable, IPSAddable, IPSIntersectable,
    IPSSubtractable
Public Class PSSurface
    Inherits PSEntity
    Implements IPSMoveable, IPSRotateable, IPSMirrorable, IPSLimitable,
    IPSAddable, IPSIntersectable, IPSSubtractable

The PSSurface type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface.
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface.
Public property | Direction | Gets the direction of the Surface.
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine.
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed.
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed.
Public property | IsTrimmed | Gets and sets the Trim status of the Surface.
Public property | IsTrimmingValid | Gets the Trim validity of the Surface.
Public property | Laterals | Gets the list of laterals on the surface.
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface.
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE.
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface.
Public property | NumberOfLaterals | Gets the number of laterals on the surface.
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface.
Public property | NumberOfPCurves | Gets the number of pCurves on the surface.
Public property | PCurves | Gets a list of the PCurves on the surface.
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface.
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface.
Public property | Volume | Gets the volume of the Surface.
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity.
Public method | AddEntityToEntity | Adds an entity to another entity.
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated.
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface.
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve.
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once.
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once.
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Overrides PSEntityDelete.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off.
Public method | DistanceTo | Gets the distance between this entity and another
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters.
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters.
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point.
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface).
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters.
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters.
 | GetSurfaceType | Gets the surface type, so removing the code from the property and removing the chance that the property can throw an exception.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity.
Public method | IntersectEntityWithEntity | Intersects an entity with another entity.
Public method | LimitToEntities | Limits a surface by a specified list of entities.
Public method | LimitToEntity | Limits a surface by a specified list of entities.
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane.
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions.
Public method | MoveByVector | Moves a single surface by a specified relative amount.
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface.
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves.
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface.
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis.
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface.
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface.
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface.
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface.
Public method | StitchToCurve | Stitches the surface to a curve or compcurve.
Public method | StitchToSurface | Stitches the surface to another surface.
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve.
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity.
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity.
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface Properties

The PSSurface type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface.
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface.
Public property | Direction | Gets the direction of the Surface.
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine.
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed.
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed.
Public property | IsTrimmed | Gets and sets the Trim status of the Surface.
Public property | IsTrimmingValid | Gets the Trim validity of the Surface.
Public property | Laterals | Gets the list of laterals on the surface.
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface.
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE.
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface.
Public property | NumberOfLaterals | Gets the number of laterals on the surface.
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface.
Public property | NumberOfPCurves | Gets the number of pCurves on the surface.
Public property | PCurves | Gets a list of the PCurves on the surface.
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface.
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface.
Public property | Volume | Gets the volume of the Surface.
Top
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Area Property

PSSurfaceArea Property

Gets the area of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.CentreOfGravity Property

PSSurfaceCentreOfGravity Property

Gets the coordinates of the centre of gravity of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point CentreOfGravity { get; }
Public ReadOnly Property CentreOfGravity As Point
    Get

Property Value

Type: Point
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Direction Property

PSSurfaceDirection Property

Gets the direction of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector Direction { get; }
Public ReadOnly Property Direction As Vector
    Get

Property Value

Type: Vector
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.HasSpine Property

PSSurfaceHasSpine Property

Gets whether the surface has a spine.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool HasSpine { get; }
Public ReadOnly Property HasSpine As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.IsClosedLaterals Property

PSSurfaceIsClosedLaterals Property

Gets and sets whether the Surface laterals are closed.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsClosedLaterals { get; set; }
Public Property IsClosedLaterals As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.IsClosedLongitudinals Property

PSSurfaceIsClosedLongitudinals Property

Gets and sets whether the Surface longitudinals are closed.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsClosedLongitudinals { get; set; }
Public Property IsClosedLongitudinals As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.IsTrimmed Property

PSSurfaceIsTrimmed Property

Gets and sets the Trim status of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsTrimmed { get; set; }
Public Property IsTrimmed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.IsTrimmingValid Property

PSSurfaceIsTrimmingValid Property

Gets the Trim validity of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsTrimmingValid { get; }
Public ReadOnly Property IsTrimmingValid As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Laterals Property

PSSurfaceLaterals Property

Gets the list of laterals on the surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSLateralsCollection Laterals { get; }
Public ReadOnly Property Laterals As PSLateralsCollection
    Get

Property Value

Type: PSLateralsCollection
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Longitudinals Property

PSSurfaceLongitudinals Property

Gets the list of longitudinals on the surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSLongitudinalsCollection Longitudinals { get; }
Public ReadOnly Property Longitudinals As PSLongitudinalsCollection
    Get

Property Value

Type: PSLongitudinalsCollection
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Material Property

PSSurfaceMaterial Property

Gets and Sets the material of the Surface in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSMaterial Material { get; set; }
Public Property Material As PSMaterial
    Get
    Set

Property Value

Type: PSMaterial
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.NumberOfBoundaries Property

PSSurfaceNumberOfBoundaries Property

Gets the number of boundaries on the surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfBoundaries { get; }
Public ReadOnly Property NumberOfBoundaries As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.NumberOfLaterals Property

PSSurfaceNumberOfLaterals Property

Gets the number of laterals on the surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfLaterals { get; }
Public ReadOnly Property NumberOfLaterals As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.NumberOfLongitudinals Property

PSSurfaceNumberOfLongitudinals Property

Gets the number of longitudinals on the surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfLongitudinals { get; }
Public ReadOnly Property NumberOfLongitudinals As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.NumberOfPCurves Property

PSSurfaceNumberOfPCurves Property

Gets the number of pCurves on the surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public int NumberOfPCurves { get; }
Public ReadOnly Property NumberOfPCurves As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.PCurves Property

PSSurfacePCurves Property

Gets a list of the PCurves on the surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSpCurve> PCurves { get; }
Public ReadOnly Property PCurves As List(Of PSpCurve)
    Get

Property Value

Type: List PSpCurve
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Shape Property

PSSurfaceShape Property

Gets the primitive shape of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual SurfaceShapes Shape { get; }
Public Overridable ReadOnly Property Shape As SurfaceShapes
    Get

Property Value

Type: SurfaceShapes
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Type Property

PSSurfaceType Property

Gets the type of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SurfaceTypes Type { get; }
Public ReadOnly Property Type As SurfaceTypes
    Get

Property Value

Type: SurfaceTypes
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Volume Property

PSSurfaceVolume Property

Gets the volume of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual double Volume { get; }
Public Overridable ReadOnly Property Volume As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface Methods

The PSSurface type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity.
Public method | AddEntityToEntity | Adds an entity to another entity.
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated.
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface.
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve.
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once.
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once.
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Overrides PSEntityDelete.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off.
Public method | DistanceTo | Gets the distance between this entity and another
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters.
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters.
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point.
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface).
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters.
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters.
 | GetSurfaceType | Gets the surface type, so removing the code from the property and removing the chance that the property can throw an exception.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity.
Public method | IntersectEntityWithEntity | Intersects an entity with another entity.
Public method | LimitToEntities | Limits a surface by a specified list of entities.
Public method | LimitToEntity | Limits a surface by a specified list of entities.
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane.
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions.
Public method | MoveByVector | Moves a single surface by a specified relative amount.
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface.
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves.
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface.
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis.
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface.
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface.
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface.
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface.
Public method | StitchToCurve | Stitches the surface to a curve or compcurve.
Public method | StitchToSurface | Stitches the surface to another surface.
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve.
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity.
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity.
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.AddEntitiesToEntity Method

PSSurfaceAddEntitiesToEntity Method

Adds entities to another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity AddEntitiesToEntity(
    IEnumerable<IPSAddable> entitiesToAdd,
    bool copeWithCoincidentFaces = false
)
Public Function AddEntitiesToEntity (
    entitiesToAdd As IEnumerable(Of IPSAddable),
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entitiesToAdd
Type: System.Collections.GenericIEnumerable IPSAddable
Collection of entities to be added.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False.

Return Value

Type: PSEntity
Entity created from the addition.

Implements

IPSAddableAddEntitiesToEntity(IEnumerableIPSAddable, Boolean)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.AddEntityToEntity Method

PSSurfaceAddEntityToEntity Method

Adds an entity to another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity AddEntityToEntity(
    IPSAddable entityToAdd,
    bool copeWithCoincidentFaces = false
)
Public Function AddEntityToEntity (
    entityToAdd As IPSAddable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToAdd
Type: Autodesk.ProductInterface.PowerSHAPEIPSAddable
Entity to be added.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False.

Return Value

Type: PSEntity
Entity created from the addition.

Implements

IPSAddableAddEntityToEntity(IPSAddable, Boolean)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.AddSurfaceCurveByParameter Method

PSSurfaceAddSurfaceCurveByParameter Method

Adds a new surface curve at the point indicated.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AddSurfaceCurveByParameter(
    SurfaceCurveTypes latOrLon,
    float creationPoint
)
Public Sub AddSurfaceCurveByParameter (
    latOrLon As SurfaceCurveTypes,
    creationPoint As Single
)

Parameters

latOrLon
Type: Autodesk.ProductInterface.PowerSHAPESurfaceCurveTypes
The surface direction option for a surface curve.
creationPoint
Type: SystemSingle
The creation point.
Remarks
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.AppendToSurface Method

PSSurfaceAppendToSurface Method

Appends another surface onto this surface, retaining this surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AppendToSurface(
    PSSurface surfacetoAppendTo,
    PSSurfaceCurve curveToAppend
)
Public Sub AppendToSurface (
    surfacetoAppendTo As PSSurface,
    curveToAppend As PSSurfaceCurve
)

Parameters

surfacetoAppendTo
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface to append onto this surface.
curveToAppend
Type: Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
The surface curve on this surface to use as the append point.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.ConvertBoundaryToCompCurve Method

PSSurfaceConvertBoundaryToCompCurve Method

Converts a boundary on a surface into a composite curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCompCurve ConvertBoundaryToCompCurve(
    int index
)
Public Function ConvertBoundaryToCompCurve (
    index As Integer
) As PSCompCurve

Parameters

index
Type: SystemInt32
The index of the boundary to convert.

Return Value

Type: PSCompCurve
The compcurve created from the boundary.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.ConvertSurfaceCurvesToWireframe Method

PSSurfaceConvertSurfaceCurvesToWireframe Method

Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSCompCurve> ConvertSurfaceCurvesToWireframe(
    SurfaceCurveTypes latOrLon,
    int[] curveNumbers
)
Public Function ConvertSurfaceCurvesToWireframe (
    latOrLon As SurfaceCurveTypes,
    curveNumbers As Integer()
) As List(Of PSCompCurve)

Parameters

latOrLon
Type: Autodesk.ProductInterface.PowerSHAPESurfaceCurveTypes
The SurfaceCurveTypes enum differentiates between a Lateral or a Longitudinal.
curveNumbers
Type: SystemInt32
This is the list of curve numbers to be converted to wireframe.

Return Value

Type: List PSCompCurve
The compcurve(s) created by the conversion operation.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.ConvertSurfaceToPowerSurface Method

PSSurfaceConvertSurfaceToPowerSurface Method

Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface ConvertSurfaceToPowerSurface()
Public Function ConvertSurfaceToPowerSurface As PSSurface

Return Value

Type: PSSurface
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Delete Method

PSSurfaceDelete Method

Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.DeleteBoundary Method

PSSurfaceDeleteBoundary Method

Operation deletes a boundary from the surface and then switches trim region editing off.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void DeleteBoundary(
    int index
)
Public Sub DeleteBoundary (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the boundary to delete.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.DistanceTo Method

PSSurfaceDistanceTo Method

Gets the distance between this entity and another

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM DistanceTo(
    PSEntity otherEntity
)
Public Function DistanceTo (
    otherEntity As PSEntity
) As MM

Parameters

otherEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The function returns the distance between this entity and the otherEntity

Return Value

Type: MM
Exceptions
Exception | Condition
Exception | Failed to determine distance between objects
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Extend Method

PSSurfaceExtend Method

Extends one edge of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Extend(
    ExtensionEdges edge,
    double length,
    ExtensionType straightCurved
)
Public Sub Extend (
    edge As ExtensionEdges,
    length As Double,
    straightCurved As ExtensionType
)

Parameters

edge
Type: Autodesk.ProductInterface.PowerSHAPEExtensionEdges
The option for the surface extension.
length
Type: SystemDouble
The extension length.
straightCurved
Type: Autodesk.ProductInterface.PowerSHAPEExtensionType
The straight curved.
Remarks
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetMaxCurvature Method

PSSurfaceGetMaxCurvature Method

Gets the maximum curvature at a position defined by TU parameters.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetMaxCurvature(
    double t,
    double u
)
Public Function GetMaxCurvature (
    t As Double,
    u As Double
) As Double

Parameters

t
Type: SystemDouble
The t parameter of the chosen surface position.
u
Type: SystemDouble
The u parameter of the chosen surface position.

Return Value

Type: Double
The maximum curvature at the chosen position.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetMinCurvature Method

PSSurfaceGetMinCurvature Method

Gets the minimum curvature at a position defined by TU parameters.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double GetMinCurvature(
    double t,
    double u
)
Public Function GetMinCurvature (
    t As Double,
    u As Double
) As Double

Parameters

t
Type: SystemDouble
The t parameter of the chosen surface position.
u
Type: SystemDouble
The u parameter of the chosen surface position.

Return Value

Type: Double
The minimum curvature at the chosen position.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetNearestNormal Method

PSSurfaceGetNearestNormal Method

Gets the normal of the surface a the point nearest to the specified reference point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetNearestNormal(
    Point referencePoint
)
Public Function GetNearestNormal (
    referencePoint As Point
) As Vector

Parameters

referencePoint
Type: Autodesk.GeometryPoint
The reference point to find the nearest point to

Return Value

Type: Vector
The normal of the surface a the point nearest to the specified reference point
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetNearestTUParameters Method

PSSurfaceGetNearestTUParameters Method

Gets the nearest TU parameters to an external point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double[] GetNearestTUParameters(
    Point referencePoint,
    float guessT = 0f,
    float guessU = 0f
)
Public Function GetNearestTUParameters (
    referencePoint As Point,
    Optional guessT As Single = 0F,
    Optional guessU As Single = 0F
) As Double()

Parameters

referencePoint
Type: Autodesk.GeometryPoint
Reference point that can lie anywhere in space.
guessT (Optional)
Type: SystemSingle
Optional estimate T to speed up calculation times.
guessU (Optional)
Type: SystemSingle
Optional estimate U to speed up calculation times.

Return Value

Type: Double
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetNormal Method

PSSurfaceGetNormal Method

Gets the normal of the Surface at the specified point (default is centre of surface).

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetNormal(
    float t = 0f,
    float u = 0f
)
Public Function GetNormal (
    Optional t As Single = 0F,
    Optional u As Single = 0F
) As Vector

Parameters

t (Optional)
Type: SystemSingle
T coordinate of point on surface.
u (Optional)
Type: SystemSingle
U coordinate of point on surface.

Return Value

Type: Vector
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetSurfacePoint Method

PSSurfaceGetSurfacePoint Method

Overload List
 | Name | Description
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters.
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters.
Top
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetSurfacePoint Method (Double[])

PSSurfaceGetSurfacePoint Method (Double)

Gets the coordinates of a position on the surface defined byb TU parameters.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point GetSurfacePoint(
    double[] TUParameters
)
Public Function GetSurfacePoint (
    TUParameters As Double()
) As Point

Parameters

TUParameters
Type: SystemDouble
A double array containing the TU parameters of the chosen surface position.

Return Value

Type: Point
A point representing the coordinates of the chosen position.
See Also

Reference

PSSurface Class
GetSurfacePoint Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetSurfacePoint Method (Double, Double)

PSSurfaceGetSurfacePoint Method (Double, Double)

Gets the coordinates of a position on the surface defined by TU paremeters.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point GetSurfacePoint(
    double t,
    double u
)
Public Function GetSurfacePoint (
    t As Double,
    u As Double
) As Point

Parameters

t
Type: SystemDouble
The t parameter of the chosen surface position.
u
Type: SystemDouble
The u parameter of the chosen surface position.

Return Value

Type: Point
A point representing the coordinates of the chosen position.
See Also

Reference

PSSurface Class
GetSurfacePoint Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.GetSurfaceType Method

PSSurfaceGetSurfaceType Method

Gets the surface type, so removing the code from the property and removing the chance that the property can throw an exception.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static SurfaceTypes GetSurfaceType(
    PSAutomation powerSHAPE,
    string id
)
Public Shared Function GetSurfaceType (
    powerSHAPE As PSAutomation,
    id As String
) As SurfaceTypes

Parameters

powerSHAPE
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The current instance of PowerSHAPE.
id
Type: SystemString
The ID of the surface to interrogate.

Return Value

Type: SurfaceTypes
The type of the surface as a SurfaceType.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.IntersectEntitiesWithEntity Method

PSSurfaceIntersectEntitiesWithEntity Method

Intersects a collection of entities with another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> IntersectEntitiesWithEntity(
    IEnumerable<IPSIntersectable> entitiesToIntersect,
    bool copeWithCoincidentFaces = false
)
Public Function IntersectEntitiesWithEntity (
    entitiesToIntersect As IEnumerable(Of IPSIntersectable),
    Optional copeWithCoincidentFaces As Boolean = false
) As List(Of PSEntity)

Parameters

entitiesToIntersect
Type: System.Collections.GenericIEnumerable IPSIntersectable
Entities to intersect.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False.

Return Value

Type: List PSEntity
Entity created from the intersection

Implements

IPSIntersectableIntersectEntitiesWithEntity(IEnumerableIPSIntersectable, Boolean)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.IntersectEntityWithEntity Method

PSSurfaceIntersectEntityWithEntity Method

Intersects an entity with another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity IntersectEntityWithEntity(
    IPSIntersectable entityToIntersect,
    bool copeWithCoincidentFaces = false
)
Public Function IntersectEntityWithEntity (
    entityToIntersect As IPSIntersectable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToIntersect
Type: Autodesk.ProductInterface.PowerSHAPEIPSIntersectable
Entity to intersect.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False.

Return Value

Type: PSEntity
Entity created from the intersection

Implements

IPSIntersectableIntersectEntityWithEntity(IPSIntersectable, Boolean)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.LimitToEntities Method

PSSurfaceLimitToEntities Method

Limits a surface by a specified list of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntities(
    List<PSEntity> limitingEntities,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntities (
    limitingEntities As List(Of PSEntity),
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntities
Type: System.Collections.GenericList PSEntity
The entities with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity
The entities produced by the limiting operation.

Implements

IPSLimitableLimitToEntities(ListPSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
Remarks
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.LimitToEntity Method

PSSurfaceLimitToEntity Method

Limits a surface by a specified list of entities.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> LimitToEntity(
    PSEntity limitingEntity,
    LimitingModes limitingMode = LimitingModes.LimitMode,
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne,
    LimitingTrimOptions trimOption = LimitingTrimOptions.LimitOne,
    bool finishOperation = true
)
Public Function LimitToEntity (
    limitingEntity As PSEntity,
    Optional limitingMode As LimitingModes = LimitingModes.LimitMode,
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne,
    Optional trimOption As LimitingTrimOptions = LimitingTrimOptions.LimitOne,
    Optional finishOperation As Boolean = true
) As List(Of PSEntity)

Parameters

limitingEntity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity with which to perform the limiting operation.
limitingMode (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingModes
The mode in which to carry out the operation.
keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.
trimOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingTrimOptions
Whether to trim one or all of the entities.
finishOperation (Optional)
Type: SystemBoolean
If true, turns edit selection off.

Return Value

Type: List PSEntity

Implements

IPSLimitableLimitToEntity(PSEntity, LimitingModes, LimitingKeepOptions, LimitingTrimOptions, Boolean)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.LimitUsingDynamicCutter Method

PSSurfaceLimitUsingDynamicCutter Method

Limits using the dynamic cutter option.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity LimitUsingDynamicCutter(
    LimitingKeepOptions keepOption = LimitingKeepOptions.KeepOne
)
Public Function LimitUsingDynamicCutter (
    Optional keepOption As LimitingKeepOptions = LimitingKeepOptions.KeepOne
) As PSEntity

Parameters

keepOption (Optional)
Type: Autodesk.ProductInterface.PowerSHAPELimitingKeepOptions
Whether to keep one or both sides of the limit.

Return Value

Type: PSEntity
Limited entity.

Implements

IPSLimitableLimitUsingDynamicCutter(LimitingKeepOptions)
Remarks
To be used with PSEntityLimiter.NextSolution.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Mirror Method

PSSurfaceMirror Method

Mirrors a single surface in a specified plane.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the surface.
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane.

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.MoveBetweenPoints Method

PSSurfaceMoveBetweenPoints Method

Moves a single surface by the relative distance between two absolute positions.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions.
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions.
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation.

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.MoveByVector Method

PSSurfaceMoveByVector Method

Moves a single surface by a specified relative amount.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
The relative amount by which the surface will be moved.
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation.

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.NearestPoint Method

PSSurfaceNearestPoint Method

Gets the nearest point on the surface compared to the specified point

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point NearestPoint(
    Point point
)
Public Function NearestPoint (
    point As Point
) As Point

Parameters

point
Type: Autodesk.GeometryPoint
The function returns the distance between this specified point and the surface

Return Value

Type: Point
Exceptions
Exception | Condition
Exception | Failed to determine nearest point
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Offset Method

PSSurfaceOffset Method

Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Offset(
    float distanceToOffset,
    OffsetCornerTypes cornerBehaviour,
    OffsetSplitAtDiscontinuity discontinuityBehaviour
)
Public Sub Offset (
    distanceToOffset As Single,
    cornerBehaviour As OffsetCornerTypes,
    discontinuityBehaviour As OffsetSplitAtDiscontinuity
)

Parameters

distanceToOffset
Type: SystemSingle
The distance to offset the surface.
cornerBehaviour
Type: Autodesk.ProductInterface.PowerSHAPEOffsetCornerTypes
The desired behaviour off the offset surface at corners.
discontinuityBehaviour
Type: Autodesk.ProductInterface.PowerSHAPEOffsetSplitAtDiscontinuity
The desired behaviour of the offset surface when the operation produces a discontinuity.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.ReverseDirectionOfSurfaceCurves Method

PSSurfaceReverseDirectionOfSurfaceCurves Method

Reverses the direction of the surface curves.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ReverseDirectionOfSurfaceCurves()
Public Sub ReverseDirectionOfSurfaceCurves
Remarks
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.ReverseSurfaceNormal Method

PSSurfaceReverseSurfaceNormal Method

Reverses the normal of the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void ReverseSurfaceNormal()
Public Sub ReverseSurfaceNormal
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Rotate Method

PSSurfaceRotate Method

Rotates a single surface by a specified angle around a specified axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the surface is are to be rotated.
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the surface is to be rotated.
copiesToCreate
Type: SystemInt32
The number of copies to create of the original surface.
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis.

Return Value

Type: List PSEntity
A list of surfaces created by the operation. If numberOfCopies is 0, an empty list is returned.

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.Scale Method

PSSurfaceScale Method

Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface Scale(
    double offsetX,
    double offsetY,
    double offsetZ,
    Point scaleOrigin = null
)
Public Function Scale (
    offsetX As Double,
    offsetY As Double,
    offsetZ As Double,
    Optional scaleOrigin As Point = Nothing
) As PSSurface

Parameters

offsetX
Type: SystemDouble
Scale value in X.
offsetY
Type: SystemDouble
Scale value in Y.
offsetZ
Type: SystemDouble
Scale value in Z.
scaleOrigin (Optional)
Type: Autodesk.GeometryPoint
Scale origin, workplane origin if none specified.

Return Value

Type: PSSurface
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.SelectLateralAndLongitudinalSurfaceCurves Method

PSSurfaceSelectLateralAndLongitudinalSurfaceCurves Method

Selects one or more lateral and longitudinal curves on the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SelectLateralAndLongitudinalSurfaceCurves(
    int[] lateralCurveNumbers,
    int[] longitudinalCurveNumbers
)
Public Sub SelectLateralAndLongitudinalSurfaceCurves (
    lateralCurveNumbers As Integer(),
    longitudinalCurveNumbers As Integer()
)

Parameters

lateralCurveNumbers
Type: SystemInt32
The lateral curves to select.
longitudinalCurveNumbers
Type: SystemInt32
The longitudinal curves to select.
Remarks
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.SelectSurfaceCurves Method

PSSurfaceSelectSurfaceCurves Method

Overload List
 | Name | Description
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface.
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface.
Top
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.SelectSurfaceCurves Method (PSSurfaceCurve[])

PSSurfaceSelectSurfaceCurves Method (PSSurfaceCurve)

Selects one or more curves on the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SelectSurfaceCurves(
    PSSurfaceCurve[] surfaceCurves
)
Public Sub SelectSurfaceCurves (
    surfaceCurves As PSSurfaceCurve()
)

Parameters

surfaceCurves
Type: Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
The specific surface curves to select.
Remarks
This operation can select any combination of laterals and longitudinals on one surface.
See Also

Reference

PSSurface Class
SelectSurfaceCurves Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.SelectSurfaceCurves Method (SurfaceCurveTypes, Int32[])

PSSurfaceSelectSurfaceCurves Method (SurfaceCurveTypes, Int32)

Selects one or more curves on the Surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SelectSurfaceCurves(
    SurfaceCurveTypes surfaceCurveType,
    int[] curveNumbers
)
Public Sub SelectSurfaceCurves (
    surfaceCurveType As SurfaceCurveTypes,
    curveNumbers As Integer()
)

Parameters

surfaceCurveType
Type: Autodesk.ProductInterface.PowerSHAPESurfaceCurveTypes
The surface direction option for a surface curve.
curveNumbers
Type: SystemInt32
The curves to select.
Remarks
See Also

Reference

PSSurface Class
SelectSurfaceCurves Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.StitchToCurve Method

PSSurfaceStitchToCurve Method

Stitches the surface to a curve or compcurve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StitchToCurve(
    PSGenericCurve curveToStitchTo,
    PSSurfaceCurve surfaceCurveToStitch,
    StitchDirectionAcross directionAcross,
    StitchDirectionAlong directionAlong,
    float stitchingTolerance
)
Public Sub StitchToCurve (
    curveToStitchTo As PSGenericCurve,
    surfaceCurveToStitch As PSSurfaceCurve,
    directionAcross As StitchDirectionAcross,
    directionAlong As StitchDirectionAlong,
    stitchingTolerance As Single
)

Parameters

curveToStitchTo
Type: Autodesk.ProductInterface.PowerSHAPEPSGenericCurve
The curve to stitch to.
surfaceCurveToStitch
Type: Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
The surface curve to stitch on the selected surface.
directionAcross
Type: Autodesk.ProductInterface.PowerSHAPEStitchDirectionAcross
Indicates whether the points should be matched across the stitch.
directionAlong
Type: Autodesk.ProductInterface.PowerSHAPEStitchDirectionAlong
Indicates whether the points should be matched along the stitch.
stitchingTolerance
Type: SystemSingle
The tolerance to stitch to.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.StitchToSurface Method

PSSurfaceStitchToSurface Method

Stitches the surface to another surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StitchToSurface(
    PSSurface surfaceToStitchTo,
    PSSurfaceCurve surfaceCurveToStitch,
    StitchDirectionAcross directionAcross,
    StitchDirectionAlong directionAlong,
    float stitchingTolerance
)
Public Sub StitchToSurface (
    surfaceToStitchTo As PSSurface,
    surfaceCurveToStitch As PSSurfaceCurve,
    directionAcross As StitchDirectionAcross,
    directionAlong As StitchDirectionAlong,
    stitchingTolerance As Single
)

Parameters

surfaceToStitchTo
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The surface to stitch to.
surfaceCurveToStitch
Type: Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
The surface curve to stitch on the selected surface.
directionAcross
Type: Autodesk.ProductInterface.PowerSHAPEStitchDirectionAcross
Indicates whether the points should be matched across the stitch.
directionAlong
Type: Autodesk.ProductInterface.PowerSHAPEStitchDirectionAlong
Indicates whether the points should be matched along the stitch.
stitchingTolerance
Type: SystemSingle
The tolerance to stitch to.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.StitchToSurfaceCurve Method

PSSurfaceStitchToSurfaceCurve Method

Stitches the surface to a surface curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void StitchToSurfaceCurve(
    PSSurfaceCurve surfaceCurveToStitchTo,
    PSSurfaceCurve surfaceCurveToStitch,
    StitchDirectionAcross directionAcross,
    StitchDirectionAlong directionAlong,
    float stitchingTolerance
)
Public Sub StitchToSurfaceCurve (
    surfaceCurveToStitchTo As PSSurfaceCurve,
    surfaceCurveToStitch As PSSurfaceCurve,
    directionAcross As StitchDirectionAcross,
    directionAlong As StitchDirectionAlong,
    stitchingTolerance As Single
)

Parameters

surfaceCurveToStitchTo
Type: Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
The surface curve to stitch to.
surfaceCurveToStitch
Type: Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
The surface curve to stitch on the selected surface.
directionAcross
Type: Autodesk.ProductInterface.PowerSHAPEStitchDirectionAcross
Indicates whether the points should be matched across the stitch.
directionAlong
Type: Autodesk.ProductInterface.PowerSHAPEStitchDirectionAlong
Indicates whether the points should be matched along the stitch.
stitchingTolerance
Type: SystemSingle
The tolerance to stitch to.
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.SubtractEntitiesFromEntity Method

PSSurfaceSubtractEntitiesFromEntity Method

Subtracts a collection of entities from another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity SubtractEntitiesFromEntity(
    IEnumerable<IPSSubtractable> entitiesToSubtract,
    bool copeWithCoincidentFaces = false
)
Public Function SubtractEntitiesFromEntity (
    entitiesToSubtract As IEnumerable(Of IPSSubtractable),
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entitiesToSubtract
Type: System.Collections.GenericIEnumerable IPSSubtractable
Entities to subtract.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False.

Return Value

Type: PSEntity
Entity created from the subtraction.

Implements

IPSSubtractableSubtractEntitiesFromEntity(IEnumerableIPSSubtractable, Boolean)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.SubtractEntityFromEntity Method

PSSurfaceSubtractEntityFromEntity Method

Subtracts an entity from another entity.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSEntity SubtractEntityFromEntity(
    IPSSubtractable entityToSubtract,
    bool copeWithCoincidentFaces = false
)
Public Function SubtractEntityFromEntity (
    entityToSubtract As IPSSubtractable,
    Optional copeWithCoincidentFaces As Boolean = false
) As PSEntity

Parameters

entityToSubtract
Type: Autodesk.ProductInterface.PowerSHAPEIPSSubtractable
Entity to subtract.
copeWithCoincidentFaces (Optional)
Type: SystemBoolean
Optional boolean defaults to False.

Return Value

Type: PSEntity
Entity created from the sub.traction.

Implements

IPSSubtractableSubtractEntityFromEntity(IPSSubtractable, Boolean)
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface.SwapSurfaceCurves Method

PSSurfaceSwapSurfaceCurves Method

Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SwapSurfaceCurves()
Public Sub SwapSurfaceCurves
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurface Fields

The PSSurface type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurface Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock Class

Captures a Surface Block object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceBlock

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfaceBlock : PSPrimitive
Public Class PSSurfaceBlock
    Inherits PSPrimitive

The PSSurfaceBlock type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | DraftAngle1 | Gets and Sets draft angle 1 of the Block
Public property | DraftAngle2 | Gets and Sets draft angle 2 of the Block
Public property | DraftAngle3 | Gets and Sets draft angle 3 of the Block
Public property | DraftAngle4 | Gets and Sets draft angle 4 of the Block
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Height | Gets and Sets the height of the Block
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the Block
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Block, which is the height x width x length, not 0 as returned by PowerSHAPE (Overrides PSSurfaceVolume.)
Public property | Width | Gets and Sets the width of the Block
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock Properties

The PSSurfaceBlock type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | DraftAngle1 | Gets and Sets draft angle 1 of the Block
Public property | DraftAngle2 | Gets and Sets draft angle 2 of the Block
Public property | DraftAngle3 | Gets and Sets draft angle 3 of the Block
Public property | DraftAngle4 | Gets and Sets draft angle 4 of the Block
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Height | Gets and Sets the height of the Block
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the Block
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Block, which is the height x width x length, not 0 as returned by PowerSHAPE (Overrides PSSurfaceVolume.)
Public property | Width | Gets and Sets the width of the Block
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock.DraftAngle1 Property

PSSurfaceBlockDraftAngle1 Property

Gets and Sets draft angle 1 of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle1 { get; set; }
Public Property DraftAngle1 As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock.DraftAngle2 Property

PSSurfaceBlockDraftAngle2 Property

Gets and Sets draft angle 2 of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle2 { get; set; }
Public Property DraftAngle2 As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock.DraftAngle3 Property

PSSurfaceBlockDraftAngle3 Property

Gets and Sets draft angle 3 of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle3 { get; set; }
Public Property DraftAngle3 As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock.DraftAngle4 Property

PSSurfaceBlockDraftAngle4 Property

Gets and Sets draft angle 4 of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle4 { get; set; }
Public Property DraftAngle4 As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock.Height Property

PSSurfaceBlockHeight Property

Gets and Sets the height of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Height { get; set; }
Public Property Height As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock.Length Property

PSSurfaceBlockLength Property

Gets and Sets the length of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock.Volume Property

PSSurfaceBlockVolume Property

Gets the volume of the Block, which is the height x width x length, not 0 as returned by PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override double Volume { get; }
Public Overrides ReadOnly Property Volume As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock.Width Property

PSSurfaceBlockWidth Property

Gets and Sets the width of the Block

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Width { get; set; }
Public Property Width As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock Methods

The PSSurfaceBlock type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceBlock Fields

The PSSurfaceBlock type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfaceBlock Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCone Class

Captures a Surface Cone object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCone

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfaceCone : PSPrimitive
Public Class PSSurfaceCone
    Inherits PSPrimitive

The PSSurfaceCone type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BaseRadius | Gets and Sets the base radius of the cone
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the cone
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | TopRadius | Gets and Sets the top radius of the cone
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCone Properties

The PSSurfaceCone type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BaseRadius | Gets and Sets the base radius of the cone
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the cone
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | TopRadius | Gets and Sets the top radius of the cone
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfaceCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCone.BaseRadius Property

PSSurfaceConeBaseRadius Property

Gets and Sets the base radius of the cone

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BaseRadius { get; set; }
Public Property BaseRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCone.Length Property

PSSurfaceConeLength Property

Gets and Sets the length of the cone

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCone.TopRadius Property

PSSurfaceConeTopRadius Property

Gets and Sets the top radius of the cone

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TopRadius { get; set; }
Public Property TopRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCone Methods

The PSSurfaceCone type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCone Fields

The PSSurfaceCone type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfaceCone Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve Class

Base class for Surface Curves.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
Autodesk.ProductInterface.PowerSHAPEPSLateral
Autodesk.ProductInterface.PowerSHAPEPSLongitudinal

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSSurfaceCurve : PSWireframe
Public MustInherit Class PSSurfaceCurve
    Inherits PSWireframe

The PSSurfaceCurve type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type (Overrides PSEntityBoundingBox.)
Public property | CentreOfGravity | Gets the centre of gravity of the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeCentreOfGravity.)
Public property | EndPoint | Gets the end point of the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeEndPoint.)
Public property | Exists | Overrides Exists() from DatabaseEntity as a surface curve must be analysed using its name. If the surface curve has been deleted, its name will now be 0 and always return False (Overrides PSDatabaseEntityExists.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeLength.)
Public property | Level | Gets/Sets the level of the surface curve by getting/setting the level of its parent surface. (Overrides PSEntityLevel.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets/Sets the name of the lateral or longitudinal. (Overrides PSEntityName.)
Public property | NumberPoints | Gets the number of points on the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeNumberPoints.)
Public property | ParentSurface | Gets the parent surface of the surface curve.
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the surface curve. (Overrides PSWireframePoints.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeStartPoint.)
Public property | Transparency | Always returns 0, as a surface curve can only ever be opaque. (Overrides PSEntityTransparency.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Calls the parent surface's AddSurfaceCurveToSelection operation. (Overrides PSEntityAddToSelection(Boolean).)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | CreateCompositeCurve | Returns a composite curve of the surface curve.
Public method | Delete | Deletes the surface curve from the surface. It is always overriden by the Lateral and Longitudinal classes as the other surface curve IDs will have to be updated afterward. (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditAfterTangencyOfPoint | Edits the after tangent at the selected point.
Public method | EditBeforeTangencyOfPoint | Edits the before tangent at the selected point.
Public method | EditTangencyOfPoint | Edits the entry and exit tangencies at a defined point.
Public method | Equals | Overrides Equals() from DatabaseEntity as the surface curve's name/ID can be changed since the surface curve was initialised. Therefore its unique internal ID is used for comparison. (Overrides PSDatabaseEntityEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point.
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point.
Public method | GetEntryFlareAngleOfPoint | Gets the flare angle of the entry tangent of the desired point.
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point.
Public method | GetEntryNormalOfPoint | Gets the entry normal of the desired point.
Public method | GetEntryTangentOfPoint | Gets the entry tangent of the desired point.
Public method | GetEntryTwistAngleOfPoint | Gets the twist angle of the entry tangent of the desired point.
Public method | GetExitAzimuthAngleOfPOint | Gets the azimuth angle of the exit tangent of the desired point.
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point.
Public method | GetExitFlareAngleOfPoint | Gets the flare angle of the exit tangent of the desired point.
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point.
Public method | GetExitNormalOfPoint | Gets the exit normal of the desired point.
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point.
Public method | GetExitTwistAngleOfPoint | Gets the twist angle of the exit tangent of the desired point.
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move(Vector) | Moves a single surfacecurve by a specified relative amount.
Public method | Move(Point, Point) | Moves a single surfacecurve by the relative distance between two absolute positions.
Public method | MoveSurfacePointsAlongVector | Moves the indicated surface points by a vector.
Public method | Offset | Offsets the surface curve by the specified amount.
Public method | OffsetPointsOnCurve | Offsets the indicated points on the surface curve.
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | Rotates a single surface curve by a specified angle around a specified axis.
Public method | SelectCurvePoints | Selects the indicated points on the surface curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _internalId | The internal ID of the Surface Curve.
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _surface | The parent surface of the Surface Curve.
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve Properties

The PSSurfaceCurve type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | BoundingBox property is not valid for this type (Overrides PSEntityBoundingBox.)
Public property | CentreOfGravity | Gets the centre of gravity of the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeCentreOfGravity.)
Public property | EndPoint | Gets the end point of the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeEndPoint.)
Public property | Exists | Overrides Exists() from DatabaseEntity as a surface curve must be analysed using its name. If the surface curve has been deleted, its name will now be 0 and always return False (Overrides PSDatabaseEntityExists.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeLength.)
Public property | Level | Gets/Sets the level of the surface curve by getting/setting the level of its parent surface. (Overrides PSEntityLevel.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets/Sets the name of the lateral or longitudinal. (Overrides PSEntityName.)
Public property | NumberPoints | Gets the number of points on the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeNumberPoints.)
Public property | ParentSurface | Gets the parent surface of the surface curve.
Public property | Point | Gets the point at the specified zero based index (Inherited from PSWireframe.)
Public property | Points | Gets the points on the surface curve. (Overrides PSWireframePoints.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the surface curve - overriden because the curve cannot be interrogated using its id. (Overrides PSWireframeStartPoint.)
Public property | Transparency | Always returns 0, as a surface curve can only ever be opaque. (Overrides PSEntityTransparency.)
Top
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.BoundingBox Property

PSSurfaceCurveBoundingBox Property

BoundingBox property is not valid for this type

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.CentreOfGravity Property

PSSurfaceCurveCentreOfGravity Property

Gets the centre of gravity of the surface curve - overriden because the curve cannot be interrogated using its id.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point CentreOfGravity { get; }
Public Overrides ReadOnly Property CentreOfGravity As Point
    Get

Property Value

Type: Point
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.EndPoint Property

PSSurfaceCurveEndPoint Property

Gets the end point of the surface curve - overriden because the curve cannot be interrogated using its id.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point EndPoint { get; }
Public Overrides ReadOnly Property EndPoint As Point
    Get

Property Value

Type: Point
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Exists Property

PSSurfaceCurveExists Property

Overrides Exists() from DatabaseEntity as a surface curve must be analysed using its name. If the surface curve has been deleted, its name will now be 0 and always return False

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Exists { get; }
Public Overrides ReadOnly Property Exists As Boolean
    Get

Return Value

Type: Boolean
Boolean indicating whether this surface curve is on the specified surface.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Length Property

PSSurfaceCurveLength Property

Gets the length of the surface curve - overriden because the curve cannot be interrogated using its id.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override MM Length { get; }
Public Overrides ReadOnly Property Length As MM
    Get

Property Value

Type: MM
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Level Property

PSSurfaceCurveLevel Property

Gets/Sets the level of the surface curve by getting/setting the level of its parent surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override PSLevel Level { get; set; }
Public Overrides Property Level As PSLevel
    Get
    Set

Property Value

Type: PSLevel
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Name Property

PSSurfaceCurveName Property

Gets/Sets the name of the lateral or longitudinal.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.NumberPoints Property

PSSurfaceCurveNumberPoints Property

Gets the number of points on the surface curve - overriden because the curve cannot be interrogated using its id.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override int NumberPoints { get; }
Public Overrides ReadOnly Property NumberPoints As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.ParentSurface Property

PSSurfaceCurveParentSurface Property

Gets the parent surface of the surface curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface ParentSurface { get; }
Public ReadOnly Property ParentSurface As PSSurface
    Get

Property Value

Type: PSSurface
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Points Property

PSSurfaceCurvePoints Property

Gets the points on the surface curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override List<Point> Points { get; }
Public Overrides ReadOnly Property Points As List(Of Point)
    Get

Property Value

Type: List Point
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.StartPoint Property

PSSurfaceCurveStartPoint Property

Gets the start point of the surface curve - overriden because the curve cannot be interrogated using its id.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override Point StartPoint { get; }
Public Overrides ReadOnly Property StartPoint As Point
    Get

Property Value

Type: Point
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Transparency Property

PSSurfaceCurveTransparency Property

Always returns 0, as a surface curve can only ever be opaque.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override double Transparency { get; set; }
Public Overrides Property Transparency As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve Methods

The PSSurfaceCurve type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Calls the parent surface's AddSurfaceCurveToSelection operation. (Overrides PSEntityAddToSelection(Boolean).)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | CreateCompositeCurve | Returns a composite curve of the surface curve.
Public method | Delete | Deletes the surface curve from the surface. It is always overriden by the Lateral and Longitudinal classes as the other surface curve IDs will have to be updated afterward. (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | EditAfterTangencyOfPoint | Edits the after tangent at the selected point.
Public method | EditBeforeTangencyOfPoint | Edits the before tangent at the selected point.
Public method | EditTangencyOfPoint | Edits the entry and exit tangencies at a defined point.
Public method | Equals | Overrides Equals() from DatabaseEntity as the surface curve's name/ID can be changed since the surface curve was initialised. Therefore its unique internal ID is used for comparison. (Overrides PSDatabaseEntityEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntryAzimuthAngleOfPoint | Gets the azimuth angle of the entry tangent of the desired point.
Public method | GetEntryElevationAngleOfPoint | Gets the elevation angle of the entry tangent of the desired point.
Public method | GetEntryFlareAngleOfPoint | Gets the flare angle of the entry tangent of the desired point.
Public method | GetEntryMagnitudeOfPoint | Gets the magnitude of the entry tangent of the desired point.
Public method | GetEntryNormalOfPoint | Gets the entry normal of the desired point.
Public method | GetEntryTangentOfPoint | Gets the entry tangent of the desired point.
Public method | GetEntryTwistAngleOfPoint | Gets the twist angle of the entry tangent of the desired point.
Public method | GetExitAzimuthAngleOfPOint | Gets the azimuth angle of the exit tangent of the desired point.
Public method | GetExitElevationAngleOfPoint | Gets the elevation angle of the exit tangent of the desired point.
Public method | GetExitFlareAngleOfPoint | Gets the flare angle of the exit tangent of the desired point.
Public method | GetExitMagnitudeOfPoint | Gets the magnitude of the exit tangent of the desired point.
Public method | GetExitNormalOfPoint | Gets the exit normal of the desired point.
Public method | GetExitTangentOfPoint | Gets the exit tangent of the desired point.
Public method | GetExitTwistAngleOfPoint | Gets the twist angle of the exit tangent of the desired point.
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetLengthBetweenTwoPoints | Gets the length of curve between two key points.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move(Vector) | Moves a single surfacecurve by a specified relative amount.
Public method | Move(Point, Point) | Moves a single surfacecurve by the relative distance between two absolute positions.
Public method | MoveSurfacePointsAlongVector | Moves the indicated surface points by a vector.
Public method | Offset | Offsets the surface curve by the specified amount.
Public method | OffsetPointsOnCurve | Offsets the indicated points on the surface curve.
Public method | ProjectOntoSurface | Projects a Curve onto a surface. (Inherited from PSWireframe.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | Rotates a single surface curve by a specified angle around a specified axis.
Public method | SelectCurvePoints | Selects the indicated points on the surface curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.AddToSelection Method

PSSurfaceCurveAddToSelection Method

Calls the parent surface's AddSurfaceCurveToSelection operation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void AddToSelection(
    bool emptySelectionFirst = false
)
Public Overrides Sub AddToSelection (
    Optional emptySelectionFirst As Boolean = false
)

Parameters

emptySelectionFirst (Optional)
Type: SystemBoolean
Determines whether previous surface curve additions are to be disregarded.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.CreateCompositeCurve Method

PSSurfaceCurveCreateCompositeCurve Method

Returns a composite curve of the surface curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSCompCurve CreateCompositeCurve()
Public Function CreateCompositeCurve As PSCompCurve

Return Value

Type: PSCompCurve
A new composite curve.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Delete Method

PSSurfaceCurveDelete Method

Deletes the surface curve from the surface. It is always overriden by the Lateral and Longitudinal classes as the other surface curve IDs will have to be updated afterward.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.EditAfterTangencyOfPoint Method

PSSurfaceCurveEditAfterTangencyOfPoint Method

Edits the after tangent at the selected point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EditAfterTangencyOfPoint(
    int pointNumber,
    Vector afterTangentVector
)
Public Sub EditAfterTangencyOfPoint (
    pointNumber As Integer,
    afterTangentVector As Vector
)

Parameters

pointNumber
Type: SystemInt32
The number of the point to select. Index starts from zero.
afterTangentVector
Type: Autodesk.GeometryVector
The control point for the after tangent.
Remarks
The tangents at the selected points is set along the curve.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.EditBeforeTangencyOfPoint Method

PSSurfaceCurveEditBeforeTangencyOfPoint Method

Edits the before tangent at the selected point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EditBeforeTangencyOfPoint(
    int pointNumber,
    Vector beforeTangentVector
)
Public Sub EditBeforeTangencyOfPoint (
    pointNumber As Integer,
    beforeTangentVector As Vector
)

Parameters

pointNumber
Type: SystemInt32
The number of the point to select. Index starts from zero.
beforeTangentVector
Type: Autodesk.GeometryVector
The control point for the before tangent.
Remarks
The tangents at the selected points is set along the curve.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.EditTangencyOfPoint Method

PSSurfaceCurveEditTangencyOfPoint Method

Edits the entry and exit tangencies at a defined point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void EditTangencyOfPoint(
    int pointNumber,
    Vector entryTangent,
    Vector exitTangent
)
Public Sub EditTangencyOfPoint (
    pointNumber As Integer,
    entryTangent As Vector,
    exitTangent As Vector
)

Parameters

pointNumber
Type: SystemInt32
The point at which to carry out the operation. Index starts from zero.
entryTangent
Type: Autodesk.GeometryVector
The desired entry tangent. If this is not to be changed, pass in the current entry tangent.
exitTangent
Type: Autodesk.GeometryVector
The desired exit tangent. If this is not to be changed, pass in the current exit tangent.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Equals Method

PSSurfaceCurveEquals Method

Overrides Equals() from DatabaseEntity as the surface curve's name/ID can be changed since the surface curve was initialised. Therefore its unique internal ID is used for comparison.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The other PSSurfaceCurve to compare to.

Return Value

Type: Boolean
Returns a boolean indicating whether the two objects are equal.
Remarks
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetEntryAzimuthAngleOfPoint Method

PSSurfaceCurveGetEntryAzimuthAngleOfPoint Method

Gets the azimuth angle of the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetEntryAzimuthAngleOfPoint(
    int pointNumber
)
Public Function GetEntryAzimuthAngleOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the entry tangency azimuth angle is required. Index starts from zero.

Return Value

Type: Vector
Entry azimuth vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetEntryElevationAngleOfPoint Method

PSSurfaceCurveGetEntryElevationAngleOfPoint Method

Gets the elevation angle of the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetEntryElevationAngleOfPoint(
    int pointNumber
)
Public Function GetEntryElevationAngleOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the exit tangency elevation angle is required. Index starts from zero.

Return Value

Type: Vector
Entry elevation vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetEntryFlareAngleOfPoint Method

PSSurfaceCurveGetEntryFlareAngleOfPoint Method

Gets the flare angle of the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetEntryFlareAngleOfPoint(
    int pointNumber
)
Public Function GetEntryFlareAngleOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the entry tangency flare angle is required. Index starts from zero.

Return Value

Type: Vector
Entry flare vector
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetEntryMagnitudeOfPoint Method

PSSurfaceCurveGetEntryMagnitudeOfPoint Method

Gets the magnitude of the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetEntryMagnitudeOfPoint(
    int pointNumber
)
Public Function GetEntryMagnitudeOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which entry tangency magnitude is required. Index starts from zero.

Return Value

Type: Vector
Entry tangent magnitude vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetEntryNormalOfPoint Method

PSSurfaceCurveGetEntryNormalOfPoint Method

Gets the entry normal of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetEntryNormalOfPoint(
    int pointNumber
)
Public Function GetEntryNormalOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which entry normal is required. Index starts from zero.

Return Value

Type: Vector
Entry normal vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetEntryTangentOfPoint Method

PSSurfaceCurveGetEntryTangentOfPoint Method

Gets the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetEntryTangentOfPoint(
    int pointNumber
)
Public Function GetEntryTangentOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which entry tangency is required. Index starts from zero.

Return Value

Type: Vector
Entry tangent vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetEntryTwistAngleOfPoint Method

PSSurfaceCurveGetEntryTwistAngleOfPoint Method

Gets the twist angle of the entry tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetEntryTwistAngleOfPoint(
    int pointNumber
)
Public Function GetEntryTwistAngleOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the exit tangency twist angle is required. Index starts from zero.

Return Value

Type: Vector
Entry twist vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetExitAzimuthAngleOfPOint Method

PSSurfaceCurveGetExitAzimuthAngleOfPOint Method

Gets the azimuth angle of the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetExitAzimuthAngleOfPOint(
    int pointNumber
)
Public Function GetExitAzimuthAngleOfPOint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the exit tangency azimuth angle is required. Index starts from zero.

Return Value

Type: Vector
Exit azimuth vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetExitElevationAngleOfPoint Method

PSSurfaceCurveGetExitElevationAngleOfPoint Method

Gets the elevation angle of the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetExitElevationAngleOfPoint(
    int pointNumber
)
Public Function GetExitElevationAngleOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the exit tangency elevation angle is required. Index starts from zero.

Return Value

Type: Vector
Exit elevation vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetExitFlareAngleOfPoint Method

PSSurfaceCurveGetExitFlareAngleOfPoint Method

Gets the flare angle of the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetExitFlareAngleOfPoint(
    int pointNumber
)
Public Function GetExitFlareAngleOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the exit tangency flare angle is required. Index starts from zero.

Return Value

Type: Vector
Exit flare vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetExitMagnitudeOfPoint Method

PSSurfaceCurveGetExitMagnitudeOfPoint Method

Gets the magnitude of the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetExitMagnitudeOfPoint(
    int pointNumber
)
Public Function GetExitMagnitudeOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which exit tangency magnitude is required. Index starts from zero.

Return Value

Type: Vector
Exit tangent magnitude vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetExitNormalOfPoint Method

PSSurfaceCurveGetExitNormalOfPoint Method

Gets the exit normal of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetExitNormalOfPoint(
    int pointNumber
)
Public Function GetExitNormalOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which exit normal is required. Index starts from zero.

Return Value

Type: Vector
Exit normal vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetExitTangentOfPoint Method

PSSurfaceCurveGetExitTangentOfPoint Method

Gets the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetExitTangentOfPoint(
    int pointNumber
)
Public Function GetExitTangentOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which exit tangency is required. Index starts from zero.

Return Value

Type: Vector
Exit tangent vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetExitTwistAngleOfPoint Method

PSSurfaceCurveGetExitTwistAngleOfPoint Method

Gets the twist angle of the exit tangent of the desired point.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector GetExitTwistAngleOfPoint(
    int pointNumber
)
Public Function GetExitTwistAngleOfPoint (
    pointNumber As Integer
) As Vector

Parameters

pointNumber
Type: SystemInt32
The point at which the exit tangency twist angle is required. Index starts from zero.

Return Value

Type: Vector
Exit twist vector.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.GetLengthBetweenTwoPoints Method

PSSurfaceCurveGetLengthBetweenTwoPoints Method

Gets the length of curve between two key points.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM GetLengthBetweenTwoPoints(
    float pointA,
    float pointB
)
Public Function GetLengthBetweenTwoPoints (
    pointA As Single,
    pointB As Single
) As MM

Parameters

pointA
Type: SystemSingle
Single representing the chosen start keypoint on the curve. Index starts from zero.
pointB
Type: SystemSingle
Single representing the chosen end keypoint on the curve. Index starts from zero.

Return Value

Type: MM
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Move Method

PSSurfaceCurveMove Method

Overload List
 | Name | Description
Public method | Move(Vector) | Moves a single surfacecurve by a specified relative amount.
Public method | Move(Point, Point) | Moves a single surfacecurve by the relative distance between two absolute positions.
Top
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Move Method (Vector)

PSSurfaceCurveMove Method (Vector)

Moves a single surfacecurve by a specified relative amount.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Move(
    Vector moveVector
)
Public Sub Move (
    moveVector As Vector
)

Parameters

moveVector
Type: Autodesk.GeometryVector
The relative amount by which the surfacecurve will be moved.
See Also

Reference

PSSurfaceCurve Class
Move Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Move Method (Point, Point)

PSSurfaceCurveMove Method (Point, Point)

Moves a single surfacecurve by the relative distance between two absolute positions.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Move(
    Point moveOriginCoordinates,
    Point pointToMoveTo
)
Public Sub Move (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point
)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions.
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions.
See Also

Reference

PSSurfaceCurve Class
Move Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.MoveSurfacePointsAlongVector Method

PSSurfaceCurveMoveSurfacePointsAlongVector Method

Moves the indicated surface points by a vector.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MoveSurfacePointsAlongVector(
    Vector moveVector,
    int[] pointNumbersToMove
)
Public Sub MoveSurfacePointsAlongVector (
    moveVector As Vector,
    pointNumbersToMove As Integer()
)

Parameters

moveVector
Type: Autodesk.GeometryVector
Vector along which to move the points.
pointNumbersToMove
Type: SystemInt32
Points to move. Index starts from zero.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Offset Method

PSSurfaceCurveOffset Method

Offsets the surface curve by the specified amount.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Offset(
    float distanceToOffset,
    OffsetSplitAtDiscontinuity discontinuityBehaviour,
    bool applyCurveSmoothing
)
Public Sub Offset (
    distanceToOffset As Single,
    discontinuityBehaviour As OffsetSplitAtDiscontinuity,
    applyCurveSmoothing As Boolean
)

Parameters

distanceToOffset
Type: SystemSingle
Distance to offset the curve.
discontinuityBehaviour
Type: Autodesk.ProductInterface.PowerSHAPEOffsetSplitAtDiscontinuity
Determines whether the curve should be split at discontinuities.
applyCurveSmoothing
Type: SystemBoolean
If true, activates the 'SMOOTH ON' option in PowerShape. If false, activates 'SMOOTH OFF'.
Remarks
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.OffsetPointsOnCurve Method

PSSurfaceCurveOffsetPointsOnCurve Method

Offsets the indicated points on the surface curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void OffsetPointsOnCurve(
    float distanceToOffset,
    OffsetSplitAtDiscontinuity discontinuityBehaviour,
    bool applyCurveSmoothing,
    int[] pointNumbersToOffset
)
Public Sub OffsetPointsOnCurve (
    distanceToOffset As Single,
    discontinuityBehaviour As OffsetSplitAtDiscontinuity,
    applyCurveSmoothing As Boolean,
    pointNumbersToOffset As Integer()
)

Parameters

distanceToOffset
Type: SystemSingle
Distance to offset points.
discontinuityBehaviour
Type: Autodesk.ProductInterface.PowerSHAPEOffsetSplitAtDiscontinuity
OffsetSplitAtDiscontinuity object for handling SPLITON/OFF.
applyCurveSmoothing
Type: SystemBoolean
Boolean to apply curve smoothing.
pointNumbersToOffset
Type: SystemInt32
Array of points to offset. Index starts from zero.
Remarks
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.Rotate Method

PSSurfaceCurveRotate Method

Rotates a single surface curve by a specified angle around a specified axis.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    Point rotationOrigin = null
)
Public Sub Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    Optional rotationOrigin As Point = Nothing
)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the surface curve is are to be rotated.
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the surface curve is to be rotated.
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve.SelectCurvePoints Method

PSSurfaceCurveSelectCurvePoints Method

Selects the indicated points on the surface curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void SelectCurvePoints(
    int[] pointsToSelect
)
Public Sub SelectCurvePoints (
    pointsToSelect As Integer()
)

Parameters

pointsToSelect
Type: SystemInt32
Point numbers to be selected. Index for the points is zero based.
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve Fields

The PSSurfaceCurve type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _internalId | The internal ID of the Surface Curve.
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Protected field | _surface | The parent surface of the Surface Curve.
Top
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve._internalId Field

PSSurfaceCurve_internalId Field

The internal ID of the Surface Curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected Guid _internalId
Protected _internalId As Guid

Field Value

Type: Guid
Remarks
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurve._surface Field

PSSurfaceCurve_surface Field

The parent surface of the Surface Curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSSurface _surface
Protected _surface As PSSurface

Field Value

Type: PSSurface
Remarks
See Also

Reference

PSSurfaceCurve Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurvesCollection(T) Class

PSSurfaceCurvesCollectionT Class

Base class for PSLateralsCollection and PSLongitudinalsCollection.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection T
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection T
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurvesCollectionT
Autodesk.ProductInterface.PowerSHAPEPSLateralsCollection
Autodesk.ProductInterface.PowerSHAPEPSLongitudinalsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSSurfaceCurvesCollection<T> : PSEntitiesCollection<T>
where T : PSSurfaceCurve

Public MustInherit Class PSSurfaceCurvesCollection(Of T As PSSurfaceCurve)
    Inherits PSEntitiesCollection(Of T)

Type Parameters

T
The type of PSSurfaceCurve.

The PSSurfaceCurvesCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | PSSurfaceCurvesCollectionT | Creates a new collection.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes surface curve from PowerShape and from surface curves collection. (Overrides PSEntitiesCollectionTRemove(T).)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _parentSurface | The parent surface of a PSSurface.
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurvesCollection(T) Constructor

PSSurfaceCurvesCollectionT Constructor

Creates a new collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurfaceCurvesCollection(
    PSAutomation powershape,
    PSSurface parentSurface
)
Public Sub New (
    powershape As PSAutomation,
    parentSurface As PSSurface
)

Parameters

powershape
Type: Autodesk.ProductInterface.PowerSHAPEPSAutomation
The base instance to interact with PowerShape.
parentSurface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The parent surface for the lateral.
See Also

Reference

PSSurfaceCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurvesCollection(T) Properties

PSSurfaceCurvesCollectionT Properties

The PSSurfaceCurvesCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSSurfaceCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurvesCollection(T) Methods

PSSurfaceCurvesCollectionT Methods

The PSSurfaceCurvesCollectionT generic type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all of the current entity type to the selection. (Inherited from PSEntitiesCollectionT.)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes surface curve from PowerShape and from surface curves collection. (Overrides PSEntitiesCollectionTRemove(T).)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurvesCollection(T).Remove Method

PSSurfaceCurvesCollectionTRemove Method

Overload List
 | Name | Description
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes surface curve from PowerShape and from surface curves collection. (Overrides PSEntitiesCollectionTRemove(T).)
Top
See Also

Reference

PSSurfaceCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurvesCollection(T).Remove Method (T)

PSSurfaceCurvesCollectionTRemove Method (T)

Removes surface curve from PowerShape and from surface curves collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Remove(
    T surfaceCurve
)
Public Overrides Function Remove (
    surfaceCurve As T
) As Boolean

Parameters

surfaceCurve
Type: T
The surface curve to delete.

Return Value

Type: Boolean
True if it removes curve from curves collection. False if it fails to remove curve from collection, but curve will be removed from PowerShape.
See Also

Reference

PSSurfaceCurvesCollectionT Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurvesCollection(T) Fields

PSSurfaceCurvesCollectionT Fields

The PSSurfaceCurvesCollectionT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _parentSurface | The parent surface of a PSSurface.
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSSurfaceCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCurvesCollection(T)._parentSurface Field

PSSurfaceCurvesCollectionT_parentSurface Field

The parent surface of a PSSurface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected PSSurface _parentSurface
Protected _parentSurface As PSSurface

Field Value

Type: PSSurface
Remarks
See Also

Reference

PSSurfaceCurvesCollectionT Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCylinder Class

Captures a Surface Cylinder object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCylinder

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfaceCylinder : PSPrimitive
Public Class PSSurfaceCylinder
    Inherits PSPrimitive

The PSSurfaceCylinder type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the cylinder
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and Sets the radius of the cylinder
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the cylinder, which is the area of the circular face, multiplied by its length, not 0 as returned by PowerSHAPE. (Overrides PSSurfaceVolume.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCylinder Properties

The PSSurfaceCylinder type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the cylinder
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and Sets the radius of the cylinder
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the cylinder, which is the area of the circular face, multiplied by its length, not 0 as returned by PowerSHAPE. (Overrides PSSurfaceVolume.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfaceCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCylinder.Length Property

PSSurfaceCylinderLength Property

Gets and Sets the length of the cylinder

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCylinder.Radius Property

PSSurfaceCylinderRadius Property

Gets and Sets the radius of the cylinder

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Radius { get; set; }
Public Property Radius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCylinder.Volume Property

PSSurfaceCylinderVolume Property

Gets the volume of the cylinder, which is the area of the circular face, multiplied by its length, not 0 as returned by PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override double Volume { get; }
Public Overrides ReadOnly Property Volume As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSurfaceCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCylinder Methods

The PSSurfaceCylinder type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceCylinder Fields

The PSSurfaceCylinder type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfaceCylinder Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceExtrusion Class

Captures a Surface Extrusion object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceExtrusion

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfaceExtrusion : PSPrimitive
Public Class PSSurfaceExtrusion
    Inherits PSPrimitive

The PSSurfaceExtrusion type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | DraftAngle | Gets and Sets the draft angle of the extrusion
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the extrusion
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NegativeLength | Gets and Sets the negative length of the extrusion
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceExtrusion Properties

The PSSurfaceExtrusion type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | DraftAngle | Gets and Sets the draft angle of the extrusion
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the extrusion
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NegativeLength | Gets and Sets the negative length of the extrusion
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfaceExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceExtrusion.DraftAngle Property

PSSurfaceExtrusionDraftAngle Property

Gets and Sets the draft angle of the extrusion

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree DraftAngle { get; set; }
Public Property DraftAngle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSurfaceExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceExtrusion.Length Property

PSSurfaceExtrusionLength Property

Gets and Sets the length of the extrusion

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceExtrusion.NegativeLength Property

PSSurfaceExtrusionNegativeLength Property

Gets and Sets the negative length of the extrusion

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM NegativeLength { get; set; }
Public Property NegativeLength As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceExtrusion Methods

The PSSurfaceExtrusion type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceExtrusion Fields

The PSSurfaceExtrusion type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfaceExtrusion Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacePlane Class

Captures a Surface Plane object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfacePlane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfacePlane : PSPrimitive
Public Class PSSurfacePlane
    Inherits PSPrimitive

The PSSurfacePlane type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the Plane
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Plane, which is 0 (Overrides PSSurfaceVolume.)
Public property | Width | Gets and Sets the width of the Plane
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacePlane Properties

The PSSurfacePlane type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Length | Gets and Sets the length of the Plane
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Plane, which is 0 (Overrides PSSurfaceVolume.)
Public property | Width | Gets and Sets the width of the Plane
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfacePlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacePlane.Length Property

PSSurfacePlaneLength Property

Gets and Sets the length of the Plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Length { get; set; }
Public Property Length As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfacePlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacePlane.Volume Property

PSSurfacePlaneVolume Property

Gets the volume of the Plane, which is 0

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override double Volume { get; }
Public Overrides ReadOnly Property Volume As Double
    Get

Property Value

Type: Double
See Also

Reference

PSSurfacePlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacePlane.Width Property

PSSurfacePlaneWidth Property

Gets and Sets the width of the Plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Width { get; set; }
Public Property Width As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfacePlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacePlane Methods

The PSSurfacePlane type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfacePlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacePlane Fields

The PSSurfacePlane type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfacePlane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceRevolution Class

Captures a Surface Revolution object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceRevolution

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfaceRevolution : PSPrimitive
Public Class PSSurfaceRevolution
    Inherits PSPrimitive

The PSSurfaceRevolution type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets and Sets the angle of the revolution
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceRevolution Properties

The PSSurfaceRevolution type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets and Sets the angle of the revolution
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfaceRevolution Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceRevolution.Angle Property

PSSurfaceRevolutionAngle Property

Gets and Sets the angle of the revolution

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Degree Angle { get; set; }
Public Property Angle As Degree
    Get
    Set

Property Value

Type: Degree
See Also

Reference

PSSurfaceRevolution Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceRevolution Methods

The PSSurfaceRevolution type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceRevolution Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceRevolution Fields

The PSSurfaceRevolution type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfaceRevolution Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection Class

Captures the collection of Surfaces in a Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSSurface
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSSurface
Autodesk.ProductInterface.PowerSHAPEPSSurfacesCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfacesCollection : PSEntitiesCollection<PSSurface>
Public Class PSSurfacesCollection
    Inherits PSEntitiesCollection(Of PSSurface)

The PSSurfacesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all Surfaces to the current selection. (Overrides PSEntitiesCollectionTAddToSelection(Boolean).)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateBlock | Creates a new surface block at the specified origin, with the specified height, width, length and draft angle for all walls.
Public method | CreateCylinder | Creates a new surface cylinder at the specified origin, radius and length.
Public method | CreateExtrudedSurface | Creates an extruded surface from wireframe.
Public method | CreateExtrudedSurfaces | Creates extruded surfaces from a list of wireframes.
Public method | CreateFilletSurfaces(PSSurface, PSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes) | Creates fillet surfaces from two individual surfaces.
Public method | CreateFilletSurfaces(ListPSSurface, ListPSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes) | Creates a fillet from the two lists of surfaces.
Public method | CreateFillInSurface | Creates a fill in Surface from the specified Curve or Composite Curve.
Public method | CreatePlane | Creates a plane at a specified origin.
Public method | CreatePlaneWithDimensions | Creates a plane at a specified origin and sets its length and width.
Public method | CreateRevolvedSurface | Creates a revolved surface from a list of wireframe.
Public method | CreateSphere | Creates a new surface sphere at the specified origin and radius.
Public method | CreateSurface | Creates a new Surface using PowerSHAPE's automatic surfacing methods. Any necessary wireframe must already be selected.
Public method | CreateSurfaceFromBreak | Breaks a surface at the indicated surface curve, so creating a new surface.
Public method | CreateSurfaceFromTriangles | Creates a surface from triangles using the specified parameters
Public method | CreateSurfacesFromSolid | Converts a solid into surfaces.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection Properties

The PSSurfacesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection Methods

The PSSurfacesCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Adds all Surfaces to the current selection. (Overrides PSEntitiesCollectionTAddToSelection(Boolean).)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateBlock | Creates a new surface block at the specified origin, with the specified height, width, length and draft angle for all walls.
Public method | CreateCylinder | Creates a new surface cylinder at the specified origin, radius and length.
Public method | CreateExtrudedSurface | Creates an extruded surface from wireframe.
Public method | CreateExtrudedSurfaces | Creates extruded surfaces from a list of wireframes.
Public method | CreateFilletSurfaces(PSSurface, PSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes) | Creates fillet surfaces from two individual surfaces.
Public method | CreateFilletSurfaces(ListPSSurface, ListPSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes) | Creates a fillet from the two lists of surfaces.
Public method | CreateFillInSurface | Creates a fill in Surface from the specified Curve or Composite Curve.
Public method | CreatePlane | Creates a plane at a specified origin.
Public method | CreatePlaneWithDimensions | Creates a plane at a specified origin and sets its length and width.
Public method | CreateRevolvedSurface | Creates a revolved surface from a list of wireframe.
Public method | CreateSphere | Creates a new surface sphere at the specified origin and radius.
Public method | CreateSurface | Creates a new Surface using PowerSHAPE's automatic surfacing methods. Any necessary wireframe must already be selected.
Public method | CreateSurfaceFromBreak | Breaks a surface at the indicated surface curve, so creating a new surface.
Public method | CreateSurfaceFromTriangles | Creates a surface from triangles using the specified parameters
Public method | CreateSurfacesFromSolid | Converts a solid into surfaces.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.AddToSelection Method

PSSurfacesCollectionAddToSelection Method

Adds all Surfaces to the current selection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void AddToSelection(
    bool emptySelectionFirst = false
)
Public Overrides Sub AddToSelection (
    Optional emptySelectionFirst As Boolean = false
)

Parameters

emptySelectionFirst (Optional)
Type: SystemBoolean
If true it will empty the PowerShape selection first.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateBlock Method

PSSurfacesCollectionCreateBlock Method

Creates a new surface block at the specified origin, with the specified height, width, length and draft angle for all walls.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurfaceBlock CreateBlock(
    Point origin,
    MM width,
    MM length,
    MM height,
    Degree draftAngle
)
Public Function CreateBlock (
    origin As Point,
    width As MM,
    length As MM,
    height As MM,
    draftAngle As Degree
) As PSSurfaceBlock

Parameters

origin
Type: Autodesk.GeometryPoint
The origin at which to create the block.
width
Type: Autodesk.GeometryMM
The width of the block.
length
Type: Autodesk.GeometryMM
The length of the block.
height
Type: Autodesk.GeometryMM
The height of the block.
draftAngle
Type: Autodesk.GeometryDegree
The draft angle to use for all walls.

Return Value

Type: PSSurfaceBlock
The created block.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateCylinder Method

PSSurfacesCollectionCreateCylinder Method

Creates a new surface cylinder at the specified origin, radius and length.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurfaceCylinder CreateCylinder(
    Point origin,
    MM radius,
    MM length
)
Public Function CreateCylinder (
    origin As Point,
    radius As MM,
    length As MM
) As PSSurfaceCylinder

Parameters

origin
Type: Autodesk.GeometryPoint
The origin at which to create the cylinder.
radius
Type: Autodesk.GeometryMM
The radius of the cylinder.
length
Type: Autodesk.GeometryMM
The length of the cylinder.

Return Value

Type: PSSurfaceCylinder
The created cylinder.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateExtrudedSurface Method

PSSurfacesCollectionCreateExtrudedSurface Method

Creates an extruded surface from wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface CreateExtrudedSurface(
    PSWireframe wireframe,
    MM length,
    MM negLength
)
Public Function CreateExtrudedSurface (
    wireframe As PSWireframe,
    length As MM,
    negLength As MM
) As PSSurface

Parameters

wireframe
Type: Autodesk.ProductInterface.PowerSHAPEPSWireframe
The wireframe from which an extruded surface will be created.
length
Type: Autodesk.GeometryMM
The length of the extruded surface.
negLength
Type: Autodesk.GeometryMM
The negative length of the extruded surface.

Return Value

Type: PSSurface
The new surface.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateExtrudedSurfaces Method

PSSurfacesCollectionCreateExtrudedSurfaces Method

Creates extruded surfaces from a list of wireframes.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSurface> CreateExtrudedSurfaces(
    IEnumerable<PSWireframe> wireframes,
    MM length,
    MM negLength
)
Public Function CreateExtrudedSurfaces (
    wireframes As IEnumerable(Of PSWireframe),
    length As MM,
    negLength As MM
) As List(Of PSSurface)

Parameters

wireframes
Type: System.Collections.GenericIEnumerable PSWireframe
The list of wireframes from which an extruded surface will be created.
length
Type: Autodesk.GeometryMM
The length of the extruded surface.
negLength
Type: Autodesk.GeometryMM
The negative length of the extruded surface.

Return Value

Type: List PSSurface
The new surface.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateFilletSurfaces Method

PSSurfacesCollectionCreateFilletSurfaces Method

Overload List
 | Name | Description
Public method | CreateFilletSurfaces(PSSurface, PSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes) | Creates fillet surfaces from two individual surfaces.
Public method | CreateFilletSurfaces(ListPSSurface, ListPSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes) | Creates a fillet from the two lists of surfaces.
Top
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateFilletSurfaces Method (PSSurface, PSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes)

PSSurfacesCollectionCreateFilletSurfaces Method (PSSurface, PSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes)

Creates fillet surfaces from two individual surfaces.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSurface> CreateFilletSurfaces(
    PSSurface firstSurface,
    PSSurface secondSurface,
    double filletRadius,
    FilletTypes filletType,
    FilletTrimOptions filletTrim,
    FilletRouteOptions filletRoute,
    FilletCreaseOptions filletCrease,
    FilletCornerTypes filletCorners
)
Public Function CreateFilletSurfaces (
    firstSurface As PSSurface,
    secondSurface As PSSurface,
    filletRadius As Double,
    filletType As FilletTypes,
    filletTrim As FilletTrimOptions,
    filletRoute As FilletRouteOptions,
    filletCrease As FilletCreaseOptions,
    filletCorners As FilletCornerTypes
) As List(Of PSSurface)

Parameters

firstSurface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The primary surface to fillet.
secondSurface
Type: Autodesk.ProductInterface.PowerSHAPEPSSurface
The secondary surface to fillet.
filletRadius
Type: SystemDouble
The radius of the fillet.
filletType
Type: Autodesk.ProductInterface.PowerSHAPEFilletTypes
Whether the fillet is concave or convex.
filletTrim
Type: Autodesk.ProductInterface.PowerSHAPEFilletTrimOptions
Whether the creation of the fillet trims surrounding surfaces.
filletRoute
Type: Autodesk.ProductInterface.PowerSHAPEFilletRouteOptions
whether the fillet follows all possible routes.
filletCrease
Type: Autodesk.ProductInterface.PowerSHAPEFilletCreaseOptions
Whether the fillet is created along creases.
filletCorners
Type: Autodesk.ProductInterface.PowerSHAPEFilletCornerTypes
Whether any corners are Roll, Mitre or Round.

Return Value

Type: List PSSurface
The list of created surfaces.
See Also

Reference

PSSurfacesCollection Class
CreateFilletSurfaces Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateFilletSurfaces Method (List(PSSurface), List(PSSurface), Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes)

PSSurfacesCollectionCreateFilletSurfaces Method (ListPSSurface, ListPSSurface, Double, FilletTypes, FilletTrimOptions, FilletRouteOptions, FilletCreaseOptions, FilletCornerTypes)

Creates a fillet from the two lists of surfaces.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSurface> CreateFilletSurfaces(
    List<PSSurface> firstSurfaces,
    List<PSSurface> secondSurfaces,
    double filletRadius,
    FilletTypes filletType,
    FilletTrimOptions filletTrim,
    FilletRouteOptions filletRoute,
    FilletCreaseOptions filletCrease,
    FilletCornerTypes filletCorners
)
Public Function CreateFilletSurfaces (
    firstSurfaces As List(Of PSSurface),
    secondSurfaces As List(Of PSSurface),
    filletRadius As Double,
    filletType As FilletTypes,
    filletTrim As FilletTrimOptions,
    filletRoute As FilletRouteOptions,
    filletCrease As FilletCreaseOptions,
    filletCorners As FilletCornerTypes
) As List(Of PSSurface)

Parameters

firstSurfaces
Type: System.Collections.GenericList PSSurface
The primary surfaces to fillet.
secondSurfaces
Type: System.Collections.GenericList PSSurface
The secondary surfaces to fillet.
filletRadius
Type: SystemDouble
The radius of the fillet.
filletType
Type: Autodesk.ProductInterface.PowerSHAPEFilletTypes
Whether the fillet is concave or convex.
filletTrim
Type: Autodesk.ProductInterface.PowerSHAPEFilletTrimOptions
Whether the creation of the fillet trims surrounding surfaces.
filletRoute
Type: Autodesk.ProductInterface.PowerSHAPEFilletRouteOptions
whether the fillet follows all possible routes.
filletCrease
Type: Autodesk.ProductInterface.PowerSHAPEFilletCreaseOptions
Whether the fillet is created along creases.
filletCorners
Type: Autodesk.ProductInterface.PowerSHAPEFilletCornerTypes
Whether any corners are Roll, Mitre or Round.

Return Value

Type: List PSSurface
The list of created surfaces.
See Also

Reference

PSSurfacesCollection Class
CreateFilletSurfaces Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateFillInSurface Method

PSSurfacesCollectionCreateFillInSurface Method

Creates a fill in Surface from the specified Curve or Composite Curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface CreateFillInSurface(
    PSGenericCurve genericCurve
)
Public Function CreateFillInSurface (
    genericCurve As PSGenericCurve
) As PSSurface

Parameters

genericCurve
Type: Autodesk.ProductInterface.PowerSHAPEPSGenericCurve
The curve or composite curve from which to create the fill in surface.

Return Value

Type: PSSurface
The new surface.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreatePlane Method

PSSurfacesCollectionCreatePlane Method

Creates a plane at a specified origin.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurfacePlane CreatePlane(
    Point origin,
    Planes principalPlane
)
Public Function CreatePlane (
    origin As Point,
    principalPlane As Planes
) As PSSurfacePlane

Parameters

origin
Type: Autodesk.GeometryPoint
The origin at which to create the plane.
principalPlane
Type: AutodeskPlanes
Sets the principal plane. Defines which plane is the principal plane of the workspace.

Return Value

Type: PSSurfacePlane
The created plane.
Remarks
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreatePlaneWithDimensions Method

PSSurfacesCollectionCreatePlaneWithDimensions Method

Creates a plane at a specified origin and sets its length and width.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurfacePlane CreatePlaneWithDimensions(
    Point origin,
    Planes principalPlane,
    MM length,
    MM width
)
Public Function CreatePlaneWithDimensions (
    origin As Point,
    principalPlane As Planes,
    length As MM,
    width As MM
) As PSSurfacePlane

Parameters

origin
Type: Autodesk.GeometryPoint
The origin at which to create the plane.
principalPlane
Type: AutodeskPlanes
Sets the principal plane. Defines which plane is the principal plane of the workspace.
length
Type: Autodesk.GeometryMM
The desired length of the plane.
width
Type: Autodesk.GeometryMM
The desired width of the plane.

Return Value

Type: PSSurfacePlane
The created plane.
Remarks
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateRevolvedSurface Method

PSSurfacesCollectionCreateRevolvedSurface Method

Creates a revolved surface from a list of wireframe.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurfaceRevolution CreateRevolvedSurface(
    Axes rotationAxis,
    Degree angleOfRevolution,
    PSWireframe wireframe
)
Public Function CreateRevolvedSurface (
    rotationAxis As Axes,
    angleOfRevolution As Degree,
    wireframe As PSWireframe
) As PSSurfaceRevolution

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which to revolve the surface.
angleOfRevolution
Type: Autodesk.GeometryDegree
The angle round which to revolve.
wireframe
Type: Autodesk.ProductInterface.PowerSHAPEPSWireframe
The wireframe representing the profile of the surface.

Return Value

Type: PSSurfaceRevolution
A revolved surface.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateSphere Method

PSSurfacesCollectionCreateSphere Method

Creates a new surface sphere at the specified origin and radius.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurfaceSphere CreateSphere(
    Point origin,
    MM radius
)
Public Function CreateSphere (
    origin As Point,
    radius As MM
) As PSSurfaceSphere

Parameters

origin
Type: Autodesk.GeometryPoint
Origin at which to create the sphere.
radius
Type: Autodesk.GeometryMM
Radius of the sphere.

Return Value

Type: PSSurfaceSphere
The created sphere.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateSurface Method

PSSurfacesCollectionCreateSurface Method

Creates a new Surface using PowerSHAPE's automatic surfacing methods. Any necessary wireframe must already be selected.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface CreateSurface(
    AutomaticSurfacingMethods automaticSurfacingMethod,
    AutomaticSurfaceTypes surfaceType,
    SurfaceAdvancedOptions advancedSurfaceOptions = null
)
Public Function CreateSurface (
    automaticSurfacingMethod As AutomaticSurfacingMethods,
    surfaceType As AutomaticSurfaceTypes,
    Optional advancedSurfaceOptions As SurfaceAdvancedOptions = Nothing
) As PSSurface

Parameters

automaticSurfacingMethod
Type: Autodesk.ProductInterface.PowerSHAPEAutomaticSurfacingMethods
The method to use to create the surface.
surfaceType
Type: Autodesk.ProductInterface.PowerSHAPEAutomaticSurfaceTypes
The type of the new surface NURBS or a PowerSurface.
advancedSurfaceOptions (Optional)
Type: Autodesk.ProductInterface.PowerSHAPESurfaceAdvancedOptions
The advanced surface option that can be used when creating the surface.

Return Value

Type: PSSurface
The new surface.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateSurfaceFromBreak Method

PSSurfacesCollectionCreateSurfaceFromBreak Method

Breaks a surface at the indicated surface curve, so creating a new surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface CreateSurfaceFromBreak(
    PSSurfaceCurve breakCurve
)
Public Function CreateSurfaceFromBreak (
    breakCurve As PSSurfaceCurve
) As PSSurface

Parameters

breakCurve
Type: Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve
The surface curve at which to break the surface.

Return Value

Type: PSSurface
The surface created by the operation.
Remarks
The original surface is derived from the breakCurve parameter.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateSurfaceFromTriangles Method

PSSurfacesCollectionCreateSurfaceFromTriangles Method

Creates a surface from triangles using the specified parameters

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSSurface CreateSurfaceFromTriangles(
    PSMesh mesh,
    List<PSGenericCurve> boundariesAndIslands = null,
    double pointsProportion = 25,
    double orientationAngle = 0,
    int numberOfPatches = 10
)
Public Function CreateSurfaceFromTriangles (
    mesh As PSMesh,
    Optional boundariesAndIslands As List(Of PSGenericCurve) = Nothing,
    Optional pointsProportion As Double = 25,
    Optional orientationAngle As Double = 0,
    Optional numberOfPatches As Integer = 10
) As PSSurface

Parameters

mesh
Type: Autodesk.ProductInterface.PowerSHAPEPSMesh
The mesh from which to create the surface
boundariesAndIslands (Optional)
Type: System.Collections.GenericList PSGenericCurve

[Missing <param name="boundariesAndIslands"/> documentation for "M:Autodesk.ProductInterface.PowerSHAPE.PSSurfacesCollection.CreateSurfaceFromTriangles(Autodesk.ProductInterface.PowerSHAPE.PSMesh,System.Collections.Generic.List{Autodesk.ProductInterface.PowerSHAPE.PSGenericCurve},System.Double,System.Double,System.Int32)"]

pointsProportion (Optional)
Type: SystemDouble
The points proportion. Defaults to 25.0
orientationAngle (Optional)
Type: SystemDouble
The orientation angle of the surface. Defaults to 0.0
numberOfPatches (Optional)
Type: SystemInt32
The number of surface patches. Defaults to 10

Return Value

Type: PSSurface
The created surface.
Exceptions
Exception | Condition
Exception | Failed to create surface from Mesh.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection.CreateSurfacesFromSolid Method

PSSurfacesCollectionCreateSurfacesFromSolid Method

Converts a solid into surfaces.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSSurface> CreateSurfacesFromSolid(
    PSSolid solidToConvert
)
Public Function CreateSurfacesFromSolid (
    solidToConvert As PSSolid
) As List(Of PSSurface)

Parameters

solidToConvert
Type: Autodesk.ProductInterface.PowerSHAPEPSSolid
The solid to be converted into surfaces.

Return Value

Type: List PSSurface
The list of the surfaces created from the solid.
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfacesCollection Fields

The PSSurfacesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSSurfacesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSphere Class

Captures a Surface Sphere object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceSphere

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfaceSphere : PSPrimitive
Public Class PSSurfaceSphere
    Inherits PSPrimitive

The PSSurfaceSphere type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and sets the radius of the sphere in MM
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSphere Properties

The PSSurfaceSphere type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Radius | Gets and sets the radius of the sphere in MM
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfaceSphere Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSphere.Radius Property

PSSurfaceSphereRadius Property

Gets and sets the radius of the sphere in MM

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Radius { get; set; }
Public Property Radius As MM
    Get
    Set

Property Value

Type: MM
The new radius of the sphere

Return Value

Type: MM
The radius of the sphere
See Also

Reference

PSSurfaceSphere Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSphere Methods

The PSSurfaceSphere type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceSphere Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSphere Fields

The PSSurfaceSphere type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfaceSphere Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring Class

Captures a Surface Spring object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceSpring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfaceSpring : PSPrimitive
Public Class PSSurfaceSpring
    Inherits PSPrimitive

The PSSurfaceSpring type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BaseRadius | Gets and Sets the base radius of the spring
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Height | Gets and Sets the height of the spring
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | Pitch | Gets and Sets the pitch of the spring
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | TopRadius | Gets and Sets the top radius of the spring
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Turns | Gets and Sets the turns of the spring
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring Properties

The PSSurfaceSpring type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BaseRadius | Gets and Sets the base radius of the spring
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Height | Gets and Sets the height of the spring
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | Pitch | Gets and Sets the pitch of the spring
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | TopRadius | Gets and Sets the top radius of the spring
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Turns | Gets and Sets the turns of the spring
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfaceSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring.BaseRadius Property

PSSurfaceSpringBaseRadius Property

Gets and Sets the base radius of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM BaseRadius { get; set; }
Public Property BaseRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring.Height Property

PSSurfaceSpringHeight Property

Gets and Sets the height of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM Height { get; set; }
Public Property Height As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring.Pitch Property

PSSurfaceSpringPitch Property

Gets and Sets the pitch of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Pitch { get; set; }
Public Property Pitch As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSSurfaceSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring.TopRadius Property

PSSurfaceSpringTopRadius Property

Gets and Sets the top radius of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public MM TopRadius { get; set; }
Public Property TopRadius As MM
    Get
    Set

Property Value

Type: MM
See Also

Reference

PSSurfaceSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring.Turns Property

PSSurfaceSpringTurns Property

Gets and Sets the turns of the spring

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public double Turns { get; set; }
Public Property Turns As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PSSurfaceSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring Methods

The PSSurfaceSpring type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceSpring Fields

The PSSurfaceSpring type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfaceSpring Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceTorus Class

Captures a Surface Torus object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSSurface
Autodesk.ProductInterface.PowerSHAPEPSPrimitive
Autodesk.ProductInterface.PowerSHAPEPSSurfaceTorus

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSSurfaceTorus : PSPrimitive
Public Class PSSurfaceTorus
    Inherits PSPrimitive

The PSSurfaceTorus type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceTorus Properties

The PSSurfaceTorus type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets the area of the Surface. (Inherited from PSSurface.)
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the coordinates of the centre of gravity of the Surface. (Inherited from PSSurface.)
Public property | Direction | Gets the direction of the Surface. (Inherited from PSSurface.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | HasSpine | Gets whether the surface has a spine. (Inherited from PSSurface.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsClosedLaterals | Gets and sets whether the Surface laterals are closed. (Inherited from PSSurface.)
Public property | IsClosedLongitudinals | Gets and sets whether the Surface longitudinals are closed. (Inherited from PSSurface.)
Public property | IsTrimmed | Gets and sets the Trim status of the Surface. (Inherited from PSSurface.)
Public property | IsTrimmingValid | Gets the Trim validity of the Surface. (Inherited from PSSurface.)
Public property | Laterals | Gets the list of laterals on the surface. (Inherited from PSSurface.)
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Longitudinals | Gets the list of longitudinals on the surface. (Inherited from PSSurface.)
Public property | Material | Gets and Sets the material of the Surface in PowerSHAPE. (Inherited from PSSurface.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberOfBoundaries | Gets the number of boundaries on the surface. (Inherited from PSSurface.)
Public property | NumberOfLaterals | Gets the number of laterals on the surface. (Inherited from PSSurface.)
Public property | NumberOfLongitudinals | Gets the number of longitudinals on the surface. (Inherited from PSSurface.)
Public property | NumberOfPCurves | Gets the number of pCurves on the surface. (Inherited from PSSurface.)
Public property | Origin | Gets the origin of the primitive (Inherited from PSPrimitive.)
Public property | PCurves | Gets a list of the PCurves on the surface. (Inherited from PSSurface.)
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Shape | Gets the primitive shape of the Surface. (Inherited from PSSurface.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Type | Gets the type of the Surface. (Inherited from PSSurface.)
Public property | Volume | Gets the volume of the Surface. (Inherited from PSSurface.)
Public property | XAxis | Gets the X axis of the primitive (Inherited from PSPrimitive.)
Public property | YAxis | Gets the Y axis of the primitive (Inherited from PSPrimitive.)
Public property | ZAxis | Gets the Z axis of the primitive (Inherited from PSPrimitive.)
Top
See Also

Reference

PSSurfaceTorus Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceTorus Methods

The PSSurfaceTorus type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddEntitiesToEntity | Adds entities to another entity. (Inherited from PSSurface.)
Public method | AddEntityToEntity | Adds an entity to another entity. (Inherited from PSSurface.)
Public method | AddSurfaceCurveByParameter | Adds a new surface curve at the point indicated. (Inherited from PSSurface.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AppendToSurface | Appends another surface onto this surface, retaining this surface. (Inherited from PSSurface.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | ConvertBoundaryToCompCurve | Converts a boundary on a surface into a composite curve. (Inherited from PSSurface.)
Public method | ConvertSurfaceCurvesToWireframe | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | ConvertSurfaceToPowerSurface | Converts the indicated surface curves to be wireframe. Curves can only be converted in one direction at once. (Inherited from PSSurface.)
Public method | Delete | Deletes the Surface from PowerSHAPE and removes it from the Surfaces collection. (Inherited from PSSurface.)
Public method | DeleteBoundary | Operation deletes a boundary from the surface and then switches trim region editing off. (Inherited from PSSurface.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSSurface.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Public method | Extend | Extends one edge of the Surface. (Inherited from PSSurface.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetMaxCurvature | Gets the maximum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetMinCurvature | Gets the minimum curvature at a position defined by TU parameters. (Inherited from PSSurface.)
Public method | GetNearestNormal | Gets the normal of the surface a the point nearest to the specified reference point (Inherited from PSSurface.)
Public method | GetNearestTUParameters | Gets the nearest TU parameters to an external point. (Inherited from PSSurface.)
Public method | GetNormal | Gets the normal of the Surface at the specified point (default is centre of surface). (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double) | Gets the coordinates of a position on the surface defined byb TU parameters. (Inherited from PSSurface.)
Public method | GetSurfacePoint(Double, Double) | Gets the coordinates of a position on the surface defined by TU paremeters. (Inherited from PSSurface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectEntitiesWithEntity | Intersects a collection of entities with another entity. (Inherited from PSSurface.)
Public method | IntersectEntityWithEntity | Intersects an entity with another entity. (Inherited from PSSurface.)
Public method | LimitToEntities | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitToEntity | Limits a surface by a specified list of entities. (Inherited from PSSurface.)
Public method | LimitUsingDynamicCutter | Limits using the dynamic cutter option. (Inherited from PSSurface.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single surface in a specified plane. (Inherited from PSSurface.)
Public method | MoveBetweenPoints | Moves a single surface by the relative distance between two absolute positions. (Inherited from PSSurface.)
Public method | MoveByVector | Moves a single surface by a specified relative amount. (Inherited from PSSurface.)
Public method | NearestPoint | Gets the nearest point on the surface compared to the specified point (Inherited from PSSurface.)
Public method | Offset | Offsets the surface along its normal by the desired distance, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ReverseDirectionOfSurfaceCurves | Reverses the direction of the surface curves. (Inherited from PSSurface.)
Public method | ReverseSurfaceNormal | Reverses the normal of the Surface. (Inherited from PSSurface.)
Public method | Rotate | Rotates a single surface by a specified angle around a specified axis. (Inherited from PSSurface.)
Public method | Scale | Scales a surface within PowerSHAPE, returning a PowerSurface. Because the type of the surface might have changed, this object no longer exists - any subsequent operations must be carried out on the returned surface. (Inherited from PSSurface.)
Public method | SelectLateralAndLongitudinalSurfaceCurves | Selects one or more lateral and longitudinal curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(PSSurfaceCurve) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | SelectSurfaceCurves(SurfaceCurveTypes, Int32) | Selects one or more curves on the Surface. (Inherited from PSSurface.)
Public method | StitchToCurve | Stitches the surface to a curve or compcurve. (Inherited from PSSurface.)
Public method | StitchToSurface | Stitches the surface to another surface. (Inherited from PSSurface.)
Public method | StitchToSurfaceCurve | Stitches the surface to a surface curve. (Inherited from PSSurface.)
Public method | SubtractEntitiesFromEntity | Subtracts a collection of entities from another entity. (Inherited from PSSurface.)
Public method | SubtractEntityFromEntity | Subtracts an entity from another entity. (Inherited from PSSurface.)
Public method | SwapSurfaceCurves | Swaps the laterals and longitudinals of a surface - laterals become longitudinals and longitudinals become laterals. (Inherited from PSSurface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSSurfaceTorus Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSSurfaceTorus Fields

The PSSurfaceTorus type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSSurfaceTorus Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow Class

Represents a window in PowerShape.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSWindow

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSWindow : PSDatabaseEntity
Public Class PSWindow
    Inherits PSDatabaseEntity

The PSWindow type exposes the following members.

Properties
 | Name | Description
Public property | AttachedProcessName | Gets the name of the loaded model or drawing.
Public property | Exists | Checks whether the Window exists. (Overrides PSDatabaseEntityExists.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets whether the Window is currently active.
Public property | Name | As the name command "is not implemented for this type of entity", this property gets and sets the number of the window. (Overrides PSDatabaseEntityName.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Type | Gets the type of the window.
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeActive | Brings the current window to the front.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow Properties

The PSWindow type exposes the following members.

Properties
 | Name | Description
Public property | AttachedProcessName | Gets the name of the loaded model or drawing.
Public property | Exists | Checks whether the Window exists. (Overrides PSDatabaseEntityExists.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets whether the Window is currently active.
Public property | Name | As the name command "is not implemented for this type of entity", this property gets and sets the number of the window. (Overrides PSDatabaseEntityName.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Type | Gets the type of the window.
Top
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow.AttachedProcessName Property

PSWindowAttachedProcessName Property

Gets the name of the loaded model or drawing.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public string AttachedProcessName { get; }
Public ReadOnly Property AttachedProcessName As String
    Get

Property Value

Type: String
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow.Exists Property

PSWindowExists Property

Checks whether the Window exists.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override bool Exists { get; }
Public Overrides ReadOnly Property Exists As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow.IsActive Property

PSWindowIsActive Property

Gets whether the Window is currently active.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow.Name Property

PSWindowName Property

As the name command "is not implemented for this type of entity", this property gets and sets the number of the window.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow.Type Property

PSWindowType Property

Gets the type of the window.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public WindowTypes Type { get; }
Public ReadOnly Property Type As WindowTypes
    Get

Return Value

Type: WindowTypes
The window type - drawing or model.
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow Methods

The PSWindow type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeActive | Brings the current window to the front.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow.MakeActive Method

PSWindowMakeActive Method

Brings the current window to the front.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void MakeActive()
Public Sub MakeActive
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindow Fields

The PSWindow type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSWindow Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection Class

Collection of Windows in CustomCore.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSWindow
Autodesk.ProductInterface.PowerSHAPEPSWindowsCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSWindowsCollection : PSDatabaseEntitiesCollection<PSWindow>
Public Class PSWindowsCollection
    Inherits PSDatabaseEntitiesCollection(Of PSWindow)

The PSWindowsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed window from the the collection.
Public property | ItemString | Gets the desired named window from the the collection.
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Clear | Closes and removes all windows in the list. (Overrides PSDatabaseEntitiesCollectionTClear.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the window with the specified name from the collection and from PowerShape.
Public method | Remove(PSWindow) | Removes the specified window.
Public method | RemoveAt | Removes the window at the specified index from the collection and from PowerShape. (Overrides PSDatabaseEntitiesCollectionTRemoveAt(Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection Properties

The PSWindowsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed window from the the collection.
Public property | ItemString | Gets the desired named window from the the collection.
Top
See Also

Reference

PSWindowsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection.Item Property

PSWindowsCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets the desired indexed window from the the collection.
Public property | ItemString | Gets the desired named window from the the collection.
Top
See Also

Reference

PSWindowsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection.Item Property (Int32)

PSWindowsCollectionItem Property (Int32)

Gets the desired indexed window from the the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWindow this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As PSWindow
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: PSWindow
The index of the desired window.

Return Value

Type: PSWindow
The desired window.
See Also

Reference

PSWindowsCollection Class
Item Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection.Item Property (String)

PSWindowsCollectionItem Property (String)

Gets the desired named window from the the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWindow this[
    string name
] { get; set; }
Public Default Property Item (
    name As String
) As PSWindow
    Get
    Set

Parameters

name
Type: SystemString

Property Value

Type: PSWindow
The name of the desired window (which is synonymous with its number).

Return Value

Type: PSWindow
The desired window.
See Also

Reference

PSWindowsCollection Class
Item Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection Methods

The PSWindowsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Clear | Closes and removes all windows in the list. (Overrides PSDatabaseEntitiesCollectionTClear.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the window with the specified name from the collection and from PowerShape.
Public method | Remove(PSWindow) | Removes the specified window.
Public method | RemoveAt | Removes the window at the specified index from the collection and from PowerShape. (Overrides PSDatabaseEntitiesCollectionTRemoveAt(Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSWindowsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection.Clear Method

PSWindowsCollectionClear Method

Closes and removes all windows in the list.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Clear()
Public Overrides Sub Clear
See Also

Reference

PSWindowsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection.Remove Method

PSWindowsCollectionRemove Method

Overload List
 | Name | Description
Public method | Remove(String) | Removes the window with the specified name from the collection and from PowerShape.
Public method | Remove(PSWindow) | Removes the specified window.
Top
See Also

Reference

PSWindowsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection.Remove Method (String)

PSWindowsCollectionRemove Method (String)

Removes the window with the specified name from the collection and from PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Remove(
    string name
)
Public Function Remove (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the window.

Return Value

Type: Boolean
True if it succeeds.
Remarks
See Also

Reference

PSWindowsCollection Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection.Remove Method (PSWindow)

PSWindowsCollectionRemove Method (PSWindow)

Removes the specified window.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool Remove(
    PSWindow window
)
Public Function Remove (
    window As PSWindow
) As Boolean

Parameters

window
Type: Autodesk.ProductInterface.PowerSHAPEPSWindow
The window to delete.

Return Value

Type: Boolean
True if it succeeds.
Remarks
See Also

Reference

PSWindowsCollection Class
Remove Overload
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection.RemoveAt Method

PSWindowsCollectionRemoveAt Method

Removes the window at the specified index from the collection and from PowerShape.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void RemoveAt(
    int index
)
Public Overrides Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
Remarks
See Also

Reference

PSWindowsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWindowsCollection Fields

The PSWindowsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSWindowsCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe Class

Captures a wire frame model in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
More...

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class PSWireframe : PSEntity
Public MustInherit Class PSWireframe
    Inherits PSEntity

The PSWireframe type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe
Public property | EndPoint | Gets the end point of the wireframe
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the wireframe
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Gets the number of points in the wireframe
Public property | Point | Gets the point at the specified zero based index
Public property | Points | Gets the points on the Wireframe
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the item from PowerSHAPE and removes it from the correct collection if it is a member of one (Inherited from PSEntity.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface.
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWireframe
Autodesk.ProductInterface.PowerSHAPEPSArc
Autodesk.ProductInterface.PowerSHAPEPSGenericCurve
Autodesk.ProductInterface.PowerSHAPEPSLine
Autodesk.ProductInterface.PowerSHAPEPSpCurve
Autodesk.ProductInterface.PowerSHAPEPSSpine
Autodesk.ProductInterface.PowerSHAPEPSSurfaceCurve


PSWireframe Properties

The PSWireframe type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | CentreOfGravity | Gets the centre of gravity of the wireframe
Public property | EndPoint | Gets the end point of the wireframe
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Length | Gets the length of the wireframe
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | NumberPoints | Gets the number of points in the wireframe
Public property | Point | Gets the point at the specified zero based index
Public property | Points | Gets the points on the Wireframe
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | StartPoint | Gets the start point of the wireframe
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Top
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe.CentreOfGravity Property

PSWireframeCentreOfGravity Property

Gets the centre of gravity of the wireframe

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual Point CentreOfGravity { get; }
Public Overridable ReadOnly Property CentreOfGravity As Point
    Get

Property Value

Type: Point
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe.EndPoint Property

PSWireframeEndPoint Property

Gets the end point of the wireframe

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual Point EndPoint { get; }
Public Overridable ReadOnly Property EndPoint As Point
    Get

Property Value

Type: Point
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe.Length Property

PSWireframeLength Property

Gets the length of the wireframe

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual MM Length { get; }
Public Overridable ReadOnly Property Length As MM
    Get

Property Value

Type: MM
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe.NumberPoints Property

PSWireframeNumberPoints Property

Gets the number of points in the wireframe

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual int NumberPoints { get; }
Public Overridable ReadOnly Property NumberPoints As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe.Point Property

PSWireframePoint Property

Gets the point at the specified zero based index

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual Point this[
    int index
] { get; }
Public Overridable ReadOnly Property Point (
    index As Integer
) As Point
    Get

Parameters

index
Type: SystemInt32
The index of the required point

Property Value

Type: Point
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe.Points Property

PSWireframePoints Property

Gets the points on the Wireframe

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual List<Point> Points { get; }
Public Overridable ReadOnly Property Points As List(Of Point)
    Get

Property Value

Type: List Point
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe.StartPoint Property

PSWireframeStartPoint Property

Gets the start point of the wireframe

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual Point StartPoint { get; }
Public Overridable ReadOnly Property StartPoint As Point
    Get

Property Value

Type: Point
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe Methods

The PSWireframe type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the item from PowerSHAPE and removes it from the correct collection if it is a member of one (Inherited from PSEntity.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectOntoSurface | Projects a Curve onto a surface.
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe.ProjectOntoSurface Method

PSWireframeProjectOntoSurface Method

Projects a Curve onto a surface.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public virtual List<PSCompCurve> ProjectOntoSurface(
    PSEntity surface,
    ProjectionType projectionType,
    bool keepOriginal
)
Public Overridable Function ProjectOntoSurface (
    surface As PSEntity,
    projectionType As ProjectionType,
    keepOriginal As Boolean
) As List(Of PSCompCurve)

Parameters

surface
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The surface to wrap onto.
projectionType
Type: Autodesk.ProductInterface.PowerSHAPEProjectionType
The type of projection to be carried out.
keepOriginal
Type: SystemBoolean
If true, it deletes the original entity.

Return Value

Type: List PSCompCurve
List of entities created by the operation.
Remarks
The old CompCurve is removed, and this object's ID set to be the new ID.
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWireframe Fields

The PSWireframe type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSWireframe Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane Class

Captures an Workplane object in PowerSHAPE
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntity
Autodesk.ProductInterface.PowerSHAPEPSEntity
Autodesk.ProductInterface.PowerSHAPEPSWorkplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSWorkplane : PSEntity,
    IPSMoveable, IPSRotateable, IPSMirrorable
Public Class PSWorkplane
    Inherits PSEntity
    Implements IPSMoveable, IPSRotateable, IPSMirrorable

The PSWorkplane type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Overrides the BoundingBox property to return a box of volume 0 at the workplane origin (Overrides PSEntityBoundingBox.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets the active status of workplane. To set a workplane active use the ActiveWorkplane property on the Model
Public property | IsLocked | Gets and sets whether the workplane is locked
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Origin | Gets and sets the origin of the workplane
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | XAxis | Gets and sets the Vector that represents the X Axis for the Workplane
Public property | YAxis | Gets and sets the Vector that represents the Y Axis for the Workplane
Public property | ZAxis | Gets and sets the Vector that represents the Z Axis for the Workplane
Top
Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AlignToView | Aligns the workplane to the current view in PowerSHAPE
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Workplane from PowerSHAPE and removes it from the Workplanes collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single workplane in a specified plane
Public method | MoveBetweenPoints | Moves a single workplane by the relative distance between two absolute positions
Public method | MoveByVector | Moves a single workplane by a specified relative amount
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | Rotates a single workplane by a specified angle around a specified axis
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToWorkplane | Gets a Geometry Workplane that represents the workplane
Top
Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane Properties

The PSWorkplane type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Overrides the BoundingBox property to return a box of volume 0 at the workplane origin (Overrides PSEntityBoundingBox.)
Public property | Exists | Checks to see if the entity exists in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | Id | Gets the Id of the entity in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public property | IsActive | Gets the active status of workplane. To set a workplane active use the ActiveWorkplane property on the Model
Public property | IsLocked | Gets and sets whether the workplane is locked
Public property | Level | Gets and Sets the Level the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | LevelNumber | Gets and sets the Level Number the Entity is on in PowerSHAPE (Inherited from PSEntity.)
Public property | Name | Gets the Name of the entity in PowerSHAPE (Inherited from PSEntity.)
Public property | Origin | Gets and sets the origin of the workplane
Public property | PowerSHAPEType | Gets the PowerSHAPE name of the object (Inherited from PSEntity.)
Public property | PSAutomation | Gets the parent PSAutomation. (Inherited from PSDatabaseEntity.)
Public property | Transparency | Gets and Sets the transparency of the Entity in PowerSHAPE (Inherited from PSEntity.)
Public property | XAxis | Gets and sets the Vector that represents the X Axis for the Workplane
Public property | YAxis | Gets and sets the Vector that represents the Y Axis for the Workplane
Public property | ZAxis | Gets and sets the Vector that represents the Z Axis for the Workplane
Top
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.BoundingBox Property

PSWorkplaneBoundingBox Property

Overrides the BoundingBox property to return a box of volume 0 at the workplane origin

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override BoundingBox BoundingBox { get; }
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Property Value

Type: BoundingBox
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.IsActive Property

PSWorkplaneIsActive Property

Gets the active status of workplane. To set a workplane active use the ActiveWorkplane property on the Model

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.IsLocked Property

PSWorkplaneIsLocked Property

Gets and sets whether the workplane is locked

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsLocked { get; set; }
Public Property IsLocked As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.Origin Property

PSWorkplaneOrigin Property

Gets and sets the origin of the workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Point Origin { get; set; }
Public Property Origin As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.XAxis Property

PSWorkplaneXAxis Property

Gets and sets the Vector that represents the X Axis for the Workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector XAxis { get; set; }
Public Property XAxis As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.YAxis Property

PSWorkplaneYAxis Property

Gets and sets the Vector that represents the Y Axis for the Workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector YAxis { get; set; }
Public Property YAxis As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.ZAxis Property

PSWorkplaneZAxis Property

Gets and sets the Vector that represents the Z Axis for the Workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Vector ZAxis { get; set; }
Public Property ZAxis As Vector
    Get
    Set

Property Value

Type: Vector
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane Methods

The PSWorkplane type exposes the following members.

Methods
 | Name | Description
Protected method | AbortIfDoesNotExist | This operation throws an error if the item does not exist in PowerSHAPE. (Inherited from PSDatabaseEntity.)
Public method | AddToSelection | Adds the entity to the selection and optionally clears the current selection (Inherited from PSEntity.)
Public method | AlignToView | Aligns the workplane to the current view in PowerSHAPE
Public method | Blank | Blanks the Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | BlankExcept | Blanks everything apart from this Entity in PowerSHAPE (Inherited from PSEntity.)
Public method | Delete | Deletes the Workplane from PowerSHAPE and removes it from the Workplanes collection (Overrides PSEntityDelete.)
Public method | DistanceTo | Gets the distance between this entity and another (Inherited from PSEntity.)
Public method | Duplicate | Copies and pastes the Entity. NB:Any dependencies are also copied and cause an exception to be thrown. (Inherited from PSEntity.)
Public method | Equals | Compares the DatabaseEntity to another DatabaseEntity by checking their IDs. (Inherited from PSDatabaseEntity.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the GetHashCode function to return the ID as an integer (Inherited from PSEntity.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors a single workplane in a specified plane
Public method | MoveBetweenPoints | Moves a single workplane by the relative distance between two absolute positions
Public method | MoveByVector | Moves a single workplane by a specified relative amount
Public method | RebaseToWorkplane | Shifts the entity from being relative to one workplane to being relative to another (Inherited from PSEntity.)
Public method | RemoveFromSelection | Removes the Entity from the current selection (Inherited from PSEntity.)
Public method | Rotate | Rotates a single workplane by a specified angle around a specified axis
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToWorkplane | Gets a Geometry Workplane that represents the workplane
Top
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.AlignToView Method

PSWorkplaneAlignToView Method

Aligns the workplane to the current view in PowerSHAPE

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void AlignToView()
Public Sub AlignToView
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.Delete Method

PSWorkplaneDelete Method

Deletes the Workplane from PowerSHAPE and removes it from the Workplanes collection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Delete()
Public Overrides Sub Delete
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.Mirror Method

PSWorkplaneMirror Method

Mirrors a single workplane in a specified plane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Mirror(
    Planes mirrorPlane,
    Point mirrorPoint
)
Public Sub Mirror (
    mirrorPlane As Planes,
    mirrorPoint As Point
)

Parameters

mirrorPlane
Type: AutodeskPlanes
The plane about which to mirror the workplane
mirrorPoint
Type: Autodesk.GeometryPoint
The origin of the mirror plane

Implements

IPSMirrorableMirror(Planes, Point)
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.MoveBetweenPoints Method

PSWorkplaneMoveBetweenPoints Method

Moves a single workplane by the relative distance between two absolute positions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveBetweenPoints(
    Point moveOriginCoordinates,
    Point pointToMoveTo,
    int copiesToCreate
)
Public Function MoveBetweenPoints (
    moveOriginCoordinates As Point,
    pointToMoveTo As Point,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveOriginCoordinates
Type: Autodesk.GeometryPoint
The first of the two absolute positions
pointToMoveTo
Type: Autodesk.GeometryPoint
The second of the two absolute positions
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveBetweenPoints(Point, Point, Int32)
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.MoveByVector Method

PSWorkplaneMoveByVector Method

Moves a single workplane by a specified relative amount

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> MoveByVector(
    Vector moveVector,
    int copiesToCreate
)
Public Function MoveByVector (
    moveVector As Vector,
    copiesToCreate As Integer
) As List(Of PSEntity)

Parameters

moveVector
Type: Autodesk.GeometryVector
The relative amount by which the workplane will be moved
copiesToCreate
Type: SystemInt32
The number of copies that should be created by the operation

Return Value

Type: List PSEntity

Implements

IPSMoveableMoveByVector(Vector, Int32)
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.Rotate Method

PSWorkplaneRotate Method

Rotates a single workplane by a specified angle around a specified axis

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public List<PSEntity> Rotate(
    Axes rotationAxis,
    Degree rotationAngle,
    int copiesToCreate,
    Point rotationOrigin = null
)
Public Function Rotate (
    rotationAxis As Axes,
    rotationAngle As Degree,
    copiesToCreate As Integer,
    Optional rotationOrigin As Point = Nothing
) As List(Of PSEntity)

Parameters

rotationAxis
Type: AutodeskAxes
The axis around which the workplane is are to be rotated
rotationAngle
Type: Autodesk.GeometryDegree
The angle by which the workplane is to be rotated
copiesToCreate
Type: SystemInt32
The number of copies to create of the original workplane
rotationOrigin (Optional)
Type: Autodesk.GeometryPoint
The origin of the rotation axis

Return Value

Type: List PSEntity
A list of workplanes created by the operation. If numberOfCopies is 0, an empty list is returned

Implements

IPSRotateableRotate(Axes, Degree, Int32, Point)
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane.ToWorkplane Method

PSWorkplaneToWorkplane Method

Gets a Geometry Workplane that represents the workplane

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Workplane ToWorkplane()
Public Function ToWorkplane As Workplane

Return Value

Type: Workplane
The Geometry Workplane that represents the workplane
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplane Fields

The PSWorkplane type exposes the following members.

Fields
 | Name | Description
Protected field | _id | The database ID of the object. (Inherited from PSDatabaseEntity.)
Protected field | _levelNumber | (Inherited from PSEntity.)
Protected field | _name | The name of the object. (Inherited from PSDatabaseEntity.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntity.)
Top
See Also

Reference

PSWorkplane Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection Class

Captures the collection of Workplanes in a Project.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPEPSDatabaseEntitiesCollection PSWorkplane
Autodesk.ProductInterface.PowerSHAPEPSEntitiesCollection PSWorkplane
Autodesk.ProductInterface.PowerSHAPEPSWorkplanesCollection

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class PSWorkplanesCollection : PSEntitiesCollection<PSWorkplane>
Public Class PSWorkplanesCollection
    Inherits PSEntitiesCollection(Of PSWorkplane)

The PSWorkplanesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Overrides the AddToSelection in EntitiesCollection. (Overrides PSEntitiesCollectionTAddToSelection(Boolean).)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateWorkplane | This operation creates a new Workplane from a Geometry.Workplane and adds it to the collection.
Public method | CreateWorkplaneAlignedToEntity | Creates a new Workplane relative to an entity and adds it to the collection.
Public method | CreateWorkplaneAlignedToView | Creates a new Workplane oriented to the current view at the specified origin and adds it to the collection.
Public method | CreateWorkplaneAtEntity | Creates a new Workplane relative to an entity and adds it to the collection.
Public method | CreateWorkplaneFromThreePoints | Creates a new Workplane from three points.
Public method | CreateWorkplaneFromXYAxes | This operation creates a new Workplane from just an origin and an X and Y axis. The Z axis is created off the X and Y axes orientation.
Public method | CreateWorkplaneFromZAxis | This operation creates a new Workplane from just an origin and a Z axis. The X and Y axes are created off the Z axis orientation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection Properties

The PSWorkplanesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entities in the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemInt32 | Gets the desired indexed entity from the the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public property | ItemString | Gets the desired indexed entity from the the collection. (Inherited from PSEntitiesCollectionT.)
Top
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection Methods

The PSWorkplanesCollection type exposes the following members.

Methods
 | Name | Description
Protected method | Add | Adds a new DatabaseEntity to the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | AddToSelection | Overrides the AddToSelection in EntitiesCollection. (Overrides PSEntitiesCollectionTAddToSelection(Boolean).)
Public method | Clear | Removes all entities in the list. (Inherited from PSEntitiesCollectionT.)
Public method | Contains | Determines whether the indicated entity is contained within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CopyTo | Copies the contents of the collection to the specified DatabaseEntityCollection, starting at the specified index. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | CreateWorkplane | This operation creates a new Workplane from a Geometry.Workplane and adds it to the collection.
Public method | CreateWorkplaneAlignedToEntity | Creates a new Workplane relative to an entity and adds it to the collection.
Public method | CreateWorkplaneAlignedToView | Creates a new Workplane oriented to the current view at the specified origin and adds it to the collection.
Public method | CreateWorkplaneAtEntity | Creates a new Workplane relative to an entity and adds it to the collection.
Public method | CreateWorkplaneFromThreePoints | Creates a new Workplane from three points.
Public method | CreateWorkplaneFromXYAxes | This operation creates a new Workplane from just an origin and an X and Y axis. The Z axis is created off the X and Y axes orientation.
Public method | CreateWorkplaneFromZAxis | This operation creates a new Workplane from just an origin and a Z axis. The X and Y axes are created off the Z axis orientation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByName | Gets the entity with the specified name. If an entity with the specified names does not exist then Nothing is returned. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetEnumerator1 | Returns an enumerator of entities. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Index of item in the list. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | Insert | Inserts the specified entity into the desired position within the collection. (Inherited from PSDatabaseEntitiesCollectionT.)
Public method | LastItem | Gets the last entity in the List. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Removes the specified item by name from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | Remove(T) | Removes the specified item from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveAt | Removes the entity at the specified index from PowerShape and from the collection. (Inherited from PSEntitiesCollectionT.)
Public method | RemoveFromSelection | Removes all of the current entity type from the selection (Inherited from PSEntitiesCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection.AddToSelection Method

PSWorkplanesCollectionAddToSelection Method

Overrides the AddToSelection in EntitiesCollection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void AddToSelection(
    bool emptySelectionFirst = false
)
Public Overrides Sub AddToSelection (
    Optional emptySelectionFirst As Boolean = false
)

Parameters

emptySelectionFirst (Optional)
Type: SystemBoolean
The selection CANNOT be cleared first as workplanes cannot be selected along with other Entity types.
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection.CreateWorkplane Method

PSWorkplanesCollectionCreateWorkplane Method

This operation creates a new Workplane from a Geometry.Workplane and adds it to the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplane(
    Workplane workplane
)
Public Function CreateWorkplane (
    workplane As Workplane
) As PSWorkplane

Parameters

workplane
Type: Autodesk.GeometryWorkplane
The workplane from which to create a workplane in PowerSHAPE.

Return Value

Type: PSWorkplane
The created Workplane in PowerSHAPE.
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection.CreateWorkplaneAlignedToEntity Method

PSWorkplanesCollectionCreateWorkplaneAlignedToEntity Method

Creates a new Workplane relative to an entity and adds it to the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplaneAlignedToEntity(
    PSEntity entity,
    Point origin
)
Public Function CreateWorkplaneAlignedToEntity (
    entity As PSEntity,
    origin As Point
) As PSWorkplane

Parameters

entity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity on which to create the new Workplane.
origin
Type: Autodesk.GeometryPoint
The intended origin for the workplane.

Return Value

Type: PSWorkplane
The created workplane.
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection.CreateWorkplaneAlignedToView Method

PSWorkplanesCollectionCreateWorkplaneAlignedToView Method

Creates a new Workplane oriented to the current view at the specified origin and adds it to the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplaneAlignedToView(
    Point origin
)
Public Function CreateWorkplaneAlignedToView (
    origin As Point
) As PSWorkplane

Parameters

origin
Type: Autodesk.GeometryPoint
The intended origin for the workplane.

Return Value

Type: PSWorkplane
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection.CreateWorkplaneAtEntity Method

PSWorkplanesCollectionCreateWorkplaneAtEntity Method

Creates a new Workplane relative to an entity and adds it to the collection.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplaneAtEntity(
    PSEntity entity,
    NewWorkplaneInEntityPositions positionAtEntity
)
Public Function CreateWorkplaneAtEntity (
    entity As PSEntity,
    positionAtEntity As NewWorkplaneInEntityPositions
) As PSWorkplane

Parameters

entity
Type: Autodesk.ProductInterface.PowerSHAPEPSEntity
The entity on which to create the new Workplane.
positionAtEntity
Type: Autodesk.ProductInterface.PowerSHAPENewWorkplaneInEntityPositions
The position on the entity at which to create the workplane: Centre, Top, Bottom.

Return Value

Type: PSWorkplane
The created workplane.
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection.CreateWorkplaneFromThreePoints Method

PSWorkplanesCollectionCreateWorkplaneFromThreePoints Method

Creates a new Workplane from three points.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplaneFromThreePoints(
    Point origin,
    Point xAxisPoint,
    Point yAxisPoint
)
Public Function CreateWorkplaneFromThreePoints (
    origin As Point,
    xAxisPoint As Point,
    yAxisPoint As Point
) As PSWorkplane

Parameters

origin
Type: Autodesk.GeometryPoint
The origin of the workplane to be created.
xAxisPoint
Type: Autodesk.GeometryPoint
The point on the intended X axis of the workplane to be created.
yAxisPoint
Type: Autodesk.GeometryPoint
The point on the intended Y axis of the workplane to be created.

Return Value

Type: PSWorkplane
The created workplane in PowerSHAPE.
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection.CreateWorkplaneFromXYAxes Method

PSWorkplanesCollectionCreateWorkplaneFromXYAxes Method

This operation creates a new Workplane from just an origin and an X and Y axis. The Z axis is created off the X and Y axes orientation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplaneFromXYAxes(
    Point origin,
    Vector xAxis,
    Vector yAxis
)
Public Function CreateWorkplaneFromXYAxes (
    origin As Point,
    xAxis As Vector,
    yAxis As Vector
) As PSWorkplane

Parameters

origin
Type: Autodesk.GeometryPoint
The origin at which to create the new workplane.
xAxis
Type: Autodesk.GeometryVector
The X axis of the new workplane.
yAxis
Type: Autodesk.GeometryVector
The Y axis of the new workplane.

Return Value

Type: PSWorkplane
The created workplane.
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection.CreateWorkplaneFromZAxis Method

PSWorkplanesCollectionCreateWorkplaneFromZAxis Method

This operation creates a new Workplane from just an origin and a Z axis. The X and Y axes are created off the Z axis orientation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSWorkplane CreateWorkplaneFromZAxis(
    Point origin,
    Vector zAxis
)
Public Function CreateWorkplaneFromZAxis (
    origin As Point,
    zAxis As Vector
) As PSWorkplane

Parameters

origin
Type: Autodesk.GeometryPoint
The origin at which to create the new workplane.
zAxis
Type: Autodesk.GeometryVector
The Z axis of the new workplane.

Return Value

Type: PSWorkplane
The created workplane.
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


PSWorkplanesCollection Fields

The PSWorkplanesCollection type exposes the following members.

Fields
 | Name | Description
Protected field | _list | The DatabaseEntitiesCollection as a list and is used in place of 'Me'. (Inherited from PSDatabaseEntitiesCollectionT.)
Protected field | _powerSHAPE | The PowerSHAPE Automation object. (Inherited from PSDatabaseEntitiesCollectionT.)
Top
See Also

Reference

PSWorkplanesCollection Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SculptTypes Enumeration

Type of sculpting operation that will be performed.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SculptTypes
Public Enumeration SculptTypes
Members
Member name | Value | Description
Carve | 0 |
Deposit | 1 |
Smooth | 2 |
Erase | 3 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


SolidTypes Enumeration

Used to specify all Solid Types.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SolidTypes
Public Enumeration SolidTypes
Members
Member name | Value | Description
Plane | 0 |
Block | 1 |
Sphere | 2 |
Cylinder | 3 |
Cone | 4 |
Extrusion | 5 |
Torus | 6 |
Spring | 7 |
Revolution | 8 |
GeneralSolid | 9 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


SolidVersions Enumeration

Used to distinguish between a version 8 solid and parasolid in PowerSHAPE.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SolidVersions
Public Enumeration SolidVersions
Members
Member name | Value | Description
Version8 | 0 |
Parasolid | 1 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


StitchDirectionAcross Enumeration

Indicates whether the points should be matched across the seam.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum StitchDirectionAcross
Public Enumeration StitchDirectionAcross
Members
Member name | Value | Description
MATCH | 0 |
NONE | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


StitchDirectionAlong Enumeration

Indicates whether the points should be matched along the seam.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum StitchDirectionAlong
Public Enumeration StitchDirectionAlong
Members
Member name | Value | Description
MATCH | 0 |
NONE | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


StitchTypes Enumeration

Allows you to choose the type of the target from one of the following.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum StitchTypes
Public Enumeration StitchTypes
Members
Member name | Value | Description
CURVES | 0 |
SURFACECURVES | 1 |
SURFACES | 2 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceAdvancedOptions Class

Contains advanced surface options that can be used when creating surfaces.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPESurfaceAdvancedOptions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class SurfaceAdvancedOptions
Public Class SurfaceAdvancedOptions

The SurfaceAdvancedOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SurfaceAdvancedOptions | Initialises a new instance of the PSSurface. SurfaceAdvancedOptions class.
Top
Properties
 | Name | Description
Public property | CornerTolerance | The corner tolerance.
Public property | EdgeMatchingOption | The edge matching option to control how PowerSHAPE adds extra surface points and curves to the initial network so that each point lies at the junction of a lateral and a longitudinal.
Public property | InteriorInterpolation | The interior interpolation methods option for surface creation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceAdvancedOptions Constructor

Initialises a new instance of the PSSurface. SurfaceAdvancedOptions class.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public SurfaceAdvancedOptions(
    Object aEdgeMatchingOption = null,
    Object aInteriorInterPolation = null,
    Object aCornerTolerance = null
)
Public Sub New (
    Optional aEdgeMatchingOption As Object = Nothing,
    Optional aInteriorInterPolation As Object = Nothing,
    Optional aCornerTolerance As Object = Nothing
)

Parameters

aEdgeMatchingOption (Optional)
Type: SystemObject
The edge matching option to control how PowerSHAPE adds extra surface points and curves to the initial network so that each point lies at the junction of a lateral and a longitudinal.
aInteriorInterPolation (Optional)
Type: SystemObject
The interior interpolation methods option for surface creation.
aCornerTolerance (Optional)
Type: SystemObject
The corner tolerance.
Remarks
See Also

Reference

SurfaceAdvancedOptions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceAdvancedOptions Properties

The SurfaceAdvancedOptions type exposes the following members.

Properties
 | Name | Description
Public property | CornerTolerance | The corner tolerance.
Public property | EdgeMatchingOption | The edge matching option to control how PowerSHAPE adds extra surface points and curves to the initial network so that each point lies at the junction of a lateral and a longitudinal.
Public property | InteriorInterpolation | The interior interpolation methods option for surface creation.
Top
See Also

Reference

SurfaceAdvancedOptions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceAdvancedOptions.CornerTolerance Property

SurfaceAdvancedOptionsCornerTolerance Property

The corner tolerance.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Nullable<double> CornerTolerance { get; set; }
Public Property CornerTolerance As Nullable(Of Double)
    Get
    Set

Property Value

Type: Nullable Double

Return Value

Type: Nullable Double
Remarks
See Also

Reference

SurfaceAdvancedOptions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceAdvancedOptions.EdgeMatchingOption Property

SurfaceAdvancedOptionsEdgeMatchingOption Property

The edge matching option to control how PowerSHAPE adds extra surface points and curves to the initial network so that each point lies at the junction of a lateral and a longitudinal.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Nullable<AutomaticSurfaceOptions> EdgeMatchingOption { get; set; }
Public Property EdgeMatchingOption As Nullable(Of AutomaticSurfaceOptions)
    Get
    Set

Property Value

Type: Nullable AutomaticSurfaceOptions

Return Value

Type: Nullable AutomaticSurfaceOptions
Remarks
See Also

Reference

SurfaceAdvancedOptions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceAdvancedOptions.InteriorInterpolation Property

SurfaceAdvancedOptionsInteriorInterpolation Property

The interior interpolation methods option for surface creation.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Nullable<AdvancedInteriorInterpolationMethods> InteriorInterpolation { get; set; }
Public Property InteriorInterpolation As Nullable(Of AdvancedInteriorInterpolationMethods)
    Get
    Set

Property Value

Type: Nullable AdvancedInteriorInterpolationMethods

Return Value

Type: Nullable AdvancedInteriorInterpolationMethods
Remarks
See Also

Reference

SurfaceAdvancedOptions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceAdvancedOptions Methods

The SurfaceAdvancedOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SurfaceAdvancedOptions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceCurveInsertionMethod Enumeration

Surface curve insertion methods.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SurfaceCurveInsertionMethod
Public Enumeration SurfaceCurveInsertionMethod
Members
Member name | Value | Description
ParameterMethod | 0 |
DistanceMethod | 1 |
WorkplaneMethod | 2 |
NearestPoint | 3 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceCurveTypes Enumeration

Surface direction options for a surface curve.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SurfaceCurveTypes
Public Enumeration SurfaceCurveTypes
Members
Member name | Value | Description
Lateral | 0 |
Longitudinal | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceCurveTypesExtensions Class

Contains all extension methods for the SurfaceCurveTypes enumeration.
Inheritance Hierarchy
SystemObject
Autodesk.ProductInterface.PowerSHAPESurfaceCurveTypesExtensions

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public sealed class SurfaceCurveTypesExtensions
<ExtensionAttribute>
Public NotInheritable Class SurfaceCurveTypesExtensions

The SurfaceCurveTypesExtensions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ToLongString | Returns long forms of the surface curve type for insertion into macro code.
 | ToShortString | Returns short forms of the surface curve type for insertion into macro code.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceCurveTypesExtensions Methods

The SurfaceCurveTypesExtensions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ToLongString | Returns long forms of the surface curve type for insertion into macro code.
 | ToShortString | Returns short forms of the surface curve type for insertion into macro code.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SurfaceCurveTypesExtensions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceCurveTypesExtensions.ToLongString Method

SurfaceCurveTypesExtensionsToLongString Method

Returns long forms of the surface curve type for insertion into macro code.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string ToLongString(
    this SurfaceCurveTypes inputSurfaceCurveType
)
<ExtensionAttribute>
Public Shared Function ToLongString (
    inputSurfaceCurveType As SurfaceCurveTypes
) As String

Parameters

inputSurfaceCurveType
Type: Autodesk.ProductInterface.PowerSHAPESurfaceCurveTypes
The surface curve type to convert to long string.

Return Value

Type: String
Long surface type name (e.g. Lateral will be 'LATERAL').

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SurfaceCurveTypes. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
See Also

Reference

SurfaceCurveTypesExtensions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceCurveTypesExtensions.ToShortString Method

SurfaceCurveTypesExtensionsToShortString Method

Returns short forms of the surface curve type for insertion into macro code.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static string ToShortString(
    this SurfaceCurveTypes inputSurfaceCurveType
)
<ExtensionAttribute>
Public Shared Function ToShortString (
    inputSurfaceCurveType As SurfaceCurveTypes
) As String

Parameters

inputSurfaceCurveType
Type: Autodesk.ProductInterface.PowerSHAPESurfaceCurveTypes
The surface curve type to convert to short string.

Return Value

Type: String
The short string to the input surface type (e.g. Lateral will be 'LATS').

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SurfaceCurveTypes. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
See Also

Reference

SurfaceCurveTypesExtensions Class
Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceShapes Enumeration

Surface shape options.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SurfaceShapes
Public Enumeration SurfaceShapes
Members
Member name | Value | Description
Block | 0 |
Cone | 1 |
Cylinder | 2 |
Extrusion | 3 |
General_Surface | 4 |
Partial_Cylinder | 5 |
Plane | 6 |
Revolution | 7 |
Sphere | 8 |
Torus | 9 |
Unknown | 10 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


SurfaceTypes Enumeration

Surface types.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum SurfaceTypes
Public Enumeration SurfaceTypes
Members
Member name | Value | Description
Plane | 0 |
Block | 1 |
Sphere | 2 |
Cylinder | 3 |
Cone | 4 |
Extrusion | 5 |
Torus | 6 |
Spring | 7 |
Revolution | 8 |
PowerSurface | 9 |
BCP | 10 |
NURB | 11 |
PDGS | 12 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


TextJustifications Enumeration

Alignment option for the text.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum TextJustifications
Public Enumeration TextJustifications
Members
Member name | Value | Description
Left | 0 |
Centre | 1 |
Right | 2 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


TextOrigins Enumeration

Defines the origin of the text.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum TextOrigins
Public Enumeration TextOrigins
Members
Member name | Value | Description
BottomLeft | 0 |
BottomCentre | 1 |
BottomRight | 2 |
LeftCentre | 3 |
Centre | 4 |
RightCentre | 5 |
TopLeft | 6 |
TopCentre | 7 |
TopRight | 8 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


TrianglePickMode Enumeration

Triangle pick modes.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum TrianglePickMode
Public Enumeration TrianglePickMode
Members
Member name | Value | Description
ContinuousLasso | 0 |
DiscreteLasso | 1 |
Box | 2 |
ToDiscontinuityAngle | 3 |
ToHorizonAngle | 4 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


TriangleStitchIterationModes Enumeration

The iteration mode used when stitching triangle meshes.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum TriangleStitchIterationModes
Public Enumeration TriangleStitchIterationModes
Members
Member name | Value | Description
SinglePass | 0 |
MultiPass | 1 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


TrimRegionEditingModes Enumeration

Defining the two possible trim region editing modes.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum TrimRegionEditingModes
Public Enumeration TrimRegionEditingModes
Members
Member name | Value | Description
BoundaryEditing | 0 |
PCurveEditing | 1 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


ViewRelationships Enumeration

Used when setting relationships between multiple views.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum ViewRelationships
Public Enumeration ViewRelationships
Members
Member name | Value | Description
Parent | 0 |
Child | 1 |
Unrelated | 2 |
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


WindowTypes Enumeration

Windows types.

Namespace: Autodesk.ProductInterface.PowerSHAPE
Assembly: Autodesk.ProductInterface.PowerSHAPE (in Autodesk.ProductInterface.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public enum WindowTypes
Public Enumeration WindowTypes
Members
Member name | Value | Description
MODEL | 0 |
DRAWING | 1 |
Remarks
See Also

Reference

Autodesk.ProductInterface.PowerSHAPE Namespace


Autodesk.WPFControls.ProductControls Namespace

Classes
 | Class | Description
Public class | DelcamProductBase |


DelcamProductBase Class

[Missing <summary> documentation for "T:Autodesk.WPFControls.ProductControls.DelcamProductBase"]

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsDecorator
System.Windows.ControlsBorder
Autodesk.WPFControls.ProductControlsDelcamProductBase
Autodesk.WPFControls.ProductControls.PowerMILLDelcamPowerMILLBase
Autodesk.WPFControls.ProductControls.PowerSHAPEDelcamPowerSHAPEBase

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract class DelcamProductBase : Border
Public MustInherit Class DelcamProductBase
    Inherits Border

The DelcamProductBase type exposes the following members.

Constructors
 | Name | Description
Public method | DelcamProductBase | Initializes a new instance of the DelcamProductBase class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets the Brush that fills the area between the bounds of a Border. (Inherited from Border.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets the Brush that draws the outer border color. (Inherited from Border.)
Public property | BorderThickness | Gets or sets the relative Thickness of a Border. (Inherited from Border.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CornerRadius | Gets or sets a value that represents the degree to which the corners of a Border are rounded. (Inherited from Border.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLooseEmbedded | Signifies whether the embedded window will be embedded with the window edges visible or not. If set to true then the window edges will be visible. Hence it is loosely embedded rather than being seamlessly embedded
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets a Thickness value that describes the amount of space between a Border and its child element. (Inherited from Border.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Toolbar |
Public property | ToolbarPosition |
Public property | ToolbarVisibility |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseExternalApplicationWindowInDebug |
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the contents of a Border element. (Inherited from Border.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close |
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | Initialise |
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the child elements of a Border before they are arranged during the ArrangeOverride(Size) pass. (Inherited from Border.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the contents of a DrawingContext object during the render pass of a Border. (Inherited from Border.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
Protected field | blnUseExternalApplicationWindowInDebug |
Protected field | objApplication |
Protected field | objVersion |
Top
See Also

Reference

Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase Constructor

Initializes a new instance of the DelcamProductBase class

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DelcamProductBase()
Public Sub New
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase Properties

The DelcamProductBase type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets the Brush that fills the area between the bounds of a Border. (Inherited from Border.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets the Brush that draws the outer border color. (Inherited from Border.)
Public property | BorderThickness | Gets or sets the relative Thickness of a Border. (Inherited from Border.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CornerRadius | Gets or sets a value that represents the degree to which the corners of a Border are rounded. (Inherited from Border.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLooseEmbedded | Signifies whether the embedded window will be embedded with the window edges visible or not. If set to true then the window edges will be visible. Hence it is loosely embedded rather than being seamlessly embedded
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets a Thickness value that describes the amount of space between a Border and its child element. (Inherited from Border.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Toolbar |
Public property | ToolbarPosition |
Public property | ToolbarVisibility |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseExternalApplicationWindowInDebug |
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.IsLooseEmbedded Property

DelcamProductBaseIsLooseEmbedded Property

Signifies whether the embedded window will be embedded with the window edges visible or not. If set to true then the window edges will be visible. Hence it is loosely embedded rather than being seamlessly embedded

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool IsLooseEmbedded { get; set; }
Public Property IsLooseEmbedded As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.Toolbar Property

DelcamProductBaseToolbar Property

[Missing <summary> documentation for "P:Autodesk.WPFControls.ProductControls.DelcamProductBase.Toolbar"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public StackPanel Toolbar { get; set; }
Public Property Toolbar As StackPanel
    Get
    Set

Property Value

Type: StackPanel
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.ToolbarPosition Property

DelcamProductBaseToolbarPosition Property

[Missing <summary> documentation for "P:Autodesk.WPFControls.ProductControls.DelcamProductBase.ToolbarPosition"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Dock ToolbarPosition { get; set; }
Public Property ToolbarPosition As Dock
    Get
    Set

Property Value

Type: Dock
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.ToolbarVisibility Property

DelcamProductBaseToolbarVisibility Property

[Missing <summary> documentation for "P:Autodesk.WPFControls.ProductControls.DelcamProductBase.ToolbarVisibility"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public Visibility ToolbarVisibility { get; set; }
Public Property ToolbarVisibility As Visibility
    Get
    Set

Property Value

Type: Visibility
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.UseExternalApplicationWindowInDebug Property

DelcamProductBaseUseExternalApplicationWindowInDebug Property

[Missing <summary> documentation for "P:Autodesk.WPFControls.ProductControls.DelcamProductBase.UseExternalApplicationWindowInDebug"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public bool UseExternalApplicationWindowInDebug { get; set; }
Public Property UseExternalApplicationWindowInDebug As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase Methods

The DelcamProductBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the contents of a Border element. (Inherited from Border.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close |
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | Initialise |
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the child elements of a Border before they are arranged during the ArrangeOverride(Size) pass. (Inherited from Border.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the contents of a DrawingContext object during the render pass of a Border. (Inherited from Border.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.Close Method

DelcamProductBaseClose Method

[Missing <summary> documentation for "M:Autodesk.WPFControls.ProductControls.DelcamProductBase.Close"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public abstract void Close()
Public MustOverride Sub Close
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.Initialise Method

DelcamProductBaseInitialise Method

[Missing <summary> documentation for "M:Autodesk.WPFControls.ProductControls.DelcamProductBase.Initialise"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public void Initialise()
Public Sub Initialise
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase Events

The DelcamProductBase type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase Fields

The DelcamProductBase type exposes the following members.

Fields
 | Name | Description
Protected field | blnUseExternalApplicationWindowInDebug |
Protected field | objApplication |
Protected field | objVersion |
Top
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.blnUseExternalApplicationWindowInDebug Field

DelcamProductBaseblnUseExternalApplicationWindowInDebug Field

[Missing <summary> documentation for "F:Autodesk.WPFControls.ProductControls.DelcamProductBase.blnUseExternalApplicationWindowInDebug"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected bool blnUseExternalApplicationWindowInDebug
Protected blnUseExternalApplicationWindowInDebug As Boolean

Field Value

Type: Boolean
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.objApplication Field

DelcamProductBaseobjApplication Field

[Missing <summary> documentation for "F:Autodesk.WPFControls.ProductControls.DelcamProductBase.objApplication"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected Automation objApplication
Protected objApplication As Automation

Field Value

Type: Automation
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


DelcamProductBase.objVersion Field

DelcamProductBaseobjVersion Field

[Missing <summary> documentation for "F:Autodesk.WPFControls.ProductControls.DelcamProductBase.objVersion"]

Namespace: Autodesk.WPFControls.ProductControls
Assembly: Autodesk.WPFControls.ProductControls (in Autodesk.WPFControls.ProductControls.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
protected Version objVersion
Protected objVersion As Version

Field Value

Type: Version
See Also

Reference

DelcamProductBase Class
Autodesk.WPFControls.ProductControls Namespace


Autodesk.WPFControls.ProductControls.PowerMILL Namespace

Classes
 | Class | Description
Public class | DelcamPowerMILLBase | Allows to show PowerMill embedded into a WPF control.


DelcamPowerMILLBase Class

Allows to show PowerMill embedded into a WPF control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsDecorator
System.Windows.ControlsBorder
Autodesk.WPFControls.ProductControlsDelcamProductBase
Autodesk.WPFControls.ProductControls.PowerMILLDelcamPowerMILLBase

Namespace: Autodesk.WPFControls.ProductControls.PowerMILL
Assembly: Autodesk.WPFControls.ProductControls.PowerMILL (in Autodesk.WPFControls.ProductControls.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class DelcamPowerMILLBase : DelcamProductBase
Public Class DelcamPowerMILLBase
    Inherits DelcamProductBase

The DelcamPowerMILLBase type exposes the following members.

Constructors
 | Name | Description
Public method | DelcamPowerMILLBase | Initializes a new instance of the DelcamPowerMILLBase class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Automation | Gets or sets the base instance to interact with PowerMILL.
Public property | Background | Gets or sets the Brush that fills the area between the bounds of a Border. (Inherited from Border.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets the Brush that draws the outer border color. (Inherited from Border.)
Public property | BorderThickness | Gets or sets the relative Thickness of a Border. (Inherited from Border.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CornerRadius | Gets or sets a value that represents the degree to which the corners of a Border are rounded. (Inherited from Border.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLooseEmbedded | Signifies whether the embedded window will be embedded with the window edges visible or not. If set to true then the window edges will be visible. Hence it is loosely embedded rather than being seamlessly embedded (Inherited from DelcamProductBase.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets a Thickness value that describes the amount of space between a Border and its child element. (Inherited from Border.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Toolbar | (Inherited from DelcamProductBase.)
Public property | ToolbarPosition | (Inherited from DelcamProductBase.)
Public property | ToolbarVisibility | (Inherited from DelcamProductBase.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseExternalApplicationWindowInDebug | (Inherited from DelcamProductBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the contents of a Border element. (Inherited from Border.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | (Overrides DelcamProductBaseClose.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | Initialise | (Inherited from DelcamProductBase.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the child elements of a Border before they are arranged during the ArrangeOverride(Size) pass. (Inherited from Border.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the contents of a DrawingContext object during the render pass of a Border. (Inherited from Border.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
 | AutomationProperty | Implementation of the dependency property.
Protected field | blnUseExternalApplicationWindowInDebug | (Inherited from DelcamProductBase.)
Protected field | objApplication | (Inherited from DelcamProductBase.)
Protected field | objVersion | (Inherited from DelcamProductBase.)
Top
Remarks
See Also

Reference

Autodesk.WPFControls.ProductControls.PowerMILL Namespace


DelcamPowerMILLBase Constructor

Initializes a new instance of the DelcamPowerMILLBase class

Namespace: Autodesk.WPFControls.ProductControls.PowerMILL
Assembly: Autodesk.WPFControls.ProductControls.PowerMILL (in Autodesk.WPFControls.ProductControls.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DelcamPowerMILLBase()
Public Sub New
See Also

Reference

DelcamPowerMILLBase Class
Autodesk.WPFControls.ProductControls.PowerMILL Namespace


DelcamPowerMILLBase Properties

The DelcamPowerMILLBase type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Automation | Gets or sets the base instance to interact with PowerMILL.
Public property | Background | Gets or sets the Brush that fills the area between the bounds of a Border. (Inherited from Border.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets the Brush that draws the outer border color. (Inherited from Border.)
Public property | BorderThickness | Gets or sets the relative Thickness of a Border. (Inherited from Border.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CornerRadius | Gets or sets a value that represents the degree to which the corners of a Border are rounded. (Inherited from Border.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLooseEmbedded | Signifies whether the embedded window will be embedded with the window edges visible or not. If set to true then the window edges will be visible. Hence it is loosely embedded rather than being seamlessly embedded (Inherited from DelcamProductBase.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets a Thickness value that describes the amount of space between a Border and its child element. (Inherited from Border.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Toolbar | (Inherited from DelcamProductBase.)
Public property | ToolbarPosition | (Inherited from DelcamProductBase.)
Public property | ToolbarVisibility | (Inherited from DelcamProductBase.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseExternalApplicationWindowInDebug | (Inherited from DelcamProductBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

DelcamPowerMILLBase Class
Autodesk.WPFControls.ProductControls.PowerMILL Namespace


DelcamPowerMILLBase.Automation Property

DelcamPowerMILLBaseAutomation Property

Gets or sets the base instance to interact with PowerMILL.

Namespace: Autodesk.WPFControls.ProductControls.PowerMILL
Assembly: Autodesk.WPFControls.ProductControls.PowerMILL (in Autodesk.WPFControls.ProductControls.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PMAutomation Automation { get; set; }
Public Property Automation As PMAutomation
    Get
    Set

Property Value

Type: PMAutomation
See Also

Reference

DelcamPowerMILLBase Class
Autodesk.WPFControls.ProductControls.PowerMILL Namespace


DelcamPowerMILLBase Methods

The DelcamPowerMILLBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the contents of a Border element. (Inherited from Border.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | (Overrides DelcamProductBaseClose.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | Initialise | (Inherited from DelcamProductBase.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the child elements of a Border before they are arranged during the ArrangeOverride(Size) pass. (Inherited from Border.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the contents of a DrawingContext object during the render pass of a Border. (Inherited from Border.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DelcamPowerMILLBase Class
Autodesk.WPFControls.ProductControls.PowerMILL Namespace


DelcamPowerMILLBase.Close Method

DelcamPowerMILLBaseClose Method

[Missing <summary> documentation for "M:Autodesk.WPFControls.ProductControls.PowerMILL.DelcamPowerMILLBase.Close"]

Namespace: Autodesk.WPFControls.ProductControls.PowerMILL
Assembly: Autodesk.WPFControls.ProductControls.PowerMILL (in Autodesk.WPFControls.ProductControls.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Close()
Public Overrides Sub Close
See Also

Reference

DelcamPowerMILLBase Class
Autodesk.WPFControls.ProductControls.PowerMILL Namespace


DelcamPowerMILLBase Events

The DelcamPowerMILLBase type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DelcamPowerMILLBase Class
Autodesk.WPFControls.ProductControls.PowerMILL Namespace


DelcamPowerMILLBase Fields

The DelcamPowerMILLBase type exposes the following members.

Fields
 | Name | Description
 | AutomationProperty | Implementation of the dependency property.
Protected field | blnUseExternalApplicationWindowInDebug | (Inherited from DelcamProductBase.)
Protected field | objApplication | (Inherited from DelcamProductBase.)
Protected field | objVersion | (Inherited from DelcamProductBase.)
Top
See Also

Reference

DelcamPowerMILLBase Class
Autodesk.WPFControls.ProductControls.PowerMILL Namespace


DelcamPowerMILLBase.AutomationProperty Field

DelcamPowerMILLBaseAutomationProperty Field

Implementation of the dependency property.

Namespace: Autodesk.WPFControls.ProductControls.PowerMILL
Assembly: Autodesk.WPFControls.ProductControls.PowerMILL (in Autodesk.WPFControls.ProductControls.PowerMILL.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutomationProperty
Public Shared ReadOnly AutomationProperty As DependencyProperty

Field Value

Type: DependencyProperty
Remarks
See Also

Reference

DelcamPowerMILLBase Class
Autodesk.WPFControls.ProductControls.PowerMILL Namespace


Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace

Classes
 | Class | Description
Public class | DelcamPowerSHAPEBase | Allows to show PowerSHAPE embedded into a WPF control.


DelcamPowerSHAPEBase Class

Allows to show PowerSHAPE embedded into a WPF control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsDecorator
System.Windows.ControlsBorder
Autodesk.WPFControls.ProductControlsDelcamProductBase
Autodesk.WPFControls.ProductControls.PowerSHAPEDelcamPowerSHAPEBase

Namespace: Autodesk.WPFControls.ProductControls.PowerSHAPE
Assembly: Autodesk.WPFControls.ProductControls.PowerSHAPE (in Autodesk.WPFControls.ProductControls.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public class DelcamPowerSHAPEBase : DelcamProductBase
Public Class DelcamPowerSHAPEBase
    Inherits DelcamProductBase

The DelcamPowerSHAPEBase type exposes the following members.

Constructors
 | Name | Description
Public method | DelcamPowerSHAPEBase | Initializes a new instance of the DelcamPowerSHAPEBase class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Automation | Gets or sets the base instance to interact with PowerSHAPE.
Public property | Background | Gets or sets the Brush that fills the area between the bounds of a Border. (Inherited from Border.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets the Brush that draws the outer border color. (Inherited from Border.)
Public property | BorderThickness | Gets or sets the relative Thickness of a Border. (Inherited from Border.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CornerRadius | Gets or sets a value that represents the degree to which the corners of a Border are rounded. (Inherited from Border.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLooseEmbedded | Signifies whether the embedded window will be embedded with the window edges visible or not. If set to true then the window edges will be visible. Hence it is loosely embedded rather than being seamlessly embedded (Inherited from DelcamProductBase.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets a Thickness value that describes the amount of space between a Border and its child element. (Inherited from Border.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Toolbar | (Inherited from DelcamProductBase.)
Public property | ToolbarPosition | (Inherited from DelcamProductBase.)
Public property | ToolbarVisibility | (Inherited from DelcamProductBase.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseExternalApplicationWindowInDebug | (Inherited from DelcamProductBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the contents of a Border element. (Inherited from Border.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | (Overrides DelcamProductBaseClose.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | Initialise | (Inherited from DelcamProductBase.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the child elements of a Border before they are arranged during the ArrangeOverride(Size) pass. (Inherited from Border.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the contents of a DrawingContext object during the render pass of a Border. (Inherited from Border.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
 | AutomationProperty | Implementation of the dependency property.
Protected field | blnUseExternalApplicationWindowInDebug | (Inherited from DelcamProductBase.)
Protected field | objApplication | (Inherited from DelcamProductBase.)
Protected field | objVersion | (Inherited from DelcamProductBase.)
Top
Remarks
See Also

Reference

Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


DelcamPowerSHAPEBase Constructor

Initializes a new instance of the DelcamPowerSHAPEBase class

Namespace: Autodesk.WPFControls.ProductControls.PowerSHAPE
Assembly: Autodesk.WPFControls.ProductControls.PowerSHAPE (in Autodesk.WPFControls.ProductControls.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public DelcamPowerSHAPEBase()
Public Sub New
See Also

Reference

DelcamPowerSHAPEBase Class
Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


DelcamPowerSHAPEBase Properties

The DelcamPowerSHAPEBase type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Automation | Gets or sets the base instance to interact with PowerSHAPE.
Public property | Background | Gets or sets the Brush that fills the area between the bounds of a Border. (Inherited from Border.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets the Brush that draws the outer border color. (Inherited from Border.)
Public property | BorderThickness | Gets or sets the relative Thickness of a Border. (Inherited from Border.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Gets or sets the single child element of a Decorator. (Inherited from Decorator.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CornerRadius | Gets or sets a value that represents the degree to which the corners of a Border are rounded. (Inherited from Border.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLooseEmbedded | Signifies whether the embedded window will be embedded with the window edges visible or not. If set to true then the window edges will be visible. Hence it is loosely embedded rather than being seamlessly embedded (Inherited from DelcamProductBase.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can be used to iterate the logical child elements of a Decorator. (Inherited from Decorator.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets a Thickness value that describes the amount of space between a Border and its child element. (Inherited from Border.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Toolbar | (Inherited from DelcamProductBase.)
Public property | ToolbarPosition | (Inherited from DelcamProductBase.)
Public property | ToolbarVisibility | (Inherited from DelcamProductBase.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseExternalApplicationWindowInDebug | (Inherited from DelcamProductBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that is equal to the number of visual child elements of this instance of Decorator. (Inherited from Decorator.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

DelcamPowerSHAPEBase Class
Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


DelcamPowerSHAPEBase.Automation Property

DelcamPowerSHAPEBaseAutomation Property

Gets or sets the base instance to interact with PowerSHAPE.

Namespace: Autodesk.WPFControls.ProductControls.PowerSHAPE
Assembly: Autodesk.WPFControls.ProductControls.PowerSHAPE (in Autodesk.WPFControls.ProductControls.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public PSAutomation Automation { get; set; }
Public Property Automation As PSAutomation
    Get
    Set

Property Value

Type: PSAutomation

Return Value

Type: PSAutomation
Remarks
See Also

Reference

DelcamPowerSHAPEBase Class
Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


DelcamPowerSHAPEBase Methods

The DelcamPowerSHAPEBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the contents of a Border element. (Inherited from Border.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | (Overrides DelcamProductBaseClose.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual element at the specified index position. (Inherited from Decorator.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | Initialise | (Inherited from DelcamProductBase.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the child elements of a Border before they are arranged during the ArrangeOverride(Size) pass. (Inherited from Border.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the contents of a DrawingContext object during the render pass of a Border. (Inherited from Border.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

DelcamPowerSHAPEBase Class
Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


DelcamPowerSHAPEBase.Close Method

DelcamPowerSHAPEBaseClose Method

[Missing <summary> documentation for "M:Autodesk.WPFControls.ProductControls.PowerSHAPE.DelcamPowerSHAPEBase.Close"]

Namespace: Autodesk.WPFControls.ProductControls.PowerSHAPE
Assembly: Autodesk.WPFControls.ProductControls.PowerSHAPE (in Autodesk.WPFControls.ProductControls.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public override void Close()
Public Overrides Sub Close
See Also

Reference

DelcamPowerSHAPEBase Class
Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


DelcamPowerSHAPEBase Events

The DelcamPowerSHAPEBase type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DelcamPowerSHAPEBase Class
Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


DelcamPowerSHAPEBase Fields

The DelcamPowerSHAPEBase type exposes the following members.

Fields
 | Name | Description
 | AutomationProperty | Implementation of the dependency property.
Protected field | blnUseExternalApplicationWindowInDebug | (Inherited from DelcamProductBase.)
Protected field | objApplication | (Inherited from DelcamProductBase.)
Protected field | objVersion | (Inherited from DelcamProductBase.)
Top
See Also

Reference

DelcamPowerSHAPEBase Class
Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


DelcamPowerSHAPEBase.AutomationProperty Field

DelcamPowerSHAPEBaseAutomationProperty Field

Implementation of the dependency property.

Namespace: Autodesk.WPFControls.ProductControls.PowerSHAPE
Assembly: Autodesk.WPFControls.ProductControls.PowerSHAPE (in Autodesk.WPFControls.ProductControls.PowerSHAPE.dll) Version: 0.9.5.0 (0.9.5.0)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutomationProperty
Public Shared ReadOnly AutomationProperty As DependencyProperty

Field Value

Type: DependencyProperty
Remarks
See Also

Reference

DelcamPowerSHAPEBase Class
Autodesk.WPFControls.ProductControls.PowerSHAPE Namespace


Version 1.0.0.0

Version [TODO: Version] was released on [TODO: Date].

Changes in This Release

  • [TODO: Add change items here]

See Also

Other Resources

Version History


Version History

The topics in this section describe the various changes made to the [TODO: Project Title] over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 1.0.0.0

  • [TODO: Add links to each specific version page]

See Also

Other Resources

Welcome


Welcome

This is a sample conceptual topic. You can use this as a starting point for adding more conceptual content to your help project.

Getting Started

To get started, add a documentation source to the project (a Visual Studio solution, project, or assembly and XML comments file). See the Getting Started topics in the Sandcastle Help File Builder's help file for more information. The following default items are included in this project:

  • ContentLayout.content - Use the content layout file to manage the conceptual content in the project and define its layout in the table of contents.

  • The .\Media folder - Place images in this folder that you will reference from conceptual content using medialLink or mediaLinkInline elements. If you will not have any images in the file, you may remove this folder.

  • The .\icons folder - This contains a default logo for the help file. You may replace it or remove it and the folder if not wanted. If removed or if you change the file name, update the Transform Args project properties page by removing or changing the filename in the logoFile transform argument. Note that unlike images referenced from conceptual topics, the logo file should have its BuildAction property set to Content.

  • The .\Content folder - Use this to store your conceptual topics. You may name the files and organize them however you like. One suggestion is to lay the files out on disk as you have them in the content layout file as shown in this project but the choice is yours. Files can be added via the Solution Explorer or from within the content layout file editor. Files must appear in the content layout file in order to be compiled into the help file.

See the Conceptual Content topics in the Sandcastle Help File Builder's help file for more information. See the Sandcastle MAML Guide for details on Microsoft Assistance Markup Language (MAML) which is used to create these topics.

See Also

Other Resources

Version History