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SkillsUSA University 
60 AUTODESK INVENTOR TIPS IN 60 MINUTES 

 
J.D. Mather – Pennsylvania College of Technology 
 
For educators and students in mechanical design.  
A rapid paced delivery of the top tips and tricks gathered from years of experience teaching Autodesk 
Inventor software. Looking for that one class that will justify your travel to SkillsUSA University - if you 
teach mechanical design/drafting using Autodesk Inventor - this is it. After this class, when you return to 
your home school you will be referred to as the Inventor Guru. 
1 p.m., Big Joe Turner A. 
 
 
 
Key Learning 
 
  Basic Interface Settings 
  BORN Technique 
  Robust Sketch Techniques 
  Neutral File Translation 
  Basic Assembly Tips 
  Drawing Tips 
 
 
 
 
 
 
 
 
 
 
About the Speaker: 
J.D. Mather is an Assistant Professor of CAD and Product Design at Pennsylvania College of 
Technology, Penn State.  He previously worked in industry for 15 years, including positions as 
journeyman machinist, research and development technician, and industrial engineering technician.   
Dr. Mather has been an Autodesk Inventor Certified Expert since release 7.  He is also a Certified 
SolidWorks Professional.  He is experienced with AutoCAD and Pro/E as well.  Dr. Mather placed second 
for Autodesk Inventor category at the Autodesk University 2006, Avatech Altogether Smarter Challenge, 
and placed first in the same category at AU 2007.  He has presented AutoCAD and Inventor classes at 
Autodesk University 2006-2009. 
jmather@pct.edu 

 
 
Reference Materials: 
http://home.pct.edu/~jmather/SkillsUSA University.pdf 

http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm 

http://www.autodesk.com/discussiongroup-inventor 
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Tip 1. You should be aware that you and your students can get a free learning license of many Autodesk 

products including Inventor Professional from the Autodesk Student Community. 

 

Before we get started I want to define a common interface. 

 

Click on the Tools tab and then Application Options. 

 

 

 

 

 

Tip 2. 

If you 

normally 

present on a 

projection 

screen you 

might want 

to increase 

the 

Annotation 

scale so that 

everyone can 

see your 

sketch 

dimensions. 
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Tip 3. On the sketch tab turn off Display – Grid items. 

Tip 4. Turn on Edit dimension when created. 

Tip 5. Turn off Autoproject edges for sketch creation and edit (Note: I will leave on for now to 

demonstrate later why you should turn it off). 

Tip 6. Make sure Autoproject part origin on sketch create is always turned on.  

3 

4 

5 

6 
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Tip 7. On the Part tab you might want to set No new sketch – when you start a new part you will select 

the plane on which to create the first sketch rather than Inventor automatically starting the first sketch. 

 

 

 

 

 

 

 

 

 

 

 

Tip 8 

On the Colors tab I prefer to 

use the Sky color scheme with 

Amber icons for high-contrast 

projection. 
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Tip 9 I would uncheck Constraint audio notification and checkmark Display component names after 

constraint names on the Assembly tab.  (Set opposite of the default settings I show here.) 

 

 

 

 

Next let’s customize some of our keystrokes. 

 

One of the most powerful features of Inventor is the use of geometric constraints like tangent, collinear, 

horizontal, vertical and perpendicular. 

 

We use these geometry constraints so frequently that it makes sense to assign “hotkeys” on the 

keyboard to quickly access these constraints. 

 

If you use the Inventor sketcher properly most of your geometry constraints will be applied 

automatically, but there will still be a frequent need to manually place constraints. 

I have not seen any evidence that working without constraints is faster than working with constraints. I 
could be wrong, but I doubt it.  
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Select the Keyboard tab and then the Categories – Sketch.  Click to the left of the command for which 

you want to define a hotkey. 

 

  Tip 11 Then minus key is a horizontal line. 

 Tip 12 The plus key is two perpendicular lines. 

  Tip 13 The asterisk reminds me of a circle.  

  Tip 14 The forward slash key is almost vertical. 

All of these settings can be Exported for Import on another machine.  

Tip 10  The period key (on the 

Numerical keypad) reminds me of the 

Inventor coincident constraint glyph. 
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Tip 15  I see a lot of 

reports of people 

losing their Browser 

panel. 

You can get it back 

from the View tab – 

User Interface.   

Notice that any green 

tab is your active 

environment. 

 

 

 

Tip 16 In this class we are going to use the Base Orphan Reference Node Technique (Born Technique). 

 

In this class use the origin geometry to your advantage. It has no parents and cannot be deleted. It will 
always be there for you. Use it to anchor your work. Use it for symmetry. Use it for consistency. You 
don’t have to have it visible to use it. 
 

Just Use it! 
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Tip 17  Sketch one line, or a circle, a rectangle or a polygon and dimension it immediately. 

This will give you a sense of scale for the rest of your sketch.  In general – keep your sketches simple – I 

recommend no more than 7-10 entities in most sketches. 

Tip 18  Following the BORN Technique create your sketches as much as practical on origin workplanes 

rather than on part faces. 

 

Tip 19  Watch out for the Constraint Persistence icon (particularly before Inventor 2011) as it looks very 

much like the Perpendicular constraint. 

Beginners hit this and don’t realize they have turned off auto-constraints.  
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Tip 20  Using a horizontal and vertical line to midpoints can lead to unexpected results. 

 

Tip 21  Using a horizontal and vertical constraints to midpoints can lead to unexpected results. 
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Tip 22  The most robust technique I have found is to 

use a diagonal construction line to constrain 

rectangles with symmetry about the origin. 

Notice that a sketch changes color when it is fully 

constrained/dimensioned. 

Make generous use of construction lines. 

 

 

Tip 23  You can click the 

right mouse button and 

turn on sketch Degrees of 

Freedom as a visual guide 

to what 

dimensions/constraints are 

needed in a sketch. 

 

I recommend simply 

dragging endpoints. 

 

 

 

 

Inventor will automatically place many constraints. 

 

Tip 24  You can go directly into a arc while in the line 

command by clicking and dragging off the endpoint of the 

line. 
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Tip 25  If you click on a circle and 

hold the mouse button down and 

drag your second endpoint to a 

second circle Inventor will 

automatically place tangent 

constraints at both endpoints. 

 

 

Tip 26  Avoid the use of 

Mirror of sketch entities 

if possible.   

Use Symmetry 

constraints instead. 

 

 

 

 

 

 

From this…. 

 

 

…to this. 

  

Tip 27   In fact. Avoid the use of 

Mirror or Pattern of sketch entities 

altogether if possible. 
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Tip 28  You can use window selection or crossing window selection just like AutoCAD. 

 

 

 

Tip 29  Dimension to a 

centerline (not endpoint) to get 

a diametral dimension. 

 

Tip 30  Notice the hand glyph – 

do you know what it signifies? 

 

 

Tip 31  You can enter units at any time and mix and match appropriate units as well as use function 

operators.  If the equation in the dialog box is red then it is not valid – if black then it is valid. 

 

Tip 32  Offsetting an 

ellipse results in 

different solutions 

depending on where 

you select the ellipse.  

One result is a 

mathematic ellipse, the 

other is a constant 

offset distance. 
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Tip 33 Remember earlier I suggested turning off the default Autoproject edges on sketch create.  Notice 

how complex this sketch is with autoproject turned on. 

 

 

Tip 34  Copy sketches and features to save time and effort.  Toggle endpoints to centerpoints for hole 

placement.  You can Ctrl unselect hole centerpoint locations. 
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Tip 35  You can click and drag off of a planar face while in the Workplane command or simply start a 

new sketch and click and drag off of the planar face.  (It is useful to know every method of creating a 

workplane.) 

Tip 36 When placing text sketch, dimension the text box immediately – it doesn’t matter what the 

dimensions are. 

 

 

Tip 37  A workplane has a front side and a backside.  Right Mouse button click on the workplane and 

select Flip Normal to flip a user created workplane. 

Tip 38  A dimensioned text box can be dragged to any angle (predictable results from lower left corner).  



15 
 

Tip 39  The Rectangular feature pattern 

command should probably be called Curve 

Driven Pattern. 

 

But sometimes you can get unexpected 

results.  In this case the design intent was 

for the patterned slots to cut entirely 

through the solid just like the first slot. 

 

 

 

 

Tip 40  The design intent can be achieved by expanding the dialog box and selecting Adjust under the 

Compute heading.  
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Tip 41  For a more complex curve driven pattern expand the dialog box and move the Start Point to an 

appropriate location and set Orientation to Direction 1. 

 

The design intent is for a pattern of tapped holes going 

around the cylinder and up the face of the cylinder. 

Looks like a Circular pattern and a Rectangular pattern will be 

needed. 

 

Tip 42  But the design intent can be accomplished with one 

“Rectangular Pattern. 
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Tip 43  The first part brought in to an assembly is automatically grounded at the origin, but I recommend 

also constraining the first component to the origin by adding 3 Mate-Flush constraints between the XY, 

XZ and YZ planes. 

Tip 44  You can use Place Component or simply drag and drop from Explorer to Assembly. 

Tip 45  In an assembly set your browser to Modeling View to gain access to part feature tree. 

 

 

Tip 46  Feature Patterns can be used to generate Component Patterns.  
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Tip 47  You can use the edge of 

surfaces for a curve driven 

pattern. 

 

 

 

 

 

 

 

 

 

Tip 48  I usually don’t worry 

too much about Top, Front or 

Right Side – it is all relative.  

You can change how your part 

is viewed on opening a file. 

 

 

 

 

 

Tip 49  To add this icon to the Navigation Bar click on the arrow in the circle.  You can then 

easily change view styles without going to the View ribbon tab. 
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Tip 50  You can Export DWG Solids by 

going to the Environments tab>AEC 

Exchange and select Save As DWG 

Solids. 

 

  

 

Tip 51  When reusing AutoCAD data in Inventor 

you can opt to Open in idw environment or 

Import into ipt environment. 

 

 

Tip 52  There are many other proprietary and neutral format file types that can be imported as well.  

Sometimes imported data is not of the highest quality.  For information on repairing neutral format dat 

in Inventor see http://au.autodesk.com/?nd=class&session_id=3056 . 

You might also review the other AU On-line Classes available on Inventor. 

 

http://au.autodesk.com/?nd=class&session_id=3056
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Tip 53  You can use scanned hand-drawn sketches or photographs as reference for creating models.  Just 

don’t take the imported image too literally (especially if, like me, you aren’t an artist – add your design 

flare in Inventor). 

 

 

 

 

You might want to test out the  

kinematics1 of a mechanism 

before taking time to fully 

model the components.   

 

1. The branch of mechanics that deals with pure motion, without reference to the 

masses or forces involved in the motion. 
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Create schematic block representation of your mechanism.  

 

 

At this point we can test the 2D motion but not the 3D motion of the crank handle.  Eventually we will 

want to create 3D components for each part of the mechanism, so let’s go ahead and push out the 

individual parts now and create an assembly. 

 

You must be in Sketch mode – click on the Make Components icon.  
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Select all of the blocks from the browser to create components. 

 

Make sure the Component position options are selected for constraining. 
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We now have an assembly of components. 

If we try to drag a component to test the motion we see that we have an unconstrained parallelogram.  

In the real world assembly the gear teeth on the arms will keep them parallel, but as we haven’t 

modeled the parts yet we will have to add an extra assembly constraint. 

 

Before we continue it will be helpful to go to Tools>Application Options>Assembly tab and turn on 

Display component names after constraint names. 
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To force the Lift Plate to remain horizontal as the mechanism moves we place an angle zero mate 

assembly constraint between the XZ Plane of the assembly and the XZ Plane of the Lift Plate.  

 

 

Since we haven’t modeled the teeth on the arms yet we need to un-suppress the YZ Flush constraint 

that Inventor automatically applied to the Lift Plate. 

Now we need to go through the rest of the assembly constraints that were automatically placed by 

Inventor and set the appropriate condition for each.  A strong understanding of assembly constraints is 
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required to complete the rest of the problem.  A disciplined step-by-step approach is required or it is 

easy to become confused.  I expand each part one-by-one and analyze each constraint and the effect on 

the assembly.  The Base component is fully constrained – so we don’t need to change any of its 

constraints. 

 

 

The Lower Left Arm (LL Arm) motion is constrained to the XY Plane – it needs to be free to move up and 

down on the XY Plane.  It is constrained at one end to the Base and on the other end to the UL arm.  No 

changes need to be made.  The constraints on all of the arms are correct. 

 

 

The Jack Screw need to be free to rotate, therefore we need to Suppress the XY Flush constraint. 
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Tip 54  Be careful – as you change between 2D and 3D 

Kinematics the constraint number and position in the list 

changes.  You must change all three remaining constraints 

on the Jack Screw to 3D Kinematic.  Check the Crank Handle 

– suppress the XY Flush constraint and verify that the Mate 

between the Crank Handle and the Jack Screw is set to 3D 

Kinematic.  The actual identification numbers of the 

constraints were created automatically by Inventor and might be different for you.  Pay attention to the 

part names. 

 

Testing our mechanism we see that the 2D motion is correct – we need to add one final constraint to get 

the 3D Motion.  For now We will leave the Distance (ratio) on 1 as we can change that at any time.  The 

easiest way to check the 2D and 3D kinematic motion is to click and drag the Lift Plate. 

If you have Inventor 

Professional with 

Dynamic Simulation 

you can go beyond 

simple kinematics 

analysis and to a full 

Dynamic Simulation of 

the mechanism when 

you have the parts 

modeled.  In this 

example the 

experiment was to see 

how the required input 

force would change 

depending on hand placement on the Crank Handle and position of the Lift Plate.  



27 
 

 

When creating 2D drawing views from 3D models the software creates the views quite literally – 

including details that might make the view a bit obscure.  We can edit the view for clarity. 

 

Tip 55  The job of editing can be simplified by judicious use of layers.  I temporarily turn off the Visible 

line layer and select the lines I wish to hide.  You can hide lines by right clicking and selecting Hide after 

selecting the entities to hide.  Then turn the Visible line layer back on. 

 

Tip 56  One of the most common questions that come up is, “How do I dimension to an apparent 

intersection?”  It is actually quite easy, but takes a bit of practice at first.  Pick the first line and then 

Right Mouse Button and select Intersection and click the intersecting line.  In this example there are two 

projected intersections – so pick the third line and Right Mouse Button select the intersecting line again 

after opting for intersection. 
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Tip 57  When you are annotating a drawing you can gain Windows 

Character Map in any command that uses text. 

 

 

 

 

 

 

 

Tip 58  What is the purpose of 

creating drawings?   

To communicate design intent.   

We can do what is needed to 

convey design intent while 

also incorporating standards.  

An example is the traditional 

practice of showing ribs in 

section. 
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Tip 59  If your students are running the student version on their own computers they can verify the 

license expiration date by going to Help>About Inventor>Product Information. 

 

 

Tip 60  Do Not double click on Big I - as this closes Inventor (or any Windows Ribbon program).  

Sometimes you might click on this icon and it is a bit slow to expand, you might then click again and the 

program suddenly closes.  When students do this they might get the impression that the program just 

crashed, but this is normal Windows Ribbon behavior. 

 

Thanks, and enjoy SkillsUSA University. 

 

Send questions to jmather@pct.edu 

 

mailto:jmather@pct.edu

