
Practice Exercise 1 
Draw and Organize Objects 
 
Objective Domains that are covered within this practice exercise are: 

• 1.2a Use Quick Select to select objects based on shared properties 

• 1.1a Create and edit polylines, arcs, polygons, and splines 

• 1.3a Save, restore, and manage layer settings using layer states 

• 1.3d Use the Layer Walk tool to display objects on selected layers 
 

Video resources that may help with this challenge exercise are: 

• 01_01 Create and work with polylines 

• 02_02 Manage layers with layer states 

• 02_05 Use the Layer Walk tool 

 

Criteria: In this practice exercise you will edit the drawing using specific 

techniques and use layer states When completed, you will find the area of the 

room. 

The following steps need to be completed: 

1. Open the Bakery-Plan Revision 2.dwg drawing file.  

2. Use the Quick Select tool to select all the text that has a height equal to 220 mm. 

3. Change the following properties of the text: 

a. Color = ByLayer 

b. Text Style = BONGARD1 

c. Text Height = 200 mm 

4. Create a New Layer State named All Visible to preserve the current layer 

configuration. 

5. Create a New Layer State named Create Areas where the layers are set as 

follows: 

a. equipment, text, and columns layers are frozen 

b. doors and windows layers are turned off (not frozen) 

c. door thresholds layer is turned on and thawed 

6. Experiment switching between the All Visible and Create Areas layer states. 

7. Set the Create Areas layer state as current. 

8. Zoom Extents so all the walls are visible and in the current window. 

9. Set the areas layer as current. 

10. Use the Boundary command with the object type set to polyline and the island 

detection turned on to generate polylines inside of each room. 

11. Use the Layer Walk tool (LAYWALK) to select the areas layer and turn off 

Restore on Exit so that only the areas layer is visible in the drawing. 

12. Turn on the text layer so that you can see the room labels. 

13. Locate the cookie dough preparation room and select its boundary polyline. 

14. Use Properties to get the area of the room. 
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Solution: 

 

1. From the ribbon, click the Home tab, Utilities panel, and the Quick Select tool, or 

enter QSELECT at the command prompt. You can also click the Quick Select 

tool on the Properties palette. 

   
 

2. In the Quick Select dialog box, change the following settings: 

• Object type = Text 

• Properties = Height 

• Value = 220 

 
 

3. Click OK to apply the selection filter. 

 

4. Right-click and choose Properties to open the Properties palette. Change the 

following values: 

• Color=ByLayer 

• Text Style = BONGARD1 

• Text Height = 200 

 

5. On the Home tab, click the Layer drop-down panel to see the expanded list. 

 



Practice Exercise 1 
Draw and Organize Objects 
 
 

 

6. Select the New Layer State control in the Layer State list. 

 
 

7. Name the Layer State All Visible and click OK. 

 
 

8. Freeze the equipment, text, and columns layers either in the Layer panel or in 

the Layer palette by clicking the sun icon and changing it to a snowflake. Turn off 

the doors and windows layer by clicking the light bulb icon,changing it from 

yellow to blue. Make sure that the door thresholds layer is turned on and thawed 

by verifying that the light bulb is yellow and there is a sun icon. 
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9. Make a new Layer State named Create Areas. 

 
 

10. Switch between the two Layer States that have been created to test them out, 

then select the Create Areas layer state to set it current. 

 
 

11. Double-click the mouse wheel to Zoom Extents or type Zoom and then click E 

(for Extents) from the command line. 

 

12. Set the areas layer current by selecting it from the Layer panel. 

 
 

13. Select the Boundary command from the ribbon by clicking the Home tab, Draw 

panel, and then expanding the Hatch drop-down panel to locate the Boundary 

command (or type BOUNDARY). 
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14. Leave all the defaults and click the Pick Points button. Pick a point within the 

interior of each room to generate a polyline for each room. Continue until all the 

rooms have a polyline boundary. 

 
 

15. On the Home tab, click the Layers panel, and then click on the Layer drop-down 

panel and select the Layer Walk tool. 

 
 

16. In the Layer Walk tool, select the areas layer and turn off Restore on Exit. Click 

Close. 

 
 

17. In the Layer drop-down menu, turn on the text layer to make the room labels 

visible. 
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18. Locate the cookie dough preparation room and zoom in closer to the room. 

 
 

 

19. Select the polyline boundary for the room, right-click, and select Properties. In 

the Properties palette, expand the Geometry section and note the Area, which is 

8000000. 

 
 

End of exercise 

 

 



Practice Exercise 2 
Advanced Editing Functions 
 
Learning Objectives that are covered within this practice exercise are: 

• 3.2.a Work with arrays 

• 3.3a Use the advanced options of the Trim, Extend and Lengthen  

• 3.4.a Use the advanced options of the Offset command  

• 3.5e Use the multi-functional grips of selected objects 
 

Video resources that may help with this challenge exercise are: 

• 01_03 Create and modify arcs 

• 01_08 Create and work with rays 

• 03_02 Edit with multi-functional grips 

Criteria: In this practice exercise you will edit the drawing using specific 

techniques. Create two parking spaces using offsetting, create additional parking 

spaces with arraying, trim the parking lot lines, and change the size of the 

building addition. 

The following steps need to be completed: 

1. Open the Parking Lot.dwg file. 

2. Create two accessible parking spaces by offsetting the labeled “A”, 13' to the 

right using the current layer as the layer for the offset object. Then offset another 

line to the right of that one also at 13'. 

3. Generate 12 additional parking spaces by arraying the second line that was 

created at 9' apart. Make the array non-associative so that the lines can be 

edited. 

4. Create a temporary line to trim the parking spaces by offsetting the line labeled 

“B”, 19' to the top. 

5. Trim all the parking lines to the edge of the temporary line using the crossing 

option. 

6. Erase the temporary line used to trim the parking lot lines. 

7. Use the multi-function grip on the midpoint of the north side of the building 

addition to add 5' to the size of the addition. 
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Solution: 

 

1. From the ribbon, click the Home tab, Modify panel, and the Offset command. 

 
 

2. From the command line select the Layer option and set it to Current. 

 

 
 

3. Enter the offset distance of 13' and select the line labeled “A”. Offset the line to 

the right. Then select the new line and offset again 13' to the right of that. It 

should like the example show here: 

 
 

4. Select the last line created. On the Home tab, click Modify, select the Array drop-

down panel, and select the Rectangular Array command. 

  
 

5. Change the number of columns to 12, the distance between the columns to 9’ 

and the number of rows to 1. Turn off the Associative option so that it is not 

highlighted. Then click Close Array. 
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6. Use the Offset tool (see step 1) to offset the line labeled “B”, 19' to the top as 

shown here: 

 
 

7. From the ribbon, click the Home tab, Modify panel, and the Trim command. 

 
 

8. Select the temporary line that was just created, and press Enter. Then select the 

Edge option from the command line and set it to Extend. 

 

 
 

9. Use the Crossing option from the command line or make a crossing window by 

picking an empty spot in the drawing and moving from right to left across the top 

of the lines that need to be trimmed as shown below. Erase the temporary line 

used to trim the objects. 

 



Practice Exercise 2 
Advanced Editing Functions 
 

10. To stretch the building addition, select the polyline that makes up the footprint of 

the building as shown below. Then hover over the midpoint grip and select the 

Stretch option. 

 
 

11. Drag the polyline up, type 5', and press Enter (make sure you have either Polar 

or Ortho on) as shown below. 

 
 

End of exercise 

 

 



Practice Exercise 3 
Reusable Content and Drawing Management 
 
Objective Domains that are covered within this practice exercise are: 

• 1.3a Save, restore, and manage layer settings using layer states 

• 1.3f Control the properties of referenced layers 

• 4.2c Create a zipped transmittal package (eTransmit) 

• 6.1a Insert and modify blocks  

• 6.1b Create and modify block definitions 

• 6.2a Attach external reference and underlay files  

• 6.2c Understand layer naming conventions when you bind a referenced 
drawing 
 

Video resources that may help with this challenge exercise are: 

• 02_02 Manage layers with layer states 

• 04_03 Create a zipped transmittal package 

• 06_01 Create blocks and apply attributes 

• 06_02 Control external references and properties of referenced layers 

Criteria: In this practice exercise you will attach and manage external references 

including the layers. You’ll edit a block and also create a transmittal package. 

The following steps need to be completed: 

1. Open the Factory Floorplan-M.dwg file. 

2. Set the XREFS layer as current, and then attach the Factory Landscape-

M.dwg, Factory Electric-M.dwg, and Factory Lighting-M.dwg drawings as 

overlays at 0,0 with no change in scale or rotation (with Overlay selected for 

Reference Type and Relative Path selected as the Path Type). 

3. Attach the Factory Site-M.dwf file at 0,0 with no change in scale or rotation. 

4. Clip the DWF Underlay (approximately) as shown here: 

 
5. Change the Xref Fading value to 75. 

6. Freeze the trees layer in the Factory Landscape-M external reference. 

7. Bind the Factory Landscape-M external reference with the Bind type. 
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Observe: What is the name of the Factory Landscape-M trees layer now? What 

happened to the Xref fading once the Xref was bound? 

8. Open the Factory Electric-M external reference. 

9. Using the Block Editor, edit the R1 block and add a .2 radius circle around the x2 

text as shown. Close and save the block. 

 
10. Save and close the Factory Electric-M external reference drawing and return to 

the Factory Floorplan-M drawing. 

11. Reload the Xref from the notification. 

12. Create a transmittal package as a zip file with the following settings enabled: 

• Set default plotter to “none”. 

• Purge drawings. 

• Place all files in one folder. 

• Include fonts. 

13. Examine the files in the transmittal package to see the fonts and Xrefs. 

14. Save the zip file on your desktop. 
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Solution: 

 

1. On the Home tab, click the Layer drop-down panel, and set XREFS as the current 

layer. 

 
 

2. Type XREF to open the Xref Palette, click the Attach tool, and select the Attach 

DWG option. 

 

 
 

3. Browse to the dataset folder for this course and select the Factory Electric-

M.dwg, Factory Landscape-M.dwg, and Factory Lighting-M.dwg drawing files at 

0,0 with Overlay selected for Reference Type and Relative Path selected as the 

Path Type. 
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4. Type XREF to open the Xref Palette, click the Attach tool, and select the Attach 

DWG option. 

 

 
 

5. Browse to the dataset folder and select the Factory Site-M.dwf file. Attach the file 

at 0,0 using the Relative path type as shown here: 

 
 

6. Select the DWF underlay in the drawing file and choose the Create Clipping 

Boundary option from the context-sensitive ribbon tab as shown here: 
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7. Choose the Rectangular option from the command line. 

 
 

8. Clip the external reference by making a window around the objects as shown 

here: 

 
 

9. On the ribbon, select the Insert tab, select the Reference drop-down panel, and 

click on the number in the Xref fading tool to the right of the slider. Change it to 

75. 

 
 

10. In the Layer drop-down panel, freeze the trees layer on the Factory Landscape-M 

external reference. 
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11. In the XREF palette, right-click on the Factory Landscape-M external reference 

and select BIND. 

 
 

12. Select Bind as the Bind Type from the Bind dialog box. Click OK. 

 
 

13. Open the Layer dialog box to see the name of the Factory Landscape-M trees 

layer and write down the layer name. 

 
 

14. Examine the drawing and notice that the Factory Landscape-M drawing is no 

longer faded. This is because it has been bound and is no longer an external 

reference. 

 

15. Select the Factory Electric-M external reference in the drawing. Select the Open 

Reference option in the context-sensitive ribbon tab as shown here. The file will 

open on a separate tab. 

 
 

16. Select Block Editor from the ribbon, Insert tab, Block Definition panel. 
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17. Select the R1 block from the list and click OK. 

 
 

18. Add a circle around the x2 text as shown below. Close the block editor and save 

the block. Then save and close the Factory Electric-M drawing. 

 
 

19. Return to the Factory Floorplan-M drawing and click on the notification that pops 

up in the lower-right corner. There will be an option to reload the Xref file that has 

changed. Click on the option to reload the Xref. 

 

20. Save the drawing. 

 

21. From the Application menu in AutoCAD, click Publish and select eTransmit (or 

type ETRANSMIT). 
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22. Click Transmittal Setups from the Create Transmittal dialog box. 

 
 

23. Click Modify from the Transmittal Setups dialog box. 

 
 

24. Make sure the following options are selected and click OK: 

• Set default plotter to ‘none’ 

• Purge drawings 

• Include fonts 

• Place all files in one folder 
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25. Examine the files in the package from the Files Table tab to see the fonts and 

Xrefs as shown below. Notice the total file size. 

 
 

26. Pick OK and save the transmittal package to your desktop. 

 

 

End of exercise 
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