
 

 

Revit Structure Rebar 
Sinan Rashid–CAD Technology Center   

Class Description 
Revit provides all of the tools needed for creating 3D models of the concrete reinforcement. Most of 

us have heard that the extra weight on the model will be too great for Revit and the computers to 

handle and that modeling the rebar is way too slow and cumbersome. That was so five years ago. 

Computers today have plenty of processing capabilities that the extra reinforcing, with proper 

graphics management, will not create issue with the model. To top it off, Autodesk has made some 

significant improvements to the reinforcing tools and the rebar annotations that makes the process 

much easier. This presentation will provide the knowledge needed to produce complete, detailed 

and more accurate reinforcement designs using the various rebar tools and utilities.  

Learning Objectives 
At the end of this class, you will be able to: 

 Learn how to use Revit software as an efficient modeling tool for concrete reinforcement 

 Learn how to produce complete reinforcement drawing documentation, 

 Learn how to customize the Revit software rebar schedules 

 Learn about different plugins that will assist in the modeling and documenting process 

 Learn how to manage visibility and model performance 

About the Speaker 

Sinan is an application engineer with Cad Technology Center, an Autodesk Platinum Partner in 

Minnesota, Sinan Rashid has been working in the architecture discipline for over 12 years as a 

designer and project architect. He holds a Bachelors and a Masters degree in Architecture. As 

software engineer with CTC Sinan he becomes a key member of the support and training team. 

Using real world experiences he assists architectural designers in developing ways to maximize 

workflow efficiencies using industry leading software. Sinan teaches courses and works directly 

with architectural design teams to provide insight for the utilization and implementation of BIM 

software strategies 

 

 

 
 
 

 



Revit Structure Rebar 

2 
 

 
Introduction 
Building Information Modeling (BIM) is fast becoming the industry de facto. Noted for driving down 
project cost and errors whilst optimizing workflow and processes, BIM promotes early cross-discipline 
project collaboration and data sharing which ultimately leads to shorter project delivery times, 
increased accuracy and more effective and efficient designs. There are many design tools used by 
structural engineers to effectively perform their everyday design tasks, one of these tools is Autodesk 
Revit software.  
In this class, we will cover the use of reinforcement tool as a platform for an innovative approach to 
reinforcing your elements inside Revit software. We will show examples of Revit’s standard 
reinforcement tools and touch on some best practices, work a rounds, and advantages of utilizing some 
of the Revit extensions tools during the project design and detailing process.  
 
Best Practices for Placement using Revit tools 
Before we hit the actual rebar tools there are settings that we will need to look at before actually 
placing the rebar in the model, these settings located in different area, the following section describe 
where to access some of them. 
 
Rebar Shape Definition and host structural rebar 
This option should be defined before any rebar is placed in a project. You cannot clear this option once 
rebar is placed at the default settings (without first deleting those instances). 
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If the first option is selected, you will be able to specify the visibility of rebar elements in the 

Graphics section of Area or Path Reinforcement Properties palette. 

 

                 Hosting of rebar is turned on                      Hosting of rebar is turned off 

 

When second option is selected, hooks are included when rebar shape matching is calculated for 

scheduling. Rebar with hooks will maintain its own shape identity. This is the default setting for new 

projects. If it is not checked Rebar with hooks will match the closest shape without hooks and not 

influence rebars shape matching 

 

 
 
 
 
 
 
 
 
 
 
 

Cover Settings 
The next thing you need to do before you place any rebar in your project is to look at the rebar cover 
settings. Cover settings are instance parameters that are associated with each wall, beam, foundation, 
and slab. If you select any of these elements and look at the properties pallet, you will see the structural 
group. This group contains the cover settings for that specific item and there are eight different rebar 
cover choices by default for each of the Rebar covert parameters Top, Bottom, and others. 
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 Personalize and add new cover settings:  
You will need to go to the Structure Tab and Reinforcement menu. Expand the fly-out and click on Rebar 
Cover Settings. The Rebar Cover Settings is a simple dialogue where you can add all the different covers 
you need in your project.  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 How Rebar objects reacts to cover: 
Cover constraints rebar set and lock the geometry of each rebar instance with respect to a concrete host 
element. The rebar cover is the internal offset of a concrete host to which rebar parametrically extends. 
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It’s really important to get the cover setting set correctly before starting place rebar because almost all 
modeled reinforcement will be slaves to the cover. The Cover Settings can of course be changed in your 
model after that, but experience shows that this can disrupt your model and schedules.  
 
There are three ways to adjust the cover of element: 

First, is by adjusting the cover in the element properties. 
This is typically the quickest way to modify cover setting of an element.  However, it does not give 
much freedom as most (if not all) elements only give 3 faces to specify.  For example: Inside Face, 
Exterior Face, and Other Face for a wall.  This allows you to define the two primary faces but then 
forces the remaining faces to be defined the same (top, bottom, left side, right side).  
If the cover has been defined differently for one "other" face than the rest, the properties will show 
this as "None."  This also happens when an element has merged with another element such as a 
column merging with a wall or a beam merging with a slab.  
 

 
 

Second, is by specifying the cover of an element in the "Edit Rebar Cover" tool. 
This option really only works well with elements that have a consistent cover on all sides, such as a 

column or elevated slab.  
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Third way of specifying the cover is by selecting a face of an element by using the pick face in the "Edit 

Rebar Cover" tool. This gives great flexibility to specify the cover of each face. This then allows you to 

have a different cover for all 6 main faces of an element. To use this or the element cover tool, first 

select the element/face you would like to manipulate then use the Cover Settings drop down to change 

its cover.  

 

 
 

 

Reinforcement Tools 

In Revit you can model regular reinforcement and fabric reinforcement. There are a number of various 

categories and families assigned for these reinforcement types, and they all behave and interconnect 

differently. 

A. Structural Rebar 
B. Structural Area Reinforcement 
C. Structural Path Reinforcement 
D. Structural Fabric Area 
E. Fabric Sheet 

 
A. Structural Rebar 
The Structural Rebar category is the main tool for placing reinforcement in Revit. The bars are defined 

by two system family called (Rebar Bar & Rebar Hook) and another component family called (Rebar 

Shape).  

Rebar Tool can be accessed from the Structure Tab in Revit or from the Modify Tab after selecting a valid 

object.  

 

You can add Rebar to an element in many different ways, but the workflow I usually prefer is to click on 

the element and choose “Rebar” from the Modify Tab. Then I go ahead and select the desired Rebar Bar 

type, Rebar Shape, Placement planes and Orientation.  
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If it’s a beam then I will create a view that cuts the element (beam) to be reinforced and follow the same 

previous steps to place rebar. 

 
B. Structural Area Reinforcement 
Use the area reinforcement tools to place large amounts of evenly spaced rebar in floors, walls, 

foundation slabs, and other concrete hosts. 
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Area reinforcement creates up to four layers of reinforcing bars in the host. You can create two layers of 

rebar perpendicular to each adjacent face (top and bottom faces for floors and foundation slabs, interior 

and exterior faces for walls). You can also define the bar size and spacing for each layer.  

 

 
 

A sketched boundary defines the extents of the reinforcing bars. Apply rebar hook types to each layer 

using the Properties palette. If you edit the properties of the area reinforcement sketch line, you can use 

hook overrides. The instance properties of the host control the rebar cover settings (offset distance 

from the edge/face of the host to the rebar) for each area reinforcement instance.  

 

Note: both the Area and Path Reinforcement will use the first straight Rebar Shape available in the 

project. If you have a several shapes like me and you want to use a certain shape, then you can add the 

hash tag (#) to the shape name to move it to the top of the list.  

 
 
C. Structural Path Reinforcement 
Use the path reinforcement tools to layout a large amount of rebar along a path.  

 

 
 

Rebar path reinforcement have the same length, but are not all parallel to each other. The rebar is 

perpendicular to the boundary you specify.  The hooked end of the rebar is near the specified boundary 

and the bars extend to one side of the path.  
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The instance properties of the host control the rebar cover settings (the offset distance from the 

edge/face of the host to the rebar) for each path reinforcement instance. Different rebar types require 

different coverage.  

The boundary of the path reinforcement is on by default. To turn it off go to (Visibility/Graphics) and 

clearing the Boundary Visibility parameter under Structural Path Reinforcement. 

 
D. Structural Fabric Area 
Fabric reinforcement creates a layer of fabric sheets in the host. Fabric wire is used to define the 

reinforcing wire, which is used to create the fabric sheets. 

 
The Structural fabric area is much like the structural area reinforcement working as a sketch based host 

for instance-driven model elements. A fabric area boundary defines the extents of the fabric sheets. 

When placed, the fabric is applied at the top or bottom for floors and foundation slabs, or internal or 

external for walls. The instance properties of the host control the rebar cover settings (the offset 

distance from the edge/face of the host to the rebar) for each fabric reinforcement instance. Different 

rebar types require different coverage.  
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In the Structural Fabric Area sketch you can add Boundary Lines and a Major Direction line. Once a 

closed loop is completed four tick boxes will appear. These tick boxes are used for determining from 

which corner the first Fabric Sheet is aligned.  

 

 
 

Along with selecting the proper Fabric Sheet and Location (Top/Bottom), you can modify the  

Lap Splices used for laying out the separate Sheets.  

 
E. Fabric Sheet 
As mentioned, Structural Fabric Areas host Fabric Sheets. This means that the placement of the Fabric 

Sheets is determined in the Area, but the parameters that make up the size, layout and material of each 

sheet are in the sheet families themselves.  

 

 

 

 

 

 

Using the Fabric Sheet Type Parameters you can standardize sheet sizes, bar diameters, spacing, mass 

and overhang, among other properties. Even though the Structural Fabric Reinforcement category is the 

one we use for scheduling, these are the parameters that are combined in the schedules.  

AMTECH_ADMIN
Highlight
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The Fabric Sheet bar diameter (Major and Minor Direction Wire Type) is not a regular length parameter, 

it's a nested family called Fabric Wire.  

 
 
 
 
 
 
 

 

Rebar Placement Options - using the native Revit commands 

There are couples of different options to select in the Placement Planes and Placement Orientation 

panels: 

1. Placement Planes  

The plane defines where the rebar is placed in the host. Click one of the following placement planes 

from Modify | Place Rebar tab | Placement Plane panel 

 Current Work Plane  

 Near Cover Reference  

 Far Cover Reference 
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2. Placement Orientation  

The orientation defines how the rebar is aligned when placed in the host. Click one of the following 

placement orientations from Modify | Place Rebar tab | Placement Orientation panel  

 Parallel to Work Plane  

 Parallel to Cover  

 Perpendicular to Cover 

 

 

 

 

 

 

 

If you are looking at a section that is perpendicular to the element, choosing Parallel to Cover 

will draw a bar perpendicular to your view, and choosing Parallel to Work Plane will draw a bar 

that is parallel to the section view (even though the view has no valid Work Plane).  

 

3. Sketch Rebar  

Use the sketch tools for manual placement of rebar shapes within a valid host. 

Note: If the sketch does not match an existing shape, a new shape will be created in the Rebar 

Shape browser and Rebar Shape type drop-down in the Options Bar. 
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Multi-Planer-Reinforcement: I use this tool to define rebar shapes that are bent in two planes.  

You begin sketching multi-planar rebar in the same way you do planar rebar. Using the Multi-planar 

rebar tool from the rebar sketching tools.  

 

 

 

 

 

 

When Multi-planar is selected in sketch mode, the shape is duplicated and attached to the original by a 

connector segment of rebar. This is best seen in 3D view.  

Three check boxes are available to further edit the multi-planar rebar shape (see the image above):  

1. Disable/Enable first connector segment 

2. Disable/Enable second connector segment 

3. Disable copy of shape segments 

Place your cursor over each box to see which tool they are.  

 

1 



Revit Structure Rebar 

14 
 

Rebar Set: You can create rebar sets perpendicular to the sketch plane of the rebar and define the 

number of bars and/or bar spacing. Using rebar sets to layout the rebar will speeds up the process of 

adding rebar by providing a quantity of identical bars. 

 

 
 

Optional: You can then select the element and from the properties pallet apply various predefined 

hooks to the ends of your rebar shape. 

 

 
 

Note: Rebar lengths default to the length of the host element or to other host elements within the 

constraints of the cover reference. To edit lengths, change to either a plan or an elevation view, select 

the rebar instance and revise the end points as needed. 

 
 
Rebar Placement Options - in Curved Wall and Footing: 
 
The way the different reinforcement tools appear today, we must acknowledge that some forms are 

inefficient to do 3D in Revit, and some seem straight out impossible.  

This is mostly due to the confession that a single distribution of Structural Rebar cannot have varying 

dimensions, and cannot be distributed in another direction and form than linear and perpendicular to 

the rebar shape plane. These limitations turn the workflow inefficient and boring, but not impossible.  

 

To place a Rebar on Curved Wall and Footing 

 Horizontal Bar, Depends on which direction you want the outside bars to run. If you want the 

longitudinal (curved) bars to be on the outside/inside faces, you can either sketch the curved bar 

against the cover (which on finish sketch would become Rebar Shape 09 in the US template) or you 

can place these curved shapes directly. You will be able to use sets for the "horizontal bars".  
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 Vertical Bars, if the bars are placed against the cover, and if the bars have hooks, they will be turned 

inside. However, you will need to use a circular/radial array to distribute the vertical bars. 
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Rebar Annotations 
 

A. Tagging Multi-Rebar Annotations 

A multi-rebar annotation allows you to tag multiple rebar and rebar sets with a single annotation. 

With multi-rebar annotations, you can select multiple aligned rebar and display the dimensions 

between the rebar references, as well as parameter data. 

To use multi-rebar annotations, there must be at least two rebar references. Only references which 

would work for Aligned Dimensions can be selected.  

Click Annotate tab >Tag panel > Multi-Rebar  

 
 

You can select multiple aligned rebar and display the dimensions between the rebar references, as 

well as parameter data. 

 
 

https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/2014/ENU/Revit/files/GUID-E0FB313E-CE57-4741-9EF5-6747BBA3BDDB-htm.html
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Use multi-rebar annotations to tag each bar in a rebar set with a detailed annotation for fabrication and 

construction. 

 

 
 
 
 
 
 
 
 
 
 

 
 
 
B. Tagging Area Reinforcement  

You can annotate the area reinforcement region using custom symbols and tags. This provides 

information about the type of reinforcement and specific boundary details. 

First, Place an Area Reinforcement Symbol.  

Click Annotate tab > Symbol panel > Area Reinforcement Symbol. 

 
 

Second, Place an Area Reinforcement Tag 

Select Annotate tab > Tag panel > Tag By Category. 
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Note: Same steps can be applied to tag path reinforcement  
 
C. Rebar Presentation 

Use this tool to Specify how rebar sets are shown in a view. Bar presentation schemes simplify the 
view while maintaining an identifiable footprint in which the rebar set is placed. 
 

 
 

We can also set the default behavior for all added reinforcement in Reinforcement Settings:  
Reinforcement Presentation. But I usually prefer to use the Show All setting however, because 
unlike the Presentation options for each rebar set, this works for all views.  
 

 
 
 
Optionally, click Modify > Structural Rebar tab > Presentation panel > (Select) to specify individual bars 
to represent the set. In the drawing area, selected rebar (highlighted) will show in the rebar set, 

unselected rebar will be hidden.  
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D. View Visibility States  
By default rebar elements in a 3D solid model are contained within host elements, and in hidden line 
view they are obscured by the host. You can set overrides for each view in a project, so the rebar 
design can be documented. Each rebar element has a view visibility setting, which is an instance 
property. To change rebar visibility, select all rebar instances and rebar sets to be made visible. On 
the Properties palette, click the View Visibility States Edit button.  
 

 
 
 
 

https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/2014/ENU/Revit/files/GUID-9AC0E042-1CA7-483F-A2C4-18F476746A2D-htm.html
https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/2014/ENU/Revit/files/GUID-A764EA7A-FE26-469B-857C-F3A70812FC34-htm.html
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In the Rebar Element View Visibility States dialog, select the views in which you want the rebar to be 
Viewed Unobscured. This view parameter displays the selected rebar, regardless of its visual style. The 
rebar cannot be obscured by other elements and is visible in front of all obscuring elements. Rebar 
elements that are cut by the cut plane are always visible. This setting has no effect on the visibility of 
these rebar instances.  
Disable this parameter to hide the rebar in all Visual style views other than Wireframe.  
 
Optionally, select the 3D views in which you want the rebar to be viewed as solid.  
 

 

 
 
Rebar Scheduling   

 
Now structural engineer and contractors can use the new rebar feature Enhancements to gain better 
insight into the project structure. With the improved Rebar Scheduling feature, you can now list 
elements per member facilitated by an added set of new parameters: 
 

 The Host Mark parameter displays the name of the structural element hosting the rebar. 

 The Host Count displays the number of identical structural elements hosting the rebar. 

 The Host Category displays the current host associated with the reinforcement elements. 
Column, Framing, Foundation, Wall, Floor, or Part.  

 And Quantity per Element displays the calculated value of the total number of rebar per host. 
This feature improves rebar documentation and supports better productivity for rebar 
detailing.   
 

Also, Revit provides us with a lot of out-of-the-box parameters that we can use in our Rebar Schedules. 
Examples of provided parameters out-of-the-box that we use are Bar Diameter, Bar Length, Total Bar 

https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/2014/ENU/Revit/files/GUID-12C2D6B0-71ED-490E-9CC6-AD3C635F092B-htm.html
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Length, Quantity, Rebar Number, Comments and the different bar segment lengths (a, b, c, etc.). Many 
of these we can manipulate, hide and in use in Calculated Values instead. 

 

 
 

Partition:  
This is the parameter from which automatic bar numbering in Revit is set.  For each partition, Revit will 
find identical rebar and assign the same rebar number. Therefore, this parameter is extremely important 
in managing and defining your bar marking and numbering system. Possible uses of the partition 
parameter are to organize the rebar numbering scheme in your model by construction sequencing and 
phasing (pours), host element types, location within a host (i.e. top and bottom bar), or location in the 
model.   
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Rebar Number:  
As mentioned above, the rebar number is defined automatically per partition. This is really the 
workhorse in automatic bar numbering, and was a very powerful, game-changing addition to rebar in 
Revit when it was introduced.  

 

 
 

Partitioning for reinforcement identification serves a number of organizational purposes depending on 
how a building is designed or how it will be constructed. Design, ordering, fabrication, and ultimately the 
placement location of rebar on site all have an impact on the partitioning needs of the contractor. Such 
factors include, but are not limited to:  

 Construction sequences and phasing  

 Host element types (concrete columns, beams, or slabs for example)  

 Precast fabrication needs  

 Location within a host (such as top and bottom in slabs, or inner and exterior in walls)  

 Location in the model  
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Reinforcement Rounding  
Revit 2014 included a Reinforcement Rounding feature. This addition was to allow numerical rounding 
of rebar lengths to simplify organization and annotation when tagging, filtering, or scheduling. This is a 
practical problem were sometimes two or more bars for some reason is not entirely identical, but we 
want them to both have the same Rebar Number, and to be on the same schedule row.  
We can access the settings of Reinforcement Rounding from the Reinforcement Settings dialogue. 

 

 
 
 
View Filters 
Filters provide a way to override the graphic display and control the visibility of elements that share 
common properties in a view. 
Example: We can use color-coded pour break for visualization using filters with pour phase parameters. 
The following image shows a visual representation of 6 partitions in a basic model where each level has 
3 specific partitions. Rebar assigned to a specific partition and filter can display like colors.  
To start creating filters, you need to go to View Tab> Graphics Panel > Filters. Now: 

1- Create new filters and make sure to give it a meaningful name to make it easy for the other user 
to understand what this filter is for. 

2- Select the Category you would like to utilize (in this case it will be the Structural rebar)    
3- Add the filter Rules and then select the desire parameter and name to filter by 
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Next, go to the View Tab> Graphics Panel > Visibility/Graphics. Select the Add tool to start adding all the 
filters you create in the previous step. After that you can start changing the Line and Patterns color for 
each filter you have, you can also hide the Rebar from a specific partition by unchecking the visibility 
check box. 
 

 

 
 
Note: Any rebar, rebar set, or fabric sheet instance in a model can only be assigned to one partition. This 
maintains numbering sequences and number matching within a partition for schedules and tags.  
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Autodesk Revit Extensions  
 
Confused or wanting to know more about what the Autodesk Revit Extensions have to offer? Here is 
information regarding the Autodesk Revit Extensions so you can be more aware of what they can offer 
you and your company. 
 
The Revit 2016 Extensions are for Subscription holders only. After you have downloaded and installed 
the Revit 2016 Extension you will see a new Extensions tab on the Ribbon.  
 

 

Here is a rundown of what is in the Revit 2016 Extensions and a brief description on some of the tools 
related to structure Rebar. 
 
The Elements Panel within the Extensions tab on the Ribbon has both a Modify and Delete tool. This is 
just for elements created with the Revit Extensions. 
 
The Project Panel within the Extensions tab on the Ribbon is where the Preferences tool is located. This 
tool is where you will setup your Regional Settings for your database. The default is United States. You 
can set up the database preferences for the following: 

 Profiles 

 Bolts 

 Materials 

 Reinforcing bars 
 
 
 

 
 
 

 
 
 
 
 
 
 
 
 
 

http://subscription.autodesk.com/sp/servlet/public/index?siteID=11564774&id=11607975
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Reinforcement tools 
It is a good tool for a starting point. Usually, I use this as a tool to model the rebar in a single columns, 
walls, Beams, or pier cap, i.e. in a Revit model. Once you create the rebar for a single element, you can 
then modify it, and copy the rebar cage to other similar objects.  
To start using any of these tools you will need to select the item first and then select the right 
reinforcement tools. In my case I select the column first and then went to extensions tab > 
Reinforcement and then select Columns. 
 

 
 

 
 

Note: The same method can apply to the other reinforcement tools  


