Wiretap

Wiretap

Reply
Active Contributor
derrick
Posts: 30
Registered: ‎11-17-2006
Message 1 of 4 (186 Views)

setting numFrames to 0 kills wiretap daemon

186 Views, 3 Replies
02-14-2007 10:54 PM
It looks like the wiretap server is not properly validating input: due to a bug, my code would occasionally try to set the number of frames of a newly created clip to 0. That causes the wiretap daemon to crash with the message:
ifffsWiretapServer: /vobs/develop/src/libMedia/vmedia/videoMedia.C:113: VideoFrame VideoMedia::smileysurprised:perator[](int) const: Assertion `frameIdx >= 0 && frameIdx < getNbFrames()' failed.
/usr/discreet/sw/sw_wiretapd: line 38: 31567 Aborted $server_prog $*
Distinguished Contributor
dlabute
Posts: 103
Registered: ‎05-11-2004
Message 2 of 4 (186 Views)

Re: setting numFrames to 0 kills wiretap daemon

02-15-2007 04:51 AM in reply to: derrick
Thanks. We'll validate and get on it right away.
Contributor
julik_tar
Posts: 20
Registered: ‎01-24-2007
Message 3 of 4 (186 Views)

Re: setting numFrames to 0 kills wiretap daemon

02-16-2007 05:20 AM in reply to: derrick
I can confirm (at least with wiretapd on flame 9.5.13), we had to insert a special case for that into our Ruby bindings to avoid killing the server.
Valued Contributor
labuted
Posts: 51
Registered: ‎11-17-2006
Message 4 of 4 (186 Views)

Re: setting numFrames to 0 kills wiretap daemon

03-06-2007 05:32 PM in reply to: derrick
We managed to replicate in house. A fix is on the way for the WT server. It won't make it in for v2007 service pack though.

Thanks for flagging it,

Dan
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.