Visualization

Visualization

Reply
Valued Contributor
nannerdw
Posts: 95
Registered: ‎06-09-2008
Message 1 of 3 (969 Views)
Accepted Solution

Japanese characters not displaying properly

969 Views, 2 Replies
10-22-2012 06:10 AM

I have a dwg file with all of the text encoded in the Shift-JIS character set.  It contains only a few Japanese characters, and the rest appear to be the Shift-JIS equivalents of Roman characters.

 

Now I'm just trying to set the text style in AutoCAD to make it show up correctly.  I've tried Big Font: extfont.shx and extfont2.shx, but neither one works.

 

The text in this file should read "DWG. NO." (confirmed by copying it into Notepad++, and changing its encoding to Shift-JIS)

-Using Autodesk Inventor Professional 2012

I found a workaround to this problem.  Here's what I did, for anyone else who might be having this same issue:

 

You have to use a text editor that’s capable of re-encoding into a different character set.

I’m using Notepad++ (Unicode version), which you can download here.

 

Open the DXF file in Notepad++

Go to Encoding > Character Sets > Japanese > Shift-JIS

Edit: Select All

Copy

File: New

Paste into the new file (This will convert all of the English characters from Shift-JIS back to their ANSI equivalents)

File: Save

Open the new file in AutoCAD (All of the English characters should now show up normally, and Japanese characters will show up as question marks.)

 

Note:

This solution will not work for files in DWG format.  They must be saved to DXF first.

Valued Contributor
nannerdw
Posts: 95
Registered: ‎06-09-2008
Message 2 of 3 (939 Views)

Re: Japanese characters not displaying properly

11-19-2012 01:27 PM in reply to: nannerdw

I found a workaround to this problem.  Here's what I did, for anyone else who might be having this same issue:

 

You have to use a text editor that’s capable of re-encoding into a different character set.

I’m using Notepad++ (Unicode version), which you can download here.

 

Open the DXF file in Notepad++

Go to Encoding > Character Sets > Japanese > Shift-JIS

Edit: Select All

Copy

File: New

Paste into the new file (This will convert all of the English characters from Shift-JIS back to their ANSI equivalents)

File: Save

Open the new file in AutoCAD (All of the English characters should now show up normally, and Japanese characters will show up as question marks.)

 

Note:

This solution will not work for files in DWG format.  They must be saved to DXF first.

-Using Autodesk Inventor Professional 2012
Valued Contributor
nannerdw
Posts: 95
Registered: ‎06-09-2008
Message 3 of 3 (925 Views)

Re: Japanese characters not displaying properly

11-20-2012 05:37 AM in reply to: nannerdw

Also, this only works with files saved as DXF 2004 or older.

-Using Autodesk Inventor Professional 2012
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.