Visual LISP, AutoLISP and General Customization

Visual LISP, AutoLISP and General Customization

Reply
Active Contributor
30 Posts
0 Kudos
Registered: ‎07-09-2010
Post 1 of 4

Loading a lisp file in vlisp editor

236 Views, 3 Replies
09-04-2012 11:32 AM

Does someone has a clue, when I load a file in the vlisp editor this is what I get in the console window:

_$
; error: bad argument type: numberp: nil

Please help

 

*Expert Elite*
3,598 Posts
550 Kudos
Registered: ‎12-17-2004
Post 2 of 4

Re: Loading a lisp file in vlisp editor

09-04-2012 01:19 PM in reply to: m.pepin

Try this:

in vlisp editor, menu debug and break on error,

then load your code,

go to menu debug and last break source, to see what is causing the error.

 

Henrique

*Expert Elite*
5,763 Posts
504 Kudos
Registered: ‎10-12-2006
Post 3 of 4

Re: Loading a lisp file in vlisp editor

09-04-2012 04:11 PM in reply to: m.pepin

Incidental to the problem, this means something is executing by loading the file.  If this is not intended behavior, then you likely have mismatched parenthesis in the code.  If it is intended behavior, I recommend you disable the execute-on-load behavior during development - it will make debugging easier.

----------------------------------
If you are going to fly by the seat of your pants, expect friction burns.
Adopt. Adapt. Overcome. Or be overcome.
A good question will be halfway to a good answer.


Active Contributor
30 Posts
0 Kudos
Registered: ‎07-09-2010
Post 4 of 4

Re: Loading a lisp file in vlisp editor

09-05-2012 05:14 AM in reply to: m.pepin

Thank you, indeed it was mismatch parenthesis. I was puzzled because when I mismatch parenthesis I got another error message than numberp nil. thank you again.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!