Visual LISP, AutoLISP and General Customization

Visual LISP, AutoLISP and General Customization

Reply
*Gustavo_Guidi
Message 1 of 2 (62 Views)

LAYER Command problem

62 Views, 1 Replies
03-27-2009 01:41 PM
I have a program that uses for set a layer and turn it off the following
string

(command "_layer" "_S" lay "_OFF" lay "_Y" "")

The problem is that in one machine with 2008 the command doesn`t prevent to
you about

Really want layer "$$$_AUX_PLAN" (the CURRENT layer) off? y

so the "_Y" must not exist and it creates an error. Is it there any variable
that set this to ON or OFF in order to checkit so the question is made or
not and to give to different way depending on the values of it?

Thanks in advance
*Gustavo_Guidi
Message 2 of 2 (62 Views)

Re: LAYER Command problem

03-27-2009 02:07 PM in reply to: *Gustavo_Guidi
I found that EXPERT variable was the problem

Thanks anyway


"Gustavo_Guidi" escribió en el mensaje
news:6150988@discussion.autodesk.com...
I have a program that uses for set a layer and turn it off the following
string

(command "_layer" "_S" lay "_OFF" lay "_Y" "")

The problem is that in one machine with 2008 the command doesn`t prevent to
you about

Really want layer "$$$_AUX_PLAN" (the CURRENT layer) off? y

so the "_Y" must not exist and it creates an error. Is it there any variable
that set this to ON or OFF in order to checkit so the question is made or
not and to give to different way depending on the values of it?

Thanks in advance
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!