Vault Mirror & Drawing Compare

Vault Mirror & Drawing Compare

Reply
*Expert Elite*
karthur1
Posts: 4,331
Registered: ‎04-27-2005
Message 1 of 11 (590 Views)
Accepted Solution

Full Mirror fails when ran from batch file

590 Views, 10 Replies
06-08-2012 12:26 PM

I have a batch file for both the partial and the full vault mirror setup.  Both are ran from using the Windows Task Scheduler.  I have the Full mirror setup to run once each night.  My problem is the full mirror fails to complete.  In the error log I get different messages.  Here is a cut/paste of a few of them.

 

6/7/2012 7:00:00 PM System.Exception: Logon failed.    at Autodesk.Connectivity.WebServicesTools.WebServiceManager.SignIn()

6/6/2012 7:00:00 PM System.Exception: Logon failed.    at Autodesk.Connectivity.WebServicesTools.WebServiceManager.SignIn()

6/6/2012 7:00:00 PM System.Exception: Logon failed.    at Autodesk.Connectivity.WebServicesTools.WebServiceManager.SignIn()

6/5/2012 7:00:00 PM System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. --->

6/4/2012 7:00:00 PM System.Exception: Logon failed.    at Autodesk.Connectivity.WebServicesTools.WebServiceManager.SignIn()

5/29/2012 7:00:00 PM System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. --->

 

 

I can run the full mirror from the Vault Mirror dialog using the same parameters as in my batch file and it will run.  the partial vault mirror works fine from both the task scheduler batch file and from the dialog.

 

Any ideas?

Doug,

I just now recopied the VaultMirror-BaseVault.exe from original zip file (just to make sure nothing has gotten hosed with the .exe).  I then manually ran the FullMirror.bat file.  When I did that, the command prompt came up.  Its been up for several minutes now. I just checked the Windows Task Manager.  It shows VaultMirror-Base Vault.exe working.

 

I'll let it run (been about 5 minutes now) and see if it works.  It usually takes it several hours to do a full mirror when I do it from the dialog.

 

Will report back when its fininshed.

 

Thanks

Employee
olearya
Posts: 673
Registered: ‎08-14-2008
Message 2 of 11 (581 Views)

Re: Full Mirror fails when ran from batch file

06-12-2012 09:57 AM in reply to: karthur1

Hey there,

 

This does seem to be a logon error.  You may need to check the actual Vault log in credentials but also do you know if the sa password is set as default or has this been changed?



Allan
Product Manager
Autodesk, Inc.
*Expert Elite*
karthur1
Posts: 4,331
Registered: ‎04-27-2005
Message 3 of 11 (579 Views)

Re: Full Mirror fails when ran from batch file

06-12-2012 10:07 AM in reply to: karthur1
The Sa password has changed. The batch file that I run the partial mirror from works fine. It uses my password and username. I copied this batch file and just changed the partial vault mirror in the command line to full vault mirror.
I can also run the ull vault mirror from the dialog with my username and password.
Employee
olearya
Posts: 673
Registered: ‎08-14-2008
Message 4 of 11 (574 Views)

Re: Full Mirror fails when ran from batch file

06-12-2012 10:35 AM in reply to: karthur1

Ah - I should have noted that the partial was working OK - sorry.  The batch file can behave differently to direct login but if one batch file works and not the other this is odd  - let me get back to you.



Allan
Product Manager
Autodesk, Inc.
Employee
Redmond.D
Posts: 814
Registered: ‎12-12-2006
Message 5 of 11 (553 Views)

Re: Full Mirror fails when ran from batch file

06-20-2012 07:20 AM in reply to: olearya

This one is my fault.  There is a missing command line parameter in the documentation.  There is an -F parameter that can be used to specify the output folder.

 

Try something like this and let me know if:

VaultMirror -PartialMirror -U Administrator -P pass -S localhost -V vault -F C:\Mirror -L out.txt

 

Command line usage should be:

VaultMirror [-PartialMirror | -FullMirror] [-U user] [-P pass] [-S server] [-V vault] [-F folder] [-L logfile]




Doug Redmond
Software Engineer
Autodesk, Inc.
http://justonesandzeros.typepad.com/

*Expert Elite*
karthur1
Posts: 4,331
Registered: ‎04-27-2005
Message 6 of 11 (551 Views)

Re: Full Mirror fails when ran from batch file

06-20-2012 08:10 AM in reply to: Redmond.D

Doug,

This is the command line that I'm using for the Full mirror (which fails).  The partial mirror works fine with the same coammand line, but I have replaced "-FullMirror" with "PartialMirror".

 

VaultMirror-BaseVault.exe -FullMirror -f "\\fmi3\Inventor\Vault Mirror" -L vaultmirrorerror.log -s fmi2 -v Vault -u administrator -p fmi

 

Kirk

Employee
Redmond.D
Posts: 814
Registered: ‎12-12-2006
Message 7 of 11 (548 Views)

Re: Full Mirror fails when ran from batch file

06-20-2012 08:56 AM in reply to: karthur1

Can you paste your Partical Mirror command line.  Feel free to change or blank out the password.

 

Also, it appears that you are using the modified version of Vault Mirror that I created for Vault Basic 2012 users.  Is that correct?



Doug Redmond
Software Engineer
Autodesk, Inc.
http://justonesandzeros.typepad.com/

*Expert Elite*
karthur1
Posts: 4,331
Registered: ‎04-27-2005
Message 8 of 11 (544 Views)

Re: Full Mirror fails when ran from batch file

06-20-2012 10:58 AM in reply to: Redmond.D

Yes, I am using Vault Basic 2012.

 

Here's the partial vault command line that I'm using.

 

VaultMirror-BaseVault.exe -PartialMirror -f "\\fmi3\Inventor\Vault Mirror" -L vaultmirrorerror.log -s fmi2 -v Vault -u administrator -p fmi

Employee
Redmond.D
Posts: 814
Registered: ‎12-12-2006
Message 9 of 11 (527 Views)

Re: Full Mirror fails when ran from batch file

06-27-2012 05:42 AM in reply to: karthur1

I'm still unable to reproduce.  Both full mirror and partial mirror work for me and I'm using VaultMirror-BaseVault.exe.

 

Does VaultMirror fail right away, or does it fail in the middle of copying files?  Can you post the entire log file?



Doug Redmond
Software Engineer
Autodesk, Inc.
http://justonesandzeros.typepad.com/

*Expert Elite*
karthur1
Posts: 4,331
Registered: ‎04-27-2005
Message 10 of 11 (525 Views)

Re: Full Mirror fails when ran from batch file

06-27-2012 06:15 AM in reply to: Redmond.D

Doug,

I just now recopied the VaultMirror-BaseVault.exe from original zip file (just to make sure nothing has gotten hosed with the .exe).  I then manually ran the FullMirror.bat file.  When I did that, the command prompt came up.  Its been up for several minutes now. I just checked the Windows Task Manager.  It shows VaultMirror-Base Vault.exe working.

 

I'll let it run (been about 5 minutes now) and see if it works.  It usually takes it several hours to do a full mirror when I do it from the dialog.

 

Will report back when its fininshed.

 

Thanks

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.