Vault General Discussion

Vault General Discussion

Reply
Active Member
tuomo.hiltunen
Posts: 10
Registered: ‎11-29-2012
Message 1 of 12 (334 Views)
Accepted Solution

Vault 2012 explorer hangs when browse folder to folder fast enough

334 Views, 11 Replies
11-30-2012 11:13 AM

Hi,

 

I have a problem on one customer,

We moved vault 2012 database to new vault 2012 server.

New server is:

windows server standard 2008 R2 64bit

MS SQL server 2008 R2 64bit

Vault standard 2012

In MS hyper-v virtual machine.

 

So the old vault was same version and restore and all installations went well, no errors or anything problem with that.

And vault was accessible right away, I also installed all hotfixes released before update1.

Not yet update1 cause have to update all clients when I do that and on old server there was no update1 eather.


I have rebuilded search indexes and limited SQL memory usage to 8192mb what is recommended.

 

All work well and vault opens fast from every network LAN or WAN

But there is little annoying thing, when I browse fast to folder to folder which contain files, vault explorer hangs and I have to force close it with task manager.

The odd thing is that when I just let explorer to show folder files before I browse to another folder it works fine, but if I dont let that second to files to show, it hangs.

 

Any help?

 

 

 

Little update again.

 

I made first 2048bit self signed certificate to the server and exported it and installed on one client, hang again on client.

Then I made 1024bit self signed certificate to the server and exported it and installed on one client, hang again on client.

 

So it seems it does not matter how long the certificate is.

 

I just notice that there is update2 on vault 2012 released on 12.12.2012 and there is that fix to SSL problem with it.

So I just try it and come back to you how the outcome is

 

Forgot to make update on this case.

 

Update 2 released 12.12.2012 fixed the SSL issue on vault basic.

There was mention on fixes list to SSL fix and it worked, so this case is solved.

Active Member
tuomo.hiltunen
Posts: 10
Registered: ‎11-29-2012
Message 2 of 12 (327 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

11-30-2012 12:01 PM in reply to: tuomo.hiltunen

Little update.

 

I just waited long enough when vault explorer hanged(about 15min) then it popup. Error: operation( or action) time out.
And worked fine after that again, even now I can browse folder faster than before hang and timeout????

but again, when I browse folders a while very fast it hanged again...

Active Member
tuomo.hiltunen
Posts: 10
Registered: ‎11-29-2012
Message 3 of 12 (296 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

12-03-2012 11:44 PM in reply to: tuomo.hiltunen

Any help? I am struggling with this problem.

Product Support
Olaf.Górski
Posts: 65
Registered: ‎08-23-2010
Message 4 of 12 (290 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

12-04-2012 01:39 AM in reply to: tuomo.hiltunen

Hello Tuomo,

 

No help directly, however, please consider following aspects which may cause performance issues. Maybe it will do help you.

 

o As virtual environments could cause unexpected consequences Autodesk reserves the right to ask that any customer reported problems be reproduced on a physical machine outside the VMware environment.
Read: Virtual environments can always cause unexpected behaviour of Vault.

 

Hope it helps 



Olaf Górski
Active Member
tuomo.hiltunen
Posts: 10
Registered: ‎11-29-2012
Message 5 of 12 (285 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

12-04-2012 02:11 AM in reply to: Olaf.Górski

Hi Olaf,

 

Thanks for response.

 

I have no antivirus at the moment installed on the server, and client machines are exactly the same as they was before move to the new server.

So it cannot be antivirus problem.

 

About virtual machine, vault works fine when we do anything else, opens fast, file transfer is fast, all works fine but this only thing that did not work is this fast folder to folder browse.

Can it be some IIS web application issue?

 

 

Board Manager
ihayesjr
Posts: 603
Registered: ‎02-01-2006
Message 6 of 12 (279 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

12-04-2012 06:38 AM in reply to: tuomo.hiltunen

Can you reproduce the problem outside of the Hyper-V environment?



Irvin Hayes Jr
Product Manager
Autodesk, Inc.

Active Member
tuomo.hiltunen
Posts: 10
Registered: ‎11-29-2012
Message 7 of 12 (266 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

12-05-2012 12:13 AM in reply to: ihayesjr

Hi Irvin,

 

I can but not that easy.

So I try to make then all the same but not in hyper-v. Same hardware and so on.

I come back to you when I have done that.

 

 

Active Member
tuomo.hiltunen
Posts: 10
Registered: ‎11-29-2012
Message 8 of 12 (232 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

12-15-2012 05:42 PM in reply to: tuomo.hiltunen

Ok,

 

I installed all to real 2008 R2 standard server and I followed directly the advanced configuration guide and make all what it is said in there, default settings and all.

SQL 2008r2 now without sp1 cause I found somewhere that it is not supported on 2012 vault. so now without it.

 

Restored backup and all hangs starts again.... ! !"#!"#

 

Ok ok, I start thinking what it can be cause all have been done exactly what guide told to do and I have googled alot of this thing and done all what I have found byt no avail..

 

I disabled the require SSL on autodesk site and I tried it without SSL, and now all works fine.

So the reason was SSL?? Can it be that brand new dell server with good Xeon and 16gb memory cannot handle 2048bit certificate?

or it is the vault web service which cannot handle it?

old server which worked was with 1024bit SSL certificate.

 

Any guess?

Active Member
tuomo.hiltunen
Posts: 10
Registered: ‎11-29-2012
Message 9 of 12 (224 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

12-16-2012 04:05 AM in reply to: tuomo.hiltunen

Or can it be that client cannot handle 2048bit cetificates?

Active Member
tuomo.hiltunen
Posts: 10
Registered: ‎11-29-2012
Message 10 of 12 (222 Views)

Re: Vault 2012 explorer hangs when browse folder to folder fast enough

12-16-2012 04:35 AM in reply to: tuomo.hiltunen

I find this link when googling long enough with ssl problems:

 

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=20350604&linkID=9261341

 

But in readme it says it is for:

 

  • Autodesk Vault Collaboration 2012 Update 1
  • Autodesk Vault Professional 2012 Update 1

No Vault basic? I have this problem exactly and it is on vault basic.

 

Can I use this update on vault basic too? or can you make update for it?

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.