Vault General Discussion

Vault General Discussion

Reply
Contributor
13 Posts
0 Kudos
Registered: ‎05-03-2007
Post 1 of 25
Accepted Solution

Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

1651 Views, 24 Replies
06-06-2011 03:18 AM

Hi,

 

Hope someone can help me with the following:

 

During copy design in Vault 2012 (Inventor 2012) I get an error: Value cannot be null; Parameter name: value

None of the files are copied. I've tried al kind of different ways, coping in the same folder, different prefix and/or suffix, first selecting files, folderlocatin in "To", other way around, no folderlocation in "To', and so on! I've also contacted our Autodesk supplier, but till now do they also not know what causes this.

 

Does anybody know what can cause this or better, has a sollution for this?

VaultServer log file attached of today 6-6-2011

 

Thimo

Netherlands

Thimo Nijpels
Comus Technology BV
Netherlands
http://www.dry-reeds.com

Hi Dan,

Thank you for your reply.  In our tests, you can set the ipj at the working folder root (example: C:\_Work) and then point your workspace to the workspace folder.  In another test, I set the IPJ file in $\ but it was mapped to C:\_Work and workspace folder was set to .\.

I hope this helps. 

 

 

Employee
540 Posts
48 Kudos
Registered: ‎06-07-2010
Post 2 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-06-2011 09:15 AM in reply to: nijpels

It looks like there is a permission problem with your filestore directory.

 

The server runs as a particular user (by default "AutodeskVault"), and that user needs full control of the filestore directory.

 

Hope this helps,

-Dave

 



Dave Mink
Data Management
Autodesk, Inc.
Contributor
13 Posts
0 Kudos
Registered: ‎05-03-2007
Post 3 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-06-2011 09:23 AM in reply to: minkd

Thanks Dave,

 

I'll try that, I'll let you know.

Thimo Nijpels
Comus Technology BV
Netherlands
http://www.dry-reeds.com
Contributor
13 Posts
0 Kudos
Registered: ‎05-03-2007
Post 4 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-06-2011 09:39 AM in reply to: nijpels

Thanks Dave,

 

It worked, someone had the idea that the user Autodeskvault was not used and deleted it!!!!

I re-installed, and copy design now works! Sometimes it's much simpler then you think!

Thimo Nijpels
Comus Technology BV
Netherlands
http://www.dry-reeds.com
Contributor
13 Posts
0 Kudos
Registered: ‎05-03-2007
Post 5 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-07-2011 03:13 AM in reply to: nijpels

Hi Dave

 

I've been cheering to early, it worked with one part, but not with compleet assemblies (idw, iam and ipt), I got the same error as before.

 

Also no-one did delete the user "autodeskvault" (which I thought before. My supplier told me it is a known problem at Autodesk and are working on it.

I know the user "autodeskvault" was there before I installed 2012 over 2011. I don't know if it was deleted on the installation of 2012.

 

Still, I've reinstalled the Vault Server 2012, but with no change.

 

Also, we hade to upgrade the SQL from 2005 to 2008, could there be the problem?

Thimo Nijpels
Comus Technology BV
Netherlands
http://www.dry-reeds.com
Employee
540 Posts
48 Kudos
Registered: ‎06-07-2010
Post 6 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-07-2011 09:17 AM in reply to: nijpels

It sounds like there are multiple problems.  My suggestion of giving the AutodeskVault user full control of the filestore was based on the errors in the vlog.  Have those gone away?

 

-Dave



Dave Mink
Data Management
Autodesk, Inc.
Contributor
13 Posts
0 Kudos
Registered: ‎05-03-2007
Post 7 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-07-2011 10:42 AM in reply to: minkd

No, till now they didn't go away after giving autodesk user full control. To be sure we also have restarted the server after reinstalling Vault server, but nothing changed.

 

Straingly enough I can copy design a single file, like a idw, iam or ipt, as soon as I select multiple files, as a iam with its ipt's then it goes wrong.

 

There must be something wrong with the installation of 2012, 2011 worked perfectly!

We had to upgrade from SQL2005 to SQL2008 because of 2012 installation, perhaps something went wrong there.

Thimo Nijpels
Comus Technology BV
Netherlands
http://www.dry-reeds.com
Employee
540 Posts
48 Kudos
Registered: ‎06-07-2010
Post 8 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-08-2011 10:09 AM in reply to: nijpels

The errors in the log  show permissions errors in the filestore.  I can't think of anything in an upgrade from SQL 2005 to SQL 2008 that would have any impact on the filestore.

 

The "Impersonation User" needs full access to the filestore (and all the files and folders within it). By default the "Impersonation User Name" is set to "AutodeskVault", but it can be changed in the ADMS-Console (Tools >> Administration >> Advanced Settings Tab >> Advanced configuration settings).  Check to make sure you are giving permissions in the filestore to the correct user.

 

The installer will create the default "Impersonation User" ("AutodeskVault") during a clean install if it does not already exist, but I believe it will use whatever is currently configured during an upgrade.

 

-Dave

 



Dave Mink
Data Management
Autodesk, Inc.
Distinguished Contributor
181 Posts
12 Kudos
Registered: ‎01-23-2008
Post 9 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-08-2011 12:39 PM in reply to: minkd

Hi

 

I have the same problem on a new installation of Vault professional 2012, Full Replication. I notice the same issues as Thimo. i only do not see anything showing in the VLOG timestamped at the time of the error. what I do see are sop exceptions which I believe are unrelated.

 

Copy Design works on single files. Will not work on 2 or more.

 

i have attached our vlog as well

 

Hope you can help :-)

 

 

Thanks,

Jeremy

Contributor
13 Posts
0 Kudos
Registered: ‎05-03-2007
Post 10 of 25

Re: Vault 2012 Copy Design error; Value cannot be null; Parameter name: value

06-09-2011 03:46 AM in reply to: jparks_79

Hi Dave and Jeremy,

 

I've checked and rechecked the permissions for user "autodeskvault" and made sure it has full access to al the folders.

It did not work.

Next I've restarted the server on which Vault Server works to make shure everything works correctly.

Still doesn't work.

 

What I do not understand, is that it is possible to copy design a single file (makes no differents between iam, ipt or idw), but as soon as I want to copy design multiple files it goes wrong.

I also made a totaly new testpart and assembly in a sepperate folder. Checking in and out is no problem, but copy design stays the same error, only once I had one other error (in Dutch):

Exeption of HRESULT

Exeption of HRESULT: 0x80004005 (E_Fail).

 

I tried this new part and assembly also on other computers (Windows XP, Windows 7), but copy design stays the same with the error:

Value cannot be null.jpg

 

Our supplier asked to send him our Vault Backup so if he can find the problem. Over 1 week I have an update trainging at our supplier, so I hope to solve it, but better it would be to have it before!

Thimo Nijpels
Comus Technology BV
Netherlands
http://www.dry-reeds.com
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.