Vault General Discussion

Reply
Contributor
vallourec
Posts: 21
Registered: ‎06-04-2008
Message 1 of 5 (365 Views)

restore failed

365 Views, 4 Replies
07-19-2011 11:46 PM

Hy,

 

I'm trying to restore a vault backup made under the Vault 2011 SP2 on a new server where Vault 2012 is installed.

I have this error message =>

"Restore failed because the backup has products that are not supported by the server"

I'm using Windows 2008 server R2 on the backup server with SQL server 2008 SP1 installed.

Also the restore server is under windows 2008 R2 SP1 with SQL server 2008 SP2.

I don't know why i have this error message because restoring to a newer version of vault is supported.

Do you know where the problem is ?

Do i have to upgrade the old server in vault 2012 before create the backup ?

Thanks for your reply.

 

Bellemere JP

 

Board Manager
ihayesjr
Posts: 564
Registered: ‎02-01-2006
Message 2 of 5 (349 Views)

Re: restore failed

07-20-2011 06:56 AM in reply to: vallourec

Can you supply the ADMS Console log from the server where you are performing the restore?



Irvin Hayes Jr
Product Manager
Autodesk, Inc.

Contributor
vallourec
Posts: 21
Registered: ‎06-04-2008
Message 3 of 5 (345 Views)

Re: restore failed

07-20-2011 07:27 AM in reply to: ihayesjr

See the log file below =>

 

20/07/2011 07:55:12 ==================================================================
20/07/2011 07:55:12 RESTORE PROGRESS: The server console is currently in the process of restoring a backup set. Please wait...
20/07/2011 07:55:12 ==================================================================
20/07/2011 07:55:12 Restore failed because the backup has products that are not supported by the server.
20/07/2011 07:55:12 Connectivity.Application.VaultManager.ServiceException: RestoringUnsupportedProducts [223]  ---> Connectivity.Core.Exceptions.CoreException: RestoringUnsupportedProducts [223]

Server stack trace:
   at Connectivity.Core.Operations.BackupSource..ctor(String backuppath)
   at Connectivity.Core.Services.KnowledgeMasterService.RestoreWithBackup(String restorePath, String toFSLocation, String toDBDataLocation, String toDBLogLocation, Boolean markForMigration, OnProgressDelegate onProgress)
   at System.Runtime.Remoting.Messaging.Message.Dispatch(Object target, Boolean fExecuteInContext)
   at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at Connectivity.Core.Services.KnowledgeMasterService.RestoreWithBackup(String restorePath, String toFSLocation, String toDBDataLocation, String toDBLogLocation, Boolean markForMigration, OnProgressDelegate onProgress)
   at Connectivity.Application.VaultManager.KnowledgeMasterService.RestoreWithBackup(String restorePath, String toFSLocation, String toDBDataLocation, String toDBLogLocation, String user, String pass, OnProgressDelegate onProgress)
   --- End of inner exception stack trace ---
   at Connectivity.Application.VaultManager.ProgressCommand.Execute()
   at Connectivity.Application.VaultManager.RestoreVaultCommand.a(String A_0, Boolean A_1, LoginInfo A_2, String A_3, String A_4)

 

 

Bellemere JP

Board Manager
ihayesjr
Posts: 564
Registered: ‎02-01-2006
Message 4 of 5 (343 Views)

Re: restore failed

07-20-2011 07:51 AM in reply to: vallourec

What edition of Vault 2011 and Vault 2012 do you have?  It looks like your 2011 edition is higher than the 2012 edition.



Irvin Hayes Jr
Product Manager
Autodesk, Inc.

Contributor
vallourec
Posts: 21
Registered: ‎06-04-2008
Message 5 of 5 (307 Views)

Re: restore failed

07-28-2011 11:41 PM in reply to: ihayesjr

Hi and thanks for you reply.

 

You've right ^_^

 

As i haven't receive my DVD yet i  download the Vault 2012 on my subscription page, but i download the vault standard and my backup was made with a pro...

Now i have to call my reseller to understand why it's not the good version on my download page...or just waiting for the DVD

 

Bellemere JP

 

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.