Vault General Discussion

Vault General Discussion

Reply
*Expert Elite*
brendan.henderson
Posts: 337
Registered: ‎07-22-2009
Message 1 of 8 (220 Views)
Accepted Solution

Lag in database 3

220 Views, 7 Replies
07-25-2012 02:27 PM

Can anybody shed some light on why 1 database in particular takes so long to complete the backup? Over the last 6 months it's gone from 1 hour between database 3 & 4 to now being 6-7 hours. The backup is working perfectly, it's just that the Vault backup is not completing before the start of another server tape backup starts, whicj includes the vault server, so sometimes the Vault database is not being included in the tape backup.

 

Capture1.JPG

Brendan Henderson
CAD Manager


New Blog | Old Blog | Google+ | Twitter


Inventor 2014 PDS Premium SP2 Update 2, Vault Professional 2014 Subs Release 1 & Update 1


Please use "Accept as Solution" & give "Kudos" if this response helped you.

Employee
tannro
Posts: 77
Registered: ‎11-13-2006
Message 2 of 8 (209 Views)

Re: Lag in database 3

07-26-2012 06:53 AM in reply to: brendan.henderson

Are you running a SQL maintenance plan?  Details are available in the Advanced Configuration Guide on the Autodesk Vault Wiki http://wikihelp.autodesk.com/Vault/enu/Help/Help/0206-Autodesk206/0264Advanced_Configuration

 

"SQL Maintenance Plans
Maintenance plans can be used to schedule tasks required to make sure that the database
performs well, such as keeping database and transaction log file sizes small and checking the
database for inconsistencies."



Ross Tanner
Autodesk, Inc.


Be sure to check out the Vault Help Wiki!
*Expert Elite*
brendan.henderson
Posts: 337
Registered: ‎07-22-2009
Message 3 of 8 (186 Views)

Re: Lag in database 3

07-31-2012 05:36 PM in reply to: tannro

Thanks Ross.

 

I just heard from the VAR. The SQL Maintenance Plan was setup up. VAR says :-

 

'You cannot do much about the ADMS backup taking this long, all we can do is on server 2008, the scheduled task can be bumped up as a priority and I think it will run faster'

 

They are sending me info on how to do this.

 

Below is the documentation of the Vault install/upgrade :-

 

The following tasks were completed on the current Vault server keoghfs2
1. Updated OS to SP2 which was a minimum requirement of ADMS 2012
2. Un-installed SQL 2008 Express and ADMS 2011
3. Installed SQL 2008 R2 Standard with instance name AUTODESKVAULT. Instance
was installed in D:\Program Files\Microsoft SQL Server
4. Installed ADMS 2012 SP1 + Hotfix (DL18480860)
5. Restored Vault 2011 backup as of 11 May 2012
6. Installed default read only CC libraries
7. Set Up SQL Maintenance Plan
8. Modified Vault backup script to suit 2012

 

 

 

 

Brendan Henderson
CAD Manager


New Blog | Old Blog | Google+ | Twitter


Inventor 2014 PDS Premium SP2 Update 2, Vault Professional 2014 Subs Release 1 & Update 1


Please use "Accept as Solution" & give "Kudos" if this response helped you.

Distinguished Contributor
bstewart
Posts: 115
Registered: ‎09-24-2008
Message 4 of 8 (177 Views)

Re: Lag in database 3

08-01-2012 05:06 AM in reply to: brendan.henderson

Hi Brendan,

 

FWIW, before changing the scheduled task priority from the default 7 to 4, our batch file was taking 10 hours.  After the change, it now takes 2 1/2 hours.

 

Bob

____________________________________________________
Product Design Suite Ultimate 2014 | Vault Basic 2014 (SP2)
Dell Precision M6600 | Intel i7-2820QM - 16GB
nVIDIA Quadro 4000M | Windows 7/64 Pro
*Expert Elite*
karthur1
Posts: 4,331
Registered: ‎04-27-2005
Message 5 of 8 (165 Views)

Re: Lag in database 3

08-01-2012 02:23 PM in reply to: bstewart

How did you change the priority?

Distinguished Contributor
bstewart
Posts: 115
Registered: ‎09-24-2008
Message 6 of 8 (161 Views)

Re: Lag in database 3

08-01-2012 03:02 PM in reply to: karthur1

I followed these instructions.

http://crackingthevault.typepad.com/crackingthevault/2011/05/improving-performance-of-vault-server-b...

 

____________________________________________________
Product Design Suite Ultimate 2014 | Vault Basic 2014 (SP2)
Dell Precision M6600 | Intel i7-2820QM - 16GB
nVIDIA Quadro 4000M | Windows 7/64 Pro
*Expert Elite*
brendan.henderson
Posts: 337
Registered: ‎07-22-2009
Message 7 of 8 (155 Views)

Re: Lag in database 3

08-01-2012 06:49 PM in reply to: bstewart

Thanks Bob.

 

If I take out the time for database 3 then the backup for the other 8 databases would take 16 minutes! See below snippet from the report. I have made the priority change and will see the result (hopefully good) tomorrow morning.

 

1/08/2012 7:03:01 PM Backing Up Databases... 1/9
1/08/2012 7:06:38 PM Backing Up Databases... 2/9
1/08/2012 7:06:39 PM Backing Up Databases... 3/9
2/08/2012 2:05:26 AM Backing Up Databases... 4/9
2/08/2012 2:05:48 AM Backing Up Databases... 5/9
2/08/2012 2:05:49 AM Backing Up Databases... 6/9
2/08/2012 2:05:51 AM Backing Up Databases... 7/9
2/08/2012 2:05:55 AM Backing Up Databases... 8/9
2/08/2012 2:05:58 AM Backing Up Databases... 9/9
2/08/2012 2:16:45 AM The backup operation has been successfully finished.

Brendan Henderson
CAD Manager


New Blog | Old Blog | Google+ | Twitter


Inventor 2014 PDS Premium SP2 Update 2, Vault Professional 2014 Subs Release 1 & Update 1


Please use "Accept as Solution" & give "Kudos" if this response helped you.

*Expert Elite*
brendan.henderson
Posts: 337
Registered: ‎07-22-2009
Message 8 of 8 (147 Views)

Re: Lag in database 3

08-02-2012 02:23 PM in reply to: brendan.henderson

Before the priority increase backup took 7.5 hours :-

 

1/08/2012 6:50:32 PM ==================================================================
1/08/2012 6:50:32 PM Logging initiated: Core server version 16.1.58.120
1/08/2012 6:50:32 PM ==================================================================
1/08/2012 6:50:32 PM
1/08/2012 6:50:32 PM -Obackup -B"D:\VaultBackup\A" -L"D:\VaultBackUp\VaultBackUpLog.txt" -VU[username] -VP[password] -S -DBSC
1/08/2012 6:50:35 PM ==================================================================
1/08/2012 6:50:35 PM BACKUP PROGRESS: The server console is currently in the process of backing up a database set. Please wait...
1/08/2012 6:50:35 PM ==================================================================
1/08/2012 7:00:06 PM Backing Up Databases... 0/9
1/08/2012 7:03:01 PM Backing Up Databases... 1/9
1/08/2012 7:06:38 PM Backing Up Databases... 2/9
1/08/2012 7:06:39 PM Backing Up Databases... 3/9
2/08/2012 2:05:26 AM Backing Up Databases... 4/9
2/08/2012 2:05:48 AM Backing Up Databases... 5/9
2/08/2012 2:05:49 AM Backing Up Databases... 6/9
2/08/2012 2:05:51 AM Backing Up Databases... 7/9
2/08/2012 2:05:55 AM Backing Up Databases... 8/9
2/08/2012 2:05:58 AM Backing Up Databases... 9/9
2/08/2012 2:16:45 AM The backup operation has been successfully finished.
2/08/2012 2:16:46 AM Connectivity.Request.Common.RequestLibrary - RequestRuntimeStop()
2/08/2012 2:16:46 AM Connectivity.Request.Vault.RequestLibrary - RequestRuntimeStop()
2/08/2012 2:16:46 AM Connectivity.Request.Foundation.RequestLibrary - RequestRuntimeStop()
2/08/2012 2:16:46 AM Connectivity.Request.Document.RequestLibrary - RequestRuntimeStop()

 

After the priority increase backup took 2 hours :-

 

2/08/2012 6:07:29 PM ==================================================================
2/08/2012 6:07:29 PM Logging initiated: Core server version 16.1.58.120
2/08/2012 6:07:29 PM ==================================================================
2/08/2012 6:07:29 PM
2/08/2012 6:07:29 PM -Obackup -B"D:\VaultBackup\A" -L"D:\VaultBackUp\VaultBackUpLog.txt" -VU[username] -VP[password] -S -DBSC
2/08/2012 6:07:32 PM ==================================================================
2/08/2012 6:07:32 PM BACKUP PROGRESS: The server console is currently in the process of backing up a database set. Please wait...
2/08/2012 6:07:32 PM ==================================================================
2/08/2012 6:16:54 PM Backing Up Databases... 0/9
2/08/2012 6:20:06 PM Backing Up Databases... 1/9
2/08/2012 6:23:46 PM Backing Up Databases... 2/9
2/08/2012 6:23:47 PM Backing Up Databases... 3/9
2/08/2012 8:05:42 PM Backing Up Databases... 4/9
2/08/2012 8:05:44 PM Backing Up Databases... 5/9
2/08/2012 8:05:45 PM Backing Up Databases... 6/9
2/08/2012 8:05:48 PM Backing Up Databases... 7/9
2/08/2012 8:05:51 PM Backing Up Databases... 8/9
2/08/2012 8:05:52 PM Backing Up Databases... 9/9
2/08/2012 8:12:17 PM The backup operation has been successfully finished.
2/08/2012 8:12:23 PM Connectivity.Request.Common.RequestLibrary - RequestRuntimeStop()
2/08/2012 8:12:23 PM Connectivity.Request.Vault.RequestLibrary - RequestRuntimeStop()
2/08/2012 8:12:23 PM Connectivity.Request.Foundation.RequestLibrary - RequestRuntimeStop()
2/08/2012 8:12:23 PM Connectivity.Request.Document.RequestLibrary - RequestRuntimeStop()

 

Many thanks to Bob and my VAR.

Brendan Henderson
CAD Manager


New Blog | Old Blog | Google+ | Twitter


Inventor 2014 PDS Premium SP2 Update 2, Vault Professional 2014 Subs Release 1 & Update 1


Please use "Accept as Solution" & give "Kudos" if this response helped you.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.