Vault General Discussion

Vault General Discussion

Reply
Contributor
cliff.haynes
Posts: 22
Registered: ‎06-28-2011
Message 1 of 4 (1,406 Views)
Accepted Solution

Error 303 when trying to delete

1406 Views, 3 Replies
07-08-2011 11:39 AM

I am trying to delete some obsolete files while logged in as administrator. I receive the following error:

 

Error 303: You do not have adequate permissions to delete this file.

 

These files have been moved to a 'trash' folder and the links have been broken. I can delete other files that are not obsolete. I have checked the folder permissions and the permissions on the obsolete state, and admin has delete privelages to both. Anything else that could cause me not to be able to delete these files? I really need them gone so I can enforce unique filenames.

 

Details:

logged in as admin

Vault Workgroup 2012

client is running on windows XP 64bit

In Out of Box settings, state security of Obsolete is set to readonly to everyone, you may get the lock icon on the main view for this kind of files.

 

If you want to perform delete operation on files in Obsolete state, you can modify the security setting for obsolete state.

 e.g. remove Everyone from access control list, add  Administrator (user or group) allowto all permission, and other users/Groups readonly permissions.

 

Or, you could check on 'No State-based security' if you want regardless state control for obsoleted file.  Thus every user in Administrator or Document Editor (Level2) role be able to delete it.

 

appendix A- Out of box settting

outofbox.png

 

B - Configure to allow administrator delete.

reset.png

 

Hope it helps.

Active Contributor
Miquel
Posts: 39
Registered: ‎05-24-2007
Message 2 of 4 (1,390 Views)

Re: Error 303 when trying to delete

07-09-2011 12:00 AM in reply to: cliff.haynes

can you delete this file in WIP state? try it.

Employee
yuhui.zhang
Posts: 194
Registered: ‎04-07-2008
Message 3 of 4 (1,377 Views)

Re: Error 303 when trying to delete

07-11-2011 01:37 AM in reply to: cliff.haynes

In Out of Box settings, state security of Obsolete is set to readonly to everyone, you may get the lock icon on the main view for this kind of files.

 

If you want to perform delete operation on files in Obsolete state, you can modify the security setting for obsolete state.

 e.g. remove Everyone from access control list, add  Administrator (user or group) allowto all permission, and other users/Groups readonly permissions.

 

Or, you could check on 'No State-based security' if you want regardless state control for obsoleted file.  Thus every user in Administrator or Document Editor (Level2) role be able to delete it.

 

appendix A- Out of box settting

outofbox.png

 

B - Configure to allow administrator delete.

reset.png

 

Hope it helps.



Fay Zhang
Software QA Engineer
Data Management
Autodesk, Inc.

Be sure to check out the Vault Help Wiki!

Contributor
cliff.haynes
Posts: 22
Registered: ‎06-28-2011
Message 4 of 4 (1,365 Views)

Re: Error 303 when trying to delete

07-11-2011 07:32 AM in reply to: yuhui.zhang

Thanks, this cleared it up. So if Admin group has all access and engineering has no access, then a user of both groups will have no access? That is how it seems after some experimentation.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.