Vault Customization

Reply
Active Contributor
michael.collins2
Posts: 43
Registered: ‎03-30-2012
Message 1 of 4 (232 Views)
Accepted Solution

Error loading extension PropertyPageSample

232 Views, 3 Replies
03-30-2012 05:07 AM

 Hi Doug,

 

I am trying to build the PropertyPageSample app. I am getting the "Error loading extension PropertyPageSample" error on starting Vault.

 

I tried running the Load Tester utility, and it said that it could not find the Autodesk.Connectivity.Extensibility.Framework version 16.0.56.200. I checked my project References and I had that DLL, but it was version 16.1.58.0.

 

I have attached my project if you would be able to look at it.  It is not all wired up yet.

 

Mike

 

It works fine for me.  So far it looks just like the Hello World sample in the SDK.

My guess is that you didn't deploy all the needed DLLs.  Here is what my deployment looks like...

 

C:\ProgramData\Autodesk\Vault 2012\Extensions\PropertyPageSample\

 Autodesk.Connectivity.WebServicesTools.dll

 PropertyPages.dll

 PropertyPageSample.dll

 PropertyPageSample.vcet.config

 

I don't think PropertyPages.dll needs to be there, but it was in your bin\Release folder.

 

Here is an article that explains which DLLs to deploy:  http://justonesandzeros.typepad.com/blog/2011/10/which-sdk-dlls-to-deploy.html

 

 

 

Active Contributor
michael.collins2
Posts: 43
Registered: ‎03-30-2012
Message 2 of 4 (220 Views)

Re: Error loading extension PropertyPageSample

03-30-2012 10:55 AM in reply to: michael.collins2

Update:

 

It turns out that the problem I was seeing was from the Test Loader utility itself, because I was running it from the obj\x86\Release folder.

 

When I run TestLoader from the bin\Release folder, it checks my extension, and reports

 

"Load complete.  No errors found"

 

But when I start Vault, it gives me a window with the the error:

 

"Error loading extension PropertyPageSample"

 

Any ideas?

 

 

 

Employee
Redmond.D
Posts: 812
Registered: ‎12-12-2006
Message 3 of 4 (217 Views)

Re: Error loading extension PropertyPageSample

03-30-2012 12:20 PM in reply to: michael.collins2

It works fine for me.  So far it looks just like the Hello World sample in the SDK.

My guess is that you didn't deploy all the needed DLLs.  Here is what my deployment looks like...

 

C:\ProgramData\Autodesk\Vault 2012\Extensions\PropertyPageSample\

 Autodesk.Connectivity.WebServicesTools.dll

 PropertyPages.dll

 PropertyPageSample.dll

 PropertyPageSample.vcet.config

 

I don't think PropertyPages.dll needs to be there, but it was in your bin\Release folder.

 

Here is an article that explains which DLLs to deploy:  http://justonesandzeros.typepad.com/blog/2011/10/which-sdk-dlls-to-deploy.html

 

 

 



Doug Redmond
Software Engineer
Autodesk, Inc.
http://justonesandzeros.typepad.com/

Active Contributor
michael.collins2
Posts: 43
Registered: ‎03-30-2012
Message 4 of 4 (217 Views)

Re: Error loading extension PropertyPageSample

03-30-2012 12:42 PM in reply to: Redmond.D

That was it.  I was missing a DLL.  Thanks!

 

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.