Discussion Groups

Simulation Mechanical and Multiphysics

Reply
New Member
Magre
Posts: 2
Registered: ‎11-21-2012
Accepted Solution

Unable to apply material in a thermal study

308 Views, 7 Replies
11-21-2012 07:50 AM

When I try to apply a material in a thermal study I get an error message similar to this and cannot  apply any material:

 

Unexpected error

Modification of a ****** thermal element, the isotropic/orthotropic has not been specified

(*translated*, my version is in french...     (sim mechanical 2013))

 

 

No matter what type of element I used, or what type of material model (iso, ortho, iso temp dependent...) I apply in the element definition I always get the same error. Even in a blank study with no geometry in it, when I create a component, select the element type and def,  and try to apply a material I get this message error. This only happens in thermal studies, first time trying to use thermal studies...

 

Seems like the software cannot read the material model from the element definition. I tried reinstalling the software and still get the same message.

Please use plain text.
Valued Mentor
AstroJohnPE
Posts: 506
Registered: ‎08-30-2012

Re: Unable to apply material in a thermal study

11-21-2012 08:31 AM in reply to: Magre

Hi Magre,

 

I agree with your thought: sounds like the software is not able to read the element definition. What happens if you do this test?

 

  1. Define the element type to be brick.
  2. Edit the Element Definition and set the material model to Orthotropic.
  3. Click OK to close the Element Definition.
  4. Edit the Element Definition again. Is the material model set to Ortho?

If it is Isotropic -- the default -- this would support the idea that the software is not able to read the Element Definition. In this case, try saving the model to another folder where you have successfully worked on other models, or save it to a really short folder and filename, such as C:\junk\test.fem. (Everyone needs a junk folder, right?)

 

Also, I see that you have version 2013. Have you installed service pack 1 and/or 2? I do not recall any problems like this that the service pack would have fixed.

 

John Holtz, PE
Mechanical Engineer
Pittsburgh, PA

16 years experience with Simulation Mechanical
Please use plain text.
New Member
Magre
Posts: 2
Registered: ‎11-21-2012

Re: Unable to apply material in a thermal study

11-21-2012 08:47 AM in reply to: AstroJohnPE

Turns out SP2 was not installed, which I tought was the case. Everything seems ok now.

Please use plain text.
New Member
diperna
Posts: 1
Registered: ‎03-28-2013

Re: Unable to apply material in a thermal study

03-29-2013 05:12 AM in reply to: AstroJohnPE

Hi, i have the problem with my installation.

My study i steady state heat transfer.

When i edit material, the library give me an message that the material is not isotrop.

Would you like to help me.

Thanks

Please use plain text.
Contributor
Ju_brl
Posts: 13
Registered: ‎04-08-2013

Re: Unable to apply material in a thermal study

07-08-2013 08:50 AM in reply to: diperna

Hi there,

I got the same error and I'm stuck with it.

 

I installed the SP2 but it doesn't change anything. What can we do ?

 

Regards.

Please use plain text.
Valued Mentor
AstroJohnPE
Posts: 506
Registered: ‎08-30-2012

Re: Unable to apply material in a thermal study

07-08-2013 10:35 AM in reply to: Ju_brl

The first thing I would try is to edit the Element Definition and click the OK button. Can you enter the material properties now?

 

Next, you could try the tests in my last post and let us know what the results are.

 

Another option is to install the latest version of the software, which is 2014 or maybe 2014 Service Pack 1.

John Holtz, PE
Mechanical Engineer
Pittsburgh, PA

16 years experience with Simulation Mechanical
Please use plain text.
Contributor
Ju_brl
Posts: 13
Registered: ‎04-08-2013

Re: Unable to apply material in a thermal study

07-09-2013 12:05 AM in reply to: AstroJohnPE

I tried this and your recommandations in your previous post and it works.
I mean the changes I make in the element properties seem to be saved.

But it's impossible to set the material properties, I always have the same error than the author.

Please use plain text.
Valued Mentor
AstroJohnPE
Posts: 506
Registered: ‎08-30-2012

Re: Unable to apply material in a thermal study

07-11-2013 10:26 AM in reply to: Ju_brl

Ju,

 

Since this discussion was marked as "solved", some people may not be reading it. I suggest that you start a new thread for your problem. Be sure to include:

  1. The version of the software ("Getting Started > Help > About", provide the build number and date)
  2. What element type you are using
  3. What material model is used in the Element Definition (be sure to click the OK button when you close the dialog)
  4. What the precise error message is when you enter the material and when it occurs.
  5. The name of the model
  6. The complete path where the model is stored (C:\.....\........\........\........etc)

 

John Holtz, PE
Mechanical Engineer
Pittsburgh, PA

16 years experience with Simulation Mechanical
Please use plain text.