Discussion Groups

Simulation CFD

Active Contributor
Posts: 47
Registered: ‎03-25-2010

FEA mapping help

267 Views, 2 Replies
07-09-2012 01:17 PM

I am currently trying to export a FEA Mapping to a .unv file that was created with Simulation Multiphysics. Basically I took the Autodesk Inventor and imported it into Multiphysics. I then applied pressure values to the inside of my valve where the fluid contacts it. I then exported the file into a .unv file format. I then ran a simulation in CFD and tried to export the FEA mapping onto the .unv file. (side note: I suppressed all the solids when running the CFD simulation, not sure if this matters). However, I coudn't find the "_newbcs" file that CFD had made. (side note: whenever I pressed the "Map results to BC" button nothing visible happens). However, I noticed that whenever I click the button there is a quick spike in CPU usage. However, I don't think this really means anything.


I also tried playing around with the different flags in CFD with no help. However, I did find that the unv_mesh_flag did work and it exported the file to the root C:/ directory. This could explain why exporting anything through the applications menu gives the error:

Unable to export requested data

Check the following:

1. File permissions and folder privileges

2. Disk space

3. Make sure the file is not in use by another process


Disc space is fine and it is not 3 becuase all programs were closed except CFD. I changed the security of the C:\ directory but it didn't do anything (What I did: gave Everyone full access to the C:\ directory).


Anyways, that was kinda a tangent. I looked in the C:\ directory (along with the folder that contains the CFD senario) and I cound't find the _newbcs file.


Wait, theres more! I checked the Status File in CFD and noticed that the unv_mesh_flag had called 1 thingy (probably a function) from Line 180 of source\cfd_unvmesh.c. However, the unv_out_flag had called 0 functions from "Line -1 of   " (which means that it never called a function).


I have also tried this and couldn't find the .int file. I have also read that Multiphysics does not support FSI. I might be missinterpreting it but I thought that meant that you counld not directly export FEA information from CFD to Multiphysics. So what I am trying to do is a workaround by exporting it into different file formats (If this is not what Fluid-Structure Interation means then please explain why this doesn't work.) So I'm basically out ideas on how to make this work.


Extra Information:

Autodesk Inventor 2013

Autodesk Simulation Multiphysics 2013

Autodesk Simulation CFD 2013

Windows 7 Professional 64bit


Thanks for reading.

Please use plain text.
New Member
Posts: 1
Registered: ‎10-13-2012

Re: FEA mapping help

10-13-2012 05:50 AM in reply to: whiteskulleton

Interesting....I just had the same thing happen to me today!


The FEA Mapping works...I"ve done it in the past.  However, this time, I'm getting the exact same response.  I hit the Map results to BC and see a little blip of activity and nothing more.


I check file paths etc...but nothing seems amis.


What is a drag is that there is no error checking or messages to let the user know what has failed.  


Ohh well --


My feeling is that it is just one of those things - a small bug.  I have a request into technical support to see what is what. I really miss the old days when one could just call up the CFdesign folks and get an answer.  It might not be what you wanted to hear but it was quick, fast and efficient.  Now we deal with the godzilla.


When I hear of a solution - I'll let you know.





P.S.  CFD 2013

Win 7 64 bit

working with a Femap neu file


Please use plain text.
Valued Contributor
Posts: 92
Registered: ‎01-18-2006

Re: FEA mapping help

12-09-2013 12:41 PM in reply to: whiteskulleton

Did this ever get solved?  I am experiencing the same thing (with the .inp format)  - I hit Map Results to BC and nothing happens.


Is it a permissions issue? 

Please use plain text.