Discussion Groups

Simulation CFD

Reply
Active Member
aoliver-
Posts: 6
Registered: ‎05-05-2011
Accepted Solution

CFD User Interface very slow

582 Views, 7 Replies
09-11-2012 01:54 AM

Hi,

 

I have just started using CFL 2013 and found it to be very slow with my model.  My machine specs aren't phenomenal, but are certainly capable (dual core, 3GHz, 8GB RAM, W7 x64, ATI HD2400), and have no problems in inventor (with the same model).  RAM usage goes to about 4.5GB when it's loaded (unmeshed), so there shoudl be plenty of juice on hand...

 

Simple things like panning the camera are very slow to respond, and creating surfaces to cap the inner volume takes about 2 minutes for each circular surface.  

 

Are there any settings that might improve speed?  I have had a look in the options but there's nothing relating to rendering etc, perhaps this is a registry setting?  At the moment it's very unproductive.

 

Cheers,

Aaron

Please use plain text.
Product Support
wildej
Posts: 757
Registered: ‎08-25-2011

Re: CFD very slow

09-11-2012 07:40 AM in reply to: aoliver-

You could first try checking that your graphics driver is up to date. Secondly, try these flags:

 

glsl 0

use_dropshadow 1

software_rendering 0



Jon Wilde
Please use plain text.
Valued Contributor
Cnoj
Posts: 93
Registered: ‎11-26-2008

Re: CFD very slow

02-18-2013 05:52 PM in reply to: wildej
How do you set the flags?
Please use plain text.
Product Support
wildej
Posts: 757
Registered: ‎08-25-2011

Re: CFD very slow

02-19-2013 02:23 AM in reply to: Cnoj

Hi,

 

Check out the help but the basics are, go to Setup -> Design Study Tools -> Flags and then simply search for them in the Default Flag Settings and Apply



Jon Wilde
Please use plain text.
Valued Contributor
Cnoj
Posts: 93
Registered: ‎11-26-2008

Re: CFD very slow

02-19-2013 08:02 AM in reply to: wildej

OK all those flags were already set.

 

I seem to have a similar problem to the OP. This is a 64 bit 16-core Xeon workstation with 40GB Ram and Quadro 6000 GPU.

 

Display is sluggish, sometimes around 1fps in transparent mode while in 'setup tasks'. Once I solve, the performance becomes unuseable, with a 5 or 10 second delay on every mouse click. If i reboot then open a design study that's been solved and go to results in the design study bar I get the same 10 second delays on everything. Switching back to Setup tasks (eg. hitting Materials in design study bar) brings me back up to 1fps.

 

I've noticed XP Task Manager shows page file useage to pretty much match memory useage of SimCFD.exe. Is that normal? This machine has only 20gig free on its main HD and system managed page file is currently at 45gig.

 

Should I be looking to the HD/page file for a solution or does this sound like a graphics/display issue? (new quadro drivers installed btw).

 

Thanks for any suggestions,

 

Jon C.

 

Please use plain text.
Product Support
wildej
Posts: 757
Registered: ‎08-25-2011

Re: CFD very slow

02-20-2013 07:33 AM in reply to: Cnoj

Hi guys,

 

Have you tried going to the website of your graphics card manufacturer and downloading the latest drivers? FYI, checking from the interface does not always find that there is a newer version, has to be done directly through their sites(s).



Jon Wilde
Please use plain text.
Valued Contributor
Cnoj
Posts: 93
Registered: ‎11-26-2008

Re: CFD very slow

02-20-2013 07:56 AM in reply to: wildej

I updated Quadro 6000 drivers to V311.15, released 2/11/13.

No Change in performance.

 

Please use plain text.
Product Support
Royce_adsk
Posts: 588
Registered: ‎08-24-2011

Re: CFD very slow

02-25-2013 01:46 PM in reply to: Cnoj

The eventual solution for this user was to change the nVidia driver profile from 'Base Profile' to '3D App - Visual Simulation'.

 

None of the described flags were needed.

 

-Royce



Royce Abel
Please use plain text.