Revit MEP

Reply
Distinguished Contributor
Mehdi.Kardehi
Posts: 132
Registered: ‎01-20-2014
Message 1 of 7 (264 Views)
Accepted Solution

pattern override using filters

264 Views, 6 Replies
03-04-2014 11:30 PM

A stupid question...

 

This thing wasted couple of hours of my time today...

I am trying to use filter overrides to change the look of my ducts with different lining

 

The steps I take

 

- draw a duct

- VG

- untick the visibility of lining

- I go to filters

- define a new one that applies to ducts and duct fittings and filters by lining thickness equals to 25 mm for example

- I override the patern with the one I want

- I draw a duct and add 25 mm lining to it but nothing happens

 

 

I was successful doing this by defining a new project parameter as duct lining and manually entering that value equal to 25mm for every piece of duct. This ways sounds very stupid as it is not connected to the Revit lining thickness.

 

Please help...I know this should be very easy to do!

 

Cheers,

M

I have submitted this issue to Autodesk Support, and the following response was recieved:

 


Autodesk Support wrote:

 

Thank you for choosing Autodesk Support.
I understand when setting up a View Filter to change the fill pattern for Duct with a Lining Thickness equal to 25mm, you are finding that the View Filter is not applied until the Lining Thickness is changed to 25mm (after the Lining is applied to the Duct).

Thank you for the sample file. I have been able to reproduce what you are seeing and I have logged this with our developers.

In looking at this issue, it looks like the View Filter is evaluating the Duct Lining as less than 25mm, as the View Filter works when set to Less than or equal to 25mm.

To work around this issue, set the View Filter to show for Less than or equal to 25mm and greater than 24.999mm. This should make the filter only apply to the elements you want.

Best regards,

[Name withheld]
Autodesk Support Team




Distinguished Contributor
Mehdi.Kardehi
Posts: 132
Registered: ‎01-20-2014
Message 2 of 7 (257 Views)

Re: pattern override using filters

03-04-2014 11:42 PM in reply to: Mehdi.Kardehi

Now things getting worst....

 

forget about my second solution....I followed the same steps and made another filter for 50 mm insulation

 

suprisingly that works perfect!!!

It just doesnt work for 25 mm thickness!!

 

If I select 50 mm lining for my duct and then change it to 25mm then it works for 25 mm as well!!!

 

Is this a bug? 

*Expert Elite*
CADastrophe
Posts: 3,421
Registered: ‎08-28-2009
Message 3 of 7 (221 Views)

Re: pattern override using filters

03-05-2014 06:39 AM in reply to: Mehdi.Kardehi

I am unable to replicate this problem, would you be able to post a small sample Project file?

Corey D.                                                                                                                  ADSK_Logo_EE_2013.png    AutoCAD 2014 User  Revit 2014 User
──────────────────────────────────────────────────────────────────────
⁞|⁞ Please use Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos as appropriate to further enhance these forums. Thank you!
Distinguished Contributor
Mehdi.Kardehi
Posts: 132
Registered: ‎01-20-2014
Message 4 of 7 (208 Views)

Re: pattern override using filters

03-05-2014 05:47 PM in reply to: CADastrophe

Please see attached.

 

you can't see the lining on this duct shown but if you edit the lining change the thickness from 25 to 30 and then back to 25 then you can see it!

*Expert Elite*
CADastrophe
Posts: 3,421
Registered: ‎08-28-2009
Message 5 of 7 (193 Views)

Re: pattern override using filters

03-06-2014 09:01 AM in reply to: Mehdi.Kardehi

This is kind of strange, but this seems to occur only when I first apply the 25mm Lining (by clicking on the Duct, Add Lining, and accepting the default value). The problem seemed to correct itself if I either...

 

a.) When entering the default thickness for the Lining, I deleted it and retyped 25mm.

 -or-

b.) After adding it, I selected the Lining and under Properties, changed it to any other value (i.e. 26mm) and back to 25mm.

Corey D.                                                                                                                  ADSK_Logo_EE_2013.png    AutoCAD 2014 User  Revit 2014 User
──────────────────────────────────────────────────────────────────────
⁞|⁞ Please use Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos as appropriate to further enhance these forums. Thank you!
Distinguished Contributor
Mehdi.Kardehi
Posts: 132
Registered: ‎01-20-2014
Message 6 of 7 (185 Views)

Re: pattern override using filters

03-06-2014 04:58 PM in reply to: CADastrophe

 

Thanks Corey...So I wasn't the only one seeing this....a software bug then

 

Would any one be able to open a case for this as I am not a subscription member? In a big project this can be very confusing

*Expert Elite*
CADastrophe
Posts: 3,421
Registered: ‎08-28-2009
Message 7 of 7 (161 Views)

Re: pattern override using filters

03-12-2014 08:48 PM in reply to: Mehdi.Kardehi

I have submitted this issue to Autodesk Support, and the following response was recieved:

 


Autodesk Support wrote:

 

Thank you for choosing Autodesk Support.
I understand when setting up a View Filter to change the fill pattern for Duct with a Lining Thickness equal to 25mm, you are finding that the View Filter is not applied until the Lining Thickness is changed to 25mm (after the Lining is applied to the Duct).

Thank you for the sample file. I have been able to reproduce what you are seeing and I have logged this with our developers.

In looking at this issue, it looks like the View Filter is evaluating the Duct Lining as less than 25mm, as the View Filter works when set to Less than or equal to 25mm.

To work around this issue, set the View Filter to show for Less than or equal to 25mm and greater than 24.999mm. This should make the filter only apply to the elements you want.

Best regards,

[Name withheld]
Autodesk Support Team




Corey D.                                                                                                                  ADSK_Logo_EE_2013.png    AutoCAD 2014 User  Revit 2014 User
──────────────────────────────────────────────────────────────────────
⁞|⁞ Please use Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos as appropriate to further enhance these forums. Thank you!
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.