Revit Architecture

Posts: 4
Registered: ‎08-06-2010
Message 1 of 7 (3,186 Views)

Revit Structure 2011 Error Message...?

3186 Views, 6 Replies
08-06-2010 06:00 AM

Hey, I was wondering if anyone has had the same error message when using Revit 2011, it was working fine until a couple of days ago and then every time I open up a Project it appears to load it but then stops and a message pops up saying "Encountered an improper argument". This is a real pain as I can't open up anything apart from a new project.


I even tried to be cheeky and open up a new project and load in a family i was trying to develop and open it up through the new project (which worked! :smileyhappy:) but when i tried to save it came up with the same message, I tried again to save and Revit told me that a fatal error had occurred and needed to close giving me the option to save a recovery (which it won't let me do either!?!?! :smileymad:)


If anyone has had this before and knows a get around please let me know as I can't exactly use Revit 2010 to open up anything either! How silly is that?



Posts: 341
Registered: ‎05-28-2010
Message 2 of 7 (3,161 Views)

Re: Revit Structure 2011 Error Message...?

08-09-2010 10:33 AM in reply to: amoeba_720

"Encountered an improper argument" is actually a Microsoft error message, so you might want to try checking out the Microsoft forums for any updates or patches necessary.


Please let us know what you find out!

Jillian Bejtlich
Forum Community Manager
Autodesk, Inc.
Posts: 4
Registered: ‎08-06-2010
Message 3 of 7 (3,150 Views)

Re: Revit Structure 2011 Error Message...?

08-10-2010 01:31 AM in reply to: Jillian.Bejtlich
Ah, Microsoft eh? I am not all too surprised! Haha! Weird thing is that none of the other guys in our drafting pool have had this problem even though we are all using the same machine, I wonder whether this has been sabotaged by one of those pesky Microsoft updates as they have already been a pain in more than one place! Haha! Thanks for the advice though, I will certainly quiz Microsoft about it and see what they suggest. If I find a fix I will definately post it on this thread! Cheers Jillian!
Posts: 4
Registered: ‎08-06-2010
Message 4 of 7 (3,121 Views)

Re: Revit Structure 2011 Error Message...?

08-13-2010 01:47 AM in reply to: amoeba_720
Alright, turns out it was something to do with Microsoft updates, our I.T. guy did a complete Microsoft Update on my machine and reinstalled revit with all the latest service packs and it seems to work now, he was a little unsure what the initial problem was to begin with though! Anyway, this seems to work so smiley faces all around! Cheers!
New Member
Posts: 2
Registered: ‎01-20-2011
Message 5 of 7 (2,667 Views)

Re: Revit Structure 2011 Error Message...?

01-20-2011 04:52 PM in reply to: amoeba_720

I encountered this same error while working In revit architecture 2011. Turns out if you pull the tool bars off the ribbion along with moving the project browser and properties dialog out of the revit window onto to another monitor, this error occurs.


Found I had to pull the "Encountered an improper argument" window over to the other monitor(out of the Model view), close it and close the Project browser, the Properties Dialog, and all the tool bars.

Once that was done I had to avoid the drawing/model space, hover the cusor over to the Windows 7  taskbar and close the Revit program window from there. This allows the revit profile to restart as its defualt.


I don't believe this is a Windows error. Seems more like poor scripting Autodesk...:smileytongue:

New Member
Posts: 2
Registered: ‎06-20-2008
Message 6 of 7 (2,129 Views)

Re: Revit Structure 2011 Error Message...?

06-13-2011 11:04 AM in reply to: amoeba_720

Is there a way to manually reset the profile?

New Member
Posts: 1
Registered: ‎11-07-2012
Message 7 of 7 (1,177 Views)

Re: Revit Structure 2011 Error Message...?

11-07-2012 06:31 AM in reply to: amoeba_720

I have found a workaround for this..


Find your "Revit.ini" file; located in C:\Users\<your name>\AppData\Roaming\Autodesk\Revit\Autodesk Revit Architecture 2012\.. (the last folder obivously specific to your install version).


Make sure Revit is closed and delete this file.


When you restart Revit, the profile will be reset and should work good as new!!


(I think the actual issue has something to do with the 'Recent Files' memory, so by deleting this file it erases the recent file list and all goes back to normal)

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!