Revit Architecture

Reply
Contributor
Ricardo-Maturana
Posts: 12
Registered: ‎11-16-2012
Message 1 of 6 (1,483 Views)
Accepted Solution

REVIT Server 2013

1483 Views, 5 Replies
12-05-2012 11:05 AM

We have set up Revit 2013 and it works fine for creating folders and subfolders.  I followed the Autodesk process step by step on creating a new file in the revit server.  Everything is fine, but when I hit save an error message appears saying that the file cannot be saved.  When I log into revitserver i see the new file, but I cannot delete, lock it, or use it at all.

 

Any thoughts on how we can lock the files to be able to delete from the revit server?

 

Thank you.

 

As a side note:

Unless Autodesk is planning on getting rid of revit server they should really invest into the documentation and troubleshooting.

You should be able to delete the file in the Revit Server Admin console.

 

If not, you can log on to the Central Server, and delete it there. ( the folder containing the .rvt file, which reads as only 1Kb file size.)

*Expert Elite*
ccollins
Posts: 866
Registered: ‎09-28-2009
Message 2 of 6 (1,469 Views)

Re: REVIT Server 2013

12-05-2012 01:10 PM in reply to: Ricardo-Maturana

You should be able to delete the file in the Revit Server Admin console.

 

If not, you can log on to the Central Server, and delete it there. ( the folder containing the .rvt file, which reads as only 1Kb file size.)

Cliff B. Collins
Registered Architect/BIM Manager
Thalden Boyd Emery Architects
St. Louis, MO
Contributor
Ricardo-Maturana
Posts: 12
Registered: ‎11-16-2012
Message 3 of 6 (1,433 Views)

Re: REVIT Server 2013

12-07-2012 10:21 AM in reply to: ccollins

This is the error that I am getting.  Everything seems to be working fine except when trying to save or open a file from the workstation.  

We are using REVIT 2013 and microsoft server2012

 

 

0:<   System.ServiceModel.FaultException`1[Autodesk.Revit.RS.Common.ClientServer.DataContract.Model.ModelFault]: Arithmetic operation resulted in an overflow.

 ' 0:< RevitServerException caught in constructor of ModelResolvableLocation: WCF Generic Fault Exception. Data or permissions for the model could be in an inconsistent state. Please contact technical support.

 

 

 

Contributor
rwebb0418
Posts: 11
Registered: ‎03-21-2012
Message 4 of 6 (1,109 Views)

Re: REVIT Server 2013

04-10-2013 04:49 PM in reply to: Ricardo-Maturana

Ricardo,

 

I have a similar setup Server 2012, running Revit Server 2013, and I'm haveing the same problem opening or saving models.  I get a slightly differnt error though.

 

2013-04-10 16:42:19,504 ERROR TID(11) LOGGER(Autodesk.Revit.RS.Service.Protected.Model.ModelServiceImplementation) MSG(BlockError: System.OverflowException: Arithmetic operation resulted in an overflow.
at System.Data.SQLite.SQLite3.GetBytes(SQLiteStatement stmt, Int32 index, Int32 nDataOffset, Byte[] bDest, Int32 nStart, Int32 nLength)
at System.Data.SQLite.SQLite3.GetValue(SQLiteStatement stmt, Int32 index, SQLiteType typ)
at Autodesk.Revit.RS.Core.Model.ModelStorage.ModelLocationSQLiteDbTable.parseOneRecord(SQLiteDataReader dataReader)
at Autodesk.Revit.RS.Core.Model.ModelStorage.ModelLocationSQLiteDbTable.readRecord(ModelIdentity modelIdentity)
at Autodesk.Revit.RS.Core.Model.ModelStorage.ModelStorageProvider.locateModel(ModelIdentity modelIdentity)
at Autodesk.Revit.RS.Service.Protected.Model.ModelServiceImplementation.LocateModel(ModelIdentity modelIdentity)
at Autodesk.Revit.RS.Service.Protected.Model.ModelServiceImplementation.CreatePermissions(ServiceModelSessionToken sessionToken, PermissionsFormatVersion permissionFormatVersion)
at IModelServiceProxyd68ce8001e454bb6a8a801c5f0a957b4.InvocationCreatePermissions_34.InvokeMethodOnTarget()
at Autodesk.Social.Core.Implementation.Logging.LoggingInterceptor.Intercept(IInvocation invocation))
2013-04-10 16:42:19,505 INFO TID(11) LOGGER(Autodesk.Revit.RS.Service.Protected.Model.ModelServiceImplementation) MSG(BlockEnd: Autodesk.Revit.RS.Service.Protected.Model.ModelServiceImplementation.CreatePermissions)

 

I'm hoping your solution will somehow point me in the right direction.

it
New Member
it
Posts: 1
Registered: ‎04-17-2011
Message 5 of 6 (375 Views)

Re: REVIT Server 2013

03-05-2014 07:57 PM in reply to: rwebb0418

Did either one of you guys find a solution to this?

 

I am still having problems saving a model to the server, with the log throwing the exact same error.

 

Edit: Also, your SOLVED tag is not a solution! 

Contributor
rwebb0418
Posts: 11
Registered: ‎03-21-2012
Message 6 of 6 (358 Views)

Re: REVIT Server 2013

03-06-2014 08:44 AM in reply to: Ricardo-Maturana

The only solution I had was to install RS2013 on a Windows Server 2008 box.  I couldn't get it to run on Server 2012.  

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!