Revit Architecture

Revit Architecture

Reply
Active Contributor
wouterbleumink
Posts: 43
Registered: ‎08-19-2009
Message 1 of 9 (4,036 Views)
Accepted Solution

Revit Server 2012 - cannot get in administration page

4036 Views, 8 Replies
07-18-2011 02:15 AM

Hi all,

 

I am trying to setup a revit server. I went trough the steps for installing the software and configuring IIS (twice), but when i try to log in the server i get an error stating that the Revit Server Administrator is not available.

 

I tried to retrace every step i made and to verrify that everything is correctly installed. Installed Revit server 2012 SP1...

 

Please help (i attached the log's for additional info)

Hi,

 

I think i found the awnser..

 

We created a new VM with a clean install of Windows Server 2008 R2 SP1, and installed the Revit Server by the book.

 

Apperently, on the Windows server under Roles the ASP.NET state service is set to manual and was not in a running state. When i ran it i was able to login to the Revit Server Administrator and connect to it from a workstation.

 

Regards,

 

Wouter

Employee
ryan.duell
Posts: 734
Registered: ‎06-01-2010
Message 2 of 9 (4,031 Views)

Re: Revit Server 2012 - cannot get in administration page

07-18-2011 05:54 AM in reply to: wouterbleumink

I would verify the following areas on the Revit Server \ Client Workstation:


1.  RevitServerAppPool and Autosync Service are Up and Running


[A]  Open Internet Information Services Manager [Start > Run > INETMGR].  Expand Server name > highlight Application Pools > highlight RevitServerAppPool.  Verify Status reads Started; if not click Start.


[B]  Open Administrative Tools > Services [Start > Run > Services.msc].  Locate Revit Server AutoSync.  Verify Status reads Started.  If not right-click > Start.


2.  Connect to Central or Local?


If you have both a central and local server, test connecting to the alternate server to see if the results

for Revit Server Administrator are the same.

 

3.  Firewall Settings


Verify the firewall setting on the client workstation and Revit Central server.  Ensure there are no additional third-party firewall applications running.  For the Windows Firewall ensure there is an exception for File & Printer Sharing.  Ensure the user has not previously blocked ports 80 and 808.  Port 80 is the http port for Revit Server Administrator.  Port 808 is used for TCP communication for all data and permissions traffic between client workstations and Revit Server[s].  Verify these ports or ranges are open as needed.

 

4. IIS


On the Revit Server > Internet Information Services (IIS) Manager > Server name > Sites > Service Name > Content View > can the user right-click on an .SVC file [for example AdminService.svc] > Browse?  

 

The results should appear similar to the image below:

 

threadPIC.png

 

 Thank you,



Ryan Duell
Autodesk, Inc.

Revit Clinic
@revitclinic


Active Contributor
wouterbleumink
Posts: 43
Registered: ‎08-19-2009
Message 3 of 9 (4,023 Views)

Re: Revit Server 2012 - cannot get in administration page

07-18-2011 06:39 AM in reply to: ryan.duell

Ryan,

 

Thank you for responding. I tried your suggestions with the following results:

 

1A. Verified that RevitServerAppPool Is running

1B. Verified that the sync service is running

 

2 Currently we only have a central server set up. I read that Revit users can directly connect to the central server.

 

3. I allready found the File- and Printer sharing note on the support-pages. I verified that all three columns are ticked in the firewall. We only use windows firewall on that server (dedicated for Revit)

 

4. I am able to open the file you mentioned. I looks like yours so i assume it is OK.

 

Further info:

The server is a new VM running Windows server 2008 R2 SP1, dedicated for Revit server (test-purposes).

We installed Revit server 2012 (and SP1). configured the server and users as per the wiki documentation and the info found on the revit clinic site.

We are able to gain acces to the server from any workstation using Windows Explorer.

We are able to Ping the server.

We are not able to connect Revit Architecture to the Revit server (not by IP adress nor by Server Name)

We are not able to get in to the administration page of the Revit server (not from the Windows Server it is running on, nor from any workstation).. allways getting the error that 'The Revit Server Administrator is not available'

 

Thanks in advance for any further info you might have.

 

Regards, Wouter

Active Contributor
wouterbleumink
Posts: 43
Registered: ‎08-19-2009
Message 4 of 9 (4,002 Views)

Re: Revit Server 2012 - cannot get in administration page

07-19-2011 01:26 AM in reply to: ryan.duell

Hi,

 

I think i found the awnser..

 

We created a new VM with a clean install of Windows Server 2008 R2 SP1, and installed the Revit Server by the book.

 

Apperently, on the Windows server under Roles the ASP.NET state service is set to manual and was not in a running state. When i ran it i was able to login to the Revit Server Administrator and connect to it from a workstation.

 

Regards,

 

Wouter

New Member
glallier
Posts: 2
Registered: ‎04-29-2008
Message 5 of 9 (3,846 Views)

Re: Revit Server 2012 - cannot get in administration page

08-24-2011 11:55 AM in reply to: wouterbleumink

Get the same problem but your solution is not working for me.

Contributor
robertlevy5725
Posts: 19
Registered: ‎02-04-2008
Message 6 of 9 (3,564 Views)

Re: Revit Server 2012 - cannot get in administration page

11-11-2011 11:35 AM in reply to: wouterbleumink

What does VM mean?

 

I have followed all the instructions and even enabled the asp net and I cannot get to the revit server admin page.

Contributor
robertlevy5725
Posts: 19
Registered: ‎02-04-2008
Message 7 of 9 (3,562 Views)

Re: Revit Server 2012 - cannot get in administration page

11-11-2011 12:45 PM in reply to: robertlevy5725

I am having the same problem. I checked all these settings the only one that was not very clear was the part about the svc file on the post above.

Member
frank.pepping
Posts: 6
Registered: ‎08-10-2011
Message 8 of 9 (3,428 Views)

Re: Revit Server 2012 - cannot get in administration page

12-09-2011 05:22 AM in reply to: wouterbleumink

If you get the following code after you opened "AdminService.svc"

 

Server Error in '/RevitServerAdminService' Application. -------------------------------------------------------------------------------- Could not load file or assembly 'System.Data.SQLite, Version=1.0.60.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. An attempt was made to load a program with an incorrect format. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.BadImageFormatException: Could not load file or assembly 'System.Data.SQLite, Version=1.0.60.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. An attempt was made to load a program with an incorrect format. Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. Stack Trace: [BadImageFormatException: Could not load file or assembly 'System.Data.SQLite, Version=1.0.60.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. An attempt was made to load a program with an incorrect format.] System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0 System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +43 System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +127 System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +142 System.Reflection.Assembly.Load(String assemblyString) +28 System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +46 [ConfigurationErrorsException: Could not load file or assembly 'System.Data.SQLite, Version=1.0.60.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. An attempt was made to load a program with an incorrect format.] System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +613 System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +203 System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +105 System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +178 System.Web.Compilation.WebDirectoryBatchCompiler..ctor(VirtualDirectory vdir) +163 System.Web.Compilation.BuildManager.BatchCompileWebDirectoryInternal(VirtualDirectory vdir, Boolean ignoreErrors) +53 System.Web.Compilation.BuildManager.BatchCompileWebDirectory(VirtualDirectory vdir, VirtualPath virtualDir, Boolean ignoreErrors) +175 System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath) +86 System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +261 System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +101 System.Web.Compilation.BuildManager.GetVPathBuildResult(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +83 System.Web.Compilation.BuildManager.GetCompiledCustomString(String virtualPath) +27 System.ServiceModel.HostingManager.GetCompiledCustomString(String normalizedVirtualPath) +134 System.ServiceModel.HostingManager.CreateService(String normalizedVirtualPath) +25 System.ServiceModel.HostingManager.ActivateService(String normalizedVirtualPath) +42 System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) +479 [ServiceActivationException: The service '/RevitServerAdminService/AdminService.svc' cannot be activated due to an exception during compilation. The exception message is: Could not load file or assembly 'System.Data.SQLite, Version=1.0.60.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. An attempt was made to load a program with an incorrect format..] System.ServiceModel.AsyncResult.End(IAsyncResult result) +11655726 System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +194 System.ServiceModel.Activation.HostedHttpRequestAsyncResult.ExecuteSynchronous(HttpApplication context, Boolean flowContext) +176 System.ServiceModel.Activation.HttpModule.ProcessRequest(Object sender, EventArgs e) +275 System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +68 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75 

The problem could be found in de binnary's of Revit Server, named  "System.Data.SQLite.DLL"

after downloading and extractiong the attachment, copy/paste the "System.Data.SQLite.DLL" and overwrite every instance of "System.Data.SQLite.DLL" in the installation directory of Revit Server.

 

This was the solution for me on three Revit Servers.

New Member
Puddlebiker
Posts: 2
Registered: ‎02-08-2012
Message 9 of 9 (604 Views)

Re: Revit Server 2012 - cannot get in administration page

03-21-2014 09:55 PM in reply to: ryan.duell

I am having the same problem

 

1.

RevitServerAppPool2014 running and restarted

Revit Server Autosync running and restarted

 

2.

No other server

 

3.

Firewall settings port 80 and 808 open and file and print sharing allowed

 

4.

RevitServerAdminRESTService2014>AdminService.svc>Browse ***Does not work*** (Is this the problem? How do I fix it?)

 

5.

Replaced all System.Data.SQLite.DLL files as above. (kept backups of originals)

 

Anyone have some advice?

 

Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.