Revit Architecture

Revit Architecture

Reply
Distinguished Contributor
damo3
Posts: 353
Registered: ‎04-08-2008
Message 1 of 3 (270 Views)
Accepted Solution

Revit Newbie - Filter not appying within In-Place family

270 Views, 2 Replies
01-21-2013 04:47 PM

Hi All, 

 

It is normal behaviour for Revit not to apply a filter to a family within an in-place family?

 

For example: 

 

I have an in-place family, with an extruded custom component and I have also inserted a family component (lets call this FAMILY 1, simply an extrusion previously created). 

My filters finds the family name "FAMILY 1" and applies a cut colour I have selected under visibility graphics.

 

I have the same component family "FAMILY 1" inserted in the floor plan, next to my in-place family. (NOT nested) I know the filter works because it applies itself to "FAMILY 1", but the same "FAMILY 1" nested in the in-place family, does not pick up the cut filter properties.

 

Categories are the same.

 

Normal, or I am I missing something? If normal, any suggested work arounds? 

 

Thanks in advance for any assistance.

It is normal when the family that is inserted in the Model in-place object is not shared; that is why when you finish the in-place, that "family 1" cannot be detected by the filter. For this to work as you were expecting, "family 1" needs to be set as "shared" in the family editor, and then loaded back into the project. Since you are new to Revit, this might sound a little confusing for you, but that's how Revit works.

*Expert Elite*
Alfredo_Medina
Posts: 2,821
Registered: ‎06-11-2009
Message 2 of 3 (239 Views)

Re: Revit Newbie - Filter not appying within In-Place family

02-01-2013 07:13 AM in reply to: damo3

It is normal when the family that is inserted in the Model in-place object is not shared; that is why when you finish the in-place, that "family 1" cannot be detected by the filter. For this to work as you were expecting, "family 1" needs to be set as "shared" in the family editor, and then loaded back into the project. Since you are new to Revit, this might sound a little confusing for you, but that's how Revit works.

-----------------------------------------------------------------------------------------------------------------
Planta1 Revit Online Consulting | info@planta1.com | my Twitter | The Planta1 Blog
Distinguished Contributor
damo3
Posts: 353
Registered: ‎04-08-2008
Message 3 of 3 (216 Views)

Re: Revit Newbie - Filter not appying within In-Place family

02-03-2013 01:54 PM in reply to: damo3

Thanks Alfredo, I since found the solution to this ( I should of come back and posted the answer) but what you have explained is spot on. 

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.