Revit Architecture

Reply
*Matt Dillon
Message 11 of 13 (140 Views)

Re: Revit can't count?

07-17-2004 07:56 AM in reply to: *Matt Dillon
I'm familiar with both and as well as the filter tool. and I considered, but found it more... call it - reassuring ... to hide the objects I was not wanting to copy, since there were a lot of objects that I did want to copy, and a lot of objects that I didn't want to copy. It seemed at the time that using would have been tedious (not that hiding wasn't ). Re-thinking my process, I should have done it all from an elevation view and it would have been simple. (Had I known that copying from a 3D view like that was going to cause problems, I probably would have). The filter tool really wasn't an option since it only allows you to filter by category, right? If so, in this case it wouldn't have done me much good. -- Matt Dillon "matthew jezyk [autodesk]" wrote in message news:40f92270$1_2@newsprd01... > Ok, > > Glad to know it helped. I'm not quite sure what you are trying to achieve in > your second paragraph. Sounds like you are using Temp Hide/Isolate as an > easy way to 'pre-filter' before you actually select the stuff you want to > copy or group? Do you know about box select and using CTRL and SHIFT to > add/remove from the selection set? Also the Filter command (the funnel > button in the option bar) is very useful. > > You lost me when you started mentioning hiding the group.... > > matt jezyk > autodesk revit > > > > "Matt Dillon" wrote in message > news:40f7d568$1_3@newsprd01... > > Matt, > > > > I think that's got it. I was doing the large copy (that messed up) from a > 3D > > view because it was easier for me to hide the spanning components that I > > didn't want to copy. The other copies that went the way I would have > > expected were done in either a plan or elevation view. > > > > So... would the correct approach have been to maybe use the 3D view to > place > > all of the spanning components in a group, then go to a 2D view and hide > the > > group, and THEN do the copy? Following that, I would guess I'd unhide the > > group and break it up into it's individual objects again? > > > > Thanks > > -- > > Matt Dillon > > > > "matthew jezyk [autodesk]" wrote in > > message news:40f7c64f_3@newsprd01... > > > Matt, > > > > > > Try the exact same thing you did initially but instead of copying to the > > > clipboard from a 3d view, keep the 2d floor plan view as the active > view. > > > Copy from Level 2 plan view to the clipboard then go to the Level 3 plan > > and > > > Paste Aligned|Current View. Does that work for you? > > > > > > The best way to describe the difference between copying from a 2d view > vs > > a > > > 3d view is it's like Copy-Paste vs Copy with Basepoint in autocad (well, > > > roughly). It's a matter of what is your known copy point. When you copy > to > > > the clipboard, revit tries to figure out where the base references are > for > > > the selected objects. It sounds like what is happening in your case is > it > > is > > > using a lower base reference than it should (like Level 1, say) even > > though > > > you know that you selected a bunch of stuff that is really associated > with > > > Level 2. Then when you paste, the new objects end up being too far up in > > > space, right? This is why trying the same operation from a 2d plan view > > > should work better - the plan view knows which level it's associated > with > > so > > > when you copy, that level will be used as the ref. There are other > options > > > in Paste Aligned that allow you paste typical floors all the way up the > > > building (Paste Aligned|Select Levels by Name and Pick Level Graphics.) > > > > > > Another way to do this is using the Copy command and not Copy-Paste at > all > > > (ahh, just like acad now - this is very much like Copy-Paste vs Copy > with > > > Basepoint in autocad). Try selecting your objects in whatever view you > > want > > > and then go to an elevation or section. With the objects still seleted, > > hit > > > the Copy button on the toolbar (not ctrl-c) and make sure to uncheck the > > > Constrain option. You should end up with a picture that looks like the > > > attached screenshot. Now you are in a mode were you can precisely copy > > from > > > one point to another and (when using unconstrian) and references will be > > > remapped like they are in regular copy-paste. Using Copy/unconstrain in > > > elevation/section is a pretty useful option. > > > > > > Hopefully this makes sense, > > > > > > matt jezyk > > > autodesk revit > > > > > > > > > > > > > > > > > > "Matt Dillon" wrote in message > > > news:40f6f21d$1_3@newsprd01... > > > > Additional Note... > > > > > > > > It seems to have something to do with the amount of objects that I had > > > > selected (only thing I can think of anyway). > > > > > > > > I had to go back and select windows/doors, etc. that were embedded in > > the > > > > spanning walls, and since I selected those in much smaller groupings, > > > > apparently, the copy/paste aligned seemed to work correctly. > > > > > > > > -- > > > > Matt Dillon > > > > > > > > > > > > "Matt Dillon" wrote in message > > > > news:40f6f043$1_1@newsprd01... > > > > > I am working on a multi-level model with four true levels, a parapet > > > > "level" > > > > > and a roof level. The 2nd level is a typical floor, so I developed > my > > > > > typical plan on that floor plan view. There are also several > > > load-bearing > > > > > and exterior walls that span multiple floors. > > > > > > > > > > Once I got the typical floor plan laid out, I went to a 3D view and > > hid > > > > all > > > > > of the elements that span multiple levels. Next I selected the > > elements > > > > > making up my 2nd floor and copied them to the clipboard. Then I > > selected > > > > > Paste Aligned, with the Pick Views option. I selected Level 1 to > copy > > > to, > > > > > and the elements copied to Level 3. OK... so what happens if I > choose > > to > > > > > copy them to Level 3? They go to Level Roof. It's like they're > copying > > > to > > > > > the 2nd level above whereever I try to send them. Is this because > > > they're > > > > > coming from Level 2 originally? That doesn't make any sense at > all... > > > > > > > > > > OK... I have a 13 year old, so I can deal with twisted logic. I > > created > > > a > > > > > couple of "Bogus" levels that were below my 1st floor and did the > > Paste > > > > > Aligned to the lowest of these. Bingo - everything got copied to the > > 1st > > > > > floor. > > > > > > > > > > Checking the properties of any of these elements shows them > > referencing > > > > > Level 1 and not "Bogus 1" or "Bogus 2". > > > > > > > > > > Is this "normal"? > > > > > > > > > > -- > > > > > Matt Dillon > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > >
*Irwin Jungreis
Message 12 of 13 (140 Views)

Re: Revit can't count?

07-19-2004 12:05 PM in reply to: *Matt Dillon
Note that you can change views _after_ selecting objects, and they stay selected. The base point for Copy to Clipboard is determined based on which view is active when you invoke the command, not the view in which you selected the objects. So, it would work fine if you use the technique you were using to select the objects in the 3D view, then switch to the plan view, then Copy to Clipboard. You can select in whatever view is most convenient for doing the selection. Here's some explanation of why things are working as they are. It seems intuitive that: 1) Copying objects and then pasting them without changing view in between should put the pasted objects at the same height as the originals. 2) Copying objects in one plan view and pasting them in another should change the height of the objects by the difference between the two level heights. 3) Pasted objects should get the same height regardless of what view you copied from. Unfortunately, these three behaviors are mutually incompatible! Consider, for example, a wall that goes from level 1 to level 3. Select it in level 2 plan and paste in level 2 plan and that shouldn't move it. Select it in level 1 plan and paste it in level 2 plan and it should move up to level 2. So, the end result must depend on which view you copied from. We've chosen to give up (3) in order to keep (1) and (2). Revit used various heuristics to select a height for a base point based on the selected objects and the view that is active at the time of Copy to Clipboard. Then, at Paste time it positions this point on the level of the view into which it is pasted. In this case, it sounds like Revit is not choosing the base point height very intelligently. (I suspect that it is including the lowest point of any wall that includes a selected door or window.) Something that has been considered is showing the base point graphically after the Copy to Clipboard command is invoked and letting the user move it around. Would that make things easier to understand? "Matt Dillon" wrote in message news:40f93e25$1_2@newsprd01... > I'm familiar with both and as well as the filter tool. > and I considered, but found it more... call it - reassuring ... to > hide the objects I was not wanting to copy, since there were a lot of > objects that I did want to copy, and a lot of objects that I didn't want to > copy. It seemed at the time that using would have been tedious > (not that hiding wasn't ). Re-thinking my process, I should have done it > all from an elevation view and it would have been simple. (Had I known that > copying from a 3D view like that was going to cause problems, I probably > would have). > > The filter tool really wasn't an option since it only allows you to filter > by category, right? If so, in this case it wouldn't have done me much good. > > -- > Matt Dillon > > > "matthew jezyk [autodesk]" wrote in > message news:40f92270$1_2@newsprd01... > > Ok, > > > > Glad to know it helped. I'm not quite sure what you are trying to achieve > in > > your second paragraph. Sounds like you are using Temp Hide/Isolate as an > > easy way to 'pre-filter' before you actually select the stuff you want to > > copy or group? Do you know about box select and using CTRL and SHIFT to > > add/remove from the selection set? Also the Filter command (the funnel > > button in the option bar) is very useful. > > > > You lost me when you started mentioning hiding the group.... > > > > matt jezyk > > autodesk revit > > > > > > > > "Matt Dillon" wrote in message > > news:40f7d568$1_3@newsprd01... > > > Matt, > > > > > > I think that's got it. I was doing the large copy (that messed up) from > a > > 3D > > > view because it was easier for me to hide the spanning components that > I > > > didn't want to copy. The other copies that went the way I would have > > > expected were done in either a plan or elevation view. > > > > > > So... would the correct approach have been to maybe use the 3D view to > > place > > > all of the spanning components in a group, then go to a 2D view and hide > > the > > > group, and THEN do the copy? Following that, I would guess I'd unhide > the > > > group and break it up into it's individual objects again? > > > > > > Thanks > > > -- > > > Matt Dillon > > > > > > "matthew jezyk [autodesk]" wrote in > > > message news:40f7c64f_3@newsprd01... > > > > Matt, > > > > > > > > Try the exact same thing you did initially but instead of copying to > the > > > > clipboard from a 3d view, keep the 2d floor plan view as the active > > view. > > > > Copy from Level 2 plan view to the clipboard then go to the Level 3 > plan > > > and > > > > Paste Aligned|Current View. Does that work for you? > > > > > > > > The best way to describe the difference between copying from a 2d view > > vs > > > a > > > > 3d view is it's like Copy-Paste vs Copy with Basepoint in autocad > (well, > > > > roughly). It's a matter of what is your known copy point. When you > copy > > to > > > > the clipboard, revit tries to figure out where the base references are > > for > > > > the selected objects. It sounds like what is happening in your case is > > it > > > is > > > > using a lower base reference than it should (like Level 1, say) even > > > though > > > > you know that you selected a bunch of stuff that is really associated > > with > > > > Level 2. Then when you paste, the new objects end up being too far up > in > > > > space, right? This is why trying the same operation from a 2d plan > view > > > > should work better - the plan view knows which level it's associated > > with > > > so > > > > when you copy, that level will be used as the ref. There are other > > options > > > > in Paste Aligned that allow you paste typical floors all the way up > the > > > > building (Paste Aligned|Select Levels by Name and Pick Level > Graphics.) > > > > > > > > Another way to do this is using the Copy command and not Copy-Paste at > > all > > > > (ahh, just like acad now - this is very much like Copy-Paste vs Copy > > with > > > > Basepoint in autocad). Try selecting your objects in whatever view you > > > want > > > > and then go to an elevation or section. With the objects still > seleted, > > > hit > > > > the Copy button on the toolbar (not ctrl-c) and make sure to uncheck > the > > > > Constrain option. You should end up with a picture that looks like the > > > > attached screenshot. Now you are in a mode were you can precisely copy > > > from > > > > one point to another and (when using unconstrian) and references will > be > > > > remapped like they are in regular copy-paste. Using Copy/unconstrain > in > > > > elevation/section is a pretty useful option. > > > > > > > > Hopefully this makes sense, > > > > > > > > matt jezyk > > > > autodesk revit > > > > > > > > > > > > > > > > > > > > > > > > "Matt Dillon" wrote in message > > > > news:40f6f21d$1_3@newsprd01... > > > > > Additional Note... > > > > > > > > > > It seems to have something to do with the amount of objects that I > had > > > > > selected (only thing I can think of anyway). > > > > > > > > > > I had to go back and select windows/doors, etc. that were embedded > in > > > the > > > > > spanning walls, and since I selected those in much smaller > groupings, > > > > > apparently, the copy/paste aligned seemed to work correctly. > > > > > > > > > > -- > > > > > Matt Dillon > > > > > > > > > > > > > > > "Matt Dillon" wrote in message > > > > > news:40f6f043$1_1@newsprd01... > > > > > > I am working on a multi-level model with four true levels, a > parapet > > > > > "level" > > > > > > and a roof level. The 2nd level is a typical floor, so I developed > > my > > > > > > typical plan on that floor plan view. There are also several > > > > load-bearing > > > > > > and exterior walls that span multiple floors. > > > > > > > > > > > > Once I got the typical floor plan laid out, I went to a 3D view > and > > > hid > > > > > all > > > > > > of the elements that span multiple levels. Next I selected the > > > elements > > > > > > making up my 2nd floor and copied them to the clipboard. Then I > > > selected > > > > > > Paste Aligned, with the Pick Views option. I selected Level 1 to > > copy > > > > to, > > > > > > and the elements copied to Level 3. OK... so what happens if I > > choose > > > to > > > > > > copy them to Level 3? They go to Level Roof. It's like they're > > copying > > > > to > > > > > > the 2nd level above whereever I try to send them. Is this because > > > > they're > > > > > > coming from Level 2 originally? That doesn't make any sense at > > all... > > > > > > > > > > > > OK... I have a 13 year old, so I can deal with twisted logic. I > > > created > > > > a > > > > > > couple of "Bogus" levels that were below my 1st floor and did the > > > Paste > > > > > > Aligned to the lowest of these. Bingo - everything got copied to > the > > > 1st > > > > > > floor. > > > > > > > > > > > > Checking the properties of any of these elements shows them > > > referencing > > > > > > Level 1 and not "Bogus 1" or "Bogus 2". > > > > > > > > > > > > Is this "normal"? > > > > > > > > > > > > -- > > > > > > Matt Dillon > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > >
*Matt Dillon
Message 13 of 13 (140 Views)

Re: Revit can't count?

07-21-2004 07:49 PM in reply to: *Matt Dillon
That would be nice. Thanks, -- Matt Dillon > Something that has been considered is showing the base point graphically > after the Copy to Clipboard command is invoked and letting the user move it > around. Would that make things easier to understand? >
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.