Printing and Plotting

Printing and Plotting

20 Posts
0 Kudos
Registered: ‎06-03-2008
Post 1 of 7

CTB settings are not applied in certain drawings.

463 Views, 6 Replies
02-06-2009 10:19 AM
I have come upon a unique situation, we have a drawing that is not recognizing the settings of our plot styles. The CTBs show up fine in the plot style list, and on other drawings they work fine. However in this particular drawing the settings just won't apply... Using our standard ctb other drawings will plot black and white with the proper line thicknesses and such but this particular drawing won't.

Before you ask, YES the plot with pot styles box is checked and the CTB does NOT say missing next to it. everything in the plot dialog appears EXACTLY the same as with the drawings that are plotting correctly. In both cases the drawings were started with our standard template and in both cases the settings seem to be identical with the same CTB being used.

Any thoughts? Is there a drawing dependent setting I am missing? I have 15 years of AutoCAD experience and have not run across this issue.

We are running:

AIS 2008 w/MDT 2008
Windows XP Pro 32 bit
Intel(R) Pentium(R) Dual CPU E6750 @ 2.66GHz
3.00 GB of RAM
250 GB HD w/200 GB free space
Nvidia QuadroFX 1500
AutoCAD certified driver (6.14.0011.6939)
Running in D3D (OpenGL caused even more crashes)
*Expert Elite*
1,741 Posts
76 Kudos
Registered: ‎12-11-2003
Post 2 of 7

Re: CTB settings are not applied in certain drawings.

02-06-2009 12:29 PM in reply to: SCJeffro
Are the errant drawings plotting in color, or in black and white with just just the wrong line thicknesses?
Line thicknesses can be set several ways which will overide the CTB settings.
1. Polylines with a thickness set.
2. Check the properties palette and make sure lineweights are not set to a number there.
20 Posts
0 Kudos
Registered: ‎06-03-2008
Post 3 of 7

Re: CTB settings are not applied in certain drawings.

02-06-2009 12:34 PM in reply to: SCJeffro
The Drawing is plotting in color, the CTB however is set up to plot Black and White. (All the pens are set to pen 7) also like I mentioned it works fine in other drawings.
Distinguished Contributor
218 Posts
0 Kudos
Registered: ‎02-16-2009
Post 4 of 7

Re: CTB settings are not applied in certain drawings.

03-10-2009 07:39 AM in reply to: SCJeffro
Your descriptions seem to fit my problems.

One of our drafters has the same issue, all seams to be in place the correct .ctb file selected, the correct line thickness, the plot with plot styles option checked. Prints all is okay exits the system restarts and whalah the incorrect .ctb file pops up even though we made efforts not to forget to apply our changes.

Now it’s gotten worse its correct .ctb seems to be showing but its just printing black and white rather than colour and the line thickness is also too thick.

Any ideas to what might be happing here?

New Member
2 Posts
0 Kudos
Registered: ‎04-27-2007
Post 5 of 7

Re: CTB settings are not applied in certain drawings.

04-30-2009 02:22 AM in reply to: SCJeffro
Truth be told, I had the same darn problem and I did the same thing and checked everything. What was strange was that my other drawings were plotting just fine with the CTB plot style and the line thickness was just fine as well. On a particular drawing, it seemed that no matter what I tried, the drawing would only plot Black and White with no line thickness although all settings match my other drawings. Even the check boxes were correct under the Plot Options.

Anyway, a long story short is that I think it is a bug in AutoCAD and Civil 3D. My solution that did work was to type PLOT at the command line and then remove ALL check boxes under the plot options and plotted the drawing. I plotted to a PDF file to save paper. Then, I typed PLOT again at the command line and provided the checkboxes I wanted being "Plot with plot styles" and "Plot Paperspace Last". You will notice that a check should appear by the "Plot object lineweights" but is grayed out, which is OK. Then plot your drawing and in my case everything was working just fine.

I hope this helps. I had this problem on 3 drawings out of hundreds of others. In each of the 3 drawings, the above solution worked just fine.

John R. Hamlton, P.E.
President / Principal Civil Engineer
Hamilton Civil Engineers
Las Vegas, Nevada
Distinguished Contributor
194 Posts
3 Kudos
Registered: ‎01-21-2009
Post 6 of 7

Re: CTB settings are not applied in certain drawings.

05-07-2009 07:56 AM in reply to: SCJeffro
I would check your viewports VISUAL STYLE to make sure it hasn't been changed to "realistic" or "3d solid" or anything else along those lines.
Im having this problem now with a drawing set that I incorporated a true 3D elevation of an edit suite we are building, it uses 3d solids on some devices and it caused my viewports visual style to change. Make sure its either set to "shade plot as displayed" or "2D wireframe". This will allow the CTB settings to work correctly. Autodesk should really have some contigency options for stuff like this, like give you options on how it handles 3d solids in a wireframe visual style.
Active Contributor
39 Posts
0 Kudos
Registered: ‎12-18-2008
Post 7 of 7

Re: CTB settings are not applied in certain drawings.

05-08-2009 12:24 AM in reply to: SCJeffro
I'm doing document management, I load CTB into a AutoDWG DWG to PDF converter and generate PDFs. You can get a try with is and see is there is some thing error with the print style. Otherwise, you may copy your CTB and try on other your colleagues' computers, if still with no success, reset.......LOLolo...

Wips, here is the converter: Edited by: EdenAQ on May 8, 2009 7:25 AM
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!