Pointing Devices and Displays

Pointing Devices and Displays

Reply
Contributor
Slater9X
Posts: 24
Registered: ‎04-15-2009
Message 1 of 9 (717 Views)

How do you disable the Legacy puck buttons in the CUI?

717 Views, 8 Replies
05-03-2010 09:28 AM
I have my tablet turned off. In options under the System tab, I have current pointing device set to "Current System Point Device". I am using Tablet Works driver 7.46.0619. My puck buttons are defined in the Tablet Works control panel. Yet, for some reason, when I am in a command and I try to use the "Right Click" on my puck instead of being "Right Click" it transitions to the defined command for the Legacy Puck Buttons in the CUI menu. I do not understand??
Does anyone know the macro for "Right Click" or how to turn off the button assignments under Legacy in the CUI?

Any help is appreciated.

FYI, I am using Autocad 2009 with windows XP.

Slater
*Jason Piercey
Message 2 of 9 (717 Views)

Re: How do you disable the Legacy puck buttons in the CUI?

05-03-2010 12:50 PM in reply to: Slater9X
Why do you have them defined in the Tablet Works control panel?
Mine are defined in the CUI. When switching to "current system
pointing device" button assignments from the CUI are not used.



wrote in message news:6384751@discussion.autodesk.com...
I have my tablet turned off. In options under the System tab, I have current pointing device set to "Current System Point Device". I
am using Tablet Works driver 7.46.0619. My puck buttons are defined in the Tablet Works control panel. Yet, for some reason, when I
am in a command and I try to use the "Right Click" on my puck instead of being "Right Click" it transitions to the defined command
for the Legacy Puck Buttons in the CUI menu. I do not understand??
Does anyone know the macro for "Right Click" or how to turn off the button assignments under Legacy in the CUI?

Any help is appreciated.

FYI, I am using Autocad 2009 with windows XP.

Slater
Contributor
Slater9X
Posts: 24
Registered: ‎04-15-2009
Message 3 of 9 (717 Views)

Re: How do you disable the Legacy puck buttons in the CUI?

05-03-2010 01:18 PM in reply to: Slater9X
I have them defined in the tablet works control panel because it is an older version that is still compatible with Autocad, thus eliminating the need to pay $75.00 dollars for the new driver.
I agree with the second part of your post, "When switching to current system pointing device button assignments from the CUI are not used."
But as I pointed out, the CUI button assignments are still being used. It does not make sense....
*Jason Piercey
Message 4 of 9 (717 Views)

Re: How do you disable the Legacy puck buttons in the CUI?

05-03-2010 01:48 PM in reply to: Slater9X
I am using a similar driver and do not define them in the
control panel, only in the CUI.

My question remains, why define them in the control panel?
Are you saying the driver you are using does not allow them
to be functional when defined only in the CUI?

If I understand correctly, you have them defined twice. Once
in the CP and once in the CUI? If so, I suspect the definitions
in the CP is to blame not the CUI definitions.

wrote in message news:6384901@discussion.autodesk.com...
I have them defined in the tablet works control panel because it is an older version that is still compatible with Autocad, thus
eliminating the need to pay $75.00 dollars for the new driver.
I agree with the second part of your post, "When switching to current system pointing device button assignments from the CUI are not
used."
But as I pointed out, the CUI button assignments are still being used. It does not make sense....
*Joel
Message 5 of 9 (717 Views)

Re: How do you disable the Legacy puck buttons in the CUI?

05-03-2010 01:53 PM in reply to: Slater9X
But, even in the CUI, that button should be "right-click" also.

What does it actually do when you "right-click" during a command? I don't
understand what "it transitions to the defined command for the Legacy Puck
Buttons in the CUI menu" means. What is that "defined command"? And why is
it not just the "right-click" anyway?

Are you actually using the second button as your right-click?

Attached is how my buttons are mapped to the 16 button puck. Button 1 is
not defined because that's hard-coded as the pick button, button 2 thru 10
are the default assignments from the Acad.CUI (had to be added into the
ACA.CUI because it didn't have anything for the buttons). Buttons 11 thru
16 are my own assignments. Button 2 is highlighted and the macro on the
right side is how Acad defines the function of the "right-click"

You may have to check your Mouse Buttons in the CUI. For mine, the mouse
buttons are also defined with 10 buttons, and they match the first 10 of the
tablet button section. Including the "grip menu" macro for button 2. That
may be the conflict.

Also check in "Options" > "User Preferences" tab > "Windows Standard
Behavior" section > Make sure "Shortcut menus in drawing area" is on and the
"Right-click Customization" button will be clickable. Click it. In there,
make sure "Shortcut Menu" is on especially for "Edit Mode" and "Command
Mode".

Good luck.
Contributor
Slater9X
Posts: 24
Registered: ‎04-15-2009
Message 6 of 9 (717 Views)

Re: How do you disable the Legacy puck buttons in the CUI?

05-03-2010 02:03 PM in reply to: Slater9X
I defined them in the control panel because, at the time, I was not familiar with Macros for the associated commands. Also, when I tried using my driver with the tablet turned on in Autocad, things got wacky....
Since then I have aquired the associated Macros so I thought I would try loading them into the CUI. However, once again, when I turned the tablet on and redefined my menu area things got wacky...

Can you confirm what driver you are using? Apparently, when used with the purchased driver, everything runs seamless. So I am told.

Anyways, for the time being, I wanted to go back to just using the control panel with the tabletworks driver. The only drawback is that Autocad does not recognize the redefined menu area.

But my frustation is a result of not being able to deactivate the buttons in the CUI.

I hope that makes sense....
*Jason Piercey
Message 7 of 9 (717 Views)

Re: How do you disable the Legacy puck buttons in the CUI?

05-03-2010 02:03 PM in reply to: Slater9X
FWIW,

My mouse buttons are blank. I've only defined button assignments
via CUI > Legacy > Tablet Buttons > Click. My second button is
defined as a macro for setting a top view current. I vaguley recall
I had to define something when CUI first came out but the defintion
of button 2 is ignored and a right click is issued.


"Joel" wrote in message news:6384970@discussion.autodesk.com...

You may have to check your Mouse Buttons in the CUI. For mine, the mouse
buttons are also defined with 10 buttons, and they match the first 10 of the
tablet button section. Including the "grip menu" macro for button 2. That
may be the conflict.
Contributor
Slater9X
Posts: 24
Registered: ‎04-15-2009
Message 8 of 9 (717 Views)

Re: How do you disable the Legacy puck buttons in the CUI?

05-03-2010 02:16 PM in reply to: Slater9X
Thanks Joel. I will give your advice a try and let you know how it goes.

The "right pick" issue was in regards to using it transparently to access the "from" option on the short cut menu. For some "unknown" reason that is when Autocad would use the button definitions in the CUI and not my presets in the control panel of the tablet works driver, this despite having my current pointing device set to "Current System Pointing Device" not Digitizer or Digitizer and mouse. I hope that makes sense.

I appreciate all your guys help. To be continued....

Thank You,

Slater
*Jason Piercey
Message 9 of 9 (717 Views)

Re: How do you disable the Legacy puck buttons in the CUI?

05-03-2010 02:23 PM in reply to: Slater9X
wrote in message news:6384977@discussion.autodesk.com...
> I defined them in the control panel because, at the time, I was not
> familiar with Macros for the associated commands. Also, when I
> tried using my driver with the tablet turned on in Autocad, things got wacky....

> Since then I have aquired the associated Macros so I thought I would
> try loading them into the CUI. However, once again, when I turned
> the tablet on and redefined my menu area things got wacky...

I guess you'll have to define what you mean by "wacky".


> Can you confirm what driver you are using? Apparently, when used
> with the purchased driver, everything runs seamless. So I am told.

7.42.0820


> Anyways, for the time being, I wanted to go back to just using the
> control panel with the tabletworks driver.

Why?


> The only drawback is that Autocad does not recognize the redefined menu area.

On my system it appears that after switching from "current system pointing
device" to "wintab" in AutoCAD you have to redefine the area. AutoCAD
evidently does not remember/store that information.


> But my frustation is a result of not being able to deactivate the buttons in the CUI.

As far as I can tell, there should be no reason to do this.

Try removing the definitions from the CP and only define them in the CUI.
Does it work?
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.