ObjectARX

ObjectARX

Reply
Contributor
ExtraLine
Posts: 11
Registered: ‎03-31-2010
Message 1 of 7 (1,030 Views)

Wrong custom rollover tooltip in AutoCAD 2012 !

1030 Views, 6 Replies
06-02-2011 01:44 AM

I have a problem with custom rollover tooltips AutoCAD 2012.

The same code, and same executable (ARX) is working well with AutoCAD 2010 and AutoCAD 2011.

 

When mouse is over some custom entity, I want to display some custom tooltip.

When mouse is over the custom entity, program regularly enters in monitorInputPoint function, custom tooltip string is properly initialized and set, but instead of displaying that custom tooltip string - AutoCAD 2012 displays some generic tooltip, containing DXF name, Color, Layer and Linetype ???? 

 

This ARX was made using ObjectARX 2010 and works on AutoCAD 2010 and 2011 - properly.



Is this a bug in AutoCAD 2012, or something is altered intentionaly ? 

 



ADN Support Specialist
fenton.webb
Posts: 352
Registered: ‎07-24-2007
Message 2 of 7 (997 Views)

Re: Wrong custom rollover tooltip in AutoCAD 2012 !

06-06-2011 07:59 AM in reply to: ExtraLine

Sorry, but this is an issue in AutoCAD 2012, and all verticals. We are currently looking into the issue, it should be fixed soon.

 

Fenton Webb

Autodesk Developer Network

 

 





Fenton Webb

Developer Technical Services

Autodesk Developer Network


Member
rbrekken
Posts: 3
Registered: ‎07-07-2010
Message 3 of 7 (891 Views)

Re: Wrong custom rollover tooltip in AutoCAD 2012 !

10-17-2011 05:32 AM in reply to: ExtraLine

Hi,

 

What's the status on this issue? I have the same problem, but an a regular LINE entity and with Autocad Map 3D 2012. It works ok in Autocad Civil 3D 2012 and it works kind of in Autocad 2012 (looks ugly together with original tooltip text). But it do not work at all with Autocad Map 3D 2012 (monitorInputPoint() gets called, but additional tooltip string is not appended)

 

I have attached some screenshots of the tooltip (additional tooltip text is in Norwegian...).

 

Regards,

Roar Brekken

ADN Support Specialist
fenton.webb
Posts: 352
Registered: ‎07-24-2007
Message 4 of 7 (877 Views)

Re: Wrong custom rollover tooltip in AutoCAD 2012 !

10-17-2011 08:55 AM in reply to: rbrekken

We've released AutoCAD 2012 sp1 to address the problem. http://bit.ly/qYEa3k

 

Fenton Webb

Autodesk Developer Network





Fenton Webb

Developer Technical Services

Autodesk Developer Network


Member
rbrekken
Posts: 3
Registered: ‎07-07-2010
Message 5 of 7 (871 Views)

Re: Wrong custom rollover tooltip in AutoCAD 2012 !

10-17-2011 11:48 AM in reply to: fenton.webb

Very strange, because I currently have SP1 for Autocad 2012 (assuming you mean 2012 and not 2013) installed, and I still have this problem. Product version: F.107.0.0. Autocad 2012 - English SP1

 

And what about Autocad Map 3D 2012? Most users having this particular problem are using Map 3D 2012.

 

Regards,

Roar Brekken

Member
hvtuong
Posts: 3
Registered: ‎04-10-2012
Message 6 of 7 (616 Views)

Re: Wrong custom rollover tooltip in AutoCAD 2012 !

04-10-2012 09:08 PM in reply to: fenton.webb

Hi,

 

How is the status of this issue? I also got this :smileyfrustrated: (I use ObjectARX 2010 with AutoCAD 2012)

 

Is this fixed in AutoCAD 2013? Has anyone try with AutoCAD 2013?

Will this be fixed if I change use ObjectARX 2012 for AutoCAD 2012?

 

Thanks,

Tuong Hoang

ADN Support Specialist
fenton.webb
Posts: 352
Registered: ‎07-24-2007
Message 7 of 7 (582 Views)

Re: Wrong custom rollover tooltip in AutoCAD 2012 !

04-11-2012 09:46 AM in reply to: fenton.webb

Sorry, I meant 2012...





Fenton Webb

Developer Technical Services

Autodesk Developer Network


Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.