ObjectARX

Reply
Active Member
latoge
Posts: 10
Registered: ‎03-09-2012
Message 1 of 3 (149 Views)

Migration from 2013 to 2014

149 Views, 2 Replies
10-10-2013 05:46 AM

Hi,
I get this error message when I try to run one of my tool (made for Civil 3D 2013) in Civil 3D 2014 :
System.MissingMethodException: Method missing : 'Void Autodesk.AECC.Interop.UiLand.IAeccApplication.Init(Autodesk.AutoCAD.Interop.AcadApplication)'.

Here are the reference I have in my project, all from ObjectARX 2013 :
Autodesk.AEC.Interop.Base
Autodesk.AEC.Interop.UIBase
Autodesk.AEC.Interop.Land
Autodesk.AEC.Interop.UILand
Autodesk.AEC.Interop
Autodesk.AEC.Interop.Common

I am using Visual Studio 2010, .Net Framework 4.   I tried to change ObjectARX 2013 for ObjectARX 2014 but I just found Autodesk.AEC.Interop, not the other ?

It's my first migration and I'm not use with ObjectARX so I don't know what I need to do. 

 

Distinguished Mentor
owenwengerd
Posts: 626
Registered: ‎08-06-2002
Message 2 of 3 (142 Views)

Re: Migration from 2013 to 2014

10-10-2013 07:46 AM in reply to: latoge

The ObjectARX API is C/C++. It looks like you are using the Managed .NET API. You should post in the .NET group where you're more likely to get help.

--
Owen Wengerd
ManuSoft
Active Member
latoge
Posts: 10
Registered: ‎03-09-2012
Message 3 of 3 (130 Views)

Re: Migration from 2013 to 2014

10-10-2013 10:36 AM in reply to: owenwengerd

Done thanks.  How can this post can be delete ?

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.