ObjectARX

Reply
Contributor
oliver253m
Posts: 16
Registered: ‎07-25-2012
Message 1 of 2 (212 Views)

AcPublish.arx needs to be loaded before acplPublishExecute

212 Views, 1 Replies
10-01-2012 02:30 PM

Greetings,

 

I ran into a small issue and didn't find any mention of it in the documentation or the forum, so I hope this helps someone.

 

If you call the acplPublishExecute() function without having used the PUBLISH command, publishing will fail with an empty error in the log.

 

It appears that the PUBLISH command will load the AcPublish.arx module as needed, but acplPublishExecute() will not, so make sure to load it yourself.

ADN Support Specialist
philippe.leefsma
Posts: 631
Registered: ‎06-02-2009
Message 2 of 2 (108 Views)

Re: AcPublish.arx needs to be loaded before acplPublishExecute

08-14-2013 12:22 AM in reply to: oliver253m

Thanks for the tip. You can also use acedArxLoad to load AcPublish.arx programmatically prior to run your publish code.

 

Regards,

Philippe.

 

______________________________________________________________

If my post answers your question, please click the "Accept as Solution"

button. This helps everyone find answers more quickly!

 



Philippe Leefsma
Developer Technical Services
Autodesk Developer Network

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.