.NET

.NET

Reply
Valued Contributor
75 Posts
0 Kudos
Registered: ‎01-10-2006
Post 31 of 36

Re: Wait for SendStringToExecute to complete

08-17-2009 06:43 AM in reply to: timbot
Thanks, I did figure that out after more reading.

So everything is working how it should now and my commands are running in sync.
*James Allen
Post 32 of 36

Re: Wait for SendStringToExecute to complete

08-17-2009 03:41 PM in reply to: timbot
You're welcome. I'm glad you got it working.

Do keep Tony's suggestion from your other thread in mind for future
reference though, i.e. chaining document and application context
commands. It's a bit more work to do the sequencing like that, but
might be worth it if you develop a need to avoid COM or pass data which
is not sufficiently represented by strings.

--
James Allen
Malicoat-Winslow Engineers, P.C.
Columbia, MO



jta_albert wrote:
> Thanks, I did figure that out after more reading.
>
> So everything is working how it should now and my commands are running in sync.
>
Valued Contributor
75 Posts
0 Kudos
Registered: ‎01-10-2006
Post 33 of 36

Re: Wait for SendStringToExecute to complete

08-17-2009 05:42 PM in reply to: timbot
Hey James,

Maybe off topic, but I am now getting this error at the end of a sub after using SendCommand.

"Could not load file or assembly 'VerticalTips, Culture=neutral' or one of its dependencies. The system cannot find the file specified."

Any help?
Valued Contributor
75 Posts
0 Kudos
Registered: ‎01-10-2006
Post 34 of 36

Re: Wait for SendStringToExecute to complete

08-17-2009 05:50 PM in reply to: timbot
I am only getting this error 25% of the time at best...
*James Allen
Post 35 of 36

Re: Wait for SendStringToExecute to complete

08-17-2009 06:40 PM in reply to: timbot
I'm sorry, I don't know what that is.

--
James Allen
Malicoat-Winslow Engineers, P.C.
Columbia, MO



jta_albert wrote:
> Hey James,
>
> Maybe off topic, but I am now getting this error at the end of a sub after using SendCommand.
>
> "Could not load file or assembly 'VerticalTips, Culture=neutral' or one of its dependencies. The system cannot find the file specified."
>
> Any help?
>
Contributor
23 Posts
0 Kudos
Registered: ‎09-14-2006
Post 36 of 36

Re: Wait for SendStringToExecute to complete

10-31-2012 02:40 AM in reply to: *James Allen

Hi Tony (or anybody else that knows),

 

I have been using your commandline class for some time and it has proved very useful thanks, but I am having trouble getting it to work for a poyline. I have read all of the information I can find but still struggling.

 

From a click event on a modeless form I want the user to be able to draw a polyline, then on completion update the form with it's area. I have tried commandline.command("_pline") from the event in the form, called a CommandMethod that calls commandline.command("_pline") both with and without CommandFlags.Session but it doesn't pause for input and continues to the following code.

 

Is this possible and if so, how should I do it?

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!