.NET

Reply
Valued Contributor
FRPT1257
Posts: 69
Registered: ‎05-03-2006
Message 1 of 2 (119 Views)
Accepted Solution

Use AutoCAD2015 API with VStudio201​0

119 Views, 1 Replies
07-19-2014 04:03 AM

SDK AutoCAD2015 samples are in VStudio2012.

 

It is possible use the VStudio2010 to develop addin for the AutoCAD2015? Or is mandatory the VStudio2012?

 

I think AutoCAD 2013/2014 is related with VStudio2010. If I develop addins with AutoCAD2013/2014 SDK and VStudio2010, they will be compatible with AutoCAD2015?

 

Thanks & Regards,

Rui

Hi,

 

AutoCAD 2005 was the first AutoCAD version supporting .NET technology.
Since AutoCAD 2006 a .NET Framework Runtime version is automatically installed with AutoCAD.

Each Visual Studio version is related to a .NET Framework version.
Visual Studio 2008 and later versions allow to target previous versions of .NET Framwork since 2002.

AutoCAD    .NET framework Runtime   Visual Studio

2005           1.0 (not installed)              2002

2006           1.1                                    2003

2007           2.0                                    2005 (or later)

2008           2.0                                    2005 (or later)

2009           3.0                                    2008 (or later)

2010           3.5                                    2008 (or later)
2011           3.5                                    2008 (or later)
2012           4.0  (3.5 supported)          2010 (or later)
2013           4.0                                    2010 (or later)
2014           4.0                                    2010 (or later)
2015           4.5                                    2012 (or later)

 

So, as AutoCAD 2015 targets the .NET Framework 4.5, Visual Studio 2012 is mandatory to use the AutoCAD 2015 .NET SDK. But, most of the time, applications built against .NET Framework 4.0 and AutoCAD 2013 SDK may work with AutoCAD 2015 without any changes.

 

*Expert Elite*
_gile
Posts: 2,106
Registered: ‎04-29-2006
Message 2 of 2 (106 Views)

Re : Use AutoCAD2015 API with VStudio201​0

07-19-2014 05:52 AM in reply to: FRPT1257

Hi,

 

AutoCAD 2005 was the first AutoCAD version supporting .NET technology.
Since AutoCAD 2006 a .NET Framework Runtime version is automatically installed with AutoCAD.

Each Visual Studio version is related to a .NET Framework version.
Visual Studio 2008 and later versions allow to target previous versions of .NET Framwork since 2002.

AutoCAD    .NET framework Runtime   Visual Studio

2005           1.0 (not installed)              2002

2006           1.1                                    2003

2007           2.0                                    2005 (or later)

2008           2.0                                    2005 (or later)

2009           3.0                                    2008 (or later)

2010           3.5                                    2008 (or later)
2011           3.5                                    2008 (or later)
2012           4.0  (3.5 supported)          2010 (or later)
2013           4.0                                    2010 (or later)
2014           4.0                                    2010 (or later)
2015           4.5                                    2012 (or later)

 

So, as AutoCAD 2015 targets the .NET Framework 4.5, Visual Studio 2012 is mandatory to use the AutoCAD 2015 .NET SDK. But, most of the time, applications built against .NET Framework 4.0 and AutoCAD 2013 SDK may work with AutoCAD 2015 without any changes.

 

Gilles Chanteau
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.