New Member
Posts: 1
Registered: ‎06-14-2011
Message 1 of 4 (1,681 Views)
Accepted Solution

Namespace 'ApplicationServices' does not exist in 'Autodesk.AutoCAD'

1681 Views, 3 Replies
06-14-2011 04:10 PM

Hi guys!


Well, you guessed, I'm new into AutoCAD programming.

I'm using VS2010 and AutoCAD 2012.


So, I have referenced acdmgd and acmdg but but I always get this error. Same error for EditorInput namespace.



I tried to reference dll from SDK or AutoCAD but same error:
"C:\ObjectARX 2012\inc"

"C:\Program Files\Autodesk\AutoCAD 2012 - English"



This is all I got when browsing the dll:



I'm also getting this warning:

The referenced assembly "acmgd" could not be resolved because it has a dependency on "System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" which is not in the currently targeted framework ".NETFramework,Version=v4.0,Profile=Client". Please remove references to assemblies not in the targeted framework or consider retargeting your project. 

Thanks you for your help!

ADN Support Specialist
Posts: 341
Registered: ‎04-30-2009
Message 2 of 4 (1,642 Views)

Re: Namespace 'ApplicationServices' does not exist in 'Autodesk.AutoCAD'

06-15-2011 06:29 AM in reply to: Araw



Are you using VS2010 (or Visual Express 2010)? That is required.


After that, for C#, go to project properties, application tab, then select ".NET Framework 4.0" at target list (do not select Client Profile)



Augusto Goncalves

Autodesk Developer Network


Augusto Goncalves
Autodesk Developer Network
*Expert Elite*
Posts: 985
Registered: ‎04-27-2009
Message 3 of 4 (1,640 Views)

Re: Namespace 'ApplicationServices' does not exist in 'Autodesk.AutoCAD'

06-15-2011 06:54 AM in reply to: Araw

Have you also set reference to acmgd.dll, which is the containing assembly of the namespace "Autpdesk.AutoCAD.ApplicationServices".


Unless you are doing RealDwg development, you ALWAYS need to set reference to both acdbmgd.dll AND acmgd.dll.


But in your case, this is because of .NET version exception causes this issue


Valued Contributor
Posts: 98
Registered: ‎01-15-2007
Message 4 of 4 (1,401 Views)

Re: Namespace 'ApplicationServices' does not exist in 'Autodesk.AutoCAD'

04-05-2012 01:44 AM in reply to: augusto.goncalves



My project is very similar. Sometimes it does compile though! Just before a compile, there will be no errors, but as I hit compile, I get the same errors as shown above. Both references have been added. 


I am using VB though, and not C#. I cannot find the .NET Framework 4.0 selection in the project properties. Anything else I can try.


Thank you very much


Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.