.NET

Reply
Active Member
latoge
Posts: 10
Registered: ‎03-09-2012
Message 1 of 3 (318 Views)
Accepted Solution

Migration from 2013 to 2014

318 Views, 2 Replies
10-10-2013 10:35 AM

Hi,
I get this error message when I try to run one of my tool (made for Civil 3D 2013) in Civil 3D 2014 :
System.MissingMethodException: Method missing : 'Void Autodesk.AECC.Interop.UiLand.IAeccApplication.Init(Autodesk.AutoCAD.Interop.AcadApplication)'.

Here are the reference I have in my project, all from ObjectARX 2013 :
Autodesk.AEC.Interop.Base
Autodesk.AEC.Interop.UIBase
Autodesk.AEC.Interop.Land
Autodesk.AEC.Interop.UILand
Autodesk.AEC.Interop
Autodesk.AEC.Interop.Common

I am using Visual Studio 2010, .Net Framework 4.   I tried to change ObjectARX 2013 for ObjectARX 2014 but I just found Autodesk.AEC.Interop, not the other ?

It's my first migration and I'm not use with ObjectARX so I don't know what I need to do.

You need to reference the Aecc Interops from the Civil3D Install folder.

 

interops.png

*Expert Elite*
Jeff_M
Posts: 4,367
Registered: ‎07-22-2003
Message 2 of 3 (299 Views)

Re: Migration from 2013 to 2014

10-10-2013 04:38 PM in reply to: latoge

You need to reference the Aecc Interops from the Civil3D Install folder.

 

interops.png

Jeff_M, also a frequent Swamper
Active Member
latoge
Posts: 10
Registered: ‎03-09-2012
Message 3 of 3 (280 Views)

Re: Migration from 2013 to 2014

10-11-2013 06:44 AM in reply to: latoge

Nice, thanks a lot ! :smileyhappy:

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.